Features

orth America

25 R

Airports, Cities, For\}vard Sortation Areas, Highways, Lakes,
Major Cities
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for which data is provided.

Plotting U.S. ZIP Codes

Besides recognizing geographic place names, Microsoft Map recognizes|U.S. -
five-digit ZIP codes. If the data that you select contains more than one type of

geographic data (for example, state names and ZIP codes), you need to

which field to use in the map as the geographic data. Figure 17-24 shows the Specify
Geographic Data dialog box, which warns you of the existence of more than one

type of data that qualifies as geographic data.

Figure 17-24: The Specify Geographic Data
dialog box enables you to select the data to
use as geographic data.

Figure 17-23: This map has all of its features removed, leaving only the states

specify




If you want {q
formatted as
ZIP codes.

Because ZIP

all of your ZI
receive the R
This dialog b
Or, you can §

b create a map that uses ZIP codes, make sure that your ZIP codes are
values, not as text. Otherwise, Microsoft Map won't recognize them as

codes are continually being added, Microsoft Map may not recognize
P codes. If Microsoft Map encounters an unknown ZIP code, you
esolve Unknown Geographic Data dialog box, shown in Figure 17-25.
ox gives you the opportunity to change the ZIP code to another one.
imply discard that item of data by clicking the Discard button.

Figure 17-26
graduated-s
that the sym
shade the en

shows a map that depicts customers by their ZIP codes. This is a

bol map (the default format when ZIP codes are used as data). Note
bols appear on the geographic centers of the ZIP codes and don’t
tire ZIP code areas.

Figure 17-26
code centers.

This map shows customers by ZIP
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Adding More Data to a Map

After you create a map, you can add additional data to it. Use the Insg

rt= Data

command to add data from a worksheet range, or use the Insert = External Data

command to add new data from a database file. Make sure that the da
geographic labels that match the map to which you're adding data.

Map Templates

As you may have figured out by now, getting a map just right can som

lot of time, Fortunately, you can save a map template, so that you carn

settings for another map. To do so, create and customize the map an

Map = Save Map Template. You can save a template that includes the
4 The features that you've added or removed
4 A particular view (zoomed in or out)

4 Both of the preceding items

ta includes

etimes take a
reuse the
then choose
following:

Saved templates then appear in the Multiple Maps Available dialog b?x, which

appears when you create a map.

Converting a Map to a Picture

You'll find that working with maps sometimes can be rather sluggish

of work goes on behind the scenes. When you finish with your map, 3

—a great deal
rou can

convert it to a static picture that is no longer linked to the data. ClicH the map once

to select it (don’t double-click it) and then choose Edit= Copy. Then
Paste Special and choose the Picture (Enhanced Metafile) option. Th

select Edit =>
s creates an

unlinked picture of the map. Then, you can select the original map olpject and

delete it.

If you convert a map to a picture, no way exists to link data back to t

ne picture. If

any of your data changes or you want to make modifications to the map, you have

to re-create the map.

Learning More

The Microsoft Map feature is relatively complex, and it definitely taks
master. The best way to master this feature is simply to create some
perform customizations. As previously mentioned, the user interfacg

es time to
maps and
is different




from Ex¢el’s, so you'll have to try some new techniques. Generally, you can find
your waly around maps by doing the following:
4 Dduble-clicking objects
4 Right-clicking objects
-4 Exploring the menus (they change somewhat, depending on the type of map)
4 Usiing the Microsoft Map toolbar

Summary

This chapter covers Excel’s new Microsoft Map feature —which is actually an OLE
server application developed by MapInfo Corporation. Some data is more
appropriate for a map than for a chart, and this chapter demonstrates the
differenge. This chapter also describes the basics of creating and customizing maps
and proyides an example of each map format.

< @ “
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Creating and
Using
Worksheet
Outlines

Ifyou use a word processor, you may be familiar with the
concept of an outline. Most word processors have an
outline mode that lets you view only the headings and
subheadings in your document. You can easily expand a
headingjto show the detail (that is, the text) below it. To write
this book, [ used the outline feature in my word processor

Excel algo is capable of using outlines, and understanding this
feature ¢an make working with certain types of worksheets
much easier for you.

Introducing Worksheet Outlines

You canuse outlines to create summary reports in which you
don't wgnt to show all the details. You’ll find that some
worksheets are more suitable for outlines than others. If your
worksheet uses hierarchical data with subtotals, it’s probably
a good dandidate for an outline.

The best way to understand how worksheet outlining works is
to look at an example. Figure 18-1 shows a simple budget
model without an outline. Subtotals are used to calculate
subtotals by region and by quarter.
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Figure 18-1: A typical budget model with subtotals.

Figure 18-2 shows the same worksheet after the outline was created.|Notice that
Excel adds a new border to the left of the screen. This border contains controls that
enable you to determine which level to view. This particular outline has three
levels: States, Regions (each region consists of states), and Grand Tqtal (the sum of
each region’s subtotal). In Figure 18.2, the outline is fully expanded so that you can
see all the data.

Q1 Total
4330
3513
5140
3795

16778
4738
4365
3447
4722

17267,
3347
3995
4669
4243
4776

17683

51728

Figure 18-2: The budget model after creating an outline.

Figure 18-3 depicts the outline displayed at the second level. Now, the outline
shows only the totals for the regions (the detail rows are hidden). Ypu can partially




expand
to level

the outline to show the detail for a particular region. Collapsing the outline
1 shows only the headers and the Grand Total row.

Figure 1
second

was a1
(horizd

Excel chn create outlines in both directions. In the preceding examples, the outline

Mar.
5081
5552
6664

17297

1 Total
16778
17267
17683
51728

Sheetl
8-3: The budget model after collapsing the outline to the
evel.

ure 184 shows the same model after a column

pw (vertical) outline. Fig y
Now, Excel displays another border at the top.

ntal) outline was added.

Figure

If you

at the
model
sSumin

each outline independent

State Jan Feb! Mar. Qf Toiaf Apri  May]  Jun| Q27
California 1118 1960 12562 4330 1271 1667 1679 4
Washington 1247 1238 1028 3513 1345 1784 1574 ‘3
Oregon Ticol 1984, 728 5140, 1461 17ed] 1144 4
Nevada 1345 1375 1075 3705 1736 1665 1372 &
West Total 5170 65271 5081 16778 5813 66600 5769 18;
New York 1429 13156 1993 4738 1832 1740 1191 4
New Jersey 1735 1408 1224 4365 1706 1320 1290
Massachusetts| 1099 1233' 1110 3442 1637, 1512] 1006 4
Florida 1705 1792 1225 4722 1946 1327 1367
EestTotal | 5058 o747 %5652 17267 7121 5699 deM A
Kentucky 1108 1078 1155 3342 1983 1082 1651
Oklahoma 1303) 1045, 1641 3995 1924; 1493 1941 &
Missouri 1511 1744 1414 4669 1243 1493 1820 4.
lllinois 1539 1483 1211 4243 1165: 1013 1445 A
sﬁ(arlvsas | » 197, 1243 76, 1495 1125] 1387
ee!

18-4: The budget model after adding a column outline.

“reate both a row and a column outline in a worksheet, you can work with
of the other. For example, you can show the row outline
second level and the column outline at the first level. Figure 18-5 shows the
with both outlines collapsed at the second level. The result is a nice

hry table that gives regional totals by quarter.
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Creating an Outline

In this section, you learn the two ways to create an outline: automatically and
manually. But, before getting into the details of those two methods, the all-
important first step is examined: getting your data ready for outlining.

Preparing the Data

Before lyou create an outline, you need to ensure the following:

4 The data is appropriate for an outline

4+ The formulas are set up properly

Determining appropriate data

What type of data is appropriate for an outline? Generally, the data should be
arranged in a hierarchy, such as a budget that consists of an arrangement similar to
the following:

Company

Division
Department
Budget Category
. Budget ltem

In this rase, each budget item (for example, airfare and hotel expenses) is part of a
budget| category (for example, travel expenses). Each department has its own
budget, and the departments are rolled up into divisions. The divisions make up the
company. This type of arrangement is well-suited for a row outline—although most
of your outlines probably won't have this many levels.

Once created, you can view the information at any level of detail that you want,
When you need to create reports for different levels of management, try using an
outline} Upper management may want to see only the Division totals. Division
managers may want to see totals by department, and each department manager
needs to see the full details for his or her department.

As demonstrated at the beginning of the chapter, you can include time-based
information that is rolled up into larger units (such as months and quarters) in a
columi outline. Column outlines work just like row outlines, however, and the
levels Teed not be time-based.
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Setting up the formulas
Before you create an outline, you need to make sure that all the summaj
are entered correctly and consistently. Consistently means that the fo

ry formulas
las are in

u
the same relative location. Generally, formulas that compute summar‘;lormulas

(such as subtotals) are entered below the data to which they refer. In s
however, the summary formulas are entered above the referenced cells

me cases,
Excel can

e that you
won't

handle either method, but you must be consistent throughout the rang
outline. If the summary formulas aren’t consistent, automatic outlining
produce the results that you want.

If your summary formulas aren’t consistent (that is, some are above and some are
below the data), you still can create an outline, but you must do it manually.

Creating an Outline Automatically

Fxcel can create an outline for you automatically in a few seconds, whe
take you ten minutes or more to do the same thing manually.

reas it might

the range of
ito Outline.
ding on the
r both.

To have Excel create an outline, move the cell pointer anywhere within
data that you're outlining. Then, choose Data= Group and Outline = Ay
Excel analyzes the formulas in the range and creates the outline. Deper
formulas that you have, Excel creates a row outline, a column outline, ¢

» modify the
‘reate a new

If the worksheet already has an outline, Excel asks whether you want t¢
existing outline. Click Yes to force Excel to remove the old outline and ¢

one.

rotals com-

Excel automatically creates an outline when you use the Data= Sub
your data

mand, which inserts subtotal formulas automatically if you set up
as a list.

The Data= Subtotals command is discussed in Chapter 23 (see the section

“Creating Subtotals”).

Creating an Outline Manually

Usually, letting Excel create the outline is the best approach. It's much
less error-prone. If the outline that Excel creates isn’t what you have in mind,
however, you can create an outline manually.

faster and

When Excel creates a row outline, the summary rows all must be above the data or
below the data (they can’t be mixed). Similarly, for a column outline, the summary
columns all must be to the right of the data or to the left of the data. lf your

worksheet doesn’t meet these requirements, you have two choices:

4 Rearrange the worksheet so that it does meet the requirements

4 Create the outline manually




w@ Example Text Outline_xk:

You also nedd to create an outline manually if the range doesn’t contain any
formulas. Ydu may have imported a file and want to use an outline to display it
better. Becauise Excel uses the formulas to determine how to create the outline, it is
not able to make an outline without formulas.

Creating an putline manually consists of creating groups of rows (for row outlines)
or groups of columns (for column outlines). To create a group of rows, click the row
numbers for all the rows that you want to include in the group— but do not select
the row that has the summary formulas. Then, choose Data= Group and Outline =
Group. Excel displays outline symbols for the group. Repeat this for each group
that you want to create. When you collapse the outline, Excel hides rows in the
group. But the summary row, which is not in the group, remains in view.

If you select a range of cells (rather than entire rows or columns) before you
create a group, Excel displays a dialog box asking what you want to group. It then
groups|entire rows or columns based on the range that you select.
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You also can select groups of groups to create multilevel outlines. When you create
multilevel outlines, always start with the innermost groupings and then work your
way out. If you realize that you grouped the wrong rows, you can ungroup the group
by selecting Data = Group and Outline => Ungroup.

Excel has toolbar buttons that speed up the process of grouping an

ungrouping

(see the sidebar “Outlining Tools”). You also can use the following keyboard

shortcuts:

4+ Alt+Shift+right arrow: Groups selected rows or columns

4 Alt+Shift+left arrow: Ungroups selected rows or columns

Creating outlines manually can be confusing at first, but if you stick|with it, you'l

become a pro in no time.




Using Outlines

This sectidn discusses the basic operations that you can perform with a worksheet
outline.

Displaying Levels

To display|various outline levels, click the appropriate outline symbol. These
symbols consist of buttons with numbers on them (1, 2, and so on) and buttons
with either a plus sign (+) or a minus sign (-).

Clicking the 1 button collapses the outline so that it displays no detail, just the
highest summary level of information. Clicking the 2 button expands the outline to
show one level, and so on. The number of numbered buttons depends on the
number of outline levels. Choosing a level number displays the detail for that level,
plus any lpwer levels. To display all levels — the most detail— click the highest-
level number.

You can expand a particular section by clicking its + button, or you can collapse a
particular|section by clicking its — button. In short, you have complete control over
the details that Excel exposes or hides in an outline.

If you prefer, you can use the Hide Detail and Show Detail commands on the Data=
Group and Outline menu, to hide and show details, respectively. Or, you can use
one of the buttons on the Pivot Table toolbar to hide or show information.

If yols constantly adjust the outline to show different reports, consider using the
Custpm Views feature to save a particular view and give it a name. Then, you can
quickly switch among the named views. Use the View => Custom Views command

for this.

Applying Styles to an Outline

When you create an outline, you can have Excel automatically apply named styles
to the summary rows and columns.

Chapter 11 discusses named styles.

Excel {ises styles with names in the following formats (where n corresponds to
the outlirle level):

4+ RowLevel_n
4 ColLevel_n
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For example, the named style that is applied to the first row level is RowLevel_1.
These styles consist only of formats for the font. Using font variations makes
distinguishing various parts of the outline a bit easier. You can, of/course, modify
the styles in any way that you want. For example, you can use the Format= Style
command to change the font size or color for the RowLevel_1 style. After you do so,
all the RowLevel_1 cells take on the new formatting. Figure 18-6 shows an outline
with the automatic outline styles assigned.

Figure 18-6: This outline has automatic styles.

You can have Excel automatically apply the styles when it creates an outline, or you
can apply them after the fact. You control this in the Settings dialog box, shown in
Figure 18-7. This dialog box appears when you select Data = Graup and Qutline=
Settings.

Figure 18-7: The Settings dialog box.

If the Automatic styles check box contains a check when you create the outline,
Excel automatically applies the styles. To apply styles to an existing outline, select
the outline, choose Data=> Group and Outline= Settings, and then click the Apply
Styles button. Notice that you also can create an outline by using this dialog box.




You ma

: % line. Se

5

Adding |

You may nee
may be able
New rows or
Nnew row or ¢
just select D
that you war
need to mak

Removing an Outline

If you no lon
Qutline = Cl¢
rows and col
effect, howe)

ger need an outline, you can remove it by selecting Data = Group and
sar Qutline. Excel fully expands the outline by displaying all hidden

VEL.

y prefer to use Excel's Format<> AutoFormat command to format an out-
eral of the AutoFormats use different formatting for summary cells.

Data to an Qutline

d to add additional rows or columns to an outline. In some cases, you
to insert new rows or columns without disturbing the outline, and the
columns become part of the outline. In other cases, you’ll find that the
olumn is not part of the outline. If you create the outline automatically,
ata o Group and Outline = Auto Outline again. Excel makes you verify

It to modify the existing outline. If you create the outline manually, you

e the adjustments manually, as well.

umns, and the outline symbols disappear. The outline styles remain in

You ca

Hiding the Outline Symbols

The outline symbols Excel displays when an outline is present take up quite a bit of
space (the exact amount depends on the number levels). If you want to see as
much as possible onscreen, you can temporarily hide these symbols, without
removing the outline. The following are the two ways to do this:

4+ Open
the O

4 Press (

To redisplay
check box irj

The Custom
status of the

with the outl

remove the outline before you select this command.

Ctrl+8

When you hide the outline symbols, the outline still is in effect, and the worksheet
displays the data at the current outline level. That is, some rows or columns may
be hidden.

't “undo” removing an outline, so make sure that you really want to

e Options dialog box, select the View tab, and remove the check from
line Symbols check box

the outline symbols, either place a check mark in the Outline Symbols
the Options dialog box or press Ctrl+8.

Views feature, which saves named views of your outline, also saves the
outline symbols as part of the view, enabling you to name some views
ine symbols and other views without them.
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Creating Charts from Outlines

A worksheet outline also is a handy way to create summary charts. If you have a
large table of data, creating a chart usually produces a confusing mess. But, if you
create an outline first, then you can collapse the outline and select the summary
data for your chart. Figure 18-8 shows an example of a chart created frqm a
collapsed outline. When you expand an outline from which you created a chart, the
chart shows the additional data. -

If your chart shows all the data in the outline, even when it’s collapsed, remove
the check from the Plot Visible Cells Only check box in the Chart tab in the Options
dialog box.

Central Total

Figure 18-8: This chart was created from the summary cells in
an outline.

Summary

This chapter discusses the advantages of creating an outline from worksheet data.
It teaches you how to create row outlines and column outlines, either automatically
or manually. It also discusses how to use an outline after it is created.

< “ <




Con

Linking and

Worksheets

olidating

is chapter discusses two procedures that are common

h

Tin the world of spreadsheets: linking and consolidation.
Linking is the|process of using references to cells in external
workbooks tg get data into your worksheet. Consolidation
combines or summarizes information from two or more

Linking

contains the
the informati
need to open

dependent w

as a dat
pletely ¢

When you co
self the follov
data in anoth
the data into
you can. But
you continua
in Workbook

worksheets (which can be in multiple workbooks).

When you lin
a way that one depends on the other. The workbook that

called the dependent workbook. The workbook that contains

called the soy

You alsa can create links to data in other applications, such

Why Link Workbooks?

1ly update the source workbook. Creating a link

orkbooks

k worksheets, you connect them together in such

ink formulas (or external reference formulas) is

on used in the external reference formula is

rrce workbook. Note, importantly, that you don’t
the source workbook when you link it to the
brkbook.

abase program or a word processor. This is a com-
ifferent procedure and is the topic of Chapter 29.

nsider linking workbooks, you might ask your-
ving question: If Workbook A needs to access

er workbook (Workbook B), why not just enter
Workbook A in the first place? In some cases,
the real value of linking becomes apparent when

A to Workbook B means that, in Workbook A,
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you always have access to the most recent information in Workbg

Workbook A is updated whenever Workbook B changes.

Linking workbooks also can be helpful if you need to consolidate ¢

example, each regional sales manager might store data in a separ

ok B, because

lifferent files. For

can create a summary workbook that first uses link formulas to retrieve specific
data from each manager’s workbook and then calculates totals acyoss all regions.

Linking also is useful as a way to break up a large model into smal
create smaller workbook modules that are linked together with a

references. Often, this approach makes your model easier to deal

memory.

Linking has its downside, however. As you'll see later, external ref
are somewhat fragile, and accidentally severing the links that you
easy. You can prevent this from happening if you understand how

}te workbook. You

er files. You can
w key external
ith and uses less

ence formulas
reate is relatively
inking works.

Later in the chapter, some of the problems that may arise are discussed, as well as

how to avoid them (see “Potential Problems with External Referen

Creating External Reference Formulas

The following are the ways that you can create an external referer

4 Type the cell references manually. These references may b
they include workbook and sheet names (and, possibly, eve
information). The advantage of manually typing the cell refe
source workbook doesn’t have to be open.

4+ Point to the cell references. If the source workbook is open
standard pointing techniques to create formulas that use ex]

+ With the source workbook open, select Edit = Paste Special

Link button.

4 Use Excel's Data=> Consolidate command. This method is ¢
the chapter (see “Consolidating Worksheets by Using Datas

Understanding the link formula syntax
This section discusses the concept of external references. The ge
external reference formula is as follows:

=[WorkbookName]SheetName!CellAddress

Precede the cell address by the workbook name (in brackets), th
and an exclamation point. Here's an example of a formula that us
Sheet] worksheet of a workbook named Budget:

=[Budget.x1s]Sheetl!Al

ce Formulas™).

ce formula:

e lengthy, because
1 drive and path
rences is that the

, you can use the
ternal references.

with the Paste

iscussed later in
Consolidate”).

neral syntax for an

> worksheet name,
es cell Al in the




ormula that ref

='[Annual

When a formulg
need to be opel
add the complg

AMSO A

bS]
doing so can|
correct. Inst|
1. Open {
2. Select

3. Enter

[

4. Finish

You'll see t

copy the fo

reference to

include the
external refi
As commar

The Paste §

formulas:
1. Open
2. Selec

3. Activ
link fq

4. Choo

D

5

AN WORKDOOK HAme of e Shest name e TSRS TRCONARS T O TR
, you Tust enclose the ext in single quotalion marks Yot example, herds a
brs to cell Al on Sheetl in a workbook named Annual Budget:

Budget]Sheetl'!Al

\ refers to cells in a different workbook, that other workbook doesn’t
. If the workbook is closed and not in the current folder, you must
te path to the reference; for example:

ink formula by pointing

ead, have Excel build the formula for you, as follows:

he source workbook.
the cell in the dependent workbook that will hold the formula.

ence, activate the source workbook and select the cell or range.

the formula and press Enter.

of the details and creates a syntactically correct external reference. When you
point to a cell reference by using the procedure outlined in the preceding steps,
the cell reference is always an absolute reference (such as $A$1). If you plan to

As long as the source workbook remains open, the external reference doesn't

path to the workbook. If you close the source workbook, however, the
erence formulas change to include the full path. If you use the File= Save
d to save the source workbook with a different name, Excel changes the
external references to use the new filename.

Pasting links

pecial command provides another way to create external reference
the source workbook.

ate the dependent workbook and select the cell in which you want the

ice\Excel\Budget Fiies\[Annual BudgetlSheetl'!Al

mentioned, you can directly enter external reference formulas, but
cause errors, because you must have every bit of information exactly

he formula. When you get to the part that requires the external refer-

at when you point to the cell or range, Excel automatically takes care

mula to create additional link formulas, you can change the absolute
a relative reference by removing the dollar signs.

the cell or range that you want to link and then copy it to the Clipboard.

rmula to appear. If you're pasting a range, just select the upper-left cell.
e Edit = Paste Special and then click the Paste Link button.
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Working with External Reference Formulas

You need to understand that a single workbook can contain links that refer to any
number of different source workbooks. This section discusses what you need to
know about working with links.

Creating links to unsaved workbooks

Excel enables you to create link formulas to unsaved workbooks, and even to
nonexistent workbooks. Assume that you have two workbooks open and you
haven’t saved either of them (they have the names Bookl and Book?). If you create
a link formula to Bookl1 in Book2 and then save Book2, Excel displays the dialog box
shown in Figure 19-1. Generally, you should avoid this situation. Simply save the
source workbook first.

Figure 19-1: This message indicates that
the workbook you're saving contains
references to a workbook that you haven't
yet saved.

You also can create links to documents that don't exist. You might want to do this
if you'll be using a source workbook from a colleague, but the file hasn't arrived.
When you enter an external reference formula that refers to a nonegxistent work-
book, Excel displays its File Not Found dialog box, shown in Figure 19-2. If you click
Cancel, the formula retains the workbook name that you entered, but it returns an
error. When the source workbook becomes available, the error gogs away and the
formula displays its proper value.

Opening a workbook with external reference formulas
When you open a workbook that contains one or more external reference formulas,
Excel retrieves the current values from the source workbooks and calculates the

formulas.

If Excel can’t locate a source workbook that’s referred to in a link formula, it displays
its File Not Found dialog box and prompts you to supply a workbook to use for the
source workbook.




workbook, [Excel displays this dialog box to help you locate the file.

Examining links
If your workbook uses several workbook links, you might want to see a list of source
workbooks. To do so, choose the Edit=> Links command. Excel responds with the

Links dialgg box, shown in Figure 19-3. This dialog box lists all source workbooks,
plus other| types of links to other documents.

These other types of links are explained in Chapter 29.

Figure 19-3: The Links dialog box lists all link sources.
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Updating links :
If you want to ensure that your link formulas have the latest values from their

source workbooks, you can force an update. This step might be necessary if you
just learned that someone made changes to the source workbook and saved the
latest version to your network server.

To update linked formulas with their current value, open the Links djalog box
(choose Edit = Links), choose the appropriate source workbook, and then click the
Update Now button. Excel updates the link formulas with the latest viersion of the
source workbook.

Excel always sets worksheet links to the Automatic update option inthe Links
dialog box, and you can’t change them to Manual. This means that Excel updates
the links only when you open the workbook. Excel doesn't automatigally update
links when the source file changes.

Changing the link source
A time may come when you need to change the source workbook for your external
references. For example, you might have a worksheet that has links to a workbook
named Preliminary Budget, but you later receive a finalized version named Final
Budget.

You could change all the cell links manually, or you could simply change the link
source. Do this in the Links dialog box. Select the source workbook that you want
to change and click the Change Source button. Excel displays a dialag box that
enables you to select a new source file, After you select the file, all external refer-
ence formulas are updated.

Severing links
If you have external references in a workbook and then decide that you no longer
need the links, you can convert the external reference formulas to values, thereby
severing the links. To do so, follow these steps:

1. Select the range that contains the external reference formulas pnd copy it to
the Clipboard.

2. Choose the Edit = Paste Special command. Excel displays the Faste Special
dialog box.

3. Select the Values option and click OK.

4. Press Esc to cancel cut-copy mode.

All formulas in the selected range are converted to their current val




Potential Problems with External Reference Formulas

Using external reference formulas can be quite useful, but the links may be uninten-
tionally severed. In almost every case, you'll be able to reestablish lost links. If you
open the workbook and Excel can't locate the file, you're presented with a dialog
box that gnables you to specify the workbook and re-create the links. You also can
change the source file by using the Change Source button in the Links dialog box.
The following sections discuss some pointers that you must remember when you
use external reference formulas.

Renaming or moving a source workbook

If you rename the source document or move it to a different folder, Excel won't be
able to update the links. You need to use the Links dialog box and specify the new
source document.

Using the File> Save As command

If both the source workbook and the destination workbook are open, Excel doesn’t

display the full path in the external reference formulas. If you use the File=> Save As
command to give the source workbook a new name, Excel modifies the external ref-
erences to use the new workbook name. In some cases, this may be what you want.
But in other cases, it may not. Bottom line? Be careful when you use the File=: Save
As commland with a workbook that is linked to another workbook.

Modifying a source workbook

It you open a workbook that is a source workbook for another workbook, be
extremely careful if you don’t open the destination workbook at the same time.
For example, if you add a new row to the source workbook, the cells all move
down one row. When you open the destination workbook, it continues to use the
old cell references — which are now invalid.You can avoid this problem in the fol-
lowing ways:

4 Open the destination workbook when you modify the source workbook. If
you do so, Excel adjusts the external references in the destination workbook
when you make changes to the source workbook.

+ Use names rather than cell references in your link formula. This is the safest
approach,.

Intermediary links

Excel doesn’t place many limitations on the complexity of your network of external
referencgs. For example, Workbook A can contain external references that refer to
Workbook B, which can contain an external reference that refers to Workbook C. In
this casgﬁza value in Workbook A can ultimately depend on a value in Workbook C.
Workbook B is an intermediary link.
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I don’t recommend these types of links, but if you must use them, be aware that
Excel doesn’t update external reference formulas if the workbook isn't oalﬂ:en. In the

preceding example, assume that Workbooks A and C are open. If you change a value
in Workbook C, Workbook A won't reflect the change, because you didn’{ open
Workbook B (the intermediary link).

Consolidating Worksheets .‘

The term consolidation, in the context of worksheets, refers to several operations that
involve multiple worksheets or multiple workbook files. In some cases, consolidation
involves creating link formulas. Here are two common examples of consolidation:

4 The budget for each department in your company is stored in a sgparate
4 worksheet in a single workbook. You need to consolidate the datajand create
' a company-wide budget.
1 4 Each department head submits his or her budget to you in a separate work-
book. Your job is to consolidate these files into a company-wide bpdget.

These tasks can be very difficult or quite easy; the tasks are easy if the Information
is laid out exactly the same in each worksheet (as you'll see shortly).

If the worksheets aren't laid out identically, they may be similar enough.|In the
] second example, some budget files submitted to you may be missing caflegories that
i aren’t used by a particular department. In this case, you can use a handy feature in
Excel that matches data by using row and column titles. This feature is discussed
later in the chapter (see “Consolidating Worksheets by Using Data=> Consolidate).

- If the worksheets bear little or no resemblance to each other, your best/bet may be
to edit the sheets so that they correspond to one another. In some cases, simply
reentering the information in a standard format may be more efficient.

You can use any of the following techniques to consolidate information f110m multiple
workbooks:
4 Use external reference formulas
4 Copy the data and use the Paste Special command
4 Use Excel’s Data= Consolidate command

4+ Usea pivdt table (discussed in Chapter 25)




|
Consoﬁidating Worksheets by Using Formulas

Consoliddting with formulas simply involves creating formulas that use references
to other worksheets or other workbooks. The primary advantages to using this
method of consolidation are the following:

4+ Dynamic updating —if the values in the source worksheets change, the formu-
las are updated automatically.

4+ Thejsource workbooks don’t need to be open when you create the consolida-
tionjformulas.
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If you are consolidating the worksheets in the same workbook—and if all the work-
sheets are laid out identically —the consolidation task is quite simple. Yau can just
use standard formulas to create the consolidations. For example, to compute the total
for cell Al in worksheets named Sheet2 through Sheet10, enter the following formula:

=SUM(Sheet2:Sheetl0!Al)

You can enter this formula manually or use the multisheet selection technique
discussed in Chapter 8 (see “Selecting Multisheet Ranges”). You can then copy
this formula to create summary formulas for other cells. Figure 19-4 gshows this
technique at work.

Figure 19-4: Consolidating multiple worksheets by using formulas.

If the consolidation involves other workbooks, you can use external reference

formulas to perform your consolidation. For example, if you want to add the values
in cell Al from Sheet1 in two workbooks (named Regionl and Region2), you can use
the following formula:

=[Regionl.x1s]Sheetl!Al+[Region2.x1s]Sheetl!Al

You can include any number of external references in this formula, upito the 1,024-
character limit for a formula. However, if you use many external refergences, such a
formula can be quite lengthy and confusing, if you need to edit it.




Remember that Excel expands the references to include the full path—which can
incfease the length of the formula. Therefore, this expansion may cause the for-
mula to exceed the limit, thus creating an invalid formula.

If the worksheets that you're consolidating aren’t laid out the same, you can still
use formulas —but you have to ensure that each formula refers to the correct cell.

Consolidating Worksheets by Using Paste Special

Another method of consolidating information is to use the Edit = Paste Special
command. This method is applicable only when all the worksheets that you're
consolidating are open. The disadvantage — a major disadvantage —is that the
consolidption isn’t dynamic. In other words, it doesn’t generate a formula. So, if any
data that was consolidated changes, the consolidation is no longer accurate.

This technique takes advantage of the fact that the Paste Special command can
perform a mathematical operation when it pastes data from the Clipboard. Figure
19-5 shows the Paste Special dialog box.

Here’s h I w to use this method:

1. Copy the data from the first source range.

2. Activate the destination workbook and select the cell in which you want to
place the consolidation formula.

3. Selgct Edit = Paste Special, click the Add option, and then click OK.

Repeat these steps for each source range that you want to consolidate. As you
can see, this can be quite error-prone and isn’t really a good method of consoli-
dating data.
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Consolidating Worksheets by Using Data>
Consolidate

For the ultimate in data consolidation, use Excel’s Data= Consolidate cg
method is quite flexible, and in some cases, it even works if the source
aren’t laid out identically. This technique can create consolidations that
link formulas) or dynamic (with link formulas). The Data = Consolidate ¢
supports the following methods of consolidation:

4 By position: This method is accurate only if the worksheets are
identically.

4 By category: Excel uses row and column labels to match data in
worksheets. Use this option if the data is laid out differently in th

mmand. This
sorksheets
are static (no
rommand

laid out

the source
e source

~worksheets or if some source worksheets are missing rows or coﬂumns.

Figure 19-6 shows the Consolidate dialog box, which appears when y;
Data= Consolidate. The following list is a description of the controls
dialog box:

6: Th

e Consolidate dialog box enables
you to specify ranges to consolidate.

Figure 19-

ou select
in this

4 Function list box: Specify the type of consolidation. Usually, y|
but you also can select from ten other options: Count, Avg, M
Product, Count Nums, StdDev (standard deviation), StdDevp

ou use Sum,

, Min,
opulation

standard deviation), Var (variance), or Varp (population variance).

4 Reference text box: Specify a range from a source file that you
solidate. You can enter the range reference manually or use any
pointing technique (if the workbook is open). After you enter th
this box, click the Add button to add it to the All References lisf

want to con-

standard
e range in
. If you con-

solidate by position, don't include labels in the range. If you consclidate by

category, do include labels in the range.




+ All references list box: Contains the list of references that you have added
with the Add button.

+ Use labels in check boxes: Use to instruct Excel to perform the consolidation
by lexamining the labels in the top row, the left column, or both positions. Use
these options when you consolidate by category.

4 Create links to source data check box: When you select this option, Excel
creates an outline that consists of external references to the destination cells
in the destination worksheet. Additionally, Excel includes summary formulas
in the outline. If you don't select this option, the consolidation doesn’t use
formulas,

+ Browse button: Displays a dialog box that enables you to select a workbook
to open. It inserts the filename in the Reference box, but you have to supply
the range reference.

4+ Add button: Adds the reference in the Reference box to the All References list.

4+ Delete button: Deletes the selected reference from the All References list.

An example

The simple example in this section demonstrates the power of the Data=>
Consolidate command. Figure 19-7 shows three single-sheet workbooks that will be
consolidated. These worksheets report product sales for three months. Notice,
however that they don’t all report on the same products. In addition, the products
aren’t even listed in the same order. In other words, these worksheets aren’t laid out
identically—which makes creating consolidation formulas difficult.

Product ID
D-800
C-580
A-145
A-195
B-201
E901

Product ID
A-145
A-189
A-195
C-213
C-415
C-590
D-800
E-go0
E-804
E-912
E923

3\, Sheet1 &l o

b

N

i

fQai—
OISO @ =i

Figure 19-7: Three worksheets to be consolidated.
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To consolidate this information, start with a new workbook. The|source work-
books can be open or not — it doesn’t matter. Follow these steps to consolidate
the workbooks:

1. Select Data > Consolidate. Excel displays its Consolidate diajog box.

2. Select the type of consolidation summary that you want to use. Use Sum for
this example. :

3. Enter the reference for the first worksheet to consolidate. If the workbook is
open, you can point to the reference. If it’s not open, click the Browse button
to locate the file on disk. The reference must include a range. Use A1:D100.
This range is larger than the actual range to consolidate, buf using this range
ensures that the consolidation still works if new rows are added to the source
file. When the reference in the Reference box is correct, click Add to add it to
the All References list.

4, Enter the reference for the second worksheet. You can simplly edit the existing
reference by changing Regionl to Region2 and then clicking Add. This refer-
ence is added to the All References list.

5. Enter the reference for the third worksheet. Again, you can simply edit the
existing reference by changing Region2 to Region3 and then clicking Add.
This final reference is added to the All References list.

6. Because the worksheets aren’t laid out the same, select the|Left column and
Top row check boxes to force Excel to match the data by using the labels.

7. Select the Create links to source data check box to make Excel create an outline
with external references.

o "

8. Click OK to begin the consolidation.

In seconds, Excel creates the consolidation, beginning at the actiye cell. Figure 19-8
shows the result. Notice that Excel created an outline, which is cpllapsed to show
only the subtotals for each product. If you expand the outline, you can see the
details. Examine it further, and you'll discover that each detail cell is an external
reference formula that uses the appropriate cell in the source file. Therefore, the
destination range is updated automatically if any data is changed.

More about consolidation
Excel is very flexible regarding the sources that you can consolidzﬂte. You can consoli-
date data from the following:

4 Workbooks that are open

4 Workbooks that are closed (you have to enter the reference manually — but
you can use the Browse button to get the filename part of the reference)

4 The same workbook in which you're creating the consolidation




Figure 19:8: The result of the consolidation.

And, of course, you can mix and match any of the preceding choices in a single
consoliddtion.

Excel remembers the references that you entered in the Consolidate dialog box and
saves them with the workbook. Therefore, if you want to refresh a consolidation
later, youjwon’t have to reenter the references.

If you perform the consolidation by matching labels, be aware that the matches
must be exact. For example, Jan does not match January. The matching isn’t case-
sensitive, however, so April does match APRIL. In addition, the labels can be in any
order, and they need not be in the same order in all the source ranges.

If you don’t choose the Create links to source data check box, Excel doesn’t create
formulas, which generates a static consolidation. If the data on any of the source
workshegts changes, the consolidation doesn’t update automatically. To update
the summary information, you need to select the destination range and repeat the
Data = Consolidate command.

|

If you name the destination range Consolidate_Area, you don't need to select it
befgre you update the consolidation. Consolidate_Area is a name that has special
megning to Excel.

If you choose the Create links to source data check box, Excel creates an outline.
This is a standard worksheet outline, and you can manipulate it by using the tech-
niques dgscribed in Chapter 18.
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Summary

This chapter discusses two important spreadsheet procedures: linking and consol-
idation. Linking is the process of referring in one worksheet to cells in external
workbooks. Consolidation is the process of combining or summarizing information
from two or more worksheets (which can be in multiple workbooks). Thi chapter
covers various methods of linking and consolidation, and lists potential pitfalls.

+ 4 &




Creating and
Using Array
Formulas

his chapter introduces a concept that may be new to

you: array formulas. Understanding this special type of
formula may open a whole new world of analytical capability.
Working with arrays (rather than with individual cells)
requires a different type of mind-set. Some people never
quite get the hang of arrays, and others take to this concept
quickly. If you're in the former group, don’t despair. Using
array formulas can be considered an optional skill.

Introducing Arrays

This chapter discusses two concepts:

4+ Array: A collection of cells or values that is operated on
as a group. An array can be stored in cells or can be a
named constant that consists of multiple elements.

4 Array formula: A formula that uses one or more arrays
either directly or as arguments for a function. An array
formpla can occupy one or more cells.

E
If you’ve eyver done any computer programming, you've proba-
bly been exposed to arrays. An array is a collection of items.
Excel’s arrays can be one-dimensional or two-dimensional.
These dimensions correspond to rows and columns. For
example, a one-dimensional array can be a cell range that
occupies cells in one row (a horizontal array) or one column
(a verticaljarray). A two-dimensional array occupies cells in
one or more rows and columns.
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You can perform operations on arrays by using array formulas. Fo
construct an array formula to multiply a five-item vertical array b;
column vertical array, the result is another five-column vertical ar
of each element in the first array multiplied by each correspondin
second array. Because Excel can fit only one value in a cell, the re
operation such as this one occupy five cells—and the same array

each of the five cells.

Figure 20-1 illustrates this example. Each cell in the range C1:.C5

formula: {=A1:A5*B1:B5}. The result occupies five cells and cont
of the first array multiplied by each corresponding element in th

The brackets around the formula designate it as an array formu
this later in “Entering an Array Formula”).

Figure 20-1: A single array formula entered in the range C1:C5
produces results in five cells. '

As you will see, arrays have their pros and cons. At the very leas

provides an alternative way of doing some operations and is the
perform others.

r example, if you
y another five-
ray that consists
g element in the
sults of an
formula is in

holds the same
ains each element
e second array.
la (more about

t, this feature
only way to




Advantages of Array Formulas
The following are some of the advantages that may be obtained by using array
formulas (as opposed to single-cell formulas):

4 Much more efficient to work with

4 Elimjnate the need for intermediary formulas

4+ Enable you to do things that would otherwise be difficult or impossible

4+ Use less memory

Disadvantages of Array Formulas

This list shows a few disadvantages of array formulas:

4 Some large arrays can slow your spreadsheet recalculation time to a crawl.
4 Arrays can make your worksheets more difficult for others to understand.

+ You must remember to enter an array formula with a special key sequence
(Ctrl+Shift+Enter). Otherwise, the result isn't what you expect.

4+ Array formulas cannot be exported to other spreadsheet formats (such as
Lotus 1-2-3).

Understanding Arrays

This sectipn presents several examples to help clarify the concept of arrays. As
always, yqu can get more from this chapter if you follow along on your own
computer.

Array Formulas Versus Standard Formulas

You often £an use a single array formula to substitute for a range of copied formu-
las. Figure|20-2 shows two examples; the upper worksheet uses standard single-
result formulas. The formulas use the SQRT function to calculate the square roots
of the values in column A. The formula =SQRT(A3) was entered into cell B3 and
copied to the three cells below it. This example uses four different formulas to
calculate the results in column B,
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Formula in Col B

5} 2.449 =SQART(A3)
8 2.828 =SQART(A4)
9 3.000 =SQART(AS)
2 =SQRT(AB)

Formula in Col B
{=SQARTAIAB)}
{=SQRTA3:AB)}
[=SART(AZ:AB)}

[=SQRT(A3:AB))

2.448
2828
3.000

Figure 20-2: These workbooks accomplish
the same result, but one uses standard for-
mulas and the other uses an array formula.

The lower workbook uses a single array formula, which is inserted intg
Use the following steps to enter this array formula:

1. Select the range B3:B6.
2. Enter SQRT(A3:A6).
3. Press Ctrl+Shift+Enter to designate the formula as an array form

Excel enters the array formula into the three selected cells. It also adg
around the formula to indicate that it’s an array formula. The key poir
this example uses only one formula, but the results appear in four diff
because the formula is operating on a four-cell array.

To further demonstrate that this is, in fact, one formula, try to edit on
in B3:B6. You find that Excel doesn’t let you make any changes. To ma
formula that uses more than one cell, you must select the entire array

edit the formula.

Virtually no advantage is gained by using an array formula in the preg
ple (except perhaps to save the time that it takes to copy the formula
value of array formulas becomes apparent as you work through this ¢

all four cells.

ula.

Is brackets
it here is that
erent cells,

e of the cells
dify an array
r before you

eding exam-
. The real
hapter.




Figure 20-3 shows another example. The worksheet on the left uses standard

formulas to lcalculate the average change from the pretest to the posttest. The

worksheet on the right also calculates the average changes, but it uses an array

formula. This array formula resides in only one cell, because the result is a single

value. This is an example of how an array formula can eliminate the need for
formulas. As you can see, you don’t need to include an additional

Elculate the change in scores.

|

1

o han_;;? Scoj

An Arra; Formula in One Cell

intermediar
column to ¢

Student 1
Student 2
Student 3
Student 4
Student 5
Student 6 B84 91
Student 7 S0

Average Change: | 2.28571
{ =AVERAGE(C3:C8-B3:89)}
Sheet iy il

Figure 20-3: Using an array formula to eliminate intermediary formulas.

The formula in cell C11 is as follows:

{=AVERAGE(C3:C9-B3:B9)}

This array formula operates on two arrays, which are stored in cells. It subtracts
each elemert of B3:B9 from the corresponding element in C3:C9 and produces (in
memory)-a new seven-element array that holds the result. The AVERAGE function
computes the average of the elements in the new array, and the result is displayed
in the cell.

|

o i Ll
Looping with Arrays
Excel’s array feature enables you to perform individual operations on each cell in
a range —in much the same way as a program language’s looping feature enables
you to work with elements of an array. For example, assume that you have a range
of cells (named Data) that contains positive and negative values. You need to
compute the average of just the positive values in the range. Figure 20-4 shows an
example of this.

World Programming Limited EXHIBIT 1007; Page 122 of 2.



Working with Arrays

This section deals with the mechanics of selecting arrays and ente
array formulas. These procedures are a little different from workin
ranges and formulas.

Figure 20
calculate the average of only the positive values
in this range.

One approach is to sort the data and then use the AVERAGE functic

the average on only the positive values. A more efficient approach
ing array formula:

={AVERAGE(IF(Data>0,Data,""))}}

The IF function in this formula checks each element in the input rang
than zero. If so, the IF function returns the value from the
s an array that’s identical to the

it's greater
otherwise, it returns an empty string. The result i
input array, except that all nonpositive values are replaced with a nu
third argument of the IF functions). The AVERAGE function then com
age of this new array, and the result is displayed in the cell.

The preceding problem can also be solved with the following nona
=SUMIF(Data,">0",Data)/COUNTIF(Data,">0")

Many similar operations can't be performed with a standard formu
example, to calculate the median of the positive values in a range,
is the only solution.

Some more useful examples that use arrays are presented later in {
for now, some rules are provided for how to work with arrays and

in to calculate
ises the follow-

se to see whether
input range;

1l string (the
putes the aver-

rray formula:

la, however. For
an array formula

his chapter, but
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Entering an Array Formula

When you lenter an array formula into a cell or range, you must follow a special
procedure] so that Excel knows that you want an array formula rather than a normal
formula. You enter a normal formula into a cell by pressing Enter. You enter an array
formula into one or more cells by pressing Ctrl+Shift+Enter.

You can eisily identify array formulas, because they are enclosed in brackets in the
formula bar. For example, {=SQRT(A1:A12)} is an array formula.

Don’t enter the brackets when you create an array formula; Excel inserts them for
you, If the result of an array formula consists of more than one value, you must
select all the cells before you enter the formula. If you fail to do this, only the first
result shows.

Editinﬁ an Array Formula
v f

If an array|formula occupies multiple cells, you must edit the entire range as though
it is a single cell. The key point to remember is that you can’t change just one ele-
ment of an array formula. If you attempt to do so, Excel displays the messages
shown in Figure 20-5.

Excel’s warning
message reminds you that
you can't edit just one cell

of a multicell array.

The following rules apply to multicell array formulas. (If you try to do any of these
things, Excel lets you know about it.):

4 You can’t change the contents of any cell that makes up an array formula.

4+ You tan't move cells that make up part of an array formula. You can, however,
move an entire array formula.

4 You can't delete cells that form part of an array formula, but you can delete an
entire array.

4+ You can't insert new cells into an array range; this rule includes inserting rows
or columns that would add new cells to an array range.
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To edit an array formula, select all the cells in the array range and activate the
formula bar as usual (click it or press F2). Excel removes the brackets from the
formula while you're editing it. Edit the formula and then press Ctrl+ShL§+Enter to
enter the changes. All the cells in the array now reflect your editing changes.

Selecting an Array Range

You can select an array range manually by using the normal selection procedures.
Or, you can use either of the following methods:

4 Move to any cell in the array range. Select Edit= Go To (or press|F5), click the
Special button, and then choose the Current Array option. Click OK to close
the dialog box.

4 Move to any cell in the array range and press Ctrl+/ to select the|entire array.

Formatting Arrays

Although you can’t change any part of an array formula without changing all parts,
you're free to apply formatting to the entire array or to only parts of it.

Using Array Constants

also use constant values as an array. These constants can be entered directly into
a formula or defined by using the Define Name dialog box. Array constants can be
used in array formulas in place of a reference to a range of cells. To use an array
constant in an array formula, type the set of values directly into the formula and
enclose it in brackets. If you defined a name for the array constant, you can use

the name instead.

So far, the examples in this chapter have used cell ranges to hold an['{ys. You can

Array constants can be either one-dimensional or two-dimensional. One-dimensional
arrays can be either vertical or horizontal. The elements in a one-dimensional hori-
zontal array are separated by commas. The following example is a ong-dimensional
horizontal array:

{1,2,3,4.5}

Because this array constant has five values, it requires five cells (in jrow). To enter
this array into a range, select a range that consists of one row and five columns.
Then, enter ={1,2,3,4,5} and press Ctrl+Shift+Enter.




When you|use array constants, you must enter the brackets. Excel doesn’t provide
them for you. The following example is another horizontal array; it has seven
elements:

{“Sun" s "MOTl" : "Tue" , "Wed" ; “Thu" ; "Ff"i " : "Sat"}

Figure 20-6 demonstrates how to create a named array constant by using the Define
Name dialpg box.

5: Creating an array constant in the
Define Name dialog box.

The elements in a one-dimensional vertical array are separated by semicolons. The
following is a six-element vertical array:

{10;20:30;40;50;60}
The following is another example of a vertical array; this one has four elements:
["Widdets";"Sprockets";"Do-Dads";"Thing-A-Majigs"}

Two-dimensional arrays also separate the elements in a single row with commas
and separpte the rows with semicolons. The next example is a 3 x 4 array (three
rows, each of which occupies four columns):

{1,2,3,4;5,6,7,8;9510,11,12}

Figure 20-f shows how this array appears in a worksheet. First, the array constant
was created and named MyArray. Then, A1:D3 was selected and =MyArray was
entered. The array formula was entered into the range by pressing Ctrl+Shift+Enter.
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Figure 20-8
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: Using an array constant to enter the names of sales regions.
ng steps demonstrate how to create this example:

e the following constant, named SalesRegions:

. California";"Pacific NW";"SouthWest";"Central”;"
nEast";" NorthEast"}

1se the elements are separated by semicolons, this is a vertical array.
t A4:A9 and enter =SalesRegions.
Ctrl+Shift+Enter.

heet in Figure 20-8 also shows the sales regions displayed horizontally.
select A1:F1 and then enter the following formula (by pressing Ctrl+Shift

5POSE(SalesRegions)}
»POSE function converts a horizontal array to a vertical array (and vice
d just described is one of several ways to enter a stored list quickly into

cells. Perhaps a better approach is to create a custom list in the Custom
of the Options dialog box.

Identifying a Value in a Range

To determine whether a particular value is contained in a range, choose Edit=> Find.

But, you al
shows a w¢
checks the
it displays

so can make this determination by using an array formula. Figure 20-9
srksheet with a list of names (named Names). An array formula in cell E4
name that is entered into cell B1 (named TestValue). If the name exists,
the text Name is in the list. Otherwise, it displays Name not found.
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