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Linking, Imporfing,
and Exporting Dafa

ou’ll want to read this chapter if you

already have data on your computer

that you want to pull into Access, or if
you have created an Access database and want to export its data to another program. Most
procedures described in this chapter for linking, importing, and exporting data are quick
and easy to use. However, a few fine points can be tricky, especially if you're working with
open database connectivity (ODBC), Paradox, or dBASE database files. Luckily, lots of
online Help is available. Choose one of these topics from the Access Help Index to get
going quickly:

e Importing Data
¢ FExporting Data

N O E S .
Q See Chapter 4 for other ways to share data among Microsoft Office programs.
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Link, Import, Export: What's the Difference?

Access gives you several ways to share data with other programs:

Link Lets you directly access data in another computer database. Any changes
you make via Access will affect the original database as well as the Access data.
base. That is, you'll be working with live data.

N E
Q In some earlier versions of Access, linking was called attaching.

Import Lets you make a separate copy of data from other programs and file formats
into an Access table. Changes you make via Access will not affect the original data,
Export Lets you copy data from an Access table to some other program or file
format, such as Microsoft Word or Excel, or even to a separate Access database,
The exported data is an entirely separate copy that isn’t linked to your original
Access data in any way.

After importing or linking data from another program into Access, you can usually use
that data as though you had created it in Access originally. Files linked from Lotus 1-2-3
files are read-only. For example, if you import or link a Paradox table into your Access
database, you can open that table and use it as you would any Access table.

Similarly, you can use exported Access tables in other programs, just as though you
had created the exported data in the other program originally. Thus you can export an
Access table to Paradox format, fire up Paradox, and then open and use the table as you
would any other “native” Paradox table.

NaOTE
& OLE is a technology that offers another way to combine information from separate
. programs. However, OLE lets you share objects, rather than data. We'll talk about

OLE in Chapter 8.

Inferacting with Other Dafabases

You can import or link data from any of these database formats:

e dBASEIII, IlI+, IV, and 5.
e Paradox versions 3.x, 4.x, and 5.0.
e Microsoft FoxPro versions 2.0, 2.5, 2.6, and 3.0.
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Automating Import and TransferText Lets you import or export
Export Procedures data between the current Access database
and a text file. See the TransferText Action
and TransferText Method topics in the
Access Help Index.

You can use a macro or Visual Basic proce-
dure to automate importing, linking, and
exporting certain types of data. Here are
the macro and Visual Basic actions you'll SendObject Lets you create Microsoft
need to use: Excel (*.xIs), rich text format (*.rtf), MS-
DOS text (*.txt), HTML (*.htm), or HTX/
IDC (*.htx, *.idc) output from a table,
query, form, report, or module and then
send that output in an electronic mail
message. See the SendObject Action and
SendObject Method topics in the Access
Help Index.

TransferDatabase Lets you import or
export data between the current Access
database and another database. See the
TransferDatabase Action and Transfer-
Database Method topics in the Access
Help Index.

TransferSpreadSheet Lets you import
or export data between the current Access
database and a spreadsheet file. See the
TransferSpreadsheet Action and Transfer-
Spreadsheet Method topics in the Access
Help Index.

Parts Four and Five of this book introduce
macros and Visual Basic.
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e ODBC databases, including Microsoft SQL Server. You'll need a properly installed
and configured ODBC driver.

e Databases created with the Microsoft Jet database engine, including Microsoft
Access (versions 1.x, 2.0, 7.0) and Microsoft Visual Basic.

e Databases kept in Microsoft Excel worksheets, versions 5.0 and 7.0.

e HTML and HTX tables and lists.

* Lotus 1-2-3 files (read-only when linked).

Before you bring data from one of these other formats into an Access database, you
need to decide whether to link to that data or import your own copy of it. Table 7.1 lists
some points that can help you decide.
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Access 97 does not automatically include the drivers for Paradox and Lotus 1-2-3
files when you install it. You can get these drivers by installing the Office 97 Valy.
Pak. This option is included on the CD-ROM of the Microsoft Office Professional
Edition 97. The ValuPak can also be downloaded from Microsoft’s Web site:
choose Help » Microsoft on the Web » Free Stuff from the Access menus. See
Access 97 Help for more information on what the ValuPak provides.

l TABLE 7.1: DIFFERENCES BETWEEN IMPORTED AND LINKED TABLES

IMPORTED TABLE LINKED TABLE

Copied from the external table to your
open database. (Requires extra disk
storage.)

Linked to your open database. No copies
are made. (Conserves disk storage.)

Use when you no longer need to have the Use when you still need to have the origi-

original application update the table.

Converted to Access format and works
exactly like a table you created from
scratch.

You can change any properties, including
the structure, of an imported table.
Access can work faster with

imported tables.

Deleting the table deletes the copy from
your open database.

Access translates certain data types of the
original table to Access data types.

nal application update the table.

Retains its original database format, but
“acts like” an Access table.

You can change some properties, but you
can’t change the structure of a linked table.

Access may work more slowly with
linked tables.

Deleting the table deletes the link only,
not the external table.

No data type translations are necessary.

Where You’'ll See Imported/Linked Tables

When you import or link data from another database, Access treats the data as it would
one of its own tables. For linked tables, however, special icons in the database window
indicate that the data is not originally from Access.

In Figure 7.1 we linked Access tables named Expense Categories, Expense Details, and
Expense Reports (from another Access database); a Paradox table named Biolife; and a
dBASE table named Grades to an open Order Entryl database. We also imported a table
named Sales from a Microsoft Excel worksheet. Notice that the icons next to the linked
tables include an arrow symbol to indicate a link to the external tables; however, the icon
next to the Sales table looks like any other Access table icon.




IMPORTING OR LINKING A TABLE |213

o
Spe_cia( link Linked Paradox table Linked Access tables
icons indicate
i tables.
linked {E Tables I 7 quenes | Foms | @ Reports B Macos | o Modues |
[ Moo [ a] oo |
#Px BIOLIFE

Customers
Employees
»E Expense Cateqories
#»E  Expense Details
#[ Expense Reports

*dB Grades
r My Company Information
Order Details
Orders J

Payment Methods

X

Payments
Products

Sales

Shipping Methods .,l
»

Linked dBASE table
Imponted table

Importing or Linking a Table

Here are the general steps for importing or linking tables. The exact procedures will
depend on the type of data you’re importing or linking. Refer to the appropriate section
below for more details.
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1. Open (or create) the database you want to import or link the table to and switch to
the database window if it isn’t visible.
2. Do one of the following, depending on whether you are importing or linking:

e To import, choose File » Get External Data » Import, or right-click on the data-
base window (the shaded part, not a table name) and choose Import. Or click
on the Tables tab on the database window, click on the database window’s New
button, and then double-click on Import Table in the New Table dialog box.

* To link, choose File » Get External Data » Link Tables, or right-click on the data-
base window and choose Link Tables. Or click on the Tables tab on the database
window, click on the database window’s New button, and then double-click on
Link Table in the New Table dialog box.
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NOTE—

You cannot delete rows from linked Excel tables or text files.

3. Choose the type of data you want to import or link in the Files Of Type drop-down
list. For example, click on the drop-down list button next to Files Of Type and then
click on Paradox to import or link a Paradox table. :

4. Locate the file name you want to import or link and then click on it in the list below
Look in. Figure 7.2 shows a typical Link dialog box; the Import dialog box is similar,

The techniques for locating drives, folders, and files in the Link and Iimport dialog
boxes are the same ones that work in the Open and File New Database dialog boxes

(see Chapters 1 and 5, respectively).

5. Click on the Import or Link button or double-click on the file name you want to

import or link.

FIGURE 7.2

A Link dialog 3.Choose a file name. 2.Choose a folder,
box for linking o ‘
an Excel table.

4.Click on Link (or Import),

1.Choose a file format.



IMPORTING OR LINKING A TABLE | 215

6. Respond to any additional prompts and dialog boxes that appear.

¢ If you're linking a dBASE or FoxPro table, you'll be prompted to choose one or
more existing indexes to associate with the table. Choosing indexes will speed
up access to the linked table.

¢ If you're importing or linking a table from Paradox or a SQL database, you may
be prompted for a password. This password is set in the external program and
is different from an Access user password.

MNO W E
g Passwords of linked tables are stored in your database so that you can open the

table later by double-clicking on it in the Access database window. Be aware that
the database password is stored in an unencrypted form. If you need to protect
sensitive data in the linked table, you should implement user-level security, rather
than use a database password. (See Chapter 18 and the Help Index topic Linking
Tables, Password-Protected Databases.)

7. Click on OK if you see a message saying the operation is complete.

8. If the Import or Link dialog box remains on your screen, you can repeat steps 3
through 7 until you've imported or linked all the tables you want. When you're
done, click on the Close button as needed.

For more help on importing and linking tables, go to the Access Help Contents,
open the Creating, Importing, And Linking Tables book, open the Importing Or Linking
Tables book, and then double-click on an appropriate topic. You also can look up topics
and subtopics under Importing Data and Linking Data in the Access Help Index.

Importing or Linking Paradox Tables

Access can import or link tables (.db files) from Paradox version 3, 4, and 5 Follow
these steps:

1. Start from the Access database window and choose the Import or Link command.
(Two easy starting points are to choose the File » Get External Data commands on
the menu bar, or right-click on the database window and choose Import or Link
Tables from the shortcut menu.)

2. Choose Paradox from the Files Of Type drop-down list.

3. Locate the file you want to import or link and then double-click on it in the list
below Look In. You may be prompted for a password.

4. Type the password that was assigned to the table in Paradox and then click on OK.
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5. Click on OK when you see the message saying the operation is complete.
6. Repeat steps 3 through 5 as needed. When you’re done, click on Close.

Having trouble? Perhaps the following tips will help:

* Alinked Paradox table must have a primary key (.px) file if you intend to update
it through Access. If that file is not available, Access won’t be able to link the
table. Without a primary key, you'll only be able to view the linked table, not tq
change it.

¢ In general, any ancillary file that Paradox maintains for a table (such as a .mb fije
for memo fields) should be available to Access.

¢ Because Access can’t open OLE objects stored in a linked or imported Paradox
table, no OLE fields will appear when you open the table in Access.

e When linking a shared Paradox table that resides on a server, you must set the
ParadoxNetPath key in the Windows Registry to the path of the Paradox.net or
Pdoxusrs.net file. Furthermore, if you're using Paradox version 4 or 5 to share data
in your workgroup, you also must set the ParadoxNetStyle key to 4.x. For Paradox
version 3 tables, set this key to 3.x (the default is 4.x).

For more details about importing and linking Paradox tables, ask the Office Assistant
to search for Iimport Or Link A Paradox Table. You can also search for Registry or Registry
Editor with the Office Assistant for details about using the Registry Editor.

WA S IR & <= “
Making changes incorrectly in the Registry Editor can produce unexpected results
in Access. Be sure to back up all or part of the Registry before making changes in
the Registry Editor. See the topic Backing Up The Registry in the Registry Editor’s
Help Index for details.

Importing or Linking dBASE and FoxPro Files

Access can import or link tables (.dbf files) from dBASE IlI, IV, and dBASE 5 and from
FoxPro 2.0, 2.5, 2.6, and 3.0. Here are the basic steps for importing or linking a dBASE
or FoxPro table:

1. Start from the Access database window and choose the Import or Link command.

2. Choose dBASE III, dBASE 1V, dBASE 5, Microsoft FoxPro, or Microsoft FoxPro 3.0
from the Files Of Type drop-down list.

3. Locate the file you want to import or link and then double-click on it in the list
below Look In.
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4. Double-click on the index file you want to use if the Select Index Files dialog box
appears. Repeat this step until you’ve specified all the index files associated with
the .dbf file you chose in step 3, and respond to any other prompts that appear.
When you're done, click on the Close or Cancel button.

§. Click on OK when you see the message that the operation is complete.

6. Repeat steps 3 through 5 as needed. When you’re done, click on Close.

When linking dBASE or FoxPro files, keep these points in mind:

* To improve performance later, you can have Access use one or more existing dBASE
index files (.ndx or .mdx) or FoxPro index files (.idx or .cdx). The index files are
tracked in a special information file (.inf) and are maintained automatically when
you update the table through Access.

e If you use dBASE or FoxPro to update data in a linked .dbf file, you must manually
update the associated indexes; otherwise, Access won'’t be able to use the linked table.

e If you move or remove any .ndx, .mdx, or .inf files that Access is using, then
Access won't be able to open the linked table.

e To link tables on a read-only drive or CD-ROM drive, Access must store the .inf
file on a writable directory. To specify this directory, you must specify the path for
the .inf file in the Windows Registry.

For more about updating, look up Import Or Link A dBase Or FoxPro Table with the
Office Assistant. Search for Registry or Registry Editor with the Office Assistant for details
about using the Registry Editor.

Importing or Linking SQL Tables

If everything is properly set up, you can use Access and ODBC drivers to open tables on
Microsoft SQL Servers and other SQL database servers on a network. Here are the basic
steps for linking or importing SQL database tables:

1. Start from the Access database window and choose the Import or Link command.

2. Choose ODBC Databases from the Files Of Type drop-down list.

3. Click the Machine Data Source tab in the Select Data Source dialog box if you want
to work with data from another user or system. Double-click on the SQI data source
you want to use. (If necessary, you can define a new data source for any installed
ODBC driver by clicking on the New button and following the instructions that
appear. After creating the new data source, you can double-click on it to continue.
Alternatively, you can manage your ODBC data sources by double-clicking on the
32-bit ODBC icon in Control Panel.)
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4. Complete the remaining dialog boxes that appear, clicking on OK as needed to pro-
ceed. (These dialog boxes depend on the data source you chose.) For example, yoy
may be prompted for the following:

¢ Your login ID and password

Whether you want to save the login ID and password (if you're linking)
The tables you want to import or link

The fields that uniquely identify each record

§. Click on Close when you're finished importing or linking.

If you're having trouble with the importing or linking procedure, consider these
points:

* Before connecting to a SQL database, you must install the proper ODBC driver for
your network and SQL database. You can find information on this procedure by
looking up the Installing Drivers topic in the Access Help Index.

* Access includes the ODBC drivers for Microsoft SQL Server, Access, Paradox,
dBASE, FoxPro, Excel, Oracle 7, and Text. Before using any other OBDC driver
check with its vendor to verify that it will work properly.

o If you'll want to edit a linked SQL table, that table usually must contain a unique
index. If no unique index exists, you can create one by executing a data-definition
query within Access. For information on data-definition queries, open the Microsoft
Jet SQL Reference book in the Access Help Contents, open the Data Definition Lan-
guage book, and then double-click on the CREATE INDEX Statement topic.

e If the SQL table’s structure changes after you link it, you’ll need to use the Linked
Table Manager to refresh your link to the table (see “Using the Linked Table Man-
ager” later in the chapter) or delete and recreate the link.

e If an error occurs while you’re importing, linking, or using a SQL table, the prob-
lem may be with your account on the SQL database server or the database itself.
Please contact your SQL database administrator for assistance.

’

For more about the subtleties of importing and linking SQL tables, look up Import Or
Link An SQL Table with the Office Assistant.

Importing or Linking Other Access Databases

Normally you’ll want to store all the tables, forms, reports, and other objects that make
up a given application in a single Access database. But in a large company, different
departments might create their own separate Access databases. Fortunately, it’s easy to
import objects (tables, queries, forms, reports, macros, and modules) or link tables from
other unopened Access databases into your open database. Then you can use the
objects as if they were part of your currently open Access database. This method is
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much easier than using copy and paste to copy several related objects at once. Also,
linked tables allow many users to share a single copy of their data over a network.

You can import just the structure or both the structure and data of Access tables.
If you intend to import objects (forms, reports, queries, and so forth) for use with
tables in the open database, the name and structure of the tables in the open
database must match the name and structure of the tables originally used to cre-
ate the objects you're importing.

To import objects or link tables from an unopened Access database:

1.
2.
3.

. Do one of the following:

. Click on the tab for the type of object you want to import if you're importing

Choose the Import or Link command from the Access database window.

Choose Microsoft Access from the Files Of Type list.

Locate the Access database you want to import or link and then double-click on it
in the list below Look In.

e To link: You'll see the Link Tables dialog box shown in Figure 7.3; skip to step 6.
¢ To import objects: You'll see the Import Objects dialog box shown in Figure 7.4;
continue with step 5.

objects. As Figure 7.4 shows, your options are Tables, Queries, Forms, Reports, Mac-
ros, and Modules. For additional import options, click on the Options button (see
Figure 7.4) and then choose any of the options shown. (For help with the options,
click on the ? button at the upper-right corner of the Import Objects dialog box,
and then click on the place you need help with.)

The Link Tables
dialog box.

| ; |Expense Details
| { Expense Repoils
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FIGURE 7.4
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6. Use any of the following techniques to select the object(s) you want to import or
link and then click on OK to continue.
* To select all the objects of a particular type in one fell swoop, click on the
Select All button.
e To deselect all the selected objects, click on the Deselect All button.
e To select one object that isn’t selected yet, or to deselect an object that is selected,
click on its name.
Access will import or link all the objects you selected and return to the database
window.

The opposite of importing or linking a database is splitting it—a trick that can make

your database run faster over networks. You can use the Database Splitter Wizard

(Tools » Add-Ins » Database Splitter) to split a database into one file that contains

the tables and another that contains the queries, forms, reports, macros, and mod-
ules. See Chapter 18 for details.

Using Linked Tables

After linking a table from another database, you can use it almost like any other Access
table. You can enter and update data, use existing queries, forms, and reports, or develop
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Another Reason
to Use Wizards

Objects created with Access Wizards are
perfect candidates for linking or import-
ing into other Access databases that also
contain objects created with those Wiz-
ards. For instance, if you use the Database
Wizard or Table Wizard (with default set-

Service Call Management, for example—
those tables will have the same structure
in both databases. If you then import into
the Service Call Management database a
report that was designed to print the Cus-
tomers table in the Order Entry database,
that report should work perfectly on the
Customers table in the Service Order Pro-
cessing database.

tings) to create Customers tables in two
Access databases—Order Entry and

new ones. So even if the data resides in separate programs on separate computers, Access
can use the external table almost as if you had created it from scratch in your open data-
base. The only real restrictions are

e You can’t change the structure of a linked table.
e You can’t delete rows from a linked Excel table or text file.
e Lotus 1-2-3 files that you link to an Access database are read-only.

Creating a Database

N T E 2
g] After importing a table from another database, you can use it exactly like any other
T Access table. Access will never know that your imported table wasn’t originally
one of its own.

Setting Properties of Linked Tables

Although you can'’t add, delete, or rearrange fields of a linked table, you can set some
table properties, including the Format, Input Mask, Decimal Places, and Caption. You
change these properties in the table design view (see Chapter 6). In the database win-
dow you can right-click on the table name on the Tables tab, choose Properties, and
change the Description property.

Anytime you click in a General or Lookup properties box in the Field Properties area
of the table design window, the Hint box in the right side of the window will tell
you if the selected property cannot be changed.
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Renaming Linked or Imported Tables

Most objects will have their original file names when you import or link them to Access.
After you've imported or linked such a file, however, you can give it a more descriptive
name in your Access database window. For instance, you could rename an imported or
linked dBASE table from CredCard to Credit Cards (From dBASE).

To rename an imported or linked table quickly, right-click on its name in the data-
base window, choose Rename from the shortcut menu, type a new name, and then
press Enter.

Speeding Up Linked Tables

Although linked tables behave a lot like Access tables, they’re not actually stored in
your Access database. Each time you view linked data, Access must retrieve records
from another file that may be on another computer in the network or in a SQL data-
base. You might grow some gray hairs waiting for this to happen.

These guidelines can help speed up performance in a linked table on a network or
SQL database:

* Avoid jumping to the last record of a large table unless you need to add new records.

¢ View only the data you absolutely need and don’t scroll up and down unnecessarily.

* Create a form that has the Data Entry property on the Data tab set to Yes. That way,
if you frequently add new records to a linked table, Access won't bother to display
any existing records from the table when you enter data (see Chapter 13). This data
entry mode (also called add mode) can be much faster than opening the form in edit
mode and jumping to the last record. (If you need to see all the records again,
choose Records » Remove Filter/Sort.)

NOTE
g Here are three more ways to open a form or table in data entry mode: (1) Choose
‘ Records » Data Entry after opening a table or form; (2) choose Open Form In
Add Mode as the Command for a form you’ve added to a switchboard with the
Switchboard Manager (see Chapters 3 and 21); or (3) in a macro design window
use the OpenForm action to open a form and set the action’s Data Mode action
argument to Add (see Chapter 20).

e Use queries and filters to limit the number of records that you view in a form or
datasheet.
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e Avoid using functions, especially domain-aggregate functions such as DSum( ),
anywhere in your queries. These functions require Access to process all the data in
the linked table. See Chapter 10 for more about these functions.

e Avoid locking records longer than you need to when sharing external tables with
other users on a network. Hogging the locks will slow response time for others
and make you unpopular in a hurry. See Chapter 18 for more about using Access
on a network.

Using the Linked Table Manager

Access stores information about links to tables in your database. If you move the file
that contains the linked table to another folder, Access won't be able to open the linked
table. Fortunately, the Linked Table Manager can find the moved tables and fix things
up quickly. Here’s how to use it:

1. Open the database that you've linked the objects to.

2. Choose Tools » Add-Ins » Linked Table Manager to open the Linked Table Man-
ager dialog box (see Figure 7.5). This dialog box shows the linked objects and the
full path names of the associated source files.

3. Click on the appropriate checkboxes to select the linked tables you want to update.
If you select a table accidentally, click on its checkbox again to deselect (clear) the
box. Or click on the Select All or Deselect All buttons to check or clear all the check-
boxes in one step.

4. Select (check) Always Prompt For New Location to force the Linked Table Manager
to request the location for each table you checked in step 3.
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5. Click on OK.

6. Usc the Select New Location Of dialog box that appears next to find the folder that
contains the moved source table, and then double-click on the file name that cop-
tains the linked table. Repeat this step as needed.

\ R P_
The Select New Location Of dialog box works the same way as the Open, File New
Database, Import, and Link dialog boxes you already know and love. See Chapters 1

and 5 for techniques you can use in these dialog boxes.

7. Click on OK when Access tells you that the links were refreshed successfully; then
click on Close in the Linked Table Manager dialog box.

What the Linked Table delete the link and then relink the table with
Manager Cannot Do the correct table name and/or password.
The Linked Table Manager is great for Also, don’t expect the Linked Table
finding files that have wandered off to a Manager to move the database or table
different folder or disk drive or have been files for you. For that job, you'll need to use
renamed. However, if anyone has renamed Windows Explorer or My Computer. Or go
the linked table or changed its password, to any Access Open, File New Database,
Access won't be able to find the table and ~ Link, Import, or Select New Location Of
the Linked Table Manager won't be able to dialog box; then right-click on an empty
fix the problem. In these cases, you must area below the Look In list, choose Explore

from the shortcut menu, and explore as
you would with Windows Explorer.

Deleting the Link to a Linked Table

When you no Jonger need to use a linked table (or Access can’t find it because someone
has renamed it or changed its password), you can delete the link. To do this, open the
database window that contains the linked table and click on the Tables tab. Then click
on the table whose link you want to delete and press the Delete key. When asked if
you're sure you want to delete the link, click on Yes.

Remember that deleting a link deletes the information used to access the linked table,
but it has absolutely no effect on the table itself. You can relink the table at any time.
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Importing or Linking Spreadsheers and Text Files

You can import or link any of these spreadsheet and text formats into Access tables:

e Microsoft Excel versions 2, 3, 4, and 5, Excel 7 (also known as Excel for Windows 95
or Excel 95), and Excel 8 (Excel 97).

e [Lotus 1-2-3 or 1-2-3 for Windows (.wk1, .wk3, and .wk4 files). Lotus files that are
linked are read-only.

e Delimited text (values are separated by commas, tabs, or other characters).

¢ Fixed-width text, including Microsoft Word Merge (each field value is a certain
width).

When importing from a text file, you can create a new table or append the data to
an existing table. If your spreadsheet or text file contains field names in the first row,
Access can use them as field names in the table.

Access looks at the first row of data and does its best to assign the appropriate data type

for each field you import. For example, importing cells A1 through C10 from the spread- %

sheet at the top of Figure 7.6 creates the Access table at the bottom of the figure. Here we 'g

a

]

FIGURE 7.6 —~ .

Importing a : ﬁ

range of cells S

from an Excel = .
spreadsheet 2 [Burns Jos
into an |Bur ‘Sunny

Wilma
Wanda
Obeewan  §25.9%0
Keith  $55,000 |
Hanley §35,000

9 U Shirley $45 000 |
10 |Wilson Chavelita _ $45,100

Wl s3]\ sheon FSRERL«L] 31|

Access table. When you import cells A1

through C10 of this
Excel spreadsheet...

8 Salaries : Table =] B3 l

|| Last Nams | First Name | Salary
¥ |Burns Joe $38 000,00 |
}_ Burns Sunny $208,000.00
| |Gladstone  |Wilma $35 500.00
_J Granolabar Wanda $45,000.00
...Access creates this table. | [Kenobe  |Obeewan | $25390.00
| |Maricks Keith $65,000.00
|| Strappman  Hanley $35 000,00
| [Lyest Shirley $45,000,00
|| Wilsan Chavelita $45,100.00
* |
Record: 14| + | Tk |s]ve] of 8
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told Access to use the first row of the range (row 1) as field labels. Values in row 2 (the first
row of “real” data) were then used to determine the data types for each field.

You can change the field names and data types assigned to an imported table during
the import procedure. Alternatively, you can create an empty table with the field names
and data types you want and then append an imported text file to the empty table. In
Figure 7.7 we imported a delimited text file in which each field is separated by a comma
and text fields are enclosed in quotes. Again we asked Access to use the first row as field
labels. Access used the second row to determine each field’s data type.

Figure 7.8 shows the results of importing a fixed-width text file into an Access table,
This time, we told Access the field name to use for each field. (Access correctly figured
out the other details, such as field position and data type.)

~ FIGURE 7.7

Importing from
a delimited text
file into an
Access table.

"Last Nawe”, "First Name","Salary" &
"Burns", "Joe", $38000.00 -
"Burns", "Sunny", $28000.00
"Gladstone”, "Yilma®, $35500.00
When you import this "Granolshar®, "anda", $§45000.00
delimited text file... "Kenobe", "Obeewan®, $25990.00
"Maricks", "Keith", $55000.00
"Strappman”, "Hanley", $35000.00
"Uiest”, "Shirley", $§45000.00
"Jilson”, "Chavelita®, $45100.00

& SALARIES Delimited : Table

Joe

T Sunny

| Gladstone Wilma |

Granolabar Wanda |
|

...Access creates this table. Kenobe | Obeewan $25 990.00
Maricks Keith $a6,000.00

|| Strappman | Hanley | §35000.00

|- Ujest | Shirley | $45,000.00

| $45,100.00

= iphavelita
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Importing from
a fixed-width
text file into an
Access table,

[purns Joe $38000.00 |
Burns Sunny $28000.00
Gladstone Wilrna $35500.00
Grano labar Wanda $45000.00
Kenobe Obeewan $25990.00
When you import this | Haricks Reith $55000,00
fixed-width text file... Strappman Hanley §35000.00
Ujest Shirley $45000.00
Wilson Chavelita $45100.00

\
e ey A 7F‘7Iﬁﬁﬂf41

dalar
$38,000.00

. | Sunny $28,000.00 | |
| Glagstone | Wilma | §35500.00 |
|| Granolabar  Wanda $45,000.00
...Access creates this table | ~|i<enobe | Obeswan | $25990.00
||| Maricks | Kaith | $55,000.00
Strapptrian Hanley $35 000.00
Ujest Shirley $45,000.00
1 | wilson | Chavelita $45,100.00 | |

Importing or Linking Spreadsheets

Importing or linking a spreadsheet into Access is a snap thanks to the Import Spreadsheet
Wizard. But before you import or link, remember that the data in your spreadsheet must
be arranged so that:

e Each value in a given field contains the same type of data.

e Each row contains the same fields.

e The first row in the spreadsheet contains either field names or the first actual data you
want to import, or you've defined a named range for the data you want to import.

If the spreadsheet you intend to use doesn't fit this specification, you'll need to fix
it before importing or linking it into Access.
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To import or link a spreadsheet:

1. Start from the Access database window in which the table should appear and
choose the Import or Link command.
2. Choose the spreadsheet format you want to import from the Files Of Type drop-down
list. Your choices are Microsoft Excel (for importing or linking) and Lotus 1-2-3 (for
importing only).
3. Locate the spreadsheet file you want to import or link and then double-click on it in
the list below Look In. The Wizard will take over. If your worksheet contains a named
range or multiple sheets, you'll see a dialog box similar to Figure 7.9 (the Import
Spreadsheet Wizard and Link Spreadsheet Wizard dialog boxes are the same, except
for their title bars).
4. Choose whether to Show Worksheets or Show Named Ranges, click on the work-
sheet or named range you want to use, and then click on Next. Figure 7.10 shows
the next dialog box you’ll see.
5. If the first row of the range you're importing or linking contains labels that you
want to use as field names for the table, select (check) First Row Contains Column
Headings. If you don’t check this box, Access will start importing or linking data
with the first row of the range and will assign the name Field followed by a sequen-
tial number as the field names (Field1, Field2, Field3,...). Click on Next to continue
to a dialog box that lets you choose whether to import the data into a new table or
into an existing table.

|_FIGURE 7.9 |

This Import | 55 Import Spieadshesl Wizard
Spreadsheet SERAE L , : LI
Wizard dia Iog :;feug spreadsheet file contains more than one sheet or range  Which sheet or range would you

box appears if
your worksheet
contains multi-
ple sheets or
named ranges.
If you're linking
an Excel work-
sheet, the Link
Spreadsheet
Wizard dialog
box will be the
same except
for its title bar.

" Show Worksheets
@ Show Named Ranges




IMPORTING OR LINKING SPREADSHEETS AND TEXT FILES I 229

This dlalog box

lets you specify
whether the Microsolt Access can use your column headings as field names for your table. Does the first row
first imported or specified contain column headings?
linked row v First Fit Contains Colun Headings
contains field Iy
names. In this
example we're
importing the
spreadsheet Fiket Nass Eatare
shown at the 1 Burns ioe 538,000 -
top of urns Sunny 528,000
i P 1ladstone  [filna 535,500
F/gure 7.6. Lranolabar [Fands 45,000
i H enoba Dbesyan $25.990
Ag(;g;eggi'l’l;gl; ariclks Heith 555,000
BStrappman [Hanley $35,000
Wizard dialog 8lUjest Shirley  [$45.000 =
box is similar. A 2
Cacel | i [ News rih |

6. Click on your choice and choose a table in the open database if you select In an
Existing Table:. Click on Next.

7. If you're importing, you'll see the dialog box shown in Figure 7.11. From here you
can specify information about each field you're importing. To tell the Wizard which
field you want to define, click anywhere on the sample data for that field in the lower
part of the dialog box. Then fill in the Field Name box, specify whether the field is
indexed by choosing No, Yes (Duplicates OK), or Yes (No Duplicates) from the
Indexed drop-down list, and specify a data type by choosing an option from the Data
Type drop-down list (if available). If you prefer to skip the field—that is, not to
import it—select (check) Do Not Import Field (Skip). Repeat step 7 as needed and
then click on Next.

8. If you're importing, the next dialog box will let you specify how Access should
assign the primary key. You can let Access add the primary key, choose your own
primary key from a drop-down list of available field names, or omit the primary
key. After making your selection, click on Next to continue.

9. The last dialog box lets you specify a table name if you chose to import data into a
new table. If you're importing, you also can choose whether to analyze the new
table’s structure with the Table Analyzer Wizard. (Chapter 16 describes the Table
Analyzer Wizard.) Complete this dialog box and then click on Finish.

10. If you're asked for permission to overwrite an existing table, click on Yes to over-
write the table and continue with step 10 or click on No to return to step 8.

11. When Access tells you that it has finished importing or linking the table, click on
OK. You'll see the new table name in the database window.

v
v
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o
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FIGURE 7.11 ——

This dialog box 2.Choose options for the selected field.
lets you specify
the field name,
indexing, and
data type for
each imported
field, and it lets
you skip fields
as needed.

1.Click anywhere in the field you want to change.

Importing or Linking Text Files

A delimited text file is one in which fields are separated by a special character, such as a
comma or tab, and each record ends with a carriage-return/linefeed combination.
Typically, character data items are enclosed in quotation marks as shown at the top of
Figure 7.7.

A fixed width text file is one in which each field is a specified width, and each record
ends with a carriage return/linefeed combination (see the top of Figure 7.8).

Before importing or linking a text file, make sure it’s arranged so that each value in a
given field contains the same type of data and the same fields appear in every row. The
first row can contain the field names you want Access to use when creating the table.

The procedure for importing or linking text files is controlled by a Wizard that’s fast
and painless to use. In fact, reading these steps takes much longer than doing them:

1. Start from the Access database window in which the table should appear and
choose the Import or Link command.
2. Choose Text Files from the Files Of Type drop-down list.
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3. Locate the text file you want to import or link and then double-click on it in the list
below Look In. The Wizard will take over (see Figure 7.12).

4. Choose the format that describes your data if Access didn’t guess the correct format
(either Delimited or Fixed Width) and then click on Next.

NOTE
g The Advanced button in the Text Import Wizard and Link Text Wizard dialog
: boxes lets you define, save, load, and delete import specifications. You can use an
import specification if you want more control over such things as the order of
dates, date delimiters, time delimiters, and other details. In most cases, it’s not
necessary to use the Advanced button because the Wizard defines the specifica-
tion for you. There’s more about using import specifications later in this chapter.

5. What happens next depends on your choice in step 4:

e If you chose Delimited, you'll see the dialog box shown in Figure 7.13. Choose
the delimiter that separates your fields, specify whether the first row of text
contains field names, and specify the character that encloses text within fields
(the Text Qualifier). As you make choices, the sample data in the dialog box
will reflect your changes, so you can see immediately whether your choices
make sense.

The first Text
Import Wizard

B Text Import Wizard [ ]

The wizard has decided that your data is in a Defimited’ format. If it isn, choose the format

dialog box lets that mote correctly describes your data.
you choose a ‘
format for mnmmwmmm S —

importing your

data. If you're

linking the text : -
file, the Link Text

Wizard dialog Baid

box will fook the

dala M&WRKMALDEUM TXT

same except for
its title bar.

"Burns"
"Burns",

"Last NHane"

"Sunny", $28

"Gladstone"  “Uilma"
"Granclabar”.
"Kenobe"

"Obeewan"

"Wanda"
.$25990 .00

“First Hane', "Salary"
,"Joe", $3800

n.00

noo. oo
,$35500 00
., $45000.00

I |"Maricks",

"Ujest", “Sh
"Wilson",6 "C

"Keith",$55000.00
"Strappman",

"Hanley",h $35000 00
irley", $45000 00
havelita",$45100 00 |

Adyanced.. |

Cancel fody
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FIGURE 7.13 .

This Text Import
Wizard dialog
box lets you
choose the
delimiter and
text qualifier
(enclosing char-
acter for fields)
for a delimited
text file. You also
can specify : 38
whether the R -4 B
first row of text 545000
contains field flenahe : $25330.
names. The 3
Link Text Wiz-
ard dialog box
is similar.

¢ If you chose lixed, you'll see the dialog box shown in Figure 7.14. You might
not need to change any of the settings, but if you do, the instructions in the
dialog box explain how (it’s easy!). As you specify the field breaks and field
widths, the sample data in the dialog box will reflect your changes.

6. Complete the dialog box shown in Figure 7.13 or 7.14 and click on Next.
7. Skip to step 8 if you're linking a text file.

Or

Use the next dialog box to choose whether to store your data in a new table or an
existing table if you're importing a text file:

s To save the data in a new table, select In A New Table, click on Next, and con-
tinue with step 8.

e To add the imported data to the end of an existing table, choose In An
Existing Table, use the drop-down list to select the existing table, and then
click on Next. SKip to step 10.
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This Text Import

wizard dialog -
box lets you I:mdhmm:demmﬁulﬁmemﬁddha&sm.m&pywm?lf
specify the posi- —_— —
tion and width Lines with arrows signify field breaks.
each field in To CREATE a bi=sk line, click at e desied postion.
of fixed width ToDELETE a bireak ine, covble: click on the fine.
yOU;"I’ The Link To MOVE a break line, click and diag it |
1e. — 1
T‘Z;é ,?;Zggz .10 20 30 40 50
is similar. urns ice 538000 . 00 &
nrns Sunny 528000 .00
ladstone Vilna $35500 .00
Granolabar anda 545000 00
- Kenobe Dbheevan 1325990 00
aricks eith 955000 00
trappman lanley 535000.00
jest Shirley 545000, 00 =]
CI I »
Advarced.. | cgack | Nab{.a_l Fikh |

WA/ A IR NG
When you add imported data to the end of an existing table, each field in the data file
you're importing must have the same data type as the corresponding field in the des-
tination table, each field must be in the same order, the data must not duplicate data
in primary key fields, and the data must not violate any validation rules. If you're using
the first row as field names, the field names in your data file must exactly match the
names of your table fields. (Appropriate error messages appear if the data breaks any
rules, and Access gives you a chance to continue importing data or to cancel the
import procedure.)

Q
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Q
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8. If you're importing to a new table or linking, specify the field name, indexing, and
data type for each field, and skip fields as needed. The procedures are the same ones
given for step 6 of the earlier procedure “Importing or Linking Spreadsheets.”
Repeat this step as needed and then click on Next.

9, If you're importing to a new table, specify how Access should assign the primary
key. You can let Access add the primary key, choose your own primary key from a
drop-down list of available field names, or omit the primary key. Click on Next to
continue. The last dialog box lets you specify a table name.
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10. If you're importing, you also can choose whether to analyze the table’s structure
with the Table Analyzer Wizard (see Chapter 16). Complete this dialog box and
then click on Finish.

11. If you’re asked for permission to overwrite an existing table, click on Yes to over-
write the table and continue with step 12 or click on No to return to step 10.

12. Click on OK when Access tells you that it has finished importing or linking the
table. You'll see the new table name in the database window.

Using an Import or Link Specification

You can ignore the Advanced button in the Text Import Wizard and Link Text Wizard
dialog boxes and focus on only the main steps given in the previous section. But suppose
dates in your text file aren’t in the standard month/day/year order used in the United
States. Perhaps your data uses a period instead of a slash as a date separator. Or maybe the
text file was created with an MS-DOS or OS/2 program instead of a Windows program.
In situations such as these, you must use an import specification to provide extra

details about your file’s format. To load a previously saved specification or to define a
new one, click on the Advanced button in any Text Import Wizard or Link Text Wizard
dialog box (refer to Figures 7.11, 7.12, and 7.13). Figure 7.15 shows the Import Specifi-
cation dialog box for a delimited text file, and ligure 7.16 shows one for a fixed width
text file. As you'd expect, the Link Specification dialog boxes are the same except for
their title bars.

| FIGURE 7.15 IS 3

.
Specification e = TES
i IOQ biec for @ File Foimal. & f_gelimiledl ' Field Delmiter. |, i) II DK I
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= e
;j h =

Saye@s:., ‘

File Cirigiry: [Windom [ANSI]

d

dialog box - Dates, Timss, and Numbers — = ) -
is similar. Dalelrder MDY =] I~ Four Digit Years ﬂ—,
Date Delimitar: ](‘ I™ LeadingZaros in Dates
- Time Delmter I:ﬁ - Decimal Symbol [
Field |nformation: .
|| Field Name | Data Type Indexed |
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Filling in the Specification
At the top of the Import Specification or Link Specification dialog box, you can specify the
File Format (either Delimited or Fixed Width). For delimited files, you also can specify:

Creating a Database

Field Delimiter If the text file uses a character other than a comma (,) to separate
fields, type the correct character, or open the drop-down list and select one. The drop-
down list includes comma, semicolon, tab, and space options.

Text Qualifier If the text file uses a delimiter other than double quotation marks (")
to surround text fields, type the correct character, or open the drop-down list and
select a character. Select {none} if your file doesn’t use a text delimiter.

In the center portion of the dialog box, you can change these settings:

File Origin Controls the way Access interprets extended characters (those with
ASCII codes higher than 128). If the text file was created with a Windows pro-
gram, choose Windows (ANSI) from the File Origin drop-down list. If the file was
created with a DOS or OS/2 program, choose DOS or OS/2 (PC-8).

Date Order If the text file has dates that aren’t in the MDY (month, day, year)
order commonly used in the United States, choose an option from the Date Order
drop-down list. Foreign dates often appear in a different order, such as DMY (day,
month, year) in France or YMD (year, month, day) in Sweden.



!36 l CHAPTER 7 e LINKING, IMPORTING, AND EXPORTING DATA

e

Date Delimiter If the text file has dates that aren’t separated by a slash (as in 11/
9/53 for November 9, 1953), type the delimiter character in the Date Delimiter
text box. Some countries outside the United States use different delimiters, such
as the period in France (09.11.53) and the hyphen in Sweden (53-11-09).

Time Delimiter If hours, minutes, and seconds are delimited by a character
other than a colon (:), specify the correct character in the Time Delimiter text box_
Four Digit Years If years in your text file include all four digits, as in 11/9/1953,
select Four Digit Years.

Leading Zeros In Dates If the dates in your text file include leading zeros, select
Leading Zeros In Dates. (United States dates normally appear without leading zeros.)
Decimal Symbol If a character other than a period (.) is used for the decima]
point in numbers with fractions, specify the correct character in the Decimal Sym-
bol text box.

In the Field Information area near the bottom of the dialog box, you can define the
Field Name, Data Type, and Indexed options for each field much as you do in table
design view. To skip a field during the import, check the appropriate box in the Skip
column. If you're working with a fixed-width file, you also can specify the Start and
Width for each field. (However, it’s often easier to drag the vertical lines in the dialog
box shown in Figure 7.14.) If you do adjust the Start and Width values manually, make
sure that no gaps exist between any two fields and that no fields overlap.

To calculate the Start value of a field, add the Start and Width values of the previ-
ous field. In Figure 7.16, for example, Field 1 starts at 1 and its width is 12. Thus
Field 2 must start at 13 (1 + 12).

Managing Import and Link Specifications

You can save your specifications for later use when importing or exporting similar text
files, and you can retrieve and delete import specifications as needed. Just use these two
buttons in the Import Specification or Link Specification dialog box:

Save As Lets you save an import/export specification. Click on Save As, type a
descriptive name for your specification (or accept the suggested name), and then click
on OK. Access will save your specifications and return you to the Import Specification
dialog box.

Specs Lets you use or delete an existing import/export specification. Click on the
Specs button and then click on the specification you want to work with. Then to use
the selected specification for the current file, click on the Open button. To delete the
specification, click on the Delete button, click on Yes, and then click on Cancel.
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Continuing with the Import or Link

When you're done changing the import or link specifications, click on OK in the Import
Specification or Link Specification dialog box. You'll return to the Wizard dialog box you
were using when you clicked on the Advanced button.

Importing or Linking HTML Files

Access 97 has a new feature that lets you import or link Hypertext Markup Language
(HTML) files to an Access database. HTML is the special coding used for referencing
graphic files and formatting in files that are published on the Internet. The files can be in
Jhtm, .html, or .htx format. Version 1.0 is supported for HTML list files, and versions 2.0
and 3.x for HTML tables or lists. Figure 7.17 shows Microsoft Internet Explorer being used
to view the file c:\Program Files\Microsoft Office\ Access\Samples\cajun.htm. Figure 7.18
shows the same file after it was imported as a new table into an Access database.

]
w
-]
] 2
£
A file £} Untitled Page - Microsoft Inteinet Exploier = [F] %] (=]
being viewed Ple Edt View Go Favoites Help =
with Microsoft F ok ote 6 ' A CQ:‘ = : = B . =
| \ b G- K & £
Internet Explorer. | U © Fowsd Sop Rehesh Home Search Favoites Fit  Fom  Mal  Ed | E
UAddress‘! ﬂ] Links [3] Best of the Web [3] Today's Links  [d] Web Gallery Product News Microsoft | S
== ' ]
What's New?
Optimizsd for huternet Exploter, 8003500 resobution
New Products
Category Product Units Price
Condiments BBQ Sauce 12-16 oz hottles ~ $18.00
Condiments Etouffee Mix 24-250z $27.00
packages
Condiments Red Bean 24-250z $27.00 =]
[Done 1o
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FIGURE 7.18

A table called

#F Cajun Products ; Table

Cajun Products | Category _ ~ Product ts Pt
imported from ¥ BEQ Sauce 12 16 oz bottle $18.00
an HTMI- file. Condimerts  Etouffee Mix 24 - 2.5 oz pack §27.00
The file was j Condiments  Red Bean Seasonings 24 - 25 oz pack §27.00
created without | |Confections | Bleignel Mix [12 - 32 0z boxe| $20.00
a primary key. | [Confections  King Cake Mix ‘12 30 0z boxe §39.00
|| Grains/Cereals. Dirty Rice Mix -8 oz boxes §20.26
|| Grains/Cereals | Hushpuppy Mix 12 18 oz boxe $18.50

| |Produce Black-eyed Peas |12 - 16 oz pack $8.50

|| Produce Carn Soup Mix 124 - 14 oz pack $42.50
| |Produce Hot Pickled Okra 18- 120z jars $20.25
| Seafood | Crawfish Jambalaya 12- 15 oz cans| £33.00

To import or link an HTML file:

1. Start from the Access database window in which the imported or linked table
should appear and choose the Import or Link command.

2. Choose HTML Files from the Files Of Type drop-down list.

3. Locate the file you want to import or link and then double-click on it in the list
below Look In to start the HTML Import Wizard. The first dialog box will show data
as in Figure 7.10 where the Import Spreadsheet Wizard is shown. The only differ-
ence is the title of the dialog box.

4. Check First Row Contains Column Headings if Access can find the field names in the
HTML file. Then click on Next.

5. If you are importing, choose whether to create a new table or append the records
to an existing table. If the latter, click on In an Existing Table: and select a table
before you click on Next.

6. If you're importing to a new table or linking, specify the field name, indexing, and
data type for each field, and skip fields as needed. The procedures are the same ones
given for step 6 of the earlier procedure “Importing or Linking Spreadsheets.”
Repeat this step as needed and then click on Next.

7. If you're importing to a new table, specify how Access should assign the primary
key. You can let Access add the primary key, choose your own primary key from a
drop-down list of available field names, or omit the primary key. Click on Next to
continue. The final dialog box lets you specify a table name.
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8. If you're importing, you also can choose whether to analyze the table’s structure
with the Table Analyzer Wizard (see Chapter 16). Complete this dialog box and
then click on Finish.

9. If you're asked for permission to overwrite an existing table, click on Yes to over-
write the table and continue with step 10 or click on No to return to step 8.

10. Click on OK when Access tells you that it has finished importing or linking the
table. You'll see the new table name in the database window.

Refining an Imported Table's Design

After importing a table, you can improve its design in several ways. To get started, open
the table and switch to design view. Then, as necessary...

e Change field names or add descriptions. This modification is especially helpful
if you didn’t import field names along with the data.
e Change data types. Access does its best to guess the correct data type for each

field based on the data you imported, and it gives you a chance to make adjust- ,31
ments. However, you can refine the initial choices as needed.

¢ Set field properties such as Field Size, Format, and so forth. 2

* Set a primary key to uniquely identify each record in the table and to improve o

performance. =

$

=

NOTE
g See Chapter 6 for more information about changing and customizing tables.

Troubleshoofing Imporf Problems

If Access has problems importing records into your table, the program will display a mes-
sage similar to the one shown below. For each record that causes an error, Access adds a
row to a table named xxx _ImportErrors (or xxx _ImportErrors1, xxx _ImportErrors2, ...)
in your database, where xxx is the name of the imported table. You can open that Import-
Errors table from the database window to view the error descriptions.

Text import Wizard

(1) Finebied impoiting fds
CAWINDOWS D eskiop\SALBAD, TAT* to table
BALBAD' Not all of your dath was succesziuly
imparted, Emor descriptions with led row
numbers of bad records can be found in the
Microsoft Access table 'SALBAD_|mportErnors1’.

£\
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Figure 7.19 shows the ImportErrors table Access created when we tried to import the
delimited text file shown at the top of the figure. Notice that the third line contains 3
tilde (~) instead of a comma as the field delimiter, and the sixth line has an exclamation
point (!) where the decimal point belongs. The SALBAD table at the bottom of the fig.
ure contains the records Access imported from the text file. Notice that the bad record
in line 3 of the Salbad text file was imported into the table as a blank record, and the
bad currency field in line 6 was imported as a blank field.

Il e e ]
When importing a text file that might have bad data, do not assign any primary

key. The resulting table records will appear in the same order as they appear in the
text file, and blank table records and fields will be easier to trace to the correspond-
ing lines in the text file. After cleaning up any problems with the imported data,
you can assign a primary key to the table.

FIGURE 7.19 3
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Problems When Importing to New Tables

When importing records into a new table, Access may run into these problems:

e Access chose an erroneous data type for a field because the first row of data didn’t
properly reflect the type of data you were importing. This error can happen if you
forget to check the First Row Contains Field Names option or if a field that con-
tains mostly text values has a number in the first row.

* One or more rows in the file contain more fields than the first row.

e The data in the field doesn’t match the data type Access chose for the field or the
data is blank. For example, a number may contain a bad character (as in the exam-
ple of Figure 7.17), or a row may contain extraneous characters or summary
information.

Problems When Importing to Existing Tables

When importing records to an existing table, Access may be tripped up if:

e The data in a numeric field is too large for the field size of a table field. For exam-
ple, Access can’t import a record if the table field has a Field Size property of Byte
but the data contains a value greater than 255.

e One or more records in the imported data contain duplicate values for a primary
key field in the table or for any field that has an Indexed propert)} set to Yes (No
Duplicates).

¢ One or more rows in the file contain more fields than the table contains.

e The data in a text file or spreadsheet field is the wrong type for the corresponding
table field. For instance, the table field may be a Currency type, but the data con-
tain a person’s name.

Creating a Database

B R ad = __——————— o ——— e —— 1]
Importing can take some time. But if the wait seems unreasonably long, it may be
a sign that many errors are occurring. To cancel the import, press Ctrl+Break.

If Access reports errors or your imported table contains blank fields or records, open
the ImportErrors table and try to figure out what went wrong. You may need to correct
your data file, or you may need to change the structure of an existing table. After solv-
ing the problems, you can import the data again.

Be careful to avoid adding duplicate records when importing the data the next time.
One way to prevent duplicate records is to copy your original data file and delete from
the copy all records that made it successfully into the table. Make any necessaty correc-
tions to your data or table; then choose In An Existing Table when importing your data.
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Another way is to delete the table you imported the first time and then import again;
or just let Access overwrite the first table you imported.

For more information about the ImportErrors table, look up the Import Errors Table
topic in the Access Help Index.

Exporting Data from Access

You can export data from your Access tables to any of the HTML, text file, spreadsheet,
or database formats already discussed; this procedure allows you to maintain your data
in Access and use it in many other programs. You also can export Access database
objects to other Access databases and to your electronic mail program.

[P R eaaeee——————— ]
Many database programs do not allow table and field names to contain spaces or
have up to 64 characters (as Access does). When you export a table, Access auto-
matically adjusts names that aren’t allowed in another program.

You can export data from your Access database with any of these options. (You'll
learn more about them soon.)

Save As/Export (On the File menu and the database window’s shortcut menu)
Converts an Access database object to Microsoft Access, Microsoft Excel (5-7, 4, or 3),
Text Files, Parado/x (3, 4, or 5), Lotus 1-2-3 (wkl or wk3), HTML (htm), dBASE (IIj, 1V,
or 5), Microsoft FoxPro (2.0, 2.5, 2.6, or 3.0), Microsoft Word Merge, Rich Text For-
mat, HTX, and ODBC Databases.

Save to HTML/Web Formats (On the File menu) Has options for converting an
Access object to HTML or IDC/HTX; also can be used to start the Publish to the
Web Wizard or change publishing defaults.

OfficeLinks (On the Tools menu and the y iceLinks drop-down toolbar button)
You can save data to a file and immediately start the appropriate Microsoft pro-
gram. These options include Merge It with MS Word, Publish It with MS Word (as a
Microsoft Word RTF file), and Analyze It with MS Excel.

Send (On the File menu) Converts an Access database object to an HTML, HTX,
Microsoft Excel, Rich Text Format, or MS-DOS Text file, and then sends the file to
someone else via electronic mail.
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Exporting Objects

The basic steps for exporting objects are remarkably similar to those for importing
objects:

1. Start from the database window that contains the object you want to export. If you
want to export the entire object, click on the object’s name on the database win-
dow. If you want to export selected records from a table or query, open the table or
run the query and then select the records you want to export.

2. Choose File » Save As/Export, or right-click on a gray area in the database window
and choose Save As/Export.

3. Choose To An External File Or Database in the next dialog box and then click on
OK. The Save Table dialog box will appear.

4. Choose the export format for the data in the Save As Type drop-down list. For exam-
ple, click on the drop-down list button next to Save As Type and then scroll down to
and click on Rich Text Format to copy the object to a Rich Text Format file.

5. Locate the folder that should contain your new file and then type a file name in the
File Name text box, or accept the suggested file name.

Ll e e —__ ——
The techniques for locating drives, folders, and files in the Save As dialog box are
the same ones that work in the Open and File New Database dialog boxes (see
Chapters 1 and 5, respectively).
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6. If you chose Microsoft Excel 5-7, Text Files, or Rich Text Format, you also can
choose one or more of these options:

Save Formatted Select (check) this option (if it’s available) to save the exported
data with as much formatting as possible; deselect (clear) this option to omit for-
matting in the exported data.

AutoStart Select (check) this option to immediately open the exported file
for viewing in the appropriate program.

All or Selection Choose All to save the entire file; or choose Selection to save
records that you selected in step 1.

7. Click on the Export button. If the file name you chose already exists, you’ll be
asked if you want to replace the existing file; click on Yes to replace the file and
continue with step 8, or click on No to leave the file alone and return to step 5.

8. Respond to any additional prompts and dialog boxes that appear.
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Access will copy your Access object to the format you requested and save the results
in the file you chose in step 5. If you chose AutoStart in step 6, the file will open in the
appropriate program (click on the program window’s Close button or choose File »
Exit to return to the Access database window).

For more help on exporting objects, go to the Access Help Contents, open the Shar-
ing Data And Pictures With Other Applications book, open the Exporting Data book, and
then double-click on an appropriate topic. You also can look up topics and subtopics
under Exporting Data in the Access Help Index. The following sections show detailed
procedures for exporting to different types of destination files.

Exporting to Text and Excel 5-7 Files |

You can export Access tables, queries, forms, and reports to text files that are useful with
word processing programs and to Excel version 5 through 7 worksheets. Here’s how:

1. Follow steps 1 to 3 of the general “Exporting Objects” procedure, given in the pre-
vious section.
2. Choose one of these export formats for the data in the Save As Type drop-down list.

* To export Access data for use with text-based word processors such as Win-
dows Notepad or WordPerfect for DOS, choose Text Files.

* To export Access data as a delimited Microsoft Word for Windows mail
merge data file, choose Microsoft Word Merge.

¢ To export Access data as a formatted Rich Text Format file, choose Rich Text
Format. You can edit this type of file in Microsoft Word, WordPad, and other
Windows word processors.

* To export Access data to an Excel version § through 7 worksheet, choose ’1
Microsoft Excel 5 through 7. ‘

3. Locate the folder that should contain your new file and then type a file name in the
File Name text box (if necessary).

4. (Optional) Choose the Save Formatted, Autostart, All, or Selection options described
in the general procedure for exporting objects. All of these options may not be avail-
able, depending on the type of file you are creating by doing the export.

§. Click on Export.

~NOTE
g If you chose Text Files and you did not choose Save Formatted, the Text Export
’ Wizard will take over. The dialog boxes and options are similar to those described I
for the Text Import Wizard. See “Importing or Linking Text Files” and Figures 7.11
through 7.15, earlier in this chapter.
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Access will save the data file in the format you chose. The first row of the spreadsheet
or text file will contain the field names from the table or query. If you selected Autostart
in step 4, the exported file will open in the appropriate program and you can view or
change it as needed. (Click on the program window’s Close button or choose File » Exit
to return to the Access database window.)

Exporting to Spreadsheets, Paradox, FoxPro, or dBASE

Use the following procedure to export Access tables and queries to Microsoft Excel,
Lotus 1-2-3, Paradox, FoxPro, or dBASE files. Later sections explain how to export to
other database formats.

1. Follow steps 1 to 3 of the general “Exporting Objects” procedure.

2. Choose one of the Microsoft Excel, Paradox, Lotus 1-2-3, dBASE, or Microsoft Fox-
Pro export formats for the data in the Save As Type drop-down list.

3. Locate the folder that should contain your new file. If necessary, type a file name
in the File name text box.

4. Click on Export.

The resulting database or spreadsheet file will contain all the data from your table or
query. For spreadsheets, the first row will contain the field names from the table or query.

Exporting to a SQL Database

To export an Access table or query to a SQL database:

1. Follow steps 1 through 3 of the general “Exporting Objects” procedure.

2. Choose ODBC Databases in the Save As Type drop-down list. The Export dialog

box appears.

. Specify a name for the table in the ODBC database and then click on OK.

4. Double-click on the ODBC data source you want to export to in the SQL Data
Sources dialog box. (If necessary, you can define a new data source for any installed
ODBC driver by clicking on the New button and following the instructions that
appear. After creating the new data source, you can double-click on it to continue.)

5. Enter whatever information your ODBC data source requires, clicking on OK as
needed. As for importing ODBC data sources, you may need to enter a logon ID
and password.

2]

Access will connect to the ODBC data source and create the new table.
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— NOTE
When you export an Access table to an ODBC database, Access does not export the
primary key and index information for the table. If you later link to your exported
table without having modified its design in the ODBC database, Access will treat
the table as read-only.

For more about exporting tables to ODBC data sources, look up ODBC, Exporting
Access Data in the Access Help Index.

Exporting to Another Access Database

Earlier in this chapter, you learned how to import or link objects from another Access
database to the open database. You also can perform the inverse operation: copy a table,
query, form, report, macro, or module from your open database to another existing
Access database. Here's how:

1. Follow steps 1 through 3 of the general “Exporting Objects” procedure.

2. Choose Microsoft Access in the Save As Type drop-down list.

3. Locate the folder that contains the Access database you want to export to and then

click on the database name in the list below Save in.

. Click on Export.

5. Specify the name for the object you're exporting in the Export dialog box or accept
the suggested name. If you're exporting a table, choose whether to export the table’s
Definition And Data or its Definition Only. Then click on OK. If the database you're
exporting to already has an object with the name you specified, you'll be asked
whether to replace the existing database object with the one you are exporting.

6. Click on Yes if you want to replace the existing object with the one you're exporting;
or click on No if you don’t want to replace the original object (you'll be returned to
step 5).

=

Access will copy the object to the other database.

Exporting to HTML or HTX Files

HTML is the system of coding that’s used to prepare files for publication on the Inter-
net. Special codes are used to reference graphic files for logos or other pictures, and
other codes, or formatting tags, are used to indicate how data should be presented (as
headers and footers, font size, bolding, etc.). An HTX file is part of a publication that
has dynamic links to a database. For an HTX export, Access creates two files: an .htx file
that refers to an HTML template and an .idc file that includes information on how to
connect to the ODBC data source containing the data to be published.
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To export an Access table or query to an HTML or HTX file:

1. Follow steps 1 to 3 of the general “Exporting Objects” procedure. (If you don’t need to
change any of the publishing defaults, select the table you want to export in the Data-
base window. Then use File » Save to HTML/Web Formats » Save to HTML, or File »
Save to HTML/Web Formats » Save to IDC/HTX, and skip the rest of these steps.)

. Choose HTML or HTX in the Save As Type drop-down list.

3. Specify a name for the new file in the Save As dialog box that appears and then

click on OK.

4. If you chose HTX, Access will show you the Publish Defaults dialog box next. Use
HTML Template to select a template file that may have specifications for a logo or
certain types of headers and footers. The DataSource Name box is where you enter
an ODBC connection used to get data for dynamic Web pages. User to Connect As:
is for the ODBC user name and Password for User is for the password needed to log
on to the ODBC data source. Click on OK to go ahead with the export after you
make your entries.

N

If you want to change the publishing defaults before you do an export, use File »
Save to HTML/Web Formats » Publish Defaults, fill in the Publish Defaults dialog box,
and click on OK.

The next section, “Using the Publish to the Web Wizard,” explains more about
HTML templates and the other settings in the Publish Defaults dialog box. Figure 7.20
shows the file Cajun Products.htm created by exporting the table Cajun Products to an
HTML file. Notice that the information looks quite different from the HTML file the
data was originally imported from as shown in Figure 7.18. The files vary because dif-
ferent HTML defaults were used to create them.
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Using the Publish to the Web Wizard

Access 97 can give you plenty of help preparing a document for publication on the Inter-
net. The Publish to the Web Wizard guides you through the process of publishing
Access objects including tables, forms, reports, or queries to the Web. The data that is pub-
lished can be static (a “snapshot” of an Access object as it is at the time of publication) or
dynamic. When a dynamic link to an Access object is published, a person browsing the
data always sees the most up-to-date version of information.

To start the Publish to the Web Wizard, follow these steps:

1. Choose File » Save to HTML/Web Formats » Publish to the Web.

2. Check I want to use a Web publication profile if you've already used the Wizard and
saved a Web publication profile that you'd like to use. Otherwise, this option will
be dimmed.
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FIGURE 7.20 ™
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3. Click on Next to continue. The next dialog box resembles the Access Database win-
dow (see Figure 7.21) with tabs for Tables, Queries, Forms, Reports, and All Objects.
You can select one or more objects to publish.

4. Select an object by clicking on its checkbox. Use the Select All or Deselect All buttons
to check or uncheck all the objects on a tabbed page at once. Click on Next to con-
tinue. (As with the other Wizards, you can click on TFinish at this point to bypass
changing the publication defaults.)

I NOTE = ———
El_rl] The next step lets you choose an HTML template, a file with specifications for
— Web page elements like background, logos, navigation buttons, and text styles.

5. Leave this option blank or use the Browse button to select an existing .htm file or
.html file. Use the checkbox under the template name box if you want to use dif-
ferent templates for some of the objects you are publishing. Click on Next to go on.
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6. Click on Dynamic (HT) publications (in the next dialog box) if you want to create
a publication with dynamic links to your Access objects. Otherwise leave Static
selected. Mark the checkbox under Dynamic if you want to publish some static
objects and some with dynamic links. After you make your choice, click on Next.
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NOTE
g The Publish to the Web Wizard can publish files to a folder on your computer (or
network), or it can use the WebPost feature to publish pages directly to an Inter-
net Server.

7. Do one of the following:

e To publish locally, enter a folder or use the Browse button to fill in a location
under I want to put nty Web publication in this folder:.

e To publish directly to the Web (assuming you have an Internet connection
established), select Yes, I want to run the WebPost Wizard to set up a new Web-
Post specification, or select Yes, I also want to use an existing WebPost server
whose ‘Friendly Name’ has been set up previously. Select a location from the
Friendly Name drop-down list before you click on Next.
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8. (Optional) To use the Wizard to create a home page with links to all the objects yoy
are publishing, select Yes, I want to create a home page and enter a file name for the
home page. Then click on Next to go to the last step of the Wizard.

9. (Optional) Check Yes, I want to save wizard answers and enter a name to save your
work as a Web publication profile. (Remember in step 2, you have the option to use
a profile saved at an earlier time instead of filling in each Wizard step from scratch.)
Click on Finish to publish the objects you selected in step 3.

You can use the Microsoft Internet Explorer to view your new publication as it will
appear on the Internet. Just open the Windows 95 Explorer, find the new .htm file, and
double-click it. Windows 95 will launch the Internet Explorer with the new .htm file open,

Using OfficeLinks

For some real razzle-dazzle, you can use OfficeLinks features to export Access data to a
file and immediately start the appropriate Microsoft Office program. To use these fea-
tures, choose the object or selection you want to export. Click on the drop-down arrow
on the OfficeLinks toolbar button and then choose an option, or choose options from
the Tools » OfficeLinks menu. Here’s an example of the OfficeLinks toolbar button
after we clicked on its drop-down arrow:

Table 7.2 briefly describes the OfficeLinks drop-down toolbar button options and
the Tools » OfficeLinks menu options you can use. The OfficeLinks toolbar button is
available on the database window’s toolbar and the print preview toolbar.

I TABLE 7.2: OFFICELINKS DROP-DOWN TOOLBAR BUTTON OPTIONS

OPTION NAME PROGRAM NAME
Merge It with MS Word Microsoft Word for Windows
(mail merge feature)
Publish it With MS Word Microsoft Word for Windows

Analyze It With MS Excel Microsoft Excel
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To use OfficeLinks:

1. Go to the Access database window, click on the tab for the type of data you want
to export (Tables, Queries, Forms, or Reports), and then select the object you
want to export. Or open the table or run the query and select the rows you want
to export. Or open an object in print preview (choose File » Print Preview).

2. Choose Tools » OfficeLinks and then choose the appropriate option. (The Merge
It option is available for tables and queries only.)

3. Answer any prompts that appear.

Access will create the output file in the current folder and then open the file in the
program you chose in step 2. When you're ready to return to Access, close the program
by clicking on its Close button or choosing File » Exit.

MNOoTE — - S|
What you see in Access isn’t necessarily what you get in the program opened by
OfficeLinks. Examples: Data on Access forms and reports that you export to Excel
will appear in rows and columns. Data on forms that you export to Word is

stored in Word tables. And graphics and OLE objects will be blank because they

can’t be exported.

Creating a Database

Mailing an Access Object

You can use the Send feature to export Access objects to HTML (.htm, .html), HTX
(.htx), Microsoft Excel (*.xls), rich text format (*.rtf), and MS-DOS text (.txt) format.
Rather than creating an ordinary file (as the Export and OfficeLinks features do), Send
embeds the data as an icon in an electronic mail (e-mail) message and then sends the
message to your recipient list. To use Send:

1. Click on the tab in the Access database window for the type of object you want to
send (Tables, Queries, Forms, Reports, or Modules and then click on the object you
want to send.

2. Choose File » Send.

3. Select the export format from the Send dialog box that you want to use. Click on OK.

4. For HTML and HTX files, you will see a Publish Defaults dialog box. Use HTML
Template to select a template file that may have specifications for a logo or certain
types of headers and footers. The DataSource Name box is where you enter an
ODBC connection used to get data for dynamic Web pages. User to Connect As: is
for the ODBC user name and Password for User is for the password needed to log
on to the ODBC data source. Fill in the required information (if you need to change
the defaults) and click on OK. If a Choose Profile dialog box appears, choose a pro-
file and then click on OK. Your electronic mail program will take over.
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5. Respond to any prompts that appear, sign on (if necessary), and send the message
as usual.

NOTE
_% As for the OfficeLinks features, what you see in Access isn’t necessarily what you

get in your e-mail messages. Examples: Data on Access forms and reports that
you mail in Excel format will appear in rows and columns on a spreadsheet. Data
on forms that you mail in Rich Text Format is stored in tables. And graphics and
OLE objects will be blank.

N E

In most electronic mail programs, you can preview and even change the object before
sending it to the recipient. When the e-mail message appears, just double-click on the
object’s icon within the message. For example, if you're sending a Customers table in
Microsoft Excel format, double-click on the Customers.xls icon in your message to
open the object in Excel. After viewing the object, close the program (File » Exit), save
your changes if necessary, and send the e-mail message normally.

To retrieve the file, the recipient must sign on to e-mail, open your mail message as
usual, and double-click on the object’s icon in the message file. This action will start the
program that’s associated with the file you sent and let the recipient read the file. For
example, if the recipient double-clicks on an .xls file icon in the message, the file will
open in Microsoft Excel.

The File » Send command is available only if your mail program is installed prop-
erly and it supports Messaging Application Programming Interface (MAPI). To use
Access with an e-mail program that supports the Vendor Independent Mail (VIM)
protocol, you must install and set up the dynamic-link library (named Mapivim.d11),
which converts MAPI mail messages to the VIM protocol. You'll find information
about installing and setting up VIM support in the Microsoft Office Resource Kit,
available from Microsoft.

Importing and Exporting from Nonsupported Programs

If you want to import data from, or export data to, a program other than one that Access
supports directly, you can use some intermediate format that Access does support.
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For instance, most programs let you import and export data in delimited text for-
mat. Thus you could export data to a delimited text file from one program and then
import that delimited text file into the other program.

Many programs also can use files that are in another program’s format, either directly or
after converting the file with some help from you. For example, Quattro Pro can open
Lotus 1-2-3 .wk3 format files directly, and Access can create such files. Therefore, to export
Access data to Quattro Pro, use the Export feature to export the Access table to Lotus 1-2-3
.wk3 format; then start Quattro Pro and open the exported .wk3 file normally. Similarly,
both Microsoft Works and Microsoft Access can open and create dBASE files. So to export
Access data to a Works database, use the Export feature in Access to export the Access table
to dBASE format; then start Microsoft Works and open the existing dBASE file. No sweat!

For information on importing or exporting files in some other program, check that
program’s documentation. Be aware that delimited files otten go by the name ASCIT
delimited file, ASCII text file, or simply DOS text file.

Where fo 6o from Here

If you took the hands-on lessons in Chapter 3, you already know the basic steps for adding,
editing, and viewing data. In this case you can skip Chapter 8 and move on to Chapter 9,
where you'll learn how to sort, search, and print your data. But if you skipped those lessons,
or you just want to know some extra tricks and tips for entering data more efficiently, con-
tinue with Chapter 8 now.
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What’s New in the ¢ Export Access objects (tables, forms,

Access Zoo? queries, and reports) to HTML or
IDC/HTX files

The biggest additions to the data-sharing

features of Access 97 are Web related. You * Use the Publish to the Web Wizard to

can now: publish static or dynamically linked

1 | data directly to the Internet
e Import data in HTML and HTX files
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