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Adding, Editing, and Viewing Dat3

n Chapters 6 and 7 you learned how

to open a database, create and open

tables, and import or link to tables
from other sources. In this chapter you'll learn how to add, change, and delete data in
tables. We’ll also introduce forms in this chapter, but you'll learn much more about
forms in Chapters 11 and 13.

Dafasheet View and Form View

You can work with Access data using either datasheet view or form view:

Datasheet View (Also called table view.) You can see many records on the screen

in a tabular format.
Form View You can see one record at a time, in a format that resembles paper

fill-in-the-blank forms.

Figure 8.1 shows table data in datasheet view and the same data in form view.
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Datishest View

Creating an Instant Form

Normally you'll be taken into datasheet view when you open a table. If you want to use
form view, you must create a form or use an existing form. (Of course, you need to cre-
ate the form only once, as long as you save it after you create it.) Chapters 11 and 13
cover forms in detail, but if you're itching to set up a quick-and-easy form right now,
follow these steps:

1. Click on the Tables or Queries tab in the database window and then click on the
name of an existing table or query.
7 2. Click on the drop-down arrow next on the New Object toolbar button (shown at
@ f left, and the second-to-last toolbar button). Then choose AutoForm from the list
that appears. Or choose Insert » AutoForm from the database menu.

Access builds a simple form and displays it on your screen.
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If you don’t mind doing a few extra mouse-clicks, you can get a nicer looking
instant form than the simple AutoForm feature produces. In step 2 on the previous
page, choose Form (instead of AutoForm) from the drop-down list on the New
Object toolbar button. Then double-click on AutoForm: Columnar in the New
Form dialog box that appears.

Closing a Form

To close the form when you're done using it:

1. Make sure the form is in the active window. (If in doubt, click on the form’s title bar.)

2. Click on the form’s Close button or choose File » Close from the menu bar or press
Ctrl+W. If the form is new or you made changes to an existing form, you'll be asked
whether to save the form.

3. Click on Yes to save the form. If you're prompted for a form name, type a form
name (or accept the suggested name) and click on OK. If you don’t want to save
changes to the form, click on No.

You can click on the Forms object tab in the database window to view the names of
all saved forms.
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Viewing Data in Datasheet or Form View

You can view table data anytime using either the datasheet view or the form you created:

Datasheet View To view data in datasheet view, click on the Tables or Queries
tab on the database window. Then double-click on the table or query whose data
you want to view. Or click on the table or query name and then click on the Open
button on the database window. Or right-click on the table or query name and
choose Open.

Form View To view data in form view, click on the Forms tab on the database
window and then double-click on the form you want to open. Or click on the
form name and then click on the Open button on the database window. Or right-
click on the form name and choose Open.

NOTE
g You can open a table or a query in datasheet view, and you can create a form for
a table or a query and then open that form. Any time you open a form, you're
also opening the underlying table or query automatically.
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Some types of queries change data or create tables rather than display data, so
be careful about opening just any old query. You'll learn more about queries in
Chapter 10.

Switching between Datasheet View and Form View

When you open a form, you can easily switch between views. To do so, click on the drop-
down arrow next to the View toolbar button (the first toolbar button); then choose an
option from the menu (Design View, Form View, or Datasheet View). Or choose appro-
priate options from the View menu (Form Design, Form, or Datasheet).

The form view options won’t appear if you open the table in datasheet view. So when
you want maximum flexibility in switching between views, open the form rather than
the table.

The Design View option is always available. How it acts depends on how you got to
the current view:

* If you opened the current table in datasheet view, the Design View options will
take you to the underlying table design (the table’s structure).

e If you opened a form, the Design View option will take you to the form’s under-
lying design (see Chapters 11 and 13).

Table 8.1 shows a summary of the Table View or Form View toolbar buttons you’ll
see from various views.

A P_
To quickly switch to the view shown on the Form View or Table View toolbar button,
click on that button without clicking on the button’s drop-down arrow first.

l TABLE 8.1: TOOLBAR BUTTONS FOR SWITCHING AMONG VIEWS

THE VIEW BUTTON
IF YOU'RE IN THIS VIEW LOOKS LIKE THIS...
Form View or Datasheet View M
Pl O
Form Design View @
v

Table Design View

= A
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Why Design View?

If you get confused, just remember that design view is for designing (creating and
changing) objects—not for managing data. You cannot see or change data from design
view. If you're in design view and want to return to your data, switch to datasheet view
ot form view.

Here’s another way to look at it: If you open a table in datasheet view and want to
switch to form view, you can’t use the toolbar button or View menus to do so because
Access won't know which form you want to open. So you'll need to open the appropri-
ate form if you want all the flexibility that Access offers.

If You Get Lost...

If you get lost, you can close all the objects until you see only the database window, or you
can quickly bring the database window to the forefront by pressing F11. From there
you can click on the tab for any type of object, click on the name of any object, and
then click on the New, Open (or Preview or Run), or Design buttons, as explained under
“Working in the Database Window” in Chapter 1. (Believe it or not, this procedure
becomes second nature after you’ve done it a few times.)

Cusfomizing the Dafasheet View

Customizing datasheet view can be a quick and easy way to display and print an attrac-
tive list of data in a table. Figure 8.2 shows the original datasheet for a Products table,
along with a customized version of that same datasheet. You can use a special Formatting
(Datasheet) toolbar, menu commands, and right-clicking to change the appearance of
datasheet view in a flash. The next few sections explain how.
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7y To print a tabular report that uses the same formatting shown in datasheet view,

customize datasheet view, and select records if you wish (as explained in this chap-
ter). Then choose File » Print (Ctrl+P), fill in the Print dialog box, and click on OK.
(To preview the records first, choose Print Preview instead of File » Print.)

Using the Formatting Toolbar

The Formatting (Datasheet) toolbar, shown in Figure 8.3, enables you to change the
appearance of text on the datasheet, to choose a color for the datasheet’s background,
foreground, and grid, and to control the appearance of gridlines.
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To use this toolbar, you first must display it on the screen (of course). Here’s how:

¢ If you are in datasheet view: Right-click on the current toolbar and then select
(check) Formatting (Datasheet).

e If no toolbar is visible, choose View » Toolbars. In the Toolbars dialog box, scroll
down to and select (check) Formatting (Datasheet), and then click on Close.

N E
When you want to hide the Formatting (Datasheet) toolbar again, repeat one of
the steps above, except deselect (clear) the Formatting (Datasheet) option.

Once the Formatting toolbar is visible, you can use it in many ways:

e To jump to a particular column in the currently selected record, choose a column
(field) name from the Go To Field drop-down list.

¢ To change the font for all text in the datasheet view, choose a font name from
the Font drop-down list.

* To change the font size for all text in the datasheet view, choose a font size
from the Font Size drop-down list.

¢ To boldface all text in the datasheet view, click on the Bold button. To turn off
boldface, click on the Bold button again. Use this same technique with the Italic
and Underline buttons to turn italics and underline on or off.

* To change the datasheet’s background color, click on the drop-down arrow
next to the Fill/Back Color button and then click on the color you want. Use this
same technique with the Font/Fore Color and Line/Border Color buttons, respec-
tively, to choose foreground (text) and gridline colors.

¢ To change the appearance of gridlines (or to hide them), click on the drop-
down arrow next to the Gridlines button and then click on the picture that shows
the type of gridlines you want. Use the same technique with the Special Effect
button to add a flat, raised, or sunken effect to the gridlines.

NOTE
 When you choose a sunken or raised effect for gridlines, Access always places hor-
izontal and vertical lines on the grid. When you choose a flat effect for gridlines,
Access can apply horizontal gridlines only, vertical gridlines only, both types of

gridlines, or no gridlines.
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Changing the Datasheet Appearances
in One Fell Swoop

Instead of using the Formatting (Datasheet) toolbar to tweak appearances one at a time,
you can use the Format » Cells and Format » Font commands on the menu bar to set
several appearances at once.

* To change the appearance of the gridlines or choose a background color,
choose Format » Cells.

¢ To change the font name, font style, size, color, and other font effects, choose
Format » Font.

* To change the default appearance of datasheets for all databases that you open,
choose Tools » Options and then click on the Datasheet tab. See Chapter 15 for
more about personalizing Access.

When the Cells Effects or Font dialog box appears, choose the settings you want. The
sample area in the dialog box will reflect your current selections. When you're done,
click on OK to accept the changes; or click on Cancel (or press Esc) to discard them.

Selecting and Arranging the Datasheet
Rows and Columns

While in datasheet view you can rearrange the datasheet columns, adjust the height of
rows, change the column widths, and even hide columns.

Selecting Datasheet Columns

If you want to resize, move, or hide more than one adjacent column at a time, you first
must select the columns you want to work with. Here are some techniques to use:

¢ To select one column, click on the field selector at the top of the column.
¢ To select multiple columns, drag the mouse pointer through several field selec-
tors. Or click on the field selector for the first column you want to select. Then use
the horizontal scroll bar if you need to and Shift-click on the field selector for the
last column you want to select.
¢ To deselect selected columns, click in the data area of any column.
N E S #‘
1 When you move the mouse pointer to a field selector, the pointer changes to a
’ thick, black | shape.
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Here’s an example of a datasheet with one column selected:
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Arranging Datasheet Rows and Columns

You can use the following tricks to adjust the height and width of rows and columns,
to move columns, and to hide and redisplay columns:

f‘l ¢ To change the height of all the rows, drag the bottom edge of a row selector

' + (shown at left) up or down. Or choose Format » Row Height or right-click on a row

_J selector and choose Row Height; then enter a height (in points) or select Standard
Height to use Access’s standard row height and click on OK.

g ¢ To change one column’s width, drag the vertical bar next to that column’s field

‘ selector (shown at left) to the left or right. Or to quickly get the best possible fit
for the column, double-click on that vertical bar.

¢ To change the width of one or several adjacent columns, select the column(s)
you want to resize. Next, choose Format » Column Width; or right-click on any
data within the selection and choose Column Width. In the Column Width dia-
log box, enter a width (in number of characters) or select Standard Width and
click on OK, or click on Best Fit. Alternatively, just drag the vertical bar next to a
selected column’s field selector to the left or right.
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NOTE
When right-clicking on records after selecting multiple columns, be sure to right-
click on data within the selection. Do not right-click on a field selector or you'll
turn off the selection in adjacent columns.

¢ To move column(s), select the column(s) you want to move. Then click on one
of the highlighted field selectors and drag the selection to the left or right. (The
mouse pointer changes to the shape shown at left as you drag.)

e To hide columns, select the column(s) you want to hide. Next choose Format »
Hide Columns; or right-click on any data within the selection and choose Hide
Columns.
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¢ To hide or redisplay any columns you wish, choose Format » Unhide Columns,
Select (check) the column names you want to show, deselect (clear) the ones yoy
want to hide, and then click on Close.

Freezing and Unfreezing Columns

When the table is wider than the screen, scrolling to the rightmost columns will force
the leftmost columns off the edge of the window. Instead of scrolling back-and-forth to
figure out which record the cursor is in at the moment, you can freeze one or more col-
umns so they never scroll out of view.

In Figure 8.4 we froze the Company Name, Contact First Name, and Contact Last Name
columns in the Customers table. Notice the heavy vertical line between the last frozen field
(ContactLastName) and the first unfrozen one (PhoneNumber). This makes it easy to scroll
to the Phone Number field without losing sight of the customers’ names.

To freeze one or more columns:

1. Select the column or columns you want to freeze.
2. Choose Format » Freeze Columns, or right-click on any data within the selection,
and then choose Freeze Columns from the shortcut menu.

The selected columns move to the leftmost positions in the datasheet automatically
and remain visible as you scroll the datasheet columns to the right. A heavy vertical
line separates the frozen columns from the unfrozen ones.

To unfreeze the columns, choose Format » Unfreeze All Columns.

NOTE —
é If the horizontal scroll bar disappears after you freeze columns, you won’t be able to
view the unfrozen columns or scroll to them. To solve this problem, either unfreeze
all the columns or resize the frozen columns smaller. Then resize the datasheet win-
dow larger (if necessary) until the horizontal scroll bar reappears.

FIGURE 8.4 =
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Saving or Canceling Your Datasheet Changes

If you've customized the datasheet view, you'll be asked if you want to save the layout
changes when you close the table, To keep the customization settings for future sessions,
click on Yes. To discard the settings, click on No.

You also can save your changes to the datasheet layout at any time. To do so, choose
File » Save or press Ctrl+S or click on the Save button on the Table Datasheet toolbar.
Now we'll switch gears and show you how to navigate forms and datasheets and

how to enter data into your tables.
You can find more details about customizing the appearance of datasheet view by
searching for topics under Datasheet View in the Access Help Index.

Navigating Forms and Datasheels

You can use any of these techniques to navigate (move around in) a table. (Of course,
you won'’t be able to scroll from record to record until you put some data in the table.)

¢ To move through records, use the navigation buttons at the bottom of the form or
datasheet window. Or choose Edit » Go To and then choose the appropriate com-
mand from the pull-down menu. The Go To options are First, Last, Next, Previous,
and New Record.

e To scroll through records in datasheet view, use the vertical scroll bar at the
right edge of the window. As you drag the scroll box, the current record number
and total records will appear next to the scroll bar, like this:

o]

BE Oideis : Table
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= 2| ABC Corparation Ajar Dors
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¢ To scroll through columns in datasheet view, use the horizontal scroll bar at
the bottom edge of the window.

* To scroll more fields into view in form view, use the vertical scroll bar at the right
edge of the window or the horizontal scroll bar at the bottom edge of the window.

Creating a Database
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As usual, scroll bars appear only if the current window is too small to hold all the
information at once. (If the window is too small, however, scroll bars won't appear.
Just resize the window larger as needed.)

e To move from field to field and from record to record, use the keys listed in

Table 8.2.

¢ To go to a particular record based on the contents of a field, you can use Find.
(For example, you can look up Doe or Granolabar in the LastName field of the Cus-
tomers table). See Chapter 9 for more details.

TABLE 8.2: SUMMARY OF KEYBOARD TECHNIQUES FOR NAVIGATING A TABLE

KEY(S) DESCRIPTION
F2 Switches between navigation and editing modes.
F5 Selects the record number box (see Figure 8.5). Type a new
record number and press Enter to go to that record.
T Moves to next or previous record (datasheet view), or next or

Ctrl+T, Ctrl+d
PR—
Ctri+«,
Ctrl+—

Tab, Shift+Tab
Enter

Ctrl+Enter

PgUp, PgDn

previous field (form view).

Moves to first or last record in a table (highlight remains in cur-
rent column or field).

Moves to next or previous character (editing mode), next or
previous field (navigation mode).

Moves one word left or right in editing mode.

Moves to next or previous field.

In datasheet view, moves to next field. In form view, ends a
short line or paragraph or inserts a blank line in a memo field or
text field that has Enter Key Behavior property set to New Line
In Field.

Ends a short line or paragraph or inserts a blank line, in a memo field
or lengthy text field that has Enter Key Behavior set to Default.

In datasheet view, scrolls up or down one window full. In form
view, scrolls to previous or next record. On a multipage form,
scrolls to the previous or next page, or to the same page on the
previous or next record.

= Continuegl.
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TABLE 8.2: SUMMARY OF KEYBOARD TECHNIQUES FOR NAVIGATING A TABLE (CONTINUED)

KEY(S) DESCRIPTION
Ctrl+PgUp, In datasheet view, scrolls right or left one window full. In form
Ctrl+PgDn view, scrolls to previous or next record.
Home, End Moves to first or last field of record (navigation mode), or to
start or end of text line (editing mode).
Ctrl+Home, Moves to first field of first record or last field of last record (naviga-
Ctrl+End tion mode), or to start or end of text or memo field (editing mode).

For quick reminders about how to scroll through records, search Help for Shortcut
Keys, Datasheet And Form View Keys or Datasheet View, Navigating, or Form View,
Navigating.

Rdding Dara fo a Table

Navigation
buttons on the
havigation bar.

Adding new data to a table is just a matter of going to a new, blank record and typing the
contents of each field. After filling one field, you can press Tab or Enter to move to the next
field. Or click on the next field you want to add data to—just as though you're filling in a
Windows dialog box. Here are the steps:

1. Open the table in datasheet view or open a form in form view. Then, if the cursor is not
already in a blank record, use one of these techniques to go to a new, blank record:

¢ Click on the New Record toolbar button (shown at left).

e Choose Edit » Go To » New Record from the menu bar.

¢ Click on the New Record button on the navigation bar near the bottom of the
window (see Figure 8.5).

Previous  Next Last New
record reco<ﬁ 7co‘rd/record
| Record: LLJ_II 1 b | fvE] of 18 A | |
| [ e
First Record Scroll left/right

record number box
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2. Type whatever you want to put into the current field (the field where the cursor is),

Then press Tab or Enter to move to the next field or click on the next field yoy
want to fill.

3. Repeat step 2 until you've finished entering data in the record.

Tips for Adding Records

Here are some pointers for adding records to a table:

(AutoNumber) If the table contains an AutoNumber field, that field will display
just the word (AutoNumber) or a portion of that word. Don't worry about it, and
don’t try to change it. Access will fill that field automatically when you enter data
into some other field in the record.

Empty To leave a field empty, don’t type anything into that field. Just press Tab
to move to the next field or click on the field you want to fill next. (You cannot
move to another record if you leave a Required field blank.)

Date/Time You can press Ctrl+; to insert the current date. Or press Ctrl+Shift+;
(that is, Ctrl+:) to insert the current time.

Ditto If you want to repeat the field entry from the previous record into a new
record, press the Ditto key (Ctrl+” or Ctrl+’).

Hyperlink Fields Use the techniques for filling in hyperlinks discussed later in
this chapter.

OLE/Memo Fields Use the special techniques for filling in OLE (pronounced
“olay”) object and memo fields, discussed later in this chapter.

After you fill in the last field of a record, you can press Tab or Enter to go to the next

blank record. If you don’t want to add another record, close the table or form (or go to
a previous record). Don’t worry about accidentally creating a blank record.

EOTE
:

As you type into a text or memo field, Access will correct certain mistyped words,
such as hte (changed to the), THey (changed to They), and sunday (changed to
Sunday) as soon as you move the cursor out of the word. This magic is the work of
AutoCorrect, which you'll learn about in Chapter 9. There you’ll also learn how to
check spelling in text and memo fields.

Saving a Record

Access saves the entire record to disk when you move to another record—you need not
do anything special to save each record. However, if a record can’t be saved because it
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fails validity checks, you'll see an error message describing the problem. See “Trouble-
shooting Data Entry and Editing Problems” later in this chapter for help.

For quick reminders on how to add records to a table, go to the Access Help Con-
tents, open the Working With Data book, and peruse any of the related subtopics and
books that interest you.

The Tiny Icons

While you're adding and editing table data, you'll see these icons at the left side of the
datasheet or form window.

’ Current record.
|

¥ New, empty record.

ﬁ Record is being edited; current changes not saved yet.

How Do I Insert a Record?

You don’t. This might seem odd, especiaily if you're a spreadsheet user. However, there’s
no reason to insert a new record between existing records in Access because you can sort
the records in any order, at any time. So just continue to add new records to the bottom
of the table and then use techniques described in Chapter 9 to alphabetize or sort the
records later.

Changing Dafa in a Table

Changing the data in a table is easy. Just move the cursor to the data you want to change
and then use standard Windows text-editing techniques to make your changes. It’s
important, however, to check the screen to see whether the field contents are selected
before you make a change. Figure 8.6 shows the difference.

e If the current field contents are selected, anything you type will instantly replace
the current field contents. To deselect before typing, press F2 or click where you
want to make a change within the field.

e If the field contents are not selected, anything you type will be inserted at the cur-
sor position. You can use the «— and — keys to position the cursor within the field.
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FIGURE 8.6 o
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If you accidentally replace all the contents of a field when you meant to insert text,
you can use any undo technique to immediately fix the error. That is, press Esc or
click on the Undo toolbar button or choose Edit » Undo or press Ctrl+Z.

Navigation Mode versus Editing Mode

Whether a field’s contents are selected when you first get to that field depends on
whether you're using Navigation mode (keyboard) or Editing mode (mouse) to move from
field to field:

e If you enter a field using the keyboard (for example, by pressing —, «, Tab, or
Shift+Tab), that field’s contents are selected instantly. This mode is called Naviga-
tion mode because the arrow keys navigate you from one field to the next.

e If you move the cursor to a field by clicking, the cursor moves to the exact mouse
pointer position and text is not selected. This mode is called Editing mode because
the arrow keys position the cursor for editing the field's contents.

To switch quickly between Navigation and Editing modes, press the F2 key any time.

.-rf-!
Keys for Editing Table Data
Table 8.3 summarizes keys you can use to edit data in datasheet view and form view.
Remember that you also can use the mouse to select text within a field: Simply drag the
mouse pointer through text to select that text within a field.
If you ever need reminders on editing data, look up the topic Fields, Editing Data
Within, and subtopics under Data Entry in the Access Help Index.
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KEY

DESCRIPTION

l TABLE 8.3: KEYS FOR EDITING DATA IN A TABLE

F2

Backspace
Delete
Insert

Ctrl+" or Ctrl+”
(same as Ctrl+Shift+")

Escape (Esc)

Ctrl++ (plus sign)
Ctrl+-

Ctrl+;

Ctrl+:

Shift+Enter

Ctrl+Alt+Spacebar

Switches between navigation mode (where pressing
arrow keys selects a field) and editing mode (where
pressing arrow keys moves the cursor within a field).

Deletes selection or deletes character to left of cursor.
Deletes selection or deletes character to right of cursor.
Toggles between insert and overwrite modes.

Copies data from field above.

Undoes changes to field (first press) then remaining
changes to record (second press).

Adds new record.
Deletes current record.
Inserts the current date.
Inserts the current time.

Saves the current record, as long as data in that record
passes all validity checks.

Inserts field’s default value (if any).

Selecting Records and Fields

The row selector at the left of each record lets you select an entire record with a single

mouse-click:

3 Soccer ball 295

4 Volleyball §3.25 |
5 Golf balls $6.75 } ;]

4
3
8
(=]
©
:
o



274 I CHAPTER 8 » ADDING, EDITING, AND VIEWING DATA

In datasheet view, you can select several adjoining records (see below) by dragging the
mouse pointer through their record selectors. Or you can click on the record selector of
one record and then Shift-click on the selector of another record. Or you can select all the
records in the table by clicking on the table selector in the upper-left corner of the table
(refer to Figure 8.1). |

Bl=1 E3

| Recora ael o[ 2 ivi[se] of 10

Table 8.4 summarizes ways to select and deselect data in a table. The sections that
follow explain how to delete, copy, and move the selected data.

I TABLE 8.4: TECHNIQUES FOR SELECTING DATA IN A TABLE

TO SELECT... DO THIS...
Part of field contents Drag mouse pointer through a portion of the field, or use
Shift+—, Shift+«, Shift+Home, or Shift+End.
Word to left or right Press Shift+Ctrl+— or Shift+Ctrl+<.
Full field contents Move to the field with an arrow key or press F2 to switch

from cursor to selection or click on the field name (the label
portion, not the field contents) in form view.

Entire record Click on the record indicator at the far left edge of the
record or form, or choose Edit » Select Record or press
Shift+Spacebar (navigation mode).

Multiple records In datasheet view, drag the mouse pointer through
appropriate record selectors, extend the selection by -
Shift-clicking on the last record you want to select, hold j
down the Shift key while clicking on adjacent record
selectors, or extend the selection using Shift+l or Shift+T

Entire Column In datasheet view, click on field selector at top of column
or press Ctrl+Spacebar in navigation mode.

C ontlnued_l }




DELETING DATA | 275

TABLE 8.4: TECHNIQUES FOR SELECTING DATA IN A TABLE (CONTINUED)

TO SELECT... DO THIS...

Multiple columns Drag mouse pointer through field selectors, Shift-click on
multiple field selectors, or press Ctrl+Spacebar to select col-
umn; then Shift+— or Shift+« to extend selection.

Entire table Choose Edit » Select All Records or press Ctrl+A or

(in datasheet view) Ctrl+Shift+Spacebar or click on table selector (see Figure 8.1).
Without using Hold down the Shift key while moving the cursor with the
the mouse arrow keys. Or press F8 to switch to “extend” mode (EXT

appears in status bar) and then use the cursor-positioning
keys or mouse to extend the selection area. Or press F8
repeatedly to select the word, field, record, and then entire
table. To turn off extended selection, press Esc (EXT disap-
pears from status bar).

Cancel selection Press the F2 key or click on any data.

Delefing Dafa

Deleting data is simply a matter of selecting the data you want to get rid of and then
pressing the Delete key.

Deleting Data within a Field

Here are two ways to delete data within a field:

e Place the cursor where you want to start deleting data and then press the Delete or
Backspace key as needed to delete one character at a time.

* Select the data within the field and then press Delete or Backspace to delete all the
selected text at once.

If you change your mind and want to bring back the deletion, press Esc or click on
the Undo toolbar button. Or choose Edit » Undo Delete from the menu bar or press
Ctrl+Z.

Creatinag a Database
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Deleting Records

To delete entire records:

1. Select the records you want to delete using the record selector at the left of each
record.

2. Press Delete (or choose Edit » Delete). You'll be asked if you're sure about deleting
the record(s).

A -2 d R R ol _______ _____ ]
When you delete one or more records, there’s no way to undo that deletion unless
you re-enter those records from scratch. So think carefully before you proceed.

3. Click on Yes to delete the selected records or click on No to avoid deleting the

records.
If you want to delete the current record only, here’s a shortcut. Make sure the cursor
| PKI is in the record you want to delete and then click on the Delete Record toolbar button

(shown at left) or choose Edit » Delete Record. Answer Yes or No as appropriate when
asked to confirm the deletion.

Other Ways to Delete Records

There are still other ways to delete records. For example, you can delete all the records
that meet some criterion, such as all types of Billiard Balls in the Products table. How
can you do this? One way is to create a filter (Chapter 9) that isolates those records,
select all those records (choose Edit » Select All Records or press Ctrl+A), and then press
Delete. Another way is to construct a Delete query (see Chapter 10).

Copying and Moving Dafa

You can use all the standard Windows cut-and-paste techniques to move and copy
selected data within a table, as well as between Access and other programs. Here is the
general technique:

1. Select the data you want to move or copy.

e If you want to copy (duplicate) the selected data, click on the Copy toolbar
button or choose Edit » Copy or press Ctrl+C.

¢ If you want to move the selected data, click on the Cut toolbar button or
choose Edit » Cut or press Ctrl+X.
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2. Move the cursor to where you want to put the data you copied or cut, and then
click on the Paste toolbar button or choose Edit » Paste or press Ctrl+V.

~NO T E
Q To add records to the end of an Access table, choose Edit » Paste Append in step 2.

Access will try to complete your request, though it may need more information,
depending on where you cut or copied from and where you pasted fo. Read any mes-
sages that appear on the screen and respond accordingly.

When Cut-and-Paste Won’t Work

Access might not be able to paste selected data into a table for several reasons:

e Access cannot paste incoming data that is incompatible with the current data
type(s). For example, you can’t paste letters into a Number or Currency field.

¢ Access cannot paste incoming data that duplicates data in a primary key field or
that duplicates data in an indexed field that doesn’t allow duplicate entries.

e If the incoming data is too long for the field, data that doesn’t fit will be truncated
(chopped off). You can increase the amount of data that a field will hold by
changing the field’s Field Size property (see Chapter 6).

» If the incoming data fails a validation check that you’ve defined for the field, you
can'’t paste the faulty data.

If Access can’t complete a paste operation for any of these reasons, it will place prob-
lem data in a table named Paste Errors. You can open the Paste Errors table to view the
data that wasn't pasted and then perhaps paste data from that table into the original
table on a field-by-field basis.

Using Huperlinks in a Table

When you include a Hyperlink field in a table, you can use it to jump to almost any
kind of information from a datasheet or a form. All you have to do is click on the hyper-
link address shown in the field to take off to another program or object. Here are some
examples of the kinds of data a hyperlink address can point to:

* A Web page on the Internet
* An object like a form or a report in an Access database
* A word processing document, a spreadsheet, or a graphic
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For example, we can add a hyperlink field to the Products database in the Order
Entry1 database and use it to link to a page of product information stored locally or on
the Internet. Once a hyperlink address that points to the page is entered, a single click
on it opens the page with Microsoft Internet Explorer. Similarly, you could use a hyper-
link field in the Employees table to jump to a resume or photo for each person.

You can also include hyperlinks on forms and reports without including a hyperlink
field in the underlying table. This method works when you don’t need to store different
hyperlinks for each record in a table (See Chapter 13). In this chapter, though, we’'ll
focus on techniques for using hyperlinks that are stored in table fields.

These are the general steps using hyperlinks in an Access table:

1. Select the table you want to add a hyperlink field to in the Database window and
click on Design.

2. Add a new field to the table and assign it the Hyperlink field type. Repeat this step
for each hyperlink field you want to include in the table. For the example men-
tioned above, you would add a field called Related Product Info to the Products
table. (See Chapter 6 for details on adding fields to a table and making other struc-
ture changes.)

3. Click on the View button on the toolbar to switch to Datasheet view. Select Yes
when asked if you want to save your changes to the table’s structure.

4. Move the cursor to the hyperlink field and click on the Insert Hyperlink button on
the toolbar to enter a hyperlink address in the table. Fill in the Edit Hyperlink dia-
log box as described below and click on OK. Or use one of the other methods
outlined later in this section for entering a hyperlink address into a field.

To use the hyperlink, just click on it. Figure 8.7 shows the Products table with a hyper-
link entered in the Related Product Info for Red Bean Seasoning. The hyperlink points to
the file c:\Program Files\MS Office 97\Access\Samples\cajun.htm. After clicking on the
hyperlink, the Internet Explorer window opened to display cajun.htm as in Figure 8.8.

Entering Hyperlink Addresses

In the last example, we used the Insert Hyperlink button on the toolbar to enter an address
in a hyperlink field. You can also enter the same information in several other ways:

e Use the Insert Hyperlink tool.

e Type in an address yourself.

e Copy and paste an address from a document into the hyperlink field.

e Copy and paste text from an Office document to create a hyperlink to that spot in
the document.

* Drag and drop to create a hyperlink to an Office document, an icon, or a .url file.




USING HYPERLINKS IN A TABLE

In the Products
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record for Red
Bean Seasoning
has a hyperlink
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Related Product
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hyperlink is
clicked, the

file cajun.htm
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The HTML file
cajun.htm was
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link to it in the
Products table.
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All of the above techniques do not work for all situations. For example, you can’t
drag and drop a hyperlink from one Access form to another form or a datasheet. So
you'll have to consider the nature of the hyperlink you are creating before you choose
the best way to enter the linking address.

Using the Insert Hyperlink Tool

The Insert Hyperlink tool opens a dialog box that lets you create hyperlinks to Internet
addresses (.url files), documents on your computer or network, or an Access database,
This dialog box includes an option that lets you jump to a specific spot. For example,
you can move to a bookmark in a Word document, a named range in a spreadsheet, or
an object in an Access database.

To use the Insert Hyperlink tool:

1. Open the datasheet or form with the hyperlink field you want to edit.

2. Click on the hyperlink field if it is empty to activate the Insert Hyperlink button on
the toolbar. If the field already contains a hyperlink address, don't click on. (You'll
end up jumping to the address.) Instead, use the Enter key, Tab, or an arrow key to
select the field.

3. Click on Insert Hyperlink on the toolbar or select Insert » Hyperlink to open the

%‘ Insert Hyperlink dialog box shown in Figure 8.9.

FIGURE 8.9 &

Th'e IHS('?IT Insert Hyperlink HE |
Hyperlink dia- .
/Og box helps Link to file or URL:
you enter | =l _owse.. |
hyper/ink (4“8 Enter or locate the path to the document you want to link to. This

can be an Internet address (URL), a document on your hard drive,

addresses. You or a document on your company's nebwork.

can use a
hyperlink to Path: I<linkto containing document>
jump to an 5
Internet
addr ess, a amed location in file: (Optional)

document on | Browse. .. |

yourcoinp uter If you want to jump to a specific location within the document, such
or networ k, as a bookmark, a named range, a database object, or a slide
or an object number, enter or locate that information above.

in an Access -
database. IV Use relative path for hyperlink
‘ oK I Cancel
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4. Enter a file name or URL in the box under Link fo file or URL:. If you click on Browse,
you can make your selection using a Link to File dialog box that works like other
Open File dialog boxes. If you check the Files of type drop-down menu in this dialog
box, though, you'll find options for All files, Office files, Internet files, Documents,
Workbooks, Presentations, Binders, Databases, Projects, Shortcuts, HTML Files,
Text Files, GIF Files, JPEG Files, VRML Files, and Templates.

5. Click on Browse for Named location in file: (Optional) if you want to jump to a specific
spot in the file you entered in step 4. The appearance of the Select Location dialog
box depends on the type of document you are jumping to with the hyperlink. If you
are linking to an Access database, you will see a window similar to a Database win-
dow. Make your choice and click on OK to return to the Insert Hyperlink dialog box.

6. Click on OK to enter the address in the hyperlink field.
e B
text as in Figure 8.7. Once you use the hyperlink, it changes to purple text. You g
3
2
]
[}
©
@
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' By default, a hyperlink address first appears in a hyperlink field as blue underlined
can change these defaults with the Options dialog box. Choose Tools » Options,
click on the General tab, and change the settings in the Hyperlinks section before
you click on OK.

Typing In Hyperlink Addresses

You don’t have to go through the Insert Hyperlink dialog box to enter an address in a
hyperlink field. If you prefer to type it in yourself, go right ahead. However, You must
follow these rules:

e A hyperlink address can have up to four parts, separated by the pound sign #: an
optional display message that appears in the field instead of the address, the address,
and an optional subaddress (pointing to a specific location). (Some addresses for
Word documents may have a subsubaddress, but this is filled in by Access.)

e If you are entering an address that begins with http, you don’t need to enter the
pound signs. For example, you can enter http://www.microsoft.com instead of # http://
www.microsoft.com##.

¢ You can also leave off the pound signs if you are entering an address without an
optional display message or a subaddress.

¢ To refer to an object in the open database, just enter the name of the object. If
more than one object has that name, say both a table and a form called Products,
precede the name with the object type as in Form Products.




282 I CHAPTER 8 ¢ ADDING, EDITING, AND VIEWING DATA

Table 8.5 shows a few examples of hyperlink addresses. For more examples and
details on entering hyperlink addresses, display the Access Help for Entfering a hyperlink
address. under hyperlinks, addresses, and click on Type the address (show me the syntax).
You can also click on the Office Assistant button on the toolbar and search for Entering
a hyperlink address.

W e = = — =EA= ==
After you enter an address in a hyperlink field, it may look different in datasheet or

form view. Access strips off the pound signs and subaddresses. To see the entire
address, press F2. You can edit the address when it is displayed in this mode. Or
right-click on the address and choose Hyperlink » Edit Hyperlink to change the
link using the Edit Hyperlink dialog box.

I TABLE 8.5: EXAMPLES OF HYPERLINK ADDRESSES

ENTER THIS ADDRESS TO JUMP TO
http://www.microsoft.com http://www.microsoft.com
Form Products The form called Products in the open database.
Resume#c:\My Documents\Resume.doc## The Word file called Resume in c:\My Docu-

ments; Resume will be shown in the hyperlink
field instead of the complete address.

¢:\My Documents\Resume.doc The Word file called Resume in c¢:\My Documents.

Copying and Pasting Hyperlink Addresses

If you have a hyperlink address somewhere in a document or on an Internet Explorer
screen, you can copy and paste it into a hyperlink field:

1. Select the address you want to copy in the document or in the Internet Explorer

window.

. Click on Copy on the toolbar.

3. Move to the hyperlink field you want to paste the address into. (Don't click on the
field if it already contains an address since we want to edit, rather than jump, at
this point.)

4. Click on Paste on the toolbar. If the address you selected was recognized as a
defined hyperlink, you can instead use Paste As Hyperlink on the Edit menu.

N




USING HYPERLINKS IN A TABLE I 283

Creating Hyperlink “Bookmarks”

To create a link to a specific location in a document:

1. Select the place you want to jump to in the document or other Office file.

2. Click on Copy on the toolbar.

3. Move to the hyperlink field you want to paste the address into. (Don't click on the
field if it already contains an address since we want to edit, rather than jump, at
this point.)

4. Choose Edit » Paste As Hyperlink.

Dragging and Dropping Hyperlinks

There’s yet another way to get a hyperlink address into a hyperlink field, dragging and
dropping. This technique does have a limitation, though. You can’t drag and drop from
one Access form to another form or a datasheet. However, you can drag a hyperlink
address in a document (defined or not), a selected portion of a document, an icon on
the Windows desktop, or a .ur] file.

1. Select the place in the document, the hyperlink address, or the icon you want to
jump to.

2. Right-click and drag the selected item to the hyperlink field in form view or
datasheet view.

3. Choose Paste Hyperlink when Access shows you a shortcut menu.

v
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Editing a Hyperlink Address

To change a hyperlink address:

e Move the cursor to the address without clicking on it. Then press F2 and edit.
Press F2 again to select the entire field again.

e Right-click on the address, choose Hyperlink » Edit Hyperlink and change the
address using the Edit Hyperlink dialog box. Click on OK to save your change.

Deleting a Hyperlink Address
To delete an address from a hyperlink field:
* Move the cursor to the address without clicking on it. Then press Del.
Or,

e Right-click on the address and choose Cut.
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Using OLE to Sfore Pictures, Sounds, and Other 0bjects

You can put pictures, sounds, charts, videos, and other objects into a field in a table
using OLE. Of course, you can put such objects into a field only if you've defined that
tield’s data type as OLE Object (see Chapter 6).

NO T E
‘ E Do not confuse an OLE object (such as a chart, sound clip, or drawing) with an Access
database object (such as a table, form, report, or macro). An OLE object is created in a
program outside of Access. Once you've embedded or linked the OLE object into an
Access table field, you usually can update the object without leaving Access.

Suppose you're creating a table to store information about employees and want to
store a résumé in each record. Furthermore, you want to use WordPerfect, Microsoft
Word, or Windows WordPad to create and edit those résumeés. In those instances, you
must define the field that should contain the résumé as the OLE Object data type—not
the Text or Memo data type.

Figure 8.10 shows the structure of a table named Star Search Models (not part of the
sample databases discussed in other chapters) that we’ll refer to as we work through some
examples here. Notice that we've defined several fields as the OLE Object data type.

FIGURE 8.10

A sample table

& Star Search Models : Table

named Star - =T
Fild Namme G2ia Type
Search Models B ModelD AutoNumbei
with several iy L ke Text
fields defined || FirstName Text
leias detine .GS ] Address Teul
the OLE Object | gislen 2 ;exl
|| StateliProvinee ext
data type. | PastalCode Text
|| HomePhone Text
|| Photograph OLE Object
|| Video OLE Object
| Voice OLE Object
|| Resume OLE Object !
|| Talents Memo _v_‘
_ Field Properties —
Geroral | Lookup |
Field Size Long Integsr
New Values Increment
Format
Caption
Indexed ‘Yes [No Duplicates)
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OLE has been around since the release of Windows 3.1. If you're already familiar with
the concepts and jargon that go along with that technology, skip to “An Easy Way to Insert
Obijects” later in this chapter. But if you're new to OLE, you'll get a crash course next.

About OLE Servers and Clients

OLE lets you insert objects from one Windows program into another. The OLE world
has two main types of programs, servers and clients.

Server An OLE server is a program that can “serve up” objects for use in other
programs. Examples of OLE servers include the Windows Paint, Sound Recorder,
and WordPad applets that come with Windows, the Microsoft Graph program
that comes with Access, and the other programs in Microsoft Office (including
Word, Excel, and PowerPoint).

Client An OLE client is a program that can accept the services (that is, the
objects) provided by programs such as those named above.

N E
& Access can act as a client or a server. Thus, you can embed or link an Excel spread-
d sheet into an OLE Object field in Access (here, Access is a client). You also can
embed or link an Access database into an Excel spreadsheet by choosing Insert »
Obiject from the Excel menu bar (here, Access is a server and the database
appears in the spreadsheet as a “package”).

You rarely have to worry about whether a program is a server; all you really care
about is the object. Let’s say you scan a photograph and store that photo in a file named
HelenPhoto.bmp. All you have to do is tell Access to stick HelenPhoto.bmp into any OLE
object field, and you’re done.

About the Source Program

Another buzzword that tags along with OLE is source program. In OLE the source pro-
gram is the one that’s used to create or edit the object. Suppose you use Microsoft Word
to type a résumé and save that résumé¢ as a file named HelenResume.doc. In this case,
HelenResume.doc is the OLE object, which you can put into your Access table, and Word
is the source program for that object.

Similarly, if you have a sound file named HelenVoice.wav on your disk, its source pro-
gram probably is Windows Sound Recorder or some other sound-editing program.
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Linking versus Embedding

An

The two ways to insert an OLE object into an Access table are called embedding and link-
ing. Here’s the difference in a nutshell:

Embed A separate copy of the object is put into your table. The copy in your
table is completely independent of the original object.

Link Access maintains a connection to the original source object, so if one copy
changes, the other copy changes as well.

Imagine that you created a document with Word and saved it with the file name
HelenResume.doc. Then you inserted that document into an Access table. A week later, you
fire up Word and change HelenResume.doc. If you originally embedded HelenResume.doc in
your Access table, the copy in your Access table will not reflect the changes you made via
Word. But if you linked HelenResume. doc into your Access table, the copy in your Access table
will reflect those changes.

Easy Way to Insert Objects

The easiest way to insert (link or embed) an object into your Access table is simply to pull
in a completed copy of the object. A completed copy is an object such as a sound, picture,
or other document that’s already stored on disk. (You'll learn how to create OLE objects
on the fly later in this chapter.) You need to know where that object is stored and what
its name is. For example, a recorded sound might be stored as c: \Mymedia\HelenVoice.wav.

If you know the name and location of the object you want to insert into your file,
here’s how to insert that object:

1. Start Access and open the appropriate database and table. (You can open the table
in either datasheet view or form view; it doesn’t matter which. Just don’t use
design view!)

2. Move to the record and OLE Object field where you want to put the object.

3. Right-click on the field and choose Insert Object, or choose Insert » Object from
the Access menu bar.

:
1
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4. Click on the Create From File option button in the Insert Object dialog box that
appears. The dialog box will look something like this:

Insert Object

5. Type the exact location and name of the object you want to insert (for example,
c:\Mymedia\HelenVoice.wav) into the File text box. If you don’t know the exact loca-
tion and name, you can use the Browse button to look for the object.

6. Do any of the following:

¢ To establish a link between the original object and the copy that’s in your
table, select (check) the Link checkbox.

¢ To embed a copy of the object in your table, leave the Link checkbox cleared.

e To display the object as an icon only, select (check) the Display As Icon
checkbox.

¢ To display the full object (such as a photo), leave the Display As Icon dialog
box cleared.

7. Click on OK.

What the Object Looks Like

What you'll see once the object is in your table depends on several factors:

e In datasheet view, only a brief description of the object is visible, as shown below.

t Major cuteness
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e In form view, the actual object appears if it's a picture, chart, or some other visual
object (see Figure 8.11).

e [f the object is a sound or another nonvisual item, or you selected Display As Icon
when you inserted the object, an icon representing the object appears on the
form, as shown in Figure 8.11.

r-selseseammmee——————————————————————————————————
We used techniques explained in Chapters 11 and 13 to create the form shown in
Figure 8.11.

FIGURE 8.11 "

OLE ObjECtS | . Microsoft Access
from the Star B Gow Tneo
Search Models
table, shown in
form view.
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Activating and Editing OLE Objects

Some objects that you put into a table, such as photos or charts, are meant to be looked at
(though you also might need to edit them sometime). Other objects, such as sounds and




USING OLE TO STORE PICTURES, SOUNDS, AND OTHER OBJECTSJ‘ZBQ

animation clips, are meant to be activated. You can activate or edit an object by double-
clicking on it. What happens after you double-click depends on the type of object:

e If you double-click on a displayed object, you'll open the source program for that
object. The object will appear either in a separate program window or in a frame
that allows in-place editing within the Access window. You can change that
object if you wish. To return to Access, exit the source program by choosing its
File » Exit command or click on its Close button (if a separate window opened) or
click outside the editing frame (if the object appears within the Access window).
Respond to any prompts that appear on the screen.

¢ If you double-click on a sound, video, or similar object, Access will “play” the
object.

Ll o
You can right-click on an object to open an instant menu of commands relevant to

that type of object.

Other Ways to Insert Objects

Access gives you several more ways to insert objects. You can use cut-and-paste tech-
niques to insert all or part of an existing object. Or create an object right from your
Access table. Or use drag-and-drop to embed an object from the server program into
an Access OLE object field. The next few sections describe these tricks.

Creating a Database

Using Cut-and-Paste to Insert (Part of) an Object

You can use the Windows Clipboard to cut and paste all of an object, or part of an
object, into an Access table:

1. Open your Access data in datasheet view or form view.

2. Start the object’s source program. For example, to start Paint, click on the Start but-
ton on the Windows Taskbar and then choose Programs » Accessories » Paint.
3. Create or open the object you want to insert into your Access table in the source pro-

gram. If you want to link the object, the object must be saved in a named file on disk.

LR ad— = — e —— = &~
To insert only part of the object, select that part using the program'’s techniques.
For example, use the Select tool in Paint to select a portion of the picture.

4. Press Ctrl+C or choose Edit » Copy from the source program’s menu bar.
5. Click on the Microsoft Access button on the Windows Taskbar.
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6. Put the cursor in your Access table in the appropriate field.
7. Do one of the following:

e To embed the object, press Ctrl+V or choose Edit » Paste from the Access
menu bar. Then skip the rest of the steps below (you're done).

¢ To link the object or change its data type, choose Edit » Paste Special from
the Access menu bar. You'll see a Paste Special dialog box similar to this one:

Paste Special 7] x|

Souice: C:AWINDOWS\Desktop\HelenPhato BMP

As: Cancel

& Pasle
Pictue
Device Independent Bilmap
Cadls 14 [~ Display As Icon

Result — —|
Inserts the contents of the Chpbaard into yoty

document so thal you may activale § using Pant.

8. Choose options that reflect what you want to do. For example:

¢ Choose Paste to embed the object from the option buttons or Paste Link to link it.

¢ Choose a different paste format from the As list. For example, choosing Picture
embeds the object as a picture that cannot be modified or activated.

¢ Select (check) Display As Icon to display the object as an icon. The icon will appear
along with a Change Icon button that lets you change the icon if you wish.

9. Click on OK.

The form in Figure 8.11 shows a Paint picture that we selected and pasted into our
Access table. Remember that only a brief description of the object will appear in datasheet
view. (We'll explain how to make the picture fit better into its container soon.)

Creating an Object Just Before You Insert It
To create an OLE object before you place it in an Access field:

1. Start in datasheet view or form view, with the cursor resting in the OLE object field
that will contain the object.
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. Choose Insert » Object from the Access menu bar or right-click on the field and
choose Insert Object.

. Choose Create New in the Insert Object dialog box.

. Double-click on the type of object you want to create from the list of object types.

. Create the object in the source program.

. Choose File » Exit from the source program’s menu bar (if the program opened in
a separate window) or click outside the OLE object field (if you're editing in place).

7. Click on Yes or OK if asked about updating the embedded object.

N bW

That’s it—you're done. You should be able to see the object in its field whenever
you're in form view.

Using Drag and Drop and OLE 2

You've probably heard about OLE 2, the version of OLE that supports drag-and-drop
and in-place editing. Drag and drop means that you can copy an object from any source
to any destination just by dragging it across the screen. No need to go through any
menus or the Windows Clipboard.

In-place editing means that when you double-click on an OLE object in (say) your
Access table, you won't be taken to the object’s source program. Rather, the tools and
capabilities of the source program will “come to you.”

e MO TE s —r————
The Microsoft Office, Corel WordPerfect Suite 7, and Corel Office Professional
suites are examples of Windows programs that support OLE 2. If you have
Microsoft Word installed, try using it as the server as you follow the steps below.

Eranttrr = [Eataicares

Using drag-and-drop to embed an OLE object from a server document into your
Access table is easy:

1. Open your Access table or form as usual and scroll to the record that contains the
OLE object field you want to update.

2. Start the OLE 2 server program and then open or create the object you want to
embed into your Access table.

3. Select the object using normal selection techniques for the server program.

4. Make sure you can see the server program and your Access table or form. To do this
quickly, open the two program windows you want to work with (and close or min-
imize others to reduce clutter); then right-click on an empty part of the Windows
Taskbar and choose Tile Horizontally or Tile Vertically.
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5. Do one of the following to drag-and-drop the selected object:

¢ To copy the selected object from the server program to the Access table field,
hold down the Ctrl key while dragging the selection from the server program
to the appropriate OLE Object field in your Access table or form.

* To move the selected object from the server program to the Access table field,
drag the selection (without holding down the Ctrl key) from the server pro-
gram to the appropriate OLE Object field in your Access table or form.

To conserve memory, close the server program.

Drag and Drop from Access
to Other Programs

In addition to dragging and dropping
from some program into Access OLE
object fields, you also can drag and drop
selected data from Access to other pro-
grams. Not all programs support such
shenanigans, but WordPad, Word, and
Excel certainly do. Suppose you want to
drag and drop some data from Access into
a Word table or an Excel spreadsheet.
Here’s how:

1. Select the rows in Access datasheet
view,

2. Open a Microsoft Word for Windows 95
document or a Microsoft Excel for Win-
dows 95 worksheet.

3.

Make sure you can see the windows
for both Access and the program
you'll be dropping the data into. To
do so, right-click on an empty part of
the Windows Taskbar and choose Tile
Horizontally or Tile Vertically.

Move the mouse pointer just to the
right of a row selector within the
selected Access data. The mouse
pointer changes to a hollow white
arrow when it’s positioned correctly.
Drag the selection to the Word docu-
ment or Excel spreadsheet window
and then release the mouse button.

The selected data from Access will be
copied to the Word document or Excel
spreadsheet.

About Bound and Unbound Objects

In this chapter, we've discussed techniques that are specific to putting a “bound OLE
object” into a table field. By bound we mean that the object is “tied to” a specific table.
As you'll see in later chapters (and various Help windows), however, Access can store
an unbound OLE object, which is an OLE object that’s attached to a form or report,
rather than to a table. You'll learn how to put an unbound OLE object on a form in

Chapter 13.

-
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For more information about linking and embedding objects, look up OLE Objects
and its subtopics in the Access Help Index.

Special Techniques for Memo Fields

If you need to type lots of text into a memo field, your best bet is to create a form for
that table (see the “Talents” memo field back in Figure 8.11). Alternatively, you can
press Shift+F2 to open a Zoom box. Either trick will give you more space to work in. As
you'll soon discovet, what happens when you press the Enter key in a memo field can
vary, but here’s what’s most common:

e If you're typing in a memo field on a form, pressing Enter ends a short line,
starts a new paragraph, or inserts a blank line in the text, as it does in most word
processing programs.

¢ If you're typing in a memo field on a table datasheet, pressing Enter leaves the
field and moves onto the next field or record.

s If you're typing data in a Zoom box, pressing Enter (or clicking on OK) closes
the Zoom box. To insert a new line instead of leaving the field or closing the
Zoom box, press Ctrl+Enter (instead of Enter) to end a short line or paragraph or
to insert a blank line.

Try using the Zoom box (Shift+F2) any time you need to enter more text than will
fit in the standard input area. The Zoom feature is available in property sheets,
datasheet view, and grid cells in the design views for tables, queries, advanced
filter/sort, and macros.

Controlling the Enter Key Behavior

A property named Enter Key Behavior is what controls the behavior of the Enter key
within forms. To change this property, switch to the form'’s design view. Then click on
the control that has the property you want to change, open the property sheet (View »
Properties), click on the Other tab on the property sheet, and then click on the Enter
Key Behavior box. Now change the property to either of these settings:

Default When selected, Access takes the action specified in the Move After Enter
setting anytime you press Enter in the field during data entry. For controls that
display text fields, the Enter Key Behavior property usually is set to Default.
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NOTE
To change the default Move After Enter setting, choose Tools » Options from the
menu bar, click on the Keyboard tab in the Options dialog box, and then choose
one of the Move After Enter settings. Your options are Don’t Move, Next Field
(the default choice), or Next Record. Click on OK. See Chapter 15 for more about
personalizing Access.

New Line In Field When selected, Access inserts a new-line character anytime
you press Enter in the field during data entry. For controls that display memo
fields, the Enter Key Behavior property usually is set to New Line In Field.

See Chapter 13 for more about changing properties on forms.

Special Techniques for Sizing Photographs

Photographs are tricky little devils to put into tables or onto forms because any distor-
tion or clipping is so immediately obvious. Suppose you scan a 3-x-5-inch photo and
use the OLE techniques described earlier in this chapter to put a copy of that photo into
a field in an Access table. In your form, you try various size modes—Clip, Stretch, and
Zoom—as shown below. But nothing quite gives the fit you're looking for.

Clip The photo is larger than its frame in this case, so Clip shows only the
upper-left corner of the photo.

Stretch The photo stretches (or shrinks) along both axes to fit within the frame,
which distorts the picture.

Zoom The photo stretches (or shrinks) along one axis to fit in the frame, which
minimizes distortion but leaves a big chunk of white space within the frame.

The problems are
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The solution to the problem is straightforward—crop and size the photo while you're
scanning it so that it will fit nicely into its container. Let’s take it from the top so you can
see how to measure the size of a container exactly.

Another solution to the problem of ill-fitting photos is to size the container on the
form to fit the photos. Of course, all the photos you intend to display on the form
must be the same size.

Step 1: Create the Table and Field

First, if you plan to put a photo in each record of a table, you’'ll need a field in the table’s
structure to hold the photo. That is, you need to give that field a data type of OLE Object.
For example, the Photograph field of the Star Search Models table (see Figure 8.12) is an
OLE Obiject field that can store photos. After creating the table structure, close and save
it in the usual manner.

Step 2: Create the Form

Next, create a form that will display the photo and other data in the table. Use the tech-
niques described in Chapters 11 and 13 to create the form and to size, position, and align
its controls to your liking. The form in Figure 8.11, shown earlier, certainly will do the
trick for displaying photos and other information. (If you just want to use a simple form,
click on your table name in the database window and then choose Insert » AutoForm, as
described earlier in this chapter.)
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Step 3: Measure the Photo’s Container

When you're happy with the general appearance of the form, open it in (or switch to)
design view. Click on the control that will display the photo, open the property sheet
(View » Properties), and then click on the Format tab. Locate the Width and Height prop-
erties and jot down those measurements (you'll need them in a moment). Figure 8.12
shows our Star Search form in design view. The control that displays the photo is selected
and its property sheet is open. As you can see, the width of that control is .9514 inches, and
its height is 1.2431 inches.
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Step 4: Scan, Crop, and Size the Photo

Once you know the size of the container that will display the photo, you can scan the
photo and also crop and size it to its container. Remember to do this while you're scan-
ning so that you don’t have to resize the photo after it has been stored on disk. Not
surprisingly, most scanner software offers much more control and flexibility in this
respect than a program such as Access, which is designed to do other things.

In Figure 8.13, we've scanned a photo using the scanning software (DeskScan II) that
comes with the HP ScanJet IIc (other scanning programs offer similar capabilities). We've
scaled the image to 28 percent and framed a portion measuring 0.95 inches wide by
1.25 inches tall—pretty close to the size of the container in our Access form.

Be sure to size and crop, to the same size as the container, any other photos you'll be
putting into the table.

Step 5: Link or Embed the Picture

Save the scanned image. Then return to your Access database, open your form, and put
the picture in its container using the OLE techniques described earlier. If you sized the
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While scanning = DeskScan Ii
this photo, we Fle Edt G
Cropped the por-

tion that we
want to appear
on the screen,
and sized it to fit
perfectly in its
container.

image carefully, it should fit perfectly into its frame without distortion, as shown earlier
in Figure 8.11.

Troubleshoofing Dafa Entry and Editing Problems

Next we'll look at solutions for some common problems that you might encounter
when entering and editing data.

Creating a Database

Duplicate Key Message

If the new record you entered into the table duplicates the contents of the primary
key field in some other record, you'll see this error message when you try to move to
another record:

Miciozoll Access |
Dupleats value inindes, pnmary key, or relationship-
Changes were unsuccessful.

o] b |
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This message can be confusing because it doesn’t appear until after you've filled in
the record. Remember that it’s referring to the field you defined as the primary key (or
to an indexed field that doesn’t allow duplicates) when you created the table’s design.

To wiggle out of this jam, click on OK. Then do one of the following:

e To correct the duplicate, move the cursor to the field that defines the primary
key and enter a new, unique value in that field.

¢ To avoid adding the record at all, choose Edit » Undo Current Field/Record or
press Esc to erase the entire new record.

If you really do need to put duplicate entries into the field, get out of the jam as
described above. Then return to the table’s design view and either remove the No
Duplicates (or primary key property) from that field or use two or more fields to define
the primary key.

Can’t Have Null Value in Index

If you see the message Index Or Primary Key Can’t Contain A Null Value when you
attempt to leave a record, it means you've left the primary key field (or an indexed field
with the Required property) in the current record empty. Click on OK to return to the
table. Then fill in the field that requires a value. Or to delete the entire new record,
choose Edit » Undo Current Field/Record or press Esc.

Value Isn’t Appropriate for This Field Type

If you enter the wrong type of data into a field, you'll see a message that the data you
entered doesn't fit the Data Type or FieldSize property setting for the field. For example,
this message will appear if a field is defined as the Date/Time data type in the table
design and you try to type a name, address, or dollar amount into that field.

Once again, click on OK to clear the message, enter the correct type of data into the
field, and then save the record again (by moving to some other record). Or press Esc to
have Access undo your changes to the record.

New Records Seem to Disappear

If records seem to disappear after you enter them, don’t panic. Simply close the table
and open the table again. Remember that if the table has a primary key, Access main-
tains an ongoing sort order based on the field(s) that define the primary key. However,
it doesn’t re-sort the table until after you close it. (Waiting to re-sort the table makes

data entry faster.)




TROUBLESHOOTING DATA ENTRY AND EDITING PROBLEMS I 299

So even though new records are at the bottom of the table when you enter them,
they’ll be in their proper sort-order position the next time you open the table. You can
scroll around to find those records to verify that they're in the table.

Data Fails Validation Rule

If you've assigned a validation rule or the Required property to a field (see Chapter 6)
and the new data in the field fails the validation rule, you'll see this message (or what-
ever custom message you defined for the field):

Microsoft Access

B
v ; < or
‘Ofdders. Ordetate’

e |

Click on OK to clear the message. You must change the field value so it passes the
validity check, or delete the entire record, before you can move on to another field.

If the data is indeed valid and your validity check is at fault, make the field pass the
currently assigned validity check or delete the record. Then return to the table's design
view and fix the Validation Rule property for that field. If necessary, fix fields that vio-
late the newly assigned validation rule.

Access Won't Let You Add or Change Any Data

| Several factors can prevent you from adding or changing data.

e If you can’t change any data in the table, the Allow Edits property may be set to
No for your form.

¢ If you can’t edit certain fields, the Enabled and Locked properties for that field
on your form may be set to prevent editing. See Chapter 13 for more about forms
and field properties.

¢ If you're sharing data on a network, you may be warned that a record you just
changed has been changed by another user since you started editing it. You can
then save the record and overwrite the changes the other user made (click on Save
Record), copy your changes to the Clipboard and display the other user’s changes
in the field (click on Copy To Clipboard), or drop your changes (click on Drop
Changes). If you chose Copy To Clipboard, you can then choose Edit » Paste
Append to add your record from the Clipboard to the table.

Creating a Database
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e If you're working on a secured system, the database administrator (the person
in charge of keeping the database secure) can withhold the right to change, and
even view, certain data. If you can’t get at some data you need to change, ask your
database administrator to extend your rights as necessary.

o If the current record contains an AutoNumber field that displays (AutoNumber)
and you can’t move the cursor to a new record, try entering data into any field in
the current record (except the AutoNumber field). Once some data exists, the Auto-
Number field will be updated and you can move the cursor to a new record.

Changing the Table Design from Datasheer View

Earlier we said that datasheet view is just for entering data and that table design view
is just for changing the table’s structure. Actually, that statement was a teeny tiny lie.
The truth is that you can use datasheet view to

e Change a field (column) name

¢ Insert a new text field, hyperlink field, or lookup field
¢ Delete a field

e (Create a table from a blank datasheet

As you'd expect, the changes you make to the table’s structure in datasheet view also
will be reflected in design view, and vice versa. So, if you'd like to change your table’s
design without leaving datasheet view, read on. (Sorry, you can’t change the structure
of linked tables.)

WAL R S —
Changing field names and deleting fields can have important consequences for
objects in your database that expect those fields to be available. So don’t make
design changes in datasheet view unless you’re sure they won't adversely affect
other objects. Also be aware that Access doesn’t ask for permission to save the
changes when you insert a column from datasheet view.

Renaming a Column

You can change a column name while you're in datasheet view. To tell Access which
column you want to rename, use one of these techniques.
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I

¢ Double-click on the field selector at the top of the appropriate column. The column
name will be selected, as shown below:

B4 Customers : Table HFIE

W|Customer 1D Company Name

1|ABC Cotporation

2 RNAA Associates

3/ Reese Clinic

A4 WinldWide Widgels

5 University of the Elite

6/ Precision Bagpipes

7 Dalahase Search and Resoua
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e Click on the field selector at the top of the column whose name you want to
change. Then right-click on the selection and choose Rename Column. Again, the
column name will be selected.

e (Click anywhere in the column whose name you want to change and then choose
Format » Rename Column. You guessed it, the column name will be selected.

With the column name selected, type a new name and then press Enter. Access will
change the name in the field selector. If you switch to table design view, you'll see that
the Field Name has changed there as well.
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Inserting a Text Column

To insert a new column (field) to the left of any existing column in the datasheet, open
the table in datasheet view, and then:

1. Click in the column that will become the new, blank column, and then choose
Insert » Column. Or right-click on the field selector at the top of the appropriate
column and choose Insert Column. A new column will appear in the datasheet.

2. Rename the column as explained in “Renaming a Column,” above.

The new field will have a Text data type and a field size property of 50. If you don't
like these settings, switch to table design view and change them.

Inserting a Hyperlink Column

To insert a new hyperlink column (field) in a datasheet:

1. Click in the column that will become the new, blank column and then choose Insert »
Hyperlink Column. Or right-click on the field selector at the top of the appropriate col-
umn and choose Insert Column. A new column will appear in the datasheet.
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2. Rename the column as explained in “Renaming a Column.”

3. If you used the right-click method and chose Insert Column, enter a valid hyper-
link address such as http: //www.microsoft.comin any row of the new column. Access
will recognize the address as a hyperlink and convert the field type from Text to
Hyperlink.

Inserting a Lookup Column

Chapter 6 gave you the full scoop on defining lookup fields from table design view.
Here’s how to insert a new lookup column (field) from datasheet view:

1. Click in the column that will become the new, blank column and then choose
Insert » Lookup Column. Or right-click on the field selector at the top of the appro-
priate column and choose Insert Lookup Column. The Lookup Wizard will take over.

2. Respond to each Lookup Wizard dialog box (see Chapter 6), choosing options and
clicking on the Next button as usual. When you've filled in the last dialog box,
click on Finish to create the lookup column.

3. Rename the column (if necessary), as explained above in “Renaming a Column.”

The new field’s Data Type and field properties will be set automatically. Of course, you
can switch to table design view and change the data type and field properties if you wish.

Deleting a Column

Deleting a column in datasheet view is easy, but be careful! When you delete a column,
you're also deleting all the data in that column. What’s more, you can’t undo the col-
umn deletion. Here are the steps:

1. Do one of the following:

e Right-click on the field selector at the top of the column you want to delete
(the column will be selected) and choose Delete Column.
e (Click on any data in the column and then choose Edit » Delete Column.

2. Decide if you want to permanently delete the selected field and data. If you're sure
you want to delete the column, click on Yes. If you've changed your mind, click on
No to leave the column alone.

If you chose Yes in step 2, the column will disappear from the datasheet (and from
the list of fields in design view).
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If you try to delete a field that's part of a relationship, an error message will tell
you to delete its relationships in the Relationships window first. Click on OK to

clear the error message, go to the Relationships window and delete the relation-
| ship (see Chapter 6), and then try deleting the field again.

1.
2.
3.

Creating a Table from a Blank Datasheet

If you're more accustomed to using spreadsheets than databases, you might prefer to
create tables from a blank datasheet, like this:

Open the database in which you want to create the new table.

Click on the Tables tab on the datasheet window and then click on the New button.
Click on Datasheet View in the New Table dialog box and then click on OK (or double-
click on Datasheet View).

. Type data into each column and row of the datasheet, as needed.
. Use the techniques described earlier under “Renaming a Column” to name the col-

umns (initially, they’ll be named Field1, Field2, Field3,...).

. Click on the Save toolbar button or choose File » Save to save your changes and

name the table.

. Type a table name (up to 64 characters) in the Save As dialog box and then click on OK.
. Decide if you want to define a primary key. Click on Yes to assign a primary key with

a field name of 1D or click on No to save the table without a primary key when asked.

Access will evaluate the data you've entered and automatically create appropriate
field types and formats. To further customize the design of your new table, switch to
design view and change the design as needed. When you're finished using the table,
click on its Close button or press Ctrl+W.

For more information about changing the table design from datasheet view, look up
Datasheet View in the Access Help Index and then choose either of these subtopics: Add-
ing Fields To Tables or Field Names. For details about deleting fields, look up Delefe Fields
In Datasheet View in the Access Answer Wizard, double-click on Delete A Field, and then
click on Delete A Field From A Table In Datasheet View.

Where fo Go from Here

In this chapter, you've learned the basics of customizing datasheet view, entering data,
and changing the table structure from datasheet view. Continue with Chapter 9 now to
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learn how to sort (or alphabetize) your data, search for particular records, filter out
unwanted records temporarily, and print your data.

What’s New in the
Access Zoo?

If you used an earlier version of Access,
you'll be quite comfortable entering and
editing data in Access 97 tables and forms.
All the basics remain the same. The big
new addition is hyperlinks, as explained in

Chapter 7. If you want to use hyperlink
fields in your databases, check out the sec-
tion in this chapter on “Using Hyperlinks in
a Table”. You'll find out how to enter and
edit hyperlinks and use them to jump to all
kinds of data on the Internet, in other

Office programs, and in Access databases.
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Sorting (alphabetizing) your data
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Finding individual Records

~ Fixing typos automatically

Replacing data in multiple records

Filtering out unwanted records

Creating complex filters

Quick prints
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