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Rbout Recess 97, Office 97, 
Windows 9S, and the Internet 

icrosoft Access 97 for Windows 95 is 
tightly integrated with Windows 95 
and Microsoft Office 97 for Win

dows 95. In this chapter we highlight the most important integration features and 
point you to places where you can get more details. We'll also give you a brief overview 
of the new features that let you share Access data via the Internet. If you're completely 
new to Access and Microsoft Office, you might want to skim through (or even skip) this 
chapter and come back to it when you find yourself asking questions such as, How can 
I make the most of what I know about Windows 95 and Microsoft Office 97? and How 
can I make the most of my Access data? 

Making the Most of Windows 95 and Access 97 
Microsoft Access is designed from the ground up to provide full support for all Win
dows 95 features. Listed in alphabetical order below are some of the most important 
Windows 95-like features that you'll find in Access. 

32-Bit Application - Microsoft Access for Windows 95 is a 32-bit application, which 
means that it runs in its own protected computer memory area. Therefore, Access won't 
grind to a halt if some other program on your computer decides to misbehave. Access 
also takes advantage of the multithreading capabilities of Windows 95, something 
programmers will appreciate; the Jet database engine, Microsoft Access, and modules 
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written for Visual Basic for Applications all run in separate threads. (On high-end Win
dows NT machines, multithreading allows several CPUs to cooperate on a single Access 
application at the same time.) 

Briefcase Replication - Access for Windows 95 takes advantage of the Windows 95 
Briefcase feature, which enables you to work remotely with replicas of your database 
and later merge the changes into your master databases. Any design changes made to 
the master databases also will be propagated to the replicas. Replication is ideal for man
aging remote changes to data and balancing the load over a network. See Chapter 17. 

Database Explorer- The database window in Access 97 for Windows 95 looks and 
acts a lot like Windows 95 Explorer, as well as windows that appear when you open My 
Computer or Network Neighborhood. To view database objects as large icons, small 
icons, a list, or a detailed list, choose options on the View menu; or click on appropriate 
Database toolbar buttons; or right-click on an empty area inside the database window 
and choose View options from the shortcut menu. To arrange icons by name, type, cre
ation date, or modification date, choose options on the View>- Arrange Icons menu, or 
right-click on an empty area inside the database window and choose Arrange Icons 
options from the shortcut menu. See Chapter 1 and Figure 4.1. 

Long File Names and UNC Paths - Like all programs designed for Windows 95, 
Microsoft Access 97 for Windows 95 supports long file names and universal naming 
convention (UNC) paths. UNC paths Jet you refer to files on a remote computer by sup· 
plying the computer name, rather than by permanently mapping a drive letter to the 
remote computer. For example, an Order Entry database file located in the"My Docu
ments folder on drive C of a computer named Hanley might have a tongue-twisting 
UNC name of\ \Hanley\c\My Documents\Order Entry.mdb. 

Plug-and-Play Screen Resolution - Plug-and-play screen resolution lets you change 
your screen resolution on the fly. To use it, minimize Microsoft Access and any other 
programs that are covering the Windows 95 desktop. Next, right-click on any empty 
area of the desktop and choose Properties. Finally, click on the Settings tab in the Dis· 
play Properties dialog box, use the slider control below the Desktop Area option to set 
the screen resolution you want to use, and then click on OK. Respond to any prompts 
that appear and then click on the Microsoft Access Taskbar button to return to Access 

Shortcut Menus - Windows 95-style shortcut menus are available throughout Access 
Simply right-click wherever you want to see a shortcut menu and then click on (or 
right-click on) the shortcut menu option you want to use (refer to Figure 4.1). 

Special Effects -Access for Windows 95 and its forms and reports can display the samt 
sunken, raised, etched, chiseled, shadowed, and flat special effects you often see in Wir 
dows 95 programs and dialog boxes. See Chapter 13 and Figure 4.2. 
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Windows 95 Look and Feel - Access for Windows 95 uses all the standard Windows 95 
controls you've grown to love, including tabbed dialog boxes, option buttons, drop-down 
lists, command buttons, and new checkmark-style (/) checkboxes. So once you've mas
tered Windows 95 skills, working with Access will seem easy and natural. Figure 4.3 shows 
a typical Access 97 for Windows 95 dialog box. 

Windows 95 Shortcuts - Creating a desktop shortcut to any Access object is similar 

to creating shortcuts in Windows 95. Simply drag and drop an object from the Access 
database window to your desktop and then use the dropped object as you would any 
shortcut. For example, double-click on the shortcut to start Microsoft Access and open 
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the associated object; or right-click on the object to open a shortcut menu (see below) 
that offers a host of possibilities for working with the object. (See Chapter 1.) 
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Making the Most of Microsoft Office and Access 
Microsoft Access 97 for Windows 95 shares many common features with other programs 
in the Microsoft Office 97 for Windows 95 suite, especially Microsoft Excel and Microsoft 
Word. So if you've installed all or part of Microsoft Office, you can take advantage of 
these common features immediately. We'll take a look at some of these shared features 
next. Later in this chapter, we'll discuss convenient ways to share data across programs in 
Microsoft Office. 

The Microsoft Office Shortcut Bar 
The Microsoft Office Shortcut Bar shown below lets you launch and switch between 
programs, open files, and more. 

Displaying and Hiding the Office Shortcut Bar 
The Microsoft Office Shortcut Bar usually appears at the upper-right corner of your desk
top. If it doesn't appear, click on the Start Taskbar button and then choose Microsoft 
Office Shortcut Bar from the Start menu. Or click on the Start Taskbar button, choose 
Run, type the command line "\MSOffice\Microsoft Office Shortcut Bar.lnk" (with the 
quotation marks), and then press Enter. 
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Handy Ways to Use the Office Shortcut Bar 
Here are some things you can do when the Office Shortcut Bar is visible: 

• To find out what an O{fice Shortcut Bar button is for, move your mouse pointer 
to the button. A SmartTip will appear near the pointer to explain the button's 
purpose. 

• To choose a button on the Office Shortcut Bar, click on the button. 
• To display the Office Shortcut Bar as a floating palette of buttons, move the 

mouse pointer to any empty area between buttons and then drag the bar toward 
the middle of the screen. 

• To dock the floating Office Shortcut Bar at the upper-right corner of the desk
top, double-click on the Office Shortcut Bar's title bar. 

• To open the Control Menu for the Office Shortcut Bar, click or right-click on 
the Office Shortcut Bar's Control Menu icon and then choose any of the options 
shown below: 

AytoHide 
!;ustomize . 

Add/A emove Qffice Programs 
Contents and Index 
About Microsoft Offrce 

- .......... -----'-1 
E!!it Alt+F4 

• To choose or hide bars on the Office Shortcut Bar, right-click on an empty area 
between buttons on the bar and select (check) or deselect (clear) the name of the 
bar you want to display or hide, respectively. 

• To switch to another bar on the Office Shortcut Bar when multiple bars are 
selected, click on the button for the bar you want to use. 

• To customize the currently selected bar on the Office Shortcut Bar, right-click 
on an empty area between buttons on the bar and choose Customize, or double
click on an empty area between buttons. Then choose an appropriate tab from the 
Customize dialog box (see figure 4.4), complete the dialog box as needed, and 
then click on OK. 
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• To add an Office Shortcut Bar button that will launch a program (including 
Microsoft Access) or open a document or folder, select the bar that should contain 
the new button. Next, use Start ~ Find or My Computer or Windows Explorer to 
locate the program, document, or folder name you want to add as a button. Then 
drag the program, document, or folder name to any button on the Office Shortcut 
Bar (when the mouse pointer displays a small + sign, you've hit the right spot on the 
Office Shortcut Bar and can release the mouse button). Your new shortcut button will 
appear at the end of the Office Shortcut Bar. 

• To remove a button from the Office Shortcut Bar, right-click on the button and 
choose Hide Button. 

• To exit the Office Shortcut Bar, click or right-click on the Control-Menu icon at 
the top-left edge of the Office Shortcut Bar, and then choose Exit. 

For more details on using the Microsoft Office Shortcut Menu Bar, see your Microsoft 
Office documentation; or click or right-click on the Control Menu icon at the top-left 
edge the Office Shortcut Bar and then choose Microsoft Office Help Topics. 

Common Bars 
Common menu bars and toolbars appear throughout the Microsoft Office suite, so you 
won't have to waste time hunting for options you use often. Figure 4.5 shows the 
Microsoft Excel, Word, PowerPoint, and Access program windows opened on the desk
top. Notice the similarities among their menu bars and toolbars. 
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Common Dialog Boxes 
Many dialog boxes-including New, Open/Import, Page Setup, Print, and Save-work 
the same way in all Microsoft Office programs. In Figure 4.6, for example, you see the 
Open dialog box for Microsoft Word. Figure 4.7 shows the very similar Import dialog 
box for Microsoft Access. 

Common Office Tools 
You'll also find common tools that work in identical (or similar) ways throughout 
Microsoft Office. Table 4.1 briefly describes each tool and tells you which Microsoft 
Office programs offer it. 
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I TABLE 4.1: COMMON MICROSOFT OFFICE TOOlS 

MENU OPTION WHERE YOU'LL 
FEATURE WHAT IT DOES OR SHORTCUT FIND IT 

Auto Correct Corrects typing errors Tools> AutoCorrect Access, Excel, Power-
automatically. Point, Word (Chapter 9) 

AutoFormat Formats a document Format > AutoFormat Access, Excel, Word 
automatically. (Chapters 11, 12, 

and 13) 

Export/Save As Saves objects with a File > Save As/Export Access, Excel, 
new name or format . or File > Save As or Exchange, PowerPoint, 

File > Export or File > Outlook, Word 
Import and Export (Chapter 7) 

Format Painter Copies the appear- Format Painter Access, Excel, 
ance of one control or toolbar button PowerPoint, Word 
selection to another. (Chapter 1 3) 

Import/Link Imports or links data File > Get External Access, Excel, 
from other programs Data > Import, or Exchange, Power-
and formats. File > Get External Point, Outlook, Word 

Data > Link Tables, or (Chapter 7) 
File > Open, or File > 
Import File > Import 
and Export 

Insert Inserts date and time, Insert menu options Access, Excel, 
page number, picture, PowerPoint, Word 
object, and more (Chapters 8 and 13) 
(depends on program). 

Options Customizes default Tools > Options Access, Excel, 
settings. Exchange, Power-

Point, Outlook, Word 
(Chapter 15) 

Print Prints objects and File > Print (Ctri+P) Access, Excel, 
documents (some or File > Print Preview Exchange, Power-
programs also offer a Point, Outlook, Word 
preview feature). (Chapter 9) 

Continued I ~ 
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I TABLE 4 .1: COMMON MICROSOFT OFFICE TOOLS (CONTINUED) 

MENU OPTION WHERE YOU'LL 
FEATURE WHAT IT DOES OR SHORTCUT FIND IT 

Properties Displays and changes File>- Database Access, Excel, 
properties of the active Properties or File >- Exchange, Power-
document or database. Properties Point, Outlook, Word 

(Chapter 5) 

Send Sends the active docu- File>- Send Access, Excel, 
ment or object using Exchange, Power-
electronic mail. Point, Outlook, Word 

(Chapter 7) 

Spell Check Checks for and Tools >- Spelling (F7) Access, Excel, 
replaces spelling Exchange, PowerPoint, 
errors. Word (Chapter 9) 

Tapping the Microsoft Knowledge Base and More 
Every Microsoft Office program offers many sources of help. For example, you can look 
in the Getting Results book, the Answer Wizard, the Help Index, the Help Contents, and 
the Readme file that come with most Microsoft Office programs. But that's not it by a 
long shot! You also can get in-depth technical help on a variety of Microsoft products 
from these resources (which are listed in alphabetical order): 

• Microsoft Download Service (MSDL) The MSDL is a bulletin board service that 
contains Microsoft Software Library (MSL) articles and support files for you to 
download to your computer. Using your modem, dial (206) 936-6735 in the 
United States, or (905) 507-3022 in Canada. 

• Microsoft Fast Tips This service offers recorded or faxed answers (in English) to 
common technical problems and lets you order catalogs, Application Notes, and 
popular articles from the Knowledge Base (KB) via fax or mail. Call (800) 936-4100 
from any touch-tone telephone. 

• Microsoft Knowledge Base (KB) The KB contains a comprehensive set of articles 
(updated daily) with detailed answers to how-to and technical support questions 
and lists of bugs and fixes. The KB is available on America Online, CompuServe, 
GEnie, Internet (via World Wide Web, FTP, or Gopher), Microsoft Developer Net
work, Microsoft TechNet, and the Microsoft Network. From the World Wide Web 
and Gopher sites, you can do full-text searches of KB articles and download files 
automatically. 
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• Microsoft Press publications Microsoft Press offers development kits, resource 
kits, and a variety of books about Microsoft products and related technologies. Call 
(800) MSPRESS or (800) 677-7377. 

• Microsoft Software Library (MSL) on America Online, CompuServe, GEnie, Inter
net, Microsoft Developer Network, Microsoft Download Service (MSDL), Microsoft 
TechNet, and the Microsoft Network. Here you'll find a collection of binary (non
text) files, including device drivers, utilities, Help files, and technical articles for all 
Microsoft products. 

• Microsoft TechNet and Microsoft Developer Network (MSDN) CD-ROMs These 
subscription services offer KB, MSL, and other information on CD-ROM. To subscribe 
to these services, call (800) 344-2121 for Microsoft TechNet or (800) 759-5474 for 
MSDN. 

• Online support forums Online support forums are frequented by end-users, 
third-party developers, and Microsoft support staff who can answer many of your 
questions quickly. You can find Microsoft forums on America Online, CompuServe, 
GEnie, the Internet, and the Microsoft Network. 

You can reach the KB and MSL at these Internet sites: 

• Microsoft World Wide Web at www.microsoft.com 

• Microsoft Gopher at gopher.microsoft.com 

• Microsoft FTP at ftp.microsoft.com (supports anonymous logon) 

You can reach the KB, MSL, or Microsoft forums from CompuServe: 

• To reach the KB, type GO MSKB at any ! prompt or choose equivalent menu 
options from your CompuServe navigation program. 

• To reach the MSL, type GO MSL at any ! prompt or choose equivalent menu options. 
• To reach the Microsoft forums, type GO MICROSOFT at any ! prompt or choose 

equivalent menu options. To reach the Microsoft Access forum directly, type GO 
MSACCESS or choose equivalent menu options. 

To reach the KB from America Online: 

• Choose Go To> Keyword and type Microsoft in the Enter Word(s) box. In the 
Microsoft Resource Center, click on Knowledge Base. 

To reach the KB from the Microsoft Network: 

1. Log on to the Microsoft Network. 
2. Click on the Start button on the Windows Taskbar and then select Find > On the 

Microsoft Network. 
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3. Type Knowledgebase in the Containing text box and then click on Find Now. 
4. Double-click on the topic that appears. 

For more information about all the resources mentioned above, look up Technical 
Information and its subtopics in the Help Index of any Microsoft Office program. If you're 
a member of the Microsoft Network, you can connect to many of these resources by 
choosing Help> Microsoft on the Web from any Microsoft Office program's menu bar. 

Sharing Access Information with other Office Programs 
Imagine having to retype all the names and addresses that you've painstakingly stored 
in your Access database-just to send form letters from Microsoft Word. And who in 
their right mind would want to retype data stored in Excel worksheets after deciding 
that a database table offers a more efficient way to store that information? None of that 
tedium and wasted effort is necessary when you use Windows 95 technologies and the 
integrated Microsoft Office suite. In the next few sections, we'll summarize ways to 
transfer information to and from Access and point you to places in this book where you 
can get more details. 

If you get messages about difficulties in starting programs or establishing links 
between programs, chances are that your computer does not have enough memory 
to complete the job you're trying to do. To solve this problem, respond to any mes
sages that appear and restart your computer (Start>- Shutdown >-Yes). Then launch 
only the program or programs that absolutely must be in memory at the same time 
and try the operation again. If you still have problems, you may need to install more 
memory on your computer. (Access itself requires about 12MB of memory, and you'll 
often need at least 16MB to perform tasks that involve multiple Office programs.) 

Using Import and Export 
You can use file import or link techniques to create an Access table from data stored in 
an external file, such as an Excel worksheet. To get started, go to the Access database 
window and choose the File > Get External Data > Import or File > Get External Data 
> Link Tables commands. 

To convert data in an Access table (or other object) for use in another program such 
as Excel or Word, use the export feature. After exporting the Access data, you can start 
the other program, open the file you created, and use it normally. To start exporting 
data from Access to another format, go to the database window and click on the table, 
query, form, or other object that contains the data you want to export. Then choose 

File > Save As/Export. 
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Chapter 7 explains how to create Access tables from files stored in these formats: 
Access, Excel, Paradox, text files, dl3ASE, foxPro, Lotus 1-2-3, ODBC databases, and 
HTML. There you'll also learn how to export data from Access to these formats: Access, 
Excel, Paradox, text, dBASE, FoxPro, Lotus 1-2-3, Rich Text Format, Microsoft Word Merge, 
ODBC databases, and HTML. See Chapter 7 for information on how to use the Publish to 

the Web Wizard to set up dynamic links between an Access database and the Internet. 

Using OLE 

Windows 95 OLE technology offers many ways to share selected data or entire files 
between Microsoft Access, Microsoft Office, and other Windows programs. Chapter 8 

provides step-by-step instructions for using these techniques to put data into Access 
tables, including OLE fields. But let's take a quick peek now at what's available. 

Using the Clipboard 
The cut-copy-and-paste technique offers a versatile way to exchange selected data between 

programs. If possible, the original formatting is preserved when you complete the paste 
operation. (When you paste rows from a Microsoft Access datasheet to another program, 
the field names also come along for the ride.) 

In a nutshell, the cut-copy-and-paste procedure is as follows: 

1. Select the object you want to move or copy using the standard selection methods 

for the program you're copying or moving from. 
2. Choose Edit>- Copy (Ctrl+C) or Edit>- Cut (Ctrl+X), or click on the Copy or Cut 

toolbar button if it's available. Your selection will be copied (if you chose Copy) or 

moved (if you chose Cut) to the Windows Clipboard. 

_,-c>..-IE. 
~ The Windows Clipboard is a scratchpad area in your computer's memory. Each 

time you copy or cut a selection to the Clipboard, the new selection replaces the 
previous contents of the Clipboard. Data on the Clipboard usually stays around 
until you exit Windows. 

3. Start the target program and open the document, table, or other object where the cop
ied or moved data should appear. Then put the cursor where the data should appear. 

4. Paste the data from the Clipboard by following one of these steps and then answer 

any prompts that appear. 

• Choose Edit>- Poste (Ctri+V) or click on the Paste toolbar button. 
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• Choose Edit >- Paste Special (if available), complete the Paste Special dialog 
box, and then click on OK. 

• In Access only, choose Edit >- Paste Append to add records to the end of the 
table shown in the current datasheet or form. 

5. The pasted material will appear on your screen. 

Using the Insert Menu Commands 
You also can use commands on the Insert menu to insert all or part of an object into the 
current document, presentation, OLE Object field, or other object. The steps for insert
ing and the appearance of the inserted data depend n which program you' re using 
when you insert the data, which Insert command ym.1 hoose, and which lyp of data 
you insert. 

Here, for example, are the steps for inserting Access table data into a Microsoft Word 
document. The inserted data becomes a standard Word table that's independent of the 
original Access table. 

1. Start Microsoft Word and open the document that should contain the Access table 
data. 

2. Choose View>- Tool bars >- Database and then click on the Insert Database button. 
3. Click on Get Data under Data Source: in the Dat::~base dialog box. 
4. Click on the change Files o{Type: toMS Access Databases (*.mdb) in the Open Data 

Source dialog box and then locate the database yOLl want to use. In the next dialog 
box, select the table you want to include in your d l umcnt. 

5. Click on the Query Opli ns button if you want to select fields and values to insert. 
Click on the Table AutoFormat button to choose a format for the inserted data. 

6. Click on the Insert Data button, complete the Insert Data dialog box that appears, 
and then click on OK. 

Flgure 4.8 shows th sc.r en , fter we in erted the Employees table data from our sample 
rder Enuy database in t a Microsoft Word document. In this example, we chose the 

Cia sic Z Tab! Autoformat ·t 1 and h1d the table gridlines (Table>- Gridlines). 
In most Office programs, you can use the Insert>- Object command either to insert 

an w obje t tha t you create on the fly or to insert an existing object that's stored in a 
fJle. hapter 8 takes you th r ugll the teps for inserting objects into OLE Object fields 
in Ac ess, s w' won't r p at them here. (The steps for inserting an object are similar 
whether y u sta rt from Acces ·, l~x el, Bxcl1ange, PowerPoint, or Word.) 

If the program can do so, it will show the inserted data with its "real" appearance; 
otherwise, the inserted data will appear as a "package" icon. (A package icon is simply an 
icon that represents the file the inserted data is part of.) In Figure 4.9, for example, we 
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MildQ;It«:W 
Here we used Open the Database toolbar in Word. Click the Insert· Database button. 

the Insert Data-
base button on • · 

the Database 
too/bar in Word 

to copy the 
Employees table 

data from our 
sample Order 

Entry database 
to a Microsoft 

Word document. 

. 3 ' • 1 

I Anita lift S ale t: Representative (206)555-9857 
2 Ao.drew Va.nNo slo Vice President. Sales (206)555-94&2 
3 Emily Niktc•g Sales Representative (206)555-3412 
4 Albett Niktog Sales lvla.nager (206)555-8122 
5 Dmis Ajat Sales Representative (2 06)555-1189 
6 Lat>e Closure Office Manager (206)555-1190 
7 Joseph Swipple Vice President., Marketing (206)555-1147 
8 Helen Wheels Product Evat>gelist (206)555-1148 
9 ll<l Honcho President. (206)555-1100 

J 
1/1 At I" Ln I Col I 

inserted the bitmap file named arcade. bmp from the \Windows folder into the Word doc

ument from Figure 4.8. Next to the bitmap file, we inserted the Address Book Lessons 
sample database. Notice that the bitmap file appears as a picture, but the Address Book 
Lessons database object appears only as a package icon, because Word can't display an 

entire database at once. To open either inserted object for viewing or editing, simply 
double-click on the object's picture or icon . 

When you're done working with the inserted object, do one of the following: 

• If the object opened within the main program window, click outside the object. 
The hashmarks and sizing handles around the object will disappear, and the main 

program's tools and menu bar will reappear. 
• If the object opened in a separate program window, choose File > Exit from 

the object's program window. You'll be returned to the main program window. 



• 1lrlM*D 
The Microsoft 

word document 
windoW after we 

used Insert~ 
Object' com

mands to insert 
0 bitmap file 

and an Address 
Book Lessons 

database into 
the document. 

SHARING ACCESS INFORMATION WITH OTHER OFFICE PROGRAMS 119 

• 
:cwy:;===•·+. 

!) a<t ~dl :tieW lnsert f'Qrm..t Iools T,ppe ~ tfelp 

D~~ ei~~l:!.. liff1f1<'1~·'·· &~IEfl;<e!!;lu~ IJ1f 
• Times New Roman • 10 • I B I Jl I [ii 5 =ill • I r= := t~ t:i!= D • ,p • A. • 

Sec I 

Inserted bitmap file 
has its "real" appearance. 

Sales Replooer>tativo 
Vice President, Sales 
Sales Representative 
Sales Manager 
Sales Representative 
Office Manager 
Vice President, Marketing 
Product Evangelist 
President 

Inserted Access database 
appears as a "package" icon. 

Dragging and Dropping 

(206)~55- 9857 
(206)555-9482 
(206)555-3412 
(206)555-8122 
(206)555-1189 
(206)555-1190 
(206)555-1147 
(206)555-1148 

06)555-1100 

The drag-and-drop technique is a convenient way to copy or move selected data from 
one open program to another. You can't drag and drop between all Windows programs, 
but a little experimentation should quickly reveal what's possible. Figure 4.10 shows 
the basic drag-and-drop procedure. 

Here's how to reproduce the example in Figure 4.10: 

1. Start Microsoft Word and Microsoft Access; then open a Word document that con
tains some text and an Access table that contains an OLE Object field. Next, tile the 
programs vertically on the screen by right-clicking on an empty area of the Win
dows Taskbar and choosing Tile Vertically from the shortcut menu. 

2. Select the text you want to copy in the Microsoft Word document. 
3. Hold down the Ctrl key while dragging the selected text from the Microsoft Word 

window to the OLE Object field in the Microsoft Access window. When the mouse 
pointer reaches its destination, release the mouse button and Ctrl key. 

These actions will copy the selected text to the OLE Object field. To move the selec
tion, rather than copy it, do not hold down the Ctrl key while dragging. 
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Using Officelinks in Access 
The OfficeLinks feature in Microsoft Access provides a nifty way to copy Access data to 

other Microsoft Office program formats and to immediately start the appropriate Office 

program. To usc OfficeLink~, select a table, query, form, or report from the Access data

base window and then choose options on the Tools ~ OfficeLinks menu or on the 

Office Links drop-down toolllar button (shown hl'low). 

trr I ...,~ . I ~A "'~ ;::· -~'ei 11J'II'I _ t ._..,., .I:MJ 

H~llWAhiiiS Old 
J!Y !;Ibm. It wti'l MS WOld 

~ ~It W~ MS El<ui 

Chapter 7 covers the OfficcLinks features in more det<lil , but in case you're curious 

now, your options CIJ'e as follows: 

Merge It Merges your Access d;tta with a new or existing Microsoft Word docu

ment and starts Microsofl Word. This feature is especially handy for creating form 

letters and mailing labels from Access tables <tnd queries. 
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Analyze It Saves your Access data as a Microsoft Excel file and starts Microsoft 
Excel. This feature is perfect when you need to examine Access data with the 
sophisticated analysis features that Excel offers. 
Publish It Saves your Access data as a Microsoft Word Rich Text Format (RTF) 
file and starts Microsoft Word. Use this feature when you want to dress up your 
Access data or mix it with word processing text and pictures. 

Using Access Data from Microsoft Excel 
Microsoft Excel and Microsoft Access have a special relationship because they both can 
interpret and display data in a tabular raw-and-column format. Excel offers several 
ways to use Access data without ever leaving Excel itself. 

Chapter 14 explains how to create PivotTables, which are special Excel objects 
that are embedded within an Access form. To create and use PivotTables that 
display Access data, you must start from Access, not from Excel. 

Converting a Worksheet to an Access Table 
You can import the current Excel worksheet to an Access table in a new or existing data
base. After you complete this procedure, the Excel worksheet and imported table will be 
independent of one another (that is, changes to the worksheet in Excel won't affect the 
Access table, and vice versa). 

Open the worksheet you want to convert (in Excel, of course) and then: 

1. Delete any blank rows in the worksheet. Then put the cursor into any cell within 
the worksheet. 

2. Choose Data ~ Convert To Access. 
3. Choose whether' to convert the data to a New Database or an Existing Database 

whose name you supply at the prompt and then click on OK. 

After a brief delay, the Import Spreadsheet Wizard (described in Chapter 17) will 
guide you through the remaining steps, and your new table will appear in the Tables 
tab of the Access database window. You can then use the table as you would any nor
mal Access table. 
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Creating an Access Form or Report from an Excel Worksheet 
You also can create an Access form or report for use with the current Excel worksheet. The 
resulting form or report will reside in the Access database, and the Excel worksheet will be 
linked to a new Access table in that database (that is, changes you make in Excel will update 
the linked table in Access, and vice versa). 

To create the form or report, start from Excel and follow these steps: 

1. Open the worksheet you want to view with the form or report. If your worksheet 
contains any blank rows, delete those rows. Then put the cursor into any cell 
within the worksheet. 

2. To create a form, choose Data ~ MS Access Form. 

Or 

To create a report, choose Data ~ MS Access Report. 

3. If your worksheet isn't already linked to an Access database, you'll see a Create 
Microsoft Access Form or Create Microsoft Access Report dialog box (an example 
appears below). Choose whether to store the form or report in a New Database or 
an Existing Database whose name you supply, choose whether the worksheet has 
a Header Row or No Header Row, and then click on OK. If you choose to create a 
new database, the new database will have the same name as your Excel file. 

C1eate Mic1osoft Access Fmm EJ 
Create form in 

... , ~~4.~:i~~~~~~ 
r £.xisting database 

.[rowse. 

My List Has 

r. Heager row r NQ header row 

4. Follow the Form Wizard or Report Wizard instructions and complete the remain
ing steps. 

Your Excel table will be linked to the Access database, and your new form or report will 

appear in the Forms or Reports tab of the Access database window and on the screen. 
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From Access, you can use the linked table and form or report normally. To use the 
form or report from Excel, click on the View Access Form or View Access Report button 
that appears near the right edge of your worksheet (see Figure 4.11). 

From Access, you can add records to linked Excel worksheets and change records, 
but you cannot delete them. From Excel, you can add and delete worksheet rows 
and change cell data as you would in any normal worksheet. 

To learn more about the AccessLinks add-in program that creates Access forms and 
reports (or to find out what to do if the Data>- MS Access Form and Data >- MS Access 
Report commands don't appear in Excel), look up AccessLinks Forms And Reports in the 
Excel Help Index. See Chapter 7 for more about linking and using Excel worksheets in 
Access. Chapter 11 explains how to use the Form Wizard, and Chapter 12 covers the 
Report Wizard. 

Ready 

Last Name 
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Clozure 
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1Work Pl1 one 
(200)555·98713 

I (205)655·5432 
(2£16)656-1234 
'('xi6)556-4367 
(205)556.f1721 
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Using Access Data from Microsoft Word 
As we mentioned earlier, you can start from Access and use the Office Links feature to 
merge Access data with a new or existing Microsoft Word main document. You also can 
start from Microsoft Word and merge data from an Access table or query into a form let
ter, mailing label, envelope, or catalog main document. Here's one way to do the job, 
starting from a blank document window in Microsoft Word: 

1. Choose Tools >- Mail Merge. The Mail Merge Helper dialog box will appear. 
2. Click on the Create button in the Mail Merge Helper dialog box and select the type 

of main document you want to create (Form Letters, Mailing Labels, Envelopes, or 
Catalog). When prompted, click on the Active Window button. 

3. Click on the Get Data button in the Mail Merge Helper dialog box and then choose 
Open Data Source. 

4. Choose MS Access Databases from the Files Of Type drop-down list in the Open Data 
Source dialog box. Then locate and double-click on the database you want to use. 

S. Click on the Tables or Queries tab in the Microsoft Access dialog box and then double
click on the Access table or query that contains the data you want to use. 

6. Respond to any prompts that appear. When you reach the main document win
dow in Microsoft Word, use the Insert Merge Field button on the Mail Merge 
toolbar to insert the merge fields that contain the data you want to display and 
type any text that should appear between fields; press Enter after inserting fields as 
needed. Figure 4.12 shows the document window after we added fields and some 
text for a form letter. 

7. Start the merge: Choose Tools>- Mail Merge (or click on the Merge Helper button 
on the Mail Merge toolbar) and then click on the Merge button; click on the Mail 
Merge button on the Mail Merge tool bar; or click on the Merge button in the Mail 
Merge Helper dialog box. 

8. Complete the Merge dialog box (shown below) and then click on Merge. Word will 
merge the latest data from your Access table or query with your main document 
and output it to the location you specify in the Merge To drop-down list. 

Moroo 0£1 
Merge To 

MergingROCOfds ·-- - -
r. Q.on't print blank ~nes .men data fields are empty. 
r Erint blark lines when data foelds ate empty 

No Query Options have been set 

Check f_rrors .. I 
!LueiJI Options... j 
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9. Print the results of the merge and close the merged results file without saving it 
(if you merged to a new document). 

10. Save your main document (File>- Save) and close it if you wish (File>- Close). 

The next time you want to merge your main document with the latest Access data, just 
open the main document in Word (File >- Open) and repeat steps 7 through 10 above. 

If you need help setting up merge fields on your main document, click on the Help 
button on the Standard toolbar in Microsoft Word and then click on the Insert Merge 

Field button on the Mail Merge toolbar. Or look up Mail Merge and its subtopics in the 
Microsoft Word Help Index. 

Sharing Access Information via the Internet 
Microsoft Access 97 for Windows 95 has new features for sharing Internet data . Yo11 car1 

• Import data that's already in HTML format. 
• Export an Access table or query to HTML format. 

.... 
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• Use a hyperlink to jump to information on the Web or in other Office programs. 
• Use the new Publish to the Web Wizard to create static or dynamic links between 

an Access database and the Internet. You can even publish "parameter" queries 
that let a person choose the Access data. they'd like to browse. 

Importing and Exporting HTML 
HTML is the special formatting that's often used to prepare data for publication on the 
Internet. HTML controls the appearance of information as it's browsed and includes 
tags for characteristics like balding and font size. Access 97 lets you import data files 
that include HTML code. With a database open, choose File>- Get External Data> 
Import and change the Files o(Type drop down to HTML. Select the .htm file you want 
to import and click OK to start the HTML Import Wizard. 

Exporting an Access table or query to an HTML file is just as easy. First highlight the 
table or query you want to export in the Database window. Then choose File>- Save to 
HTML/Web Formats>- Save to HTML. Access will convert the data to an .htm file and open 
it in an Internet Explorer window. By default, the .htm file is created in \My Documents. 
To find out how to change the HTML template and other details about importing and 
exporting HTML data, see Chapter 7. 

Using the Publish to the Web Wizard 
The new Publish to the Web Wizard lets you publish Access data to the Web with static 
or dynamic output. Static output is published to the Web once and doesn't change until 
you decide to update it. Dynamic output reflects changes made to the Access database 
each time it is browsed. Dynamic output allows users to view data they select by return
ing the results of a query. We'll explore the process of publishing Access data to the 
Web in Chapter 7. 

For Programmers and Techies Onl~ 
Two features in Microsoft Access, Microsoft Office, and other programs for Windows 95 
will dazzle and delight programmers and application developers. These features are OLE 
Automation and Visual Basic for Applications. For a Reader's Digest condensation of what 
these features mean to you, please read on. 
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About Visual Basic for Applications (VBA) 
Visual Basic for Applications (VBA) is a consistent programming language for building 
programs across Microsoft Office, and it replaces the Access Basic language that came 
with Access 2.0. The beauty of VBA is that you can reuse code written for Access in 
Microsoft Excel, Visual Basic, or Project with only minor changes. 

Chapter 25 introduces you to VBA. For online help with the language, look up Visual 
Basic and its subtopics in the Access Help Index. Or go to the Access Help Contents, 
double-click on the Visual Basic For Applications book and then explore the additional 
books and subtopics that appear. 

About OLE Automation 
OLE Automation is a standard technology that programmers use to expose their OLE 
objects to development tools, macro languages, and other applications that support 
OLE Automation. From Access you can use VBA to manipulate OLE Automation objects. 
You also can use OLE Automation to manipulate Access objects from other programs, 
such as Microsoft Excel. 

We'll introduce you to OLE Automation in Chapter 27 of this book. For more infor
mation on the topic, look up OLE Automation and its subtopics in the Access Help Index. 

Where to Go from Here 
This chapter has introduced you to the many ways that Microsoft Windows 95, Microsoft 
Access for Windows 95, and other programs in the Microsoft Office for Windows 95 suite 
can work together to help you get the most from your Access data. It also gave you a bird's 
eye view of the new Access 97 features for working with data from the Internet. In the next 
chapter, you'lllearn how to create instant databases and ready-to-use applications with just 
a few clicks of your mouse. 

What's New in the 
Access Zoo? 
Some data-sharing features such as import 
and export, OLE, and Office Links were 
available in earlier versions of Access 
(although they weren't as easy to use as 
they are in Access 97). The menus and 

tool bars of older Office programs also had 
common commands and buttons. How
ever, all the toolbars and menu bars have 
been revamped to make them easier to 
use. The biggest addition to Access 97 
covered in this chapter is the ability to 
share Access data via the Web. 
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Creating a 
Data ase and Application 

t's termlm logy time again! An appH

cati n is a computer-based syst m 
that lets you perform usefu l tasks, 

such as managing orders, accounts receivable, product inventory, arid other types of 
information. A turnkey application enables you to enter and use information with the 
turn of a key; that is, without worrying about how everything is put together behind 
the scenes. Finally, an Access database is a file that holds all the objects for a single appli
cation, including the tables, forms, reports, queries, modules, and macros. In this chapter 
you'll learn how to create databases and more than 20 different turnkey applications. 

If you haven't tried the hands-on lessons in Chapter 3, you should do so now. Those 
lessons take you through creating a database and turnkey application and give you 
practice using Access Wizards. 

After creating your database, you can use the Database Splitter Wizard (Tools ~ 
Add-Ins~ Database Splitter) to split it into one file that contains the tables and another 
that contains the queries, forms, reports, macros, and modules. A split database can run 
faster than a single-file database over a network because only the table data is kept on 
the server. Form and report designs and other database objects reside on each user's 
local computer so traffic over the network is minimized. See Chapter 18 for details. 
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A Database Is Not a Table 
If you're an experienced "xBASE" user, 
you might think the term database is syn
onymous with the term table. However, 
Access follows the more formal database 
terminology in which database refers to all 
the data plus all the objects you use to 
manage that data. Remember that you 

Getting Started 

don't need to create a new database each 
time you want to create a table or some 
other object. Instead, put all the tables 
and objects that make up a single applica
tion into one database. That way, objects 
that belong together will be stored in the 
same database. 

... 

The first step to creating any application is to set up the database file. Often the best 
method is to start with a blank database if you plan to import or link most of your 
tables from data stored in other computer files (see Chapter 7) or if you're a developer 
who prefers to create most database objects from scratch. 

Beware! Starting with a blank database can be more work than starting with a Wizard
created database of predefined objects. Taking the from-scratch route usually involves 
these general steps: 

1. Create the blank database (see "Creating a Blank Database" in this chapter). 
2. Create, import, or link the tables (see Chapters 6 and 7). 
3. Create data entry forms (see Chapters 11 and 13). 
4. Enter data using data entry forms or datasheet view (see Chapter 8). 
5. Create additional forms, reports, and queries as needed (see Chapters 10 through 13). 
6. Use programming techniques, form buttons, macros, and other tricks to assemble 

the objects into a turnkey application (see Parts Four and Five). 

If you plan to let Access Wizards create your database and application automatically, 
your work is done almost before you start. In fact, you often can get by with just three 
main steps: 

1. Use the Database Wizard to create a database and a turnkey application 
(see "Creating a Database with the Database Wizard" in this chapter). 

2. Enter data (see Chapter 8) . 
3. Print reports as needed (see Chapters 3 and 9). 
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Of course, you might need to tweak the turnkey application throughout its lifetime. 
The rest of this book will show you how. 

By studying the sample applications created by the Database Wizard, you can 
more quickly learn techniques for designing and customizing your own applica
tions. For example, you can study database objects in design view to find out what 
makes those objects tick. You also can study the relationships among tables in the 
database using techniques discussed in Chapter 6. 

Creating a Blank Database 

M#@Q;IQM 
The New dialog 
box lets you cre

ate a blank 
database (Gen
eral tab) or any 

of more than 
20 predefined 

turnkey applica
tions (Data
bases tab). 

To create a blank database 

1. Do one of the following: 

• If you're starting from the Microsoft Access main menu, choose File >- New 
Database or press Ctrl+N or click on the New Database toolbar button. You'll 

see the New dialog box, shown in Figure 5.1. 
• If you're at the Microsoft Access startup dialog box (see Chapter 1), choose Blank 

Database and click on OK. The File New Database dialog box, shown in Figure 5.2, 

will open. Skip to step 3. 

• 
New 6EJ 

[ ~evrew 

~ ~ ~ Prevrew not avarlable 

OK Cancel 
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MitdljjlftW 
Use the File New 
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Type a file name or accept suggested name. Click on Create to create 
the database with the 
specified File name. 

..... 

2. Click on the General tab (if it's not selected already) in the New dialog box and 
then double-click on the Blank Database icon (shown at left). The File New Data

base dialog box will open (see Figure 5.2). 
3. Type the new database file name (or accept the suggested name) in the File name text 

box. Your file name can be any length, and it can include spaces and most punctu

ation marks. Examples: Order Entry, My Videotape Collection, Mom's Database. 
4. Save the database. Access usually suggests that you save the database in a folder named 

My Documents on drive C. To save the database to a different drive or folder, choose 

that drive or folder from the Save in drop-down list. For more details, see "Using the 

File New Database Dialog Box" later in this chapter. 
5. Click on the Create button. 

Figure 5.3 shows the blank database window that appears next. From here you can 

start adding new tables as explained in Chapter 6. 



FIGURE S.3 
The database 

window for 
a new blank 

database 
named Mom's 

Database. 
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Access databases have the file extension .mdb. However, this extension-like that 
l.l.liii _ _. of most other files on your computer-usually is hidden from view. To show file 

extensions in dialog boxes that display file names, right-click on the Start button 
on the Taskbar and choose Explore (or double-click on My Computer on the Win
dows desktop). When the Exploring or My Computer window opens, choose 
View~ Options, click on the View tab in the Options dialog box, deselect (clear) 
Hide MS-DOS File Extensions For File Types That Are Registered, and click on OK. 
Close the Exploring or My Computer window. 

Using the File New Database Dialog Box 
The File New Database dialog box (refer to Figure 5.2) is similar to the Open dialog box 
described in Chapter 1, and the easiest way to learn about this dialog box is to experiment 
with it. These tips will help you choose a location and file name for your database: 

• To choose the computer, drive, or folder where the database should be stored, 
click on the Save in drop-down list button and then click on the appropriate item. 

• To open objects shown in the list below Save in, double-click on the appropri
ate object icon or name. 

• To open the folder that's just above the currently selected folder, click on the 
Up One Level toolbar button in the dialog box; or click anywhere in the list below 
Save in and then press Backspace. 
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To find out the purpose of any tool bar button in a window or dialog box, move your 
mouse pointer to that button and look for the SmartTip near the mouse pointer. 

• To display a list of Favorite databases and folders, click on the Look in Favor
ites toolbar button. The list below Save in will then show your favorite folders and 
databases only. 

• To create a new folder within the current folder, click on the Create New Folder 

toolbar button. In the New Folder dialog box that appears, type a folder name and 
then click on OK. Open (double-click) the new folder if you wish. 

• To enter a drive, directory, and/or file name manually, type the appropriate 
information into the f-ile name text box at the lower-left corner of the File New 
Database dialog box or choose an item from the File name drop-down list. 

Here are some other things you can do in the File New Database dialog box: 

• To change the appearance of the list below Save in, click on the List, Details, or 
Properties toolbar buttons as needed. 

• To explore the current folder (in Windows Explorer), control folder sharing, dis

play folder properties, and more, right-click on an empty area in the list below 
Save in and then choose options from the shortcut menu. 

• To display or change properties for an item selected in the list below Save in or 

control the order in which file names are listed or map a network drive, click on the 
Commands and Settings toolbar button and choose a menu option. 

• To manage an existing database file (for example, cut, copy, delete, rename, or 
view its properties), right-click on that file in the list below Save in and choose an 
appropriate option from the shortcut menu. 

When you're finished using the File New Database dialog box, click on Create (to 
create the database shown in the File Name text box) or click on Cancel (to return 
to Access without creating a database). 

Creating a Database with the Database Wizard 
Chapter 3 explains how to use the Database Wizard to create a turnkey application for 
managing address information. Here's the Cliffs Notes version of the steps to follow for cre
ating any of more than 20 turnkey applications in Access: 

1. Do one of the following: 

• If you're at the Microsoft Access startup dialog box, choose Database Wizard 
and click on OK. 
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• If you're at the main Microsoft Access window, choose File ~ New Database from 
the menu bar or press Ctrl+N or click on the toolbar's New Database button. 

2. Click on the Databases tab (see Figure 5.4) in the New dialog box and then scroll to 
the icon for the type of information you want to manage. When you've found the 
icon you want to use, double-click on it and the File New Database dialog box will 
open (refer to Figure 5.2). 

3. Type a database name (or accept the suggested name) in the File name text box. If 
necessary, choose a drive and folder from the Save in drop-down list. Finally, click 
on the Create button. 

When you complete step 3, an empty database window will appear briefly, followed 
by the first Database Wizard dialog box. Here's how to finish the job: 

4. Read the description of the new database in the first Database Wizard dialog box and 
then click on Next to open the second Database Wizard dialog box (see Figure 5.5). 

You'll find standard buttons at the bottom of each Wizard dialog box. These include 
Cancel (cancels the Wizard and returns to wherever you were before you started the 
Wizard), Back (returns you to the previous Wizard dialog box), Next (continues to 
the next Wizard dialog box), and Finish (goes to the last Wizard dialog box and 
assigns default settings for any dialog boxes you skip). 

• 
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5. Use the guidelines below to choose which fi elds to include in each table and to tell 
the Wizard whether to include sample data. When you're finished , click on Next to 
continue with the third Wizard dialog box. 

• To choose a table to work with, click on the table's name in the tables list at 
the left . Then, in the fields list .at the right, select (check) the fields you want to 
include and deselect (clear) fields you want to omit from the table. Optional 

fields are shown in italics. Required fields are checked initially and shown in 
normal (roman) type. (You won't be allowed to clear required fi elds.) Repeat 
this step as n eeded. 

• To include sample data, select the box next to Yes, include sample data. To omit 
the sample data, deselect that box. Including sample data can help you learn to 

use the database more quickly. Once you've played with the database a bit, you 
can delete the sample data or delete the database itself and create a new one 
without sample data. 

6. Choose a background color and general style for database forms (also called screen 
displays) in the third Database Wizard dialog box. The left side of the dialog box 

will show a sample form that refl ects your current choice. Click on the Next button 
to continue. 
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7. Choose a style for printed reports in the fourth Database Wizard dialog box. Again, 
the sample area will reflect your choice. Click on Next to continue. 

8. Specify a title for your database and pick a picture for use on reports in the fifth 
Wizard dialog box. (See Chapter 3 for pointers on choosing sample pictures.) After 
making your selections, click on Next to go to the last dialog box. 

9. Choose whether you want to start the database after the Wizard builds it in the last 
dialog box. If you check Yes, Start The Database, you'll be taken to a Switchboard 
form that lets you work with your database immediately; if you clear this option, 
you'll go directly to the database window, bypassing the Switchboard. You also can 
choose whether to display online help about using a database. Again, refer to Chap
ter 3 if you need more details. 

10. Click on the Finish button to create the database and its turnkey application form, 
named Switchboard. 

That's all there is to it. Wait patiently for a few moments while the disk drive whirls 
and the Database Wizard creates an entire database of tables, forms, reports, and other 
objects. (You'll see progress bars as the Wizard completes its tasks.) When the Wizard 
finishes its job, you'll either see the main Switchboard form for your database or the 
database window, depending on your choice in step 9. Figure 5.6 shows the sample 
Switchboard form for the Book Collection database, and Figure 5.7 shows the Tables tab 
on the database window for this same database. 

Now you're ready to explore your new database and fill it with useful information. 

• 
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The next section explains a little about each database that the Wizard can create auto
matically. For information on three other sample database applications that come with 
Access, look up Sample Databases And Applications in the Access Help Index. Not sure how 
to navigate the database window? See Chapter 1 for help. Finally, refer to Chapter 3 for 
pointers on creating a new turnkey application. 

About the Sample Databases 
If you already have an application in mind, Access can probably set it up for you auto
matically. The Database Wizard can create these business and education databases: 

Blank Database 

Contact Management 

Event Management 

Inventory Control 

Membership 

Resource Scheduling 

Students and Classes 

Asset Tracking 

Donations 

Expenses 

Ledger 

Order Entry 

Service Call Management 

Time and Billing 
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and these personal and household databases: 

Blank Database 

Book Collection 

Music Collection 

Recipes 

Wine List 

Address Book 

Household Inventory 

Picture Library 

Video Collection 

Workout 

The following sections describe each database the Database Wizard can create and 
Jist key tables, forms, and reports in each database. (Pay special attention to the Key 
Reports in each Jist because they give you clues about the kind of information you can 
get out of the database.) The brief descriptions presented here can help you decide 
which databases you can use right out of the box and which you can use as a starting 
point for your own custom databases. 

Ha ther tba o lis ting every table, form, and report in each database, we've described 
key objects only. ln general, you should use the Switchboard forms-and not the data
bas window- to maiotain data, fill in forms, and print reports in these databases. 
Certain reports, such as invoices and purchase orders, aren't listed in the Key Reports 
sections below because you must click on a button on a form in order to preview and 
print those reports properly. You'll find an asterisk followed by the type of report 
printed-for example, (*Invoice)-next to the names of key forms that have special 
Preview/Print buttons. 

You'll also find these databases-complete with sample data-on the CD-ROM 
disk that accompanies this book. See Appendix B for details. 

Blank Database 
This database is for Access application developers and other people who want to create 
objects from scratch or to import or link objects from other computer databases (see 
Chapter 7) . 

Key Tables None. 
Key Forms None. 
Key Reports None. 
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The next section explains a little about each database that the Wizard can create auto
matically. For information on three other sample database applications that come with 

Access, look up Sample Databases And Applications in the Access Help Index. Not sure how 
to navigate the database window? See Chapter 1 for help. Finally, refer to Chapter 3 for 
pointers on creating a new turnkey application. 

About the Sample Databases 
If you already have an application in mind, Access can probably set it up for you auto

matically. The Database Wizard can create these business and education databases: 

Blank Database 

Contact Management 

Event Management 

Inventory Control 

Membership 

Resource Scheduling 

Students and Classes 

Asset Tracking 

Donations 

Expenses 

Ledger 

Order Entry 

Service Call Management 

Time and Billing 
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and these personal and household databases: 

Blank Database 

Book Collection 

Music llection 

Recipe 

Wine List 

Address Book 

House.h ld Inventory 

Picture Library 

Video ,oJiection 

Workout 

The following sections describe each database the Database Wizard can create and 
list key tables, forms, and reports in each database. (Pay special attention to the Key 
Reports in each list because they give you clues about the kind of information you can 
get out of the database.) The brief descriptions presented here can help you decide 
which databases you can use right out of the box and which you can use as a starting 
point for your own custom databases. 

Hather than listing every table, form, and report in each database, we've described 
key obje ts only. ln genera l, you should use the Switchboard forms-and not the data
bas window-to maintaln data, fill in forms, and print reports in these databases. 
Certain reports, such as invoices and purchase orders, aren't listed in the Key Reports 
sections below because you must click on a button on a form in order to preview and 
print those reports properly. You'll find an asterisk followed by the type of report 
printed-for example, (*Invoice)-next to the names of key forms that have special 
Preview/Print buttons. 

You'll also find these databases-complete with sample data-on the CD-ROM 
disk that accompanies this book. See Appendix B for details. 

Blank Database 
This database is for Access application developers and other people who want to create 
objects from scratch or to import or link objects from other computer databases (see 
Chapter 7). 

Key Tables None. 
Key Forms None. 
Key Reports None. 
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Address Book 
Use the Address Book database to keep track of names, addresses, phone numbers, and 
other vital statistics. Chapter 3 took you on a step-by-step tour of this database and showed 
you how to customize it. 

Key Tables Addresses. 
Key Forms Addresses. 
Key Reports Addresses By Last Name, Birthdays This Month, Fact Sheet, Greeting 
Card List. 

Asset Tracking 
Use the Asset Tracking database to track information about your company's assets. 
Great for businesses that own valuable stuff! 

Key Tables Asset Categories, Assets, Depreciation, Employees, Maintenance, Status. 
Key Forms Asset Categories, Assets, Employees, Status. 
Key Reports Assets By Category, Assets By Date Acquired, Assets By Employee, 
Depreciation Summary, Maintenance History. 

Book Collection 
Bibliophiles, students, teachers, and librarians will love the Book Collection database, 
which lets you keep track of your favorite books, authors, and quotations. 

Key Tables Authors, Books, Quotations, Topics. 
Key Forms Authors, Books, Quotations, Topics. 
Key Reports Quotes By Author, Titles By Author, Titles By Topic. 

Contact Management 
Everyone who hands you a business card or buys you lunch is a potentially valuable 
contact. Use the Contact Management database to record information about your con
tacts, track phone calls you make to them, and dial calls automatically using your 

computer's modem. 

Key Tables Calls, Contact Types, Contacts. 
Key Forms Contact Types, Contacts. 
Key Reports Alphabetical Contact Listing, Weekly Call Summary. 



Donations 

Event 
Mangement 

Expenses 

Household 
lnventor_y 

ABOUT THE SAMPLE DATABASES 1145 

Donations 
Charitable organizations, nonprofit corporations, and starving book authors can use 
the Donations database to track contributions and fund-raising campaigns. 

Key Tables Contributors, Donation Campaign Setup, Pledges. 
Key Forms Campaign Information, Contributors. 
Key Reports Campaign Summary, Pledge Listing, Unpaid Pledges. 

Event Management 
Managing administrative details for large events such as seminars, training classes, 
meetings, and concerts is a snap with the Event Management database. 

Key Tables Attendees, Employees, Event Types, Events, Fee Schedules, My Com
pany Information, Payment Methods, Payments, Registration. 
Key Forms Attendees (*Invoice), Employees, Event Types, Events, Fee Schedules, 
My Company Information, Payment Methods. 
Key Reports Attendees Listing, Sales By Employee, Sales By Event. 

Expenses 
Filling out employee expense reports is easy when you use the Expenses database to do 
the job. Throw those tedious paper forms in the recycling bin and fill out those expense 
reports quickly on your computer. 

Key Tables Employees, Expense Categories, Expense Details, Expense Reports. 
Key Forms Expense Reports By Employee (*Expense Report), Expense Categories. 
Key Reports Expense Report, Expense Report Summary By Category, Expense 
Report Summary By Employee. 

Household Inventory 
Perfect for insurance purposes, the Household Inventory database helps you keep a 
room-by-room inventory of every valuable item in your home. (Be sure to keep a backup 
copy of this database in your bank safety deposit box or some other place that will be 
secure in case a natural-or unnatural-disaster strikes.) 

Key Tables Categories, Household Inventory, Rooms. 
Key Forms Categories, Household Inventory, Rooms. 
Key Reports Inventory By Category, Inventory By Room, Inventory By Value, 
Inventory Details. 
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Inventory Control 
The Inventory Control database offers everything you'll need to manage your com
pany's product inventory. 

Key Tables Categories, Employees, Inventory Transactions, My Company Infor
mation, Products, Purchase Orders, Shipping Methods, Suppliers. 
Key Forms Categories, Employees, My Company Information, Products 
(*Purchase Order), Shipping Methods, Suppliers. 
Key Reports Product Cost Comparisons, Product Purchases By Supplier, Product 
Summary, Product Transaction Detail. 

Ledger 
Use the Ledger database to maintain a chart of accounts and transactions against each , 
account. 

Key Tables Account Types, Accounts, Transactions. 
Key Forms Account Types, Accounts, Transactions. 
Key Reports Account Summary, Summary By Account Type, Transaction Listing. 

Membership 
The Membership database is perfect for organizations that must track information 
about members, committees, and dues payments. 

Key Tables Committees, Members, Member Types, My Organization Informa
tion, Payment Methods, Payments. 
Key Forms Committees, Member Types, Members (*Invoice), My Organization's 
Information, Payment Methods. 
Key Reports Alphabetical Member Listing, Committee Members, Invoice, List. 
ing By Membership Type, Outstanding Balances. 

Music Collection 
If you're a music fan with many recordings in your library, you can use the Music Col 
lection database to store information about your albums/CDs, favorite recording 
artists, and the locations of your best-liked music. 

Key Tables Music Categories, Recording Artists, Recordings, Tracks. 
Key Forms Music Categories, Recording Artists, Recordings. 

I 
Key Reports Albums By Artist, Albums By Category, Albums By Format, Tracl 
By Album. 
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Order Entry 
If your business processes orders from customers, you'll want to try the Order Entry 
database, which has all the tools you need for managing customer, product, order, pay
ment, and shipping information. 

Key Tables Customers, Employees, My Company Information, Order Details, 
Orders, Payment Methods, Payments, Products, Shipping Methods. 
Key Forms Employees, My Company Information, Orders By Customer (*Invoice), 
Payment Methods, Products, Shipping Methods. 
Key Reports Customer Listing, Receivables Aging, Sales By Customer, Sales By 
Employee, Sales By Product. 

Picture library 
Photography buffs can use the Picture Library database to list and describe pictures on 
each roll of film in your library. Great for tracking the thousands of shots you took at 
the Louvre! 

Picture Library Key Tables Photo Locations, Photographs, Rolls Of Film. 

Recipes 

Resource 
Scheduling 

Key Forms Photo Locations, Rolls Of Film. 
Key Reports Photographs By Date Taken, Photographs By Film Roll, Photographs 
By Location, Photographs By Subject. 

Recipes 
If you use the Recipes database, you'll never have to wonder where you stashed your 
recipes for Cheez Whiz a Ia Orange and Twinkies Au Gratin. This database helps you 
plan, shop for, and whip up nourishing meals. 

Key Tables Food Categories, Ingredients, Recipes. 
Key Forms Food Categories, Ingredients, Recipes. 
Key Reports Recipe Details, Recipes (Sorted Alphabetically), Recipes By Category. 

Resource Scheduling 
Use the Resource Scheduling database to schedule the use of company resources such as 
meeting rooms, cars, overhead projectors, airplanes, and other equipment, and to assign 
each resource for use with a certain customer at a specific time. 

Key Tables Customers, Resource Types, Resources, Schedule, Schedule Details. 
Key Forms Customers, Reservations, Resources Types, Resources. 
Key Reports Resource Schedule, Resources By Type. 
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Service Call Management 
Service companies that send technicians to customer sites can use the Service Call Manage
ment database to track customers, employees, work orders, invoices, payments, and more. 

Key Tables Customers, Employees, My Company Information, Parts, Payment 
Methods, Payments, Workorder Labor, Work-order Parts, Workorders. 
Key Forms Employees, My Company Information, Parts, Payment Methods, 
Workorders By Customer (*Invoice). 
Key Reports Finished Workorders In House, Revenue Entered By Employee, Sales 
By Month, Unfinished Workorders, Workorder Summary. 

Students and Classes 
Teachers and school administrators will !ike using the Students and Classes database to 
track students, classes, assignments, and grades. 

Key Tables Assignments, Classes, Departments, Instructors, Students. 
Key Forms Classes, Departments, Instructors, Students. 
Key Reports Class Listing By Department, Class Results Summary, Results By 
Assignment, Results By Student, Student Schedules, Students. 

Time and Billing 
The Time and Billing database can help consultants, lawyers, and other professionals 
who bill their time by the hour to manage their businesses more efficiently. 

Key Tables Clients, Employees, Expense Codes, My Company Information, 
Payment Methods, Payments, Projects, Time Card Expenses, Time Card Hours, 
Work Codes. 
Key Forms Clients (*Invoice), Employees, Expense Codes, My Company Infor
mation, Payment Methods, Time Cards (*Time Sheet), Work Codes. 
Key Reports Client Billings By Project, Client Listing, Employee Billings By 
Project, Project Billings By Work Code. 

Video Collection 
The Video Collection database can help film and television aficionados avoid being 
buried in the brown tape of a large video library. Use this database to store information 
about videotaped programs and movies. 

Key Tables Actors, Program Types, Video Programs, Videotapes. 
Key Forms Actors, Program Types, Videotapes. 
Key Reports Alphabetical Program Listing, Program Listing By Actor, Program 

Listing By Type. 
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Wine list 
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Key Tables Wine List, Wine Purchases, Wine Types. 
Key Forms Wine List, Wine Types. 
Key Reports Wine By Type, Wine By Vintage, Wine By Vintner. 

Workout 
Tracking each activity in your exercise regimen and each day's progress toward physical 
perfection is no sweat with the Workout database. 

Key Tables Exercise Types, Exercises, Units, Workout Details, Workout History, 
Workouts . 
Key Forms Exercise Types, Exercises, Units, Workout History, Workouts. 
Key Reports Exercise Listing By Type, Workout History By Exercise, Workout 
Stats By Month. 

Changing the Database Properties 
You can view, change, and define properties for your database by choosing File>- Database 
Properties from the menu bar, or by right-clicking on the database window's title bar (or 
any gray area on the database window) and choosing Database Properties. Figure 5.8 
shows the database properties for an Order Entry database that we created with the Data
base Wizard. Here's a description of the tabs in the dialog box: 

General Displays general information about the database. 
Summary Displays and lets you change summary information, including a Hyper
link base path (see Figure 5.8). 
Statistics Displays file statistics, including date created, modified, accessed, and 
printed. 
Contents Lists all the tables, queries, forms, reports, macros, and modules in the 
database. 
Custom Displays and lets you add and delete custom properties that can help 
you find a database quickly. 

Click on the appropriate tab in the Properties dialog box; then view and change the 
properties as needed. When you're finished, click on OK to return to the database. 
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Why customize database properties? Because you can use them later to find a data
base if you've forgotten its file name or location. To look for and open a database based 
on its properties, choose the File ,... Open commands in Microsoft Access, Word, or 
Excel. When the Open dialog box appears, click on the Advanced button, specify the 
properties you want to look for in the Define More Criteria area of the dialog box, and 
then click on the Find Now button. 

To learn more about database properties, search for the Properties, Database topic and 
its subtopics in the Access Help Index. For details about searching for specific database 
properties in the Open dialog box, look up Advanced Find Dialog Box in the Help Index. 

Where to Go from Here 
Once you've set up a database, you can start using it. For your next stop, go to the fol
lowing chapters in this book: 

• If you created a blank database and none of your data exists on a computer, con

tinue with Chapter 6. 
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• If you created a blank database and some or all of your data exists on a computer, 
continue with Chapter 7. 

• If you used the Database Wizard to create a database, con tinue with Ch apter 8. 

What's New in the 
Access Zoo? 
Creating databases is easier and more 
flexible now than it was in Access 7. Major 
improvements include 

• The Database Wizard has new easy
to-use features that adapt a template 
to your own needs. 

• The Intelligent Assistant recognizes 
the field types for columns you add 
to a table in Datasheet view, even the 
new Hyperlink field type . 
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