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Personalizing Access 

ou can tailor your Access work envi­
ronment to your own requirements 
and working style. If you're happy with 

the way Access is working now, there's no need to change the default settings and you 
should feel free to skip this chapter. But if you'd like to learn how to tweak things a bit, 

read on. 
Note that other chapters in this book explain how to customize the features described 

in Table 15.1, so we won't repeat those discussions here. 

Your 
You can personalize many aspects of your Access work environment by following the 

general steps below: 

1. Open a database (if one isn't open already) and choose Tools~ Options. You'll see 

the Options dialog box shown in Figure 15.1. 
2. Click on a tab to select a category. (For your convenience, we've arranged the fol­

lowing sections in alphabetical order according to the category of options that 

each tab controls.) 
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I 

TO CUSTOMIZE 
THIS ... 

ActiveX Controls 

Menus 

Security 

Tool bars 

Switchboards 

1#3MIJII 

USE THESE OPTIONS ... 

Tools > ActiveX Controls 

View> Toolbars > Customize 

Tools > Security 

View > Toolbars 

Tools >Add Ins > 
Switchboard Manager 

AND SEE THIS 
CHAPTER OR HELP 

INDEX TOPIC 

Look up ActiveX 
Controls subtopics in 
the Access Help Index. 

24 

18 

23 

21 

Choosing 
Tools > Options 
takes you to the 
Options dialog 

box, where you 
can change 

Options · IDES 

numerous 
default settings 

in Access. 

· ·. D~tasheet 
View 

I Tab.les{Queriesj· Fonils/Rep.orts l I General .. Hyperlinks/HT~ll I 

Coudition;Cotumn 

Module 
Edit/Find 

OK Cancel 

Advanced 
Keyboard 

" 



lddij;lltf'M 
The Advanced 

tab in the 
Options 

dialog box. 
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3. Change options, as described in the sections that follow. Depending on the option 
you're setting, you can type a value, select a value from a drop-down list, select an 
option button, or select (check) or deselect (clear) a checkbox. Selecting a checkbox 
activates the associated option (that is, it says "Yes, I want this option"); deselecting 
the checkbox deactivates the option (that is, it says "No, I don't want this option"). 

4. Click on OK when you're finished making changes. 

For more about the options discussed in the following sections, choose Tools > 
Options and click on the appropriate category tab. Next, click on the ? button at the 
upper-right corner of the Options dialog box and then click on the option you're inter­
ested in; or right-click on the option name and choose What's This?; or click in a text 
box or combo box and press Shift+ Fl. You also can look up topics under Default Settings 

in the Access Help Index. 

s 
The Advanced options (see Figure 15.2) control how Access handles data in a multiuser 

environment and how it handles OLE and DDE operations. 

Options ' 1.113 

View j General j Hyperlinl<sfHTMLj Edit/Find 

Datasheet J T abies/Queries j Forms/Reports j t~odule 

Default Record Lod"ng 

r. flo\o<~l 
I"' AU Records 

( EQ.ited Record 

l Command·Llne Arguments: 

Keyboard 
Advanced 

[ Conditional Compilation Arguments: 

OLE/DDE Ti!!leout (sec): ro- ' PrQject Name: 
r;:;---- ; J,-~1-or-,-th-w-in-,..d ------

Nk[mber of Update Retries: 12 

ODBC Refresh lnterY.al (sec): 11500 

B.efresh Interval (sec): p;o-
UR.date Retry Interval (msec): izso 

" 



620 CHAPTER 15 • PERSONALIZING ACCESS 

ldrl@lftil 
The Datasheet 

tab in the 
Options 

dialog box. 

The OLE/DDE options are as follows: 

DDE Operations Select or clear options to choose whether to Ignore DDE Requests 
from other programs and whether to Enable DDE Refresh at the interval given by the 
OLE/DDE Timeout (Sec) setting. 

OLE/DDE Timeout (Sec) Specify the interval, in seconds (from 0 to 300), that 
Access will wait before retrying a failed OLE or DDE operation. 

See Chapter 18 and the online Help for details about these multiuser options on the 
Advanced tab: Default Record Locking, Default Open Mode, Number Of Update Retries, 
ODBC Refresh Interval (Sec), Refresh Interval (Sec), and Update Retry Interval (Msec). 

The Datasheet options, shown in Figure 15.3, let you change the default appearance of the 
datasheet view when you first open a table or query. Most options are self-explanatory, so 
we won't trouble you with reading through the details about them. However, you might 
want to know about the Show Animations option, which lets you enable or disable the ani­
mated insertion and deletion of records and columns in datasheets. 

You can override the Default Colors, Default Gridlines Showing, Default Font, Default 
Column Width, and Default Cell Effect settings in data-sheet view. To do so, choose the 
Font, Cells, and Column Width options on the Format menu, or use the Formatting 
(Datasheet) toolbar, as explained in Chapter 8. 

Options , DEi 

View 
Keyboard 
Datasheet 

General, 
Module 

T abies/Queries 

jOWhite ::J 17 ~erlical 

Edit/Find 
Adv'!nced 

Forms/Reports 

::J 
Qelault Column Width: j1" 

Si;e; 

3 (103 

r Raised 

r Jionl<en 

17 ShoJ!iAnimations 

I 
" 
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Changing Edit/Find 0 

l#l3Q;lllll 
The Edit/Find 

tab in the 
Options 

dialog box. 

Use the Edit/Find options, shown in Figure 15.4, to choose the default method for 
doing a Find or Replace operation, to control whether to confirm various types of 
changes, and to control the size of value lists when you use filter by form. 

The Default Find/Replace options are listed below. You can override these settings in 
the Find In Field (Edit > Find) or Replace In Field (Edit> Replace) dialog boxes, as 

explained in Chapter 9. 

Fast Search Searches the current field and matches the whole field. 
General Search Searches the current field and matches any part of the field. 
Start Of Field Search Searches the current field and matches the beginning char­

acter or characters in the field. 

The checkbox options below Confirm let you control whether Access displays a 
confirmation message when you change a record (Record Changes), delete a database 
object (Document Deletions), or run an action query (Action Queries). It's a good idea 

to leave these options checked. 
The options below Filter By Form Defaults For Database control which fields supply 

values when you use the Filter By Form feature (see Chapter 9), and how many rows to 
display in a filter-by-form list. These options affect the current database only, and you 
can set different defaults for other databases. You can override the options for a given 
filter-by-form operation, as explained in Chapter 9. To speed up filter-by-form opera­
tions, limit the Filter By Form Defaults settings to local indexed fields and reduce the 

number of records read. 

Options o 613 

Keyboard 

Datasheet 
View 

l 
l 
l 

Module 
T obles/Queries 

General 

Advanced 
Forms/Reports 

Edit/Fi~d 

.. 
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l#d@IIH 
The Forms/ 

Reports tab in 
the Options 
dialog box. 

s 
Use the Forms/Reports options, shown in Figure 15.5, to control the default templates 
used for form and report designs and to define the selection behavior when you drag 
the mouse pointer to select controls in form and report design view. 

The Forms/Reports options are 

Selection Behavior Choose Partially Enclosed to have Access select controls that 
are even partially contained within the frame. Choose Fully Enclosed to have 
Access select only controls that are completely contained within the frame you 
draw while dragging the pointer. 

Form Template The default is Normal, a built-in, general-purpose template that 
Access uses to create an AutoForm or blank form. You can specify any existing 
form in the database as the form template, if you wish. If you specify a form that 
doesn't exist in the database, Access will use the built-in Normal form template. 
Report Template As with forms, the default report template is Normal, but you 
can specify any existing report in the database as the report template. Access uses 
this template to create an Auto Report or blank report. If you specify a report that 
doesn't exist in the database, Access will use the built-in Normal report template. 

View j General I Hyperlinks/HH•ld Edit/Find 

Datasheet j T-obles/Queries Forms/Reports j ~lodule 

r. &.~:.:::~::.c..':::.:.'c::";.':::.;; 
C F!!.IIY Enclosed 

E.orm Template: 

!Normal 

Report TemPlate: 

r Always Use ~vent Procedures 

Keyboard 

Advanced 

.. 
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Always Use Event Procedures When this option is selected (checked), Access 
will bypass the Choose Builder dialog box and go directly to the Module window 

after the builder button is clicked on a property sheet. 

<101> "1!1" IE. 

Form and report templates define whether to include a form or report header and 
footer, whether to include a page header and footer, the dimensions of each section, 
and the default properties for each control. A template does not create controls on a 

new form or report. 

When designing a form or report, you can override the default settings in many 
ways. For example, you can change the default properties for new controls that 
you add to a form or report in design view, and you can use AutoFormat styles to 
format all or part of a design. See Chapter 13 for complete details about designing 

forms and reports. 

If you'd like to use custom control settings for all new forms or reports that you 
design, customize the properties for each control to your liking. Then save the design 
and define it as a template in the Form Template or Report Template option setting 

described above. 

en ns 
The General options (see Figure 15.6) let you change these default settings: 

Print Margins Use the Print Margins options to assign default Left Margin, Right 
Margin, Top Margin, and Bottom Margin settings for new reports and forms (the 
settings have no effect on existing forms and reports). Initially all the margins are 

one (l) inch wide. 
To change the margin settings in an existing form or report, open the form or report 
in design view, choose File >- Page Setup, click on the Margins tab, change the Top, 
Bottom, Left, and Right settings as needed, and then click on OK (see Chapter 9). 
Default Database Folder Specify the folder in which Access will store or search 
for databases. The default is the dot (.) which stands for the default Access work­
ing directory, a folder named My Documents. (If you rename the My Documents 
folder in Windows 95 later, Windows 95 will adjust the appropriate Registry set­

tings to point to the renamed folder automatically.) 
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lildQ:IIIU 
The General tab 

in the Options 
dialog box. 

Options 613 

Datasheet I T ables,{Queries l Forms/Reports I Module 
View General !Hyperlinks/HT~!Lj Edit,{Firid 

Q.efault Database Folden 
!,_eft Margin: je:V1y Documents 

BJght Margin: 
[l!ew Database Sort Order: 

IopMargin: ]General 

!l_ottom f"largin: jl'' 

OK 

Advanced 
Keyhoaid 

New Database Sort Order Choose the language used for alphabetic sorting of 
new databases. Options include General (for English), Traditional Spanish, Dutch, 
and several other languages. To change the sort method for an existing database, 
make the change here (in the New Database Sort Order text box) and then com­
pact the existing database as discussed in Chapter 17. 

Provide feedback with sound When this option is selected (checked), Access 
will play sounds when events like completion of printing happen. 

ngi in l Options 
The Hyperlinks/HTML options let you customize the way hyper links are shown on the 
screen. You can also set options for connecting with HTML data and ActiveX Server data. 

• 
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Hyperlink Color Tells Access what color to use for showing hyperlinks that have 
not yet been followed. 

Underline Hyperlinks When checked, has Access display hyperlinks with 
underlines. 

Followed Hyperlink Color Specifies the color on screen of hyperlinks that have 
been followed (jumped to). 

Show Hyperlink Addresses in Status Bar When checked, has Access show the 
hyperlink address for a hyperlink that is clicked on. (Hyperlinks can appear as a 
shortcut name, instead of an address.) 

HTML Template Names a template for HTML: files that are created by export­
ing to HTML format or using the Publish to the Web Wizard. An HTML template 
has specifications for file headers, footers, and other visual elements. 
Data Source Name Specifies the name of the Open Database Connectivity 
(ODBC) connection used to query Access data for dynamic Web pages. 
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1#(3@100!11 
The Keyboard 
options in the 

Options 
dialog box. 

User to Connect As The user name for connecting to the ODBC data source 

named above. 
Password The password for the above user name. 
Server URL The location of the ActiveX Server Page (ASP) file on the Web server. 
ASP files are used with Microsoft Internet Information Server 3.0 or later. 
Session Timeout (min) Sets a limit in minutes for how long a Web session can 

remain inactive before it is timed out (terminated). 

You can get more detailed information on ODBC data connections, ASP files, and 
HTML templates from the Office Assistant. Enter any of these topics in the search box 
of the Assistant and press Enter. Then click on your choice in the list that appears. 

ngi s 
The Keyboard options, shown in Figure 15.7, let you control how the Enter key, arrow 
keys, Tab key, and insertion point behave when you use the keyboard to move within 

or between fields in a form or datasheet. 

Move After Enter Determines what happens when you press Enter in a field. Your 
options are Don't Move (Enter has no effect), Next Field (Enter moves the cursor to 
the next field), or Next Record (Enter moves the cursor to the first field in the next 

record). 
Arrow Key Behavior Choose Next Field if you want the cursor to move to 
another field when you press f- or ---7, or choose Next Character if you want the 
cursor to move within the field when you press those keys. If Next Field is 

selected, you can press F2 and then f- or ---7 to move the cursor within a field. 

Datasheet 

View 
Keyboard 

: t·~oveAfterEnler 
r Do!)'tMove 

" ~~~~fe:e.ii! 

T abledQueries 
General 
Mod•Jie 

F01ms/Reports 

Edit/Find 
Advanced 

r Cyrsor Stops at First/Last Field 
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Behavior Entering Field Determines what happens when the cursor lands in a 
field. Your options are Select Entire Field, Go To Start Of Field, or Go To ~nd Of Field. 
Cursor Stops At First/Last Field Determines what happens in a datasheet when 
you press the f- key in the first field of a row or the ~ key in the last field of a 
row. Select (check) this option to have the cursor stay in the current field, or dese­

lect (clear) it to move the cursor to the previous or next record. 

When designing a form, you can control the behavior of the Enter key in text boxes 
(that is, Text and Memo fields). To do this, open the form in design view, open the property 
sheet, and click on the Other tab on the property sheet. Next, select the text box control, 
and then change the Enter Key Behavior property either to Default (so that it uses the Move 
After Enter setting discussed above) or to New Line In Field (so that pressing the Enter key 
moves the cursor to a new line in the field). To simplify entry of multiple text lines in a 
Memo field, the control's Enter Key Behavior is initially set to New Line In Field. If you 
choose Default instead, you typically must press Ctrl+Enter to enter a new line in the 

Memo field's text box. 

u s 
The Module Design options, shown in Figure 15.8, determine the default characteristics 
of the module design window used for creating Visual Basic procedures and functions 

(see Chapter 25). 
As Figure 15.8 shows, you can change colors and font used for your code, various 

coding options, how code is displayed in the Module window (Code View), and some 
settings that apply to the Current Database Only. For more about using and customiz­
ing the Module window, see Chapter 25 and the online Help for the Module tab, or 

type Modules in the search box of the Office Assistant. 

Options 
Use the Tables/Queries options (see Figure 15.9) to choose defaults for new table fields 

and indexes and to control default behavior in the query design window. 

The Table Design options are 

Default Field Sizes Lets you specify the default field size for newly created text 
and number fields in table design view. Specify a Text field size from 0 to 255; 

choose a default Number field size from the Number drop-down list. 
Default Field Type Lets you choose the default field type for newly created 

fields in table design view. 
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lit3Q;liiJ:I 
The Module tab 

in the Options 
dialog box. 

li@ljiliBJI 
The Tables/ 

Queries tab in 
the Options 
dialog box. 

Options "' DEl 
View l General jHyperlinks/HTr~d 

Datasheet l Tables/Queries l Forms/Reports 

Edit/Find 
~lodule 

Te;s_t Area: 17 A;tto Indent 

P' Auto S~tntax Check 

Keyboard 

Advanced 

I:~Bllt\1 WiJ 
Fo[eground: !Automatic ~ 

P' Rll_quire Variable Declaration 

17 <;;_ompile on Demand 

17 AutQ.list Members 
17 Auto Q.uick Info 

P' Auto Q,ota .Tips 

[ackground: !Automatic ~ 
indicator: !Automatic ~ 

IabWidth: r 

OK Cancel 

Keyqoard Module l P.dv.:~nced 

View General I Edit/Find 

Datasheet T abies/Queries l Forms/Reports 

.Q.efaOJit Field Type: 

jrext 

Number: j Long Integer :::J ,<\.OJto!ndex on Import/Create: 

QlJery Design 

P' .9_how hble Names 

r iJ~,JtputAitFie!ds 

P' Enable .AutoJoin 

It D ;key;code;num 

01 
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Autolndex On Import/Create Lets you specify field names that are indexed auto­
matically when you first create them in table design view or when you import them 
from an external file. The Indexed property on the General tab of the table design 

window will display Yes (Duplicates OK) for automatically indexed fields. 

In the Autoindex On Import/Create text box, enter the beginning characters or 

ending characters that the automatically indexed field names should contain, and 
separate each field name (or partial field name) with a semicolon (;). Example: the 
Autoindex On Import/Create setting shown in Figure 15.9 will cause Access to auto­

matically index field names such as ID, MyiD, KeyField, Codel, and AutoNum. 

Each table can have up to 32 indexes. You're likely to bump up against that 32-
index limit rather quickly if you include many field names in the Autolndex On 
Import/Create option or if many fields that you create or import include the field 

names listed in the Autolndex On Import/Create text box. 

The Query Design options are 

Show Table Names Lets you display or hide table names in the QBE grid. To over­

ride this setting, choose View > Table Names in the query design window. 
Output All Fields When selected, all fields in a query's underlying tables or que­
ries appear when the query is run; when deselected only the fields added to the QBE 
grid appear. To override this setting, change the query's Output All Fields property. 
Enable Autojoin Lets you choose whether to create automatic inner joins 
between two tables that you add to the query design window. Access can create an 
inner join for tables if those tables are already joined in the Relationships win­
dow, or the tables contain fields that have the same field name and the same or 
compatible data type in each table. Even if you disable automatic joins, you can 

create them manually in the query design window. 
Run Permissions Choose Owner's to run new queries with the owner's permis­
sions, or choose User's to run new queries with the current user's permissions. 
These permissions are important on secured databases. To view or change a query's 
owner, choose Tools > Security> User And Group Permissions from the menus 
and then click on the Change Owner tab. To override the query's default run per­
missions, open the query in design view and change its Run Permissions property. 

See Chapter 6 for details about designing tables, Chapter 7 for more information 
about importing tables, Chapter 10 for more about queries, and Chapter 18 for tips on 

networking and security. 
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I#HMidl•J 
The View tab 

in the Options 
dialog box. 

ns 
Use the View options, shown in Figure 15.10, to control the appearance of the database 
window and macro design windows and to choose whether the status bar and startup 

dialog box appear. 

Status Bar Lets you display or hide the status bar. (Your life will be easier if you 
leave the status bar visible, so you can see the helpful hints Access displays there.) 
Startup Dialog Box Controls whether the startup dialog box appears when you 
start Access. When this option is selected, Access displays the initial dialog box that 
lets you choose which database to open; when deselected, you're taken directly to 
the Access main menu, which has only the File, Tools, and Help menus. 

€»'1111" liE 

If you turn off the startup dialog box, you must open a database (File > Open 
Database) or create a database (File > New Database) before you can choose 

Tools > Options again. 

Dat<>sheet l T ables[Queries l Forms/Re!)orfsl 
View I General j HypefiiQI<s[HTMLj 

~1odule 
'E<;Iit/Fiml 

Mv~rlced !• 
!(e',iboard 

" 
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Hidden Objects Controls whether to display or hide objects in the database 
window if they have a property of Hidden. When you choose to display hidden 
objects, their icons will be dimmed in the database window. To hide an object, go 
to the database window, locate the object you want to hide, right-click on the 
object's name, select (check) the Hidden property near the bottom of the dialog 
box, and then click on OK. 
System Objects Controls whether to display or hide the names of internal sys­
tem objects that Access creates, or system objects that you create. These system 
objects start with the letters Msys or Usys. If you select (check) the System Objects 
option, Access will show system objects along with other table names in the data­
base window, though their icons will be dimmed. (It's best to leave these objects 
hidden to avoid confusion.) 

Don't mess around with any of the system objects that Access creates if you aren't 
absolutely sure of what you're doing. The results can be disastrous. 

Names Column Controls whether to display or hide the Macro Name column in 
the macro design window. To override this setting, choose View> Macro Names 
from the macro design menus. 
Conditions Column Controls whether to display or hide the Condition column. 
To override this setting, choose View > Conditions from the macro design menus. 

To change your screen's video resolution (if your screen supports adjustable reso­
lutions and you're using Windows 95), minimize Access and other programs you're 
running, so you can see the Windows 95 desktop. Then right-click on any blank 
area on the Windows desktop, choose Properties, click on the Settings tab in the 
Display Properties dialog box, drag the slider control below the Desktop Area 
option, and then click on OK. When prompted, click on OK and then click on Yes 
to accept the changes. 

Personalizing a 
You can personalize a database in several ways: 

" Set startup options that take effect when you open the database. See the next section. 
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1#3@11111 
The Startup 

dialog box after 
we clicked on 
the Advanced 

button. 
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• Set database properties that document your database and make it easier to find the 
database later. See "Changing the Database Properties" in Chapter 5. 

• Set object properties for objects that appear in the database window. See "Changing 
Properties of an Entire Table or Object" in Chapter 6. 

The Startup options let you control options that take effect when you open a particular 
database. You can use the Startup dialog box instead of, or in addition to, an AutoExec 
macro. The AutoExec macro will run after the Startup dialog box options take effect. 
(See Chapters 20 and 28 for more about macros.) 

To set the Startup options: 

1. Open the database for which you want to set startup options. 

2. Choose Tools > Startup; or right-click on any gray area on the database window 
and choose Startup. You'll see the Startup dialog box, shown in Figure 15.11. 

3. Change any of the options described just below. 

4. Click on OK to accept the new settings and close the Startup dialog box. 
§. Close the database and open it again if necessary. 

To bypass the Startup settings and use the default options shown in Figure 15.11, 
hold down the Shift key while opening the database. 

AQplicalion Title: Dhpl<;y f.mm: 

j(none) i} 
.1\pplication !C•)n: !7· Display J;!atabase Window 

.::,1 W Display Status ]!ar 

Menu Bar: Ehortcut Menu Bar: 
II default) i} .:J jldefaull) 

W Allow F !!11 Menus 

W Allo!t! Default Shortccrl Menus 

W .<\flow Viewing Code After [Hor 

17 Ajlow Suilt·in T ooltiars 

17 Alfow T ooltiaJ Changes 

17 Uw.<\ccess Spedal!';;e9s 
(Show Database \.1/indo\\•; Show Code 
\\Iindow, and Pause Executipn) 

'" 
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The Startup dialog box options are described below. Note that some options take 
effect as soon as you close the Startup dialog box; however, others don't take effect 
until the next time the database is opened (these "delayed" options are marked with an 

asterisk below). 

Application Title Lets you display your own application title in the Access title 
bar. Type Jhe title you want to display. To use the default application title of 

Microsoft Access, leave the Application Title text box empty. 
Application Icon Lets you replace the standard Access "key" icon with an appli­
cation icon of your own choosing. The icon appears in the Access title bar and on 
the application's Taskbar button. To specify an icon, type its name into the Appli­
cation Icon text box; or click on the Build button next to the Application Icon 
option, locate the icon (*.ico) or bitmap (*.bmp) file you want to display, flnd 
then double-click on its file name. (On Windows NT, you can use icon files only, 
not bitmap files.) If you'll be distr!buting your application, it's best to put the icon 
or bitmap file in the same folder as your application. To use the default icon for 

Access, leave the Application Icon text box empty. 
Menu Bar * Lets you choose a global menu bar to display when you open the 
current database. Choose an existing menu bar from the drop-down list next to 
the Menu Bar option, or choose (Default) to use the Access default menu bar. 
Chapter 24 explains how to create custom menu bars. Until you create a custom 
menu bar, the only choice you'll see for this option is (default). 
Allow Full Menus * Lets you choose whether a full set, or a restricted set, of 
menus appears on the Access built-in menu bars. Select (check) this option to dis­
play a full set of built-in menus; deselect (clear) this option to display a restricted 
set of built-in menus that doesn't allow design changes to database objects. 

·Allow Default Shortcut Menus * Lets you choose whether the Access default 
shortcut menus are available. Select (check) this option to display shortcut menus 
when you right-click on a toolbar or other object; deselect (clear) this option to 

prevent shortcut menus from appearing when you right-click. 
Allow Viewing Code After Error * Lets you control whether to enable the 
Ctrl+Break key and allow code viewing in the Module window after a run-time error 
occurs in the application. (When you're finished developing your application, you 
may want to deselect this option to prevent users from viewing your code.) 
Display Form * Lets you choose which form to display when the database is 
opened. To avoid displaying any form, choose (None) from the Display Form 
drop-down list. The applications you create with the Database Wizard specify a 

form named Switchboard as the Display Form. 
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" Set database properties that document your database and make it easier to find the 
database later. See "Changing the Database Properties" in Chapter 5. 

• Set object properties for objects that appear in the database window. See "Changing 
Properties of an Entire Table or Object" in Chapter 6. 

p 
The Startup options let you control options that take effect when you open a particular 
database. You can use the Startup dialog box instead of, or in addition to, an Auto Exec 
macro. The AutoExec macro will run after the Startup dialog box options take effect. 
(See Chapters 20 and 28 for more about macros.) 

To set the Startup options: 

1. Open the database for which you want to set startup options. 
2. Choose Tools > Startup; or right-click on any gray area on the database window 

and choose Startup. You'll see the Startup dialog box, shown in Figure 15.11. 

3. Change any of the options described just below. 
4. Click on OK to accept the new settings and close the Startup dialog box. 
5. Close the database and open it again if necessary. 

To bypass the Startup settings and use the default options shown in Figure 15.11, 
hold down the Shift key while opening the database. 

Startup IJEi 

AQplication Title: ~D·_rsp_~7Y __ ~_rm_: ___________ ~~- ,I ____ o_K~~ 
linone) .2J -

Cancel 
Application !co~n: P' Display Qatabase Window 

. P' · Display Statui gar 

,2hortcut Menu Bai: 

hdelault) Sj d jldelaull) 

P' Allow Fyll Menus 

P' Allo!£1 Default Shortcut Menus 

P' .<),llow Viewing Code ,lifter f.rror 

r.l Ajlow Bui(t:in T ·~olbars 

P' Allow T oolbar Changes 

r.l Use Access Specialfl,eys 
(Show Database Window. Show Codec 
Window. and Pause E~ecution) 
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The Startup dialog box options are described below. Note that some options take 
effect as soon as you close the Startup dialog box; however, others don't take effect 
until the next time the database is opened (these "delayed" options are marked with an 
asterisk below). 

Application Title Lets you display your own application title in the Access title 
bar. Type ,the title you want to display. To use the default application title of 
Microsoft Access, leave the Application Title text box empty. 
Application Icon Lets you replace the standard Access "key" icon with an appli­
cation icon of your own choosing. The icon appears in the Access title bar and on 
the application's Taskbar button. To specify an icon, type its name into the Appli­
cation Icon text box; or click on the Build button next to the Application Icon 
option, locate the icon (*.ico) or bitmap (*.bmp) file you want to display, find 
then double-click on its file name. (On Windows NT, you can use icon files only, 
not bitmap files.) If you'll be distributing your application, it's best to put the icon 
or bitmap file in the same folder as your application. To use the default icon for 
Access, leave the Application Icon text box empty. 
Menu Bar * Lets you choose a global menu bar to display when you open the 
current database. Choose an existing menu bar from the drop-down list next to 
the Menu Bar option, or choose (Default) to use the Access default menu bar. 
Chapter 24 explains how to create custom menu bars. Until you create a custom 
menu bar, the only choice you'll see for this option is (default). 
Allow Full Menus * Lets you choose whether a full set, or a restricted set, of 
menus appears on the Access built-in menu bars. Select (check) this option to dis­
play a full set of built-in menus; deselect (clear) this option to display a restricted 
set of built-in menus that doesn't allow design changes to database objects. 
Allow Default Shortcut Menus * Lets you choose whether the Access default 
shortcut menus are available. Select (check) this option to display shortcut menus 
when you right-click on a toolbar or other object; deselect (clear) this option to 
prevent shortcut menus from appearing when you right-click. 
Allow Viewing Code After Error * Lets you control whether to enable the 
Ctrl+Break key and allow code viewing in the Module window after a run-time error 
occurs in the application. (When you're finished developing your application, you 
may want to deselect this option to prevent users from viewing your code.) 
Display Form * Lets you choose which form to display when the database is 
opened. To avoid displaying any form, choose (None) from the Display Form 
drop-down list. The applications you create with the Database Wizard specify a 
form named Switchboard as the Display Form. 
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Display Database Window * Lets you choose whether to display or hide the data­
base window when you open the database. It's often handy to hide the database 
window if your database displays a form at startup. (Even if the database window 
doesn't appear at startup, you usually can display it anytime by pressing Fll.) 
Display Status Bar * Lets you choose whether the status bar appears at the bot­
tom of the Access window (usually it's best to leave this option checked, so you 
can see the status bar). To turn off the status bar for all Access databases, choose 
Tools> Options, click on the View tab, and deselect (clear) Status Bar. The status 
bar won't appear in the current database if you've turned off the status bar for the 
current database, all databases, or both. 

Shortcut Menu Bar * Lets you choose a shortcut menu bar to display when you 
right-click on a form or report in form view or print preview. Choose art existing 
shortcut menu bar from the drop-down list next to the Menu Bar option, or 
choose (Default) to use the Access default shortcut menu bar. See Chapter 24 for 
details on creating custom shortcut menus. 

Allow Built-In Toolbars * Lets you choose whether to allow users to display the 
Access built-in toolbars. This setting will not affect custom toolbars that you add. 
Normally you'll want to leave the toolbars available, unless you're developing an 
application that has its own custom toolbars and you don't want Access toolbars 
to appear. 

Allow Toolbar Changes * Lets you choose whether to allow users to change the 
built-in toolbars and custom toolbars. Select (check) this option to allow changes to 
the toolbars. Deselect (clear) this option to disable the View> Toolbars >Customize 
command and the right mouse button on toolbars. 

Use Access Special Keys * Lets you choose whether to enable or disable these 
special keys: Fll or Alt+Fl (displays the database window), Ctrl+G (displays the 
debug window), Ctrl+Fll (toggles between the custom menu bar and the built-in 
menu bar), Ctrl+Break (stops code from running and displays the current module 
in the Module window). 

For details about any option in the Startup dialog box, right-click on the option name 
and click on What's This?, or click in an option's text box and then press Shift+Fl. For 
information about important things to consider when you alter settings in the Startup 
dialog box, type Startup Dialog Box in the Office Assistant search box and then click on 
the Considerations when setting options in the Startup dialog box topic. 
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installing Wizards, 

ljtij@ldfJ 
The Add-In 

Manager dialog 
box with one 

add-in installed. 
(This add-in is 

courtesy of Ken 
Getz at KNG 
Consulting.) 

Access Wizards, builders, and menu add-ins are contained in speciallibrarydatabases. 
You can use the Add-In Manager to install or uninstall existing libraries, and to add new 

library databases. 

Library databases have the file extension .mda; otherwise, they are similar to standard 
database (.mdb). Several libraries come with Access and are installed automatically by 
the Setup program (see Appendix A); however, these libraries do not appear in the 
Add-In Manager dialog box. You also can create your own libraries or purchase them 
from third-party suppliers. 

To get started with the Add-In Manager, follow these steps: 

1. Choose Tools > Add-Ins > Add-In Manager. The Add-in Manager dialog box, 
shown in Figure 15.12, will appear. Installed libraries are marked with an x. 

2. Do one of the following: 

• To add an add-in to the list, click on the Add New button, locate and click on the 
add-in's file name in the File Open dialog box, and then click on OK (or double­
click on the file name). This procedure copies the library to the Access installation 
folder (usually \MSOffi ce\Access) and installs it in the Available Add-Ins list. 

• To install an available add-in, click on the add-in name in the Available Add­

Ins list and then click on the Install button. 

• 

Ill! Add-in Manager 13 

Close 

Mailable Add·ihs; llninstall I 
I \actiLti~~Y.;;~~~ . r·-·· 

KNG Consulting 

Insert DoMenulterri code direcUy intoyour modules 
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• To uninstall a currently available add-in, click on the add-in name in the 
Available Add-Ins list and then click on the Uninstall button. When the library is 
uninstalled, it's available on disk but won't be loaded into memory and can't be 
used. You can conserve memory and reduce the time it takes to load Access by 
uninstalling libraries that you aren't using. 

• To quickly install or uninstall an add-in, double-dick on the add-in name in 
the Available Add-Ins list (double-clicking will toggle the x on or off). 

3. Click on Close when you're done using the Add-In Manager. You'll be returned to 
the database window. 

Don't just experiment with installing and uninstalling add-ins. If you do, you 
might lose Wizards and options on the Tools> Add-Ins menus. To restore lost 
add-ins, reinstall Access and any third-party add-ins. 

You can learn more about the Add-In Manager by searching for Add-In Manager in 
the Access Answer Wizard. For details about creating and installing library databases, 
see Chapter 16 "Creating Wizards, Builders, and Add-Ins" in the Access manual titled 
Building Applications with Microsoft Access for Windows 95. 

Customizi 

In previous versions of Access, you could customize Wizards by using the Add-In Man­
ager. This feature is no longer available (and often isn't needed) because many Wizards 
allow customization when you use them. 

If you need to customize the Table Wizard, you can learn how to do so in the Access 
Developer's Toolkit. For more information on the Access Developers Toolkit, look up Devel­
oper's Toolkit, Contents Of in the Access Help Index. 

Other Waijs to A 

This chapter has discussed many ways to personalize Access. But there are more! You also 
can personalize the appearance and behavior of Access by changing options in Windows 
Control Panel, by specifying startup options on the command line that starts Access, and 
by customizing the Registry file. The following sections briefly discuss these techniques. 
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I Panel Access 

Like most Windows programs, Access inherits many of its settings from options that 
you set in Windows Control Panel. To get started with Control Panel, click on the Start 
button on the Taskbar, and choose Settings~ Control Panel (or double-click on the My 
Computer icon on your desktop, and then double-click on the Control Panel folder). 

When the Control Panel window opens, double-click on the icon for the settings you 

want to change (see Table 15.2). Remember that your changes in Control Panel will 

affect most other Windows programs. 

ICON 

Display 

( '··· 
~ 
Fonts 

~ 
~ 

Network 

Passwords 

SETTINGS 
OPTION 

32-bit 
ODBC 

Display 

Fonts 

Network 

Passwords 

WHAT IT DOES 

Lets you add, delete, or configure data sources and 
install new 32-bit ODBC drivers on your computer. A 
data source includes the data source name, description, 
server, network address, network library, and other infor­
mation used to identify and locate data on a network 
(see Chapter 18). 

Lets you choose the colors used for various parts of the 
screen and change the appearance of your Windows 
desktop. 

Lets you add and remove fonts and set True Type options. 

Lets you manage your network configuration, choose a 
primary network logon, enable or disable file and printer 
sharing, identify your computer to the network, and 
choose how to allow access to shared resources on your 
computer (see Chapter 18). 

For networked computers, this option lets you change 
your Windows password and the password for other 
password-protected devices, allow remote administra­
tion of your computer, and choose personal preferences 
for users of your computer (see Chapter 18). 
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SETIINGS 
ICON OPTION 

~ 
Printers 

Printers 

Regional 
Settings 

Regional 
Settings 

System 

System 

WHAT IT DOES 

Lets you install and remove printers, change printing set­
tings, and select the printer you want to use as the 
default printer. 

Lets you specify international settings, including units of 
measurement, list separators, and formats for dates, 
times, currency, and numbers. 

Lets you manage hardware devices on your computer, 
maintain hardware configuration profiles, and optimize var­
ious Windows settings for better performance. (Windows 
usually is optimized for better performance automatically.) 

For more information about the options listed in Table 15.2, see your Windows doc­
umentation or use the Help> Help Topics menus in Control Panel. You also can click on 
any Control Panel icon and look at the status bar to find out what it does, and you can 
right-click on options in the various Control Panel dialog boxes and choose What's This? 

Using Command-line Options When Starting Access 
You can use startup options to open a database automatically, run a macro, supply a user 
account name or password, and more, simply by specifying options on the command 
line that starts Microsoft Access. Access gives you two ways to specify startup options, 
and we'll explain both methods shortly: 

• On the Start > Programs Menus Access always starts with any options you've 
specified in the Start > Programs menus. Typically, only one Microsoft Access entry 
appears on these menus. 

• In a Shortcut Access starts with any options you've specified in the shortcut. 
You can set up as many shortcuts as you need (see Chapter 1), and you can place 
those shortcuts in a folder or directly on your Windows desktop. 

A standard Access startup command, without any command-line options, usually 
looks like this: 

c:\msoffice\access\msaccess.exe 
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To specify command-line options, begin with the startup command shown above, then 
type a space, and then type additional options as needed (with each option separated by a 
space). The example below starts Access and opens the Order Entryl database in the folder 
named My Documents on drive C (of course you must enter all the text on one line): 

c:\msoffice\access\msaccess.exe 
"c:\My Documents\Order Entryl" 

If the path to your database contains spaces, be sure to enclose the path in double 
quotation marks, as shown in the example above. If the path doesn't include 
spaces, you can omit the double quotation marks. 

This example starts Access and opens the Order Entryl database in run-time mode: 

c:\msoffice\access\msaccess.exe 
"c:\My Documents\Order Entryl" /runtime 

Table 15.3 shows the most commonly used Access command-line options. For a com­
plete list and more information, search for Command Line Options in the Access Answer 
Wizard, and then double-click on Startup Command-Line Options under Tell Me About. 

OPTION* 

database 

source database I 
Compact target 
database 

Database /Excl 

/Nostartup 

EFFECT 

** Opens the specified database. 

** Compacts the source database to the name specified as 
the target database, and then closes Access. Omit the 
target database name if you want to compact the database 
to the source database name. 

Opens the specified database for exclusive access. Omit 
the /Excl option to open the database for shared access in 
a multiuser environment 

Starts Access without displaying the startup dialog box. Same 
as choosing Tools> Options, and deselecting Startup Dialog 
Box on the View tab of the Options dialog box. 
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I 
OPTION* 

/Profile user profile 

/Pwd password 

/Repair database 

Database /RO 

database /Runtime 

/User user name 

/Wrkgrp workgroup 

information file 

/X macro 

EFFECT 

Starts Access using the options in the specified user profile 

instead of the standard Windows Registry settings created 
when you installed Microsoft Access. The /Profile option 
replaces the /ini option used in previous versions of Access 
to specify an initialization file. See the Microsoft Access 
Developer's Toolkit for tools and information about creat­
ing user profiles. 

Starts Access using the specified password (see Chapter 18). 

Repairs the specified database and then closes Access (see 
Chapter 1 7). 

Opens the specified database for read-only access. 

Starts Access in run-time mode and opens the specified 
database. In run-time mode, users cannot access the data­
base window or open database objects in Design view. 
This option is useful for running turnkey applications, such 
as those the Database Wizard creates. 

Starts Access using the specified user name (see Chapter 18). 

** Starts Access using the specified workgroup information 

file (see Chapter 18). 

Starts Access and runs the specified macro. You also can 
run a macro when you open a database by using an 
AutoExec macro (see Chapters 20 and 28). 

*To specify a forward slash (/)or semicolon (;) on the command line, type the character twice. For example, 

to specify the password ;eao/rnaa47 on the command line, type ;;eao/ /rnaa47 following the /Pwd 

command-line option. 

** Specify a path name if necessary. If the path name contains any spaces, enclose the entire path name 

in double quotation marks. See the example in the chapter. 

Specifying Startup Options on the Start Menu 
If you always want Access to use the same startup options, you can modify the 
Microsoft Access entry on the Start > Programs menus: 

1. Right-click on the Start button on the Windows Taskbar, and choose Explore. The 
Exploring Start Menu window will open. 
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2. Double-click on the Programs folder in the right pane of the window and then double­
click on folders as needed until you locate the Microsoft Access shortcut icon. 

3. Right-click on the Microsoft Access shortcut icon and choose Properties. Or click 

on the icon and press Alt+Enter. 
4. Click on the Shortcut tab in the Microsoft Access Properties dialog box. 
5. Press the End key to move the insertion point to the right of the Access startup 

command in the Target text box. 
6. Type a space and enter the command-line settings you want to use. 
7. (Optional) Set the Start In, Shortcut Key, and Run options in the dialog box. (To 

learn more about any of these options, right-click on an option name and choose 

What's This?.) 
8. Click on OK to return to the Exploring window. 

9. Close the Exploring window. 

The next time you use the Start )»- Programs menus to start Access, your command­

line options will take effect. 

Specifying Startup Options in a Shortcut 
Chapter 1 explained how to create shortcuts. Assuming you've already set up a shortcut 

for Microsoft Access, here's how to modify it to include startup options: 

1. Locate the shortcut in a folder or on your desktop. 
2. Right-click on the Microsoft Access shortcut icon and choose Properties or click on 

the icon and press Alt+Enter. 
3. Fill in the Microsoft Access Properties dialog box, as explained in steps 4 through 7 

of the previous section. 
4. Click on OK to accept the changes. 

The next time you double-click on an Access shortcut icon, Access will start with the 

command-line options you chose. 

About 
When Access starts up, it reads various settings from the Windows Registry file. (In 
Access 2.0, startup settings were stored in the initialization file, named \windows\ 

msacc20. i ni . ) Many of these settings are defined when you install Access, and some are 
updated when you use certain Access utility options, such as the Workgroup Adminis­
trator discussed in Chapter 18. You'll rarely need to update the Registry file manually, 
but if you do so, be very careful-and back up the Registry first! Incorrect updates to the 
Registry can prevent Access and other Windows programs from working correctly. 
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If you do need to update the Registry, you must use the Registry Editor to make the 
changes. To get started, click on the Start button on the Windows Taskbar, choose Run, 
type regedit, and press Enter. Your changes will take effect the next time you start Access. 

To learn more about changing the Registry, search for Registry in the Access Answer 

Wizard and then explore subtopics as needed. 

In this chapter you've learned many ways to personalize Access to your own working 
style. The next chapter presents ways to analyze your databases and speed up their 

performance. 

What's New in the 
Access Zoo? 
The options for customizing Access 97 for 
Windows 95 have been reorganized a bit. 
Here are some reminders to help upgrad­
ers figure out where to look for changes: 

• The Options dialog box has a new 
page for hyperlink options. Use 
Tools~ Options to get to this tabbed 

dialog box. 

• Use the Customize dialog box to 
change menus and toolbars now. 
Choose View~ Toolbars ~ Customize. 
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Speeding Up Your Database 

f you're dreaming of a database that 
screams along at the speed of a For­
mula 1 Ferrari, but you're getting 

performance that's more like the plod, plod, plod of a desert tortoise, this chapter may 
be just what you're looking for. Here you'll find tips for tweaking that tired database 

engine so that it races swiftly along the information superhighway. 
As you read this chapter, keep in mind that you can't make a Ferrari out of a Volkswagen 

Bug, or a Pentium out of an 80386. But you can squeeze the best possible performance out 
of the computer hardware you do have. If you're still hungry for speed after trying the sug­
gestions in this chapter, you can always throw money at the problem and invest in faster, 

more expensive hardware. 
For more tips on optimizing performance in a network environment, see Chapter 18. 

So Where Oo \ Start? 
For your convenience, we've divided this chapter into the five performance areas 

listed below: 

" General Performance 
• The Performance Analyzer 
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• Tables 
• Queries 
• Forms, Reports, and Printing 

Start with the suggestions in the General Performance category and then work your 
way to the other categories if you notice sluggishness in those areas. Within each sec­
tion below, we've arranged the tips in the general order that you should try them. So 
start at the top of each list of suggestions and work your way down to the bottom. 

<Co.,... liE 

The optimal settings in the categories that follow can vary with the type of com­
puter hardware you're using to run Access. For best results, tweak one setting at a 
time, and monitor the performance after each change. 

You can find out more about optimizing Access performance by searching for Perfor­
mance with the help of the Office Assistant. 

Two basic methods are available to speed up general performance. First, you can make 
changes to general Windows 95 settings, which may also speed up many Windows 
applications, not just Access. Second, you can make changes through Access, which 
will speed up Access, but should have no effect on other Windows applications. 

Tweaki a a 95 Settings 
For best overall performance in Access and Windows, you should maximize the 
amount of memory and disk available as discussed below: 

• Increase the memory (RAM) on your computer. Access requires at least 12MB of 
RAM, but the more RAM you buy and install, the better the performance. Don't 
use any of your RAM for a RAM disk. 

• Optimize Windows 95. Windows 95 can report any system optimization prob­
lems to you. You should check this report in the System Properties dialog box and 
take any action recommended. You should also check a couple of settings avail­
able to you from this dialog box. To see the system performance report and check 
these settings, follow these steps: 

1. Open the Control Panel by selecting the Settings option on the Start menu and 
then select the Control Panel item. 
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2. Double-click on the System icon. 
3. In the System Properties dialog box, click on the Performance tab and read the 

report within the Performance Status frame. 
4. Click on the File System button and select the typical role for your machine 

using the drop-down list box on the Hard Drive tab in the File System Proper­
ties dialog box. Set read-ahead optimization to Full using the slider control. 

Click on OK. 
5. Click on the Graphics button in the System Properties dialog box. Make sure 

the slider control for Hardware Acceleration in the Advanced Graphics Settings 
dialog box is set to Full, unless you are having problems with your display. In 
that case, you may wish to back off this setting a notch or two. The on-screen 

help will guide you in deciding where to leave this setting. Click on OK. 
6. Click on OK in the System Properties dialog box to accept the settings. If you 

are prompted to restart Windows 95, click on Yes to do so. 

• Optimize memory usage. In most cases, letting Windows 95 manage memory for 
you is the best idea. However, in two situations you may need to set your own virtual 
memory parameters. If you have only a little space on your default Windows 95 drive 
or if a different hard disk drive has a faster access time, you should tell Windows 95 to 

use a different drive for virtual memory. Follow these steps: 

1. Open the Control Panel by selecting the Settings option on the Start menu and 

then selecting the Control Panel item. 

2. Double-click on the System icon. 
3. Click on the Performance tab in the System Properties dialog box and then 

click on the Virtual Memory button. The dialog box will appear as shown in 

Figure 16 .1. 
4. Select the Let Me Specify My Own Virtual Memory Settings option button. 

Then select the faster or ~ess full drive using the Hard Disk drop-down list box. 
If you have a choice, opt for the fastest drive with at least 15MB of free space. 
Set a swap file size with a minimum size that, when added to the amount of 

system RAM, totals 25MB. 
5. Click on the OK button and then close the System Properties dialog box by 

clicking on its OK button. 
6. Click on Yes to restart Windows at the prompt. Restarting Windows makes the 

change in your swap file take effect. 
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• Close unneeded applications and TSRs. You can make more memory available 
by closing applications and terminate-and-stay-resident (TSR) programs that you 
aren't using. Using DOS-based TSR programs can slow system performance 
because of shifts from protected mode into real mode to allow the TSR to run. To 
prevent TSR programs from running automatically when you start up your com­
puter, delete the appropriate lines in autoexec. bat or convert them to comments 
by preceding the lines with a REM command, for example: 

Rem DOSKEY 

• Defragment your hard disk and compact your databases. To speed disk perfor­
mance and maximize the amount of free space available, you should periodically 
delete unnecessary files from your hard disk, defragment your hard disk with a 
"defrag" utility such as the Windows 95 Disk Defragmenter, and then compact 
your Access databases (see Chapter 17). You should also take these steps before 
optimizing the size of your Windows swap file, as discussed next. If you are using 
the Microsoft Plus! Pack for Windows 95, have the System Agent run ScanDisk 
and Disk Defragmenter nightly to keep your disk performance top notch. 

• Peel off that wallpaper. If you have a full-screen (Tile) wallpaper bitmap on your 
Windows desktop, open Windows Control Panel and double-click on the Desktop 
icon. Now replace the wallpaper with a solid color or pattern bitmap or no bitmap 
at all. Depending on your video display, eliminating wallpaper can free up 
between 256K and 750K of RAM. 



SPEEDING UP GENERAL PERFORMANCE 1651 

ngs 
You can do the following in Access to improve performance: 

• Open single-user databases exclusively. When opening databases that won't be 
shared with other users, select the Exclusive checkbox in the Open dialog box 
whenever possible. This setting tells Access not to spend time tracking multiuser 

record locking. 
• Store single-user databases and Access on the local hard disk. Response will be 

faster if you install Access, and all databases that don't have to be shared, on your 

local hard disk drive, rather than on a network server. 
• Use indexes wisely. Indexes can speed access to data, but they also can slow 

down record updating (see Chapter 6). For best results with indexes, you should: 

• Create only as many indexes as necessary. 
• Create indexes on fields that you frequently sort by. 
• Create indexes on fields that you frequently search by. 
• Include only the fields that are absolutely necessary in a multiple-field index. 

You should consider a multiple-field index only when you search or sort on a 
combination of fields. For example, if you frequently search for customers with 
a particular last name in a particular zip code, then a multiple-field index on 

these two fields will help performance. 

• Put only tables on the server for multiuser databases. Keep all other objects on the 
local machine's drive. You can use the Database Splitter Wizard to separate the tables 

for storage on the server. 
• Experiment with record locking strategies. You want a strategy that minimizes 

editing conflicts but allows appropriate access to the database. You must strike a 
balance between the performance penalties of multiple concurrent access and the 

inconvenience penalties of restrictive record locking. 
• Adjust parameters to avoid locking conflicts. Experiment with the values of 

Refresh Interval, Update Retry Interval, Number of Update Retries, and ODBC Refresh 
Interval. To find these settings, open the Tools menu, select Options, and click on the 

Advanced tab. 

OO>"'III'"IIE. 

For more information on record-locking strategies, see Chapter 18. 
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I#L3Q;IItif4 
Using the 

Performance 
Analyzer on a 

simple 
database. 

Analuzer 
Access 97 includes a Performance Analyzer. This tool examines your database objects 
and reports ways to improve their performance. The Performance Analyzer provides 
suggestions, recommendations, and ideas. The analyzer itself can perform suggestion 
and recommendation optimizations for you. Idea optimizations require that you work 
with Access's features yourself to perform the optimization. 

EII:»"V"IIIE 

The Performance Analyzer can examine database objects only. It cannot provide 
information about how to speed up Access itself or the underlying operating system. 

To show you what the Performance Analyzer can do, we've used it to analyze a 
database created to hold names, addresses, and similar information for a nonprofit cor­
poration. Figure 16.2 shows the results. As you can tell, the Performance Analyzer has 
provided several tips for improving the speed even of this relatively simple database. 

Table "Basic Information': Add index to field[s) Year' 
Table 'Basic Information': Add index to lield[s) Year ,Last Name' 
Table 'Basic Information': Add index to field[s) 'Grades Taught' 
Table 'Basic Information': Add index to lield[s) 'Home City' 
Table 'Basic Information': Add index to lield[s) 'Appear on Published LisLLast ~lame' 

w: Table 'Basic Information': Relate this table to others in the database 

'f · Suggeslion :'f. Idea 4 Fixed 
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To use the Performance Analyzer, follow these steps: 

1. Open the database you want to analyze. 
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Put a reasonable amount of data in your tables before running the Performance 
Analyzer. The query analysis step in particular takes into account the actual amount 
of data in each table. 

2. Select Analyze from the Tools menu and then select Performance from the cascad­
ing menu. 

3. Click the tab in the Performance Analyzer dialog box for the type of object you 
would like to analyze. Then select each object you want to include in the analysis. 
You can either click the checkbox that precedes an object or click the object's name 
and then click Select. Use Select All or Deselect All for quick ways to select or 
deselect the entire list of names on an individual tab. 

4. Repeat step 3 until you have selected all the objects you want to optimize. 
5. Click on the OK button. The Performance Analyzer displays dialog boxes that tell 

you which objects it is analyzing. It then displays a list of Suggestions, Recommen­
dations, and Ideas. 

6. Select Suggestion or Recommendation in the Suggestions list box and click on the 
Optimize button. Or to implement an Idea, open the appropriate table, query, 
form, report, macro, or module and make the change recommended. 

You can select the All tab to see a list of all database objects. Then use the Select All 
and Unselect All buttons to speed the process of selecting items. 

Speeding Up Tables 
If you follow these techniques, you can design tables that operate in the most efficient 
manner possible. Access even provides help for improving tables in the form of the 
Table Analyzer Wizard. 

• Avoid redundant data. Repeated data makes table access inefficient. Use the 
Table Analyzer Wizard to avoid common problems with tables. Select Analyze > 
Table from the Tools menu and follow the directions provided by the Wizard. 
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• Select appropriate data types for your fields. Choosing text where a number 
would be better, for example, can increase the size of your tables and make join 
operations less efficient. 

• Build indexes for fields that will be searched, joined, or have criteria set. Creating 
the indexes makes queries faster on the table. 

Speeding Up Oueries 
Microsoft Access uses a special data-access technology known as "Rushmore" to opti­
mize queries automatically whenever possible. You can help Access do the job more 
efficiently by following the guidelines below. (See Chapter 10 for more about queries.) 

• Use and display only the fields you need. Include only the fields you need in a 
query. Clear the Show box in fields used as selection criteria if you don't need to 
display those fields in the query result. 

• Use sorting wisely. Sorting can slow down performance, especially when you sort 
on nonindexed fields. 

• Use Make Table queries for static data. If you frequently need to base reports or 
analyses on data that doesn't change often, it's more efficient to run Make Table 
queries to create tables of selected (or calculated) data. Then you can view or report 
on the new tables without running a query each time. If your data does change, you 
can run the Make Table queries again to re-create the static tables. Note that this 
technique does involve trade-offs: First, it uses extra disk space to hold the static 
tables. And second, if you forget to run the Make Table query after data changes, 
you won't get up-to-date information. 

• Use queries only when necessary. Response will be faster if you base forms, 
reports, arid other queries on tables (such as those created by Make Table queries), 
rather than a query. Queries will, of course, be necessary if you need to pull infor­
mation from several different tables that change often, or if you need to sort the 
data on a form or report. 

• Create queries that can be optimized. F'or faster performance, avoid using restric­
tive query criteria (AND, OR, and NOT) on calculated and nonindexed columns. 
You can also speed up queries by using the Between ... And, In, and= (equal) opera­
tors on indexed columns. 

" Avoid using domain aggregate functions. Domain aggregate functions, such as 
DLookup, can slow down processing because these functions must look up data in 
tables that aren't included in the query. If you need to include data from another 
table, it's best to add the table to the query or to create a subquery. (To learn 
about subqueries, search for Subqueries in Help.) 
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• Use fixed column headings in Crosstab queries. Response will be quicker if you 
use fixed column headings in Crosstab queries whenever possible. To specify fixed 
column headings, go to query design view, choose View >- Properties, click on an 
empty part of the tables area, and type the headings into the Column Headings 
property box (separated by commas), like this: 

"Qtrl","Qtr2","Qtr3","Qtr4" 

For more information about optimizing queries, search for Optimizing Queries or 
Rushmore Technology with the Office Assistant. (You can actually omit the second word 
of the Rushmore search and get the same results.) 

Speeding Up Forms, Reports. and Printing 
The following tips can speed up your forms, reports, and printing. (See Chapters 11 
through 14 for more about designing forms and reports and creating graphs.) 

• Use Data Entry mode to add records to large tables. When adding new records 
in forms or datasheets that have many existing records, choose Records > Data 
Entry to hide existing records while you add new ones. This is faster than moving 
to the blank record that follows the last record. To view all the records again, 
choose Records >- Remove Filter/Sort. 

• Use hyperlinks instead of command buttons to perform tasks such as opening 
forms. Database forms and reports are created without a VBA module in Access 97. 
(Objects created with older versions of Access always included a VBA module.) Con­
sequently, forms and reports load more quickly when they don't have VBA code 
attached. Since command buttons have VBA code attached, you can increase sys­
tem efficiency by using hyperlinks whenever you can. 

• Use pictures instead of OLE objects. If you don't need to update OLE Paintbrush 
objects, Graphs, and other embedded objects, convert them to pictures. To do this, 
go to form or report design view, right-click on the object, and choose Object > 
Convert. In the Convert dialog box, select Picture in the list box and click on OK. 

• Be stingy with bitmaps and other graphics on forms. Bitmap and other graphic 
objects (such as lines, bordered fields, and opaque fields) can slow the form's 
opening and printing time. And color bitmaps will be slower than black-and­
white bitmaps. Of course, the very things that make forms more attractive and 
fun to use also slow down their performance. So you'll need to decide whether the 
trade-off of speed for aesthetics is worthwhile. 

" Close forms when you're not using them to free up memory. 
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• Avoid sorting and grouping on expressions. Reports will be faster if you avoid 
unnecessary sorting and grouping on calculated expressions. 

• Avoid overlapping controls on forms and reports. These controls take more 
time to display. 

• Use imported tables rather than attached tables. If your forms include list boxes 
or combo boxes based on unchanging tables in another database, import those 
tables rather than attaching them to your database (Chapter 7). Imported tables will 
take up more disk space than attached tables, but processing will be faster. 

• Use fast printing techniques. For faster printing of reports and forms, try these tips: 

• If you plan to print a form or report with a laser printer, open the form or 
report in design view, and choose Edit > Select Form or Edit > Select Report. 
Open the property sheet (View> Properties), select Other Properties from the 
drop-down list, and set Fast Laser Printing to Yes. (Yes is the default setting for 
this property.) 

41CD"111"11E 

If you have an older laser printer, or need to print overlapping graphic items cor­
rectly, you'll need to leave Fast Laser Printing set to No. 

• Print in Portrait orientation where possible. Landscape printing can be slower, 
especially when printing many horizontal lines on nonlaser printers. 

• Convert a database application into an MDE file. This new feature in Access 97 
lets you save a database without its source code in a compact format, which 
results in better performance when the database is used. However, users cannot 
view or edit source code. See Chapter 28 for details on creating an MDE file from a 
database or search for MDE with the Office Assistant. 

Improving the performance of your database applications makes users happy. They receive 
zippy response when they are working with the data. Once you have created a high­
performance database application, however, you have to make it available to users. To do 
so, you have to know how to administer a database, which is the topic of the next chapter. 



What's New in the 
Access Zoo? 
We've just taken a look at many of the 
features you can use to improve the per­
formance of Access 97 for Windows 95. 
Other new features in this version that 
make Access run more quickly are 

• Forms and reports are now created as 
"lightweight" objects that don't 

WHERE TO GO FROM HERE 165.7 

inc:lude Visual Basic modules. These 
streamlined objects load more quickly 
than their old counterparts. You are 
still free to add code to these objects if 
you need to. 

• The Database Wizard creates light­
weight forms whenever it can by 
using hyperlinks instead of VBA code 
for tasks like opening other forms. 
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Rdministering Your Database 

his chapter covers the mundane, yet 
essential, housekeeping tasks that 
fall into the category of database 

administration. Topics include how to back up, compact, convert, encrypt, decrypt, 

repair, replicate, and document the structure of your databases. 
Many database administration tasks are optional, and you should feel free to pick 

and choose those that interest you most. However, the following section, "Backing Up 
a Database," is a must for anyone using Access on a single-user computer and for data-

base administrators. 

c>-.rE 
The database administrator is the person who is responsible for maintaining the 
integrity and security of a database on a multiuser network (for example, making 
backups, compacting and repairing databases, protecting data from prying eyes). 
Database administration tasks are discussed in this chapter and in Chapter 18. 
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Backing up your database is the cheapest and most effective way to ensure your data 
against disasters. For example, if your database structure becomes damaged due to an 
unexpected power loss, or your hard disk fails due to old age, flood, fire, or other catas­
trophe, your data can become unreadable and be irretrievably lost. This loss would be 
particularly disastrous with an Access database, since every object you create within a 
database is stored in one large database file! Up-to-date backups can save time, money, 
even your job-and they're easy to do. For maximum protection, store backups off-site, 
in a disaster-proof container. 

Repairing a damaged database is sometimes possible, as you'll learn later in the 
section "Repairing a Database." However, the best method of data protection is 
to make regular backups. 

Exactly where you store your backups and how often you make them is up to you. 
If the database is small enough, you can back it up to a floppy. Or you can use a file 
compression program to create a compressed copy of the database and back that up to 
a floppy. For larger databases, you'll need to back up to a tape drive or perhaps a hard 
drive with removable disks. 

You may also want to keep a second backup copy of the database on your local hard 
disk. That way, if you make a change to the original database that somehow corrupts 
the original, you can quickly copy the local backup to the original file name without 
bothering with external drives or tape devices. 

Backing up a database is basically a matter of copying two crucial files to the backup 
device: 

• The database file This file stores all your data and database objects and usually 
has the extension .mdb. 

• The system.mdw workgroup database file The Setup program creates system.mdw in 
the \access folder automatically. This file contains important information about each 
user's toolbar and option settings. It also stores workgroup security information. 
(A workgroup is a group of users who share data and the same system database file.) 

If the system.mdw file is lost or damaged, you won't be able to start Access. If you 
can't restore this file from a backup copy, you'll need to reinstall Access (see 
Appendix A) and set up any toolbars, option settings, and security again. 
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To create a database backup, follow the steps below: 

1. Close any open database by choosing File )>- Close Database. 
2. Make sure all other users also close the database so that no open copies :tre on the 

system. (Database administrators: You may prefer to make backups in the wee 
hours of the morning so that network users don't have to spend time twiddling 
their thumbs while you churn out database backups.) 

You can also back up individual database objects by creating a database and then 
importing the objects from the original database to the copy (see Chapter 7). The 
advantage of this approach is that users do not have to close the database first. 

3. Switch to whatever program you use to make backups. This can be the Windows 
Explorer, the Copy command available in the MS-DOS window, the Windows 95 
Backup program, a tape drive system, or some other backup utility. 

4. Copy the .mdb file to the backup destination of your choosing. 
5. Copy the workgroup file to the backup destination. If you haven't set up a custom 

workgroup, this will be the system.mdw file from your Access directory. See Chap­
ter 18 for information about setting up a custom workgroup file. 

Restoring a from Backups 
To restore the database from a backup copy, use your backup software to copy the .mdb 
file from your backup device to the appropriate database file in the database folder. If 
the file system.mdw was lost or damaged, copy that file from the backup device to the 

\access folder. 

If the backup database and the original database have the same names, you'll be 
replacing the original file. If you want to keep the original file for some reason, 
rename the file before restoring the backup copy to your hard disk. 

For more information about making backups, search for Backup and System.mdw 

with the Office Assistant. Also consult the documentation that comes with your backup 

program. 
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Compacting a Database 
As you add and delete records, macros, tables, and other objects in your database, the 
hard disk space formerly occupied by deleted objects can become fragmented into many 
small pieces that can't be used efficiently. This fragmentation, in turn, can slow down 
system performance to a sluggish pace and waste valuable disk space. The solution is to 
compact your databases periodically. Compacting reorganizes the space occupied by an 
Access database and can recover wasted space so that your system can perform better. 

Before compacting a database, consider the following points: 

• Because Access must copy the entire database during compacting, it will need as 
much available disk space as the database itself requires. You can check the size of 
the database and the available disk space with the Windows File Manager. 

• To compact a database, you must have Modify Design permission for all tables in 
the database. Permissions are discussed in Chapter 18. 

• The database must be closed when you compact it. You must check to make certain 
no one on your network is using the database before you attempt to compact it. If 
anyone has it open, the operation will fail. 

• When you compact that table's database, if you've deleted records from the end 
of a table that has an AutoNumber field, Access will reset the next counter num­
ber to one more than the last undeleted counter number. 

To compact the database: 

1. Choose File>- Close if the database you want to compact is open. (Any users on the 
network must also close that database.) 

2. Choose Tools >- Database Utilities >- Compact Database. 

3. Choose the drive, folder, and file name of the database that you want to compact from 
the Database To Compact From dialog box and then select the Compact button. 

4. Select the database for compacting from the list box in the Compact Database Into 
dialog box or type a valid file name for the compacted database in the File Name text 
box. Next choose Save. Or if you want to compact into the same database, double-click 
on the database name in the list box. If you use the same name in steps 3 and 4, Access 
will ask for permission to replace the original with the copy. (Choose Yes if you want 
to replace the existing file, or No if you want to specify a different name.) 

Access will compact the database, displaying a progress message along the status bar 
as it does so. 
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To maintain optimum performance in your database, you must either compact it 
using its original name or rename it with its original name after compacting. 

Compacting Other Areas of Your Hard Disk 
As mentioned, a fragmented database can slow down Access performance. Likewise, a 
badly fragmented hard disk, or one that is low on free space, can slow down all the 
applications on your computer, including both Windows 95 and Access. In addition to 
compacting your databases, as described here, you should also defragment your hard 
disk periodically and make sure that your hard disk has plenty of free space available. 

To perform this task, you can use the Disk Defragmenter provided with Windows 95 
(select Start> Programs > Accessories > System Tools > Disk Defragmenter) or a defrag­
menter provided by another vendor. Most such tools work the same way. Select the drive 
you want to defragment, click on OK, and then take a coffee break while the defrag­
menter does its work. 

If you have the Microsoft Plus! Pack for Windows 95, you can use the System Agent 
to schedule the Disk Defragmenter to run on a periodic basis. We suggest scheduling 
it to run nightly to keep your disk working at top speed. 

mz 

You cannot use Disk Defragmenter to defragment a network disk, a CD, or a disk 
compressed with a compression program not supported by Windows 95. 

For more information about compacting databases, search for Compacting Databases 
with the Office Assistant. For more about the Disk Defragmenter, search for Defragmenter 
in Windows Help. 

Converting from Other Access Formats 
If you've upgraded to Access 97, you can use the new version to work with databases 
created under Access l.x, Access 2.0, and Access95 without going through any special con­
version. However, before you can change the structure of any tables, modify the design of 
any objects, or add or remove database objects in an old database, you must convert that 
database to Access 97 format. 
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You may not want to convert a database to Access 97 format. You may need 
to share such databases with users who have not upgraded or cannot upgrade to 
Access 97. If you convert, such users will not be able to access the data. In addi­
tion, you should not convert databases accessed by applications created using 
Visual Basic 3.0 or 2.0 unless they are recompiled. Such applications need to be 
recompiled using Visual Basic 4.0 before they can be converted. The structure of 
the Data Access Objects has changed slightly in Access 97 and Visual Basic 4.0. 

To convert a database to Access 97: 

1. Choose File> Close if the database you want to convert is open. (Any users on the 
network must also close that database.) 

2. Use the Explorer to make a backup copy of the database. Make certain that all 
linked tables are still located in the folder that the database refers to. 

3. Choose Tools > Database Utilities > Convert Database. If you are converting a 
secured database, you must have Open/Run, Open Exclusive, Modify Design, 
Administer, and Read Design permissions. 

4. Choose the drive, folder, and file name of the database that you want to convert 
from the Database To Convert From dialog box, then select the Convert button. 

5. Select the database to convert in the list box from the Convert Database Into dialog 
box or type in a valid file name for the converted database in the File Name text box. 
Next choose Save. If you use the same name in steps 4 and 5, Access will ask for per­
mission to replace the original with the converted copy. (Choose Yes if you want to 
replace the existing file; choose No if you want to specify a different name.) 

.IT j{ 1: lllil 

Access l.x objects that contain a back-quote character (') in their names will not 
convert. You must rename such objects using the version of Access in which they 
were created before you can convert them. 

When Access converts a database, it constructs a special table called the ConvertErrors 
table. This table contains information about any validation rules that would not convert 
to Access 97. The ConvertErrors table contains fields describing the error, naming the 
field where it occurred, naming the table where it occurred, naming the table property 
containing the problem, and naming the value that would not convert. You can use this 
information to rewrite validation rules as necessary so that your database can function as 
it did before the conversion. In general, you will find yourself having to update user­
defined functions; domain aggregate functions; totals functions; references to fields; and 
references to forms, queries, and tables. 
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Encr~pting and Decr~pting Your Datab 
You can encrypt a database to ensure that the database can be opened and viewed only in 
Access. Though encryption doesn't prevent another Access user from tampering with the 
database, it does prevent anyone from using another application (such as a word proces­
sor or utility) to inspect data in the database. Encryption is recommended if you plan to 
send a copy of a database to another Access user or to an off-site storage location. 

You can use encryption/decryption in conjunction with the Access security features 
discussed in Chapter 18 and any security that your network software provides. 

Decrypting reverses the encryption process. While you can open an encrypted database 
without decrypting it first, the database will be 10 to 15 percent slower in its encrypted 
state. Therefore, if you receive a copy of an encrypted database from another Access user, 
you probably should decrypt it before you start using it. 

The following points apply to database encryption and decryption: 

" Access automatically determines whether the database is encrypted. If the database 
isn't encrypted, Access encrypts it. If the database is already encrypted, Access 

decrypts it. 
• The hard disk must have enough space available to store both the original data­

base and the temporary copy that Access creates during encryption/decryption. 
• The database must be closed when you encrypt or decrypt it. If anyone has it 

open, the operation will fail. 

To encrypt or decrypt a database: 

1. Choose File > Close if the database you want to encrypt or decrypt is currently 
open. In a multiuser environment, all other users must also close the database. You 
must have Modify Design permission to encrypt or decrypt a secure database if 

user-level security is in force. 
2. Choose Tools> Security> Encrypt/Decrypt Database. 
3. Choose the name of the database you want to encrypt or decrypt from the Encrypt/ 

Decrypt Database dialog box and then choose OK. 
4. Type in a valid file name for the encrypted (or decrypted) database in the Encrypt 

Database As (or Decrypt Database As) dialog box and choose Save. Or if you want 
to encrypt/decrypt into the same database, double-click on the database name in 
the list box. If you use the same name in steps 3 and 4, Access will ask for permis­
sion to replace the original with the copy. (Choose Yes if you want to replace the 
existing file, or No if you want to specify a different name.) 
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For more information about encrypting and decrypting databases, search for Encrypt 
or Deoypt with the Office Assistant. 

just as they will not convert, Access 1 .x objects that contain a backquote character 
(') in their names will not encrypt. You must rename such objects, using the ver­
sion of Access in which they were created, before you can encrypt them. 

Before turning off your computer, you should always exit Access properly by choosing 
File >- Exit. Proper shutdown ensures that all your database objects are saved to disk 
and prevents damage to your database. 

If a power outage or some other mishap occurs, some data might not be saved and 
your open database could be damaged. In most cases, Access can detect the damage 
automatically whenever you try to open, compact, encrypt, or decrypt the damaged 
database, and it will ask for permission to repair it. Simply choose OK when asked if you 
want to begin the repair process. 

Occasionally, however, Access might be unable to detect the problem, and the data­
base may behave strangely. In such a case, you can use the Repair Database command 
to fix the corrupted database. Here's how: 

1. Close any open databases using File > Close. As usual, any users on the network 
must also close the database. 

2. Use the Explorer to make a backup copy of the database. 
3. Choose Tools > Database Utilities > Repair Database. 

4. Choose the drive, folder, and name of the database you want to repair, then 
choose Repair. 

Once the repair is done, choose OK to clear the message that appears. You should 
now be able to open the database with the usual File > Open Database commands. 

If you were editing data when Access shut down unexpectedly, your last change may be 
lost after you repair the database. Return to the form or datasheet you were working with; 
if necessary, reenter your changes. Also check any other objects you were working on when 
the system shut down and redo any changes that didn't make it into the database. 
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When Repair Doesn't Solve the Problem 
Sometimes hard disk errors will prevent Access from repairing the database properly, or 
they may prevent Access from running at all. For these types of problems, you'll first need 
to run a hard disk repair utility (such as ScanDisk, which comes with Windows 95). Then 
try running Access and repairing the database again. If Access won't run at alC you'll need 
to reinstall it with the Setup program, as explained in Appendix A. If you can't repair the 
database satisfactorily, you must restore it from a backup copy. 

You can find online information about repairing databases by searching for Repair with 
the Office Assistant. To learn about ScanDisk, search Windows 95 Help for ScanDisk. 

Viewing Information a Your Database 

ljlijij:lltll 
The Properties 

dialog box for a 
table appears 

when you 
choose View )>­

Properties. 

Once you have created a database of objects, you may want to review the attributes of 
those objects from time to time. Access provides you two means of examining the prop­
erties associated with objects in a database. First, you can click on any object in the 
Database window and then select Properties from the View menu. This action opens a 
Properties dialog box like the one shown in Figure 17 .1. This dialog box tells you what 
the object is, when it was created, when it was last modified, who owns it, and whether 
it has the hidden or replicated attributes. You can enter further documentation into the 
Description text box if you desire to do so. In this way, you can store a description of 
each object in the database. 

• 
1\ly Company Information Properties 013 

General J 
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The Properties 

dialog box 
for an entire 

database. 

You can also view information about the database in general, as well as store addi­
tional information that documents the database and helps you to locate it. To view this 
information, select File > Database Properties. The properties dialog box shown in Fig. 
ure 17.2 appears. The General tab displays the attributes of the database file. The 

Contents tab provides a list of all the objects in the database. The Statistics tab provides 
some summary information about how the database has been used. 

The most useful tabs, however, are the Summary and Custom tabs. The Summary 
tab allows you to record information about who created the database and who owns it. 
You can also enter a description on this tab, as well as keywords to aid in searching for 
the file. The Custom tab allows you to define special properties for the database that 
help in searching for the file if you cannot remember its file name. Use the Name drop­
down combination box to enter a name for the property. Select a type from the Type 
drop-down list box. Then enter a value for the property in the Value text box. To add to 
the list of custom properties for the database select the Add button. You can use the Sum­
mary and Custom tabs to record a lot of information that documents your database. You 
can also search for a database file using the summary information and custom properties 
called up by choosing the Advanced button in any file dialog box. 

Genera!. Summiu.v J Statistics j C~ntents j CtHioml 
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Documenting Your Da 

lllrlQ:llt41 
The Documenter 

dialog box lets 
you choose 

which informa­
tion to include in 
the object defini­

tion report. 

When developing applications or sharing your database with other users, a helpful step 
is to include documentation about the various design elements in the database objects. 
For instance, you can preview or print a report of the properties, code, and permissions 
associated with controls on a form or report. Access makes it easy to produce database 
documentation for a single object, or for several objects at once. 

To document an object or a set of objects, follow these steps: 

1. Choose Tools>- Analyze>- Documenter. You'll see a Documenter dialog box, as in 
Figure 17 .3. 

The Documenter does not usually install when you install Access. You may have to 
install it using the Add/Remove Programs icon in the Control Panel. 

.. 
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2. Select the tab for the type of object you want to document. (Choose All Object 
Types to document the entire database.) Select the specific objects you want to doc­
ument by clicking on their checkboxes. Use the Select All and Deselect All buttons 
to simplify this process. 

3. (Optional) Click on the Options button if you'd like to select which properties are 
documented for an object, then select any properties you want by using the option 
buttons presented, and click on OK. 

4. Choose OK to generate the object definition. After a few moments, the Object Def­
inition report appears in a print preview window. 

5. Do any of the following: 

• To view the report, scroll through or zoom out or in as you would in any print 
preview window. 

• To print the report, click on the Print toolbar button or choose File >- Print. 
• To save the report as a table or as an external file, choose File >- Save As Table or 

File > Output To. If you choose the former, Access 97 will create a table called 
Object Definition. If you use Output To, choose a file format (HTML, Microsoft 
Excel, MS-DOS Text, or Rich Text Format) and choose OK. Enter a name in the 
Output To dialog box and click on OK. 

6. Click on the Close Window toolbar button or choose File >- Close. 

Figure 17.4 illustrates the first page of an object definition report for the Customers 
table in an order entry database generated using the Database Wizard. 

The object definitions can take some time to generate, so be patient. Grab a cup 
of coffee or turn on your favorite talk show to pass the time. 

mE r m r n r r 

Replicating Your 
These days almost everyone takes work with them on the road. What do you do when 
you want to take a copy of your database with you to work on? How do you manage 
changes you make while you are working away from the master copy? Access 97 allows 
you to replicate your database in its entirety or a selected portion. When it is replicated, 
the database contains special tables and properties that enable Access to distinguish 
between the design master, the copy that determines the overall structure of the data­
base, and a copy. Changes in design take place only within the design master, and tools 
are available that allow you to synchronize all of the copies of the data. 
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Creating a 

Replicas can be managed either through Access or the Windows 95 Briefcase. You always 
have a choice of which you prefer to use to create and synchronize your replicas. Before 
creating a replica, you need to take three steps: 

1. Remove the database password using Tools> Security> Unset Database Password. 
2. Be certain the Briefcase is installed. (If it is not, use the Add/Remove Programs icon 

in Control Panel to install it.) 

3. Be certain that Briefcase Replication was installed with Access. (If not, visit the 
Control Panel again.) 

If Briefcase Replication is not installed, Access will present a dialog box informing 
you of this fact when you try to create a replica the first time. 
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Then open the Explorer and drag the database to the Briefcase. When you drop the 
database file on the Briefcase, Access automatically converts it for replication. 

To create a replica using Access 97, follow these steps: 

1. Open the database you want to replicate and make sure all users of the database on 
a network have closed the database. 

2. Select Tools > Replication > Create Replica. 

3. Choose Yes in the dialog box to close the database. 

4. Choose either Yes or No in the next dialog box to make a backup of the database. 
5. Use the file dialog box presented to select a location for the replica and click on OK. 

~--~~~-41Gi 
Converting to a replicable database is a one-way process. The only way to make it 
nonreplicable is to create a new database and import the data from one of the 
replicas. 

You can make as many replicas of your design master as you wish. In fact, you can 
even make replicas from a replica. The total group of replicas you make is known as the 
replica set for the database. You add to the replica set by creating a new replica as 
described above. You remove replicas from the replica set by deleting the database file 
for the replica you want to remove. Only members of a replica set and their design mas­
ter can synchronize their data. 

A partial replica includes a subset of the records in a database. For example, you might 
want to give a salesperson a replica of a database that includes records for their territory 
only. Neither the Access menu nor toolbar commands give you an easy way to create a 
partial replica, but you can create a partial replica with a VBA program. 

For information on creating a partial replica, search for Replicate with Office Assis­
tant and click on Create Partial Replicas. 

How do you synchronize all of the changes made in your replica with the design master 
or with other replicas? The process is easy. Just follow these steps: 

1. Open the Briefcase and select the database file. 

2. Select Update Selection from the Briefcase menu. (You could also select Update AlL) 
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The Briefcase then automatically merges the changes with the copy of the database, 
either design master or replica, available on your desktop computer. If you would 
rather manage synchronization from Access, follow these steps instead: 

1. Open the database to synchronize. 
2. Select Tools >- Replication >- Synchronize Now. 
3. Select either the design master or another replica using the file dialog box and then 

choose OK. 
4. Click on Yes when prompted to close the database. 

If members of a replica set develop synchronization conflicts, Access prompts you to 
resolve them when you open the replica that has the conflicts. Selecting Resolve in this 
dialog box causes Access to lead you step by step through the process of conflict reso­
lution. You are offered the chance to copy fields or delete the conflicting record in 
order to resolve conflicts. 

You may encounter a situation in which you feel that a replica has been updated so 
significantly that you would rather have it as the design master. You can convert any 
member of a replica set into a design master using this procedure: 

1. Open the replica that will become the new design master. 
2. Select Tools >- Replication >- Synchronize Now. 
3. Select the current design master using the File dialog box and check the Make File­

name the Design Master checkbox. (Access fills in Filename with the name of the file 
you opened in step 1.) 

4. Choose OK to create the new design master. 

You might also encounter a situation in which a well-meaning user has deleted the 
design master. In this case choose the replica you want to use to replace the design master. 
Preferably this ·replica would be the most recently synchronized copy. Then synchronize 
this replica with as many others as you feel necessary to build an accurate master copy of 
the data. Finally, open the replica that will replace the design master and choose Tools > 
Replication>- Recover Design Master. Click on the Yes button when Access prompts you to 
confirm that you have synchronized this replica with all others. 

Where to Go from Here 
You have just learned quite a bit about administering a database in either a single-user or a 
multiuser environment. In discussing administration, we have covered topics that imply 
that your database resides on a network. The next chapter deals more fully with the issues 
of networking and security and expands upon some of the issues dealt with briefly here. 
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What's New in the 
Access Zoo? 

You've just taken a lo.ok at many of the fea~ 
tures that make Access 9 7 for Windows 95 
easy for database (ldministrators to use. 
These features include 

• The ability to replicate a database so 
that multiple users can work with 
copies of the data 

• The ability to convert Access l.x, 2.0, 
and Access 95 databases to the 
Access 97 for Windows 95 format 

• Assistance with documenting your 
databases. 
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Networking and Securit~ 

his chapter covers two issues that will 
be of interest to anyone responsible 
for an Access installation on a net­

work. The first is the one on most network administrators' minds: how to get peak 
performance from Access on a network. The second topic is setting up a security scheme 
to prevent unauthorized users from accidentally or deliberately harming objects within 
your Access applications. 

Allowing Users to Share Data 
In many organizations multiple users must have simultaneous access to the same data. 
Access is designed to support multiuser databases "out of the box," but you will need to 
consider a few factors carefully. The first is where to store the application itself. You can 
set up your database in either of two ways to allow multiple users to share data and 
other objects, as discussed in the sections that follow. 
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Option 1: Put the Entire Database on the Server 

l#(ij@ll:ll 
If you put the 
entire Access 

.mdb file on the 
server, all users 

will share all 
objects. 

One way to give multiple users access to a database is simply to put the entire database 
(that is, the entire Access .mdb file) on the server, as shown in Figure 18.1. With this 
approach, there's no difference between a single-user database and a multiuser one; you 
just transfer the database to a shared drive and tell your users where to find it. 

The one advantage to this approach is that all users share all the same objects. Thus 
a change to any object, including a form, report, or macro, is instantly accessible to all 
users. Data changes-such as adding, editing, or deleting records from a table-are also 
immediately visible. 

<»'111"'1E. 

You must be extremely careful when changing the design of any object in a shared 
database. If two users are doing design work in the same database simultaneously, 
the database may become corrupted if one saves changes to an object the other 
has already modified. For safety, do not allow more than one user at a time to mod­
ify objects and always keep a backup of any networked database. Make sure every-
one logs off before you back up the database so know it's in 
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Option Put On s on 
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tion database. 

The downside to putting the entire database on the server is that you end up with a lot 
of network traffic. Virtually every object that each user opens needs to come across the 
network. This includes forms and reports, which are normally static in an application 
in use, as well as the changeable tables. As an alternative, you can put just the shared 
tables on the server in a "data" database. Then set up a database that contains all objects 
except those shared tables, and put a copy of that "application" database on each work­
station, as in the example shown in Figure 18.2. You can then use the File> Get External 
Data > Link Tables menu item to link the tables in the data database to those in the 

application database so that all users can see the shared data. 
For more information on linked tables, see Chapter 7. 
This approach has both an upside and a downside: 

• It reduces network traffic because only shared table data is transmitted across the net­
work. Forms, reports, and other objects are read from each user's local hard drive. 

• The network administrator can more easily back up just the tables in the database 

because the tables are stored independently of the other objects. 
• If a user changes some other object (such as a form, report, or macro), that change 

affects only his or her workstation. Other users never see that change. 

(The last item in the list can be either a curse or a blessing, depending on whether 

the user improves or destroys the modified object.) 
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To prevent users from changing objects, you'll need to use Access security features to 
database (see "Securing Your Database," later in this chapter). 

the Tables 
Putting just the shared tables on the network is easier than ever in Access 97, thanks to 
the Database Splitter Wizard. Here we'll take you through an example using our Order 

Entry database generated using the Database Wizard. 
To create the database of shared tables, you need to do the following (you should 

already know how to use the Windows Explorer or the MS-DOS prompt to copy files 

and create directories): 

1. Make a backup copy of the entire Order Entry database and give this copy a new 
name. (In the case of this example, the original database is named Order Entryl.mdb. 

We made a copy called OrderEntryBackup.mdb. Long file names are useful.) This copy 
will provide a safety net in case you later decide that you didn't really want to split 

the database after all. 
2. Open the database that you want to split. Hold down the Shift key when you open 

the database so the Switchboard form won't open. 
3. Select Tools> Add-ins> Database Splitter. This action starts the Database Splitter 

Wizard, shown here. 

ThiS wizard mo 
database .to a 
usef envito 
and allows continU.(;I\IS frot*eJid. devefotl[Jle~l 
without affecti(lg data <)t[nlenupti(lg ~rs. 

It could bi> a long process. t<\<>1<.~ a backup 
copy of ynur database:before splitting it : 

VIO\lld you like tosplit the <;latabas~ now? 

4. Read the information on the Wizard screen and then click on the Split Database 

button. 
5. Enter a name for your back-end database in the File name text box of the Create 

Back-end Database dialog box. Make sure that the directory is the correct directory 

on the network drive. Then click on the Split button. 
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Be sure to close all open objects (Tables, Queries, Forms, and Reports) before split­
ting your database. Otherwise, the Database Splitter will not be able to properly 

export and reattach the tables. 

l#lrlll;lll:ll 
Order 

Entryl be.mdb 
contciins only 

the tables from 
the original 

database. 

6. Click on the OK button when you see a dialog box announcing that the database 
was successfully split. You now have two versions of the database, the back-end 
version containing just the tables and the original version containing all the rest of 

the objects and links to the tables in the back-end version. 

7. Close the open version of the database. 

At this point, the server holds a copy of the database tables (in their own .mdb file) 
that you want the users to share. By checking the Contents tab of the File >- Database 
Properties dialog box, you can see that this back-end database contains only the tables 

from the original database, as shown in Figure 18.3. 
The original Order Entryl.mdb file contains all of the other database objects plus links 

to the tables in the Order Entryl_be.mdb database. The names of linked tables are now 

marked with an icon in the local database, as shown in Figure 18.4. 
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Now you can put a copy of the local database on every user's workstation. When the 
user opens the local copy of the database, Access will automatically link to the shared 
tables on the server and handle any conflicts that arise when two or more users try to 
edit the same data. (See "Editing on a Network" later in this chapter.) 

If you ever need to change the links to the tables, select Tools > Add-ins > 
Linked Table Manager. Check the Always prompt for new location checkbox in 
the Linked Table Manager dialog box, and you will have the opportunity to 
edit the link information using a standard file dialog box. 

Preventing Exclusive Access 
When users will be sharing data in an Access database, you need to make sure that no 
single user opens the database in Exclusive mode. Otherwise, no other users can open 
that database. Access for Windows 95 has changed its default behavior to support shared 
access more directly than previous versions. The default values for most settings support 
shared access. To make certain that use of Exclusive mode is discouraged or prevented, 
you can take these three steps: 

• Instruct all users to make certain the Exclusive checkbox is cleared in the Open Data­
base dialog box (after choosing File > Open Database) before opening the database. 
(fhis checkbox is cleared by default. This approach assumes, of course, that all users 
will be conscientious about not choosing to open a database in Exclusive mode.) 
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• Choose Tools > Options from the Access menu bar, select the Advanced tab, and 
make sure the Default Open Mode option is set to Shared, its default value. This 
setting automatically clears the Exclusive checkbox when the user first gets to the 
Open Database dialog box. 

• Set up a security system (discussed later in this chapter) that denies the Open 
Exclusive permissions to selected users. This is the strictest control, since it 
doesn't even let users open the database exclusively. 

Of course, you'll need to grant yourself and other administrative users the right to 
open the database in Exclusive mode so that you can perform operations that require 
exclusive use, such as backing up, compacting, and repairing the database. 

For more information on compacting and repairing, see Chapter 17. 

Creating Upgradeable Custom Applications 
Separating the tables from the other database objects is also a good strategy if you plan 
to market a custom application that you've created or if you need to maintain a data­
base that you've already distributed on a network to multiple users. 

You can put all the tables for an application in one database, and then put all the 
other objects in a separate database. Use the Database Splitter Wizard, as in the example 
above, to split all the tables in the separate database. 

Be sure to distribute both databases to first-time buyers or users. When you release 
an upgraded version of your product, send the upgraders only the database (.mdb) file 
that contains the objects, not the database containing tables. That way, you don't have 
to worry about users overwriting their existing data when they install your upgraded 
version. Instead, they'll just link the new front-end database to their existing tables. 

Avoid changing the structure of tables after the initial release of your application. 
Otherwise, you'll need to ship the revised tables, and you'll need to provide a 
convenient way for users to put their data into your newly structured tables. This 
procedure can be a nuisance for both you and the upgraders. 

Editing Data on a Network 
Access uses a simple, common-sense strategy for handling conflicts that occur when 

two or more users edit the same data. The way Access handles such conflicts depends 
on the Record Locks property of the form your users are using to do the edits, as shown 
in Figure 18.5. 
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Record Source. . SELECT [Employees].' FROM [I 
Filter ....... . 
Order By .. . 
Allow Filters ...• 
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Default View .. 
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Data Entry.. . . . . No 
Recordset Type ••. 
Record Locks .... 
Scroll Bars .. 
Record Selectors .. 
Navigation Buttons <..::..=c.:..::..'-""'==------' 
Dividing lines.... Yes 
Auto Fiesi<:e •....• Yes 
Auto Center Yes 
PopUp.... No 
ModaL:..... .. No 
BorderStj>le .. ·. . . Sizable ... .ti I 

We'll discuss conflict handling in datasheets a little later, since most often you'll 
have your network users working via forms. 

• 

If the Record Locks property is set to Edited Record, when one user is editing a record 
(so that the pencil symbol appears in that record's selector) and another user tries to 
edit that same record, the second user sees an international No symbol, indicating that 
the record is locked by another user. 

Access may take up to 60 seconds to display the No symbol when another user is 
editing a record. You can change this interval on the Advanced tab of the Tools> 
Options dialog box. Set the Refresh Interval to the maximum number of seconds 
you want Access to wait before updating a record's locking status. 

When the first user saves the changes, the No symbol disappears, Access updates the 
view of the record on both machines, and the second user can then view and change 
that same record. Figure 18.6 shows the situation where one user has "locked out" 
another user by editing a record. 
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Access saves the changes to a record whenever you move the cursor to another 
record or choose Records> Save Record or press Shift+Enter. 

" 

If Record Locks is set to No Locks, both users will be allowed to edit the record. How­
ever, when the second user tries to save the changes after the first user has done so, Access 
offers the second user the chance to overwrite the first user's changes, copy the record to 
the Clipboard for pasting into the table later, or discard the changes, with the dialog box 
shown in Figure 18.7. 

If you get this dialog box on your screen, it means you have tried to modify a record that 
another user has already changed. You have three choices for dealing with this situation: 

• Choose Save Record to have your changes overwrite whatever the other user 
saved, without inspecting the records. 

• Choose Drop Changes to leave the other user's record alone and discard any 
changes you have made. 

" Choose Copy to Clipboard to leave the other user's record alone but place your 
own changes on the Windows Clipboard. When you do this, your form will be 
updated to show the other user's changes. If you decide you'd rather keep your 
version, simply click on the form's record selector to select the whole record, and 
choose Edit>- Paste or press Ctrl+V to return your changes to the form. Then save 
your record again. 
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Access automatically refreshes each user's screen at regular intervals, to help ensure that 
each user is seeing current data. However, you can force Access to refresh your data at 

any time by choosing Records > Refresh. 
When Access refreshes the current form or datasheet, it updates changes and indicates 

deleted records. However, it does not reorder records, show new records, or update a 
dynaset to show or hide records that no longer meet the underlying query's selection cri­

teria. To force Accessto refresh a dynaset completely, press Requery (Shift+F9). 

Access does not support a single network strategy that works perfectly for all situations. 
You may need to experiment with some of the default settings to achieve maximum 

performance with minimal conflicts on your own network. Here's how: 

1. Choose Tools > Options from the Access menu bar. 
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2. Click on the Advanced tab to view the multiuser and ODBC settings, as below. 

Options 613 
l General lHyperlinks/HTMt! Edit/Flnd l 
I T ables/Querle~ 1. Forms/ReportS l 

3. Use Table 18.1 (and the built-in help) to choose new settings. 

OPTION SETTING 

Default Record Locking No Locks (default) 

All Records 

Edited Records 

RESULT 

Records are not locked dur­

ing edits. 

All records underlying a par­
ticular object (e.g., a form) 
are locked when that object 

is open. 

Only the record being edited 

is locked. 
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I 
OPTION SETTING RESULT 

Default Open Mode Shared (default) Database is open for shared 
use by default. 

Exclusive Database is open for 
exclusive use. 

Refresh Interval 1 to 32,766 seconds Updates your screen at the 

(default= 60) specified interval. 

Update Retry Interval (see 0 to 1,000 milliseconds Waits for the specified time 

the section "Minimizing (default= 250) before trying again to save a 

Conflicts") 
locked record. 

Number of Update Retries 0 to 10 (default= 2) Number of times Access will 
automatically try to save a 
change to a record that 
another user has locked. 

ODBC Refresh Interval 1 to 3,600 seconds Updates your screen at the 
specified interval when 
you're accessing a database 
using ODBC. 

Ignore DDE Requests Default is No (unchecked) Determines whether Access 
responds to DDE requests 
from other applications. 

Enable DDE Refresh Default is Yes (checked) Determines whether DDE 
links are refreshed whenever 
the screen is updated. 

OLE/DDE Timeout 0 to 300 seconds Determines how long Access 

(default= 30) waits for an OLE or DDE 
operation to complete. 

4. Choose OK when you're done. 

The Record Locks property applies only to forms. The Default Record Locking setting in 

the Advanced options tab applies to datasheet views of tables and queries and to dynasets 

opened in Basic. The same rules for resolving write conflicts apply in all cases. If you 
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encounter a record-locking conflict in a Visual Basic procedure, Access generates a cus­

tom error that you can trap and respond to. 
For more information on dealing with errors in your Visual Basic code, see Chapter 25 

or search for Errors with the Office Assistant. 
Now that you know the various record-locking settings, how do you choose among 

them? It depends on how your users use the data and how much training you can 

give them. Let's look at the pros and cons of each strategy. 

No Locks Strategy 
As we explained above, when you use the No Locks strategy (sometimes called optimis­
tic locking), records are not locked while being edited. Two users can edit the record at 
the same time. When you try to save your changes to a record that somebody else has 
also changed, you'll be given the option to overwrite the other user's changes, copy your 
version of the record to the Clipboard, or discard your changes, as discussed above. 

Although the No Locks strategy offers the most flexibility, it also creates two poten-

tially unpleasant situations: 

• After you make changes to a record, another user can easily overwrite those 

changes. 
• Another user can lock a record that you're editing. You won't be able to save your 

changes until the other user unlocks the record. 

An alternative to the No Locks strategy is to automatically lock whatever record is 

being edited. 

Edited Record Strategy 
When you choose the Edited Record locking strategy (sometimes called pessimistic lock­
ing), any record that's currently being edited by one user is locked and unavailable to all 
other users. No two people can edit the same record at the same time, which means: 

• On the upside, Access automatically ensures that no two users edit the same record 
at the same time. And you can be sure that once you start editing a record you'll be 

able to save your changes. 
• On the downside, other users may start getting irritated if you keep a particular 

record locked for too long. Even worse, a record lock in Access nearly always 
affects more than one record, since Access locks records in 2048-byte pages. This 
means that users can be locked out of records that no one else is editing, as shown 

in Figure 18.8. 
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When you're attached to a SQL database via ODBC, the rules of the SQL database 
govern locking. Access always acts as if you've selected the No Locks (optimistic 

locking) strategy. 

The solution to the problem, of course, is to practice good network citizenship and 
make sure that you always save a record immediately after you've made your changes. 
That way, other users will have instant access to the modified record. 

All Records Strategy 
The most restrictive locking option is All Records. Once a user opens a form or datasheet, 
that user has a lock on all its records. No other users can change any records in the table 
as long as that person is using the table. Use this method only if you're absolutely sure 
that you want only one person at a time to be able to make changes to a table. The need 
for this option is generally limited to administrative table changes that have to be com­

pleted without interference from other users. 
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Choosing a locking Strategy 
Which locking strategy should you use? The answer depends on your data and your 
application, of course. But for almost all networked Access applications, we've found 
that the benefits of the No Locks strategy far outweigh its disadvantages. Although 
you'll have to train your users to deal with the occasional write conflict errors that may 
occur, the gain in performance more than balances this inconvenience. 

In addition, in most workplaces you can use the natural workflow to reduce or elim­
inate record-locking conflicts. If]oe is responsible for customers whose last names start 
with A through M and Mary is responsible for those from N through Z, they won't even 
be trying to edit the same records at the same time. 

Minimizing locking Conflicts 
When Access encounters a locking conflict, it will make several tries to save the record 
before giving up and showing an error message to the user. Access waits for whatever 
period of time is specified in the Update Retry Interval multiuser setting and then tries 
to save the record again. It repeats this process as many times as you've specified in the 
Number of Update Retries setting. If it can't resolve the conflict after that number of 
tries, then it displays a locking conflict error message. 

You can minimize update conflicts and error messages by tweaking those two set­
tings. For example, if users frequently get locking error messages, and you think it's 
because too many people are trying to save data at the same moment, then increase 
both settings. Access will wait longer, and try more times, before showing the error 
message. Of course, if many locking conflicts occur, this setting will make your appli­
cation appear to be more sluggish as it makes multiple futile retries to save the data. 

On the other hand, if you want Access to display a locking error message as soon as 
a conflict occurs, set the Number of Update Retries option to zero. 

Securing Your Database 
Access allows you to implement security on your database objects as you need it. By 
default, security is completely invisible to both the designers and the users of an Access 
database. As your needs require it, you can secure individual objects so that, for exam­
ple, most users can't modify a particular form. If you are extremely concerned about 
security, you can use Access to remove all but a few ways to retrieve data from your 
tables. In networked applications, a well-designed security system can help make the 
application more maintainable by eliminating many sources of potential disaster. 
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Security Concepts 
To understand Access security, you'll need to grasp four basic security concepts: users 
and groups have permissions on objects. 

• An Access user represents a single person who uses an Access application. Users are 
distinguished by their user name, password, and a unique secret identifier called 
the Personal Identifier (PID). To use a secured Access application, a user has to 
type in her user name and password to be able to get to any objects. 

• An Access group is a collection of users. You can use groups to represent parts of your 
organization, such as Development and Accounting, or simply security levels, such as 
High and Low. Often you'll find that assigning users to groups, and permissions 
directly to those groups, makes a security system more maintainable. 

• An Access permission is the right to perform a single operation on an object. For 
example, a user can be granted read data permission on a table, allowing that user 
to retrieve data from that table. Both users and groups can be assigned permissions. 

" An Access security object is any one of the main database container objects (table, 
query, form, report, macro, or module) or a database itself . 

.-.IIIRI! INII II IN!Ic:;;; 

Because both users and groups can have permissions, you may have to check several 
places to determine a user's actual permissions. The user's actual permissions are the 
least restrictive combination of the user's own permissions (called explicit permissions) 
and the permissions of all groups the user belongs to (called implicit permissions). So 
if Mary does not have permission to open the Accounting form, but she's a member 
of the Supervisors group that does have permission to open that form, she will be 
able to open the form. 

Access includes a rich set of permissions that you can assign to groups and individuals 
on an object-by-object basis. You can grant any of the permissions listed in Table 18.2 to 
any group or to any individual user in a group. 

s 
Every single time you start Access, you must supply a valid user name and password. Sur­
prised? Think you've got a special copy of Access that doesn't require this step? That's 
because Access does its best to be helpful. When you launch Access, it automatically tries to 
log you on as a user named Admin with a blank password. If this process works-and you 
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PERMISSION PERMITS USER TO CAN BE APPLIED TO 

Open/Run Open a database, form, report, or Databases, forms, reports, 

run a macro macros 

Open Exclusive Open a database with exclusive Databases 

access 

Read Design Look at an object in design view All object types 

Modify Design View, change, and delete objects All object types 

Administer Full access, including the right to All objects and the security 

assign permissions to users system 

Read Data View, but not alter, data Tables and queries 

Update Data View and change data, but not Tables and queries 

insert or delete 

Insert Data View and add data, but not modify Tables and queries 

or delete 

Delete Data View and delete data, but not add Tables and queries 

or 

haven't activated your security system by assigning a password to the Admin user--Access 

suppresses the logon dialog box completely. 
To be able to log on as any other user, you'll need to assign a password to the Admin 

user, as discussed below. The next time you start Access, you'll see this logon dialog box: 

Logon 013 

!;!ame: 

!Admin 

Eass;va!d: . 

I .QK I 
cancel .. l 
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If for some reason you decide to deactivate security, you can suppress the logon 

dialog box by changing the Admin user's password back to a blank. 

Workgroup Files 
Access stores security information in a workgroup file, which is named system.mdw by 
default. Access includes a tool, called the Workgroup Administrator, to create new 
workgroup files. To create a new workgroup file, follow these steps: 

1. Locate the Workgroup Administrator (wrkgadm.exe) item in Explorer and open it, as 

shown below. 

2. Click on Create. 

Workgroup Administrator 

Name; 
Company: 
Workgroup 

Mike Gunde•hoy 
Pyramid Computers 
C:)MSOFFICEIACC.ESS\SYSTEM.MDW 

Y o1ri wodcgroup is defined by th€'1 v<orkgroup information fil~ ihat is used at 
starl\fp. You c<>() create a new ':Norkgro.uP by creating a ne~( information 
file, or loin an existing workgroup by changing the information file that is 
used at.ttartup . 

.-l1~ ••• ~li.',.._•~.a~Je-:;.:..,::""'J) Joir;.. 

3. Supply a name, organization, and unique Workgroup ID (WID). The WID is used 
by Access to make sure that your workgroup is unique. Store this information in a 
safe place-you'll need it if you ever need to re-create your original workgroup. 

Workgroup Owner Information 13 
' '•i .··'·, ·.--·· ,'' ',' ·.·:·;,,· ·•. '.· .,-, 

!he new workgroup. information file is i<:jentified by the t1am~. 
organization. ar.d case·sensitive workgroup 10 ;>ou specify. 
Use the nom~ apd organizatio<J information below, or enter a different 
r\~;me or organization. !f'you want to ensure thatyour workg~oup is. 
uniq\je. al~o enter. a \mique wprkgroup ID ofw to 20 num!l.ers or 
letters. · 

l'iameo j Mike G underlo~ 

.Q.tganiza!ion' · "s'""~'""be-,~~~-'-"------~~ 

WoflsgrocipiD: l224em78N9~ 

OK . J ·. Cancel 
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4. Supply a path and file name for the new Workgroup file. You should use the .mdw 

extension for this file. 

Workgroup Information File Ei 
U$e the path and name below. or enter a different path and name tor the 
new wmkgroup infomation file, 

Qatabase: OS OFT OFFICE 97\0FFICE\SYBEX ~IDY,i !l.rowse ... 

OK C<~ncel 

5. Click on OK three times to create the new workgroup, confirm its information, and 

return to the main Workgroup Administrator screen. 
6. Click on Exit to close the Workgroup Administrator. 

-.BRr.- Ill - <G; 

The original workgroup file created when you install Access is not secure because 
Access creates it for you using the user name and organization name you used for 
the Access install and a blank WID. Anyone who can get to your computer and 
use Help > About in any Office application can recover this information and so 
re-create your original workgroup file. Armed with this file, an intruder can break 

any security scheme you design. 

To learn more about workgroups and the workgroup information file, search for 
Workgroup File with the Office Assistant and click on Create A New Microsoft Access Work-

group Information File. 
You can also use Workgroup Administrator to switch from one workgroup file to 

another. You'll need to do this if you have secured databases from two different sources. 

To switch workgroups, follow these steps: 

1. Locate the Workgroup Administrator (wrkgadm. ex e) item in Explorer and open it. 

2. Click on the Join button. 
3. Type in the name of the workgroup you want to join 

Or 

Use the Browse button to locate the file on your drive. 
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I 

I 

4. Click on the OK button twice to join the new workgroup and confirm the informa­
tion message. 

You have successfully joined the wmkgroup defined by the workgroup informatiorffile 
C:\MSOFFICE\I>.CCESS\SYSTEM.MDW. 

5. Click on Exit to close the Workgroup Administrator. 

and 
Every Access workgroup comes with the built-in user and groups listed in Table 18.3 
and Table 18.4. Access created this user and these groups to provide a bare bones secu­
rity system. 

USER 

Admin 

GROUP 

Admins 

Users 

MEMBER OF COMMENTS 

Admins, Users Default logon user 

CONTAINS COMMENTS 

Admin 

Admin 

Any member has full permissions on all 
objects, regardless of security. 

Members by default have permissions 
on all objects. 

The most important thing to realize about the built-in user and groups is that most of 
them are not secure and cannot be made secure. The Admin user and the Users group are 
identical in every single workgroup file ever created. If you assign permissions to Admin 
or Users, you are in effect making those permissions available to any Access user. 
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Since the Admin user has full permissions on all objects by default, and everyone is 
logged in as the Admin user unless they've activated their security (that is, placed a 
password on the database), this system ensures that all users can swap databases with-

out worrying about security. 

Ownership: The per Permission 
Another important security concept is the idea of ownership. Whoever creates an object 
in the first place, or imports it from another database, is the initial owner of the object. 
The owner can give ownership to another user or group, or any member of the Admins 

group can reassign the ownership of any object. 

Assigning object ownership to a group such as Developers makes it easier for 
in a secured database. 

The owner of an object always has Administer permission on that object, even if 
someone else tries to take it away-and in some cases, even if the interface erroneously 
reports that they don't have this permission. Therefore, an object's owner can do any­

thing with that object, no matter how anyone else tries to limit the owner. 

Working with and 
The first step for implementing a security system is to decide which users and groups 
you'll need. You'll need to keep at least one user-usually yourself-in the Admins group, 
since only members of the Admins group can create new users and perform other security 
tasks. Other users should be grouped by the tasks they need to perform so that you can 
assign permissions to groups. A security scheme for a small database might look like the 

diagram in Figure 18.9. 
Select Tools> Security> User and Group Accounts from the Access menu to open 

the User and Group Accounts dialog box. From this dialog box you can create and 
delete users and groups, assign users to groups, and change your own password. 
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lilrlQ:lll:fJI 
Plan for security 

in an Access 
database. Admins Managers 

The Users Tab 

Developers Data Entry Reporting 

Louise Bill 

The Users tab has a combo box at the top where you can select any user in the system. The 
Group Membership section shows which groups this user is a member of. 

• To create a new user, click on the New button. In the dialog box that appears, supply 
a unique name and Personal ID (PID) for the user. Click on the OK button to create 
the user. Access uses the PID to uniquely identify the user you've just created. 

• 
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The PID is not a password. New users are already created without a 
assign a password to a user, close Access, reopen it, log on as the new user, and use 
the User and Group Accounts dialog box to set that user's password. 

• To delete a user, select the user in the combo box and click on the Delete button; 
then click on the Yes button to confirm the delete. You can't delete any of the built-

in users. 
• To clear the password of a user who has forgotten his or her password, click 

on the Clear Password button. 
• To add a user to a group, select the group in the left list box and click on the 

Add>> button. 
• To remove a user from a group, select the group in the right-hand list box and 

click on the <<Remove button. 

You can't remove any user from the Users group, and you can't remove the last 

member from the Admins group. 

The Groups Tab 

The Groups tab has a single combo box that shows you all of the existing groups in 

your database. 
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• To create a new group, click on the New button, supply a name and Personal ID 
(PID) for the new group, and click on the OK button. Access uses the PID to make 
this new group unique. 

You should store all of the PIDs you use for both users and groups, along with the 
WID for your workgroup file. If your workgroup file is ever lost or corrupted, you 
can use this information to re-create the information it contains. 

• To delete a group, select the group in the combo box, click on the Delete button, 
and click on the Yes button to confirm the deletion. 

The Change Logon Password Tab 

User and Group Accounts 6£1 

Users I Groups Ch<!nge Logon PasSword I 
Usei Name: Admin 

.Qid Password: 

b!ew Password: 

]!erify: 
~-~---

OK Caricel 

To change your password, enter your current password and then enter the new pass­
word, typing it the same way twice. Access checks that you didn't accidentally mistype 
the new password. 

Viewing ip d s 
To modify object permissions and ownership, select Tools> Security> User and 
Group Permissions from the Access menus. 
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The Permissions Tab 
To check the permissions by user for individual database objects, click on the Permis­

sions tab. Then use the dialog box as follows: 

Permisdons I Change Owner J 

Us~r/G10up !:lame: .Qbiect Name: 

_All Fields 
Cw:tomers 
Employees 
Emplo}lees \Vith Supervisors 
My Compan_y Information 
My Customers 
My Orders 

Obiect T ~pe: j Table 

• To view a user's permissions on any object, first choose the Users radio button. 
Then click on the user whose permission you want to check in the list box. Select 
the type of the object from the combo box. Select the object in the object list box. 
The Permissions area will show the current explicit permissions for this user. 

• To view a group's permissions on any object, first choose the Groups radio but­
ton. Then click on the group whose permission you want to check in the list box. 
Select the type of the object from the combo box. Select the object in the object 
list box. The Permissions area will show the current permissions for this group. 

" To change permissions on an object, first choose the user or group you want to 
change permissions for, as above. Select the type of object from the combo box. 
Select one or more objects in the list box. Click in the Permissions checkboxes to 
select or deselect the various permissions. When the correct set of permissions is 

showing, click on the Apply button to make the changes. 
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The Change Owner Tab 
If you click on the Change Owner tab you can view the current owner of an object or 
change the owner. 

User and Gwup Permissions 013 

Permissions Change Owner j 
Qbiect: 

Customers 
Employees 
Employees \1/ith Supervisors 
My Company Information 
My Customers 
My Orders 

Current Owner 

Admin 
Admin 
.6.drnin 
Admin 
Admin 
Admin 

Obiectlype: t!ew Owner: 

!lililli-011: 111111113::1· J.il.dmin 

List: ·r· firoups r.' !,!sers 

Change Owr1er 

Current User: 

" To view the current owner of an object, select the Object Type in the left combo 
box. Select one or more objects. The New Owner combo box will show you the 
current owner of these objects. (If you select objects owned by more than one user 
or group, the box will remain blank.) 

" To change ownership, select the Object Type in the left combo box. Select one or 
more objects. Select the New Owner from the combo box and click on Change 
Owner. 

r 

As you've seen so far, Access security can be a complex business. The interactions of 
users, groups, owners, objects, and permissions require careful study. However, follow­
ing a few simple steps will help ensure the integrity of your security system. 

1. (Optional) If you haven't done so already, use the Workgroup Administrator to cre­
ate a new, unique Workgroup. Store the WID in a safe place. 
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When you 

launch the User­
Level Security 

Wizard, you 
can choose 

exactly which 
objects in 

your database 
to secure. 
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2. Start Access and create a new user for yourself to use. Add this user to the Admins 

group. 
3. Change the Admin user password to any nonblank string. Store this password in a 

safe place in case you later decide to desecure the database. 
4. Exit and restart Access. Log in as your new user. Change the password on your new 

user to something known only to you. 
5. Create any other users and groups you require. Store the PIDs in a safe place in case 

you ever need to re-create one of these users or groups. 
6. Run the Access Security Wizard (described below) to remove permissions from the 

database. 
7. Assign permissions to those users and groups you want to be able to work with 

objects. 

level 
Access includes a built-in User-Level Security Wizard to handle some of the tedium of secur­
ing a database. The User-Level Security Wizard makes a new copy of your database owned 
by the user who runs the Wizard, makes sure all objects in that database are owned by that 
user as well, and removes all permissions for the Admin user and the Users group from 
these objects. It also encrypts your database for protection from prying eyes armed with 

hex editors. 
To use the User-Level Security Wizard, choose Tools> Security> User-Level Security 

Wizard from the menus. The Wizard starts by asking you which objects to secure, as 
shown in Figure 18.10. Most of the time you will want to secure all objects in your 

database. 
When you proceed from this dialog box, Access will prompt you for a file name for 

your new secured database. The Wizard will then create this new database and make 

lffi User-Level Security Wizard Ei 

The.Sec(uity Wizard creates' a new secured d.otabase from your 
existing umecured data\)ase.Yota existing database isn't modified 
in ar& way •. If you've never. used Microsoft Access Security before; 

. click Help for an o:verview. 

I (:Q,(i;l I 
Cancel I 

Help I 

.. 
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secured copies of your objects in it. The process ends with the congratulatory message 

shown here. 

Security Wizard II 

( .. ':fn F:\My06cuments\Sybex\Mastering Microsoft v Access\Databas~s\Qrde~ Entiyhec.mdb .is now iecured .. Only mer 
Mike. a~d members of t~e Admins gro\lP of the current Workgroup 
have permissions.orrlhe databa.se and the selected objects in it 

F:\My [)ociinwnts\Sybex\Mastetihg Microsoft .... · · . . .. · • 
.l:.ccess\Pqtabases\Orde! Entrytmdb hasn't been modified in any 
way. 

Click HelP for an ove)view of c(eating users ahdgrol,lps and setting 
permissions. 

Here are some additional sources of information about security: 

• From the Access menu bar, choose Help > Contents and Index and click the Con­
tents tab. Select Securing A Database and double-click on the topic you're interested 
in. You can then choose Options> Print Topic from the Help window's button bar 

to print the topic as needed. 
" For tips on planning database security, search for Security with the Office Assistant 

and then click on Secure A Database. 
• You can also refer to Chapter 14 in the Building Applications manual that comes 

with your Access program. 
• Clicking on Help from the User-Level Security Wizard will provide you with an 

overview of using Access security. 

Skating Past the logon Dialog Box 
Once you've activated the login procedure for Access (which you do by setting up a 
password for the Admin user), you'll always be faced with this dialog box as soon as you 

start Access: 

Logon DE3 

jAdmin 

.Eassword: 

OK 

Ci>ncel 
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If you get tired of filling out the dialog box, you can put your user name and (option­
ally) your password into your startup command. That way, Access will fill in the dialog 

box automatically and take you right past it. 
To set up a custom startup command, you can use any combination of these three 

custom startup switches: 

<database name> If you want to create a shortcut to open a particular database 
when you start Access, follow the startup command with a blank space and the 

location and name of the database you want to open. 
/User <user name> To supply a user name at startup, follow the startup com-
mand with a space, followed by /User, followed by a space and your user name. 
/Pwd <]Jassword > To supply your password at startup, follow the startup com­
mand with a space, followed by /Pwd, followed by another space and your password. 

You can set up a custom startup command by using Windows Explorer. The proce­
dure we'll explain here doesn't change the way your original copy of Access works at 
all. Rather, it creates a new icon on your Windows desktop and associates it with your 

selected settings. Here are the exact steps: 

1. Launch the Windows Explorer, make sure it doesn't fill the whole screen, and nav­
igate to the folder containing the msaccess. exe program (usually the c: \program 

fi 1 es\msoffi ce\access folder). 
2. Drag this program out of Explorer by holding down the right mouse button and 

drop it on any blank area of your Windows desktop. Select Create Shortcut(s) Here 

from the context menu that appears when you drop the program. 
3. Right-click on the icon you just created. Select Properties from the menu and click 

on the Shortcut tab in the Properties dialog box. 
4. Enter the command line switches in the Target text box and choose OK. 

Let's suppose that you've been assigned the user name Gondola and the password 
omnipotent. Furthermore, you want to have this shortcut automatically open the data­
base named ContactManagementl.mdb in the c: \contact folder. In that case you'd 

want to change the startup command in the Command Line text box to: 

C:\MSOFFICE\ACCESS\MSACCESS.EXE c:\contact\ 
ContactManagementl.mdb /User Gondola /Pwd omnipotent 

The one risk here, of course, is that anyone who has access to your computer, and a 
little knowledge of shortcuts, can look up your password in about two seconds flat. If 
that's a risk you cannot afford to take, then you can leave the password out of the startup 
command (in my example, remove /Pwd omnipotent). If you choose this option, you'll 

have to provide the password each time you start Access. 
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For more information on custom Access startup commands, search for Startup with 
the Office Assistant and click on Startup Command-Line Options. 

Password Securitq 
As you've seen above, the full Access security model can be quite complex to imple­
ment and maintain. If you're interested only in protecting your own database from 
prying eyes, you can use the Database Password feature, which is a simpler way to lock 
up your data. This feature isn't really suitable for networked, multiuser applications, 
since it doesn't let you distinguish among individual users. But it can be an easy way to 
add some security to single-user databases. 

To set a password on your database: 

1. Open the database, being sure to check the Exclusive box on the File Open dialog 
box, and choose Tools >- Security >- Set Database Password. 

2. Choose a password and type it into both the Password and Verify boxes (tYPing it 

twice is a precaution to prevent you from making an accidental mistake the first time). 
3. Click on the OK button. 

When you attempt to open this database in the future, you'll see the dialog box 
below. Enter the same password you chose in step 2 above to get into the database. 

()K ... · k · Cimcetj. 

~--~~-<IGi 
If you ever forget your database password, all of your data will be lost forever. There's 
nothing anyone, including Microsoft, can do to bypass this password once it has 
been set. Be sure to pick something you'll remember and to record the password in a safe place. 
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Where to Go from Here 
In this chapter we've introduced two of the most complex issues in Acc.::ss: multiuser 

record locking and security. Now that you've learned about all the basic pieces you 
need to write useful Access databases, we're going to turn our attention to the elements 
that distinguish a finished application from just another database. Part Four shows you 
how to enhance your project with macros, toolbars, menus, and other tools to make 
your users' lives easier. 

What's New in the 
Access Zoo? 
Data sharing and security with Access 97 
for Windows 95 works pretty much th~ 
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Creating a Custom Rpplication 

his chapter starts Part Four of this 
book, where we'll look at how to turn 
a database into an application (or 

app, for short). This chapter is also a transition for you, the reader, because you'll be 
going from the role of computer user to application developer. We'll explain what 

that's all about as we go along in this chapter. 

What Is an Application? 
An application is a database that's been automated, using menus, dialog boxes, and 
other familiar components of the Windows interface. The goal is to create a product 
that anyone-even people who know nothing about Microsoft Access-can use. 

When you use the Database Wizard to design a database, the Wizard creates a simple 
application with forms, reports, and perhaps one or more switchboards. You can create 
much more elaborate applications than those that the Database Wizard creates by 
creating every database object from scratch. Or you can create all the database objects­
tables, queries, forms, and reports-using the Database Wizard. Then you can create 
your own switchboards and dialog boxes to tie those objects together in a smooth, easy-

to-use application. 
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Who's Who in Application Development 
Before we begin our foray into applications development, you'll need to understand 

the terms developer and user: 

Developer The person who creates the application-most likely yourself, since 

you're the one reading this book. 
User The person, or people, who will be using the completed application. This per-

son might be a computer neophyte. 

This chapter marks your initiation into the ranks of application developers. As a 
developer your mission is to create applications that people with little or no computer 

experience or training can use. 

How Much Programming Is Involved? 
Historically, only people with advanced training and experience in computer program­
ming were able to build custom programs (applications). But with Access, you can 
create very sophisticated custom applications with little or no programming. Why? 
Because the tables, queries, forms, and reports that you create using techniques from 
the preceding chapters make up at least 90 percent of the overall application. 

The other 10 percent of the application will consist of hyperlinks, macros, and/or 
Visual Basic procedures that determine how the application behaves as the user interacts 
with the program. We'll talk about macros and procedures in upcoming chapters. First 
you need to understand events, which are the triggers that launch your custom macros 

and procedures into action. 

What Are Events? 
The custom applications that you create with Microsoft Access are event driven. In English 
that means that the application normally just sits there on the screen waiting for the user 
(the person using the mouse/keyboard) to do something. When the user does indeed do 
something, that action triggers an event, which the program then responds to. 

Virtually every activity that occurs on the screen is an event. Here are some examples: 

• Moving or clicking the mouse 
• Pressing and releasing a key 
" Moving the cursor to a control 
• Changing the contents of a control 
" Opening or closing a form 
., Printing a report 
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For example, when you're using a form or switchboard and you click on a command 
button, your action generates a "button click" event. The application responds to the 
event by carrying out whatever action the command button tells the program to do. 
The action is defined, by you, in the form of a macro or by Visual Basic code. 

Microsoft Access can detect many kinds of events. And you can assign a custom 
action to any one of these events. Before we talk about how to create actions, let's talk 
about how you go about finding the events to which you want to assign custom actions. 

Finding Event Properties 
You assign an action to an event by assigning a macro or procedure name to an event 
property. Every form, report, and control has its own set of events. To see the events, you 
need to open the form or report in design view and open the property sheet. Then Here 
are the exact steps: 

1. Open a database and open the database window; click on the name of the form or 
report whose events you want to explore. 

2. Click on the Design button to open that object in design view. 

• If you want to see events for the form as a whole, choose Edit> Select Form or 
click in the square in the upper-left corner where the rulers meet. 

• If you want to see events for the report as a whole, choose Edit> Select Report 
or click in the square in the upper-left corner where the rulers meet. 

• If you want to see events for a particular control, click on the specific control. 

3. Open the property sheet (click on the Properties button or choose View> Properties). 

II!Im 

If you want to look at the events for a specific control, you can just right-click on the 
control and choose Properties from the shortcut menu. Then click on the Events tab. 

4. Click on the Event tab. 

The property sheet will show you all the events that you can assign actions to. The 
exact events that become available depend on which object is selected at the moment. 
For example, if you chose Edit> Select Form under step 2, the property sheet would 
show event properties for the entire form, as in Figure 19.1. 

If you click on a specific control before (or after) opening the property sheet, you'll 
see events for that particular control only. For example, Figure 19.2 shows the event 
properties for the currently selected command button, named Option 1. 
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I#LdiJiliQI 
Event properties 

for an 
entire form. 

ld3@1QM 
Event properties 
for a single con­

trol on a form. 

format I Data Event I Other j All 

On Current, • • • • • . (Miht@iiml 
Before Insert •.•.•• 
After Insert .• ; ...•.. 
Before Update • , •.•. 
After Update ..••.• 
On Delete , ••...•. 
Before Del Confirm •• 
After Del Confirm , .•• 
On Open. , • , .•..• [Event Procedure] 

On Load ......... 
OnRe$ize.,, .. ,,, 
Of\ Unload •..••.•• 
On Close •••... : •• 
On Activate ••.•••• 
On Deactivate ••... 
On Got Fo,us •••• , • 
On Lost Focus .. , .. 
onclick ••.....•.. 
OnDbiCiick ••..• ,. 
On Mouse Down •••• 
On Mouse Move ••. , 

lfB.i~H~&i·!.I:Mi@IUil@ji 
Format \ Data Event J Other j All I 
OnEnter •..•..•.. l 
OnExit., ., ••.• , • 
OnGotfoCIJS.,.,,. 
Ori Lost Focus , •••• 
On Click. . , , , •.• , . =HandleButtonCiick( 1) 

OnDbiCiick.,., .. , 
On Mouse DoV>m , .•. 
On ~louse ~1Qve , • , • 
On~lous.,Up •. , .• , 
On Key Down.,.,., 
OnKeyUp •. , ..••. 
On Key Press , •.•. , 

• 

.. 

xl 

In Figures 19.1 and 19 .2, you can see that some of the events have [Event Procedure) 
listed as the property. Behind that event procedure is the Visual Basic code that deter­
mines what happens when the event occurs. A little later in this chapter, we'll show 
you how to create a control and the action for that control using Control Wizards. But 
first, here's a quick overview of some of the many different types of events to which you 

can assign actions. 
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Sample form Events 
To see the event properties for a form as a whole, you open the form in design view, 
choose Edit> Select Form, then open the property sheet, and select the Events tab, as 
we did back in Figure 19.1. You can assign actions to many events, but let's start by 
focusing on the events that occur when the user first opens a form. Here they are, in the 
order in which they occur: 

Open > Load > Resize > Activate > Current 

You can assign an action to any one of these events using the On Open, On Load, 
On Resize, On Activate, and On Current properties. But why so many different events 
for the simple act of opening a form? Because having lots of events to assign actions to 
gives you great freedom in customizing how your custom application will behave when 
the user opens the form. For example, you can assign an action to the On Open prop­
erty and that action will play out first. You can assign a different action to the On Load 
event and that action will play out second. You can assign custom actions to as many, 
or as few, event properties as you wish. 

Ill 

As always, you can get more information about an event by clicking on the event 
name in the property sheet and then pressing the Help key Fl. 

When the user closes a form, three events occur: 

Unload > Deactivate > Close 

To assign actions to these events, you use the On Unload, On Deactivate, and On 
Close event properties for the form. 

To illustrate just how specific you can be when assigning actions to events, let's sup­
pose you want some special action to occur when the user switches from one open form 
to another. The On Open and On Close events wouldn't do you any good in this case. 
However, the Activate and Deactivate events do occur when switching from one open 
form to another, like this: 

Deactivate (first form) >Activate (second form) 

Sample Control Events 
Every control on a form has its own set of event properties to which you can assign 
actions. The exact event properties that are available to you depend on the type of con­
trol you're working with at the moment. For example, the event properties for a text 
box are different from the event properties for a combo box. 
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But virtually all controls have some simple events that occur when the user enters 

the control (by clicking on or tabbing to it). Those events properties are 

Enter > GotFocus 

To assign actions to these events, you first need to select a specific control (still in 
design view), open the property sheet, and click on the Events tab, just as we did back 

in Figure 19.2. 
When the user exits a control, these two events occur: 

Exit > LostFocus 

Keep in mind that the events we've discussed here are just a few examples of the doz­
ens of events that you can assign actions to. You'll see many, many more examples as 
we progress through this, and forthcoming, chapters. To get you started in creating 
your own controls and assigning actions to the events that those controls generate, 
we'll turn our attention now to the Control Wizards, the easiest way to create custom 

controls and actions. 

Step 
The easiest way to create a control and to assign a custom action to it is via the Control 
Wizards, available in the forms design screen. Here are the basic steps for creating a 

control and action using the Control Wizards: 

1. Open the form to which you want to add a control in design view. 
2. Make sure the toolbox is open. (If not, click on the Toolbox toolbar button or 

choose View> Toolbox.) 
3. Make sure the Control Wizards button in the toolbox is pushed in, as shown below. 

4. Click on the type of control you want to create. (The Command Button tool is a 
good one to cut your teeth on because it's easy to create and the Wizard offers 

many options.) 



l#dij;IIQI 
We'll use the 

Control Wizards 
to add a 

Close button 
to this form. 
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Remember, if you forget what type of control the various buttons in the toolbox 
create, you can just point to a button and wait for the ScreenTip to appear. 

5. Click the location in the form where you want to put the control you're about to 
create. 

6. If the control you are creating is supported by the Control Wizards, you'll see the 
first Wizard screen. just follow the Wizard's instructions and make your selections 
as you would with any Wizard. 

When you've finished, you'll see the control on your form, already selected with sizing 
handles in case you want to move or resize the control. 

To test the new control, switch to form view. In form view, use the control as you 
normally would. For example, if you created a command button, just click on the com­
mand button. When you do, the action you chose while completing the Wizard will be 
played out. 

Note that when you add a control to a form, you change the form. When you try to 
close the form, you'll be asked if you want to save the change. Choose Yes if you're 
happy with your new control and want to save it. 

Let's take a look at a specific example of using the Control Wizards to create a fairly simple 
control. Suppose that you used the Database Wizard to create the Order Entry database. 
You open up the My Company Information form (Figure 19.3) and decide that perhaps 

Ill! My Company Information 13 

Enter your company's name anct address information here. You will save 
the in1onnation by closing the form. 

c ,,,'',' 

Company ?#JWNN$®1! Detou~ 

Address 305 -14th Ave. S. 
Sutte 38 Invoice Descr 

Ctty Seattle 

state !Province if'.IA 
Phone Number 

Postal Code 98128-
Fax Number 

Courrrry USA 

Sales Tax Rate 6.00% 

10 days. 

Thank you for placing your 
orcter with us. 

(706) 555-4112 

(706) 555-4115 

" 
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lilijijill@l 
The My 

Company Infor­
mation form in 

design view. 
The toolbox is 
open and the 

Control Wizards 
button is 

pushed in. 

you'd like to add a command button to that form that will allow the user to close the form 

without clicking on the built-in Close button. 
First, we need to close the form (click on its Close button), get to the database win­

dow, and reopen the form in design view. In this example we would click on the Forms 
tab, click on My Company Information as the name of the form to modify, and then 

click on the Design button. You're taken to the forms design window. 
If the toolbox isn't open, click on the Toolbox button or choose View> Toolbox. Then 

make sure the Control Wizards button in the toolbox is pushed in, as in Figure 19.4. 
Now we can use the scroll bars surrounding the form to get down to the lower-right 

corner of the form, where we want to place the command button. We click on the 
Command Button tool in the toolbox and then click down near the lower-right corner 

of the form to place the button. 
For a moment, we see an outline indicating where the button will appear. Then the 

Command Button Wizard kicks in automatically. The first Wizard window asks what 
we want this button to do. In this case we choose Form Operations under Categories and 
Close Form under Actions (since we want this button to close the form), as in Figure 19.5. 

~ M,.,.,..,ff Access l!!ll'i.U3 
file fdit . '{iew Insert Fgrroat Iools Y!'it1dow tlelp 
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The first win­

dow in the 
Command 

Button Wizard 
asks what you 
want the but-

ton to do. 
The options 
are grouped 
into several 
categories. 

1#3Q;11EiQI 
Here we've 

opted to put the 
word Close, 

rather than a 
picture, on the 
command but­

ton we're 
creating. An 

ampersand in 
front of a 

letter means 
"underline the 

next letter. " 

Command Button Wi2ard 
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What aclion do you want to happen when the button is pressed? 

Different actions are available for each category. 

Record Navigation 
Recmd Operations 

I 

Cancel 

Actions: 

.1\pply Form Filter 

Edit Forrn Filter 
Open Forrn 
Print a Form 
Print Current Form 
Refresh Form Data 

• 

After making a selection, we click on the Next> button, and the second Wizard win­
dow asks how we want the button to look. It suggests using the Exit picture, which is 
a door with an arrow pointing the way out. But in this example, we decide we'd rather 
have the button just show the word Close (with the C underlined). So we click on the 
Text option button and type &Close in the text box, as in Figure 19.6. 

Do Y?u want text or a picture on the buttor.? 

If you choose Text, you can type the text to display. If you 
choose Picture, you can dick Browse to find a pictllre to display. 

r. :fexh I &Close 

~;icture: Q!.[lllllll!llllll!ll!ll!ll 
Stop Sign 

r 

Cancel <!).ack 

• 
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litftQ;IIQJ! 
Here we've 

opted to name 
the button 

CloseCompany­
Jnfo. 

To underline a letter in a button's text, just put an ampersand in front of the letter 
you want underlined. As you'll see later in the book, the same technique applies to 
many controls, such as underlining hotkeys in your own custom menus. If you 
want to include an ampersand in the text on the button, just type two ampersands 
together, like this: &&. 

We then press Next> to open the final Wizard window, which asks what we want to 
name this button. The Wizard will suggest a generic name, like Command23, but we 
can use a more descriptive one. In Figure 19.7 we've opted to name this button Close­
Companylnfo. 

Finally, we choose Finish from the last Wizard window, and the Wizard disappears. 
Now we can see the new command button on the form. You can size and move this new 
button using the standard techniques. Figure 19.8 shows the new command button close 
to the lower-right corner of the form. 

Now we can save the change and close the form. We can't use the new Close button 
to do that though because the controls you create work only in form view, not design 
view. So to close and save this form you can choose File> Close from the menu bar or 
click on the form's Close button. When asked if you want to save the changes to the 
design of the form, choose Yes. You'll be returned to the database window. 

" 
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The new Close 

command 
button appears 
near the lower­
right corner of 

the form. 
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Testing the New Control 

I#@Q;li@M 
The My Com­

pany Informa­
tion form in 

form view with 
the new Close 
button visible. 

To test the new control, you first need to open the form in form view (not design view). So 
in this example, we could just double-click on My Company Information in the database 
window. The form appears looking pretty much the same as it did back in Figure 19.3, 
except that now we can also see the new custom Close button, as in Figure 19.9. 

To test the new command button, just click on it. The form should close, which is 
all that we wanted this particular button to do. 

11@1 ldy t!om11any Information J3 

' En\et your company's'lilmi<l' andaclclress iiiform~ii:in'nefe /YOt:t:Wllt~save> 
the information lly closing th~ 

Company 

Address 305 -14th Ave. s. 
Su[e 38 

coy Seattle 

statell'rovince <NA 

Postal Code 98128-

Cour~ry USA 

Sales Tax Rate 6.00% 

Invoice Oeser Thank yoco for placing yocor 
order wtth cos. 

Phone Ntltniler (706) 555-4112 

Fax Number (706) 555-41'15 

"' 
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More Wizard-Created Controls 

The command button to close a form is just one example of a control that you can create 
using Control Wizards. The Option Group, Combo Box, List Box, Command Button, and 
Subform/Subreport tools in the toolbox also offer Wizards to make creating those types 
of controls a bit easier. Your best bet is to simply experiment. Here are a few points to 
keep in mind as you do so: 

• You can create controls only in design view. 

• The Control Wizards will appear only if the Control Wizard button in the toolbox 
is pushed in before you start creating the control. 

• If you change your mind while you are working, you can cancel the Wizard. 
• If you create a control and then change your mind and want to get rid of it, just 

click on the control (in design view) and press Delete. 

• The Control Wizards create the control and assign certain properties to it. To change 
the properties of a control that a Wizard has created, right-click on the control and 
choose Properties from the shortcut menu that appears. 

• The action that a Control Wizard creates is written in Visual Basic, a topic we'll 
introduce in Chapter 25. If you want to take a peek at the code that the Wizard 
created, right-click on the control and choose Build Event from the shortcut 
menu that appears. 

• To test the new control, you must be in form view, not design view. 

Whenever you need to add a custom command button, combo box, or option group 
on a form, try using a Control Wizard. If you can't get the Control Wizard to create the 
action that you want the control to perform, your next best bet is to create a macro­
the topic of our next chapter. 

Where to Go from Here 
Creating custom Access applications is a complex subject. Here are some pointers for 
finding specific topics of interest: 

• To try out some custom applications, see Appendix B and Appendix C. 

• To learn about using hyperlinks to a form to perform actions, see Chapter 13. 
" To learn about using macros to define custom actions, see Chapter 20. 
" To learn about creating custom switchboards and dialog boxes for an application, 

see Chapters 21 and 22. 

• To learn about creating custom menus and toolbars, see Chapters 22 and 23. 
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What's New in the 
Access Zoo? 
Here's what's new io application 
development: 

• Hyperlinks can be used to perform 
actions like opening a. form or report. 
In earlier versions of Access, you had 
to use a macroto perform these tasks. 
New Tools/Macro commands let · 
you convert macros to Visual Basic, 
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create menus from macros, create 
too.! bars from macros, and create 
shortcut menus from macros. 

• The RunCommand macro action 
replaces the DoMenultemattion. 

• Enhancements to the Mtr(lule win~ 
dow, Debug Window, and Object­
~roWser make it easier to create 
Visua!B<isic for Applications modules. 


