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reafing Forms
Wwith Form Wizards

form offers an alternative way to

view and work with data in your

tables. Unlike the datasheet view,
which always displays data in rows and columns, a form can display data in just about
any format. Perhaps the most common use of a form is to create a fill-in-the-blanks
view of your data that resembles a paper form your company already uses.

With Form Wizards you can create great-looking data entry forms in about two sec-
onds flat. You just pick the style you want, click your mouse a few times, and voila, a
form appears. You can use any Wizard-created form, except a chart or PivotTable
(described later in this chapter), to enter data into tables. This chapter explains how to
use Form Wizards to create several types of predesigned forms. These designs (with a
few tweaks here and there) probably can handle most of your data entry needs.

t

You can save lots of time by using Form Wizards to set up forms, even if you plan
| to customize those forms extensively. Chapter 3 explains how to work with Wiz-
ards and gives you hands-on practice with them.
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Just in case you're wondering whether Access has more form design tools to offer,
the answer is a resounding Yes! If you need a more elaborate form than the Form Wiz-
ards can create, Chapter 13 explains how to design and customize forms and reports.

If you need extra help with designing a new form, double-click on the Working With

Forms book in the Access Help Contents and then double-click on books and topics that
interest you.

What Hinds of Forms Can the Form Wizards Create?

The Form Wizards can create several types of forms showing fields from one or more
tables and/or queries. To help you decide which type of Wizard-designed form is best
for your own data, we show some representative examples. Then we explain how to
create forms with Wizards, save those forms, and use them effectively.

Columnar Forms

In a columnar form each field appears on a separate line with a label to its left; only one
record is shown on each screen. The Wizard fills the first column with as many fields as
will fit on a single screen, then it fills the next column with as many fields as will fit,
and so forth. Figure 11.1 shows a sample columnar form for the Customers table,

You can customize the styles available in Form Wizards. To get started, open any
form in design view and choose Format » AutoFormat, or click on the AutoFormat
, button on the Form Design toolbar. Click on the format you want to customize in the

AutoFormat dialog box and then click on the Customize button. See Chapter 13 for
more details.

Tabular Forms

Figure 11.2 shows a tabular form for the Products table. As you can see, tabular forms
display fields in a horizontal row with field labels at the top of the form. Each new row
‘ represents a new record.

Tabular forms are best when you want to display just a few relatively narrow fields
‘ and you want to see several records at once. To avoid spending most of your time scroll-
‘ ing back and forth in a tabular form, add just a few fields to the form.



A columnar form
for the Custom-
ers table, in the
Standard style.

A tabular form
for the Products
table in the
Clouds style. The
tabular layout is
best when you
have just a few
narrow fields to
display and you
want to see sev-
eral records on a
single screen.
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Datasheet Forms

A datasheet form initially displays data in datasheet view much as it appears when you
open a table or run a query or when you use the Form View toolbar button to switch to
datasheet view in any form. This type of form is often used as the basis for subforms,
described in a moment. Figure 11.3 shows a datasheet form for the Employees table.

Creating a Database
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| FIGURE 11.3 [ _ T
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You can switch from datasheet form to form view by choosing View » Form View,
or by clicking on the drop-down arrow next to the Form View toolbar button and then
choosing Form View. In form view the fields appear in a tabular layout, but only one
record is visible on each page of the form. Figure 11.4 shows the Employees form after we
switched from datasheet view to form view; this example uses the International style.

The Form Wizards take their best guess when trying to fit labels and fields on your
form. After creating the form, you may need to switch to design view and refine the
design. In Figure 11.4, for example, the Employee ID label is cut off because the
font is too large. To fix this problem, switch to design view and widen the label
control or choose a smaller font for the labels.

The datasheet

. [ 1 Employees
form, shown in At

form view. To __ DloyeelD FirstName  lastName  Tite
resize the win- I

dow to fit
snugly, we chose
Window » Size
To Fit Form.
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Hierarchical Forms

Sometimes you’ll want to work with related tables in your forms. For example, you
might want to design an order form that includes customer and order information,
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along with details about the products ordered. A hierarchical form showing data from
tables that have a one-to-many relationship is perfect for jobs like this.

The Form Wizards can create hierarchical forms in two basic flavors: a main form
and subforms or a main form and linked forms. (A subforn is a separate form that’s
embedded in a main form.)

Figure 11.5 shows a main form with subforms and displays information from four
tables: Customers, Orders, Order Details, and Products. The main form shows fields
from the Customers table, arranged in columnar layout. The subforms for the Orders
table and the Order Details and Products tables appear in datasheet layout.

Na T E
ﬂ The main form and subform often go by the names main/subform, form/subform,
or master/detail form.
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Linked forms, such as those shown in Figures 11.6 and 11.7, also present multitable
data hierarchically. But instead of showing all the fields from the main table crowded
on the same page used for subforms, the main table’s fields appear on a separate form.
You can then click on the command button near the top of the form to show records
that are synchronized with the record on the first form. The linked form can be a main
form or a main form with a subform (see Figure 11.7).

To produce the forms shown in Figures 11.5, 11.6, and 1 1.7, we ran the Form Wizard
and selected all fields from the Customers, Orders, and Order Details tables and just the
Unit Price field from the Products table. While viewing the Order Details subform, we
dragged the Unit Price field for the Products table next to the unit price field for the
Order Details table; this arrangement lets us see the unit price from the Products table
while we enter the actual selling price into the unit price field of the Order Details table.

We also dragged the OrderID field in the Order Details subform to the left of the Order-
DetaillD field.

If you've already created forms that include the necessary linking fields, you can quickly
combine them into a main form with a subform. To do 50, open the main form in
design view, press F11 to bring the database window to the front, click on the Forms
tab on the database window, and choose Window » Tile Vertically. Then drag the
subform from the database window to an appropriate spot on the main form’s design
window and respond to any prompts that appear. See Chapter 13 for more details.

A linked form
showing Cus-
tomers data on
the main form.
Clicking on the
Orders com-
mand button
displays the
form shown in
Figure 11.7. This
example uses
the Flax style.

&3 Customers

(3075554650
(G07) 555-4654

Main form Command button opens linked form
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Figure 11.6.
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Making Hierarchical Forms Work Properly

To work properly the main form and subform must be linked by a common field in a
one-to-many relationship (or, less often, a one-to-one relationship).

¢ The table or query on the one side—for example, Customers—supplies data for
the main form.

¢ The table or query on the many side—for example, Orders—supplies data for the
subform.

e The forms are linked by a primary key field on the one side and a normal field (called
the foreign key) on the many side. In the Customers and Orders example, CustomerID
is the primary key field on the one side and a foreign key on the many side.

Creating a Database
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——— —

The most common problem with creating hierarchical forms occurs when the Form
Wizard can’t figure out how to link your main form and subform. This problem can
occur, for example, if you haven’t explicitly set up a relationship between the tables,
either via the Relationships window or a multitable query. As you'll see shortly, the
Form Wizard will let you know when this problem exists, and it will give you a chance
to set up relationships.

Lo B = s of = S ————— =
& Chapter 6 explains how to use the Relationships window to define relationships

between tables in your database. Chapter 10 explains how to use queries to
define relationships, select specific data, and perform calculations on data. Chap-
ter 13 explains how to set properties that link main forms and subforms.

One way to get the most out of using the Form Wizards is to create hierarchical
forms. For best results, include all fields from tables on the many side. You can always
remove unwanted fields or rearrange them later.

In some cases involving multiple related tables that have lookup fields, Access may
not connect the related tables and fields properly, and it might not tell you that it is
unable to do so. For example, when we included all the Order Entry database fields
from our sample Customers, Orders, Order Details, and Products tables on a form, the
drop-down list for the ProductID field in the Order Details subform was empty and
the lookup values displayed incorrectly.

To work around this glitch, we opened the problem subform (Order Details Sub-
form) in form design view, opened the property sheet (View » Properties), and clicked
on the OrderDetails.ProductID control. Then we changed its Row Source property to
Products, its Column Count property to 2, and its Column Widths property to 0”;1” and
saved the subform. See Chapter 6 for information about lookup fields and Chapter 13 for
details about working with properties.

You should also avoid renaming subforms or linked forms. Doing so can prevent
Access from finding and opening those forms. If you do rename the forms, you'll need
to open each main form and subform in design view, choose View » Properties (if the
property sheet isn’t visible), and click on the All tab on the property sheet. Then fix every
reference to the old form name in the Name and Source Object properties and in all Event
Procedures. (You can edit any event procedure, and then use the Edit » Replace com-
mand to globally change references in the current module.) Be sure to fix these properties
for the entire form and for any command buttons and subforms on the form.

For more details about creating hierarchical forms, look up Subforms, Creating in the
Access Help Index. Chapter 13 explains how to alter properties and select controls, See
Parts Four and Five for more about events and the Visual Basic program code that’s used
in Event Procedures,
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Charts

Charts convert the numbers in your data to useful graphs that help to clarify the meaning
of those numbers. The chart in Figure 11.8 shows the contribution of each customer’s

orders to the company’s total sales. We used a Select query as the data source for the sam-
ple chart (refer to Figure 10.17 in Chapter 10). Chapter 14 explains how to create charts.

FIGURE 11.8 h
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PivotTables

A PivotTable lets you summarize large amounts of data, much as a Crosstab query does
(see Chapter 10). But a PivotTable is more flexible than a Crosstab query because it lets
you interactively switch the row labels, column labels, and summary calculations as
needed. In Figure 11.9 you see a PivotTable that’s based on the query shown below.
Chapter 14 explains how to create and use PivotTables.

You must have Microsoft Excel installed to create and use PivotTables.

s — —
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Using Wizards to Create a Form

Now that you've seen the many types of forms the Form Wizards can create, why not
try the Wizards? The steps are easy:

1. Start from any of these places:

¢ To base your form on a specific table, start from the database window, click
on the Tables tab, and highlight the table name. Or open the table in datasheet
view. If the table has a filter and sort order associated with it, the new form will
inherit the filter and sort order automatically (see Chapter 9).

NO T E
You also can start your form from table design view. If you do, however, the form
can be displayed in design view only; you'll get an error message that your table
is exclusively locked (click on OK to clear the message). To view the form in form
view, pull down the Window menu and switch to the table design window. Then
close the table design window (Ctrl+W), switch back to the form design window,
and click on the Form View toolbar button.,
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* To base your form on a specific query (or saved filter), start from the data-
base window, click on the Queries tab, and highlight the query name. Or open
the query in datasheet or design view.

* If you’re not sure which table or query you want to base the form on, start
anywhere in Access (of course, a database must be open) or click on the Forms

tab in the database window.

2. Click on the drop-down arrow next to the New Object toolbar button. You'll see

this menu:

af

@ AutoForm
& AutoReport

@ Table

51 Query

13 Eorm

i Beport

3 Makra

32 Module

£% Cass Module

3. Choose one of these options:

AutoForm Creates a one-column form using the template named in the Form
Template box on the Forms/Reports tab of the Options dialog box (Tools »
Options » Forms/Reports; see Chapter 15). Typically, this template is named

Creating a Database

Normal, and it resembles the Standard style shown in Figure 11.1. After choos-
ing this option, skip to step 11—you’re done! Using the AutoForm option
makes sense only if you selected a table or query in step 1.
New Form  Opens the New Form dialog box, shown here:

New Form

7]

B

| Create a new form without |
using a wizard.

Choose the table or query where
the object's data comes from:

o]

[21x]

AutoForri: Colurnar V
SutoForm; T abular
AutoForm: Datashest
Chart ‘Wizard

PivotT able Wizard

Cancel
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T e — = o — —————————
To open the New Form dialog box in fewer steps, click on the Forms tab in step 1

and then click on the New button in the database window. Or start from any tab on
the database window and choose Insert » Form. To create an AutoForm quickly,
highlight a table or query name on the Tables or Queries tab in the database window
and then choose Insert » AutoForm.

4. Choose the table or query from the drop-do‘:vn list (near the bottom of the New Form
dialog box) on which you want to base the form. (This box may be filled in already.)

[ K=y i 4 e —
% You must select a table or query before choosing any of the AutoForm Wizards or
the Chart Wizard in step 5. If you plan to use the Form Wizard or PivotTable Wizard
in step 5, you'll have another chance to choose tables and queries.

5. Click on one of the following options (they appear in the list near the top of the New
Form dialog box) and then click on OK; or just double-click on the appropriate option.
When you click on an option, the area in the left side of the dialog box will show an
example and describe the form the selected option will create. Your options are

Design View Opens an empty form design window.

Form Wizard Opens the Form Wizard. From here you can select which tables,
queries, and fields to include on the form, create subforms or linked forms (if
appropriate), choose a style for the form, and specify a title and name for your
form(s). Figures 11.1 through 11.7 show examples of forms that we created with
the Form Wizard.

AutoForm: Columnar Creates a columnar form from all the fields in the
selected table or query (see Figure 11.1) without asking any more questions.
AutoForm: Tabular Creates a tabular form (see Figure 11.2) without asking
any more questions.

AutoForm: Datasheet Creates a datasheet form (see Figures 11.3 and 11.4)
without asking any more questions.

Tl O I B ===y
When you choose AutoForm: Columnar, AutoForm: Tabular, or AutoForm: Datasheet,
Access places fields in the order they’re defined in the table design or query, puts the
name of the table or query on the form’s title bar, and uses the default style. The
default style is the style you (or someone else) chose most recently. If necessary, the
Wizard will create a main form and subforms, even if you don't ask it to. After choos-
ing an AutoForm option, skip to step 11 and then save your form.
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Chart Wizard Creates a form that displays a free-standing chart of your table
or query data (see Figure 11.8 and Chapter 14).

PivotTable Wizard Creates a form that can display a Microsoft Excel Pivot-
Table (see Figure 11.9 and Chapter 14).

6. Assuming you chose Form Wizard in step 5, you'll see the first Form Wizard dialog
box, shown in Figure 11.10. Use any of the techniques described below to add as
many fields from as many tables or queries as you need and then click on Next.

¢ To select a table or query, click on the drop-down arrow button below Tables/
Queries and then choose the table or query to use.

¢ To add one field to the form, click in the Selected Fields list where the new
field should appear (optional). Then double-click on the field in the Available
Fields list, or click on the field in the Available Fields list and then click on the
> button. The field you select will move to the Selected Fields list and will
appear on the form in the order shown.

* To copy all the Available Fields to the Selected Fields list, click in the Selected
Fields list where the new fields should appear and (optional) then click on the >>
button.

* To remove a field from the Selected Fields Tist, double-click on that field, or
click on the tield and then click on the < button.

e To remove all fields from the Selected Fields list, click on the << button. The
fields will reappear in the Available Fields list.

Creating a Database
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7. If you chose fields from multiple tables, but haven’t yet defined relationships
between the tables, the Wizard will display the dialog box shown below. Click on
OK if you want to exit the Wizard and define relationships (see Chapter 6) or click
on Cancel to return to step 6 and remove some fields from your form.

J You have thosen fislds tiom thess tables
/ ! Customirs, Orders, Order Detal; one of moes of the
labiles ki1 [elated 1o the olbere. Clich OX |o sdit
syelem telationships [youll nead Lo restai the wizaid)
Chick Cancel lo return 9 the wazaid and remove
o fiekds

8. In the next dialog box or two, you’ll be asked to choose a layout of Columnar, Tab-
ular, Datasheet, Justified, Form With Subform(s), or Linked Forms, depending on
which tables and fields you selected in step 6. Choose the options you want and
then click on Next to continue to the next dialog box.

L i o
"/ As you make choices in the dialog boxes described in steps 8 and 9, the Wizard will
give you detailed instructions and show previews of your form as it takes shape.
Just watch the screen carefully and you shouldn’t have any trouble figuring out
what to do.

9. Choose a style by clicking on one of the available styles and then click on Next. For
maximum readability, choose the Standard style. (As Chapter 13 explains, you can
customize the styles and create new ones of your own. Later in this chapter we'll
show you how to change a form’s style instantly.)

10. Accept or change the suggested title(s) in the last Form Wizard dialog box (see Fig-
ure 11.11), choose the option that lets you view or enter information (because this
option usually is most convenient), and then click on Finish.

@VA“"IHGH-’-—: S o _ _ — _

The title you select in step 10 is used for the form name, the form'’s Caption prop-
erty (which displays text on the form’s title bar), the command button’s Caption
property (which displays text on the command button of a main form that has a
linked form), and the Visual Basic code that Access creates behind the form. If
the form already exists in the database, you'll have a chance to overwrite the
existing form or choose a different title.
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11. (Optional) Resize or maximize the form that Access created for you. As long as the
form is not maximized, you can choose Window » Size To Fit Form to get a nice
snug fit of the form window around the form's fields.

After your form appears in form view, you can

» Use your form to edit existing records or add new ones (see “Opening and Using
a Form”).

e Tdit or add records in datasheet view. To switch to datasheet view, choose View »
Datasheet View, or click on the drop-down arrow button next to the Form View
toolbar button and choose Datasheet View.

¢ Change the form’s design in design view, as explained in Chapter 13. To switch to
design view, click on the Form View toolbar button or choose View » Design
View, or click on the drop-down arrow button next to the Form View button and
choose Design View. Typically, you'll just need to rearrange or widen the fields
and labels. You had a chance to rearrange and resize fields in the Chapter 3
hands-on lessons.

e Print or print preview the form (see Chapters 3 and 9).

e Sort or filter the records, or search for records that meet specific criteria (see Chap-
ters 3 and 9).

e Save and close the form (see “Saving a Form” later in this chapter).

Creating a Database
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~Creafing Reports
with Report Wizards

or most of us, printing the data
stored in tables or the information
gathered from queries is an essential
part of using a database. Access Report Wizards provide easy-to-use—yet powerful—
tools for creating reports in several predefined formats. Even if you plan to customize
the designs later (as we did in many examples shown in this chapter), you'll save time
if you use the Report Wizards to set up reports.

Chapter 3 explains how to work with Wizards and gives you hands-on practice
with Report Wizards. Chapter 9 covers printing. In Chapter 13, you'll learn how to
design forms and reports from scratch and how to customize existing designs.

If you need more help with designing a new report, open the Working With Reports
book in the Access Help Contents and explore subtopics in the Basics and other books. Or
double-click on Reports, Creating in the Help Index and explore the subtopics that appear.
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What Hinds of Reports Can the Wizards Creafe?

The Report Wizards can create several types of reports showing fields from one or more
tables and/or queries. To help you decide which type of Wizard-designed report might
be best for your own data, we’ll show some examples. Then we’ll explain how to create,
save, and use Wizard-generated reports.

Columnar (Vertical) Reports

In a columnar or vertical report, each field appears on a separate line with a label to its
left. Figure 12.1 shows a sample columnar report for the Products table.

You can customlze the styles avaﬂable in Report leards To get started, open any
report in design view and choose Format » AutoFormat or click on the AutoFormat
button on the Report Design toolbar. In the AutoFormat dialog box, click on the for-
mat you want to customize and then click on the Customize button.

Tabular Reports

Figure 12.2 shows a tabular report for the Products table. As you can see, tabular reports
display fields in a horizontal row with field labels at the top of the report. Each new row
represents a new record.

Groups, Totals, and Summary Reports

Groups/totals reports such as the one shown in Figure 12.3 organize your data into
groups that appear in tabular format. At your request, the Wizard will calculate sum,
average, minimum, and maximum values for numeric and currency fields in each
group and display sums as percentages of totals.

The group/totals report shown in Figure 12.3 is based on the query shown in
Figure 12.4. The calculation in the last column of the query is as follows:

$ Before Tax:CCur([Quantity]*
[Order Details].[UnitPrice]*(1-[Discount]))

Summary reports are just like group/totals reports except that they omit the detail
records between each group. Figure 12.5 shows a report that’s almost the same as Fig-
ure 12.3, only designed as a summary report. (We omitted the Product Name field in
Figure 12.5.) This report is based on the query shown in Figure 12.4.
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A columnar
report for the
products table
in the Soft
Gray style.

Product iD

Product Name
Unit Price
Product ID
Product Name
Unit Price
Product iD
Product Name
Unit Price
Product ID
Product Name
Unit Price
Product ID
Product Name
Unit Price
Product ID
Product Name
Unit Price
Product ID
Product Name
Unit Price
Product ID
Product Name

Unit Price

Basketball
o $4.95
‘ 2
‘:Footbz}ll
$5.65
| ]
lsoccel' ball
$12.95|
‘ 4
iVolleyball
i $3.25
(Golf balls
' 8675
6
Crystal ball
' $45.55
7
Baseball
$8.75
K
Billiard balls
$127.451

Tuesday, September 05,1995

. Pagetof2
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A tabular report

for the Products P r @dlﬂcts

table in the

Bold style.
The tabular L
layout is best Product ID Product Name Unit Price
when you have
just a few 1 Basketball $4.95
narrow fields to )
display and you 2 Football $5.65
want to see
many records on 3 Soccer ball $12.95
a single page.
4 Volleyball $3.25
5 Goif balls $6.75
6 Crystal ball $45.55
7 Baseball $8.75
8 Billiard balis $127.45
9 Tether ball $9.65
10 Foosball $17.85

Tuesday, September 05, 1995
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A Casual style
groups/total
report that’s

grouped by
Order Date and
subtotaled on
aumeric and
currency fields.
This report is in
Outlinel form.
We tailored the
appearance of
this report after
the Report Wiz-
ard created it.
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Orders by Date

ﬁllﬂll\!ﬂl'“ﬂﬂ&I!EllH!(Ellﬂllﬁl!ﬂ!lﬂllﬂnﬂﬂﬁilN!lﬁllm"ﬁliﬂil&ﬂﬁ!lﬁliBl!ﬂilﬁl(&!!ﬁHﬁﬂﬁ!lﬂl!ﬂllﬁ!lﬁliﬁi!ﬁil@i%ﬁl!

Order Date 2/1/95
Product Name Quantity Unit Price Discount $ Before Tax
Basketball 1 $4.95 0.00% $4.95
Biltiard balls 2 $127.45 0.00% $254.90
Football 1 $5.65 0.00% $5.65
Football 1 $5.65 0.00% $5.65
"Summary for 'OrderDate’ = 2/1/95 (4 detail records)
Sum 5 $271.15
Avg 1.25 $36.93 0.00% $67.79
Min 1 $4.95 0.00% $4.95
Max 2 $127.45 0.00% $254.90
Percent 6.49% 16.48%
Order Date 2/2/95
Product Name Quantity Unit Price Discount $ Before Tax
Basketball 2 $4.95 0.00% $9.90
Crystal ball 2 $45.55 0.00% $91.10
Foosball 4 $17.85 0.00% $71.40
Football 2 $5.65 0.00% $11.30
Tether ball 5 $9.65 0.00% $48.25
Summary for 'OrderDate’ = 212195 (5 detail records)
Sum 15 $231.95
Avg 3 $16.73 0.00% $46.39
Min 2 $4.95 0.00% $9.90
Max 5 $45.55 0.00% $91.10
Percent 19.48% 14.09%
Order Date 2/11/95
Product Name Quantity Unit Price Discount $ Before Tax
Baseball 2 $8.75 0.00% $17°50
Basketball 1 $4.95 0.00% $4.95
Basketball 2 $4.95 0.00% $9.90
Football 1 $5.65 0.00% $5.65
EllﬂllﬂllBHEl|ﬂ|lﬂ|l§ﬂﬂll§llﬂllEll!ﬂIIHI!QHEHHIIEHWHEIIEIimllﬁllﬂllmHEMEHEHEHE“EEIQHB&H!lmllﬁl!ﬁn%ﬂ&l!
Tuesday, September 05, 1995 Page 10f 7
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FIGURE 12.4

This multiple-
table query sup-
plies data for
the report in
Figure 12.3,
showing orders
placed in 1997,
(See Chapter 10
for more about
creating queries
like this one.)

il Qui_\ﬂ : Select Querp e

Quan_tity

UritPrice Discount

— Prodycti ame £ Before Tax.
Order Datails Products Qrder Details Order Betails
Ascending

~ WhentheReport
- Wizard Needs Your Help

- 'Som'etimes you'll need to add yom ownfor-

- in Figure 12.3, the Quanttty column head- . .
_ing was a bit too narrow, and formats for
:the Sum, Avg, Min, Max ‘and grand total

matting refmements in report de519n view, -

_especially for reports that present summary
calculations and are based on queries that
~ also involve calculatlons Fortunately, mak-
ing such refmements takes only a few
minutes and is much faster than bur!dmg a

comphcated report from scratch

For example after the Report Wrzard cre-

ated the first version of the report shown

~ caleulations weren’t quite nght To fix

these problems we switched to report

desrgn view, opened the property sheet

', (Vlew > Properties), and cllcked on the

property sheet’s Format tab Then we did
the foﬂowmg

~» Widened the bold iabels for Quantrty
- and Unit Price near the top of the
report desrgn '

'.Sélected all the cOntroIs"thet presenf
, :summary calcufatnons and changed
their Text Alrgn property to Right.

e Selected controis that display sum-

- mary calculations and grand totals

~ for money amounts and changed

_ their Format property to Currency.

e Selected the control that displays
_average quantity (Avg in the Quantity
column) and changed its Format

~ property to Fixed.

_» Opened the Sorting And Grouping dia-

log box (Vlevv > Sorting And Group-
ing), selected OrderDate in the Field/
, Expressron column, and changed the
 Keep Together group property to
Whole Group. -

We also made slmnlar changes to the first
version of the report shown in Figure 12.5.
See Chapter 13 for more about changing -
report formats. ! '
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—
A Summary s . P
report fooks like Orders By Date (Summary)
a group/totals
report, but fa ' : s
without the Order Date 2/1/95
detail records : Quantity Unit Price Discount $ Before Tax
between €0Ch ' ' o Summary for ‘OrderDate’ = 2/1/95 {9 detail records)
group. For Sum 20 $503.10
variety, we've Avg 222 $25.26 0.00% $55.90
shown this Min 1 $4.95 0.00% $4.95
report in the Max 5 $127.45 0.00% $254.90
Corporate style, Percent 25.97% 30.57%
'fg r?nbgtI.the/fz Order Date 2/11/95
tailored the Quantity Unit Price Discount $ Before Tax i
appearance of ) ) Summary for OrderDate’ = 2/11/95 (4 detail records)
this report after Sum 6 $38.00
the Report Wiz- Avg 1.50 $6.08 0.00% $9.50
ard created it. Min 1 $4.95 0.00% $4.95
Max 2 $8.75 0.00% $17.50
Percent 7.79% 2.31%
- Order Date 2/18/95
Quantity Unit Price Discount $ Before Tax
Summary for ‘OrderDate’ = 2/18/95 (2 detaif lecords)
Sum 2 $52.29
Avg 1.00 $26.15 0.05% $26.15
Min 1 $6.75 0.00% $6.74
Max 1 $45.55 0.10% $45.55
Percent 2.60% 3.18%
Order Date 2/25/95
Quantity Unit Price Discount $ Before Tax
Summary for ‘OrderDate' = 2/25/95 (1 detail record)
Sum 2 $11.30
Avg 2.00 $5.65 0.00% $11.30
Min 2 $5.65 0.00% $11.30
Max 2 $5.65 0.00% $11.30
Percent 2.60% 0.69%

Monday, October 09, 1995 Page 1 0f'5




454 | CHAPTER 12  CREATING REPORTS WITH REPORT WIZARDS

Charts

If you've already saved a chart as a form, you can quickly convert it to a report. To
do so, click on the Forms tab in the database window, right-click on the chart you
want to save as a report, choose Save As Report, type a name for the new report,
and then click on OK. The newly saved report will appear when you click on the

Charts convert the numbers in your data to meaningful graphs. The chart in Figure 12.6
shows the contribution of each customer’s orders to the company’s total sales. We used
a Select query as the data source for the sample chart (see Figure 10.17 in Chapter 10).
Charting is basically the same, whether you display the chart on a form or a report.
So once you know how to create a form-based chart, you also know how to create a

report-based chart. Chapter 14 explains how to create charts.

Reports tab in the database window.

Mailing Labels

You can design mailing labels that will print on standard Avery mailing label stock.

Figure 12.7 shows some garden-variety mailing labels formatted for Avery 5196

(3.5" diskette) labels. See “Creating Mailing Labels,” later in this chapter to find out

how to produce mailing labels from your Access data.

FIGURE 12.6

A pie chart
showing the
contribution of
each customer’s
orders to total
sales. We
tailored the
appearance of
this chart after
the Wizard
created it.

Customer Contributions to Total Sales

B 23%
M 14%

1%

B 21%

O ABC Corporation

i Reese Clinic

E RNAA Associates
dUniversity of the Bite
& WorldWide Widgets
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Mailing labels
sorted in postal
code, last

name, and first
name order. This
example is for-
matted for Avery
5196 (3.5 dis-
kette) labels.

We used a For-
mat function to
display the
postal codes
with hyphens
(for example,
92575-4747).

Wilbur Stumingi
University of the Elite
P.O. Box 655
Lander, WY 82520-
USA

Anita Adams

Database Search and Rescue
5356 £. 20th St.

Santa Fe, NM 87110-3857
USA

Hanley Strappman
RNAA Associates
2743 Bering St.
Anchorage, AK 99508-
USA

Shirley Ujest
WorldWide Widgets
187 Suffolk Ln.
Boise, ID 83720~
USA

Sheila Stumingi

Precision Bagpipes

P.O. Box 23981

San Diego, CA 92575-4747
USA

lsing Wizards to Create a Report

Susita Schumack

Reese Clinic

2817 Milton Dr.
Afbuguerque, NM 87110-
USA

Andy Adams

ABC Corporation

87 Polk St.

Suite 5

San Francisco, CA 94117-
USA

The procedures for creating a report with Wizards depend on the type of report you
choose, but these are the basic steps:

1. Start from any of these places:

¢ To base your report on a specific table, start from the database window, click
on the Tables tab, and highlight the table name. Or open the table in datasheet
view. If the table has a filter and sort order associated with it, the new report
will inherit the filter and sort order automatically (see Chapter 9 and “Remov-
ing a Filter and Sort Order” later in this chapter for more details).
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You also can start from table design view. If you do, however, the report can be
displayed in design view only, and you'll get an error message that your table is
exclusively locked (click on OK to clear the message). To view the report in print
preview, pull down the Window menu and switch to the table design window.
Then close the table design window (Ctrl+W), switch back to the report design
window, and click on the Report View toolbar button.

° To base your report on a specific query (or saved filter), start from the data-
base window, click on the Queries tab, and highlight the query name. Or open
the query in datasheet or design view.

° If you're not sure which table or query you want to base the report on, start
anywhere in Access (of course, a database must be open), or click on the Reports
tab in the database window.

2. Click on the drop-down arrow next to the New Object toolbar button. You'll see
this menu:

SutoFomm -
SutaRepot
Wi Table
Y M Guery
i) Neiw Form
Hew Repait:
R Mew Maci
"":2 NP Mo;ﬁ:?a

3. Choose one of these options:

AutoReport Creates a one-column report using the template named in the
Report Template box on the Forms/Reports tab of the Options dialog box
(Tools » Options » Forms/Reports; see Chapter 15). Typically, this template is
named Normal, and it is completely plain. After choosing this option, skip to
step 11—you’re done! Using the AutoReport option makes sense only if you
selected a table or query in step 1.
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Report Opens the New Report dialog box, shown here:

7. SR SR ;@@'S&M&MZW
v/ To open the New Report dialog box in fewer steps, click on the Reports tab in step 1
and then click on the New button in the database window. Or start from any tab on
the database window and choose Insert » Report. To create an AutoReport quickly,
highlight a table or query name on the Tables or Queries tab in the database window
and then choose Insert » AutoReport.

WMM@% %%@%@W%W@M@?MWWWQ

4. Choose the table or query you want to base the report on from the drop-down list
near the bottom of the New Report dialog box. (This text box may be filled in for
you already.)

i N o-r BE Biasee ZWMWW%&W%%W&%&@}M SRR Wﬁ%@sﬁ%@ff St Z\%‘&R“%ﬁfffi 7 ;A‘%%%L%@%WMW
You must select a table or query before choosing any of the AutoReport Wizards,
" the Chart Wizard, or the Label Wizard in step 5. If you plan to use the Report Wiz-

ard in step 5, you'll have another chance to choose tables and queries.

5. Click on one of the following options in the list near the top of the New Report dialog
box and then click on OX (or just double-click on the appropriate option). When you
click on an option, the area in the left side of the dialog box will show an example and
describe the report the selected option will create. Your options are:

Report Wizard Opens the Report Wizard. From here, you can select which
tables, queries, and fields to include on the report, choose how to group, total,
and summarize your report, choose a style for the report, and specify a title and
name for your report.
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AutoReport: Columnar Without asking any more questions, creates a colum-
nar report from all the fields in the selected table or query (refer to Figure 12.1).
AutoReport: Tabular Without asking any more questions, creates a tabular
report (refer to Figure 12.2).

B 2R %@W@%AA& = = 4“%?;‘”%‘5@&@‘

e s
- When you choose AutoReport Columnar or AutoReport: Tabular, Access places
- fields in the order they're defined in the table design or query, puts the name of
the table or query on the report’s title and title bar, and uses the default style. The
default style is the style you (or someone else) chose most recently when using
the Report Wizard. After choosing an AutoReport option, skip to step 11 and then
save your report.

@”@%@{%@‘&@&W@W’@(M

Chart Wizard Creates a report that displays a free-standing chart of your
table or query data (see Figure 12.6 and Chapter 14).
Label Wizard Creates mailing labels from your table or query (see Figure 12.7
and “Creating Mailing Labels,” later in this chapter).

6. Assuming you chose Report Wizard in step 5, you'll see the first Report Wizard dia-
log box, shown in Figure 12.8. Use any of the following techniques to add as many
fields from as many tables or queries as you need, and then click on Next.

¢ To select a table or query, click on the drop-down arrow button below Tables/
Queries and then choose the table or query to use.

FIGURE 12.8 N

Use this Report B Report Wizard
Wizard dialog | oROr mizal
box to specify

which field
should appear
on your report.
You can select
fields from as
many tables

Products

: Pl’OdubUD CompanyMame
and querles, 775 ' OrderDate
you wisn. | Quantity
Access will use .
your selections
to decide how
to lay out

the report.
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o To add one field to the report, click in the Selected Fields list where the new
field should appear (optional). Then double-click on the field in the Available
Fields list, or click on the field in the Available Fields list and then click on the
- button. The field you select will move to the Selected Fields list and appear
on the report in the order shown.

e« To copy all the Available Fields to the Selected Fields list, click in the
Selected Fields list where the new fields should appear (optional); then click on
the >> button.

e To remove a field from the Selected Fields list, double-click on that field, or
click on the field and then click on the < button.

e To remove all fields from the Selected Fields list, click on the << button. The
fields will reappear in the Available Fields list.

7. If you chose fields from multiple tables but haven’t defined relationships between
the tables yet, the Wizard will display the dialog box shown below. Click on OK if
you want to exit the Wizard and define relationships (see Chapter 6); of click on
Cancel to return to step 6 and remove some fields from your report. In the next few
dialog boxes, you'll have a chance to customize your report. Your options will
depend on which tables and fields you selected in step 6 and whether you choose
to group your data.

ysoft Access

Youhave choser figlds from
Orders, Ordet Detalls, Praduct

 isbles knt elatedtothe other
sster relationships fyoud nee
Click Caricet to relum to the

8. Pick the options you want in each dialog box and then click on Next to continue
to the next dialog box. Here’s a summary of the dialog boxes you'll see: -

How to view your data The dialog box shown in Figure 12.9 appears if the
report can be grouped in various ways. Choose the grouping option you want to
use and then click on Next.
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FIGURE 12.9 N

Use this Report
Wizard dialog
box to choose
how to view a

report that can : DrdeDate
be grouped in . } -

more than one ggacromtl:tﬁt Product ame, UritPrice,

way. This
dialog box
appears only if
it’s needed.

lCompanyName

s %%M%WQMW&WM
As you make choices in the dialog boxes described in steps 8 and 9, the Report
Wizard will give you detailed instructions and show previews of your report as it
takes shape. Just watch the screen carefully and you shouldn’t have any trouble fig-
uring out what to do.

Grouping levels and grouping options The dialog box shown in Figure 12.10
appears if your report can be grouped by additional levels. To choose a grouping
field, double-click on it; or click on the field name and then click on the > but-
ton. To move it up a level, click on the T button in the dialog box; to move it
down a level, click on the | button. To remove the bottom-most grouping field,
click on the < button (repeat as needed). If you want to control the grouping
interval for your additional fields, click on the Grouping Options button in the
dialog box, choose the interval you want from the appropriate Grouping Inter-
vals drop-down lists, and then click on OK. Click on Next to continue.

Sort order for detail records and summary options The dialog box shown
in Figure 12.11 appears if your report is grouped. From here, you can sort detail
records by up to four fields, in ascending or descending order. To control vari-
ous groups/totals and summary options, click on the Summary Options button
(if it's available); then select the options you want to use (see Figure 12.12) and
click on OK. Click on Next to continue.
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This Report . Click to group by the selected field.  Click to clear a grouping field.
Wizard dialog
box lets you
choose addi-
tional grouping
fields and pick
grouping inter-
vals for those ~ '
fields. This - Lf.lrderDate, ProductMame
diafog box
appears only if
it’s needed.

f Report Wza:d

| lCompanyName

Quartity, UnitPnce, Discount

- Giouping Options oL

Click to group fields by intervals.  Click to change grouping priority.

FIGURE 12.11 N

Use this Report  Choose up to four Click to choose ascending
Wizard dialog detail fields to sort by. or descending sort.
box to choose ;
the sort order
for up to four
detail fields,
and to choose
various sum-
mary options.
This dialog box
appears only if
it's needed, and
the Summary
Options button
appears only
if your report
includes
numeric fields.

i hepmt Wizard

Click to choose summary options (see Figure 12.12).
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FIGURE 12.12 h

Clicking on the
Summary
Options button
in the dialog

box shown in Fig-
ure 12.11 takes
you to this Sum-
mary Options
dialog box.

' Calsulats pascent of
i Mumtallrsums o

FIGURE12.13 a

Use this dialog
box to choose
a layout for a

grouped report.

HEE HEXX HHHH HHXX XKXN
i

HERRSE HARR
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[V Adust the field iy
il ftonapage

Report layout The appearance of this dialog box depends on whether your
report is grouped. If it’s grouped, it will resemble Figure 12.13; if it isn't grouped, it
will resemble Figure 12.14.
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Use this dialog
box to choose o
a layout for a 4 ot ol tepait?

report that isn’t -
grouped. The
term “Vertical”
in the Layout
group of this
dialog box
means the
same as
“Columnar.”

RHHK MHRHH

o R t
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9. Click on one of the available styles when asked to choose a style and then click on
Next. (As Chapter 13 explains, you can customize the styles and create new ones of
your own. Later in this chapter we’ll show you how to change a report’s style
instantly.)

10. Accept the suggested title or change it if you wish in the last Report Wizard dialog
box (see Figure 12.15). Make sure you’ve selected Preview The Report (because this
option usually is most convenient) and then click on Finish.

R A B Bl B P & = ’ A w@@%m%w’f@ﬁ
The title you select in step 10 is used for the report name, the report’s Caption
property (which displays text on the report title bar), and the report title. If the
report already exists in the database, you'll have a chance to overwrite the exist-
ing report or choose a different title.
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The last Report i Renait Wizard
Wizard dialog '
box asks what
title you want
for the report,

what you want

to do next, and
whether you
want to display
Help on work-
ing with the
report. It’s
often easiest

to accept the
default settings
and click

on Finish.

Access will create your report and display it in the print preview window. Figure 12.16
shows a sample report in the print preview window. Anytime your report appears in this
window, you can

e Print the report. To print without opening the Print dialog box, click on the Print
toolbar button (see Figure 12.16). To print from the Print dialog box, press Ctrl+P
or choose File » Print, choose your printing options, and then click on OK (see
Chapter 9 for more about printing).

e Zoom out or in on the report. Click on the Zoom toolbar button or click the
magnifying glass mouse pointer on a spot in the report. You also can use the tool-
bar's Two Pages button and Zoom Control drop-down list, or right-click and
choose Zoom or Pages options as needed (see Chapter 9).

o Send the report to a Microsoft Word file and open it in Word. Click on the
drop-down arrow next to the OfficeLinks toolbar button and then choose Publish
It With MS Word.

o Send the report to a Microsoft Excel spreadsheet and open it in Excel. Click on
the drop-down arrow next to the OfficeLinks toolbar button and then choose
Analyze It With MS Excel.

¢ Send the report to your network mail program. Choose File f Send, select the
format you want for the message file, and click on OK. When prompted, sign on
to your mail system; then send the message as you would any network mail.
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—
AN
A sample report N
shown in the PS> \060 @é
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Orders by Date
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Order Date 212887
Product Mame Quartity Unit Fricze Discourt $ Bdfore Tax
Bifliard balks 1 P1Z7.45 0,004 27 A6
Billiard batk 1 ¥127.95 0009 P74
Crystat balt 2 H555 D.003% A0
Footbatl 3 Fe.e5 Q.00% $16.95
Golf balls B §2.15 0.00% F1200
Yolleyball 8 $1095 00w wWEID

Aurvceearyfor Qe Tt s |
Sum 13

B 5%

cdAnan

% :/’m’w’”‘%@u. & - ¢
Graphics and some complex formattmg may not transfer to Mlcrosoft Word or
Microsoft Excel.

S

o Close the print preview window and go to design view, where you can change
the report’s design. Click on the Close toolbar button or press Ctrl+W. Often you’ll
just need to rearrange or widen the fields and labels as described in Chapter 13.

e Save and close the report {see “Saving a Report” later in this chapter).
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) Yddr’ Report

" You can use the File » Save As/Export commands described in Chapter 7 to create
a Microsoft Word mail merge document from a table or query. Chapter 7 also
explains how to save reports as HTML files, text files, Excel files, and Rich Text For-
mat files.

., :he Wrzards Budd

- ',The Report szards go through the same .

~ steps that the Form Wizards do as they

L con re up your automatrc reports That o
s, they make sure data from multiple
~ tablesis synchromzed proper!y, and they
sizeand place fields on the report so that

o 'need to set up mumtable queries just to

display’ ﬁeids from severa[ tables at once:

' 'When snzmg each contro! the Wizard iays o

out all the necessary fields, regardless of

the current page size. If the resultmg
__report is too big for the page it calculates

the ratio of the total size of the too- big
report to. the desired page size; then it
shrinks every control by that ratio to cre-

' ',feverythmg frts on the page | A
: ate a report of the maximum allowable’ -
size. Because the Wizard uses a simple ratio
method for sizing controls on reports you

- may need to switch to desxgn view and
tweak the size, position, or font for controls
that appear squashed "

if the report is based on fields from multi- -
ple tables and/or queries, the Wizard
creates an SQL statement behind the
_report that specmes whrch tables, queries,
_ andfields to use and sets up the necessary
 table rdatlonshlps Because the Wizard
can do all thi 'automatlcaﬂy, you’lt rare!y'

For more help with designing a new report with Wizards, look up Wizards, Report
Wizard in the Access Help Index.

Creating Mailing Labels

You can design mailing labels that will print on standard Avery mailing labe! stock. Fig-
ure 12.7, earlier in this chapter, shows some standard mailing labels.
To create mailing labels using Report Wizards:

1. Start from the database window or from the datasheet view of a table or query as
explained earlier.

2. Click on the drop-down arrow next to the New Object toolbar button and choose
Report.
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';choose Properttes, and then chck on the
- Paper tab. Set the Paper sze to Custom, o
. 'speafy the unit of measurement and the
':appropnate wndth and iength Click on
0K and then retum to Access

3. Click on Label Wizard in the New Report dialog box. Next use the drop-down list
at the bottom of the dialog box to select the table or query you want to base the
report on (if it’s not selected for you already). Click on OK.

4. Choose a label size, unit of measure, and label type as needed from the dialog box
shown in Figure 12.17. If necessary, click on the Customize button in the dialog
box, create a custom label size, and then click on Close. Or select (check) Show
Custom Label Sizes and select a custom label. Click on Next to continue.

"
This Label Wiz- ' ; ‘ ‘ ‘ P
ard dialog box
lets you choose

a standard
label or a
custom size.

2

EARERT
ERtZsE NI
23442 3040

Click to manage Select or deselect to toggle between
custom tabel sizes.  showing built-in and custom labe! sizes.




468 | CHAPTER 12 o CREATING REPORTS WITH REPORT WIZARDS

5. Choose font name, font size, font weight, and text color options when prompted.
You also can select or deselect italics or underlining. Click on Next to continue.

6. Choose the fields you want on the label from the dialog box shown in Figure 12.18.
To add a field, position the cursor in the Prototype Label box and then double-click
on a field in the Available Fields list. You also can type text or press Enter at the cur-
sor position. To delete fields or text from the Prototype Label box, select the text
with your mouse and press the Delete key. Click on Next to continue.

i @O W B %&Wﬁf%@ﬁ%@i@%ﬁwW@m&wﬁﬁ&ﬁw%%%%wwwmﬁﬁw%%‘ S 2
If the mailing label isn’t large enough to hold all the lines and fields you specified,

~ Access will explain the problem and let you know that some fields will be lost. You
can return to the previous Label Wizard screens (by clicking on the Back button as
needed) and adjust your selections.

7. Select the fields in the order in which you want them sorted. For example, to sort
customer labels for bulk mailing by zip/postal code and then by last and first name
within zip/postal code, double-click on PostalCode, double-click on ContactLast-
Name, and then double-click on ContactFirstName. Click on Next to continue.

8. Specify a name for your report or accept the selected name from the final dialog
box. The name must be unique because the Label Wizard won't let you overwrite
an existing mailing label report. Choose other options as needed (though the
defaults usually are just fine) and then click on Finish.

)
Use this dialog ; ; ; ;
box to design
your mailing
labels. The
Prototype Label
box will reflect
your latest
changes, QS f : {Comparyh ame}
shown in this BilingAddress}
example.

{ContactFirstName} {ContactLastN ame}

StateDiProvince
PostalCode
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The title you select in step 8 is used for the report name and Caption property
(which displays text on the report title bar).

Access will create the mailing label report and display it on the screen.

z

If you don’t have enough horizontal space to display the entire fabel format,

Access will let you know. You can go to design view and tweak the report design
as needed (see Chapter 13). Or choose File » Page Setup, click on the Layout tab,
and then reduce the number of columns or the size of the columns.

~ Formatting Postal Codes
- and Phone Numbers

If you uSe the Access Wizards to create
fields such as postal codes and phone

‘numbers, the input masks cause values in

those fields to be stored as text without -
punctuation characters. The same input

~ masks cause the appropriate punctuation

marks to appear for those fields in forms

‘and datasheéts. For example, Access uses
this input mask for PostalCode fields:

Zoodoo\~9999
‘And this input mask for PhoneNumber

fields:

1 (999%) *000,-0000 ,
Although most reports created by the

'Wizarkds do take advantage of these input
. masks, the mailing labels don't. For exam-
_ ple, a postal code might appear as either

five numbers (85711) or nine numbers

(857114747), A phone number might

appear as 6195551234. To report those
values in more readable formats, such a,s" o
85711-4747 for a postal codeand
(619)555-1234, you'll need to use the
Format function in your reports. -

“For example, in design view for fgh:ema"ii'-,' -

ing labels shown in Figure 127, we
changed simple references to the postal
code from [PostalCodel to: '
Format: ([PostalCodel;” !@@@@@-G@’@@“)‘ -
Toformata phone number ﬁeidy,’, §uch as
[PhoneNumber], you could use this For-

mat function:

Format ([PhoneNurber], " (060) @0@-00GE")
See Chapter 10 and look up Format Func- -
tion in-the Access Help'index for more
about formatting text (string) values.
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Saving a Reporf

If the Wizard didn’t save your report automatically, you should save the report if you
want to use it later. Here's how:

e To save and close the report, return to design view by clicking on the Close but-
ton on the print preview toolbar. Then choose File » Close or press Ctrl+W and
click on Yes.

e To save only your latest changes, press Ctrl+S or choose File » Save or click on
the Save toolbar button (shown at left).

The first time you save a report that hasn’t been saved before, you'll be prompted
to enter a name for it. Type a name (up to 64 characters, including blanks) and
then click on OK.

Opening a Report

If you've closed a report, you can reopen it with these steps:

1. Start in the database window and click on the Reports tab.
2. Do one of the following:

e To open the report in print preview (with data displayed), double-click on
the report name you want to open, or click on it and then click on the Preview
button.

e To open the report in design view (where you can change the report’s design),
click on the report name and then click on the Design button.

Copying is a quick way to create a new report that’s based on an existing report. To
copy a report, click on the Reports tab in the database window, highlight the report
to copy, and press Ctrl+C. Next press Ctrl+V, type a name for the new report, and
click on OK.

Removing a Filter and Sort Order

If your report is based on a table or query that you've filtered or sorted in datasheet
view, the report will inherit the filter and sort order automatically and will be filtered
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or sorted anytime you preview or print it. You can remove the filter or sort from the
report by following these steps:

1. Open the report in design view.

2. Choose View » Properties if the property sheet isn’t open. Click on the Data tab on
the property sheet.

3. Choose Edit » Select Report to make sure you've selected the entire report.

4. Double-click on the Filter On property in the property sheet to change that prop-
erty from Yes to No. If necessary, double-click on the Order On property to change
it from Yes to No.

5. Save the report design (Ctrl+S).

The next time you preview or print the report, the records will not be filtered or sorted.
If you later want to use the report with the filter and/or sorting, repeat the five steps
above, except change the Filter On and/or Order On property from No to Yes in step 4.

Changing the 5tyle for a Report

Just as you can change the overall style for forms, you also can change a report’s style
without re-creating the report from scratch. It’s easy:

1. Open the report in design view. If you're starting from the database window, click
on the Reports tab, click on the report you want to change, and then click on the
Design button. Or if you've switched to print preview from design view, click on
the Close toolbar button (shown at left) or choose View » Design View.

2. Choose Format » AutoFormat or click on the AutoFormat button (shown at left)
on the Report Design toolbar. You'll see the AutoFormat dialog box, shown in Fig-
ure 12.19.

Use the Auto-
Format dialog
box to instantly
change the
style for your
report or to
customize an
existing style.
Switch to report
design view and
choose Format »
Autoformat to
open this

dialog box.

Autof ml

HAHKRKK

HRRK KRR
MRHH MRR

Label from Detaii
Contral fram Detail
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3. Choose the format you want to use from the AutoFormat dialog box and then click

on OK.
4. Save your changes (Ctri+S) and click on the Report View toolbar button; or choose

View » Print Preview to switch back to the print preview window.

Where fo Go from Here

This chapter introduced the many types of instant reports you can create with the
Report Wizards. From here, you can continue with Chapter 13 to learn how to design
new reports and forms from scratch and how to customize existing reports and forms.

;ﬁ";'What's New in the

~ Access Zoo7 - .
"Th Report descgn wmdow in Access 97 ,
"'has een' 1mproved The menus and

perform tasks (e 9. zoommg,m p mt pre- o
wew) more qu:ckly than before .
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3. Choose the format you want to use from the AutoFormat dialog box and then click
on OK.

4. Save your changes (Ctrl+S) and click on the Report View toolbar button; or choose
View » Print Preview to switch back to the print preview window.

Where fo bo from Here

This chapter introduced the many types of instant reports you can create with the
Report Wizards. From here, you can continue with Chapter 13 to learn how to design
new reports and forms from scratch and how to customize existing reports and forms.

. :ffWhat"s'New in the
 Access Zoo?

' ,The'Report de51gn wmdow in Access 97
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Crefing Custom
Forms and Reporls

ccess has some truly awesome tools
for creating high-powered, good-
looking forms and reports. If you've
ever used a Windows drawing or painting package, you probably won't have any trouble
learning to use the design tools. (If you've never used one of those programs, the mouse
skills involved may take a little practice, but the overall process is still fairly simple.)

As you read this chapter, remember that you can customize the basic designs created by
Form Wizards and Report Wizards (see Chapters 11 and 12), or you can create your own

designs from scratch. If you're new to form and report design, you'll definitely want to start
with a Wizard-created design so you can experiment with the design tools right away.

R

g TR Y
If you're planning to experimen

t extensively with Access form and report design
tools, set up a new table—perhaps named All Field Types—that has one field for

each data type that Access offers and enter some records into it. Then use the Form

Wizards and Report Wizards described in Chapters 11 and 12 to create a form or
report that’s based on fields in your All Field Types table.
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Switching to Design Vi

To change the appearance of an existing form or report, you must switch to design view
using any of these techniques:

e To change a form or report that’s not open, go to the database window and click
on the Forms or Reports tab (as appropriate) in the database window. Click on the
name of the form or report you want to change and then click on the Design but-
ton in the database window, or right-click on the form or report name and choose
Design.

e To change a form or report that’s open on your screen, click on the Form View
button (top left) on the Form Design toolbar, or choose View » Design View if
you're editing a form. Or click on the Close Window (Close) button (bottom left)
on the Print Preview toolbar or choose View » Design View if you're editing a
report. Note that if you opened the report in print preview, clicking on the Close
Window button will close the report; you'll need to open it as described above.,

’ o 2 x@%@'@&yfss‘?’w@@&@f 2 %W%Wx%&%&@%&%&%%%ﬁ%&@mw&%
The Iessons in Chapter 3 gave you some hands-on practice with changing a form
in form design view.

Remember that the tools for changing your form or report design are available in design
view only. Therefore, except where the instructions specifically say to start from another
view, be sure you're in design view before using any procedures described below.

When working with forms and reports, it's a good |dea to hide the Taskbar tempo-
rarily. To do this, right-click on an empty area on the Taskbar, choose Properties,

and select (check) Always On Top and Auto Hide. Then click on OK. See the sidebar
titled “Maximizing Your On-Screen Real Estate” in Chapter 1 for more details.

Previewing and Saving Your Changes

As you work in design view, you'll want to preview your handiwork from time to time.
To do so, click on the Form View toolbar button (if you're designing a form) or the
Report View button (if you're designing a report). Those buttons are the first ones on
the Form Design and Report Design toolbars.
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You also can preview your form or report by choosing options on the View menu:

e To preview a form in form view, choose View > Form View.

o To preview a form in datasheet view, choose View » Datasheet View.

o To preview a report in print preview, choose View » Print Preview.

o To preview a report in layout preview (which presents just enough sample data
to show you what the report will look like), choose View » Layout Preview. You
also can switch to Layout Preview by clicking on the drop-down arrow on the
Report View toolbar button and then choosing Layout Preview.

When you're ready to make more changes, go back to design view, as described in
the previous section.

Another good idea is to save your changes whenever you're happy with them. Simply
click on the Save toolbar button or press Ctrl+S.

Creafing @ Form or Report from Scrafch

Here's how to create an entirely new form or report without using the Wizards.
1. Start from the database window and use one of these techniques:

o Click on the Forms or Reports tab in the database window and then click on
the New button in the database window.

o Click on the Tables or Queries tab, click on the table or query you want to attach
to your form or report, and then click on the drop-down arrow next to the New
Object toolbar button. Now choose either Form or Report, as appropriate. The
New Form or New Report dialog box will open (see Figure 13.1 for an example of
the New Form dialog box).

The New Form

dialog box is

similar to the ok
New Report I AutoForm: Colurnar
di(]lOg box. JAutoFom Tabular

AutoForm: Datasheet
Chart Wizard
ivotT able Wizard
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2. Choose form or report from the drop-down list in the dialog box to attach the form
or report to a table or query. You don’t need to choose a table or query if you're cre-
ating an unbound form, such as a dialog box or a switchboard (see Chapter 21).

3. Click on the Design View option in the dialog box and then click on OK (or double-
click on Design View).

o SR Gies St M&WMM%‘&M@%@M‘M@%*WMMM%@WM@%MM
if the datasheet for the table or query has a filter or sort associated with it, the
new form or report will inherit the filter and sort order automatically. Chapter 9
explains how to add and apply filters and sorting in forms. “Removing a Filter and
Sort Order” in Chapter 12 explains how to deactivate or activate the filter and
sort for a report.

You'll be taken to a blank form or report window in design view. Think of this win-
dow as an empty canvas on which you're free to create anything you want. Of course,
you do need to understand the available tools and techniques before you start creating
anything. That’s what the rest of this chapter is all about.

To undo a mlstake you've made in desugn view, press Ctrl+Z or cllck on he Undo
toolbar button or choose Edit » Undo immediately.

For online details about the design process, go to the Access Help Contents, open the
Working With Forms, Working With Controls On Forms Or Reports, or Working With Reports
book; then open additional books and topics as needed.

lesign Taols

Figures 13.2 and 13.3 show an empty form and reportt, respectively, in design view. In
both figures, we’'ve maximized the design window to increase the available work space.
Let’s take a quick look at the design tools shown in the figures.

Choosing a Style for Your Design

Initially your form or report design will have a standard look, which works well for most
people. However, Access comes with several predefined styles that you can use to change
the appearance of a form design’s background and the font, color, and border of controls
on a form or report. As you'll learn later, you also can create your own custom styles.
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| FIGURE 13.2

An empty form
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design view.
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Control is Access lingo for any graphical object on a form or report that displays
data, performs some action, or makes the form or report easier to read.

To choose a style for your design:

1. Select the controls you want your changes to apply to (see “Selecting Controls, Sec-
tions, Forms, and Reports” later in this chapter).

= @B W B

R

If you don't select controls first, Access will apply the new style to the entire design.
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An empty
report (maxi-
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2. Choose Format » AutoFormat or click on the AutoFormat button (shown at left)
on the Form Design or Report Design toolbar. The AutoFormat dialog box will
open (see Figure 13.4).

3. Select a style in the Form AutoFormats or Report AutoFormats list. The sample pic-
ture will change accordingly. The new style usually affects the design’s background
and the Font, Color, and Border of controls.

4. Click on the Options button to change this behavior. Then select (check) the
styles you want to apply or deselect (clear) styles you want to leave unchanged
(see Figure 13.4). Again, the sample picture will reflect your changes.

5. Click on OK.

Access will apply the new style to the background of a form, to existing or selected
controls, and to new controls. (Of course, you can change the style anytime you want
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a different look by repeating steps 1 to 5.) If you don’t see a change, make sure the form
or repott is selected (and not some other object in the design window) before you click
on AutoFormat.

If your design contains a control whose appearance isn’t defined for the AutoFormat
style you chose, an Update AutoFormat dialog box similar to this one will appear:

Choose onc of these options and then click on OK:

* To update the current control with the style for another type of control in the
AutoFormat style, click on the drop-down arrow next to Update As A and then
choose the control that has the style you want to use.
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* To leave the current control’s appearance unchanged, choose Leave Fach xxx
Unchanged (where xxx is the type of control that doesn’t have a predefined style).

For more about Creating your own AutoFormat styles, see “Customizing AutoFormat
Styles” later in this chapter. Or look up AutoFormat and its subtopics in the Access
Help Index.

The Field List, Design View Toolbars, and Toolbox

Toolbox, and Formatting (Form/Report Design)—offer a treasure trove of menu
shortcuts, formatting features, and design tools. You’ll probably want to keep all
these toolbars handy as you work.

Field List Lists all the fields in the underlying table or query. To place a field,
simply drag it from the field list to your design,

Toolbox  Provides tools for adding controls to your design.

r, special effects,
borders, and line thickness for a control. Many buttons on this toolbar work the same
way as those on the Formatting (Datasheet) toolbar, described in “Customizing the
Datasheet View” in Chapter 8.

For now, just knowing how to hide and display those tools (and the property sheet)
is sufficient.

¢ To display or hide the design toolbars, right-click on any visible menu bar, tool-
bar, or the toolbox and then choose the toolbar you want to display or hide. If no
toolbars are visible, choose View » Toolbars and select {check) or deselect (clear)
the toolbars you want to show or hide.

° To display or hide the toolbox, choose View » Toolbox or click on the Toolbox
button (shown at left) on the Form Design or Report Design toolbar.

° To display or hide the field list, choose View » Field List. Or click on the Field
List button (shown at left) on the Form Design or Report Design toolbar,
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You can size and move the tools using these techniques:

e To change a toolbar or toolbox to a floating palette of buttons, double-click on
an empty area within the tool. Or drag an empty area within the tool away from
the edge of the screen and release the mouse button.

o To move a floating toolbar or toolbox, drag its title bar.

o To size a floating toolbar or toolbox, drag any border.

s To display a floating toolbar or toolbox as a single row or column of buttons,
double-click on an empty (nonbutton) area within the tool. Or drag the tool to an
edge of the screen and, when the outline expands to the length of the edge you've
dragged to, release the mouse button.

For details about working with toolbars, see “Using the Toolbars” in Chapter 1. To
find out what a toolbar or toolbox button is for, point to it with your mouse and then
look at the ScreenTip below the mouse pointer and the status bar at the bottom of the
screen. For online Help with toolbars, search for Toolbars, Positioning and Toolbars, Show-
ing And Hiding in the Access Help Index.

The Property Sheet

You can use the property sheet (shown below) to view or change the properties of a
selected control or controls or of the entire report or form. The properties that appear
on the property sheet depend on what part of the design you've selected.

D ynyase't, .
No bocks
Bath
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Like many tools in design view, the property sheet can be toggled on or off, displayed
or hidden. To display or hide the property sheet, use any method below:

¢ Click on the Properties button (shown at left) on the Form Design or Report Design
toolbar.

° Choose View » Properties from the menu bar.

° Right-click on any object and choose Properties.

Changing a Property
To change a property:

1. Select the object or objects you want to change. (See “Selecting Controls, Sections,
Forms, and Reports” later in this chapter.)

2. Open the property sheet as described above (View » Properties).

3. Click on the tab for the type of properties you want to change. (Properties that
don’t make sense for all selected objects won't appear on the property sheet.) From
left to right, the property tabs are as follows:

Format Lets you specify appearance properties. Format properties are changed
automatically when you move or resize a control and when you use the Format-
ting (Form/ Report Design) toolbar buttons to customize a control.
Data Lets you specify the source of the data and the data’s display format,

On forms, Data properties control such things as default values and allowable
values.

On reports, Data properties also control whether a text box shows a run-
ning sum.
Event Lets you control what happens when certain events occur. For example,
an On Click event property defines what happens when you click on a com-
mand button in form view. You'll learn more about event properties in Part Four
of this book.
Other This category is a catchall for things such as the name of a control
when it’s used in expressions, macros, and procedures; the text that appears on
the status bar when you select the control in form view; how the Enter key
behaves during data entry (see Chapter 8); whether the AutoCorrect feature is
enabled (see Chapter 9); the custom shortcut menu that appears when you
right-click on a form or control; and the ControlTip text that pops up when
you point to the control in form view.



DESIGN TooLs |

All Displays all available properties for the control. When you're not sure
which tab contains the property you're looking for, click on the All tab.

4. Click in the text box next to the property you want to change. A drop-down list
button and/or Build button (...) may appear.

When you select multiple controls and then change properties, your changes will
affect all the selected controls. Thus you can change the background color or font
for an entire group of objects in one fell swoop. For another way to copy properties
from one object to another, see “Copying Properties to Other Controls,” later in
this chapter.

5. Do one of the following:

o Type the property value you want. If you're entering lots of text into the box,
you can press Shift+F2 (Zoom) to expand the box.

e (Click on the drop-down button if one is provided and choose the property
from the list.

e Click on the Build button (if one is provided) and build an expression with
help from a “builder” dialog box.

¢ Double-click in the text box to choose the next available property from the drop-
down list. Double-clicking is especially handy for quickly flipping Yes/No values.

" Take some time to explore the properties of controls on a form or report that you
generate with a Wizard. To avoid becoming overwhelmed by the sheer number of
properties available, looking at the properties on the Format, Data, Event, and
Other properties tabs separately is easier than trying to wade through all properties
on the All tab.

To learn more about what a property does, click in the appropriate property text box
and look at the status bar at the bottom of the screen for a brief description. If you still
need more details about the property, press Fl.
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The Ruler

The ruler is most helpful when you're sizing or moving objects by dragging. As you
drag, a shadow on the ruler indicates the object’s size and location. To hide or display
the ruler choose View » Ruler.

The Grid

You can use the grid to align objects on the design. To hide or display the grid choose
View » Grid.

S
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1 If you've turned on the grid but can't see the grid dots, set the grid density to 24
~ or less (as described in a moment).

Snapping to the Grid

As you move and size objects on the screen, they’ll usually snap (align) to points on the
grid, making it easier for you to keep objects aligned. This alignment will happen even
if the grid isn't visible at the moment.

° To activate or deactivate grid snap, choose Format » Snap To Grid.
° To disable grid snap temporarily, hold down the Ctrl key while moving or siz-
ing an object,

Changing the Grid Density

The grid dots are visible only when the grid density is set to 24 or fewer dots per inch
(and when Grid on the View menu is selected). To change the grid density:

1. Open the property sheet (View » Properties) and click on the Format tab.

2. Select the form or report. To do so, choose Edit » Select Form (if you're designing
a form) or choose Edit » Select Report (if you're designing a report). The property
sheet shows properties for the form or report as a whole.

3. Scroll down to the Grid X and Grid Y properties and set each to 24 or smaller. (The
default setting is 24 for both properties.)

4. Close the property sheet if you wish.
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Sizing Controls and Aligning Them to the Grid
To tidy up your design, you can size all the controls on the design and you can align
them to the current grid. Here’s how:

1. To select all the controls, choose Edit » Select All (or press Ctrl+A).
2. Do either (or both) of the following:

e To size all the controls so they touch the nearest gridpoints, choose Format »

Size » To Grid.
¢ To align all controls to the grid, choose Format » Align » To Grid.

All the controls will size or align to their nearest grid mark. You can make additional
changes using techniques described later under “Moving Controls” and “Resizing
Controls.”

Changing the Size of the Form or Report

If the grid is on, the form or report background shows crosshair lines at 1-inch intervals.
It also shows grid dots (if the grid density is 24 or less). Most important, the background
shows the actual boundaries of the form or report (refer to Figures 13.2 and 13.3). If the
form or report is too large or too small, you can change the size anytime you wish:

e To change the width, drag the right boundary line of the background to the left

or right.

e To change the height, drag the bottom boundary line of the background up or
down.

¢ To change both the width and the height, drag the lower-right boundary line

diagonally.

Sizing the Background to Prevent Spillover Pages

If you want all your data to fit across a single page in a printed report, the background
width plus the report margins must be less than (or equal to) the paper width.

To adjust the margins, choose File » Page Setup from the design window’s menu
bar. Click on the Margins tab, use the Margins options in the dialog box to set margin
widths (see Figure 13.5), and then click on OK.
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FIGURE 13.5

The Page Setup
dialog box.

If you try to change the margins to some small number and Access increases the
width you specify, it's not a malfunction. Access is adjusting your entry to compen-
sate for the printer’s dead zone. The dead zone is the area at the outer edge of the
page where the small wheels that pull the paper through the printer are located.
The printer can’t print in the dead zone.

Designer Shills

Becoming an Access designer is a three-step process. First you must learn what tools are
available in design view, then you must learn how to use them, and finally you must
play with them until you can create any form or report your imagination can conjure
up. The rest of this chapter should help you achieve the first two steps; the last step
youll have to do on your own.
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Adding Bound Controls (Fields)

When you want to show data from the underlying table or query in your form or
report, you should add a bound control to your design. The most commonly used bound
controls are text boxes. (Bound controls are created automatically when you use a Form
Wizard or Report Wizard.)
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Unbound controls can include results of calculations and objects such as informa-
tional text, graphics, lines, and boxes that aren’t connected to underlying data.

Some Wizards also add unbound controls to the designs they create.

To add a bound control to your design:

1. Display the field list if it’s not visible (choose View » Field List).
2. Use any of these techniques:

¢ To add one field to the form or report, drag the field from the field list to the
place where it should appear in the design.

o To copy all fields to your form or report at once, double-click on the title bar
in the field list and then drag the selected fields to the design.

e To copy several fields, use standard Windows techniques (for example, Shift-
click or Ctri-click) to select multiple fields in the field list and then drag the
selected fields to the design.

Access will create a text box, list box, checkbox, combo box, or bound OLE object
control, depending on the data type and the Display Control propesty defined for the
field in the underlying table design or query design. (The Display Control property is
on the Lookup tab of the table design view property sheet; see Chapter 6.)

The control will include a label that displays either the field’s name or whatever text
you assigned to the field’s Caption property in table design view. If you want to change
the label text, click inside the label until the insertion point appears and then edit the
text (or select the label text and type new text to replace it).

Of course, you also can use other tools in the toolbox to create a bound control, but
doing so is not as easy as dragging fields from the field list.

About Inherited Properties

The bound controls will inherit all the Lookup propetties from the underlying table
fields, along with these General properties: Format, Input Mask, Caption, Default Value,
Validation Rule, Validation Text, and Decimal Places.
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Even though the Default Value, Validation Rule, and Validation Text properties a
inherited, you won’t see their settings on the Data tab of a new control’s property she
You can add a Validation Rule, Validation Text, and Default Value property to the cc
trol on the form if you wish. If you do so, Access uses the form’s Validation Rule an
Validation Text in addition to the underlying table’s validation rule for the associate
field. The Default Value property assigned on the form will override the table’s Defat
Value property.

Selecting Controls, Sections, Forms, and Reports

Before you can change, move, or delete objects in the design, you must select them. Tl
first step is to click on the Select Objects toolbox button (shown at left) so that it appea
“pushed in.” Then use any of these techniques:

e To select one control, click on the control. Sizing and move handles will appe
as shown in Figure 13.6.

¢ To select adjacent controls, start at any point outside a control and drag a re
angle over the controls you want to select.

FIGURE 13.6
A selected
control. This
example shows
the parts

of a text box,
which is a
compound
control that
has both a
label and

a field.

To control how precise you must be when dragging the selection rectangle ove
adjacent controls, choose Tools » Options and then click on the Forms/Report:
tab in the Options dialog box. Next choose either Partially Enclosed (lets you drz
the rectangle through only part of a control or group of controls) or Fully Enclose
(requires you to drag the rectangle completely around the control or group of cc
trols). Click on OK to save your changes.

Move handles

T
L ﬂ:irstName
S— ]

iFirst N

Sizing handles
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e To select nonadjacent controls, parts of compound controls (such as a field and
its label), or overlapping controls, hold down the Shift key and click on each con-
trol you want to select. This standard Windows technique is called Shift-clicking.

e To use the ruler to select controls, move the mouse pointer to the horizontal or
vertical ruler. (The pointer changes to a { or T, respectively.) Then click on the
line that goes through all the controls you want to select. Or drag the mouse
along the ruler until shading encloses the controls you want to select and then
release the mouse button.

e To select a section in a form or report, click on the gray bar that shows the sec-
tion name. (You’ll learn more about sections shortly.)

e To select all controls on a form or report, choose Edit » Select All or press Ctrl+A.

e To select the entire form or report, choose Edit » Select Form or Edit » Select
Report. Or, if the rulers are visible, click on the box where the rulers intersect
(below the File menu). Or click on the Select Objects drop-down list (shown at
left) on the Formatting (Form/Report Design) toolbar, and then choose Form or
Report from the top of the list.

f % M;@%@W&WM%MW” R = 2 ARG i

If the property sheet “blanks out” suddenly when you clickon a contro| that s already
selected, you can restore the property display in either of two ways: press Enter if you
want to keep any changes you've typed into the control; or press Escape if you don't
mind discarding any changes you’'ve typed in.

Here’'s how to deselect controls:

e To deselect all selected controls, click in an empty area of the design.
e To deselect certain controls in a group of selected controls, Shift-click on the
controls you want to deselect.

Working with Selected Controls

Once you've selected a control (or a group of controls), you can delete, move, resize, or
align your selection and change spacing between selected controls.

Deleting Controls

To delete controls select the controls you want to delete and press Delete. If you change
your mind, immediately choose Edit » Undo, press Ctrl+Z, or click on the Undo button
on the Form Design or Report Design toolbar.
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To delete just the label portion of a compound control, click on the label and press
Delete.

S s 5 5 &Wﬁ
To hide the label temporarily without deleting it, change the label’s Visible prop-
erty to No on the Format tab of the property sheet.

oy BB B

Moving Controls

You can position controls anywhere on the design. First select the control or controls
you want to move.

e To move entire selected controls, pass the mouse pointer over the controls until
the pointer changes to an open hand and then drag the selection to a new posi-
tion. (To move controls to a different section of the report or form, make sure all
selected controls are in the same section and then drag them to the new location.)

¢ To move part of a selected compound control, pass the mouse pointer over the
move handle in the upper-left corner of the control until it changes to an upward-
pointing hand, and then drag the control to a new position. '

You can hold down the Shift key while dragging to move the control vertically or
horizontally only.

e To move a selected control by a very small amount, press Ctrl+—, Ctrl+«,
Ct11+T, or Ctil+l. The control will move in the direction of the arrow key you
pressed while holding down the Ctrl key.

Resizing Controls

If a control is too large or too small, you can resize it in various ways. As always, you
begin by selecting the control or controls you want to change.

e To resize selected controls, move the mouse pointer to a sizing handle (the
pointer changes to a two-headed arrow), drag the sizing handle until the controls
are the proper size, and then release the mouse button. If you've selected multiple
controls, all controls will be resized by the same amount.

e To size selected controls so that their data will fit the contents, choose Format »
Size » To Fit.

e To size selected controls to the nearest grid mark, choose Format » Size » To Grid.
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e To resize a label control to fit snugly around the label text, double-click on
one of the label’s sizing handles.

» To make selected controls the same size, choose Format » Size and then pick To
Tallest, To Shortest, To Widest, or To Narrowest. Access will resize all selected con-
trols according to the option you chose (for example, all selected controls will be
as tall as the tallest control in the selection).

e To size selected controls by a very small amount, press Shift+—, Shift+«,
Shift+T, or Shift+!.

a

Aligning Controls

Your forms and reports will Jook much nicer if text and data are neatly aligned. Here’s
how to align controls:

1. Select the controls you want to line up.

2. Choose Format » Align from the menus, or right-click on a selected control and
choose Align.

3. Choose Left, Right, Top, Bottom, or To Grid, as appropriate. For example, if you
choose Format » Align » Left, all selected controls will align with the leftmost con-
trol in the selection. ‘

If selected controls are overlapping when you align them, Access will place the
controls in a staggered arrangement, which probably isn't what you want. [ts
best to make sure the controls don’t overlap before you try to align them.

Adjusting the Horizontal and Vertical Spacing

You can further fine-tune your design by adjusting the horizontal and vertical spacing
between two or more selected controls:

1. Select the controls you want to adjust. If you want to space the controls an equal
distance apart, select three or more controls.

2. Choose Format » Horizontal Spacing to adjust horizontal spacing between
selected controls. Choose Format » Vertical Spacing to adjust vertical spacing.

3. Choose one of these spacing options:

Make Equal Makes the horizontal or vertical distance between three or more
selected controls equal. Access will space the selected controls evenly within
the space that’s available between the highest (or leftmost) and the lowest (or
rightmost) selected control.
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Increase Increases the horizontal or vertical space between selected controls
by one grid point.
Decrease Decreases the horizontal or vertical space between selected controls
by one grid point.

Duplicating Controls

The Duplicate feature offers a quick and easy way to create an evenly spaced and aligned
copy of one or more selected controls. Simply select the control(s) you want to duplicate
and choose Edit » Duplicate (or right-click on the selection and choose Duplicate). You
can then resize or move the copied control, or change its properties, as desired.

)
To create multiple copies of one or more controls with the same relative spacing
and position for each copy, duplicate the control(s) once, adjust the spacing and
position as needed (without making any other changes), and then make as many
duplicates of the still-selected controls as you need.

T B B B T SR R R B R e

Changing the Font, Color, Border,
Appearance, and More

The Formatting (Form/Report) toolbar (see Figure 13.7) provides many great ways o
beautify a control. You can change the text font and alignment; add foreground, back-
ground, and border colors; add special effects such as a raised, sunken, or etched border;
and choose border width.

Follow these steps to work with this toolbar:

1. Do one of the following:

If the toolbar isn’t visible, right-click on any toolbar that is visible and choose
Formatting (Form/Report Design).

Or

If no toolbar is visible, choose View » Toolbars, select (check) Formatting
(Form/Report Design), and then click on Close.

2. Select the control or controls you want to customize.

3. Click on a button in the Formatting (Form/Report) toolbar or click on the drop-
down arrow next to a button; then choose an option to apply the effect you want.
(In the Fill/Back Color and Line/Border Color drop-down palettes, clicking on the
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Use the Format-
ting (Form/
Report) to
choose fonts,
text alignment,
colors, borders,
and special
effects for a con-
trol, In this
example, we've
clicked on the
drop-down
arrow next to
the Line/Border
Color button.

Bold ltalic  Underline Align left  Center Align right
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Transparent button makes the selected control transparent, so that the color
shown in the control is the same as the color of the control, section, or form
behind it.) As usual, you can find out what a button is for by moving the mouse
pointer to the button and waiting a moment for a ScreenTip to appear.

se

After pulling down the Fill/Back Color, Font/fore Color, Line/Border Color, Line/
Border Width, or Special Effect palettes on the toolbar, you can drag them off the
toolbar to leave them open as you work. To return any palette to the toolbar, click on
the drop-down arrow for its toolbar button, or click on the palette’s Close button.




| CHAPTER 13 « CREATING CUSTOM FORMS AND REPORTS

[ ] OTE #

Instead of using the toolbar, you can select the control(s) and change format prop-

"~ erties in the property sheet; but that’s doing it the hard way (unless the property
sheet offers additional features that aren’t available on the toolbar). For example,
you can select from 16 million different colors by using the property sheet, instead
of only the 56 different colors shown in the color palettes.

 FIGURE 13.8 —H
The Tab Order ; ; T —
dialog box.
Custor Qeder.
ContactFirstMame
Contactlasth amme
Bilingaddress
ity
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Country
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Controlling the Tab Order

The tab order controls the order in which the cursor moves through fields on a form
when you press the Tab and Shift+Tab keys. After you’ve rearranged fields in a form, the
current tab order may seem jumbled when you use the form in form view. To fix the tab
order, follow these steps:

1. Choose View » Tab Order in form design view. You'll see a Tab Order dialog box
similar to the example shown in Figure 13.8.

2. Select the section in the Section group you want to redefine (for example, choosc
Detail).

3. Click on the Auto Order button to have Access quickly set the tab order from left
to right and top to bottom.

4. Click on or drag through the row selector(s) for the rows you want to reposition to
assign the tab order manually. Then move the mouse pointer to one of the selected
row selectors and drag the row or rows to a new position in the Custom Order list.

5. Repeat steps 3 and 4 as needed and then click on OK.
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In form view, pressing Tab will now move the cursor forward in the new tab order.
Pressing Shift+Tab will move the cursor backward in the new tab order.

\"/ To prevent the cursor from landing on a control when you press Tab or Shift+Tab
" in form view, return to form design view and set the Tab Stop property for that
control to No. You'll find this property on the Other tab of the property sheet.

Copying Properties to Other Controls

Suppose you've formatted a control just the way you want it and now want other con-
trols to have the same look. Making this happen is quick and easy:

1. Select the control that has the formatting you want to copy to another control.
2. Do one of the following:

e To copy the format to one other control, click on the Format Painter button
on the Form Design or Report Design toolbar.

o To copy the format to several other controls, double-click on the Format
Painter button.

3. Click on the control that should have the new format.
If you double-clicked on the Format Painter button in step 2, continue clicking on
other controls that should have the new format.

4. Press Esc or click on the Format Painter button again when you're done copying
the format.

The format painter will copy any formatting properties that you can set via the For-
matting (Form/Report) Toolbar, and almost every property that you can set via the
Format tab on the property sheet. Pretty nifty!

Adding Help, Menus, and Prompts to Controls

By now, you’ve probably taken advantage of status bar prompts, shortcut menus, and
ScreenTips to help you figure out what to do next or to do something more quickly.
Guess what? You can add these conveniences to any control on your form by updating
properties on the Other tab of the property sheet.
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When you drag names from the field list to your design, Access automatically fills

in the Status Bar Text property with any text that appears in the Description col-

umn for that field in table design view. if the Description is blank, the Status Bar
Text also will be blank.

To set up custom help text and shortcut menus that will appear in form view, select the
control you want to customize (in form design view), open the property sheet (View »
Properties), and then click on the property sheet’s Other tab. Now assign values to any
of these properties. Figure 13.9 shows a completed example:

Status Bar Text Displays a message on the status bar when the cursor lands in
the control.

Shortcut Menu Bar Displays a custom shortcut menu when you right-click on
the control. Chapter 24 explains how to create custom shortcut menus,
ControlTip Text Displays a pop-up message when you point to the control with
the mouse. ControlTips are similar to the ScreenTips that appear when you point
to toolbar buttons.

A memo field to
which we've
assigned Status
Bar Text, Short-
cut Menu Bar,
and ControlTip
Text properties.

esonbe lhe employee 3 dulies
e Lme in Fleld

Form design view
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Help Context ID Displays information from a custom Help file that's named in
the Help File property (the Help File property appears on the Other tab when you
select the entire form). The custom Help will appear if you move the focus to
(click on) the control in form view and then press F1. You can create a custom
Help file using Microsoft’s Windows Help Compiler and a rich-text format text
editor, such as Microsoft Word for Windows or the Windows WordPad. Many
third-party companies also offer Help authoring tools.

F e ]

The Wmdows Heip Compiler and the Help Compiler Guide come with the Microsoft
Access Developer’s Toolkit, Microsoft Visual Basic, Microsoft Visual C++, and the
Microsoft Software Development Kit (SDK). Please contact Microsoft for more infor-

mation about these tools.

Figure 13.10 shows the form from Figure 13.9 after we switched to form view, clicked in
the field, and let the mouse pointer rest in the field for a moment. Right-clicking on the
field would display a menu of options from our Writing Tools shortcut menu (not shown).

For more about any of these “helpful” properties, open the property sheet (View » Prop-
erties), click on the Other tab, click in the appropriate property box, and then press F1.

| FIGURE 13.10 |
The field from
Figure 13.9 in
form view.
Notice the sta-
tus bar text at
the bottom of
the screen and
the ControlTip
text near the
mouse pointer.

Form view 1

1" Process incowing mail
47 Send outgoing mwail
¢ Type letters T

Lnswer phones

Enter Job Descriptio 1
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When you drag names from the field list to your design, Access automatically fills
* in the Status Bar Text property with any text that appears in the Description col-
umn for that field in table design view. If the Description is blank, the Status Bar
Text also will be blank.

To set up custom help text and shortcut menus that will appear in form view, select the
control you want to customize (in form design view), open the property sheet (View »
Properties), and then click on the property sheet’s Other tab. Now assign values to any
of these properties. Figure 13.9 shows a completed example:

Status Bar Text Displays a message on the status bar when the cursor lands in
the control.

Shortcut Menu Bar Displays a custom shortcut menu when you right-click on
the control. Chapter 24 explains how to create custom shortcut menus.
ControlTip Text Displays a pop-up message when you point to the control with
the mouse. ControlTips are similar to the ScreenTips that appear when you point
to toolbar buttons.

A memo field to
which we've
assigned Status
Bar Text, Short-
cut Menu Bar,
and ControlTip
Text properties.

Dufies ..
Describe the employes’s duties

wiiing Tools
Enter Job Description
0

Form design view
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Help Context ID Displays information from a custom Help file that's named in
the Help File property (the Help File property appears on the Other tab when you
select the entite form). The custom Help will appear if you move the focus to
(click on) the control in form view and then press F1. You can create a custom
Help file using Microsoft’s Windows Help Compiler and a rich-text format text
editor, such as Microsoft Word for Windows or the Windows WordPad. Many
third-party companies also offer Help authoring tools.

~ The Windows Heip Compller and the Help Compiler Guide come Wlth the Mlcrosoft
Access Developer’s Toolkit, Microsoft Visual Basic, Microsoft Visual C++, and the
Microsoft Software Development Kit (SDK). Please contact Microsoft for more infor-

mation about these tools.

Figure 13.10 shows the form from Figure 13.9 after we switched to form view, clicked in
the field, and let the mouse pointer rest in the field for a moment. Right-clicking on the
tield would display a menu of options from our Writing Tools shortcut menu (not shown).

For more about any of these “helpful” properties, open the property sheet (View » Prop-
erties), click on the Other tab, click in the appropriate property box, and then press F1.

FIGURE 13.10 =
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the ControlTip
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mouse pointer.
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Customizing AutoFormat Styles

You can customize existing AutoFormat styles, add new styles, and delete unwanted
styles in a flash. You can customize the font, color, and border controls in each section
as needed. You also can set background colors for each section and choose a Picture for
the form background. (For more about displaying background pictures, see “Adding a
Background Picture” later in this chapter.) Any new styles you add will be available to
the Form Wizards and Report Wizards and in the AutoFormat dialog box shown earlier
in Figure 13.4.

To open the AutoFormat dialog box, click on the AutoFormat button on the Form
Design or Report Design toolbar or choose Format » AutoFormat, If you want to update
or delete an existing AutoFormat, click on that format in the Form AutoFormats or Report
AutoFormats list.

When you click on the Customize button in the dialog box, you'll see a Customize
AutoFormat dialog box similar to this one:

i &5 Customize AutoFormat

° To create a new AutoFormat style based on formats in your current form or
report, choose the first option.

* To update the selected AutoFormat with formats from your current form or
report, choose the second option.

° To delete the selected AutoFormat, choose the third option.

Click on OK and then click on Close when you are finished working in the Auto-
Format dialog box.
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Specifuing the Record Source On e Fly

If you've accidentally chosen the wrong source for data in your report or form, or you
wish to change it, here’s what to do:

1. Open the property sheet (View > Properties), and click on the Data tab.

2. Select the entire form or report (Edit » Select Form or Edit » Select Report).

3. Click on the Record Source property box on the property sheet’s Data tab. A drop-
down list button and a Build button will appear.

4. Do one of the following:

e Type the table name or query name of the record source into the property box
or choose a table or query from the drop-down list.

e Build a query on-the-fly by clicking on the Build button and on Yes if a mes-
sage appears. Define a query that selects and displays the records you want,
using techniques discussed in Chapter 10. Test and save the query if you wish.
When you're done defining the query, choose File » Close (or press Ctrl+W, or
click on the Close button in the SQL Statement dialog box) and answer Yes if
prompted to save your changes. Press Enter to move the cursor to the next
property box. An SQL statement will appear in the Record Source property box;
this SQL code is just an equivalent way to express the query.

5. Preview the report or switch to form view.

If you see #Name? or #Errox? in a control, that control has become undefined as a
result of your efforts in step 4. Return to design view, delete the incorrect or extraneous
control(s), and drag the appropriate field(s) from the field list to your design. Or open
the property sheet in design view (View » Properties), select the control you want to
change, click on the Control Source box on the property sheet’s Data tab, and type in
or select the appropriate field or expression.

For more information about troubleshooting #Name? and #Error? problems, look up
Troubleshooting Forms in the Access Help Index or Answer Wizard, double-click on Trouble-
shoot Forms, and then click on the button next to I Need Help T roubleshooting Problems With
Controls On My Form.

Sections, Headers, and Foofers

All reports and forms are divided into the sections described below to help you control
what appears where on the finished form or report. We'll show some examples in a
moment.
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Form Sections

Forms are divided into as many as five sections:

Form Header Always visible at the top of a form; printed only on the first page.
Page Header Printed at the top of each page when you print forms (never visible
in form view).

Detail Generally used to show fields (data) from an underlying table or query.
Page Footer Printed at the bottom of printed forms only. Never visible in form
view.

Form Footer Always visible on the bottom of the form window; printed only on
the last page.

Figure 13.11 shows the design view for a completed form with a form header and
footer, page header and footer, and detail section. Figure 13.12 shows the same form in
form view. Remember that page headers and footers appear only on printed copies of

FIGURE 13.11 u
A sample form  Form design view
in design view, _ B
illustrating the R Microsoft Access
various sections. ' : '
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The design
shown in
Figure 13.11
looks like this in

form view. mal e
]Sales Hep s'éyntaytiv'e

the form and in print preview, so you'll never see them in form view. In Figure 13.13
you see the same form in print preview with its page header clearly visible. (To see the
Confidential! Secret! page tooter in print preview, click on the form to make it fit on the
page or use the vertical scroll bar to scroll to the bottom of the form.)

FIGURE 13.13
In print preview R Microsoft Access
(and in printed i
copies of the
form), the
design shown
in Figure 13.11
looks fike this.
Although it's
cut off on this
figure, the
Confidentiall
Secret! Private!
Personal!
Classified! page
footer also will
appear at the
bottom of
each page in
print preview
and on the
printed copies.




6 | CHAPTER 13 » CREATING CUSTOM FORMS AND REPORTS

Report Sections

Reports can have sections similar to those in forms. But reports also can have grouping
sections, which allow you to break data into separate groups. Each group can have its
own header and footer. Here’s a summary of the sections:

Report Header Printed once at the beginning of the report (Example: a cover page).
Page Header Printed at the top of each page.

Group Header Printed at the top of each group.

Detail Printed once for each record in the underlying table or query.

Group Footer Printed at the bottom of each group (often used to place subtotals
at the end of each printed group).

Page Footer Printed at the bottom of each page.

Report Footer Printed once at the end of the report. Often used to display grand
totals at the end of a report that includes subtotals.

Figure 13.14 shows a report with multiple sections in design view, and Figure 13.15
shows the printed report.

FIGURE13.14

A sample
report showing
sections of a
report design.
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The report :
produced by Orders By Date Report header
the design in '
Figure 13.74. OrderDate ProductName Quantity UnitPrice Discount § Before Tax — Page header

This report is

sorted and Group header

grouped on the Basketball 1 $495  0.00% $4.95
OrderDate and
ProductName Basketball 2 $495  0.00% $9.90
f/elds (G/thOUgh Billiard balls 2 $127.45 0.00% $254.90
the Product-
Name group Crystal ball 2 $4555  0.00% $91.10
header and Foosball 4 $1785  000%  $71.40 Detail
footer are
empty). Football 1 $565 . 0.00% $5.65
Football 1 $5.65 0.00% $5.65
Football 2 $5.65 0.00% $11.30
Tether ball 5 $9.65 0.00% $48.25
Summary for 'OrderDate’ = 2/1/95 (9 detail records) GI’OUp footer
Sum 20 $503.10
2/11/95
Baseball 2 $8.75 0.00% $17.50
Basketball 1 $4.95 0.00% $4.95
Basketball 2 $4.95 0.00% $9.90
Football 1 $5.65 0.00% $5.65
Summary for '‘OrderDate’ = 2/11/95 (4 detail records)
Sum 6 $38.00
2/18/95
Crystal ball 1 $4555 0.00% $45.55
Golf balls 1 $6.75 0.10% $6.74

Summary for 'OrderDate’ = 2/18/95 (2 detail records)
Sum 2 $52.29

Wednesday, September 06, 1995 page 105 — Page footer
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Report Sections

Reports can have sections similar to those in forms. But reports also can have grouping
sections, which allow you to break data into separate groups. Each group can have its
own header and footer. Here’s a summary of the sections:

Report Header Printed once at the beginning of the report (Example: a cover page).
Page Header Printed at the top of each page.

Group Header Printed at the top of each group.

Detail Printed once for each record in the underlying table or query.

Group Footer Printed at the bottom of each group (often used to place subtotals
at the end of each printed group).

Page Footer Printed at the bottom of each page.

Report Footer Printed once at the end of the report. Often used to display grand
totals at the end of a report that includes subtotals.

Figure 13.14 shows a report with multiple sections in design view, and Figure 13.15
shows the printed report.

FIGURE 13.14 "

A sample A Mi cess - [Eigure “Report]
report showing '
sections of a
report design.

E«Befam by m}

I§ Before Tax |
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The report
produced by
the design in

Figure 13.74.
This report is
sorted and
grouped on the
OrderDate and
ProductName
fields (although
the Product-
Name group
header and
footer are

empty).

Orders By Date

Report header

OrderDate ProductName Quantity UnitPrice Discount $ Before Tax — Page header
Group header
Basketball 1 3495  0.00% 3496 |
Basketball 2 $4.95 0.00% $9.90
Billiard balls 2 $127.45 0.00% $254.90
Crystal bail 2 $4555 0.00% $91.10
Foosball 4 1785 000% $71.40 Detail
Football 1 $5.65 0.00% $5.65
Football 1 $5.65 0.00% $5.65
Football 2 $5.65 0.00% $11.30
Tether ball 5 $9.65 0.00% $48.25 _ |
Summary for 'OrderDate’ = 2/1/95 (9 detail records) Group footer
Sum 20 $503.10
Baseball 2 $8.75 0.00% $17.50
Basketball 1 $4.95 0.00% $4.95
Basketball 2 $4.95 0.00% $9.90
Football 1 $5.65 0.00% $5.85
Summary for 'OrderDate’ = 2/11/95 (4 detaif records)
Sum 6 $38.00
Crystal ball 1 $45.55 0.00% $45.55
Golf balls 1 $6.75 0.10% $6.74
Summary for 'OrderDate’ = 2/18/95 (2 detail records)
Sum 2 $52.29

Wednesday, September 06, 1995

page 10f5 — Page footer
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Adding or Removing Headers and Footers

The View menu provides commands to add and remove report page headers and foot-
ers, and form page headers and footers. Adding a header or footer section is easy:

1. Choose View.

2. Choose the unchecked command for the section you want to add (Page Header/
Footer, Form Header/Footer, or Report Header/Footer).

Deleting a section is just as easy, but you should think carefully before deleting. If
you delete a section that already contains controls, you'll lose all the controls in that
section. Fortunately, Access will warn you if you're about to lose controls and will give
you a chance to change your mind. (This operation has no “undo.”)

It's a good idea to save your design (File 2 Save or Ctrl+S) before you delete a section.
That way, if you accidentally delete the wrong section, you can close your design with-
out saving it (File » Close » No) and then reopen the previous copy in design view.

To delete a section, choose View and then choose the checked command for the sec-
tion you want to delete. If Access asks for confirmation, click on Yes only if you're sure
you want to delete all the controls in that section.

You can move controls to another section of the form or report before deleting the
section (see “Moving Controls” above for details). You also can resize a section, as
explained later in this chapter under “Sizing a Section.”

Grouping Data in Reports

You can group data in reports (but not in forms) by creating Sorting And Grouping sec-
tions. These sections are handy for sorting data and printing subtotals, as shown earlier
in Figure 13.15.

Sorting And Grouping sections differ from the other sections described above in that:

e You can use Sorting And Grouping sections only in reports (not forms).

e You don’t use the View menu to add or remove Sorting And Grouping headers or
footers.

e A Sorting And Grouping header or footer is often based on some field from the
underlying table or query or on some expression that involves a field.
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The Easy Way to Create Groups/Subtotals

The easiest way to create a report with sorting and grouping sections is to start from the
database window and use the Report Wizards to create the report (see Chapter 12).
When the Wizard is done, your report design will include the sorting and grouping sec-
tions and controls needed to print subtotals, grand totals, and percentage totals. You
can then switch to design view and tweak the report groupings to perfection.

Grouping without a Wizard

If you prefer to set up sorting and grouping sections without any help from a Wizard,
start in report design view and follow these steps:

1. Click on the Sorting And Grouping button (shown at left) on the Report Design
toolbar or choose View » Sorting And Grouping from the menus. You'll see the
Sorting And Grouping dialog box. A completed example is shown in Figure 13.16.

2. Use the drop-down list under Field/Expression to select the field to group by, or
type a custom expression of your own.

The report from
Figure 13.15,
shown in design
view, with the
Sorting and
Grouping dia-
log box open on
the screen

Ascending

& Page Fodler

i @ HeportFooter
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3. Change the Sort Order from Ascending to Descending to arrange groups from largest-
to-smallest order (for example, from Z to A or from December to January).
4. Change these properties in the lower pane of the dialog box, as needed:

Group Header To create a header section for the group, change the Group
Header property from No to Yes.

Group Footer To create a footer section for the group, change the Group Footer
property from No to Yes.

Group On To choose how you want to form the groups, select options from
the Group On drop-down list. The available options depend on the type of
field you're grouping on, as summarized in Table 13.1.

CHOOSE THIS GROUP

ON PROPERTY TO GROUP RECORDS ON
Text Fields
Each Value Same value in the field or expression
Prefix Characters Same first n number of characters in the field or

expression (set n with the Group Interval property)

Date/Time Fields

Each Value Same value in the field or expression
Year Dates in the same calendar year

Qtr Dates in the same calendar quarter
Month Dates in the same month

Week Dates in the same week

Day Dates on the same day

Hour Dates in the same hour

Minute Dates in the same minute

AutoNumber, Currency, or Number Fields
Each Value Same value in the field or expression

Interval Values that fall in the interval you specify in the
Group Interval property
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Group Interval To change the interval or number of characters to group on,
type a number into the Group Interval box. For instance, to group records by the
first three letters of a customet’s last name, change Group On to Prefix Charac-
ters and set the Group Interval to 3.

Keep Together To prevent a group that’s less than a page in length from being
split across two pages, change this property from No to Whole Group (keep the
entire group together) or With First Detail (keep just the group header and first
detail record together).

5. (Optional) Add any of the following to the header or footer section: fields from the
field list, calculated controls (for subtotals and totals), horizontal lines, rectangles,
and page breaks.

See “Creating Calculated Controls” and “Adding Page Breaks” later in this chapter
for more about those topics.

Creating More Than One Group

You can add more than one level of grouping. For instance, you might want to group
orders first by OrderDate and then by ProductName within OrderDate, and then by
Quantity within ProductName, as shown in Figure 13.16.

To add another level, open the Sorting And Grouping dialog box. Click in the Field/
Expression column where you want the new group to appear in the grouping hierar-
chy. If you need to open up a new row in the dialog box, click on the row selector where
the blank row should appear and then press Insert. Now fill in the Field/Expression,
Sort Order, and Group Properties as described above.

Deleting, Moving, or Changing a Group Header/Footer

You can hide, delete, or move a grouping section, and you can change the field or
expression used for grouping as follows:

¢ To hide a group header or footer section (but keep the grouping), click in the
appropriate row in the Sorting And Grouping dialog box. Then change the row’s
Group Header or Group Footer property (as appropriate) to No. Records will still
be grouped and sorted as before, but the selected group header or footer for this
section won't be printed.

o To delete a grouping section, click on the appropriate row selector in the Sorting
And Grouping window, press the Delete key, and click on Yes when asked for con-
firmation. Records will no longer be grouped or sorted by the field or expression,
and any group headers and footers for this section will disappear from the repoit.
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e To move a grouping section, click on the appropriate row selector in the Sorting
And Grouping window and then drag the selected row up or down to a new posi-
tion in the grouping hierarchy. Access will rearrange the group header and footer
sections in the report design immediately.

e To change the field or expression used for grouping, click in the appropriate
Field/Expression box in the Sorting And Grouping dialog box. Then select
another field name from the Field/Expression drop-down list or type in a different
expression. To change the field displayed in the group header or footer section,
delete the old field from the appropriate section in the report design and then
drag a new one from the field list. Or select the control and change its Control
Source data property.

Hiding Duplicate Data in a Report

The sample report in Figure 13.15 and the corresponding report design in Figure 13.16
illustrate how the Sorting And Grouping feature can hide duplicate data. In those examples
we placed the OrderDate control in the OrderDate Header section (not in the Detail sec-
tion). That way, the order date information appears only when the order date changes, not
on every detail line.

Another way to hide duplicate data in a report doesn’t require the Sorting And
Grouping feature. Here are the steps:

1. Base the report on a query or table datasheet that’s sorted by the field you want to
group on or create the query on the fly, as discussed earlier in “Specifying the
Record Source on the Fly.”

2, Put the bound control for the group header in the detail section of the report. In
Figure 13.17, for example, we put CompanyName in the detail section and used it
as a sort field.

3. Open the property sheet (View » Properties), click on the control whose duplicate
values you want to hide, and change the Hide Duplicates property on the Format
tab to Yes. You also might want to change the Can Shrink property to Yes (to elim-
inate blank lines during printing) and the Can Grow property to Yes (to allow text
such as the company name to expand as needed).
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A report that's
sorted by
Company-
Name, Order-
Date, and
OrderlD

and suppresses
duplicate values
in all three
fields. We used
the Report Wiz-
ard to create an
ungrouped Tab-
ular report on
the Customers
and Orders
tables, and
then changed
the report’s
Record Source
on the fly to sort
each field in
Ascending order.

Company Name Order Date Order ID
ABC Corporation 2/1/95 1
3/14/95 2

4/18/95 3

5/21/95 4

6/25/95 5

Reese Clinic 2/18/95 11
2/25/95 12

3/26/95 13

4/15/95 14

5/1/195 15

RNAA Associates 2/1/95 6
4/1/95 7

4/9/95 8

5/11/95 9

6/12/95 10

University of the Elite 2/1/95 21
4/1/95 22

5/7/95 23

6/28/95 24
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Sizing a Section

Keep in mind that blank space in a form or report design always shows up as blank space
in the final form or report. Suppose you leave a blank, 2”-high page footer section at the
bottom of a report design. Later, when you print the report, every page will have 2 extra
inches of blank space at the bottom!

To fix the problem, change the height of the section as follows: Move the mouse
pointer to the divider at the bottom of the section. When the pointer changes to a
crosshair (shown below), drag the divider up or down and then release the mouse
button.

A section can’t be made smaller than the space required by the controls within that
section. If you can’t make a section as narrow as you’d like, first size and/or move the
controls in the section so that they take up less height. Then resize the section again.

Summarizing Your Data by Hiding a Section

Suppose you've set up a report with detail lines, subtotals, and totals. Now you want to
show only those subtotals and totals, without the detail lines. This type of report is
called a summary report because it summarizes your data without providing unwanted
details. That is, summary reports let you focus on the forest (your bottom line), while
conserving the trees (paper).

In Chapter 12 you learned how to use the Report Wizards, which can produce sum-
mary reports quite easily. But you also can set up summary reports (or hide any section
in a form or report) without using a Wizard. The secret is simply to hide or delete infor-
mation in the appropriate section, using either of these methods:

¢ Click on the band at the top of the section you want to hide. (For example, click
on the Detail band to hide detail lines in a summary report.) Now open the prop-
erty sheet (View » Properties), click on the Format tab, and change the section’s
Visible property to No. This method leaves all the controls in the section, but
doesn’t show the contents of the section in the finished form or report. If you
change your mind about hiding the information in the section, just click on the
section’s band again, open the property sheet, click on the Format tab, and change
the section’s Visible property back to Yes.
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¢ Delete all controls from the section; then size the section so that it has no height
at all. Of course, this method is more drastic than the one above, and it doesn’t
allow you to redisplay the section later.

Adding Your Own Confrols

You've already learned how to add controls to a report or form by dragging field names
from the field list. But bound controls are only the tip of the object iceberg. In the sec-
tions that follow, you'll learn how to use the toolbox to create more than a dozen different
types of controls.

Using the Toolbox

The toolbox (shown in Figure 13.18 and briefly described in Table 13.2) provides all the
tools you'll need to create your own controls.

Figure 13.19 shows a hodgepodge form, in form view, with many of the controls
that Access offers. Figure 13.20 shows the same form in design view. Of course you'll
probably never create a form as weird as this one, but it does illustrate the possibilities.

To open the toolbox if it isn’t visible, click on the Form Design or Report Design
toolbar’s Toolbox button (shown at left) or choose View » Toolbox.

Once you've opened the toolbox, using it is easy. The Select Objects and Control
Wizards buttons are foggle buttons that you can click on to activate or deactivate.

.
The Toolbox F—
provides all the .
buttons you Select Objects
need to design Label
controls of
your own.

b Control Wizards
| Text Box
Option Group Toggle Button
Checkbox

List Box

Option Button
Combo Box
Command Button Image
| Bound Object Frame
| Tab Control

Line

Unbound Object Frame
Page Break
Subform/Subreport

| More Controls

Rectangle ';
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BUTTON NAME

WHAT IT DOES

Select Objects
Label

Option Group*

Option Button

Combo Box*

Command Button*

Unbound Object
Frame*

Page Break
Subform/Subreport

Rectangle

Control Wizards

Text Box

Lets you select controls in the design window.

Creates a control that displays descriptive text (e.g.,
title, caption, instructions).

Creates a control that frames a set of checkboxes,
option buttons, or toggle buttons. In form view, only
one option in the group can be selected at a time.

Creates a control that you can select or clear. (Some-
times called a radio button.)

Creates a control that's like a list box and text box com-
bined. In form view, you can either type the text into the
combo box or select an item from the drop-down list.

Creates a control that opens a linked form, runs a
macro, calls a Visual Basic function, or runs a Visual
Basic procedure.

Creates a control that displays a picture, graph, or OLE
object that isn’t stored in the underlying table or query.

Creates a control that starts a new page in a report or
form or a new screen in a multiscreen form.

Inserts a form or report within the form or report you're
designing now.

Creates a control that appears as a rectangle or square.
Used for decoration.

Turns the Control Wizards on or off. In this chapter, we
assume that the Control Wizards button is selected
(pushed in), so that Wizards are available to help you
create option boxes, combo boxes, list boxes, charts,
and command buttons.

Creates a control that gives you a place to enter or view
text in a form or report. Also used to display calculation
results.

Continued i%}
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BUTTON NAME WHAT IT DOES

Toggle Button Creates a control that acts as an on/off button. Toggle
buttons can display text or a picture.

Checkbox Creates a control that you can select (check) or clear.
List Box* Creates a control that gives you a list of choices.
Image Creates a control that displays a picture. Image controls

display faster and offer more image formats than
Unbound Object controls, and they’re recommended
when you don't need to edit the object directly from
the form or report.

Bound Object Frame Creates a control that displays an OLE object (such as a
picture) that is stored in the underlying table or query.
(It's easiest to create bound controls by dragging fields
from the field list.)

Tab Control Creates a control with tabbed pages (like the ones you
see in a Properties menu).

Line Creates a control that appears as a straight line. Used
for decoration.

More Controls Displays a menu of ActiveX and other special purpose
controls.

* A Wizard will take you through the setup steps if the Control Wizards button is selected.

The Chart button, which creates a control that displays a chart, doesn’t appear in the toolbox initially.
Chapter 14 explains how to add this button and produce charts.

To create custom controls (such as the Calendar control provided with Access), choose Insert » Custom
Control.

The steps for using the other buttons appear below:

1. Click on the toolbox button you want to use. (If you want this button to remain
selected until you choose another one, double-click on the toolbox button.)

2. Click where you want the uppet-left corner of the control to appear or drag an out-
line to define the size and location of the control you're creating.

3. Respond to any prompts that appear (as described in the following sections).
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A hodgepodge
form in form
view. This

form includles
most types of
Access controls.

- =an Francisca

4. Click on the Select Objects toolbox button (if it’s not selected already). Then select
the control and adjust its size, position, colors, borders, lines, and other properties
as needed.

To quickly learn how to use one of the toolbox buttons, click on the button you're
interested in and press F1. Or click on the Help button on the Form Design or Report
Design toolbar and then click on the toolbox button you want to know more about,

Changing Default Properties for Toolbox Tools

If you find yourself repeatedly changing the same old properties for a certain type of
control, you can alter that control’s default properties.

For the Current Form or Report Only

You can use either of two methods to change the default properties for newly created
controls in the current form or report.
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The hOdge- & Microsoft Access - Form - Figure 1319 Form

podge form from

Figure 13.19 in .
n view.

s vien: Label for the "Fyerything " Form

the toolbar, grid,

and ruler so you

can see the con-
trols more easily.

Custarners subforrn

Page break (not visible in form view)

Here’s one method:

1. Open the propérty sheet (View » Properties) and click on the All tab (or the tab for
whichever group of properties you want to change).

2. Click on the toolbox button for the object whose default properties you want to
change. The title bar of the property sheet will reflect the name of the control you
selected in step 1.

3. Change the properties as needed.

Here’s the other method:

1. Set the properties for the controls that should serve as the model for other controls
of the same type. For example, draw a rectangle and assign it properties that should
be used for other rectangles in the design.

2. Select the control or controls that have the properties you want to copy.

3. Choose Format » Set Control Defaults.
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New controls placed in the design will have the new default properties you set.

To copy the properties from one control to other controls on your design, use the
Format Painter. See “Copying Properties to Other Controls” earlier in this chapter.

For Future Form and Report Designs

Access also offers two ways to use your customized controls and other characteristics of
the current design as defaults for new forms or reports.

The first way is to use your customized form or report design as a template for future
designs. Access uses form and report templates to set up the initial appearance of a design:

e Any time you create a new design without a Wizard.

° Any time you use the AutoForm Wizard (Insert » AutoForm or the equivalent New
Object toolbar button) or AutoReport Wizard (Insert » AutoReport or the equiva-
lent New Object toolbar button) to create a new design.

To specify your current form or report as a template:

1. Set the default controls for the form or report design, as described in the previous
section, and then save the form or report (Ctrl+S).

2. Choose Tools » Options and click on the Forms/Reports tab in the Options dia-
log box.

3. Change the Form Template or Report Template option from Normal (the default
template that comes with Access) to the name of the customized form or report
you want to use for setting default characteristics in new designs.

4. Click on OK.

Access will use the template named in the Forms/Reports tab of the Options dialog
box for new designs that you create without Wizards and for new designs created with
the AutoForm and AutoReport Wizards.

| The Form Template and Report Template settings apply to any database you open

~ or create. If the specified template isn’t in the currently open database, Access will
use the Normal template instead. To use your templates in other databases, import
or export the templates as needed (see Chapter 7).
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The second method is to create a new AutoFormat style or update an existing Auto-
Format style with properties from the current design. You can then use the new or
updated style to restyle the current form or report design or to set the initial appearance
for any new ones you create. See “Customizing AutoFormat Styles” and “Choosing a
Style for Your Design” earlier in this chapter.

Adding Labels

Labels display descriptive information such as titles, captions, or instructions on your
form or report. The text in a label stays the same from record to record.

To create a label, click on the Label toolbox button (shown at left), click where the
upper-left corner of the label should appear or drag an outline to define the label’s loca-
tion and size, and then type the text for the label. Text will wrap automatically within
the label. If you want to force text to a new line as you're typing, press Ctrl+Enter. Press
Enter when you're finished typing the label text.

To customize the label, select the label and then use the property sheet or the For-
matting (Form/Report) toolbar (refer to Figure 13.7) to change the text appearance,
colors, borders, and so forth.

Adding Text Boxes

Text boxes provide a place for you to enter or view text. To create a text box, click on
the Text Box tool (shown at left). Then click where the upper-left corner of the text box
should appear or drag an outline to define the text box location and size. A field label
and unbound text box will appear in your design.

If you want your design to include a field from the underlying table or query, it's
easiest to drag that field name from the field list.

¢ To change the contents of the text box, open the property sheet (View » Prop-
erties), select the text box control (not the label), and then change the Control
Source data property to a field name or expression.

e To change the label text, click in the label and edit the text normally. Or change
the label’s Caption property on the property sheet’s Format tab.
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e To hide the label, select the label and then change the Visible property on the
property sheet’s Format tab to No.

WMM%MMMMMM&LW%
To prevent Access from creating labels when you add text boxes to the current
form or report design, click on the Text Box tool in the toolbox, and then change
the Auto Label property on the property sheet’s Format tab to No.

Adding Option Groups

An option group (shown below) contains a set of related buttons or checkboxes from
which you can select one button or checkbox in form view (option groups are rarely
used on reports). This control is especially useful when only one in a small list of
options is valid and you don’t need to let the user type in a value.

= Form - Eaphic 13.05 : Form ‘

The selected option can be “remembered” so that the form can later decide what to
do next (for example, print labels). Or the selection can be stored in a table field (for
instance, the options could store I in the PaymentMethod field if you choose Master
Card in form view),

To create an option group:

1. Make sure the Control Wizards toolbox button (shown at left) is selected (pushed in).
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2. Click on the Option Group toolbox button (shown at left); then click in the design
or drag an outline where the control should appear. The Option Group Wizard will
take over.

3. Type the labels you want for each option when prompted, pressing Tab or | after
each entry. Each label must be unique. When you’re done typing labels, click on
Next (or press Enter) to continue. You can choose whether to assign an option as
the default selection in new records that you create.

4. Choose No, I Don’t Want A Default or select an option from the drop-down list
next to Yes, The Default Choice Is. Click on Next to continue.

5. Assign a numeric value to each option. Usually you can accept the suggested values.
Each value must be unique. These values can either be stored in a table field or used
in a macro or Visual Basic code to make decisions about what to do next (for exam-
ple, a value of 1 can mean “pay via Master Card”). Click on Next.

6. Choose either of the options described just below when asked what you want
Access to do when you select a value in your option group in form view.

Save The Value For Later Use Uses the value to make decisions in a macro or
other procedure. The value is saved only as long as the form is open in form view.
Store The Value In This Field Stores the value in the table field you choose
from the drop-down list.

7. Click on Next.

8. Choose the options you want when asked what style and type of buttons you want
for the group. The example in the Option Group Wizard dialog box will reflect
your current choices. When you're done, click on Next.
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t's customary in Windows programs to use the default style, Option Buttons, for
* buttons within an option group. This style makes it clear that only one option but-
ton in the group can be selected at a time. However, you also can display the
option group buttons as checkboxes (only one button can be checked at a tnme)
or toggle buttons (only one button can be pushed in at a time).

9. Type a label when asked what label you want for the group and then click on
Finish.

The option group and its label will appear on the design. You can select the option
group or its label and change their appearance with the usual techniques. If you'd like
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to change how an option group behaves, open the property sheet (View » Properties),
click on the Data tab, and then do any of the following:

e To control which field is updated when you make a selection in form view, click
on the frame around the option group and change the field name listed in the
Control Source property. To simply have Access remember the selected value
(updating no fields), delete the field name in the Control Source property.

e To change the option group’s default selection, click on the frame around the
option group and change the Default Value property.

e To change the value assigned to a selection, click on the appropriate option
button, checkbox button, or toggle button in the group; then change the Option
Value property. Make sure all the values assigned to buttons in your option group
are unique.

Chapter 20 dlscusses how to create macros, and Chapter 25 introduces Visual
Basic programming. In Chapter 22 you'll learn about using checkboxes to make
decisions.

Adding Toggle Buttons, Option Buttons, and
Checkboxes

Toggle buttons, option buttons, and checkboxes are simply different spots on the same
leopard. That is, each control provides a button or checkbox that you can either select
or deselect in form view.

Remember from the previous section that option groups are used to select just one
item in a related group of items. By contrast, the individual controls discussed in this
section typically are used to set any number of independent fields to Yes or No. For
example, you can use a checkbox named Tax Exempt to indicate the tax exempt status of
an order, another named Paid to indicate whether an order is paid, and still another named
Filled to indicate whether an order has been filled. Most Windows programs use check-
boxes for these purposes; but Access also lets you use option buttons or toggle buttons.

You can use the Toggle Button, Option Button, or Checkbox tools in the toolbox
to add more options to an existing option group. Access automatically assigns an
Option Value data property to new controls that you add, but you should check

the value to make sure it’s what you want.
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To create one of these controls, click on the appropriate tool in the toolbox and then
click in the design or drag an outline where the control should appear. The Option But-
ton, Checkbox, and Toggle Button tools are shown here:

You can change the Data properties for the button or checkbox as described above
for option group buttons.

Adding Combo Boxes and List Boxes

Combo boxes and list boxes (shown below) let you choose a field’s value from a list.
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Combo boxes (above, at bottom), combine a text box with a drop-down list. The list
stays hidden in form view until you click on the drop-down button next to it. You can
either type a value into the text box or select it from the list. In list boxes (above, at top),
the list is always visible, and the selected option is highlighted.

To create a combo box or list box:

1. Make sure the Control Wizards toolbox button (shown at left) is selected (pushed in).
2. Click on the Combo Box button (left, top) or List Box button (left, bottom) in the tool-

box, as appropriate, and then click in the design or drag an outline where the control
should appear. The Combo Box Wizard or List Box Wizard will take over.
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3. Choose one of these options when asked how you want your box to get its values
and then click on Next:

I Want The Box To Look Up The Values In A Table Or Query Access dis-
plays the list from a table or query you select.

I Will Type In The Values That I Want Access displays the list from values
that you type.

Find A Record On My Form Based On The Value I Selected In My Box  Access
displays the values from fields that are in the form’s underlying table or query
records.

4. Do one of the following, depending on your choice in step 3:

If you chose to look up the values in a table or query, select the table or
query and click on Next. Then select the fields you want to see in the combo
box or list box and click on Next. Continue with step 5.

If you chose to type in the values, type the number of columns to display and
press Tab. Now type in values for each column and row (pressing Tab to
advance to the next column or row). When you're finished entering values,
click on Next. When prompted, choose the column in your combo box or list
box that contains the value you want to either remember or store in the table,
and then click on Next. Skip to step 6.

If you chose to display values from fields on the form, choose the fields on
your form that contain the values you want to see in the combo box or list box
and then click on Next (these fields will become columns in your combo box or
list box). Continue with step 3.

5. Adjust each column in your combo box or list box as instructed on the screen. If
you chose to display values from fields on your form, you can select (check) Hide
Key Column (Recommended) to hide the primary key field in the combo box oz list
box; or deselect (clear) this checkbox to show the primary key field. You also can
rearrange columns as you would in datasheet view (see Chapter 8). Click on Next.

6. If asked what you want Access to do when you select a value in your combo box or
list box in form view, choose either of these options:

Remember The Value For Later Use Uses the value to make decisions in a
macro or other procedure. The value is saved only as long as the form remains
open in form view.

Store That Value In This Field Stores the value in the table field you select
from the drop-down list.

7. Click on Next.
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8. (Optional) Type a label when asked what label you want for the combo box or list box.
9. Click on Finish.

The combo box or list box (and its label) will appear. If you’d like to change the
properties of a combo box or list box, open the property sheet (View » Properties) and
click on the box portion of the control (not the label). Then customize the properties
as explained next.
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You can easily change a combo box to a list box, and vice versa, as explained later
in the section “Presto Change Type.”

The most important properties on the Data tab of the property sheet for a combo
box or list box are

Control Source Specifies which field is updated when you select an item in the
box. To simply have Access remember the selected value, delete the field name in
the Control Source property box.

Row Source Type Specifies where the row data comes from (table or query, list
of values, or list of field names).

Row Source Tells Access how to get data for each row. If you've selected Table/
Query as the Row Source Type and have no idea about how to enter SQL state-
ments for the Row Source, don't despair. Simply click in the Row Source box and
then click on the Build button that appears. Now design (or modify) a query that
will select and display the row data you want. When you're done, choose File »
Close » Yes, or press Ctrl+W and then click on Yes.

Bound Column Specifies which column number supplies data for the Control
Source.

Limit To List Specifies whether to let the user enter values that aren’t shown in
the combo box drop-down list.

Default Value Specifies the default value assigned to the Control Source when
you create a new record in form view.

The most important properties on the Format tab are
Column Count Specifies the number of columns to display in a combo box or
list box.
Column Heads Specifies whether column headings appear in a combo box or
list box.
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Column Widths Specifies the width of each column shown in the box. Column
widths are listed in column order from left to right and separated with a semicolon
(). Set the column width to 0 if you don’t want to display the column.

List Rows Specifies the number of rows to show in a combo box’s drop-down list.
List Width Specifies the width of the drop-down list in a combo box. For exam-
ple, type 2 for a 2”-wide drop-down list. Or type Auto to make the drop-down list
as wide as the text box.

Adding the Current Date and Time

It’s easy to display the current date and time anywhere on a form or report. To do so:

1. Choose Insert » Date And Time.
2. Fill in the Date And Time dialog box that appears (see below).
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3. Click on OK. A new text box will appear in the form header or report header (if one
is visible), or in the detail section. It looks something like this:

{:Format(Dateo,"Long Datem &."" e[

4. Drag the new text box to wherever it should appear in your design.
5. Switch to form view or print preview to see the results.

Presto Change Type

Access offers a time-saving morphing feature that lets you instantly convert one type of
control into any other compatible type. For example, you can convert a list box to a
combo box, or change a checkbox to a toggle button with just a couple of mouse clicks.
Here’s how:

1. Select the control you want to convert to another type.

2. Choose Format » Change To, or right-click on the control and choose Change To.
3. Choose any control type that’s available in the menu that appears.

4. Change the control’s properties as needed.

Adding Lines

You can draw a line anywhere within a section on a form or report design. Click on the
Line toolbox button (shown at left); then click in the design or drag an outline where
the line should appear. To create a perfectly vertical or horizontal line, hold down the
Shift key while you drag.

After creating a line, you can select it and move or resize it as needed. You also can
use the Formatting (Form/Report) toolbar to change the line’s color, thickness, or spe-
cial effects.

Drawing Frames around Controls

The rectangle tool is especially nice for drawing neat frames around any control. To use
it, click on the Rectangle toolbox button (shown at left) and then click in the design or
drag an outline where the rectangle should appear.

If the frame contains a background color, the frame may cover the controls behind
it. That’s easy to fix. Select the frame and then choose Format » Send To Back. If you'd
like to add a background color or other special effect to the frame, select the rectangle
and choose the effects you want from the buttons and colors in the Formatting (Form/
Report) toolbar. Raised, sunken, and etched effects and colored backgrounds look espe-
cially nice.
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Adding Page Breaks

You can add a page break to force a new page on a printed form or report. To do so, clic

on the Page Break toolbox button (shown at left) and then click in the design where yor

want the page to break. (If you no longer want the page to break, select the page break

contro! and press Delete. You also can drag the page break to a new place on the design
Here are some points to remember about page breaks:

e To avoid splitting data across pages, place the page break above or below oth
controls (not in the middie of a control).

e In a form the page break will appear in the printed copy only, not on the scree
(The next section explains how to break forms into multiple screens.)

e To print page breaks before or after a section in the printed form or report, click i
the section where you want the page break, open the property sheet (View
Properties), click on the Format tab, and then change the Force New Page proj
erty from None to Before Section, After Section, or Before & After.

Creating a Multiscreen Form

If you want to create a form in which each page is the same size and each window
shows only one page at a time, follow these steps:

1. Design your form normally.

2. Add a page break wherever you want the form to break, with each page break equ
distant from the previous one. For example, if each detail area should be tw
inches high, put the first page break at 2”, the next one at 4”, and so on. You ca
use the vertical ruler’s guidelines to help you adjust the page break position;
open the property sheet (View » Properties), click on the Format tab, and set tt
Top property for each page break to the measurement you want. (Access will mos
the page break automatically when you change the Top property.)

3. Size the Form Footer so that the top of the form footer section is at a multiple of tt
screen size you've chosen. Continuing with our 2” screen example, if you've place
page breaks at 2” and 4” and the last field is at 5.25”, place the form footer at tt
6" mark on the ruler.

4. Select the form (Edit » Select Form), open the property sheet (View » Properties
and then click on the Format tab. Now set Default View to Single Form; set Au
Resize to Yes; and set Auto Center to Yes.

5. Save and close the form.

To see the results, go to the database window and open the form. If the form is mas
mized, click on the window’s Restore button. Then choose Window » Size To Fit Forn
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Now, to view each screen of your form, press the Page Up and Page Down keys or
click above or below the scroll box in the vertical scroll bar. Pressing Page Up at the top
of the form will take you to the previous recoid; pressing Page Down at the bottom of
the form will take you to the next record.
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Navigating through a multiscreen form may feel somewhat clumsy if you are used
to using Page Up and Page Down to move between records (instead of pages). You
may prefer to use a Tab control instead and place each screen of information on a
separate tabbed page. See “Adding Tab Controls” in this chapter for more infor-
mation on this new Access 97 feature.

Adding Page Numbers to a Printed Form or Report

Access makes it easy to add page numbers to a printed form or report. Here’s how:

1. Choose Insert » Page Number. You'll see the Page Numbers dialog box shown below.

2. Select the format, position, and alignment, and choose whether to show the page
number on the first page.

3. Click on OK.

A text box control similar to the one shown below will appear at the top or bottom
of the page (depending on your choice in step 2).
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Adding Hyperlinks

In Chapter 8 we explained how to use hyperlink fields in a table to jump to other database
objects or documents from a datasheet view or a form. With a hyperlink field in a table, you
can jump to a different address from each record. For example, in the Employee table
of the Order Entry database, you could store the address of each person’s resume in a
hyperlink field.

When you don’t need to jump to a unique information source for each record in a
table, you can use a hyperlink that’s not tied to a hyperlink field. This type of hyperlink
is placed on a form or a report in design view using the same basic techniques described
in Chapter 8 for entering an address in a hyperlink field. In brief, you can

e Use the Hyperlink toolbar button to open the Insert Hyperlink dialog box.

e Copy and paste a hyperlink address from a document or browser window onto
a form or report design.

s Copy and paste selected text to jump to a specific spot in a Microsoft Office file.

e Drag and drop a hyperlink address or text in a Microsoft Office document.

Figure 13.21 shows the Employee form from the Orders Entry database with a hyper-
link address that jumps to the Switchboard form in the same database. The hyperlink
on the form was placed using the Hyperlink toolbar button. For details on using the
Hyperlink tool or the other techniques listed above, check Chapter 8. The only differ-
ence is that you end up placing a label object on the form with a hyperlink address
attached, instead of inserting an address into a field. If this process isn't clear, don’t
worry. We'll step through an example of using the Hyperlink toolbar button to place a
hyperlink on a form a little later.

You can also use a few other techniques to include hyperlinks on a form ot report. You
can use an image object or command button with a hyperlink address attached. (Hypez-

FIGURE 13.21 N
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link Address and Hyperlink SubAddress properties ate available.) When the image or
button is clicked, it jumps to the address specified by the hyperlink address properties.

If you're using a command button for a hyperlink, you don’t have to set the hyper-
link address properties yourself. The Command Button Wizard has a new option in
Access 97 that helps you create a hyperlink button. See the sidebar “Creating a Com-
mand Button Hyperlink” in “Adding Command Buttons” later in this chapter.
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~ If you place a hyperlink in a report, it will not be “hot.” That is, nothing will happen
when you click the hyperlink on the screen. But when you export the report to a
spreadsheet or a document, the hyperlink will be active, enabling you to jump to

the address the hyperlink points to.

R L

Using the Hyperlink Toolbar Button
To add a hyperlink that’s not attached to a field, follow these steps:

1. Open the form or report you want to add a hyperlink to in design view.

2. Click on the Insert Hyperlink toolbar button to open the Insert Hyperlink dialog box.

3. Enter a URL or file name under Link to file or URL:. Use the Browse button, if you
like, to get help from the Link to File dialog box. If you are jumping to an object in
the open database, enter the object’s name in the box under Named location in file
(Optional):. If you have more than one object with the same name, use the Browse
button to make your choice, or precede the object name with the object type as in
Table Employees or Form Employees. Click on OK to return to the design window.
(See Chapter 8 for more information on valid hyperlink addresses and allowable
shortcuts for addresses.)

4. The new hyperlink will appear in the upper-left corner of the form or report design.
Drag it to the desired location.

A hyperlink object placed with the Insert Hyperlink tool is really just a glorified label
object that has its Hyperlink Address property and/or Hyperlink SubAddress property
defined. To check this for yourself (if you're interested!), right-click a selected hyperlink
in the design window and choose Properties from the shortcut menu. Click on the Foz-
mat tab and look for the Hyperlink Address and Hyperlink SubAddress properties. The
hyperlink shown in Figure 13.21 has Form Switchboard as its Hyperlink SubAddress property
and nothing for the Hyperlink Address property. (If the hyperlink pointed to a file other
than the open database, that file name would appear as the Hyperlink Address property.)
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Using an Image for a Hyperlink

Instead of using text such as http://www.microsoft.com or Form Switchboard to sh
hyperlink on a form or report, you can use a picture:

1.
2.

Open the form or report to include the hyperlink in design view.

Place an image object on a form using the Image button in the Toolbox. (See
ing a Picture or Image” later in this chapter for more detailed instructions on
this tool.)

. Right-click the selected image, choose Properties from the shortcut menu, anc

on the Format tab.

. Enter a URL address or file name for the Hyperlink Address property or the

of an object in the current database for the Hyperlink SubAddress property
can use the ... at the end of either property line to open the Edit Hyperlink
box. (Chapter 8 explains the use of this dialog box.)

. Test the image hypetlink by going into form view and clicking the picture

should jump to the hyperlink address you entered in the Properties menu.

Adding Command Buttons

Command buttons perform some action when you click on them in form view.
instance, you can add buttons that navigate through records, save or print recor
open and close forms, print reports, run other programs, and so on. To create a ¢
mand button:

1.

Make sure the Control Wizards toolbox button (shown at left) is selected (push

. Click on the Command Button toolbox button (shown at left); then click :

design or drag an outline where the button should appear. The Command B
Wizard will take over.

. When asked what the button should do, click on an action category (for exe

Record Navigation) in the Categories list, and then click on an action (for examp
To Next Record) in the Actions list. Click on Next to continue. If prompted for
about the action you chose, complete the dialog box, and then click on Next.

. When asked what the button should look like, either choose Text and ent

text that should appear on the button, or choose Picture and then select a pi
(To see all available pictures, select the Show All Pictures checkbox. To select
tom bitmap picture or icon from your hard drive, click on the Browse buttor
then double-click on the file you want to use.) Click on Next to continue.

. When asked what you want to name the button, type a meaningful name anc

click on Finish.
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The command button will appear in your design. To test the button’s action, switch
to form view and click on the button.

On command buttons that show pictures instead of text, it’s a good idea to set the
Status Bar Text and ControlTip Text properties on the Other tab of the command
button’s property sheet. Initially, the ControlTip Text will be set to the name of the

action you chose. See “Adding Help, Menus, and Prompts to Controls” earlier in
the chapter for details.

Adding Tab Controls

Access 97 has a new feature that lets you add your own tab controls to a form. A tab
controlis simply an object with multiple tabbed pages like the Properties menu you are
now familiar with. This control makes it easy to organize a form with many objects into
a less cluttered view of related information. For example, we could use a tab control to
show review and salary data for an employee on its own page of the Employee form,
instead of crowding it in with the basic details like name and address.

Here’s one way to create the tab control shown in Figure 13.22:

1. Add fields for Last Review Date and Salary to the Employees table in the Order
Entry database called Resume.
2. Select the Forms tab and click on New from the Database window.

3. Leave Design View highlighted and select Employees as the table for the new form.
Click on OK.
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FIGURE 13.22
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4. Choose View » Toolbox to show the toolbox, if it’s not visible, Click on the Tab
Control button in the toolbox. Then click and drag on the form to place a tab con-
trol. It will look like this:

5. Change the caption for the first page of the tab control by right-clicking the page
and choosing Properties from the shortcut menu. Enter Basic Info for the Caption
property.

6. Place fields on the page by choosing View » Field List. Then drag each field you
want to show on the first page of the form from the field list box to the tab control.
For Figure 13.22, the Employee ID, First Name, Last Name, Title, and Work Phone
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fields were dragged onto the Basic Info page of the tab control. The fields were then
aligned and spaced using the Format menu commands. The Left properties of the
text objects (the areas that show the field values) were also adjusted to make more
room for the field labels.

7. Right-click on Page 2 of the tab control and choose Properties from the shortcut
menu. Enter Review/Salary for the Caption property.

8. Drag the Last Review Date and Salary fields from the field list to the second page of
the tab control. Change the Left properties for the text objects to a larger number
to make more room for the labels. Align the field with the Format menu command
if you need to. '

Switch to Form View to test the action of the new tab control. Just click on a tab to
switch form pages. Figure 13.23 shows the finished form with the second tab control
page visible.

FIGURE 13.23 |
The Employee
with Review
info form with
the second
page of the tab
control visible.
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Adding Pictures, Sounds, and Other Obijects

Your forms and reports can include pictures, sounds, and other objects. These can be
standalone unbound objects, such as a company logo, or they can be bound objects,
stored in the underlying table or query.

Adding an Unbound Picture or Object

Unbound objects stay the same from record to record. Use them to display such things
as a company logo on a report or form header or to attach a sound file, containing
instructions, to the form header.
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To create an unbound object:

1. Click on the Unbound Object Frame toolbox button (shown at left), and then click
in the design or drag an outline where the control should appear. Oz click in the
section where you want to insert the object and choose Insert » Object. You'll see
an Insert Object dialog box similar to the one shown in Figure 13.24.

2. (Optional) If you want to display the object as an icon, select (check) Display As Icon.

3. Do one of the following:

e To create the object from scratch, choose Create New, select an object type
from the Object Type list, and then click on OK. Create the object in its source
program, and then exit the program as appropriate. (For most programs, you can
choose File » Exit & Return or click on the program window’s Close button or
press Alt+F4. Click on Yes if asked whether you want to update the object.)

¢ To create the object from an existing file, choose Create From File. The Insert
Object dialog box will change to include a Browse button and a Link checkbox.
Type the file name in the File text box or use the Browse button to locate the
file. If you want to link the object so that it changes whenever the original file
changes, select (check) Link. If you want to display the object as an icon, select
(check) Display As Icon. Click on OK.

The object will appear in design view. If you want to be able to edit a picture or play
a sound in form view, open the property sheet (View » Properties), click on the Data
tab, and change the object’s Enabled property to Yes.

FIGURE 13.24 "
The Insert DL
Object
dialog box.
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Your form may scroll faster from record to record If you put the unbound object in
the form header or footer section (not in the detail section).
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If you want to edit the object while you’re in design view, you can double-click on
the object; or right-click on the object and choose (Object » Edit from the shortcut
menu that appears. Or select the object and choose Edit » ...Object » Edit from the
design view menus.

Here’s an even quicker way to put an unbound OLE object into your design. Open
the program you used to create the object (or use the program to create a new object).
Select the object using the program’s usual tools and then copy the data to the Win-
dows Clipboard (choose Edit » Copy or press Ctrl+C to place fields on the page). Close
the program if you wish and switch back to your form or report design. Now click in the
section where the object should appear and paste the object into your design (choose
Edit » Paste or press Ctrl+V).
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If the source program you're copying from supports OLE 2, try the drag-and-drop
method. Right-click on an empty part of the Windows Taskbar and choose Tile Verti-
cally so you can see both the Access window and the window that contains the object
you want to copy. Then Ctrl-drag the selected object from the source program to your
form or report design. The programs in the Microsoft Office and Novell PerfectOffice
suites support OLE 2, and so does the WordPad word processor (which comes with
Windows 95).

Adding a Picture or Image

You also can use an Image control to display unbound pictures and logos on your forms
or reports. Image controls are faster than unbound object controls and are recommended
if you don’t need to change the picture after adding it to the design. To add an image to
your design:

1. Click on the Image toolbox button (shown at left); then click in the design or drag
an outline where the control should appear. Or click in the section where you want
to insert the object and choose Insert » Picture. You’ll see an Insert Picture dialog
box similar to the one shown in Figure 13.25.
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| FIGURE 13.25 | _
The Insert Pic- )
ture dialog box .
after we clicked Clipart
on the Preview
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dialog box.

Insert Picture

2. Locate and double-click on the picture you want to insert. The image will appear
on your design.

S aen e % e
If you want to display a different picture in an Image control, right-click on the con-
trol, choose Properties, click on the Format tab in the property sheet, and then click
in the Picture property box. Next click on the Build button; then locate and double-
click on a file name in the Insert Picture dialog box.

Adding a Background Picture

Suppose you want to add a background to your form or report, such as a picture of
clouds, or a scanned image of a preprinted form or photograph. It’s easy to do if you fol-
low these steps:

1. Select the entire form or report (choose Edit » Select Form or Edit » Select Report).

2, Open the property sheet (View » Properties) and click on the Format tab.

3. Scroll down to and click in the box for the Picture property, and then click on the
Build (...) button that appears.

4. Locate and double-click on the picture you want to use for the background design
when the Insert Picture dialog box appears (refer to Figure 13.25).

5. (Optional) Change the Picture Size Mode, Picture Alignment, and Picture Tiling
properties as needed.
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The picture you selected will appear as a background for the form or report design.
To see the full effect of your new background, switch to form view or print preview.
Later in this chapter, we'll give you some pointers on sizing pictures and setting up
Access forms that look like the preprinted paper forms you may be using now.

To remove the picture background, repeat steps 1 and 2 above, scroll down to and
click in the Picture property box, select and delete the file name text, and then press
Enter. When prompted, click on Yes to delete the picture from the background.

Using Non-Bitmap Pictures

Pictures come in many formats—bitmap ((bmp), Windows Metafile Format (-wmf), and
Tagged Image File Format (.tif)—to name just a few. If you use the Image tool to place
a graphic on a form or report, Access usually can display that image perfectly because
the Image tool can interpret many different picture formats.

However, if you use the Unbound Object Frame tool to put a non-bitmap image into
a form or report design {(or you store the image in an OLE Object table field), you may get
an object package, rather than the original artwork, when you try to view that image.

’ 7 WM@%&&%@M@

Use the Image tool or Picture property to place an |mage nf you won't need to change
the image later. Use the Unbound Obiject Frame tool if you will need to change the
image. The Image tool and Picture property offer the widest variety of displayable
image formats to choose from.

For example, suppose you use the Unbound Object Frame tool in form design view
to place a Windows Metafile object in the Form Header of a form. Instead of seeing the
picture that was contained in the object you placed, you'll see a package icon that looks
like this in form design view (its appearance in form view is similar):

Ea ﬁ
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In design view or datasheet view, you can double-click on the package to view
its contents if an association exists between the package type and a program on

your computer.
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If you prefer to see the actual picture (rather than the object package icon) on your
form or report, you'll need to convert the image to a bitmap (.bmp) file or to some other
graphics format that Access can display.

. To

make that conversion, you can use a graphics conversion program, such as

Hijaak for Windows (published by Quarterdeck Office Systems).

Once you've converted the object to a bitmap file, you can insert it via the Unbound

Ob

ject Frame tool (or the Picture property or Image tool), as explained earlier in this

chapter.

After placing the picture, open the property sheet (View » Properties), click on the
Format tab, and then experiment with the Size Mode or Picture Size Mode property set-
tings—Clip, Stretch, and Zoom—to see which option offers the best fit. See “Controlling
the Size of Pictures,” later in this chapter for more details on customizing the picture size,

If you don’t have a fancy graphics conversion program, try this trick to convert the
graphic fo a .bmp file:

1.

<

Place the graphic into a word processing program (such as WordPerfect for Windows)

using that program’s tools.

. Select the object in the word processing document (usually by clicking on it), and
copy it to the Windows Clipboard (press Ctrl+C).

. Exit your word processing program (if you wish).

. Open Paint. Paste the graphic into Paint (press Ctrl+V) and save the file as usual.

Voila! You've saved the graphic as a bitmap file.

Here are some other things you can do after copying a graphic to the Clipboard in

your word processing program:

L

Switch back to your Access form or report design. Click in the section where the
image should appear and then paste the image (press Ctrl+V or choose Edit »
Paste). Again, the image will appear as a picture in your form or report (though it
will be embedded as a word processing document, rather than a Paint picture).
Double-clicking on the image in design view will take you back to the word pro-
cessing program.

Store the picture in a table as a bound OLE object. Open the table in datasheet
view or form view, click in the appropriate record and OLE Object field, and press
Ctrl+V or choose Edit » Paste to store the embedded picture.
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Coloring the Picture Background

In some cases, the picture background will be white (or some other color). Setting the
Back Color to Transparent won’t help if the white background color is actually a part of
the bitmap image. If you want the background color of the bitmap to match the back-
ground color of your form or report, you'll need to use the Windows Paint applet or
some other graphics program to change the bitmap image’s background color.

If the image is mostly white background, you'll need to crop the image. Use Paint, or
a better graphics program if you have one. In Paint, select the area you want to crop,
and choose Edit » Copy To to copy just the selected area to a file. For more information
on Microsoft Paint, start Paint (Start » Programs » Accessories » Paint) and choose
Help » Help Topics or press F1.

Adding an OLE Object Field

Bound object controls are used to display a picture, chart, or any OLE object that’s stored
in the underlying table or query. Unlike unbound objects, bound objects will change
from record to record. In form view, you can change the bound object by double-clicking
on it (see Chapter 8 for more information on entering data into OLE objects fields).

The easiest way to add an OLE object to your report or form is to drag it from the
field list to your design. The field must be defined in the table as an OLE Object data type.
(You also can use the Bound Object Frame tool to create the object, but it’s not as easy.)

When you first add an OLE object to a form or report design, Access displays its
actual size, clipping it to fit within the object frame if necessary.

Adding ActiveX Controls

Access 97 comes with some special purpose tools called ActiveX controls. (In previous
versions of Access, they were called custom controls or OLE controls.) These controls are
typically used by programmers to add functionality to a form that’s not available through
Access itself. For example, the Microsoft WebBrowser control can be programmed to
open a Web page in the control’s own window. Some ActiveX controls also come with
the Microsoft Access Developer’s Toolkit and are documented there; others are available
from third-party companies or in other Microsoft products such as Visual Basic 4.0.

To insert an ActiveX control into your design:

1. Click in the section where the new control should appear.
2. Click on More Tools in the Toolbox or choose Insert » ActiveX Control to show a
menu of the ActiveX controls that come with Access.
. Select a control from the menu.
4. Right-click the control, choose Properties, and set any properties you may need to
adjust for the control.

(78
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For more information about ActiveX controls, look up ActiveXControls and its sub-
topics in the Access Help Index. You can also check Chapter 16, “Using ActiveX Controls”
in Building Applications with Microsoft Access 97.

Controlling the Size of Pictures

If you're not happy with the way Access sizes a picture or custom control, you can
change the control’s Size Mode (or Picture Size Mode) property:

|
|
|

1. Open the property sheet (View » Properties) and then click on the Format tab.

2. Select the object you want to change or select the entire form (Edit » Select Form)
or report (Edit » Select Report) if you want to change the background picture.

3. Choose one of these options from the Size Mode or Picture Size Mode property’s
drop-down list:

Clip Displays the object at actual size. If the object is larger than the control
frame, Access will clip the image at the borders. Clip is the fastest display method.
Stretch  Sizes the object to fill the control. Stretch may change the object’s
original proportions, especially in circles and photos (bar charts and line charts
should look just fine).

Zoom Sizes the object’s height or width to fill the frame without distortion,
then shows the entire object without clipping.

ey " B BP T S

Remember that if you're working with a picture stored in a table field, the size mode
affects the display of every picture in the table. For example, you can’t assign the Clip
size mode to one record, and the Zoom size mode to another. This is why it’s so
important to size and crop equally all the photos you'll be putting into a table.

The example below shows the same picture with different Size Mode properties
assigned.
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Changing the Front-to-Back Order of Controls

You can create some interesting effects by changing the front-to-back order of controls.
That’s how we added the drop-shadow gray rectangle around the computer example
above and the squares below. We also used the technique to place the white box first in
front of the black one and then behind it in the example shown below.

To change the front-to-back order of controls:

1. Select the control or controls you want to move in front of or behind another

control.
2. Choose Format » Bring To Front or Format » Send To Back, as appropriate.

To use this feature to uncover objects hidden by a newly drawn rectangle, select the
rectangle and choose Format » Send To Back.

Creating Calculated Controls

A calculated control uses an expression as its control source. Calculated controls let you
display values calculated from data in one or more fields, or from other controls. For
example, you can calculate the extended price of an item by multiplying the value in
the quantity field by the value in the unit price field, like this:

=[Quantity]*[UnitPrice]
Access doesn’t store the result of a calculated control in a table; instead, it recom-
putes the value each time the record is displayed. (In form view, calculated controls are

read-only.)
To create a calculated control:

1. Create a control of any type that has a Control Source property on the Data tab of the
property sheet. Typically, you'll use text boxes for this purpose, but combo boxes, list
boxes, unbound and bound object frames, toggle buttons, option buttons, and
checkboxes also work.
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2. Select the control and use one of these methods to enter the expression:

° Type an equal sign (=), followed by the calculation expression, directly into the
box. Example: In a text box, type =[Quantity]*[UnitPrice] to multiply the value
in the Quantity field by the value in the UnitPrice field.

° In the Control Source data property box, type the expression (preceded by an
equal sign).

° In the Control Source data property box, click on the Build (...) button to open
the Expression Builder, Expression Builder handles the messy details of Access
expression syntax while you focus on what you want to do. Choose items in
the dialog box by clicking and double-clicking on entries in the three panels
near the bottom of the dialog box and clicking on operator buttons above the
panels. As you do this, Expression Builder automatically puts in the square
brackets, dots, exclamation points, and other details required. When you're
done using Expression Builder, click on OK.

The top panel in Figure 13.26 shows a finished expression in Expression Builder.
Here are the steps we followed in the Expression Builder dialog box to create that
expression:

1. In the bottom-left panel, we double-clicked on the Functions folder (which is
marked with a plus sign) and then clicked on Built-In Functions.

L FIGURE 13.26 § i

A completed Click on a button to copy Expression appears

expression in its operator to editing panel. in this editing panel.
Expression
Builder.

® Queres
3 Forrmns
& Reports
|3 Functions
7 BuiltIn Functions
(3 Order Processingts

@
%

Double-click on folders Click on an item Double-click on an item
marked with + to open them. to select it. to copy it to editing panel.
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. In the bottom-center panel, we clicked on <All>.

3. In the bottom-right panel, we scrolled down to the Sum function and double-
" clicked on it to copy the function Sum (<expr>) to the editing panel at the top.

4. In the top panel, we clicked on <expr> to select it.

5. In the bottom-lett panel, we clicked on Orders Freight - Figure 13 22 (the name of the

form we were designing).

6. In the bottom-center panel, we clicked on <Field List>.

7. In the bottom-right panel, we double-clicked on FreightCharge to copy that field
name to the editing panel.
We clicked on OK to close the Expression Builder dialog box and copy the expression
into the Control Source property box. (If you don’t type the initial = sign in the
expression, Access will add it automatically when you click in another property box.)
9. We pressed Enter to complete the entry and move the cursor down to the next
property box.

®
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Instead of double-clicking on an item in the bottom-right panel, you can highlight
the item and then click on the Paste button in the dialog box. Either way, Access
will copy the item into the editing panel. '

Keep the following points in mind as you enter calculated controls:

e For checkboxes, option buttons, and option groups, you must change the Control
Source data property. You can’t simply type the expression into the control.

e Chapters 9 and 10 show examples of calculation expressions for filters and que-
ries. To use those examples in a control, simply precede the example with an
equal sign. Table 13.3 offers a few more examples.

e The Expression Builder provides the easiest way to enter functions and to refer-
ence fields in tables, queries, forms, and reports. You also can use it to display
page numbers and dates.

e You can use the Format property on the Format tab of the property sheet (or the
Format function) to display calculated expressions in any format you wish.

For more information about entering expressions into calculated controls, search for
Expressions subtopics in the Access Help Index, or click on the Help button in Expres-
sion Builder.
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EXPRESSION SAMPLE RESULT

=[ShippingMethodID] & “: ” & [ShippingMethod] 1: Federal Express if Shipping-
MethodID is 1 and ShippingMethod
is FederalExpress.

=[Quantity]*[UnitPrice] 350 if Quantity value is 10 and Unit-
Price value is 35.

=[Products Subform].Form![UnitPrice] * 1.15 46 if UnitPrice on a subform named
Products Subform is 40.

="Page ” & [Page] & " of "& [Pages] Page 3 of 5 on page 3 of a five-page
printed report or form.

=Now( ) Systern date and time.

=DatePart(“yyyy” ,Now( )) 1995 (year portion of system date
and time).

=UCase([LastName] & “, “& [FirstName]) STRAPPMAN, HANLEY if LastName is

Strappman (or strappman or STRAPP-
MAN) and FirstName is Hanley (or
hanley or HANLEY).

Note: All expressions must be entered on a single line.

Adding a Subform or Subreport

A subform or subreport is simply a form within a form or a report within a report.
Figures 13.27 and 13.28 show a main form with a subform and a main report with a
subreport, respectively.

In Chapters 11 and 12, you learned how the Form Wizards and Report Wizards can
create main/subforms and main/subreports for you automatically. The same concepts
described in those chapters also apply when you’re creating a main/subform or main/
subreport without a Wizard. Here are the essential facts you need to know:

s Generally you use a subform or subreport when there’s a one-to-many relationship
between the data in the main form or report and the data in the subform or subre-
port. The main form or report is on the “one” side of the relationship, and the
subform or subreport is on the “many” side. Example: A main form based on the
Orders table and a subform based on the Order Details table will show each order
and its related order details.
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You must create and save the subform or subreport before you can use it in a main
form or report.
Each main form or report can contain more than one subform or subreport, and
you can have up to two nested subforms/subreports in a main form or report. (A
nested subform/subreport is one that contains a subform/subreport of its own.)
To display the subform as a datasheet, change the subtorm’s Default View property
on the Format tab to Datasheet. It's usually best to display a subform as a datasheet.
In the main form or report, you can use expressions to refer to values in the sub-
form or subreport. See “Creating Calculated Controls” above. '

Chapter 11 explains how to navigate through main forms and their subforms.
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FIGURE 13.28

A main Orders
report with an

Order Details

subreport. Order Date Order ID
2/1/95 1

Product Name Quantity Unit Price Extended Price

Basketball 2 $4.95 $9.90

Crystal ball 2 $45.56 $91.10

Foosball 4 $17.85 $71.40

Football 2 $5.65 $11.30

Tether ball 5 $9.65 $48.25

&> Totals 15 $231.95

Order Date Order ID

3/14/95 2

Product Name Quantity Unit Price  Extended Price

i Crystal ball 1 $45.55 $45.55
Football 1 $5.65 $5.65

Golf balls 2 $6.75 $13.50

Soccer ball 1 $12.95 $12.95

Tether ball 1 $9.65 $9.65

@& Totals 6 $87.30

Page 1 of 9
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_..Without a Wizard

To add a subform/subreport to a main form or report, without using Wizards:

1. Open your main form or report in design view, and then press F11.
2. Choose Window » Tile Vertically so that you can see both the database window
and the form or report design.
3. Click on the Reports or Forms tab in the database window, as appropriate. (For
example, click on the Forms tab if you're designing a main form.)
4, Drag the icon for the form or report you want to insert from the database window
to your design. Usually, you'll want to put the subform/subreport into the detail
section of your design.

To check or fix the subform/subreport link to the main form or report:

1. Open the property sheet (View » Properties).
2. Click on the Data tab.
3. Click on the Subform/Subreport’s border (not the label).

o The Source Object property shiould show the subform or subreport name.
o The Link Child Fields property should refer to the linking field (or fields) in
the subform or subreport. '
o The Link Master Fields property should refer to the linking field (or fields) in
the main form or report.

_..With a Wizard

You also can use the Subform/Subreport Wizard to add the subform or subreport. This
often is the easiest way to combine a subform or subreport with the main form or report.
Here's how:

1. Start in the design view for the main form or report and make sure the Control
Wizards toolbox button is selected (pushed in).
2. Click on the Subform/Subreport toolbox button (shown at left) and then click in
the design, or drag an outline where the subform or subreport should appear. The
Subform/Subreport Wizard will take over. ~
3. Do one of the following when asked how you want to create your subform or
subreport:

o To create a subform or subreport from existing tables and queries and spec-
ify how to link them, choose Table/ Query and then click on Next. In the next
dialog box, choose fields from as many tables and queries as you wish and then
click on Next.
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e To create the subform or subreport from an existing report or form, choose
Forms (or Reports), choose the appropriate form or report from the drop-down
list, and then click on Next.

As a shortcut, you can press F11 (if necessary) and choose Window » Tile Vertically
to show the form or report design and the database window side by side. Then
click on the Tables or Queries tab in the database window, and drag the table or
query to the place on the design where you want the subform or subreport to
appear. Continue with step 4 below.

4. When asked whether you want to choose fields from a list or to define which fields
link your main form or report to the subform or report, fill in the dialog box
according to the instructions shown and then click on Next.

5. When asked what name you want for your subform or subreport, type a name (or
use the suggested name) and then click on Finish.

6. Use the Data tab on the property sheet to check or fix the link between the main
form/subform or main report/subreport if necessary, as described in step 5 of the
earlier procedure for creating subforms and subreports without Wizards.

You might want to select the subform or subreport in the main form or main report
and then change its Format properties. For example, change the Can Grow and
Can Shrink properties to Yes and change the Border Style property to Transparent.

Showing Fields from Another Table or Query

It’s usually easiest to produce a form or report if the underlying query or table includes all
the fields you want to display. However, you can still show data from other tables or que-
ries even if they're not part of the underlying data. Here are some techniques to use:

¢ Add a subform or subreport, as described just above.

e In forms, base the form on a query that uses dynamic lookup (AutoLookup). See
Chapter 10 for an AutoLookup query example.

e In forms and reports, create a combo box or list box as explained earlier in “Add-
ing Combo Boxes and List Boxes.” (If the field you place on a design is defined as
a lookup field in the underlying table, a combo box or list box will appear
automatically.)
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e Use the DLookup function to display the value of a field that’s not in the record
source for your form or report. For details on this technique, look up DLookup
Function in the Access Help Index. Note that using Dlookup usually isn't as effi-
cient as creating a query that contains the records you want to use and then
basing your form or report on the query.

Putting @ Preprinted Form on the Screen

If data to be entered into your tables will come from a preprinted form, such as a mag-
azine subscription card, you can simplify the transcription process by scanning the
printed form and using it as the background for your Access form so that the two will
look exactly alike.

The whole trick to putting a preprinted form on your screen is to first scan the pre-
printed form to get an electronic bitmap image of it. Next use that bitmap image as the
background picture for the form. Finally, align controls from the underlying table or
query with prompts on the preprinted forms. The following sections explain each step
in detail.

~ See ”Speaal Techmques for Sizing Photographs” in Chapter 8 for tips on snzmg
~ and storing photographs in OLE Object fields.

R fw%ww?wzmwﬁ%wmmwww@%mﬁ i

Step 1: Scan the Pre-Printed Form

You can scan the preprinted form into a file. If you don’t have a scanner, contact a local
print shop, desktop publishing, or electronic prepress service bureau to see if they can
scan the form for you. Be sure to size and crop the form to ensure that it will fit nicely on
the screen. Figure 13.29 shows an example in which we’ve scanned a subscription form
from a magazine, using the scanning software that came with an HP ScanJet Ilc scanner.

Save the scanned image to a bitmap file with a name that will be easy to remember
later. We named ours MSJ.bmp. (Be sure to remember which folder contains the file so
you'll know where to look for it later.)
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FIGURE 13.29 -

A sample sub- »
scription form E
scanned and
cropped in the
scanning soft-
ware for the HP
Scanjet lic
scanner.

Step 2: Create the Table

If you haven’t already done so, create a table that will store data from the form. When
creating the table, include at least one field per “blank” on the fill-in-the-blank form.
Figure 13.30 showsthe table we created to hold data from a preprinted subscription
form. After creating the table structure, close and save the table normally.

'I" I’ B &
If you plan to query the data from the forms, or use the data to create form letters
and other reports, be sure to break the name and address data into several fields
(see Chapter 6).

Step 3: Create a Simple Form
Create an instant form as the starting point for your custom form. Here’s how:

1. Click on the name of the table that will hold the data (MS] in our example) in the
Access database window.

2. Click on the drop-down button next to the New Object toolbar button and then
choose AutoForm, or choose Insert » AutoForm. Access will create the form.

3. Choose File » Close » Yes and save the form in the usual manner. (We named our
form MSJ Form.)
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The structure of
a sample table

named MSj to ; ) Uni
from : Yes/No Subscribed far one year
hOId d(]tG' tion T Twoears Yes/Mo kSubscribed for bwo years )
a SUbS(‘j”p || CheckEnclosed YesMo Check was enclosed with order
form. This table | Hnwoice Tesito Gend the subserber an invoige
ture : YesiNa VES if subscribier paying with American Erpress
struc ! et ! et
| MasteCard Yes/Mo YES if subsoriber paying with Master Card
reflects the | visa Yes/Mo YES if subscriber paying with isa card
structure of Tent - Acoount number on credit card
[ : ) | Date/Time {Expiration date on credit card
the or/gmal i Tent | Subscriber's nams
SCGI’H’)@d form. Test  Subscribers address

Tent ) - Subscriber's ciy, state, and zip code

Step 4: Put the Printed Form on the Screen

Next, put the scanned image of the printed form onto the AutoForm you created. You
can use the form’s various Picture properties to do so. Starting in design view, here are
the steps to follow:

1. Open the AutoForm you created earlier (for example, MSJ Form). '

2. Open the property sheet (View » Properties) and then click on the Format tab.

3. Choose Edit » Select Form to select the entire form.

4. Scroll down to and click on the Picture property in the property sheet; then click
on the Build button for that property. '

5. Locate and double-click on the name of your scanned image. In our example we
chose MSJ.bmp as the picture.
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Step 5: Size and Position the Controls

The last step is to drag each control into position and delete the labels. Figure 13.32
shows an example in which we’ve positioned controls and removed their labels (except
for the OneYear label). Then we switched to form view and typed some sample data.

our sample MS|
Form with data
for one record
typed in. We
need only
delete the
OneYear label
on the form to
make it look
just like the 2 i o
prepr inted form ot pres v MastertCurd Lhvisa
we scanned in 432-12345678-9012 Exp, e
originally. : ,

Andy Adarns
123A 5t

iega, C& 52123

CityiStateldip
Y

Printing a Report from the Form

If you want to print reports similar to the forms you use for data entry, follow these steps:

1. Open the form in form view or form design view. Or go to the database window,
click on the Forms tab, and then click on the form you want to print.

2. (Optional) If you want to view the report before printing it, choose File » Print
Preview and preview to your heart’s content.

3. Choose File » Print, select any options you need from the Print dialog box, and then
click on OK. Access will print the form image along with the data from the table.

If you're printing on preprinted blank forms, rather than on blank paper, you may
want to hide the image on the report background by printing the data only. To do so,
go to the Print dialog box (step 3 above), click on the Setup button, select (check) Print
Data Only, and then click on OK. Choose other options in the Print dialog box as needed
and then click on OK again.
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Saving the Form as a Report

You also can save the form as a report. To do so, return to the database window, click
on the Forms tab, and then right-click on the form you want to save as a report. From
the shortcut menu, choose Save As Report, type a name for the report (for example MSJ
Report), and then click on OK. You can then print the report or change the design as
you would any normal report.

One Page per Form, Please

Here's an easy way to ensure that each report is printed on a new page:

1. Open the form or report in design view.

2. Click on the band across the top of the Detail section.

3. Open the property sheet (View » Properties) and then click on the Format tab.
4. Change the Force New Page property to After Section.

5. Close and save the form or report (File » Close » Yes).

Then print the report normally, as convenient.

Form Letters, Mailing Labels, Etc.

Even though you're using a preprinted form to store and retrieve data, those data are
stored in a plain old Access table. So feel free to design reports for form letters, enve-

lopes, mailing labels, a customer directory—whatever—from that table. Or if you have
Microsoft Word 97 for Windows 95 (either separately or as part of the Microsoft Office
suite), you can export data to Word. Start in the database window:

1. Highlight the name of the table or query that will supply the data in the database
window (MS] in our example).

2. Click on the drop-down list next to the OfficeLinks toolbar button, and then click
on the Merge It with MS Word button (or choose Tools » Office-Links » Merge It
with MS Word from the menus). This activates the Microsoft Word Mail Merge
Wizard.

3. Choose either Link Your Data To An Existing Microsoft Word Document or Create
A New Document And Then Link The Data To It.

4. Click on OK.

5. (Optional) If you chose to link to an existing Word document, select the document
in the dialog box that appears and click on Open.

6. Microsoft Word will start automatically and will display either an existing Word
document or a new blank document, depending on your choice in step 3.
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7. Insert merge fields from the table into your Word document (using the Insert
Merge Field toolbar button), edit the document text, and use any other features
offered in Word.

8. Prepare to merge the Word document with the data in your Access table by clicking
on the Mail Merge Helper toolbar button or choosing Tools » Mail Merge. Then
click on Merge. Fill in the dialog box that appears and click on Merge once more.

9. Choose File » Exit when you're done using Word. When asked whether to save your

documents, save (at least) your mail merge main document. You'll be returned to

Access.

After saving your mail merge main document in Word, you can return to Word at any
time, open that document, and perform the merge again (starting with step 8 above).
Any changes you've made to your Access data will be reflected in the merged output.

For help on using mail merge, search for Mail Merge in Word’s Help Index. Chapters 4
and 7 of this book also provide information about using other Microsoft Office programs
with your Access data.

First Rid for Designing Forms and Repors

Designing perfect forms and reports usually involves some trial and error. This section
describes some common problems and how to solve them.

Grid dots are invisible Turn on the grid (View » Grid). If the dots are still invisi-
ble, select the report or form (choose Edit » Select Form or Edit » Select Report, or
click on the square where the vertical and horizontal rulers intersect), open the
property sheet (View » Properties), click on the Format tab, and change the Grid X
and Grid Y properties to 24 or less.

The property sheet blanks out unexpectedly when you click on a control that’s
already selected Press Enter if you want to keep any changes that you've typed
into the control, or press Esc if you don’t mind losing the changes you’'ve typed.
You can't size the form/report background properly Some control or line prob-
ably is in the way. Try turning off the grid lines, setting the form or report
background to white, and maximizing the window so you can see all the controls
more easily. Move or resize controls as needed (be sure to look for controls at the
edges of the report or form). Resize the background again.

The margins are too large Choose File » Page Setup, reduce the settings on the
Margins tab, and click on OK.
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You need to put more on each page Reduce the margins, increase the back
ground dimensions, resize controls smaller, and move controls closer together tc
make room.

Blank pages appear in printed reports This will happen if the width of the
report plus the left and right margins exceed the width of the page. Try some
combination of the following: Reduce the margins in page setup (File » Page
Setup), resize controls smaller and move them closer together, and reduce the
report background width.

You don’t want detail records in a subtotals/totals report Open the property
sheet, click on the Format tab, click in the report’s Detail section, and change the
Visible property to No.

Report shows duplicate values Use the Sorting And Grouping feature; or select
the control that shouldn’t show duplicate values, open the property sheet, click
on the Format tab, and change the Hide Duplicates property to Yes. See “Iiding
Duplicate Data in a Report” earlier in this chapter.

Form or report shows duplicate records Base the form on a query whose
Unique Values property is set to Yes (see Chapter 10). Or create a “unique values”
query for the Record Source on the fly as described earlier in “Specifying the
Record Source on the Fly.” '
Your records aren’t sorted the way you want them Base the form or report on
a table or query that’s sorted the way you want it. Or create a query for the Record
Source on the fly as described earlier in “Specifying the Record Source on the Fly.”
Or if you're designing a report, use the Sorting And Grouping features described
earlier under “Grouping Data in Reports.”

Your form or report is using the wrong table or query Specify a new Record
Source as described under “Specifying the Record Source on the Fly.”

#Name? appears in a field in form view, print preview, or the printed
report  You've probably changed the Record Source for your form or report, and
now some controls are invalid. Fither delete the bad controls or change their Control
Source data property to a field or expression that reflects the current record source.
This problem also can occur if the Control Source is misspelled or if the field in the
underlying table or query no longer exists. _

#Num! appears in a field in form view, print preview, or the printed report This
message appears in a control that contains a calculation expression in which the divi-
sor evaluates to zero (computers hate it when you try to divide by zero). For instance,
#Num! will appear if [GrandTotal_Qty] in this expression evaluates to zero:

= [Tota1_Qty]/[GrandTota]_Qty]
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To solve the problem, test for a zero divisor. For instance, change the simple
expression above to the more robust expression shown here:

=11f([GrandTotal Qty]>0,[Total Qtyl/
[GrandTotal_Qty],0)

The above IIF function translates to “If the grand total quantity is greater than
zero, display the total quantity divided by the grand total quantity. Otherwise,
display zero.”

#Error appears in a field in form view, print preview, or the printed
report You've probably entered an incorrect expression into a calculated field, or
you're using a circular reference to a control (for example, in a control named
MyCalc, you've entered an expression such as =/Numl[*[Num2J+[MyCalc]). Switch to
design view and correct the expression.

You want to create or print a report from a form This is easy. Right-click on
the form in the database window and choose Save As Report. Then type a new
name for the report and click on OK. If you just want to print the form as a report,
open the form in design view or form view, and then choose File » Print Preview.
You want to create a form from a report This isn’t so easy. Your best bet is to
create the form from scratch or to use a Form Wizard that produces a form similar
to the original report. You also can select controls from various sections of the
report design, copy them to the Windows Clipboard, and then paste them into
the form design.

For more troubleshooting advice, look up Troubleshooting Forms and Troubleshooting
Reports in the Access Help Index.

Where fo 6o from Here

In this chapter, you've learned just about anything anyone could ever need to know
about creating and customizing forms and reports. If you'd like to learn how to create
charts and PivotTables, continue with Chapter 14 now. Or if charts and PivotTables
aren’t your top priority, go ahead and explore topics in Part Three or Part Four..
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Creating Charts and Pivot Tables

ccess offers many ways to analyze and

summarize your data graphically with

line charts, pie charts, bar charts, and

other types of business charts. Charts can display numerical data in a compact, visual for-

mat that's easy to understand. They also can uncover trends and relationships that might
otherwise go unnoticed.

PivotTables offer another way to summarize data. But instead of showing your data
as a picture (the way charts do), PivotTables present the data in a tabular layout that
you can change (pivot) dynamically.

In this chapter, we'll first show you how to create charts in forms and reports. Then
we’ll show you how to set up PivotTables. In no time, you'll be able to set up dazzling
business charts and information-packed PivotTables with just a few mouse clicks.

Plenty of online help supplements the basic techniques presented in this chapter.
For details on charting, look up Charts (or Graphs) and then explore the related subtopics
in the Access Help index. You also can use the extensive online help that’s available from
the Help menu in Microsoft Graph.
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For help with PivotTables, look up the PivotTables subtopics in both the Microsoft
Access and the Microsoft Excel Help indexes.
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~ Before reading this chapter, you should know how to create, save, and use expres-

'~ sions in queries (Chapters 9 and 10), and you should know how to create forms and
reports (Chapters 11 through 13).

Charfing Your Data

Charting takes a bit of trial and error to bring out the best in your data. But it will be eas-
fer if you know some basic charting terminology.

We can divide charts into two general categories of charts: 2-D (two dimensional)
and 3-D (three dimensional). To help you get your bearings, Figure 14.1 shows a typical
2-D column chart, and Figure 14.2 shows a sample 3-D column chart of the same data.
Both figures are labeled to indicate the chart’s many body parts. As yow'll discover later
in the chapter, you can use Microsoft Graph to customize any of the labeled areas to
your heart’s content.

_FIGURE 14.1 -

A typical 2-D Value (y) axis Chart title Gridline Legend
column chart
labeled with
the names of Sales by Employee
areas you can
customize. 140000 ’
120000 - ]
100000 ’»’—
“ 30000 - -
g
& 0000 | -
40000 - L
20000 -
"
Buchanan Callahan Davolia Dodsworth ulter
Employee | ast Hame -“l
Data marker Tick mark Axis title Category (x) axis

Tick mark label
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A typical 3-D Wall
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with the addi- Sales by Employee
tional parts
that won't Value (z) axis —— 140000
appear on a
2-D chart.
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#1996
01997

Series (y) axis
Buchanan
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Floor Category (x) axis
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Throughout this chapter we've used data from the Northwind sample database
* that comes with Access. Chapter 1 of this book explains how to open this database.

The most important elements of a chart are described below:

Axes The horizontal (x) and vertical (y) lines that establish the range of values plot-
ted on the chart. Normally the x-axis categorizes the data and the y-axis measures the
values. This is true for most charts, except pie charts and doughnuts (which have no
axes) and bar charts (where the x- and y-axes are reversed). 3-D charts also have an
imaginary z-axis (or value axis) projecting outward from the chart.

Series A group of related data points from a single field that you plot, usually
against the vertical axis. In charts, a data series appears as a line or a set of bars,
columns, or other markers (depending on the chart type). You can plot several
series in a chart.

Titles Text that appears at the top of the chart and along the axes.

Gridlines Lines that extend across the tick marks on an axis across the area
you're plotting.

Tick marks Small marks along an axis that divide it into segments of equal length.
These make the chart easier to read and indicate the scale.
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Labels These appear at each tick mark to identify values on the axis. You also
can label each data value.

Scale The scale defines the range of values on the axes and the increments used
to divide the axes by tick marks.

Slice In a pie chart, each slice represents a single charted value (glance ahead to
Figure 14.4).

Choosing the Data You Want to Chart

The main trick to charting your data is to decide exactly which data to chart. Once you've
done that, the Chart Wizard will lead you through the steps necessary to describe fow to
chart that data.

If all the fields to be charted are in a single table, you can just base the chart on that
table. However, if you want to chart fields from two Or more separate tables, or you
want to chart the results of calculations on table fields, you'll need to create a query to
join those tables or perform those calculations, and then base the chart on that query,

When designing the query, be sure to include the following fields in the QBE grid:

Include at least one field for categorizing the data. Typically the category fields
will appear on the chart’s horizontal (x) axis. For instance, if you're charting sales
by product category, include the CategoryName field. If you're charting salesper-
son performance, put EmployeelD or LastName in the QBE grid. You can include
more than one category field if necessary. Thus to chart sales by product category
and by month, you'd include the CategoryName field and a date/time field (such
as OrderDate) in the QBE grid.

Include the field, or a calculated field, that you want to total, average, or
count. This field usually appears on the chart’s vertical axis. This field should be a
numeric or currency value (such as extended price or quantity sold) that Access
can total, average, or count and plot on the chart, or another type of field that
Access can count. You can chart more than one field.

Charts can be based on a table, Select query, Crosstab query, or Totals query. You
can chart up to six fields of any data type except Memo or OLE Object. (In fact,

the Chart Wizard won’t even show Memo and OLE Object fields in dialog boxes
that let you choose fields.)

When you've finished creating the query, you should save it (File » Save) and close it (if
you wish). Remember that only the design will be saved. So as the data changes in the table
in the future, any charts that you’ve based on that query will change automatically to
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reflect the latest data in the table. (See “Freezing the Data in Your Chart” later in this chap-
ter for two ways to prevent this updating.)

Figure 14.3 shows an example in which we’ve joined several tables from the North-
wind database in a query (note the join lines). Here we’ve included oniy two fields in
the QBE grid:

CategoryName We want to chart total orders by product category, so we've
included this column in the QBE grid.

ExtendedPrice The second column contains an expression named Extended-
Price, which calculates the numeric values (Quantity times UnitPrice) to be
summed and charted.

Figure 14.4 shows a pie chart that’s based on the query shown in Figure 14.3. Each
pie slice shows total sales within one product category.

Now suppose you want to chart total sales by employees, and you want to break sales
down by the order date. You could start with a QBE grid similar to the one shown in
Figure 14.5.

When the query or table being charted includes a date/time field such as Order-
Date, the Chart Wizard will let you group the date/time data. Therefore, you often
don’t need to group the data in the query. However, if your chart will contain too
much data along the x-axis or in pie slices, and the Chart Wizard doesn’t offer any
way to group that data, it's best to specify criteria in your query. In Figure 14.5, for
example, we used criteria in the query to limit employee names shown on the

x-axis to last names that start with letters in the first part of the alphabet.

The QBE grid in
this query
includes two
fields, Category- , )
Name and OrdealD ~ CategorD

Quew < Figure 1#0 “Select .l]ery e

*

. ! CustomeriD ] : - CategoryName
ExtendedPrice EmplayeslD | | Desoription
(a calculated A DrderDate A Quantity : Picture

field).

ExtendedPncé: [3 Lianllty]' [Qrder DetailsJ{UnitPrice]
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FIGURE 14.4

A pie chart
based on the
query shown in
Figure 14.3.
Each slice of the
pie represents
the total sales
in one product
category. We
used Microsoft
Graph 5.0,
described later,
to customize
this chart.
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The sample chart back in Figure 14.1 shows one possible chart type and format for
this data. In that example, the y-axis shows total sales amounts (labeled in the axis as
Sales $). The x-axis shows employee LastNames (labeled as Employee Last Name). Fach
column (data marker) represents the total sales for a particular employee and for the
years 1995, 1996, and 1997. The legend explains which year each column represents.
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To create the example back in Figure 14.2, we used the same query as for Figure 14.1, but
we displayed it in a 3-D column chart. Notice how this chart shows the employee’s Last-
Name on the x-axis and the year (from the OrderDate field) on the y-axis; it uses a third z-
axis for the values. e

For both charts, we responded to questions from the Chart Wizard in the same way.
That is, we chose to chart the OrderDate, LastName, and Sales fields; we grouped the
OrderDate values by year; and we summed the Sales field. When the Chart Wizard
asked what type of chart we wanted, we chose a 2-D column chart for Figure 14.1 and
a 3-D column chart for Figure 14.2. The Chart Wizard figured out how to arrange the
data on the chart automatically. Later, we used Microsoft Graph to customize each
chart further.

Notice that in both Figures 14.1 and 14.2, we're charting just the extended price
([Quantity]*[UnitPrice]). To include discounts, shipping charges, and/or sales tax in the
chart, we’d need to create the appropriate expressions and totaling queries (see Chapter 10
for examples).

About Freestanding and Embedded Charts

Once you've decided which fields to include on the chart and you've created and saved
the appropriate query, you must decide how you want to display the chart. You can dis-
play charts as either freestanding charts ot embedded charts.

Freestanding Charts

Freestanding charts (vefer to Figures 14.1, 14.2, and 14.4) are forms or reports that display
only a chart. Like the proverbial cheese, the freestanding chart is meant to stand alone by
showing overall results. For example, you can use a freestanding chart to sum total sales
by category, to count customers in each state, or to show average sales by employee by
month or year. Although a freestanding chart is still considered an “embedded” object, it
isn’t used as part of a larger report or form. To create a freestanding chart, you start from the
database window, rather than from form or report design view. See “Creating a Freestand-
ing Chart” for more details.

Embedded Charts

Embedded charts are part of a larger form or report. Embedded charts can be linked to
the underlying table or query, so they change to reflect values that relate to the cur-

rently displayed record (see Figures 14.7 and 14.8 later in the chapter). Or they can be
untinked, so they do not change as you scroll from record to record (see Figure 14.6).
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FIGURE 14.6

An unlinked
embedded
chart is the
same in each
record or printed
report. Here the
chart displays
1997 sales for
every product
category. As
usual, we've
customized the
chart for
dramatic effect.
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To embed a chart within a form or report, you start from the form design window or
report design window and use the Chart toolbox button or the Insert » Chart command.
When creating an embedded chart, you can embed the chart in either of two ways:

® Asan unlinked chart, which doesn’t change from record to record.
° As a linked chart, which does change from record to record.

Use an unlinked embedded chart when you want to display multiple copies of the
same chart. For instance, Figure 14.6 shows two forms, each for a different product cat-
egory and each showing a copy of the same chart of 1997 sales in all product categories.

Use a linked embedded chart when you want the chart to change from record to record.
For instance, by linking a chart of 1997 sales figures to a form that shows data from a Cat-
egories table, you can display sales results for just the category whose data you're viewing
at the moment, as shown in Figure 14.7.

When you scroll to another record, the same chart shows the sales performance of
that category only, as shown in Figure 14.8.
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For the charts shown in Figures 14.6, 14.7, and 14.8, we used this query:

Ekpﬂ ; Format([DrderD ate],"ywyy

Whera

[}

1337

Creating a Freestanding Chart

Assuming you’ve already created and saved the query (or table) on which you want to
base the chart, start in the database window and follow these steps to create a freestand-
ing chart:

1. Click on the drop-down list next to the New Object toolbar button (second-to-last
item on the toolbar) and then choose either Form or Report. Or choose Insert »
Form or Insert » Report from the database window’s menu bar. Or click on the
database window’s Forms or Reports tab and then click on the New button. The
New Form or New Report dialog box appears.

2. Select the table or query on which you want to base the form from the drop-down
list in the dialog box.

'rl‘P‘W&W&WMW%W%WW%%W&WWMM&@WMA','j 2 e r’"4 7

As a shortcut to steps 1 and 2 above, you can start from the database wmdow, click
on the Tables or Queries tab, and highlight the table or query you want to chart.
Or start from an open table or query. Then use the New Object toolbar button or
Insert menu options, as described in step 1.
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. Click on the Chart Wizard option in the list and then click on OK; or double-click

on Chart Wizard.

. When asked which fields contain the data you want for your chart, choose up to

six fields and then click on Next to continue.

When asked what type of chart you'd like, click on the button that represents the
appropriate chart type. The Chart Wizard dialog box will describe the selected type
in more detail (see Figure 14.9). Click on Next to continue.

. When asked how you want to lay out the data in your chart, follow the guidelines

below to place fields on the chart and to summarize and group number and date/
time fields as needed. As you make changes, the sample chart will reflect your cur-
rent selections (see Figure 14.10). Click on Next when you're ready to continue.

o To put data on the chart, drag and drop field buttons onto the appropriate
places in the sample chart.
To summarize number data on the chart, double-click on a number field in
the chart. A Summarize dialog box will open (see Figure 14.11). Click on a
Summarize option and then click on OK.
To group date/time data and limit it to a range, double-click on a date/time
field in the chart. A Group dialog box will open (see Figure 14.12). Choose how
you want to group the date/time field (by Year, Quarter, Month, Week, Day,
Hour, or Minute). If you want to chart a limited range of date/time values,
select (check) the Use Data Between option, and fill in the starting and ending
values you want to include. Click on OK when you’re done choosing options.

FIGURE 14.9
Use this Chart
Wizard dialog

box to choose a
chart type.

d Chart Wizard
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Use this Chart
Wizard dialog
box to place
fields on the
chart axes and
to group or
summarize
date/time and
number fields.

Use the Summa-
rize dialog box
to choose how

you want to
summarize
numeric data.

B Summarize

 FIGURE 14.12 |

Use the Group
dialog box to
choose how to
group a date/
time field and
to specify the
range of dates
to include in
the chart.
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m the chart, drag the appropriate button off the chart.

o To remove fields fro
The word Series, Data, or Axis will appear in the empty spot.

o To preview the chart in Microsoft Graph, click on the Preview Chart button
near the upper-left corner of the dialog box. When you're done previewing,
click on the Close button in the Sample Preview dialog box that appears.

7. When the last Chart Wizard dialog box appears, specify a title for your chart,
choose whether to display a legend, and select other options as needed. Then click

on Finish and wait for the Wizard to do its job.

The finished chart will appear in form view, print preview, or design view, depend-

ing on your choice in step 7.

Using the Freestanding Chart

art you create will be stored in a form or report. SO
you can switch back to design
print the chart with

Remember that any freestanding ch
when the chart is open in form view or print preview,
view as usual. When you're in form view or print preview, you can
File » Print (or Ctrl+P). We'll explain how to customize the chart in design view later
in this chapter.

You can close and save the chart with the usual File » Close » Yes commands. To
he Forms or Reports tab in the database window, and then
the appropriate form or report. The chart will show current
” table or converted it to an image, as described

reopen the chart, click on t
double-click on the name of
data (unless you based it on a “frozen
later in this chapter).

Creating an Embedded Chart

To create an embedded chart of either type, follow this basic procedure:

1. (Optional) Add the Chart button to the form design or report design toolbox, as
explained shortly. You need to do this only once.
2. Create and save the form or report you'll be placing the chart in. Be sur

enough room for the chart.
3. (Optional) Create a query for the chart if you need to base the chart on a query.

4. Open, in design view, the form or report you created in step 2 and use the Chart
button in the toolbox or the Insert » Chart command on the menus to create and

embed the chart.

e to leave

Let’s look at each step more closely.
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Adding the Chart Tool to the Toolbox

There are two ways to create embedded charts:

e Use the Insert » Chart command on the form design or report design menus.
o Use the Chart button in the toolbox.

Although the Insert » Chart command always appears on the design view menus,
the Chart toolbox button isn’t available initially. This button is easy enough to add:

1. Open any form or report in design view. For instance, click on the Forms tab in the
database window, click on any form name, and then click on the Design button.

2. Make sure the toolbox is visible (View » Toolbox).

3. Display the toolbox as a floating palette (see Figure 14.13) for maximum flexibility.
If the toolbox is docked at an edge of the design window, you can change the tool-
box to a palette by moving the mouse pointer to an empty place near one of the
toolbox buttons and double-clicking on that empty spot.

4. Right-click on the toolbox and choose Customize from the shortcut menu. The
Customize Toolbars dialog box appears.

FIGURE 14.13 N

The form design
window after we
changed the
toolbox to a
floating palette,
right-clicked on
the Toolbox,
chose Custom-
ize, selected the
Commands tab,

and then ) |re
clicked on Tool- : [Table Design
box in the Query Design

iForm{Report Design

Categories list.

Drag from here... . To here.
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. Select the Commands tab and click on Toolbox in the Categories list (see Figure 14.13).

. Scroll down the list under Commands until the Chart button is visible. Then move
your mouse pointer to the Chart button (see Figure 14.13) and drag that button on
top of any button in the toolbox or to an empty spot in the toolbox.

. Reposition the Chart button within the toolbox by dragging it to a new spot if you
wish. (If you decide to remove the Chart button, simply drag it off the toolbox.)

. Click on the Close button in the Customize dialog box when you're finished cus-
tomizing the toolbox.

The Chart button will be available in the toolbox anytime you design a form or report.

For more information about creating and customizing toolbars (and the toolbox),
see Chapter 23. Or look up Toolbar Buttons, Adding in the Access Help Index and then
double-click on one of the subtopics that appears.

Creating the Report or Form

You can use standard techniques to create the form or report that will contain the chart,
based on whatever table (or query) you wish. Just be sure to leave enough room for the
chart that you’ll be embedding later.

Figure 14.14 shows a sample form, in form view, that's based on the Employees table
in the Northwind sample database. This form includes the EmployeelD, HireDate, First-
Name, LastName, and Photo fields from the table. We've left empty space in the form
for the embedded chart.

FIGURE 14.14

A sample form,
in form view,
based on the

Employees table
in the North-

wind database

that comes
with Access.
We've left
empty space
for the chart
we'll be embed-
ding later.

The EmployeelD field uniquely identifies each employee.

85 Employees
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When you've finished designing the initial form or report, you should save it; then
close or minimize the form or report to get it out of the way while you create the query
for your chart.

Creating the Query for the Embedded Chart

When creating a query for an embedded chart, you can follow the guidelines described
earlier under “Choosing the Data You Want to Chart.” However, if you want the chart
to change on a record-by-record basis, you also must include the field that links the
chart to the report or form, since this field will tell the chart which data to display.

For instance, when creating a chart of total sales to embed on the form shown in
Figure 14.14, you must include the field that links the data from that query to the
Employees table. In this example, the EmployeelD field in the Orders table identifies
which employee sold each order. Therefore, the underlying query must include that
EmployeelD field, as shown in Figure 14.15.

If you don’t want the chart to change on a record-by-record basis, you won’t need to
provide a linking field. But you still must set up a query if the chart will plot the results
of calculations on table fields or if the chart is based on fields that come from more
than one table.

Once you've created the query for the chart, you can close and save it (File »
Close » Yes).

FIGURE 14.15
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identifies which employee sold each order.
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Embedding the Chart

Now that you’ve created a report ot form to hold the chart, and a query upon which to
base the chart, you can embed a chart into the report or form. The steps fo’r‘creating an
embedded chart are nearly identical to those for setting up a freestanding chart. The
main differences are that you use the Chart toolbox button or the Insert > Chart
command to get started and you must decide whether to link the chart to the form or
report. Here are the steps:

1. Open the form or report you want to embed the chart into, in design view. If you
plan to use the Chart toolbox button and the toolbox is hidden, choose View »
Toolbox or click on the Toolbox toolbar button to display it.

2. Click on the Chart toolbox button (shown at left). Or choose Insert » Chart from
the menu bar.

3. Click on the place on the form or report design where the upper-left corner of the
chart should appear or drag to define the size of the chart.

The Chart Wizard takes over.

4. When asked where you want your chart to get its data, select Tables, Queries, or Both
from the bottom of the dialog box. Then highlight the table or query that contains the
data and click on Next, or just double-click on the table or query you want to use.

. When asked which fields contain the data you want for the chart, double-click on
those fields (or click on the >> button to copy all the available fields). You can
choose up to six fields. Click on Next to continue.

. When asked what type of chart you would like, click on the chart type you want to
use, and then click on Next.

. When asked how you want to lay out the data in your chart, follow the guidelines
given in step 6 of “Creating a Freestanding Chart” earlier in this chapter to place
fields on the chart and to summarize and group number and date/time fields as
needed. As you make changes, the sample chart will reflect your current selections
(see Figure 14.10). To produce the finished example shown in Figure 14.17, we chose
not to show the EmployeelD, to show the OrderDate along the x-axis, to group
orders by year, and to limit the chart to OrderDates between 1/1/95 and 12/31/97.
Click on Next when you're ready to continue.

The next Chart Wizard dialog box, shown in Figure 14.16, lets you choose whether
the chart should change from record to record.

8. Do one of the following and then click on the Next button to continue.

e To link the chart and the form so that the chart changes from record to record,
choose the appropriate linking fields from the Form Fields and Chart Fields
drop-down lists, or accept the suggested field names if they’re correct. You can
link up to three different fields.
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e To have the chart stay the same from record to record, delete the field
names or choose <No Field> from the top of the drop-down lists.

9. Specify a title for your chart when the last Chart Wizard dialog box appears, choose
whether to display a legend, and selectother options as needed. Then click on Finish
and let the Wizard to do its job.

An embedded object frame with a sample chart appears on the form or report. You
can size and move that frame, or change its properties, using the standard techniques.
You also can customize the chart as discussed shortly. To view the finished chart,
switch to form view if you're working with a form, or to print preview if you're working
with a report.

Figure 14.17 shows (in form view) the finished Employee Summary form after we
embedded a chart that’s linked to the form’s EmployeelD field.

If you create a freestanding chart and later decide to convert it to a chart that's
embedded in a form or report, you don’t have to start again from scratch. Instead,
select the entire form or report in design view (Edit » Select Form or Edit » Select
Report) and change the Record Source property on the Data tab of the property
sheet to the name of the chart’s underlying table or query. Then use the field list
to add new controls to the form or report. If necessary, change the chart control’s
Link Child Fields and Link Master Fields properties so the chart will change as you
scroll from record to record (see the next section).
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Changing the Linking Fields

After creating an embedded chart, you may want to change the linking fields. This
might be necessary, for example, if you chose the wrong linking fields while creating
the chart, or you decide to link a previously unlinked chart to your form or report. To
change the linking fields:

1. Switch to design view and select the control that displays the chart (click on it
once, so it has sizing handles).

2. Open the property sheet if it isn’t already open (choose View » Properties or click
on the Properties toolbar button).

3. Click on the Data tab in the property sheet.

4. Change the Link Child Fields property to the appropriate linking field(s) in the
chart’s underlying table or query (for example, EmployeelD). _

5. Change the Link Master Fields to the appropriate linking field(s) in the main form
or report (for example, EmployeelD).
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In the example below, the chart’s Link Child Fields and Link Master Fields properties
are each set to EmployeelD.
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The field names listed in the Link Master Fields and L|nk Child Fields do not have to
be the same. For example, if the employee identifier field is named EmployeelD in

one table and SalesPerson in the other table, that’s OK. However, both fields must

have the same kind of data and the same (or compatible) data type and size.

Changing the Chart’s Query On the Fly

Let’s suppose that after creating a freestanding or embedded chart, you realize that it
doesn’t present exactly the set of data you want. Perhaps you’d like to limit the data to
a different time interval. Or maybe you’d rather present average values or plot the num-
ber of records instead of charting sums. Here are two ways to make a change:

e Delete the freestanding form from the database window or delete the embedded chart
in form design or report design view. Then if necessary, change and save the query
used to isolate the data. Finally, recreate the chart from scratch. This approach is
rather drastic, but it might be quicker if you haven’t spent any time changing the
chart’s appearance (as described shortly).

¢ Go to form design or report design view and customize the chart’s data source
using on-the-fly techniques discussed below. With these techniques, you change
the underlying query that isolates the chart’s data, rather than deleting the chart.
On-the-fly changes are preferable if you've already spent some time customizing
your chart, or you want to make a few quick changes without leaving design view.
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You can easily create another form or report that contains a chart similar to one
you've already designed. Just use normal copy and paste techniques in the database
window to copy the original form or report, as discussed in Chapter 1. Or open the
form or report in design view, form view, or print preview; then choose File » Save As,
type a new name, and click on OK. Finally, open the copied form or report in design
view and use the on-the-fly techniques described in this chapter to customize the chart.

If you opt for the on-the-fly method, start in form design or report design view and
follow these steps: '

1. Click on the chart control to select it.

2. Open the property sheet if it’s not already open (View » Properties) and click on
the Data tab in the property sheet.

3. Click in the Row Source property box and then click on the Build button that
appears. You'll be taken to a SQL Statement : Query Builder window like the one
shown in Figure 14.18.

. Modify the query using the standard techniques discussed in Chapter 10. In Fig-
ure 14.19, for example, we changed the sample query to calculate average sales
instead of total sales and to limit the charted data to records in 1996 and 1997.

. Preview the query results: Click on the Query View or Run toolbar button or choose
View » Datasheet View or Query » Run. If necessary, return to the query design
window (by clicking on the Query View toolbar button or choosing View » Design
View) and make any necessary changes. Repeat this step until the query returns the
data you want.

|
The SQL State- 21501 Statement : Query Builder
ment : Query = = -
Builder window
appears after
you select the
chart control,
open the prop-
erty sheet, and
click on the Build
button in the — :
Row Source data EutPrice

Figure 14 14
property box. - Sum

Group records by month Sum the extended price.
and year; show all months.
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FIGURE 14.19 "
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6. Click on the query design window’s Close button when you’re done changing the
query, or choose File » Close, or press Ctrl+W. When asked about saving changes
to the SQL statement, click on Yes. You'll be returned to the form design or report
design window. :

7. Switch to form view or report print preview to see the effects of your on-the-fly
changes.

Customizing a Chart

Your chart may need some final tweaking after you finish creating it. To customize the
chart, change its properties in design view, use the design techniques described in
Chapter 13, or refine it in Microsoft Graph 5.0 as described in the sections that follow.

Changing the Chart’s Size, Position, and Properties -

You can make some changes to the size and appearance of the chart right in the report
or form design window. Open the form or report that contains the chart (in design
view); then click on the chart or its frame. Once the frame is selected, you can do any
of the following:

e Change its background (fill) color, border color, and general appearance using the
Formatting (Form/Report) toolbar. If that toolbar isn’t visible, right-click on any
visible toolbar or the toolbox and choose Formatting (Form/Report); or choose
View » Toolbars, select (check) Formatting (Form/Report), and then click on the
Close button.

i -
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o Move and size the frame using the standard techniques for moving and sizing con-
trols. (However, to change the size of the chart itself, you'll need to use Microsoft
Graph, as described in the next section.) ‘

e Change other frame properties using the property sheet. (If the property sheet
isn’t visible, click on the Properties toolbar button or choose View » Properties.)

Using Microsoft Graph to Customize the Chart
To make changes directly to the chart, you use Microsoft Graph. Getting started is easy:

o Open the form or report that contains the chart (in design view)
e Double-click on the chart.

You'll be taken to Microsoft Graph, and your screen will resemble Figure 14.20.

] % CRETEER e e SRR
To have the chart shown in Microsoft Graph reflect your actual data, switch to form

view or print preview at least once after creating the chart and before changing it.

Microsoft Graph has its own menu bar, five toolbars, and an extensive Help system.
Its desktop contains two windows: a Datasheet window (not used with charts based on
data from Access tables) and a Chart window.

To customize the chart, first make sure the Chart window is in front (click on it if
necessary). To tailor an area of the chart, you can choose options from the menu bar,
double-click on an area, or right-click on an area and choose options from the shortcut
menu. For example, double-clicking on a data axis on a bar chart opens the Format
Axis dialog box shown in Figure 14.21. From here you can click on the appropriate tab
in the dialog box and then change the patterns, scale, font, number format, or align-
ment of data on the axis. (Click on the Help button if you need more information about
the dialog box.) When you're done making changes, click on OK.

The best way to learn how to customize a chart is simply to experiment until you get
the look you want. Each time you make a change, the Chart window will reflect your
latest tweak. If you make a mistake and discover it immediately, you can choose Edit »
Undo or press Ctrl+Z (or click on the Undo button on the Standard toolbar) to restore
the chart to its most recent appearance.

The following guidelines will help you experiment more efficiently:

o To view the Microsoft Access and Microsoft Graph program windows at the
same time, resize the Microsoft Graph and Access windows smaller than full
screen (if the windows are cutrently maximized, you'll need to click on the
Restore button before resizing them). You also might want to minimize any pro-
grams other than Access and Graph. Now right-click on an empty area on the
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Windows Taskbar and then choose either Tile Vertically or Tile Horizontally. In
Access, the chart will be marked with diagonal hash marks as a reminder that
Microsoft Graph is active (refer to Figure 14.20). Displaying both windows at once
makes it easier to see immediately what effect changes made in Graph will have
on your form or report design in Access.

If no data appears on a chart that’s linked to your form or report, you're prob-
ably looking at a record that does not satisfy the query underlying the chart. Close
Microsoft Graph (choose File » Exit & Return To or click on Graph’s Close button).
Then switch to form view or report print preview and scroll to a record that does
display a chart. Now return to design view and double-click on the chart again.

To customize a particular area of the chart, right-click on that area and choose an
option from the shortcut menu. Or double-click on the area you want to change.
To change the chart’s magnification in the Microsoft Graph window, choose
View » Zoom from the Microsoft Graph menus, select the magnification you
want, and then click on OK. It’s often handy to reduce the magnification so that
you can see and work with the entire chart at once. Be aware that changing the
magnification in Microsoft Graph doesn't resize the chart on your form or report.
To resize the chart in your form or report design, drag the borders of the chart win-
dow in Microsoft Graph to reflect the chart size you want in your final design. (To see
the chart at full magnification before resizing, choose View » Zoom ( 100% » OK.)

%@%@%@
To fit the chart’s frame to the resized chart, return to form design or report design
view and choose Format » Size » To Fit from the menus.

¢ To display or hide the Microsoft Graph toolbars, choose View » Toolbars, select
or deselect the appropriate toolbars, and click on OK. (Or right-click on any visible
toolbar and click on the name of the toolbar that you want to show or hide.)
To find out what a Microsoft Graph toolbar button is for, move the mouse
pointer to that button and wait for the ScreenTip and status bar message to appear.
(If no ScreenTip appears, choose View » Toolbars » Customize, click on the
Options tab, and select Show ScreenTips on toolbars.) For additional help with a
toolbar button, click on the Help button in the Standard toolbar (it’s labeled with a
large question mark); then click on the toolbar button you're curious about.
To change the chart type, choose Chart » Chart Type or right-click on the
chart and choose Chart Type from the shortcut menu; then select an option in
the Chart Type dialog box that appears. For greater control over the chart type,
Chart » Chart Options button. You also can select a chart type from the Chart
Type drop-down button on the Standard toolbar.
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* To associate the data series with the horizontal rows shown in the Microsoft
Graph Datasheet window, choose Data » Series In Rows or click on the By Row
button on the Standard toolbar.

¢ To associate the data series with the vertical columns shown in the Microsoft
Graph Datasheet window, choose Data » Series In Columns or click on the By
Column button on the Standard toolbar.

* To change the color of a data series, double-click on the data series you want to
change, click on a color sample, and then click on OK. Or click on the data series
and then choose a color from the Color drop-down button on the Standard toolbar.,

e To delete the chart’s titles, data labels, legend, axes, grid-lines, or other ana-
tomical parts, select the object you want to delete and then press Delete (or right-
click on the object and choose Clear).

¢ To insert titles, data labels, legend, axes, gridlines, or other anatomical parts,
choose Chart » Chart Options, click the appropriate tab, make your changes, and
click on OK.

° To customize any area of the chart, double-click on it, or right-click on it and
choose the Format option. You also can select certain ijects (such as titles or
axes) and click on appropriate buttons in the Formatting toolbar.

* To customize the spacing between tick labels, double-click on the axis to open
the Format Axis dialog box (refer to Figure 14.21). If the tick labels are too
crowded or too far apart, click on the Scale tab. Then, if the axis displays numbers,
increase or decrease the Major Unit for scaling. For instance, if you double the
major unit number, only half as many tick marks will appear on the axis. If the axis
displays text, you can increase or decrease the number of categories between tick-
mark labels and tick marks. You may need to adjust other options in the Scale
dialog box to get the effect you want.

* To change the alignment and orientation of tick labels, double-click on the
axis, click on the Alignment tab, and click on one of the markers in the larger box.

* To add arrows, shapes, and text annotations to your chart, click on an appro-
priate button in the Drawing toolbar, then drag in the chart area to define the size
of the object. If you're not sure how to use a Drawing toolbar button after select-
ing it, look at the status bar of the Microsoft Graph window for a hint.

When you’re done making changes, choose File » Exit & Return To or click on the
Microsoft Graph window’s Close button. Remember that if you changed the chart’s size
in Microsoft Graph, you can return to Access (design view), select the chart control, and
choose Format » Size » To Fit. This step will resize the frame for a better fit.
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Building a Better Chart

Even after you've mastered the mechanics of creating charts, you still may need to
experiment further in order to produce charts that are easy to understand. The tips
offered below should help to make your experiments more efficient.

e Pick the chart type that most clearly represents your data. For example, line
charts are good for illustrating trends. When you want to show how each element
contributes to a total, try an area chart or stacked bar chart. If your goal is to com-
pare values, column charts and bar charts are good choices. Pie charts are ideal for
showing the relative contributions of different parts to the whole.

Experiment until you find the best chart type for your data. This is easy: In
Microsoft Graph, choose Format » Chart Type and change the chart type.

Avoid cluttering your charts with unnecessary data or labels that obscure the
message you're trying to convey. For example, if you want to focus on first-quarter
sales (January through March), there’s no need to show sales for April through
December. If necessary, use a query to filter out unwanted data.

Make important information stand out in your charts. For example, explode
the most important slice or slices in a pie chart, use bright colors or more notice-
able patterns for key data items, or annotate important data points with Microsoft
Graph’s drawing tools. See the pie charts in Figure 14.22 for an example.

Beware of 3-D charts. They give a more dramatic appearance, but can sometimes
obscure important data points. 2-D charts often provide the clearest view of your
data, as shown at the bottom of Figure 14.23. Sometimes, however, you can get a
clearer view in a 3-D chart by changing its 3-D viewing angles in Microsoft Graph. To
rotate a 3-D chart, choose Format » 3-D View or right-click on it and choose 3-D
View, then use the buttons in the Format 3-D View dialog box to adjust the elevation,
rotation, and perspective (click on the Help button in the Format 3-D View dialog
box for details). Or click on the edge of a wall of the chart, click on one of the sizing
handles, and then drag as needed to rotate the chart and change its perspective.

Use a consistent scale to show charts that contain related data. This will make the
data easier to compare.

For more help while you're using Microsoft Graph, click on the Help button that
appears in various dialog boxes, press F1, or choose options from the Help menu.
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Freezing the Data in Your Chart

Recall that charts based on a query will always show up-to-date information. If you prefer,
you can freeze the chart so that it shows data at a particular point in time and never
changes. One way to freeze the chart is to convert it to an image, as described just
below. Another way is to separate the chart from its underlying table or query by cre-
ating and running a Make Table query that places selected data in a separate table that
never changes. Then you can base your chart on the frozen table, instead of the live
data. (See Chapter 10 for more about Make Table queries.)

Changing the Chart to an Image

Normally your chart will display up-to-date information from the underlying table or
query. If you prefer to freeze that chart’s data so it never changes again, you can convert
it to an image.

# R R 2 i %
. Only freestandmg charts can be converted to images. Once you change the chart
to an image, there’s no way to undo that change, so use this technique with care!

1. Open the form or report that contains the freestanding chart in design view.

2. Click on the chart to select it and then choose Format » Change To » Image. Or
right-click on the chart and choose Change To » Image. You'll be asked to confirm
the change.

3. Click on Yes if you're sure you want to freeze the chart into an image that cannot
be changed. Or click on No to leave the chart alone.

B S O B T S e

S
If you're sure the charted data will never change, convert the chart to an image to
make your form or report open more quickly.

Charting Data from Other Programs

So far, we've focused on charts that display data from Microsoft Access tables and que-
ries. However, your reports and forms also can chart data from other programs. Suppose
your employee information is stored in an Access table, but your company’s sales per-
formance data is in a Microsoft Excel spreadsheet that’s maintained by the Accounting
department. You can use the embedding techniques described in the next section to

| send a memo (custom addressed to each employee) that graphically illustrates the com-
pany’s sales performance.
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Embedding Charts from Other Programs

Follow these steps to create a chart that uses data from another source, such ps Microsoft
Excel, Lotus 1-2-3, or data that you type directly into Microsoft Graph’s Datasheet window.

1. Open your form or report in design view.

2. Click on the Unbound Object Frame toolbox tool (shown at left).

3. Click on the place in the form or report design where the upper-left corner of the
chart should appear, or click and drag to define the chart’s size. The Insert Object
dialog box appears, listing all the OLE programs on your computer.

4. Click on Microsoft Graph 97 Chart in the Insert Object dialog box and then click
on OK,

As Figure 14.24 shows, Microsoft Graph opens with some sample data in the Datasheet
window and a sample chart for that data in the Chart window. You can click in the
Datasheet window and change the existing data as needed. The results will be reflected
instantly in the Chart window.

FIGURE 14.24
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If you prefer to clear the existing data and type in data or import data from another
program, click on the Select All button (shown in Figure 14.24) and then press the
Delete key. Now click in the cell where you want to start typing or importing data and
use the guidelines below to put data into Microsoft Graph’s Datasheet window:

* To enter data into a cell, select the cell you want to edit by clicking on it or using
the arrow and Tab keys to reach the desired cell, and then begin typing. Anything
you type replaces the existing contents of the cell.

° To import a text or spreadsheet file, click where you want the first cell to appear,
Choose Edit » Import File, select the type of file you want to import from the List
Files of Type drop-down list, and then double-click on the file you want to import.
Respond to any additional prompts that appear. For example, if you're importing a
text file, a Text Import Wizard will ask you to provide more information about the
file’s format.

° To import data from a Microsoft Excel chart, choose Edit » Import File, select
XI* from the List Files of Type drbp-down list, and then double-click on the chart
you want to import. Respond to any additional prompts that appear.

5 N’OT E@:@mm% m%&@%@%@@mﬁ%@%%fﬁw
- Text files generally have extensions of prn, .Csv, or .txt; spreadsheet files have
wk* and .xI* extensions; Microsoft Excel charts have .xlc or .xIs extensions.

° To import data that you've copied to the Clipboard, choose Edit » Paste or
press Ctri+V,

After importing or typing in your data, you can click on the Chart window to view
and customize your chart as desired. When you're finished, choose File » Exit & Return
To or click on the Microsoft Graph window’s Close button. The chart will appear in
your Access form or report. If necessary, resize the chart in the design window, or return
to Microsoft Graph and resize the Chart window,

i 7 SRS

.~ You also can link charts developed in other programs that support OLE to unbound
object frames in forms and reports and to OLE Obiject fields in tables. Please see
Chapters 8 and 13 for more information on using OLE to link and embed objects.
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Creafing PivotTables

PivotTables are powerful tools for gleaning management information from large amounts
of data. Although they’re similar to Crosstab queries (described in Chapter 10), PivotTables
are much more powerful because they let you switch row and column headings dynami-
cally and filter data on the fly, so you can focus on just the information you need to know
at the moment.
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PivotTables aren't really native Microsoft Access objects at all. They’re embedded
Microsoft Excel objects that you create and modify by starting from an Access
form. Of course, you must have Microsoft Excel installed in order to use Pivot-

Tables and the PivotTable Wizard that creates them.

Figure 14.25 shows a sample PivotTable after we created it within an Access form
(using the PivotTable Wizard) and then clicked on the form’s Edit PivotTable button.

FIGURE 14.25

A PivotTable  Page axis Column axis Query and pivot toolbar
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This PivotTable answers the question: What were the sales (by month) during the first
half of 1997 for Produce sold to all companies by all employees?

With just a few simple selections from the drop-down lists in the pages axis, this one
PivotTable can answer many more questions:

e What were the sales (by month) during the first half of 1997 for Produce sold by
the employee named Fuller to all customers?

e What were the sales (by month) during the first half of 1997 for Produce sold by
the employee named Fuller to the company named La corne d’abondance?

e What were the sales (by month) during the first half of 1997 for all products sold
by all employees to the company named La corne d’abondance?

¢ What were the sales (by month) during the first half of 1997 for all products sold
by all employees to all customers?

You get the ideal

Now suppose you want to focus on employee sales performance rather than product
sales performance. No sweat. Just drag the shaded LastName and ProductName controls to
new positions on the PivotTable (see Figure 14.26), and the answers become clear instantly.

FIGURE 14.26 -

The PivotTable  page axis Column axis Query and pivot toolbar
from Figure
14.25, after Microsoft Excel - Worksheet'in Pivot Form
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control to the
row axis.

Sum of ExtPrice [Month I ] O
me [157 297 : ; Grand Tota'

2969.£

Callahan : : : 3188.28

Davolio i | | 5360 11036
Dodsworth ! : ' ! 116.25 116.2¢

! : 350: (L3S

: 1590
1534 150 17683.7¢

, ; 1050 15o0) BT

753.75. : L 213315 2886.5

378575 : 9410.25, 472115 33216.65

Row axis Data




CREATING PIVOTTABLES | 60

To summarize the sales by employee and product, move the ProductName control to
the row axis (just below the LastName control), and the PivotTable will change once
more (see Figure 14.27). As you can see, the possibilities for rearranging the PivotTable
are practically endless and easily explored.

The PivotTable  Page axis Column axis Query and pivot toolbar
from

Figure 14.26,
after moving
the Product-
Name control
from the page
axis to the
row axis.
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Understanding PivotTable Buzzwords and Procedures

Before you create your first PivotTable, take a moment to understand the PivotTable
buzzwords listed below. The labels on Figures 14.25, 14.26, and 14.27 show how each
of these terms relates to areas on the sample PivotTables.

Row The field or fields that contain values to use for row labels on the PivotTable’s
row axis. In Figure 14.25, the row field is ProductName; in Figure 14.26, the row field
is LastName; and in Figure 14.27, the row fields are LastName and ProductName.
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Column The field or fields that contain values to use for column labels on the Pivot-
Table’s column axis. In Figures 14.25, 14,26, and 14.27, the column field is Month.
Data The field or fields that contain values to summarize in the body of the table,
In Figures 14.25, 14.26, and 14.27, the data field is ExtPrice (extended price), and
we've used the Sum function to summarize that field.

Page The field or fields that contain values to use for labels on the PivotTable’s
page axis. You can use these'fields to filter data in the PivotTable. In Figure 14.25
the page fields allow filtering on CategoryName, CompanyName, and LastName,
This filter lets us limit summarized values to sales in a specific category (e.g., Pro-
duce), or to a certain company (e.g., La corne d’abondance), or by a particular
employee (e.g., Fuller). In Figure 14.26 the page fields are CategoryName,
CompanyName, and ProductName; and in Figure 14.27 the page fields are
CategoryName and CompanyName.

Creating a PivotTable requires just a few main steps:

1. Create and save a query for the PivotTable’s underlying data (see Chapter 10) if nec-
essary. Figure 14.28 shows the query we used to produce the PivotTables shown in
Figures 14.25, 14.26, and 14.27. We used the following calculations for the ExtPrice
(Extended Price), Month, and OrderDate fields, which are partially hidden in the Fig-
ure 14.28 QBE grid:

e ExtPrice: [Quantity]*[Orders}![UnitPrice|
* Month: Format ([OrderDate],”m yy”)
e OrderDate: Between #1/1/97# And #6/30/97#

Because the PlvotTab!e Wizard lets you choose flelds from multiple tables you might
not need to create a query. However, you will need a query if you want to display
calculation results (e.g., extended price, which multiplies quantity times unit price) or
you want to limit the results to certain records (e.g., orders placed in 1995).

2. Use the PivotTable Wizard to create a form that contains an embedded PivotTable.
See “Creating a PivotTable with the PivotTable Wizard” below for details.
3. Open your form in form view, edit the PivotTable in Microsoft Excel as needed,
and print the PivotTable if you wish. When you're finished editing, return to
Access. All this is explained in “Editing a PivotTable” later in this chapter.
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Creating a PivotTable with the PivotTable Wizard

Creating a PivotTable is easy, thanks to the PivotTable Wizard. Here's the quickest way
to do the job:

1. Start at the database window and click on the Tables tab (to create the PivotTable
from a table) or the Queries tab (to create the PivotTable from a query).

2. Click on the name of the table or query that contains the data for your PivotTable.

3. Choose Insert » Form; or click on the drop-down arrow next to the New Object
toolbar button and then choose Form.

4. Double-click on PivotTable Wizard in the New Form dialog box.

5. Read the first PivotTable Wizard dialog box and then click on Next.

6. Select the table or query that contains the fields you want to include in the Pivot-
Table and then select the fields. You can choose multiple fields and tables as
needed (see Figure 14.29). Click on Next to continue.
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7. Follow the instructions in the next PivotTable Wizard dialog box (see Figure 14.30)
to place the row, column, data, and page fields and customize the appearance and
summary statistics for each field as needed. Here are some guidelines.

To show items in the field as row labels, drag the appropriate field name(s) to
the ROW area.

To show items in the field as column labels, drag the appropriate field
name(s) to the COLUMN area.

To summarize values in the body of the table, drag the appropriate field
name(s) to the DATA area.

To show fields that you want to use for filtering, drag the appropriate field
name(s) to the PAGE area.

To delete a field that you’ve placed on the PivotTable, drag it off the white
part of the PivotTable. Or double-click on the field’s button within the Pivot-
Table and then click on Delete.

To customize the field, double-click on its button in the PivotTable. You'll see
a PivotTable Field dialog box (there’s an example below). This dialog box lets
you assign a new name (label) to the field, choose different summary statistics,
hide certain values of the field, specify the format of numbers in the body of
the PivotTable, and delete the field from the PivotTable (the options available
will depend on which field button you double-clicked on). For help with any
option or button in the PivotTable Field dialog box, click on the ? button in the
dialog box, and then click on the option or button you're curious about. After
choosing options, click on OK to return to the PivotTable Wizard.

f PivotT able Field




CREATING PIVOTTABLES

"FIGURE 14.29
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Don’t worry if you fail to select the ideal field positions and appearance options in
the PivotTable Wizard dialog box shown in Figure 14.30. You'll have a chance to
change your mind later when you edit the PivotTable in Microsoft Excel.

7

8. Click on Next to move to the final PivotTable Wizard dialog box. Type a name for
the PivotTable (if you wish). For best results, leave the other options unchanged, as
shown in Figure 14.31. Then click on Finish.

9, Save the form when the PivotTable form appears on your screen. To do so, click on
the Save toolbar button or choose File » Save or press Ctrl+S. Type a valid form
name (up to 64 characters, including blank spaces), and then click on OK.

FIGURE 14.31
The final Pivot-
Table Wizard
dialog box.

Figure 14.32 shows a PivotTable embedded in an Access form in form view. Notice
that the form doesn’t show all the data in the PivotTable and that it doesn’t offer any
scroll bars. To see what's really in the PivotTable, you'll need to edit it, as explained
next.

Editing a PivotTable

To view the details in a PivotTable or change the PivotTable in some way, you must edit
the PivotTable in Microsoft Excel. As weird as it might seem, you must start the editing
procedure from Access—not from Excel. Fear not, it's easy:

1. Open the form that contains your PivotTable in form view, if it isn’t open already.
That is, click on the Forms tab in the database window and then double-click on
the name of your PivotTable form.
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Click to edit the PivotTable in Microsoft Excel

2. Open the PivotTable in Microsoft Excel using one of these techniques:

o To open the table in a separate Excel window, click on the Edit PivotTable
button below the PivotTable or double-click on the embedded PivotTable.

o To edit the PivotTable in-place (within the Microsoft Access window),
right-click on the PivotTable, and then choose Worksheet Object » Edit. You
probably won't use in-place editing very often because it’s less flexible than
editing in a separate Excel window.

L[ You cannot make changes to the PivotTable unless the underlying data is current
ss=2 (or already saved with the table). To refresh the data and make it current, click on
the Refresh Data button (shown at left) on the PivotTable toolbar or choose Data »
Refresh Data from the menus. '

3. Change the PivotTable as needed. The next section offers some tips for changing
PivotTables.
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4. (Optional) If you want to print the PivotTable in Excel, try this shortcut (we’ll
assume here that you're editing in a separate Excel window). Choose File » Page
Setup from the Microsoft Excel menu bar. From the Page tab in the Page Setup dia-
log box, choose an Orientation (Portrait or Landscape), Scaling, and other options,
as needed. You also can choose options from the Margins, Header/ Footer, and Sheet
tabs. To preview the report, click on the Print Preview button. To print the report,
click on the Print button in the print preview window or the Page Setup dialog box,
fill in the Print dialog box, and then click on OK.

5. Return to Access when you're finished viewing, changing, and printing your Pivot-
Table, using one of these techniques:

¢ If you're editing in a separate Microsoft Excel window, choose File » Exit
from the Microsoft Fxcel menu bar, or press Alt+F4, or click on the Excel win-
dow’s Close button.

° If you're editing in-place within the Microsoft Access window, click outside
the PivotTable (for example, on an empty area of the form, below the hash
marks that appear at the bottom of the PivotTable).

6. Close the form if you're done working with it (Ctrl+W). Any changes you made to
the PivotTable in Microsoft Excel are saved automatically.

Customizing Your PivotTable in Microsoft Excel

You can customize a PivotTable many ways once you've opened it in Microsoft Excel,
and experimentation really is the best teacher when it comes to making PivotTables do
what you want. These pointers should get you up and running quickly:

° To pivot or reorder a field, drag its shaded control button to a new page axis,
row axis, column axis, or body position on the worksheet. We used this technique
to rearrange the data in Figures 14.25, 14.26, and 14.27. Watch the status bar for
tips about how to drag and drop a control once you've started to drag it.

¢ To return to the PivotTable Field dialog box (shown earlier), double-click on a field
control in the page, column, or row axis. Or click on a field control or on a value in
the area you want to customize; then click on the PivotTable Field button (shown at
left) in the PivotTable toolbar. From here you can change the field label, summariza-
tion method, number formats, and other attributes as needed.

® To return to the PivotTable Wizard dialog box, click on the PivotTable Wizard
button (shown at left) in the PivotTable toolbar or choose Data » PivotTable
Report. See step 7 under “Creating a PivotTable with the PivotTable Wizard” and
Figure 14.30 earlier in this chapter for details about using this dialog box.

° PivotTable, right-click on the place you want to customize and then choose an
option from the shortcut menu.
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For more information about customizing PivotTables in Microsoft Excel, look up
PivotTables and its subtopics in the Excel Help Index.

'saved wnth the Psv ,‘VtTable or form ThlS tS a
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latest data any tnme you v1ew the Pwot-
_ Table. To see the most current data, you
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Creating a Chart from a PivotTable

With just a few more keystrokes, you can create a chart from a PivotTable. Here’s how:

1. Open the PivotTable in Microsoft Excel, as explained earlier in this chapter. Then
customize the PivotTable fields as needed.

. Select the PivotTable cells, including the column fields and row fields you want to
chart, but excluding grand totals or page fields. To select cells, drag your mouse
through them.

. Choose Insert » Chart to open the Chart Wizard.

. Follow the instructions in the Chart Wizard dialog boxes. :

. View the chart (and print it if you wish). The chart always reflects your current
selections in the page axis of the PivotTable. For example, if you select a category
from the CategoryName page, the chart will show data for that category only.

. Exit Microsoft Excel (Alt+F4) when you're finished viewing your chart.

For more details about charting PivotTables, look up PivotTables, Plotting PivotTable
Data in the Microsoft Excel Help Index.
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Troubleshooting PivotTable Problems

PivotTables are quite easy to use, but if you're having the troubles listed below, you
might not agree. Fortunately, the fixes for most PivotTable troubles are straightforward:

Data field is using the Count function rather than Sum to summarize a numeric
field Your numeric data may contain blank values. To fix the problem, open the
PivotTable in Microsoft Excel and click on the cell that says “Count Of” followed by
the field name. Next, click on the PivotTable Field button in the PivotTable toolbar
and double-click on the Sum option in the PivotTable Field dialog box.

Data in the PivotTable is cut off and you can’t see any scroll bars You're
probably viewing the form in Microsoft Access form view. Starting in Access form
view, click on the Edit PivotTable button or double-click on the PivotTable. The
PivotTable will open in Microsoft Excel and the scroll bars will appear.

Excel won’t let you change your PivotTable You've probably forgotten to
refresh the data. Click on the Refresh Data button on the PivotTable toolbar or
choose Data » Refresh Data.

Numbers aren’t formatted properly (or at all) in the PivotTable By default,
numbers aren’t formatted. To format numbers, click on a cell in the unformatted
data and then click on the PivotTable Field button in the PivotTable toolbar. Next
click on the Number button in the PivotTable Field dialog box, fill in the Format
Cells dialog box that appears, and then click on OK twice.

PivotTable toolbar is missing in Excel From the Microsoft Excel menu bar,
choose View » Toolbars, select (check) PivotTable, and then click on OK.
Starting from Microsoft Excel, you can’t find the PivotTable You can’t get to
the Access PivotTable from Excel. Start in Microsoft Access form view and then
click on the Edit PivotTable button or double-click on the PivotTable. The Pivot-
Table will open in Excel and you can view and customize it as needed.

For more information about troubleshooting problems with PivotTables, look up
PivotTables, Troubleshooting in the Excel Help Index or the Access Help Index.

Where fo bo from Here

In this chapter, you've learned how to summarize data with charts and PivotTables. If
you’ve been following this book in sequence, you now know all the basics for working
with Microsoft Access. But don't stop here! The next chapter explains how to person-
alize Access to your own working style.
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