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Welcome...
Welcome...

to MapInfo Professional 7.0. The User's Guide explains the installation process and 
the many features new to MapInfo Professional, as well as describing basic and 
advanced mapping concepts. The feature descriptions are thoroughly detailed, and 
the concepts are reinforced in the web-enabled interactive tutorial. Veteran MapInfo 
users should peruse -What's New in MapInfo Professional, so you don't miss any of 
the exciting new features and enhancements. 

The Reference, an alphabetical listing of menu options and buttons, indicates feature 
purpose, availability, and menu path. Additionally, succinct step-by-step instructions 
on completing dialogs are provided. 

MapInfo Professional online help accommodates various methods of accessing 
information. Choose a Help topic from the alphabetical list of tasks or menu 
commands, or use the search feature to find the pertinent entry by topic. Use Find to 
search for a specific word or phrase in the Help files.

Perhaps the best method of acquainting yourself with MapInfo Professional is to 
access the interactive tutorial. The tutorial provides an exciting, hands-on entree to 
basic, advanced, and new features of MapInfo Professional. 

Each component of the documentation set meets a specific need — together they will 
help you become an expert MapInfo Professional user. We encourage all users, novice 
and veteran, to become familiar with the documentation media. The information they 
provide, added to your mapping creativity, will help you use MapInfo Professional to 
its fullest potential.
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Chapter 1: Introduction
Introduction

Chapter 1: Introduction
Welcome to the MapInfo family of products. As 
the field of desktop mapping continues to 
expand, MapInfo leads the way with new 
products that are designed to fulfill users’ 
desktop mapping needs from the most basic, 
with Microsoft Data Map in Excel 97, to the 
most specialized with MapMarker, our premier 
address matching product. 

MapInfo Professional®, our flagship product, is 
a comprehensive desktop mapping tool that 
enables you to perform complex geographic 
analysis such as redistricting, accessing your 
remote data, dragging and dropping map 
objects into your applications, creating thematic 
maps that emphasize patterns in your data, and 
much more. 

Among the new features are enhanced database 
connectivity, powerful new object processing 
and editing capabilities, an updated Crystal 
Reports reporting engine, usability 
enhancements, new projections as well as new 
and improved tools. Chapter 3 provides a full 
description of new and enhanced features.

This User’s Guide contains all of the 
information you need to learn about and be 
productive using MI Pro. For those of you who 
want to get started right away, see our online 
tutorial. 

➤ 

➤ 

➤ 

➤ 

➤ 

➤ 
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Chapter 1: Introduction
Desktop Mapping at a Glance
Huge quantities of information are available today, far more than ever before. Data 
abounds in spreadsheets, sales records, and marketing files. Paper and disk store 
masses of information on customers, stores, personnel, equipment, and resources. 

Nearly all of it has a geographic component. An estimated 85 percent of all databases 
contain some sort of geographic information such as street addresses, cities, states, 
ZIP Codes, or even telephone numbers with area codes and exchange numbers.

Desktop mapping can help you sort through all of this information, and, using the 
geographic components in your data, display your results on a map. This lets you see 
patterns and relationships in the mass of information quickly and easily without 
having to pour over your database.

Thematic maps and graphs show distribution of customers for a 
marketing campaign.
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M

M
aking MapInfo Professional Work for You
With MI Pro, the power of desktop mapping is at your complete disposal. You can 
display your data as points, as thematically shaded regions, as pie or bar charts, as 
districts, etc. You can perform geographic operations such as redistricting, combining 
and splitting objects, and buffering. You can also make queries against your data and 
access your remote data directly from MI Pro.

For example, MI Pro can show which branch store is the closest to your biggest 
customers. It can calculate the distances between customers and stores; it can show 
you the customers who spent the most last year; it can color-code the store symbols by 
sales volume. What makes it all come together is a visual display of your data on the 
map. 

Windows Compatibility
MI Pro is Microsoft Windows 98, Windows 2000, Windows NT 4.0, Windows XP 
Professional and Windows XP Home and Office compatible, so you will feel right at 
home with its windowing environment. MI Pro is designed to fit smoothly into your 
work environment, so it only changes the results you get, not the way you work. 

Maps and Data
To begin with, you can use the data you already have, in the form it’s already in — 
spreadsheets such as Lotus 1–2–3 and Excel, databases such as dBASE/FoxBASE, 
Access 2000, popular CAD packages, and other GIS applications, to name just a few. If 
your data is on a remote database, you can access it directly from MI Pro. If you have 
data that is not already online, you can create database files right inside MI Pro, or use 
data supplied by MapInfo — such as census data.

Similarly, you can use any of thousands of maps available from MapInfo, everything 
from street and highway maps to world maps. You can also create your own maps, 
either in MI Pro or with a drawing package. Anything that can be diagrammed — 
floor plans, flow charts, even brain anatomy — can be treated as a map and entered 
into MI Pro.

After you’ve organized your data visually, you’ll save the results to files, or send them 
to any of the dozens of printers and plotters MI Pro recognizes.
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Feature Rundown 
MI Pro gives you the processing power of databases (including powerful SQL 
queries) and the visual power of maps, plus charts and graphs. It’s an essential 
business tool for data analysis, sales, and presentations.

Here is a look at some of the things MI Pro offers:

• Direct opening of files created with dBASE or FoxBASE, delimited ASCII, 
shapefiles, Lotus 1–2–3, Microsoft Excel, and Microsoft Access; importing of 
graphics files in a variety of formats; a function for creating database files 
from within MI Pro.

• Multiple views of your data in three formats: Map, Browser, and Graph 
windows. Hot Views technology allows you to open multiple views of the 
same data simultaneously and update all views automatically when you 
make a change to any one view.

• Live ODBC access to remote database data such as Oracle and SQL Server.

• Seamless map layers that allow you to handle several map layers as if they 
were one layer.

• Cartographic legends, enabling you to create and customize legends for any 
map layer.

• Thematic maps to create analyses of your data with high visual impact, 
including grid surface themes, 3DMaps, and Prism maps.

• Use raster underlay capabilities to enhance your work session.

• Querying capabilities ranging from simple selections of data from a single file 
to complex SQL queries from one or more files.

• Workspaces that save all your settings and views so you can start where you 
left off at the end of your last work session.

• HotLinks that let you launch files or URLs directly from a Map window. 

• OLE embedding of Map windows into other applications

• A comprehensive array of drawing and editing tools and other functions for 
customizing your maps.

• Thousands of ready-made maps and functions for creating your own maps.

• Crystal Reports, the industry-standard report-writing program, allows you to 
create reports of your tabular data directly in MI Pro.

• A layout window for preparing output.

• Improved printing and export capabilities for high-quality output

• The ability to change the projection of your map for display or digitizing.

• Object processing functions that help to correct errors in data, set node snap 
tolerances for different objects, as well as thin nodes and polygons.
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When it’s time to run MI Pro, you’ll feel right at home with its windowing 
environment. After you’ve organized your data visually, you’ll save the results to 
files, or send them to your printer or plotter.

etting Started
If you have your data on hand and you can read a map, you’re just about ready to 
begin. Soon, we’ll show you an example of how easy it is to put MI Pro’s power to 
work for you. 

But first, install MI Pro following the instructions in Chapter 2. Read through What’s 
New in MapInfo Professional to get a feel for the range of mapping possibilities. 
Chapter 4 provides an overview of basic mapping terms and concepts, a must read for 
the new user. Do the web-enabled tutorial to learn MI Pro’s features, and become 
accustomed to the more common tasks and functions.

For more product and service information, you can connect directly from MI Pro to 
our forum on the Microsoft Network (Help > Connect to MapInfo Forum). Or, consult 
our World Wide Web site (http://www.mapinfo.com). 

I Pro Documentation Set
In addition to the User’s Guide, MI Pro’s documentation set includes the online 
Reference, online MapBasic Reference, an online version of this guide, online Help, 
online Tutorial, and the StatusBar.

MI Pro Reference
MI Pro’s online Reference is a complete guide to all MI Pro menu commands, tools, and 
functionality. Alphabetically organized, each entry provides step-by-step instructions 
for completing dialogs and carrying out the various operations.

MapBasic® Reference
The MapBasic online Reference is a complete guide to all MapBasic commands. See 
Chapter 24, Using the MapBasic Window, for a discussion of which MapBasic 
commands can be used.
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Installing Online Documentation
Access the online MapInfo Professional Reference, online MapBasic Reference, or the 
Crystal Reports User’s Guide directly from the MI Pro CD, or install the Adobe® 
Acrobat Reader to access the files locally.

Choose to access any of the online manuals directly from the CD.

To install the documentation locally: 
1. Install the Acrobat® Reader.
2. Copy the files from the [CD_ROM]:\PDF_DOCS folder to a local directory.

mi_ref.pdf is the MapInfo Professional Reference Guide and requires ~9 MB of 
disk space.

mi_ug.pdf is this Guide and requires ~17 MB of disk space.

mb_ref.pdf is the MapBasic Reference Guide and requires ~10 MB of disk 
space.

crw_ref.pdf is the Crystal Reports User’s Guide and requires 13 MB of disk 
space.

arclink3.pdf contains documentation on ArcLink.

easyloader.pdf contains documentation on the EasyLoader tool.

3. From Windows Explorer, double-click on any file to automatically launch the 
Acrobat® Reader and the online books.

If you’d prefer to have a printed version of the Reference Guide (version 7.0), contact 
Customer Service. Copies are $29.95 plus shipping.

Customer Service
• Hours: Monday through Friday, 8AM to 7PM EST

• Telephone Number: (800) 552–2511, option 3

• Queue/Voice mailbox: 6329

• Internet address: custserv@mapinfo.com

Online Help
MI Pro’s comprehensive Online Help system provides the information you need to 
learn and use MI Pro more effectively. You can reach the information in several ways:

• Use the Help Contents screen to choose topics from books. Click on a book to 
display its topics, and choose a topic from the list. 
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• Use the Find feature to search on a specific word. Type the word you want to 
search for, and click Rebuild. MI Pro displays a list of words to help narrow 
your search. Click on a word, and a list of topics displays that contain the 
selected word. Double-click on the topic you want or click Display to display 
the topic.

• Use the Index feature to find a topic quickly. Type the first few letters of the 
word you are looking for. The topic that most closely matches what you typed 
is highlighted. Click the index entry you want to display.

• Context-Sensitive Feature: Press the F1 key to receive more information on 
any menu command or dialog. The Help window for that item displays. Also 
click on the Help button in the MI Pro dialogs to display information on the 
current dialog.

• See Also information: Click on the green underlined text in any Help window 
to bring up information on related tasks or key words and phrases. 

Online Help has been designed to display in half of your window so that you can 
view your maps, Browser windows, and dialogs alongside the Help window. Of 
course, you can always change the size of the Help window to work the way you are 
most comfortable. Choose Help > Always On Top to keep the Help window on your 
screen so you can continue to work in MI Pro. Or use Alt-Tab to toggle between the 
Help screen and the MI Pro desktop.

Online Tutorial
Get started quickly with MI Pro’s Web-enabled online tutorial designed to give novice 
users a quick introduction to MI Pro. Let the tutorial guide you through MI Pro’s main 
features. Try the lessons live in MI Pro or run a live demonstration. You can go at your 
own pace. 

To access the tutorial directly from the MI Pro 7.0 CD Browser, choose Run MapInfo 
Tutorial. You can also copy the files to a local or network area and run it locally. See 
the first tutorial page to find out how. 

StatusBar
MI Pro’s StatusBar along the lower edge of your screen provides helpful information 
during your mapping session and allows you to make some changes directly in the 
StatusBar. Choose Options > Show/Hide StatusBar to control the display of the 
StatusBar. 

• StatusBar Help: For instantaneous answers to “What does that command do” 
simply move the cursor over the command. A brief description of the 
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command displays in the left pane of the StatusBar along the lower edge of 
your screen.

• Zoom, Map Scale, Cursor Location: View any one of these settings in the 
StatusBar. You can change which one is displayed directly from the StatusBar.
Click the arrow on the right side of the box to display a popup list of the three 
options. Click on the setting you want to display. The StatusBar automatically 
updates. These display settings are also controlled in the Map Options dialog 
(Map>Options).

• Editable Layers: To keep track of which layer is currently editable, MI Pro 
displays the layer in the StatusBar. You can change the editable layer directly 
in the StatusBar Click on the arrow to the right of the box to display a popup 
list of the layers in the Map window. Click on the layer you want to make 
editable. The StatusBar automatically updates, showing the new editable 
layer. 

• Selectable Layers: The StatusBar indicates which layer the current selection is 
from. If there is nothing selected, the StatusBar reads: “Selecting: NONE.”

• Browser window Records: When viewing a table in a Browser, the record 
count displays in the StatusBar. 

• Snap-to-Node: This S-key toggle feature is in use when SNAP displays in the 
StatusBar.

MI Pro and the Microsoft IntelliMouse™
MI Pro supports the Microsoft IntelliMouse™ as follows:

Document Scrolling
In the Map, Layout, Browser, and MapBasic windows, hold down the Control key and
move the wheel to scroll the document vertically; the effect is the same as clicking on 
the arrow at the end of the scroll bar.

Document Panning
In the Map and Browser windows, hold down the wheel button on the IntelliMouse™ 
and move the mouse to pan the document. Release the button to end the panning. 
There are three panning speeds. The speed of the panning is based on the cursor’s 
distance from the starting point, indicated by the origin mark. In the Map window, the
distance moved at each speed is a percentage of the zoom distance. For example, the 
amount to move at slow speed is. 005 * ZoomDistance, medium speed is. 01 * 
ZoomDistance, and super speed is .1 * ZoomDistance. In the Browser, the window is 
scrolled by 1, 3, and 7 lines or columns for slow, medium and super speeds. When the 
cursor is within 15 pixels of the starting point, there is no panning.
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AutoScroll
In the Map and Browser windows, click and release the wheel button to activate 
AutoScroll. When the mouse cursor is moved away from the starting point the 
document starts to scroll in whatever direction you move the mouse. When the cursor 
is returned to the starting point, scrolling stops. AutoScroll is turned off by any mouse 
click or key stroke. AutoScroll is also turned off when MI Pro loses the focus, for 
example, when you Alt-Tab to another application. 

Zoom
In the Map and Layout windows, move the wheel forward to zoom in on the 
document. Roll back the mouse wheel to zoom out on the document. The wheel has a 
series of detents; each “click” is the same as one click with a zoom tool. The mouse 
wheel does not recenter the view. 

nsuring Success with MapInfo Professional
Unquestionably, MapInfo Professional can set your organization apart from 
competitors; however, it also requires knowledge of the program’s basic functionality. 
Here is a five-step process you can use to ensure your own success:

1. Read the documentation. The MapInfo Professional User’s Guide and 
Reference (if purchased) provide all of the information needed to perform the 
basic functions of the software. They are also included on the distribution CD 
as PDF files. MapInfo Professional also provides an online tutorial to help get 
you started.

2. Get trained. Get the most out of your MI Pro software. MapInfo Corporation 
and its partners provide comprehensive training courses throughout the 
world. You will learn everything from basic to advanced operations and 
develop important skills along the way. 

3. Check the Tech Notes. The Tech Tip Archive on our Web site contains 
numerous documents from MI Pro’s Knowledge Base and a FAQ section. The 
Tech Tips explain common problems and provide how-to information that 
can help with specific issues. New documents are added often, so stop by 
www.mapinfo.com and see what’s new.

4. Join the MapInfo-L community. The MapInfo-L mailing list is an Internet list 
server that allows you to share your ideas and insight with other MI Pro 
users. 

For details and subscription information about MapInfo-L refer to 
http://www.directionsmag.com.

Contact Bill Thoen <mapinfo-l-owner@lists.directionsmag.com> if you need help.
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On occasion, problems with Internet mail result in lost postings. If users are aware of 
recent postings that are not in the database, please do not re-post to MapInfo-L! 
Instead, please forward a copy of the posting to either Bill Thoen or the MapInfo Test 
Drive Center (testdrive@mapinfo.com). 

Utilize support along the way. When you’re stopped at a critical point, Technical 
Support is here to help. See the contact information section below for details on 
contacting your local support center.

Training Requirements
The best way to ensure success with MI Pro software is to make certain that users are 
trained in the product and version of the MI Pro software being used. Since MapInfo 
recognizes that it is not always possible for the designated contact to be trained 
immediately, MapInfo offers a 30-day grace period on this requirement. At the end of 
the 30-day grace period, MapInfo Technical Support reserves the right to withhold 
support from untrained designated contacts. 

Note:  Trained contacts can place an unlimited number of support calls during 
the time period of a valid technical support contract.

Technical Support Offerings
MapInfo Corporation offers a free support period on all new software purchases and 
upgrades, so you can be productive from the start. Once the free period ends, 
MapInfo Corporation offers a broad selection of extended support services for 
individual, business, and corporate users. 

Note:  To utilize Technical Support, you must register your product. This can be 
done very easily during installation. 

Full technical support for MapInfo Professional is provided for versions 6.0 and 
higher.

Extended support options are available at each of our technical support centers in the 
United States, United Kingdom, and Australia. See below for how to contact the office
nearest you.

Contact Information
To receive more information on MapInfo’s technical support programs, contact a 
representative in your area or one of our technical support offices. 
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In the United States, call 1–800–FASTMAP for more information. To purchase 
MapInfo technical support or renew your current contract, please contact MapInfo 
Customer Service at 1–800–552–2511, and press 3 at the main menu, or send an e-mail 
at custserv@mapinfo.com.

At our European Headquarters in the UK, call 44.1753.848229, or send an e-mail at: 
support-europe@mapinfo.com

In Australia, call 61.2.8925.7344, or send an e-mail at: ozsupport@mapinfo.com 

Working with Technical Support
Technical Support is here to help you, and your call is important. This section lists the 
information you need to provide when you call your local support center. It also 
explains some of the technical support procedures so that you will know what to 
expect about the handling and resolution of your particular issue.

Before You Call
Please have the following information ready when contacting us for assistance on 
MapInfo Professional.

1. Serial Number. You must have a registered serial number to receive Technical 
Support.

2. Your name and organization. The person calling must be the contact person 
listed on the support agreement.

3. Version of the product you are calling about. 
4. The operating system name and version.
5. A brief explanation of the problem. Some details that can be helpful in this 

context are:

• Error messages

• Context in which the problem occurs

• Consistency – is the problem reoccurring or occurring erratically?

The Support Tracking System
The Support Tracking System is used internally by the Technical Support department 
to manage and track customer issues. The system also provides the ability to track 
calls with accountability. This system helps Tech Support respond to all customer 
issues effectively, efficiently, and fairly. 
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Expected Response Time
Most issues can be resolved during the customer’s initial call. If this is not possible, a 
response will be issued before the end of the business day. A Technical Support 
representative will provide a status each business day until the issue is resolved.

Support requests submitted by e-mail are handled using the same guidelines as 
telephone support requests; however, there is an unavoidable delay of up to several 
hours for message transmission and recognition.

Exchanging Information 
Occasionally a Technical Support representative will ask you to provide sample data 
in order to duplicate your scenario. In the case of our developer tools (such as MapX 
and MapXtreme), a small subset of sample code may be requested to help duplicate 
the issue. 

The preferred method of exchanging information is either via e-mail or our FTP site. 
Use following e-mail addresses: 

• United States – techsupport@mapinfo.com 

• Europe – support-europe@mapinfo.com

• Australia – ozsupport@mapinfo.com 

Use the following FTP site:
For information regarding our FTP site, please contact Technical Support.

If information cannot be provided electronically, we also accept information in the 
following media formats:

• 3.5” Floppy Disks

• Zip Disks (100 meg format only)

• CD-ROMs

• Jaz Drives (1 gig format only)
12 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 026



Chapter 1: Introduction

M

Software Defects
If the issue is deemed to be a bug in the software, the representative will log the issue 
in MapInfo Corporation’s bug base and provide you with an incident number that can 
be used to track the bug.

Future upgrades and patches have fixes for many of the bugs logged against the 
current version. 

Other Resources

MapInfo Test Drive Center

The Test Drive Center on MapInfo Corporation’s Web site is a forum for technical 
users of our products to learn about MapInfo Corporation’s latest software offerings. 
You can download trial versions of software, as well as obtain patches and fixes.

You’ll need to complete a registration form to gain access to most areas of the Test 
Drive Center. This is a one-time process. As new products and services become 
available in the Test Drive Center, you will not need to re-register to access them. You 
can simply update your existing registration information to indicate an interest in the 
new product. 

MapInfo-L Archive Database

MapInfo Corporation, in conjunction with Bill Thoen, provides a web-based, 
searchable archive database of MapInfo-L postings. The postings are currently 
organized by Discussion Threads and Postings by Date.

Disclaimer: While MapInfo Corporation provides this database as a service to its user 
community, administration of the MapInfo-L mailing list is still provided by Bill 
Thoen.

More information on MapInfo-L can be obtained at the MapInfo Test Drive Center 
(http://mapinfo.com/support/technical_support/lists.cfm). 
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MapInfo Automated Fax Support 

MapInfo Technical Support’s Automated Fax Support system puts the latest Technical 
Support solutions to common technical questions into your hands almost 
immediately. You can access hundreds of technical documents on MapInfo products 
using the system. These fax documents are updated constantly to ensure that you are 
receiving the latest technical information. This service is available 24 hours a day, 7 
days a week, free of charge. No support agreement is required. 

To use Automated Fax Support, all you need is a touch-tone phone and a fax machine. 
Here’s how: 

• Call (518) 285-7283, and choose option 4.

• Follow the simple instructions.

• Select a fax using a document number or receive an index of available 
documents.

• Enter your fax number and the selected documents will be delivered 
immediately.
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Chapter 2: Installation
Installation

This chapter presents the information you need 
to install MapInfo Professional successfully, 
whether as a single user or as a network 
administrator.
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System Requirements 

Windows 98, Windows 2000, Windows NT 4.0 And Windows XP
Memory: MapInfo Professional Version 7.0 requires 32 megabytes of RAM with a 
minimum of a Pentium PC.

Disk space: The space requirement for each component displays during installation.

Monitor: 16- or 24-bit color SVGA recommended.

The MapInfo Professional Installer requires that your TEMP variable be set to
a valid directory. 

You must have Windows 98, 2nd edition and NT 4.0 SP6 with at least IE 4.01 
SP2 installed.

Before Installing
Before installing MapInfo Professional, record your serial number in an easy-to-
remember place, such as a manual title page. A valid serial number is required for 
installation. Also, please complete the postage-paid registration card provided and 
return it to MapInfo Corporation. Additionally, register online by accessing the 
Contact Info option on the CD Browser.

If the MapInfo Professional 7.0 installer detects an existing version of MapInfo 
Professional, 6.0 or earlier, or detects that MapInfo Professional had been installed at 
some time, the MapInfo 7.0 installer will copy MAPINFOW.WOR, STARTUP.WOR 
and MAPINFOW.PRF from the operating system's system directory to <user profile 
root>\Application Data\MapInfo\MapInfo.

Application data (appdata) files are the non-executable data files that MapInfo 
Professional uses during execution. See Appendix C: Data and Settings Management.

Please note that MAPINFOW.PRF might need to be modified to point to the correct 
directories for MapInfo Professional 7.0. Please perform the following:

1. Start MapInfo Professional 7.0.
2.  Choose Options > Preferences > Directories.
3. Change the paths for Theme Templates and Graph Support Files to point to 

where they now reside in MapInfo Professional 7.0.

• Theme Templates: <user profile root>\Application 
Data\MapInfo\MapInfo\Professional\700

•  Graph Support Files: <All Users>\Application 
Data\MapInfo\MapInfo\Prof. . . \700 
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avigating the MapInfo Professional 7.0 CD Browser
The initial screen of the MapInfo Professional 7.0 CD Browser includes these options:

• Install Products: Install MapInfo Professional, DBMS Support, Data, Online 
Reference, and Install Utilities, including: ECW Compressor, GPS, and Meta 
Data Browser.

• What’s New: Display a list and description of new and enhanced features.

• Online Reference: MapInfo Professional 7.0 provides the following online 
reference documents: MapInfo Professional Reference Guide, MapInfo 
Professional User Guide, MapBasic Reference, Crystal Reports User Guide, as 
well as the Adobe Acrobat Reader.

• Run MapInfo Professional Tutorial: Click to run the HTML based, 
comprehensive MapInfo Professional 7.0 tutorial.

• Other Products: Display information about MapBasic, MapInfo Discovery, 
and MapInfo Pro for SQL Server.

• Contact Info: Access MapInfo’s Home Page at www. mapinfo.com; view our 
Web site and register your product online.

nstall Products
Click the Install Products button to install MapInfo Professional, DBMS Support, 
Data, online reference manuals, and Utilities, including: ECW Compressor, Meta Data 
Browser, GPS, and to learn more about MapInfo Discovery Publisher.

apInfo Professional 7.0
We strongly recommend that you exit from all Windows programs before beginning 
the installation process.

You must have Administrator rights to run the Installer on NT/2000 and Windows XP.

If your Windows Start menu does not have a MapInfo program folder, the installation 
process will create such a folder. If your Windows Start menu already has a MapInfo 
program folder, the installation process will create a new MapInfo icon within that 
folder. 

MapInfo Professional now incorporates the ability to provide its application data files 
to each user. Called a Per-User install, this functionality runs the first time you run 
MapInfo Professional or MapInfo Professional client on a machine, and each time the 
MapInfo Professional Installer is re-run thereafter. The application data files include, 
among others, the Pen Styles file, Custom Symbols files, Graph Support files, and 
Thematic Legend templates.
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To install MapInfo Professional: 
1. Choose Install Products from the MapInfo Professional CD Browser.
2. Choose MapInfo Professional. The Welcome screen displays. Choose Next to 

continue the installation process.

If you have MapInfo Professional 7.0 installed, the Program Maintenance 
Screen displays. Choose modify, repair, or remove MapInfo Professional 7.0. 
See Modifying, Repairing or Removing MapInfo Professional 7.0.

3. The License Information screen displays. Choose “I accept the terms” to 
accept the terms of the agreement; choose Next to continue the installation 
process.

4. The Customer Information screen displays. Enter your name, organization 
name, and serial number. All three fields are required. Choose Next to 
continue the installation process.

5. The Setup Type screen displays: Typical Workstation installation is 
appropriate for most users; Custom Installation is appropriate for advanced 
users, and Network Installation is designed for network administrators.

After Installation, the prompt: "Would you like to check our website for any 
current updates to our product?" displays. If you have an Internet connection, 
check Yes to be connected to the page of the MapInfo Corporation Web site 
containing information about product updates.

Typical Workstation Installation

Choose this installation to install MapInfo Professional program files, Online Help, 
Tools, Universal Translator, and Crystal Reports. ArcLink is not selected.

To install the Typical Workstation Installation:

• Choose Typical Workstation Installation; the Destination Folder screen 
displays.

• Choose Next to accept the destination folder indicated, and continue the 
installation process, or choose Change to display the Change Current 
Destination Folder dialog.

• The Ready to Install the Program screen displays; click Install to begin the 
Installation process. Click Back to return to the previous screen.

• The Installing MapInfo Professional 7.0 screen displays with a progress bar 
indicating the status of the installation process.

• The Installation Complete screen displays. Choose Finish to return to the 
Install Products screen.
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Custom Workstation Installation

Choose this installation to select components of MapInfo Professional 7.0.

To install the Custom Installation: 

• Choose Custom Installation; the Custom SetUp Screen displays.

The options for a Custom Setup include: MapInfo Professional, Tools, 
Translators, and Help Files. A feature description, and the space required for 
the feature and its sub-features displays in the Feature Description area. Click 
on the feature icon to select the feature for installation.

When you select a feature, a menu displays allowing you to choose to install 
and/or run the feature and its subfeatures from various locations, including 
your local hard drive or from CD. If you select the hard drive option, the 
feature will be installed on your local hard drive in the folder indicated; to 
specify a different location, choose Change to display the Current Destination 
folder screen. 

If you choose to install a feature to your hard drive, the Space button is 
enabled; choose this button to display the Disk Space Requirement dialog. 

Additionally, you can choose to not install a component.

Network Installation 

Choose this installation if you are a Network Administrator. 

To install the Network Installation: 

• Choose Network Installation; the Administrator Selection Screen displays.

The options for a Network Setup include: MapInfo Professional, Tools, 
Translators, and Help Files. A feature description, and the space required for 
the feature, displays in the Feature Description area. Click on the option icon 
to select the option for installation.

When you select a feature, a menu displays allowing you to choose to install 
and/or run the feature and its subfeatures from various locations, including 
your local hard drive or from CD. If you select the hard drive option, the 
feature will be installed in the path indicated; on your local hard drive in the 
folder indicated; to specify a different location, choose Change to display the 
Current Destination folder screen. 
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If you choose to install an option to your hard drive, the Space button is 
enabled; choose this button to display the Disk Space Requirement dialog. 

Additionally, you can choose to not install a feature.

See the section: “Installing MapInfo Professional on a Network Drive” for 
additional details.

Modifying, Repairing, or Removing MapInfo Professional 7.0 
Use the Program Maintenance feature of the CD Browser to modify, repair, or remove 
MapInfo Professional 7.0. To access Program Maintenance:

1. Choose Install Products from the MapInfo Professional CD Browser.
2. Choose MapInfo Professional. The Welcome screen displays. Choose Next. 

The Program Maintenance screen displays. 

3. Choose modify, repair, or remove MapInfo Professional 7.0. 

Modify: Display the Custom Selection dialog to change the way features are 
installed.

Repair: Repair installation errors in the program.

Remove: Removes MapInfo Professional 7.0.

You can also access the Program Maintenance screen through: Control Panel > 
Add/Remove Programs > MapInfo Professional 7.0.

DBMS Support
Select DBMS Support from the Install These Products screen of the MapInfo 
Professional CD Browser to install DBMS Support and the IUS Driver. Close all open 
applications before installing.

To install DBMS Support from the Install These Products screen:
1. Choose Install Products from the MapInfo Professional CD Browser.
2. Choose DBMS Support. The MapInfo Professional RDBMS Support screen 

displays presenting two options: DBMS Support and Install IUS Driver.

DBMS Support: Click this button to install Database Management System for 
MapInfo Professional 7.0. MapInfo Professional DBMS Support provides the 
ODBC drivers listed in the ODBC Driver List. 

If you will be using MapInfo Professional 7.0’s remote database connectivity 
feature, and need to install additional ODBC drivers, see the following 
section: Adding ODBC Drivers. 
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3. The Welcome screen displays. Choose Next to continue the installation 
process.

4. The License Information screen displays. Choose YES to accept the terms of 
the agreement and to continue the installation process.

5. The Select Components screen displays. Select the product for which you are 
installing ODBC support: 

MapInfo Professional version 7.0 or later 

MapInfo Professional RunTime version 7.0 or later 

MapInfo ProViewer 7.0 or later

6. The Choose Destination Location dialog displays. Indicate the path where 
MapInfo Professional is installed. Choose the Browse button to view the 
Choose Folder dialog. Click Next to continue the installation process.

7. The Select Components screen displays. Select the components you want to 
install.

MapInfo Professional ODBC Connectivity Support: select this option to 
install MapInfo Professional support for OpenDatabase Connectivity.

Oracle Spatial Object Support: select this option to install MapInfo 
Professional support for Oracle Spatial Object. You need to install Oracle 
Client version 8.1.6 or greater for this option to function.

MapInfo Professional DAO (Microsoft Access) Support: select this option to 
install support for Microsoft Access tables.

8. The Select Program Folder screen displays; designate the program folder.
9. The MDAC-DAO-ODBC installer is placed below the directory selected in 

Step 6 in the ODBC\Disk1 folder and run from there.
10. The MDAC-DAO-ODBC Welcome screen displays. Choose Next.
11. The Select Component screen displays. Click in the left margin of the list box 

to select drivers. To cancel a selection, clear the check mark by clicking in the 
margin next to the driver again. Space required for the drivers and ODBC/
MDAC files selected and space available information displays. Choose Next.

12. The Install Shield Wizard dialog displays. Click Finish to complete the setup.
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Adding ODBC Drivers

To add ODBC drivers:
1. Access the folder where MapInfo Professional 7.0 is installed. 
2. Choose ODBC\Disk1. Run Setup from that location and select Modify from 

the Welcome screen. 
3. The Select Component screen displays. Click in the left margin of the list box 

to select drivers. To cancel a selection, clear the check mark by clicking in the 
margin next to the driver again. Space required for the drivers and ODBC/
MDAC files selected and space available information displays. Choose Next.

4. The Install Shield Wizard dialog displays. Click Finish to complete the setup.

Installing the IUS Driver
To install the INFORMIX Universal Server Driver (IUS) you must first install DBMS 
Support.

1. Choose Install Products from the MapInfo Professional CD Browser. 
2. Choose Install Utilities.
3. Choose DBMS Support. The MapInfo Professional RDBMS Support screen 

displays presenting two options: DBMS Support and Install IUS Driver.
4. Choose Install IUS Driver.The Installation Options screen displays. Choose:

Typical: Program will be installed with the most common options.

Compact: Program will be installed with minimum required options.

Custom: Choose the options you want to install; recommended for advanced 
users.

The IUS Program will be installed in the Destination Directory indicated: 
enter a different location or choose Browse to select a different location. 
Choose Next.

5. The Select Folder for Informix Application Icon screen displays. Select a 
folder for the Informix Application icons. Choose Next. The Ready to Install 
files screen displays; to change any information indicated on the screen, 
choose Back to return to previous screens.

6. The Installation process initiates; choose Finish when the process is complete.
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Installing Data 
To install the free data provided with MapInfo Professional 7.0:

1. Choose Install Products from the MapInfo Professional CD Browser.
2. Choose Data; the MapInfo Professional Data screen displays. 
3. Choose Install Free Data.
4. The Welcome screen displays. Choose Next to continue the installation 

process.
5. The License Information screen displays. Choose YES to accept the terms of 

the agreement and to continue the installation process. 
6. The Choose Destination Location screen displays. Specify the directory where 

the data will be installed.
7. The Setup Type screen displays: 

Custom Install: Choose which datasets to install. The size of each dataset 
displays, as well as space required and space available. Respond Yes to the 
“Would you like setup to display workspace Icons”prompt if you want to 
create an icon for each data set you choose. Choose Next. 

Typical Install: Install all datasets. Respond Yes to the “Would you like setup 
to display workspace Icons”prompt if you want to create an icon for each 
data set you choose. Choose Next. 

8. The Select Program Folder screen displays if you chose to set up Workspace 
icons. Select the program folder where the icons will be created. Choose Next.

9. The Start Copying Files screen displays; choose Back to return to any screen 
to change selections.

10. The Setup Complete dialog displays; click Finish. 

Get More Data
To learn more about our data products, click the Get More Data button in the MapInfo 
Professional Data screen of the Data Installation process. If you have a Browser 
installed, you will be automatically connected to MapInfo Corporation’s Web site, 
where information about MapInfo’s World Wide Data Products is detailed. We have 
over 350 data products to choose from—products that provide reliable and current 
information.
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Online Reference
MapInfo Professional 7.0 provides the following online reference documents: 
MapInfo Professional Reference Guide, MapInfo Professional User Guide, MapBasic 
Reference Guide, Crystal Reports User Guide, ArcLink, and EasyLoader 
documentation, as well as the Adobe Acrobat Reader.

To install the documentation locally: 
1. Install the Acrobat Reader.
2. Copy the files from the [CD_ROM]:\PDF_DOCS folder to a local directory.
3. From Windows Explorer, double-click on any of the PDF files to automatically 

launch the Acrobat Reader and the online book.

Installing ECW Compressor
 We recommend that you exit all Windows programs before installing.

1. Choose Install Products from the MapInfo Professional 7.0 CD Browser.
2. Choose ECW Compressor. The Welcome screen displays. Choose Next to 

continue the installation process.
3. The Software License screen displays. Choose YES to accept the terms of the 

agreement and to continue the installation process.
4. The Choose Destination Location screen displays. Specify the directory where 

ECW Compressor will be installed. 
5. The Select Program Folder screen displays. Select a folder. Choose Next to 

continue. 
6. The Setup Complete screen displays: choose to display the ReadMe file and/

or create a shortcut on your desktop. Choose Finish. 

Installing Meta Data Browser 
 We recommend that you exit all Windows programs before installing Meta Data 
Browser.

1. Choose Install Products from the MapInfo Professional 7.0 CD Browser.
2. Choose Meta Data Browser; the Introduction screen displays. Choose Next to 

continue the installation process.
3. The License Agreement screen displays. Choose YES to accept the terms of 

the agreement and to continue the installation process.
4. The Choose Install Folder screen displays. Specify the directory where Meta 

Data Browser will be installed. Select Choose to display a list of directories.
5. Choose the Shortcut location. You have the option to put the icon in a new 

group, into the MapInfo group, in the Start menu, on the Desktop, or to 
display no icon. Click Install to begin the installation.

6. After installation is complete, select Done.
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Installing GPS
To install Global Positioning Software from Blue Marble: 

1. Choose Install Products > Install Utilities from the MapInfo Professional CD 
Browser.

2. Choose GPS. You will be prompted to exit all applications before installing. 
Choose OK.

3. The MapInfo Special Edition dialog displays. Choose OK.
4. The Select Destination Location screen displays. Specify the directory where 

GPS will be installed.
5. The Software License screen displays. Choose YES to accept the terms of the 

agreement and to continue the installation process.
6. The Add to the Start Menu dialog displays: choose Yes to add a shortcut to 

the Start menu.

7. The ReadMe displays; choose OK to exit the ReadMe.  

Installing MapInfo Professional on a Network
Installing MapInfo Professional on a network involves two separate procedures:

• Installing MapInfo Professional on a network drive (presumably done by the 
Network Administrator).

• Setting up users with program manager icons, etc. (presumably done by the 
user).

Installing MapInfo Professional on a Network Drive
The procedure for installing MapInfo Professional on a network drive is the same as 
the regular installation procedure except for the following:

• Select Network Installation in the Setup Type screen.

• Continue as in a Workstation Installation, selecting features, destination 
locations, etc.

A Network Installation alone does not install any files to the local hard drive.

Setting Up Clients
To permit a user to use this network installation of MapInfo Professional, run Setup as 
described below: 

1. Map a drive to the MapInfo Professional Install directory.
2. Select Run from the Start menu. 
3. Run SETUP.EXE from the [MapInfo install directory]\AddClient.
4. The MapInfo Professional 7.0 Client Welcome screen displays. Select Next.
apInfo Professional User�s Guide 25

Apple Inc. 
Exhibit 1021 

Page 039



Chapter 2: Installation

 

5. The License Information screen displays. Choose “I accept the terms.” Select 
Next. 

6. The Customer Information screen displays with the network install values as 
the default. Modify for the current instance and select Next.

7. Select Install to continue the installation.

8. Select Finish to complete the client installation.  

Starting MapInfo Professional 
• From the Start menu, select MapInfo Professional 7.0 (or MapInfo 

Professional 7.0 Client, if this is a network installation) from the Selected 
Program folder. This is usually Programs > MapInfo.

Installation Troubleshooting

Temp Variable
The MapInfo Professional Installer requires that your TEMP variable is set to a valid 
directory to which the user can write.

Other Issues
The Installer must be run from a drive with a letter such as G: and not from an explicit
UNC path. For example, you might have the MapInfo Professional CD in your 
computer as USERSPC. Other users may share this device as USERSPC; however, it 
would not contain a drive letter. The MapInfo Professional Installation program 
requires a drive letter. To remedy this situation: 

1. Right-click on the shared directory or CD-ROM and select Map Network 
Drive. 

2. Choose a drive letter to map. 
3. Run the Installation Program again from the newly mapped drive letter. 

Removing MapInfo Professional from Your System
Remove MapInfo Professional 7.0 by accessing the MapInfo Professional 7.0 CD 
Browser, Program Maintenance screen, or by choosing the Add/Remove program 
option from the Control Panel in Windows, 98, 2000, Windows NT or Windows XP. 
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Using the MapInfo Professional 7.0 CD Browser to Uninstall 
To uninstall MapInfo Professional 7.0:

1. Choose Install Products from the CD Browser.
2. Choose MapInfo Professional. The Welcome screen displays. Choose Next.
3. The Program Maintenance Screen displays. Choose Remove.   

ontrolling Advanced System Settings
MapInfo Professional has some advanced system settings—settings that cannot be 
configured through a dialog box. These settings allow you to control several low-
level, technical aspects of how MapInfo Professional runs. Most MapInfo Professional 
users do not need to worry about these advanced settings.

For example, MapInfo Professional has a DDE time-out setting, which controls how 
long MapInfo Professional tries to communicate with other applications during DDE 
communications. If you run a MapBasic application, and that application encounters 
time-out errors during DDE, you may want to increase the DDE time-out setting.

If you need to modify one of MapInfo Professional’s advanced system settings (such 
as the DDE time-out setting), use the following procedure.

Modifying the Windows Registry
MapInfo Professional stores system settings in the Windows registry. To edit the 
Windows 98 registry, use the REGEDIT program. To edit the Windows NT registry, 
use the REGEDT32 program. 

 Warning Be very careful when editing the registry; damaging the registry can 

cause serious problems in your operating system. 

For example, to set MapInfo Professional’s DDE time-out setting, locate the following 
key in the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\MapInfo\MapInfo\Common

Within that key, edit the DDeTimeout value. If there is no value by that name, create a 
new value of type string (this data type is referred to as REG_SZ on Windows NT), 
and assign the name DDeTimeout to the value. Set the value’s data to be a number, 
representing the number of milliseconds (e.g., enter 30000 to specify a time-out of 
30,000 milliseconds, or 30 seconds).

For more information on editing the registry, see the online help for REGEDIT or 
REGEDT32.
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Descriptions of Settings
This section describes advanced settings that are stored in the registry.

DDeTimeout = number

This setting controls MapInfo Professional’s time-out setting in DDE conversations 
where MapInfo Professional is the client (the application that initiates a conversation). 
The number represents milliseconds. The default value is 10,000 milliseconds (ten 
seconds). If you run a MapBasic application that attempts to initiate a DDE 
conversation, but the conversation fails because the server application does not 
respond within the time-out period, you may need to increase the DDeTimeout 
number.

OffscreenBitmap = number

The number is 0 (zero) or 1 (one). A value of 1 (the default) indicates that MapInfo 
Professional will process off-screen bitmaps when drawing a map. This means that if 
you cover a Map window, and then bring the Map window to the front again, the map 
redraws instantly. If you set this setting to zero, MapInfo Professional will not process 
off-screen bitmaps. This means that when you bring a Map window to the front, you 
may have to wait as MapInfo Professional redraws the map. 

If you are using a video driver that is uncommon or buggy, and if you encounter 
video problems with Map windows, you may be able to eliminate those problems by 
setting the OffscreenBitmap number to 0.

MaxFiles = number

This setting must be an integer from 10 to 100, indicating how many files MapInfo 
Professional can open simultaneously. This setting does not limit the number of tables 
you can open, but it does limit the number of tables you can edit at one time (the 
number of tables that have unsaved edits). The default value is 29. If you need to 
work with more files simultaneously, set number to 100.

MaxORACLETILES= number

A value from 0 = unlimited tiles to infinity. 

Improving Performance
To improve MapInfo Professional’s performance, increase the speed of the processor 
in the machine. A video accelerator card will increase the speed of the redraw. It will 
not speed up the initial draw of the map, but all subsequent redraws will be faster. A 
faster disk cache will also improve performance, as will adding memory.
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ontrolling the Location of Application Data Files 
During Installation
By default, the setup program for MapInfo Professional installs application data files 
to locations that make sense for the typical user. After installing MapInfo Professional, 
the user is free to move one or more of the application data files to another predefined 
location and MapInfo Professional will find that file. For example, the administrator 
of a machine might move mapinfow.pen from the per user area (its default location) 
into the install directory so all users on that machine will share the same set of pens. 

For IT persons responsible for a large number of MapInfo Professional installs it is not 
practical to manually move application data files to realize the desired configuration. 
To solve this problem we have developed a solution that allows IT persons to specify 
the location of application data files by creating a setting file, call MODE.INI, prior to 
installing MapInfo Professional. 

1. Create a MODE.INI file in the root directory of the installer. 

2. Open MODE.INI into any text editor.

3. Edit MODE.INI, modifying the code of the application data file/group whose 
location you wish to change.

4. Install MapInfo Professional.

The following is a list of predefined locations for application data files supported by 
MapInfo Professional, and the corresponding numeric code to be used in MODE.INI.

Code Description Location

1 per user, roaming <Current User>\Application Data

2 per user, not roaming <Current User>\Local Settings\Application 
Data

3 per machine <All Users>\Application Data

4 program directory <Install Dir>
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The following is a list of application data files/groups and their default location: 

MODE. INI File Example
Create a text file with the following syntax:

GraphSupport = 3

CustSymb = 1

ThmTmplt = 1

MapInfow.clr = 1

MapInfow.fnt = 1

MapInfow.pen = 1

MapInfow.abb = 4

MapInfow.prj = 4

MapInfow.mnu = 4

Filename Default Location

mapinfow.clr per user, roaming

mapinfow.pen per user, roaming

mapinfow.fnt per user, roaming

mapinfow.abb program directory

mapinfow.prj program directory

mapinfow.mnu program directory

custsymb per user, roaming

thmtmplt per user, roaming

graphsupport per machine
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Chapter 3: What’s New in 
MapInfo Professional
What’s New in MapInfo 

Professional 7.0®

MapInfo Professional’s  ® new features and 
enhancements are designed to make your 
Professional experience a rewarding one—one 
which lets you easily connect to a remote 
database and make a new DBMS connection 
from a variety of dialogs, and which lets you 
perform Conflict Resolution faster than ever 
before.   Powerful new object processing and 
editing capabilities, including the ability to 
create Voronoi polygons, greatly improves data 
presentation and analysis. Import GML files; 
open shapefiles painlessly from the Open 
dialog; and create JPEG 2000 files using 
enhanced Save Window As capabilities. Use the 
Send to MapInfo MapX Mobile feature to 
export a Map window to MapX Mobile format 
for display on a mobile device.

The following sections give a brief summary of 
what’s new, and what’s better than before. For 
detailed discussions of how to use the new 
functionality, see the appropriate chapters in 
this User’s Guide and the alphabetical entries in 
the MapInfo Professional Reference. And, as 
always, Help is just a click away.

➤ 

➤ 

➤ 

➤ 
Apple Inc. 
Exhibit 1021 

Page 045



Chapter 3: What�s New in MapInfo Professional

 

 MapInfo Professional 7.0 Includes: 

Enhanced Operating System Support
In addition to supporting Windows 98, and NT 4.0, MapInfo Professional® 7.0 has 
been certified for Microsoft Windows 2000. Additionally, MapInfo Professional 7.0 has

earned the “Designed for Microsoft Windows XP®“ logo. This certification ensures 
that the installer and program meet specific requirements for automation and 
maintenance. 

New and Enhanced Database Support

Database Connectivity
MapInfo Professional 7.0 supports:

• The latest versions of Oracle Spatial, 9i and 9i Locator, while continuing 
support for 8.1.6 and 8.1.7.

• SpatialWare 4.6 on all of its supported platforms, including SpatialWare for 
Microsoft SQL Server versions 7 and 2000 and Informix 9.21 with linked 
tables and live access.

• Microsoft Access 2000 and SQL Server, versions 7.0 and 2000.

And, to make your database work more productive, MI Pro 7.0 provides a new 
interface for opening remote tables; the ability to easily save tables to a remote 
database using Save Copy As and to create new tables on remote databases; as well 
the means to create a new table from existing tables. 

Have a favorite connection setting? Use the new Startup preference setting to 
automatically use that connection when beginning your MapInfo Professional 
session.  Or, choose to make a connection from within three dialogs: Open Table, 
Create New Table, and Save Copy As.

Finally, resolving database conflicts is now simplified using the improved Conflict 
Detection for Live Access.
32 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 046



Chapter 3: What�s New in MapInfo Professional

M

Easy Loader
The Easy Loader user interface has had a face-lift! There are now both Main and 
Options dialogs to make the Easy Loader process more efficient. If a directory is 
specified, automatically generate TAB files to access tables on a remote server. 
Additionally, upload text objects to an SQL server if a text-supported SpatialWare 
(4.6) or later is found on the server. You can create an Identity Property which 
automatically generates new keys on an SQL server: it is now the default. The “not 
null” constraint is also added for other servers.

Live Access
MapInfo Professional’s support for live access to remote tables now includes 
SpatialWare 4.6 on SQL Server 2000.

Ease of Use Improvements

Open Dialog
The Open dialog has been redesigned—opening new possibilities for efficient access 
and management of your files. Now you can open  MapInfo workspaces, as well as 
DBMS tables, from this dialog; you can make a new connection; and access the Places 
Bar, which speedily takes you to the directories you designated in the Preferences 
option. And, where appropriate, these changes appear throughout the interface, to 
make such frequently used tasks as saving a simpler process. 

Find in Front Window Only
You have (as usual) many windows open, Browser windows, Map windows, 
Redistrict window—and you want to perform a Query Find. Now, simply select the 
Find in Front Window Only option to limit this operation to the front window.

And:
• Create files in JPEG 2000 format during the Save Window As process. Also, 

display images in JPEG 2000 format.

• Enhanced support for Microsoft Excel data import option.

• For individual value themes, save categories and their associated styles in a 
theme template. 

• Erase and Erase outside support point, multipoint, and collection objects.
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• Data Aggregation is now available for buffering.

• Create a new table from an existing table—helpful after creating a selection.

• Combine objects and store the results in a new table.

• Save Window As now supports exporting files at a user-defined resolution 
allowing you to control the DPI of the exported file--and export to JPEG 2000 
format.

File Type Support

Shapefile Support
Ability to open and read shapefiles directly from the File > Open dialog. And, there is 
a cache option for optimal perfomance.

Raster Handlers
MapInfo Professional  7.0 includes the government raster handlers that support raster 
formats frequently used by government agencies, including: ASRP; ADRG; CADRG; 
CIB; NITF. Additionally, the MrSID and ECW raster handlers are now installed as part 
of the default MapInfo Professional installation.

Importing
We have added the ability to import OSGB format GML files. 
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New and Enhanced Map Creation and Editing Options

Rotate Objects 
Since rotating text and labels proved to be a much appreciated feature, we have added 
the ability to rotate objects—again helping you to create effective presentations. You 
can interactively rotate objects by dragging the new rotate handle.

And: 
• Use the arrow keys to move a selected object in an editable layer in a Map or 

Layout window. One press moves the object one pixel—use the Shift key to 
move the object ten pixels.

• The backspace key can be used as a delete key to undo the last node when 
using these tools: polyline, polygon, custom polyline, custom polygon, 
polygon search, ruler tool. 
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New and Enhanced Object Processing

Voronoi Polygon
The simple interface of the Voronoi polygon feature provides access to a dynamic and 
effective method for data presentation—and presenting your data clearly is what it is 
all about. Create a Voronoi polygon to turn your point data into exclusive coverage 
and trade areas, displaying information in a unique and dramatic way.

Polyline Split
Split by polyline, a new object processing feature, lets you easily create custom 
objects. Split points, multipoints, and collections, as well as closed and linear objects. 
Use a road, or a line you create, to split both closed and linear objects—and, analyze 
these custom geographies using the full range of MapInfo Professional's data analysis 
tools.
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New and Enhanced Map and Layout Display Options

New North Arrow Tool
Using either a Tools menu option, or a button, place a North Arrow in your Map or 
Layout window. You choose the style and location—as well as whether to include a 
magnetic declination indicator.

And: 
• Label partial objects supports labeling both polylines and regions.

• The Change View dialog allows you to change the coordinates of the Map 
window’s center using Military Grid Reference coordinates.

New and Enhanced Publishing Options

Crystal Reports 8.5
MapInfo Professional 7.0 provides a new version of Crystal Reports—with its many 
enhancements, including Microsoft Access back end database system, publish to 
HTML, export to HTML and PDF, and OLE 2 embedding capability.

Send to MapInfo MapX Mobile 
The Send to MapInfo MapX Mobile tool makes a copy of the data needed to duplicate 
a MapInfo Professional 7.0 Map window and display it on a hand-held device 
running MapX Mobile.
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Use MapInfo MapX Mobile to create powerful, feature rich applications for any 
mobile workforce. In the commercial sector, these include applications for service and 
repair representatives, sales professionals, field engineers, technicians, or claims 
representatives. Within government sectors, these include applications for law 
enforcement professionals, health, building, and agricultural inspectors, social 
services caseworkers, and other mobile professionals. 

New Preferences
You want to set your MapInfo Professional work environment so that you can do your 
real work—and not spend time adjusting the many variables we offer. Therefore, as 
we add program options to enhance your mapping and data presentation capabilities, 
we also add preference settings to make those options manageable. MI Pro 7.0 
includes these new preferences:

Default Projection: designate a default table projection for creating new tables and 
for importing MIF, MBI, and IMG files, as well as setting a default projection for the 
Choose Projection dialog option. The Session Projection preference makes the option 
available for MapBasic applications.

Default Styles: designate defaults for Line, Region, Symbol, and Text Styles—and 
highlight controls for selected and target objects.

Default DBMS connection: designate your most frequently-used DBMS connection 
as your default and it will automatically reconnect at StartUp.

Auto scroll: enable or disable auto scroll for each newly created Map or Layout 
window.

New and Improved Tools 
Coordinate Extractor Tool: updated to extract coordinates in any projection listed in 
the .prj file.

TOC Utility: users of government raster formats can now build a seamless table of all 
the files listed in a TOC file. The utility will create one or more seamless tables, 
grouped by zone and resolution.

Universal Translator: now supports bounded, affined, and affine and bounded 
projections. 
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Projections
• Double Stereographic Projection for Canada

• Austrian Projection

• New Zealand Projection

• Japan JGD 2000 Projection

Sample Data Improvements
• New ImagePro Aerial photography for DC area

• Increased detail in World files and country subsets

• 14 different StreetPro data sets (with MapX Mobile Geosets)

• Data dictionary Hot Link files providing an easy way to display and manage 
data.

• Data Installer --changed and improved-- to categorize different geographies.

MapBasic Support
In addition to exposing all new features via MapBasic’s programmable interface, new 
MapBasic options have also been added. For example, New Document Window 
allows the display of map or layout windows in a dialog.  
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Mapping Concepts

Now that you have installed MapInfo 

Professional® and been enticed by the wide 
variety of features and functionality in the 
What’s New in MapInfo Professional chapter, 
you are probably anxious to get mapping. But, 
first, take a few minutes to read this chapter, 
especially for those of you new to MI Pro. This 
chapter gives you a solid understanding of the 
concepts, components, and tools for successful 
mapping in MI Pro. 
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Organizing Your Data and Maps: An Overview of Tables 
To use MI Pro, you need the files that contain your records and maps that come from 
MI Pro or that you created yourself. MI Pro organizes all its information, whether 
textual or graphic, in the form of tables; each table is a group of MI Pro files that 
constitute either a map file or a database file.

Everything you do in MI Pro begins when you open one or more tables. 

How Files Make Up a Table
When you open your data file in MI Pro, MI Pro creates a table. This table consists of 
at least two separate files. The first file contains the structure of the data. The second 
file contains the raw data. All MI Pro tables will have the following two files:

• Somefile.tab: This file describes the structure of your table. It is a small text 
file describing the format of the file containing your data. 

Emergency medical calls thematically shaded by type of call and time of call, with response 
zones shaded by number of calls
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• Somefile.dat or somefile.wks, dbf, xls: These files contain your tabular data. If 
you are working with a dBASE/FoxBASE, delimited ASCII, Lotus 1–2–3,  
Microsoft Excel, or Microsoft Access file, your MI Pro table will consist of a 
.tab file and your data or spreadsheet file. For raster tables, the equivalent 
extension might be bmp, tif, or gif.

Your data may also contain graphic objects. Once you assign X and Y coordinates to 
your data records, your table will also contain graphic objects. In Chapter 8, you will 
learn how to assign X and Y coordinates to your data records so you can display them 
on a map. If you already have graphic objects in your table, you will have two more 
files associated with the table:

• Somefile.map: This file describes the graphic objects.

• Somefile.id: This file is a cross reference file that links the data with the 
objects. 

For a Microsoft Access table, there will be a file Somefile.aid associated with the table 
instead of Somefile.id. This file is a cross reference file that links the data with the 
objects for a Microsoft Access table. 

Your table may also include an index file. The index file allows you to search for map 
objects using the Find command. If you want to locate an address, city, or state using 
the Find command, those fields must be indexed in your table. The index is located in:

• somefile.ind. 

Opening Tables and Files
To work with your data, you must first open the file or table that contains the desired 
information. To open the table:

• Choose File > Open. The Open dialog displays. 

Note:  If you are at the Quick Start dialog (the first dialog you see after starting 
MapInfo), choose the Open a Table button. The Open Table dialog displays.

What you specify in the Open dialog depends on the following:

• Are you opening an existing MI Pro table?

• Are you opening a DBMS file?

• What views, if any, do you want to open for this table? 

• Are you bringing your data into MI Pro for the first time?
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Opening Existing MI Pro Tables
Simply choose the appropriate table or tables. Note that although an MI Pro table 
consists of two or more component files (states.tab, states.dat, states.map etc.), only 
the .tab file appears in the File Name box of the Open dialog. It is the only component 
file you must open. 

Using Preferred View
MI Pro gives you control over how to display your table. Using the Preferred View list 
box in the Open dialog, you can specify in what view you want the table to display. 
There are five view options:

• Automatic – MI Pro chooses the most appropriate view. If the data is 
mappable (i.e., graphic objects are attached to the data), for example, MI Pro 
opens the table in a Map window. If you have a Map window displayed and 
the table you want to open is mappable, MI Pro will automatically open the 
table in the current Map window. If the data is not mappable, MI Pro will 
attempt to open the table in a Browser window. If the table cannot be mapped 
or browsed, MI Pro opens the table using the No View option (no data is 
displayed). 

• Browser – MI Pro attempts to open the table in a Browser window. 

• Current Mapper – MI Pro attempts to add your data to the current Map 
window. 

• New Mapper – MI Pro attempts to open the table in a new Map window. 

• No View – MI Pro opens the table, but no data is displayed. 

Of the five Preferred View options, Automatic and No View will work on all tables, 
regardless of what kind of data they contain. MI Pro attempts to open the table as 
specified for Browser, Current Mapper, and New Mapper. If it cannot, it will open the 
table  according to the following rules:

• If Current Mapper is selected, and there is no Map window displayed, MI Pro 
will attempt to open the table in a new Map window.

• If Current Mapper or New Mapper is selected and the data is not mappable, 
MI Pro will try to open the table in a Browser window.

• If the table cannot be mapped or browsed, MI Pro will open the table using 
the No View option (no data is displayed)

More information on opening tables is in Chapter 5, Basics of Desktop Mapping. 
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Bringing Your Data into MapInfo Professional
MapInfo Professional allows you to use data that was created in other file formats. 
When you bring data into MI Pro for the first time, you need to specify its format. For 
example, if your data is in Delimited ASCII format, choose Delimited ASCII from the 
File Format drop-down list. 

Other choices include:

• dBASE DBF

• Lotus 1–2–3

• Microsoft Excel

• Microsoft Access

• Raster Image

• Remote Database Connection

• Workspace

• Grid Images

• ESRI ® Shapefiles

When you choose a particular file format, the File Name box will only list files that 
have the appropriate extension. For example, if you choose dBASE DBF from the File 
Format drop-down list, MI Pro will only list files that are in dBASE format.

Choose the appropriate file. MI Pro creates a table structure for that data. When you 
open the table in future work sessions, MI Pro will treat these files as if they were in 
MI Pro’s native format. The next time you want to open the table, you should choose 
the .tab format for the table. If you accidently attempt to open the file again with its 
original file format, MI Pro prompts you with the message:

Table definition already exists. Overwrite it?

This message displays because MI Pro has already created a table for that file. Press 
Cancel and open the associated .tab file. 

Also keep in mind that MI Pro supports long filenames and UNC paths. The UNC 
paths allow you to access your data without having to remember your drive 
mappings from one session to another. 

To display your table in the Map window, your data must contain X and Y 
coordinates. If it doesn’t already, you can add them using MI Pro. Assigning these 
coordinates is called geocoding. More about geocoding follows later in this chapter 
and in Chapter 8, Putting Your Data on the Map.
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MI Pro supports raster image display. Raster images are computerized pictures. These
graphic images can be used as backgrounds for maps you create in MI Pro and can 
serve as a reference for your displayed data. 

When you bring in a raster image to MI Pro, you may need to register it (specify its 
map coordinates) so MI Pro can display it properly. Choosing the Raster Image file 
format from the Open dialog will bring you to the Image Registration dialog where 
you can specify the appropriate map coordinates. Once you register the image, a 
process that creates a .tab file for the image, you can open it as you would open any 
table in a Map window. Images that you purchase from MI Pro will already be 
registered. 

If a raster image is georeferenced it will be automatically opened. If a raster image has 
an associated world file, you will be prompted to choose the projection. If you open a 
raster image that does not have any georeferencing information, you will be 
prompted to display or register the image.

For a full discussion of raster image display, see Chapter 19, Displaying Raster 
Images.

MI Pro’s Building Blocks: Map Layers
Computer maps are organized into layers. Think of the layers as transparencies that 
are stacked on top of one another. Each layer contains different aspects of the whole 
map. 

In MI Pro you begin by opening your table of data and displaying it in a Map window.
Each table displays as a separate layer. Each layer contains different map objects, such 
as regions, points, lines, and text. 

For example, one layer may contain state boundaries, a second layer may have 
symbols that represent capitals, a third layer might consist of text labels. By stacking 
these layers one on top of the other, you begin to build a complete map. You can 
display one, two, or many tables at a time.
46 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 059



Chapter 4: Mapping Concepts

M

M

 Map layers form the building blocks of maps in MI Pro. Once you have created your 
map of layers, you can customize the layers in a variety of ways, add and delete 
layers, or reorder them. For a full discussion, see Chapter 7, Mapping in Layers. 

ap, Browser, and Graph Windows
When it’s time to take a look at your tables on screen, MI Pro offers you different 
formats for viewing your data: in a Map window, Browser window or Graph window. 
Choose the format you want from the Window menu:

• Map windows present information arranged as conventional maps, allowing 
you to visualize the geographic patterns of your data.

• Browser windows present information as tabular lists (just as conventional 
databases do), allowing you to fully examine tabular data.

• Graph windows present information arranged as graphs, allowing you to 
visualize and make comparisons of the purely numerical patterns.

Map Windows
Use Map windows to display the geographic objects in your table. They can display 
information from many tables at once, with each table a separate layer.

You can create your maps or edit existing maps. You can open a Map window directly 
through File > Open or by selecting Window > New Map window.
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Browser Windows
Use Browser windows to view and manipulate your data records in traditional row 
and column form, typically used in spreadsheets and databases. Each column 
contains information about that particular field, such as name, address, phone 
number, cable ID number, or order amount. Each row contains all information relating 
to a single record.

You can edit records in your table, copy records, add new ones, or delete existing 
records. To open a Browser directly, choose Window > New Browser Window. 

To create a report of your data, use the Crystal Reports functionality included with 
this version of MI Pro (Tools > Crystal Reports). 

Graph Windows
The Graph window allows you to visualize statistical relationships in graph format. 
You can create many different kinds of graphs: 3D, bar, line, area, historgram, scatter, 
bubble, and pie graphs. You can also choose from a number of different graph 
templates.  To create a Graph, choose Window > New Graph Window. 

Map, Browser, Graph windows
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Layout Windows
The Layout window allows you to combine Browsers, Map windows, Graph 
windows, and other graphic objects into one layout which can then be sent to a 
printer or plotter. To use a Layout window, choose Window > New Layout Window. 

Legend Windows
There are two legend windows available in MI Pro: the theme legend window and the 
cartographic legend window. 

The theme legend window is automatically created and details the meaning of colors, 
symbols and styles on a thematic map. Display or hide this legend by using the 
Options > Show/Hide Theme Legend Window menu option.

The cartographic legend displays legend frames for any map layer, not just thematic 
map layers. The legend window displays the legend, or key, to the cartographic data 
on your map. The legend frames can all be in one window, or can be split among 
several legend windows for the same map. Therefore, each map can have one or more 
cartographic legend windows containing the frames of your choice. Additionally, you 
can customize the text and style of the information presented.   Modifications to the 
legend can be made through shortcut menus you access by right-clicking in the 
legend window or through the Legend menu. To create a cartographic legend, choose 
Map > Create Legend. A Map window must be active for this menu command to be 
available. 

Hot Views
MI Pro allows you to display your data in many different windows and with different 
views at the same time. For instance, you can display the World table of country 
boundaries in a Map window to view the geographic boundaries. At the same time 
you can display the tabular data of the World table in a Browser window to see the 
country names, population, and other data in the file. If you make a change in either 
window, it is reflected in the other. 

Only one view can be active at a time. To make a different window active, click on its 
title bar. Notice that the menu bar changes depending on which window is active. For 
instance, when you are working in a Map window when you also have a Browser 
open, only the Map menu is available on the menu bar. Make the Browser active. The 
Browse menu replaces the Map menu. 
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Getting Your Data on the Map: Geocoding 
In order to display your data in MI Pro, your data needs to contain X and Y 
coordinates so MI Pro will know where to position the data on the map. The process 
of assigning map coordinates is called geocoding. MI Pro assigns coordinates to your 
records by matching the geographic information in your data with geographic 
information in a table that already contains X and Y coordinates. 

For example, your database contains street addresses of retail stores. You tell MI Pro 
to match these street addresses to the streets in a corresponding city map table. Once 
geocoded, you can display these records in a Map window.

For more information on preparing your data for mapping, see Chapter 8, Putting 
Your Data on the Map.

Map Objects
We mentioned earlier that maps in MI Pro are made up of layers of map objects. There
are four basic types of objects:

• Regions: closed objects that cover a given area. These include polygons, 
ellipses, and rectangles. For example, country boundaries, postal code 
boundaries, sales territories.

• Point objects: represent single locations of data. For example, customer 
locations, restaurants, parking meters. Points can also be combined into 
multipoint objects.

• Line objects: open objects that cover a given distance. These include lines, 
polylines, and arcs. Examples are streets, rivers, powerlines.

• Text objects: text that describe a map or another object, such as labels and 
titles.

• Collection objects: combination of region, line, and multipoint objects.

You can have each type of object in a separate layer (most common), or you can 
combine objects in the same layer. MI Pro lets you create, edit, customize, and display
these objects to make maps that meet your needs.
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ools to Get the Job Done
MI Pro provides four toolbars of tool buttons and commands to give you tremendous 
mapping creativity at the click of a button. 

To reshape the toolbars, click and drag on their borders. Drag the title bar to move 
them. To dock a toolbar, drag it to the area directly underneath the Main menu bar. 
The toolbar changes shape and positions itself directly under the menu bar. You can 
easily change it back to the floating view. Just click on the background area of the 
toolbar and drag it away from its position. The toolbar retains the same shape as it 
had before you docked it. You can also do this from the Options menu. Choose 
Options>Toolbars, and in the Toolbar Options dialog select the Floating check box for 
each toolbar that you want to have float and be able to move around. Clear the 
Floating check box for each toolbar you want to dock. To display or hide the toolbars, 
select or clear the Show check box. You can also choose whether you want to display 
color buttons or larger buttons for each toolbar. Choose Save as Default to save your 
arrangement. To remove a toolbar from the screen, double-click its control box.

Standard Toolbar
The Standard toolbar contains tools for commonly performed menu functions from 
the File, Edit, and Window menus. It also contains tools for quick access to a new 
Redistricting window and online Help.

New Table New Graph Window

Undo Cut

Open New Layout Window

New Browser Copy

Save Table New Redistricting Window

New Map Window Paste

Print Help
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Main Toolbar
The Main toolbar contains tools to select objects, change the view of the Map window, 
get information about an object, and show distances between objects. It also contains 
command buttons that allow you to change layer attributes and open a legend or 
statistics window.

Change View button Accesses the Change View dialog so 
you can specify settings for Map 
window width, map scale, resizing, and 
centering.

Grabber button Accesses the Grabber tool so you can 
reposition a map or layout within its 
window.

Info tool button Accesses the Info tool so you can view 
the tabular data that is associated with a 
map object.

Label button Accesses the Label tool so you can label 
objects with information from the 
related database.

HotLink button Accesses the HotLink tool, so you can 
launch active objects such as files or 
URLs from your Map window. 

Layer Control button Accesses the Layer Control dialog so 
you can specify how the various tables 
in a Map window are layered and 
displayed.

Legend button Accesses the Legend window for maps 
or graphs.

Marquee Select 
button

Accesses the Marquee Select tool so you 
can select and search for map objects 
within a given rectangle (marquee box).
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Boundary Select 
button

Accesses the Boundary Select tool so 
you can select and search for map 
objects within a given region.

Polygon Select 
button

Accesses the Polygon Select tool so you 
can select objects within a polygon that 
you draw. 

Unselect All button Accesses the Unselect All tool so you 
can clear all of your object and record 
selections. Performs the same operation 
as the Query>Unselect All command.

Invert Selection Selects all objects or records not 
included in the current selection, and 
cancels the current selection. 

Graph Select button Accesses the Graph Select tool. As you 
click on graph objects, such as a riser 
bar, pie slice, column, etc., the tool 
selects the corresponding records from 
the table. 

Radius Select button Accesses the Radius Select tool so you 
can select and search for map objects 
within a circular region.

Ruler button Accesses the Ruler tool to determine the 
distance between two points and the 
length of some path.

Select button Accesses the Select tool to select 
objects/records in a Map, Layout, or 
Browser window. Also acts as the 
default pointer/cursor tool.

Assign Selected 
Objects button

Assigns selected objects to the target 
district during a Redistricting session.

Set Target District 
from Map button

Sets the target district from the map 
during a Redistricting session.
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The Drawing toolbar contains tools and commands that are used to create and edit 
map objects.

Statistics button Accesses the Statistics window to tally 
the sum and average of all numeric 
fields for the currently chosen objects or 
records.

Zoom-in button Accesses the Zoom-in tool to get a closer 
area view of a map or layout.

Zoom-out button Accesses the Zoom-out tool so you can 
get a wider area view of a map or 
layout.

Drag Map Window 
button

Accesses the Drag Map Window button 
to drag an MI Pro map into an OLE 
container application.

Clip Region On/Off 
button

Redisplays the entire map.

Set Clip Region 
button

Isolates a map region for display. 

Add Node button Accesses the Add Node tool, which 
allows you to add a node to regions, 
lines, or polylines when you are in 
Reshape mode.

Arc button Accesses the Arc tool, which allows 
you to draw an arc the size and shape 
of one quarter of an ellipse.

Ellipse button Accesses the Ellipse tool, which allows 
you to create elliptical and circular 
objects. 
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Frame button Accesses the Frame tool, which allows 
you to create frames in the Layout 
window to display maps, graphs, 
browsers, and legends.

Line button Accesses the Line tool, which allows 
you to draw straight lines.

Line Style button Accesses the Line Style dialog where 
you can change the style, color, and 
width of line objects.

Polygon button Accesses the Polygon tool, which 
allows you to draw polygons (a closed, 
connected sequence of lines).

Polyline button Accesses the Polyline tool, which 
allows you to draw polylines (an open, 
connected sequence of lines).

Rectangle button Accesses the Rectangle tool, which 
allows you to draw rectangles and 
squares.

Region Style button Accesses the Region Style dialog where 
you can change the fill pattern, color, 
and background, plus the border style, 
color, and width of region objects.

Reshape button Toggles in and out of Reshape mode. 
Reshape allows you to edit regions, 
polylines, lines, arcs, and points by 
moving, adding, and deleting nodes 
that define them.

Rounded Rectangle 
button

Accesses the Rounded Rectangle tool, 
which allows you to draw rounded 
rectangles and squares.

Symbol button Accesses the Symbol tool, which allows 
you to place point symbols on your 
map like “push pins.”
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The Tools Toolbar contains tools for working with MapBasic and buttons that display 
when the tools are loaded.

Symbol Style button Accesses the Symbol Style dialog 
where you can change the style, color, 
and size of a symbol object.

Text button Accesses the Text tool, which allows 
you to add titles, labels, and annotation 
to maps and layouts.

Text Style button Accesses the Text Style dialog where 
you can change the font typeface, size, 
style, color, and background of text 
objects. 

Run MapBasic 
Program button

Accesses the Run MapBasic Program 
dialog where you can choose an 
application to run under MI Pro.

Show MapBasic 
Window button

Displays or hides the MapBasic 
window.

Map Wizard button Launches the Map Wizard, which 
enables you to put data on your map 
quickly, using a wizard interface. 

MetaData Browser 
button

Launches the MI Pro’s MetaData 
Browser, which enables you to build 
and launch geospatial metadata 
requests to any NSDI clearinghouse, as 
well as analyze the metadata you 
receive. This tool is available when you 
load the MetaData Browser from the 
Tool Manager. 

North Arrow button Launches the North Arrow tool that 
has been loaded from the Tool 
Manager. Use this tool to designate  
where the North Arrow should display. 
Click this button draw a rectangle in 
which the North Arrow will be place.
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DBMS Toolbar
The DBMS Toolbar contains tools and commands that are used to access tables 
residing on a remote database.

he Power of MapInfo Professional: Editing and Analyzing 
Now that you have an overview of tables, layers, windows, map types, geocoding, 
and tools, you are ready to bring the full capabilities of MI Pro into play. For instance, 
you can label areas on the map or draw on it. You can calculate distances between 
health care providers and their patients and get counts on how many patients live 
within a given radius of a particular hospital. (Labeling and drawing map objects is 
covered in chapters 15 and 17.)

Open DBMS Table 
button

Accesses the Open dialog, which allows 
you to access a remote database. If a 
connection has not previously been 
established, you will be prompted to 
open a connection. This button is also 
found in the Open dialog if DBMS is 
installed.

Make DBMS Table 
Mappable button

Accesses the Make DBMS Table 
Mappable dialog, which allows you 
make a table linked to a remote 
database mappable in MI Pro.

Refresh DBMS Table 
button

Accesses the Refresh DBMS Table 
dialog, which allows you to refresh an 
MI Pro linked table with the most recent 
data residing on the remote database for 
that linked table.

Unlink DBMS Table 
button

Accesses the Unlink DBMS Table dialog, 
which allows you to unlink a 
downloaded table from its remote 
database.

Change Symbol for a 
Mappable DBMS 
Table button

Accesses the Change Symbol for a 
Mappable DBMS Table dialog, which 
allows you to change the symbol style 
of a mappable DBMS table.

DBMS Disconnect Accesses the Close DBMS 
Disconnection dialog, where you can 
close a connection to a remote database.  
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Making selections from your table allows you to extract new information from sets 
and subsets of your data or see patterns and distributions, getting answers to such 
questions as: Which of my customers bought more than $5000 of equipment? Which 
of my customers is located within a 200 mile radius of my warehouse? Which of my 
customers bought more than $5000 of equipment and is located within a 200 mile 
radius of my warehouse? For more on selecting, see Chapter 9, Selecting, and Chapter 
10, Selecting Using Queries.

You can shade boundaries (counties, towns, states, countries) according to the total 
number of customers in each one or according to the number of customers who 
purchased within the last year. MI Pro refers to this as thematic mapping. For more 
information about thematic mapping, see Chapter 11.

MapInfo Professional in Action: An Example
Now that you understand the basic principles of desktop mapping, you’re ready to 
go. Imagine that your job is to purchase advertising time from radio stations to market
your product, a statewide tire service. You have demographic information for your 
state by county, and radio stations have supplied you with their own demographics 
and transmission ranges. You also have a list of your tire service center locations.

Using MI Pro, you can quickly and easily bring this information into focus and make 
informed decisions about which radio stations to use to advertise your tire service. 

You want to begin by viewing your service centers on a map in relation to the radio 
stations, looking for the stations that reach the areas where your centers are located.
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To begin building your map, open the MI Pro tables you will need: the state, county, 
and street maps.

Next, open your file of service centers and tell MI Pro to geocode it by matching the 
street addresses of the service centers with the street locations in your StreetInfo map. 
A few more keystrokes telling MI Pro to add the tire centers to the map, and your data 
suddenly leaps into view. Blue stars tell you at a glance the distribution of your tire 
centers across the state. You use the same method to put the red circles representing 
the radio stations on the map. 

Using your file of county demographics, you ask MI Pro to shade the counties where 
most of your target market (males 35 and older) lives

.

Consulting your list of radio transmission ranges, select the Buffer command and 
create a buffer circle around each radio station, the circle representing each station’s 
broadcast area. Just by looking you can tell which broadcast areas include the highest 
concentration of tire service centers or you can ask MI Pro to give you an exact count 
of the number of tire centers within each area. Tell MI Pro to shade the buffer circles in 
order according to the number of service centers that fall within each circle. Shade the 
circles with the most service centers red.
apInfo Professional User�s Guide 59

Apple Inc. 
Exhibit 1021 

Page 072



Chapter 4: Mapping Concepts
.

With the radius of each station’s transmission range marked, you can see which 
stations broadcast in areas where your target market is (the shaded counties). But how 
well do these stations penetrate that market? Which stations will reach the people 
who are most likely to use your service centers?

Join the demographic information supplied by each station to the broadcast area 
shown on your map. Now you can click on any point within that area and see all the 
demographic information: the age and income distributions of the station’s listeners, 
and the times of day when particular age and income groups are tuned in, for 
example.

Even better, ask MI Pro to cross-check the radio stations that reach your best 
customers with the areas where that population is highest. Fill the broadcast areas of 
those stations with crosshatching.

Look at the map and choose the stations that reach your best customers in the areas 
where you have the most locations. Your best bets are green-shaded circles in 
crosshatched areas. Now you know where your target customers are. Click the Info 
tool on these areas to see the time of day your target market is listening. Now you 
know when to purchase air time.

You can save this map and use it for future planning. For example, it can help you 
spot a good location for a new tire center or coordinate radio advertising with direct 
marketing. Do you want to increase advertising in key areas of the state? 
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Use the MI Pro Layout window to prepare a visually exciting and informative 
presentation that features this map along with graphs and tables.

As you become better acquainted with MI Pro, you will find that its applications are 
limited only by your imagination.
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Basics of Desktop Mapping

This chapter helps you understand and use the 

basic features of MapInfo Professional®. The 
online tutorial that comes with MI Pro also 
covers basic and most commonly used features 
in the software so that you can try your hand at 
all the features explained herein.
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Starting MapInfo Professional 
Now that you have MI Pro installed and have read a little about its power and 
functionality, you are ready to begin mapping and analyzing your data. To start MI 
Pro, double-click on the MapInfo Professional icon on your desktop. In a few seconds, 
MI Pro’s Quick Start dialog displays. Here you can choose how you want to start your
mapping session. The Quick Start dialog displays every time you start MI Pro, but 
you can change this behavior in the Startup preferences (Options > Preferences > 
Startup). In the Startup Preferences dialog, clear the Display Quick Start Dialog box to
deactivate the display of the Quick Start dialog. 

If you had been working in MI Pro earlier, you could return to the previous mapping 
session by choosing Restore Previous Session or use last workspace. Because this is 
your first look at MI Pro, choose the Open a Table option to begin. The Quick Start 
dialog will disappear, and the Open dialog displays. 

Opening a Table
Just about everything in MI Pro starts with opening a table. As you learned in the 
previous chapter, you can display the information in your tables in a number of ways 
in MI Pro.  This chapter presents the most common ways to view your data: by 
mapping, browsing or graphing. Viewing a layout of your maps and displaying raster
images are discussed in separate chapters.

 To open your table:
1. Choose File > Open. The Open dialog displays.
2. Choose the drive and directory for the table you want to open. 
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3. Choose the appropriate table (.tab file). When opening multiple tables, use 
Shift-click to select adjacent tables and Control-click to select non-adjacent 
tables.

4. Choose New Mapper from the Preferred View list.
5. Click Open.

A window containing the data from the table displays as a map.

To set a default path you want MI Pro to use when opening tables, click Directories in 
Options > Preferences to display the Directory Preferences dialog. Select the Tables 
path and click Modify directory. Choose the drive and directory you want in the 
Choose Directory dialog and click OK. You can also set default paths for workspaces, 
MapBasic programs, Import files, and DBMS SQL queries.

You can open additional tables from File > Open to add more information (layers) to 
the  Map window. If you want the second table to be displayed in the current Map 
window, leave the Automatic option selected in the Preferred View list.  MI Pro will 
display the table in the current Map window automatically.  

If you do not want the table to display with the first map, choose New Mapper. MI 
Pro opens the second table in its own Map window.

If your data file does not contain graphic objects, you will not be able to display the 
table in a Map window. You can only bring it up in a Browser. You must first geocode 
the table to display it as a map. Geocoding is discussed more fully in Chapter 8. 

You can also open tables without displaying them, making the data available for other 
uses. In this case, choose No View from the Preferred View list box in the Open  
dialog. 

Use the Places Bar to quickly access the specified directory. There are four MI Pro 
Professional Places options: Table; Workspaces; Import Files; Remote Tables. 
Designate each directory path in Options > Preferences> Directories.

If the operating system is Windows 2000, select MapInfo Places to display MapInfo 
Professional specific folders, or choose Standard Places to display the default places.
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Mapping a Table
Opening a table as a map creates a Map menu on the menu bar. Use the Map menu to 
control the look and function of the map. You can change certain aspects of the active 
Map window in the Map Options dialog (Map>Options), such as the map units, and if
the Map window’s projection is appropriate, specify Cartesian calculation methods. 
With the Layer  Control command, you can reorder the layers in the map, change the 
display, add new layers, create and modify thematic maps, change the view, add 
labels and text, and set/change map units and projection. These options are further 
discussed in Chapter 7, Mapping in Layers, and Chapter 11, Thematic Mapping.

To create a new map:
1. Choose Window > New Map Window.
2. Choose the table(s) you wish to display in a Map window and click OK.

Legends
You can create two kinds of legends in MapInfo Professional: cartographic and theme 
legends. Theme legends are those associated with thematic maps. Cartographic 
legends enable you to create a legend for any map layer(s) in your Map window. The 
combination of the two types makes it possible to provide cartographic data for all of 
your map layers.
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Cartographic Legends
Cartographic legends display cartographic data for a map layer. A legend is created 
for each layer in your Map window that you choose to include in the legend. 
Cartographic legends can be displayed in a layout, expanding MapInfo Professional’s 
presentation capabilities. You can create a legend for an individual layer, giving it 
particular emphasis, or you can place legends for several layers in one legend 
window. You can also customize many elements of the cartographic legend and the 
legend window, including the window title, legend frame borders, and the legend 
title and subtitle. Here is a brief description of how to create a cartographic legend:

1. Choose Map > Create Legend. The Create Legend – Step 1 of 3 dialog 
displays. 

2. Select the layers you want to use in the legend and click Next. The Create 
Legend – Step 2 of 3 dialog displays. 

3. Specify the legend properties and legend frame elements and click Finish. 
Your legend displays on the screen. 

For more details on the options available in the cartographic legend feature, see 
Chapter 16, Creating a Cartographic Legend. 

Theme Legends
Theme legends are created automatically when you create a thematic map. They 
provide a key of the colors, symbols, and styles used in the map. Their display is 
controlled via the Show/Hide Theme Legend Window command in the Options 
menu. Use the appropriate command in the Map menu to modify them (Map 
>Modify Thematic Map), or simply double-click on the legend to display the Modify 
Thematic Map dialog. 

If a theme legend is part of a cartographic legend, and you click on it to modify it, the 
Modify Thematic Map dialog displays. Click the Legend button to modify the legend. 
For more on theme legends and thematic mapping, see Chapter 11. 
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Browsing a Table
There are times when viewing the tabular data in a table is necessary. In MapInfo 
Professional, this is called browsing the table. 

To browse a table:
1. Choose Window  > New Browser Window.
2. Choose the table you wish to browse and click OK

The Browser shows the fields of the data table (column headings) and the records of 
data (rows).

A Browse menu item is now available to give you further functionality. Choose 
Browse > Pick Fields to display only the columns of data you want to see. If you wish 
to show information that is only implicit in the base table, in the Pick Fields dialog 
choose Expression from the Fields in Table list. For more on expressions see Deriving 
Columns in Chapter 10, Selecting Using Queries, or Expression in the MapInfo 
Professional Reference.

If you wish to show or hide the Browser window grid, choose Browse > Options.

You can add new records to the Browser. First, choose Edit > New Row to add a row 
(or use Ctrl-E). You can enter text directly into each field. As you type, press Tab or 
Shift-Tab to move from field to field.  You must remember to save the new 
information to the base table before exiting the program. 
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The square box to the left of each record in the Browser window is the select box. Click 
on it to select the record in the Browser window and also in the corresponding Map 
window. To add records to the selection, shift and drag to select consecutive records, 
or shift-click on non-consecutive records.

Selecting records creates a subset of the table that you can browse, map, or graph, just 
like the full table. More on selecting is found later in this chapter and also in Chapter 
9, Selecting.

You can also create a report of your tabular data using the Crystal Reports 
functionality included with MapInfo Professional. The Crystal Reports User’s Guide 
has also been included online to help you get the most out of this powerful report 
writing program. See the Installation chapter for information on how to access the 
User’s Guide. 

raphing
MapInfo Professional’s graphing feature enables you to create detailed graphs that 
allow you to visually compare your data. You can create 3D, bar, line, area, histogram, 
bubble, scatter, and pie graphs. To create a graph:

1. Choose Window > New Graph Window. The first step of the Graph wizard 
displays.

2. Choose a graph type, and choose a template. Click Next. Step 2 of the wizard 
displays.

3. Choose the table and fields you want to graph, and click OK. 

Your data now appears as a graph in a new Graph window. The Graph menu now 
displays on the menu bar. Use the Graph menu to customize the look of your graph. 
There are many formatting and editing options to choose from. Some of these are 
specialized, based on the type of graph you created. 
apInfo Professional User�s Guide 69

Apple Inc. 
Exhibit 1021 

Page 081



Chapter 5: Basics of Desktop Mapping
If you are using graphs created in versions of MapInfo Professional prior to version 
5.5, and you bring them into version 7.0, you will not be able to use the new graphing 
options on those graphs. The pre-5.5 Graph menu displays for  these graphs. For 
information on the older graphing options, see the MapInfo Professional Reference. 
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A fundamental function of MapInfo Professional is selecting objects or records so that 
you can perform additional tasks on them.

Selections are temporary tables. When you make a selection, MapInfo Professional 
creates this temporary table to store the records you’ve selected. You can perform 
many of the tasks with a selection table that you can perform with a permanent (base) 
table:

• View it in a Browser, Map (if it has graphic objects), Graph, or Layout 
window. 

• Cut and copy it into the clipboard and paste it into another table, or even into 
another application.

• Use it to edit a table. If you want to edit only certain records in a table, you 
can get those records into a selection and then edit that selection.

• Make a further selection from it. 

To convert selections into permanent tables, use the File > Save Copy As command. 
Once you’ve saved the temporary selection table as a permanent table, you can treat 
the new table like any other table. 

Selection tables are totally dependent on the table from which they were created. If 
you close a base table, all associated selection tables are deleted.

Making Selections
MapInfo Professional gives you a number of commands and tools for making 
selections. They fall into two categories:

• Selecting from the screen: Select tool, Invert Selection tool, Radius Select tool, 
Marquee Select tool, Boundary Select tool, Select All command. 

To select records with the tools, click on or encircle the associated graphic objects. To 
select records with the Select All command, choose Select All from the Query menu. If 
you are selecting objects with Select All in a Map window, MapInfo Professional 
displays the menu option with the name of the topmost Selectable layer, for instance, 
Select All from Cosmetic Layer; Select All from States.

• Selecting with queries: Select, SQL Select. 

When you select records with either of these methods, you actually create a logical 
expression that MapInfo Professional uses to select the records. The selected records 
are stored in a query table. For example, the expression SALES > 20000 means that MI 
Pro will select only those records with sales higher than $20,000.
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In some situations, you might want to combine selecting from the screen and 
querying to get the records you want. For example, you want to select all the clients 
who live within 20 miles of a proposed shopping mall and earn more than $30,000. 
You could first select all clients that live within the 20 mile radius using the Radius 
Select tool. Then perform a query on the temporary table, selecting those clients who 
make more than $30,000 a year.

MapInfo Professional calls the current selection, Selection. Once you act on the 
selection (view it in a Browser or Graph window, for example), MI Pro calls it Query1,
Query2, Query3, and so forth, depending on its order in the current session. 

If you make a selection through Select or SQL Select, you can override MI Pro’s 
default name and give the selection a descriptive name.

See Chapter 9, Selecting, and Chapter 10, Selecting Using Queries, for more on these 
topics. 

Inverting a Selection
Using the Invert Selection tool or the correcponding menu command (Query>Invert 
Selection), you can reverse the current selection in a Map or Browser window. Invert 
Selection cancels the current selection and selects all the previously unselected objects 
or records. It is available when there are records or objects selected.

Invert Selection provides  a quick and easy way to select a large number of objects 
from the screen. For example, you have a large table of points displayed on a street 
map. You need to select most of the points for your mapping task. Instead of selecting 
all of the points you need, select the ones you do not need. Then click the Invert Select 
tool or choose Query>Invert Selection. Your current selection is inverted. Every object 
that was not part of the current selection is now selected, and the current selection is 
cancelled.   
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iewing Attached Data 
You will often want to view the tabular data attached to your map objects. Choose the 
Info button from the Main Toolbar. Click on a map object. The Info tool window 
displays the data for that map object. If the table contains many fields, resize the 
window to see more or use the scroll bar to access all of the fields. 

If you click on a location that contains more than one map layer, the Info tool window 
will show a list of all the objects for that location (small Info tool window, below). To 
see the fields associated with one of the objects, click on the name of the object in the 
window. The Info tool window expands to show all the data for the layer. Choose the 
>> button to bring up the next object’s fields. The List button returns you to the list of 
objects for the location.
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Note:  If a layer is editable, you can make changes directly in the Info tool data 
fields when outline boxes surround the data fields. If the layer is not 
editable, no outline boxes will appear. The information in the Info tool List 
window is not editable at any time. 

Closing Tables
Closing a table removes it from active use in your current session. Choose the Close 
command from the File menu to close tables. When you close a table, you 
automatically close all views of that table. If you close a table that is displayed in a 
Map window with other tables, MapInfo Professional removes that table from the 
window, but the Map window remains open. 

In addition, any subset tables of the original table (known as query tables) also close. 
You can use the Close command for any table, whether or not it is displayed in a 
window. 

Click on the layer name here to expand the Info tool 
List window to show all data for the layer.

Click here 
with the 

Info tool to 
display all 
data at this 

location.
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Opening and closing tables is different from opening and closing windows in which 
you view your tables. You can open a table without opening any views of the data. 
Similarly, closing a window does not close the table (or tables) you are viewing in the 
window. They are still open and available for use. To close a window, click the 
Control-menu box in the upper-left corner of any window and select Close.

If you have made changes to a table but have not yet saved those changes, MapInfo 
Professional will ask you if you want to save them before closing the table. To save 
your changes, choose Save Table from the File menu. 

rinting
Once you have created the perfect map or graph, you can easily print the individual 
windows. 

For presentation, use the Layout menu to bring together all views of your mapping 
session. Here, you can combine different types of windows to create an attractive and 
more informative presentation.  Choose Window > New Layout Window to display a 
Layout window that you can use to arrange your maps, browse tables, graphs, 
legends, titles, logos, etc. See Chapter 21, for tips and techniques about working in the 
Layout window.
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Setting Up the Page
Before you print your map or layout, you will need to set up your page. In the Page 
Setup dialog (File>Page Setup), specify the paper size, orientation, and margins. 

Printing Your Map
When you have your page set up the way you want, you are ready to print. Choose 
File>Print to display the Print dialog. The Print dialog allows you to specify printer 
properties, a page range in which to print and the number of copies that will print. 
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Click the Options button to fine-tune the look of the output. A Print Options dialog 
corresponding to the type of window you are printing will display (Map, Browser, 
Graph, 3DMap). For maps, for example, the Map Print Options dialog displays. Here 
you can specify the size of the map, how its contents will display, the scale, and its 
width and height. For details on all the Print Options dialogs, see the MapInfo 
Professional Reference.

Advanced Printing Options
Advanced printing options enable you to specify how you want MI Pro to print your 
map or layout, and tell MI Pro how to handle color and transparency for raster and 
grid images. Click the Advanced button to display the Advanced Printing dialog. 

The options that are selected when you initally display this dialog are the default 
settings, which are set in the Output preferences. The Advanced Printing dialog 
enables you to override the default print settings for individual windows. To actually 
change the default print settings, you must go to the Output preferences 
(Options>Preferences>Output) and change the print settings there. See Chapter 6, 
Working with Preferences for more information. 

Output Methods
You can choose from two types of output methods. Click the button next to the 
method you want to use. The Print Directly to Device method is the printing method 
used in previous versions of MI Pro.  The Print using Enhanced Metafile (EMF) 
method generates an Enhanced Metafile from the print contents, which is then sent to 
the printer. This method produces good quality output while reducing printing time 
and spool sizes, but your printer must be able to handle the metafile. 
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Note:  If you are printing a map/layout that contains a translucent image, you 
must select Print Using Enhancement Metafile (EMF). The Print Directly to 
Device option does not support translucent images.

Display and Color Options
Additional settings control Map window borders, transparency in vector and raster 
images, and color in raster images. Select the check boxes next to the option(s) you 
want. 

To print a border around your Map window, check the Print Border For Map Window 
box  (this options is not available for Layout windows). 

To have MI Pro handle transparent fill and bitmap symbols in vector images 
internally, check the Internal Handling for Transparent Vector Fills and Symbols box. 
If you clear the box, transparency will be handled by your printer. 

When the ROP method is selected, the transparent image is rendered using a raster 
operation (ROP) to handle the transparent pixels. This method is used to draw 
transparent (non-translucent) images on-screen. This method may or may not work 
well when printing.  You will need to determine if your particular print driver 
handles ROPs correctly.

Check the Print Raster in True Color When Possible box to use 24-bit true color to 
print raster and grid images. To be able to print a raster image in true color, the image 
must be 24-bit and the printer must support more than 256 colors. 

Select a dither method from the Dither Method list to use when your image must be 
converted from 24-bit to 256 colors. Choose either the halftone or error diffusion 
dither methods. 

Overriding the Default Printer
The printer listed in both the Print and Page Setup dialogs is the default printer that 
MI Pro uses for all print jobs. This can be either the Windows default printer or a MI 
Pro preferred printer that you select. Set the default printer in the Printer preferences 
(Options>Preferences>Printer). Both of these dialogs include the option of overriding 
the default printer for an individual print job.  

To use a printer other than the one indicated in the Printer preferences to print a 
particular window (Map, Layout, etc.), choose either: 

•  File>Print. Click the Name drop-down list to see a list of the printers you 
have access to, and select the one you want to use. This selection overrides the 
default printer settings for this print job. 
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• File>Page Setup. In the Page Setup dialog, click the Printer to display the 
preferences dialog for the default printer. Click the Name drop-down list to 
see a list of the available printers, and select the one you want to use. This 
selection overrides the default printer settings for this print job. 

Note that the printer override applies only to the window you are currently printing. 
To actually change the default settings, you must go to the Printer preferences and 
specify a new default printer.  See Chapter 6, Working with Preferences for more 
information. 

xporting Files
You can export your Map window to other file formats with the Save Window As 
command (File>Save Window As). This enables you to use your map in another 
application, such as word processing, presentation, or desktop publishing packages. 

To export a file:
1.  Choose File > Save Window As. The Save Window As dialog displays. 

2. Specify the Image Size settings. You can keep the image the same size as the 
window or choose a custom size.  If you choose  Custom, also make any 
desired changes to the width and height of the image. You can make these 
changes in inches or in pixels.

3. If you are saving the window to a raster format, select a resolution for the 
image. Metafile formats do not use the resolution option (WMF, EMF files).

4. Click the Advanced button. The  Advanced Exporting Options dialog 
displays. 
apInfo Professional User�s Guide 79

Apple Inc. 
Exhibit 1021 

Page 091



Chapter 5: Basics of Desktop Mapping
If you are exporting a simple map or layout that does not contain raster or 
grid images, or any transparent fill patterns, you may be able to bypass the 
advanced settings. If you would like to include a border for your exported 
file, though, be sure to  select the Export Border check box. 

5. Complete the dialog according to information in the following section, and 
click OK. 

6. Click Save in the Save Window As dialog. The Save Window to File dialog 
displays. 

7. Name the file and select a file format. 
8. Click Save to save the window to the specified format.  
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Advanced Exporting Options
The Advanced Exporting Options dialog settings allow you to apply the color, 
transparency, and border handling that are available for printed maps to your 
exported files. Note, however, that borders are not exported from Layout windows. 
The settings are the same as in the Advanced Printing dialog. See the Advanced 
Printing Options section earlier in this chapter for a complete description. 

Overriding the default settings also works the same way. As with the advanced 
printing options, the options that are selected when you initally display the Advanced 
Exporting Options dialog are the default settings, which are set in the Output 
preferences. The Advanced Exporting Options dialog enables you to override the 
default export settings for individual file export operations. To actually change the 
default export settings, you must go to the Output preferences 
(Options>Preferences>Output) and change the settings there. See Chapter 6, Working 
with Preferences for more information. 

Supported Export Formats
MI Pro enables you to save to a number of formats. Windows Bitmap is the initial 
default.  The Save Window to File dialog sets the last-used format as the default. The 
supported formats are listed below: 

• Windows Bitmap (*.bmp)

• Windows Metafile (*.wmf)

• Windows Enhanced Metafile (*.emf)

• JPEG File Interchange Format (*.jpg)

• JPEG 2000 (*.jp2)

• Portable Network Graphics Format (*png)

• Tagged Image File Format (*tif)

• TIFF CMYK (*.tif)

• Photoshop 3.0 (*.psd))  
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Using Workspaces
If you work with the same tables repeatedly, you know that opening each one 
individually every time you use it can be tedious. With MI Pro’s workspace feature, 
you can automate this process so you can get back to the business of creating maps 
and analyzing data sooner. 

When you work with MI Pro you generally use many different tables and windows. A
Map window, for instance, is likely to be built of several layers. MI Pro uses workspaces

to save your work setup from session to session. Workspaces prevent you from 
having to reassemble all the pieces of your earlier setup from scratch.  So, you don’t 
have to reopen tables, re-create maps or layouts, resize windows, or do anything else 
just to duplicate what was on your desktop the last time you were using MI Pro. 
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Contents of a Workspace
The workspace is a list of all the tables and windows you are using, stored in a file 
with the extension .wor. The workspace keeps track of the following elements:

• Map, Browser, Graph, 3DMap, and Layout windows, including their size and 
position on the screen

• Query tables created from base tables using either the Select or SQL Select 
statements (queries will not be saved)

• Graphs

• Thematic maps

• Legend windows

• Cosmetic objects

• Labels

• Styles for fonts, symbols, lines, and fill patterns used to display objects

To view the contents in the workspace file, open the .wor file in a text editor or word 
processor. 

aving a Workspace
To save your current work setup, choose File > Save Workspace. MI Pro displays a 
dialog in which you name the workspace and set the directory to which it should be 
saved. When you start your next session, you can open this workspace right from the 
Quick Start dialog and continue where you left off. 

You can change the directory path that MI Pro uses for opening or saving workspaces 
in Directories preferences (Options > Preferences >Directories). In the Directory 
Preferences dialog, click the Workspaces path in the Initial Directories for File Dialogs 
group, and click modify. You can also simply double-click the path. The Choose 
Directory dialog displays. Select the path you want to use, and click OK. 

If you have edited a table (added, deleted, or modified items) you must explicitly save 
those changes first using Save As or Save commands in the File menu. Saving a 

workspace will not save edits you have made to tables in the workspace. 

If you close a window or table and you have thematic maps, graphs, label settings or 
label edits, or cosmetic objects pending, MI Pro will prompt you to save the session to 
a workspace. 
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Opening a Workspace
When you start MI Pro, the Quick Start dialog displays, and the last workspace you 
had open is identified in the dialog. Click on it and MI Pro opens it automatically. You
can now begin working where you left off. 

To open a different workspace at startup, choose Open a Workspace from the Quick 
Start dialog (or File > Open and choose Workspace from Files of type.) to display the 
Open dialog. Choose the workspace you want. All the tables and windows you saved 
to the workspace will display. 

If you are already in a mapping session and wish to open a workspace, choose File > 
Open and choose Workspace from Files of type. Choose the appropriate workspace 
from the list provided.  

You can also open more than one workspace at a time the same way you can open 
multiple files in other Windows applications using the Shift and Control keys. 

If you are currently working with data in various windows, adding a workspace will 
add the workspace to your current setup. This can be very useful if you have files and 
windows in several workspaces to be analyzed. You can save this entire complex —  
the workspace you added plus the material you added it to, by saving it as a new 
workspace.

Use the Close All command to close all tables and windows. For more information 
about opening workspaces, see the sections Open and Preferences in the 
MapInfoProfessional Reference.

Specifying Directories and Search Paths
If you wish to set a default directory for MI Pro to use when opening a workspace, 
click Directories in Options > Preferences to display the Directory Preferences dialog. 
Select Workspaces, and click the Modify button. Choose the drive and directory you 
want in the Choose Directory dialog and click OK. 

To specify search paths that MI Pro will use to look for tables referenced in 
workspaces, in the Search Directories for Tables group, click Add. Specify a drive and 
directory in the Choose Directory dialog and click OK. You can set up to four paths. 
Use the Up and Down keys to change the search order. Use the Add and Remove 
buttons to add or remove paths from the list. 
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When you change the name of a MI Pro table that is listed in a workspace, you 
invalidate that workspace. Table names are stored in the workspace file. If you change 
the name of the table, the workspace does not know how to find it. 

For example, you might create a workspace called customer.wor which contains the 
states table. If you later rename the states table to america, MI Pro will not be able to 
open the customer.wor workspace. It will try to open the states table and not be able 
to locate it.

There are two ways to avoid this problem:

• Make any table name changes before you start to build workspaces. 

• Open the workspace table in any text editor and manually change the table 
names.

• Open a workspace. Rename the table(s) using Table > Maintenace > Rename 
Table and immediately save the workspace.

MapInfo Professional v. 6.0.0.32  and later places an "interactive" clause after each 
open table statement to prompt you for the file location if the table is not found in the 
original workspace path. The old workspace must be saved in this version to take 
advantage of this feature. 
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Leaving MapInfo Professional–The Mapinfow.wor Workspace
To leave MapInfo Professional, choose File>Exit. If there are any tables open that you 
have edited, MI Pro asks if you want to save them. You can choose to either save them 
or exit and lose those changes.

The Startup preferences allow you to automatically save your work setup to a 
workspace when you exit, and display that setup when you enter MI Pro again. 

To save your setup to the workspace, check the Save MAPINFOW.WOR option in the 
Startup Preferences dialog. To display MAPINFOW.WOR, clear the Display Quick 
Start Dialog check box when you enter MapInfo and select Load MAPINFOW.WOR. 

Starting MapInfo Professional–The Startup.wor Workspace
You have yet another option when saving your work as a workspace. Instead of 
starting MapInfo Professional with the mapinfow.wor, which only opens the tables 
you were last working with, you can specify that MI Pro loads a particular workspace 
on startup every time. 

First, display the tables in the size and position you want to see them at startup. Then, 
at the File > Save Workspace dialog, save the configuration as a file called startup.wor. 
It is important that you save startup.wor to the MapInfo program directory or to your 
home directory (where Windows configuration files such as win.ini are stored) so MI 
Pro can find it at startup. For more on startup.wor, see the entry in the MapInfo 
Professional Reference.
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aving Printer Information to a Workspace
MI Pro enables you to save your printer information to a workspace, and restore 
printer information from a workspace.  These settings are located in the Startup 
preferences. (Options > Preferences > Startup).

To save printer information to a workspace, check the Save Printer Information to 
Workspaces box. When you save your workspace, the printer name, paper 
orientation, paper size, and the number of copies will be saved. When this preference 
is on, the workspace is written as a version 6.0 or later workspace. It is recommended 
that you leave this preference on. If you will be sharing workspaces with other users, 
particularly if they are using earlier versions of MI Pro, you may want to leave the 
preference turned off. 

To restore printer information from a workspace, check the Restore Printer 
Information to Workspaces box. When you open the workspace, the printer name, 
paper orientation, paper size, and the number of copies are restored.  This is useful if 
you are sharing workspaces with other MI Pro 6.0 or later users who are also using the 
same printers. You may want to leave it off if you want to send the workspace to 
someone who is using a different printer.  If this preference is turned off, MI Pro uses 
the default printer selected in the Printer preferences. 

dditional Tools
MI Pro contains many additional tools that simplify mapping tasks, convert MI Pro 
files to different file formats and vice versa, automate tasks for working with DBMS 
tables, and more. The Tool Manager helps you run and manage these many utilities 
easily. 

Use the Tool Manger to run, add, edit, or remove tools from the currently registered 
list of tools in the Tools menu. You can also configure a tool to run automatically upon 
startup. If you performed a Custom installation, you may have elected to not install 
the tools. In this case when you open the Tool Manager dialog, the list box will be 
empty (Tools > Tool Manager). 

A brief description of all the tools is provided below. 
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Tools
• AutoLabeler – Places text object style labels in the Cosmetic Layer of the 

active Map window.

• CoordSys Bounds Manager– Enables you to check and set the coordinate 
system bounds for mappable MI Pro base tables. 

• Concentric Ring Buffer – Creates concentric ring buffers around one or more 
map objects. The tool also computes aggregated values for underlying data 
that occur within each ring. Therefore, it can be used to count how many 
customers occur within each ring and their total sales. You can graph the 
results.

• Coordinate Extractor – Extracts x, y coordinates for each record in your table 
using any projection in the MAPINFOW.PRJ file and places them in 
designated columns. 

• Create Line by Length – Draws lines in the Cosmetic Layer of a specific length 
and angle.

• DBMS Catalog – Allows a DBA to create a MI Pro MapCatalog table in a 
remote database. The catalog is needed for downloading coordinate 
information to MI Pro from a remote database.

• DBMS Count Rows in Table – Updates the MapCatalog entry of a table to the 
correct number of rows. 

• DBMS SQL Builder – Allows you to connect to an SQL database server, build 
queries and execute SQL statements. Additionally, issue queries to preview 
data and download query results to a local MI Pro table.

• Degree Converter – Converts a column of data containing DMS coordinates 
to Decimal Decimals and Decimal Degrees to degrees/minutes/seconds.

• Disperse Points – Disperses points located at the same position. Points can be 
dispersed systematically or randomly.

• EasyLoader – Uploads MapInfo .tab files into remote databases. 

• Grid Maker – Draws a grid of longitude/latitude lines on your map, i.e., a 
graticule.

• Grid Tools – Provides three grid tools: create a MI Pro native grid file from a 
table of points;  convert grids from any format that MI Pro can read into MI 
Pro grid format (.MIG); display x, y, and z coordinates, and row and column, 
of where you clicked on the grid. 

• HTML Image Map – This tool allows you to create an HTML image map from 
a MI Pro Map window for use in a Web page. 

• Labeler – Transfer layer’s labels into permanent text objects; label current 
selection; make individual labels created with the Label tool into permanent 
text objects. 
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• Legend Manager – Take control of how MI Pro displays Legend windows. 
Includes the ability to have multiple Legend windows open, and associate 
each legend with a specific Map window.

• Map Window Manager – Designate the title of a Map window and default 
table view.

• Mapping Wizard Tool – Enables you, via a wizard, to open data, maps, 
perform analysis, and generate output. This utility is set to load automatically 
when you start MI Pro. 

• MapX Geoset Utility – Enables you to read a MapX Geoset into a MI Pro 
Professional Map window, and write a MapX Geoset from the contents of the 
MI Pro Map window.

• MDBLauncher – Launches the MI Pro Metadata Browser.

• Named Views – Save a Map window’s current zoom and center as a named 
view. Return to that view by selecting the view name from a dialog.

• North Arrow - Add a North Arrowto a Map or Layout window in various 
styles, and, optionally, add a Magnetic Declination Arrow. Use the North 
Arrow tool to designate in which corner to position the North Arrow, or use 
the North Arrow button on the Tools Toolbar to draw a rectangle and place 
the North Arrow at the specified location. See North Arrow in the MapInfo 
Professional Reference.

• Overview – Opens a new Map window to provide an overview of another 
Map window.

• Rotate Labels–This tool allows you to rotate all the labels in a map layer at 
once. 

• Rotate Map Window – Enables you to rotate the contents of the current Map 
window a specific number of degrees. It calculates and sets an Affine 
transformation for the Map window. 

• Rotate Symbols–This tool allows you to rotate all the symbols in a map layer 
at once. 

• ScaleBar – Create a custom distance scalebar to annotate a Map window. This 
tool can also be used in Layout windows. 

• Seamless Table Manager – Creates and manages seamless map sheets.

• Search and Replace – Search a character column for a specific string and 
replace it with another string.

• Send to MapX Mobile - Write a custom MapX geoset and associated .Tab files 
to create a user-defined subset of a map window’s background data for 
display on a mobile device. See a full description of MapX Mobile under Send 
to MapX Mobile in the MapInfo Professional Reference.

• Set the Minimum Bounding Rectangle Utility – Enables you to set the 
Minimum Bounding Rectangle for ODBC live access based tables.
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• Shields – Draw decorative frames around text objects.

• Spatialize SQLServer Table - Allows an existing SQL Server table to 
accomodate spatial data. 

• Symbol Maker– Create, edit, and delete MI Pro symbols. These symbols 
become part of the standard MI Pro symbol set.

• Table Manager – Get information about all currently open tables, including 
table metadata.

• TOC Utility- Build a seamless table of all the files listed in a TOC file.  Create 
one or more seamless tables, grouped by zone and resolution

• Universal Translator – Import and export MI Pro data to and from other 
popular mapping files formats. This utility is set to load automatically when 
you start MI Pro.

Using the Tool Manager
To access the Tool manager, choose Tools > Tool Manager. The Tool Manager dialog 
displays. Simply check the boxes of the tools you want to load. The tool will display in 
the menu options of the Tools menu. Check Autoload as well when you want a tool to 

load automatically when you start MI Pro. You can also add tools from the MI Pro 
Tool directory or tools that you have created. 

You can also edit the name, path, and description of a tool. Click on a tool to highlight 
it and click the Edit Tool button to make the desired changes. 

For more information on the Tool Manager, see the MapInfo Professional Reference. 

Many more MapBasic tools are available from www.mapinfo.com and other MapInfo-
related web sites
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Working with Preferences

Preferences allow you to change a number of  
default settings, enabling you to customize 
certain aspects of the program’s behavior. As 
you gain experience with MapInfo 

Professional®, you will probably want to 
change some of these settings. This chapter 
discusses the various preferences and what 
they control.
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Accessing Preferences
All preferences are accessed via Options > Preferences.  Here is a brief description of 
the preference categories:  

• System Settings – Controls what information is copied to the clipboard, color 
defaults, aspect ratio, paper and layout units, the number of Undo objects 
permitted, how symbol types used prior to version 4.0 are drawn, and how 
MI Pro handles 2-digit years.

• Map Window – Controls  settings for resizing a Map window; moving 
duplicate nodes; snap tolerance; units for distance and area; display of scroll 
bars in the Map window; display of degrees in either decimal or degrees, 
minutes, seconds form; and the display of InfoTips. 

• Legend Window – Controls the legend frame default settings.

• Startup – Controls whether MAPINFOW.WOR is saved upon exiting and 
loaded upon starting MI Pro; whether queries are saved in workspaces; and 
the display of the Quick Start dialog upon startup. 

• Address Matching – Controls the placement of house numbers when 
specifying  street addresses.

• Directories – Specifies default directories for opening and saving tables, 
workspaces, MapBasic programs, import files, ODBC SQL queries, theme 
templates, graph support files, saved queries, new grids, and Crystal Report 
files. Also specifies the directories MI Pro searches for tables without fully 
qualified paths referenced in workspaces or MapBasic programs.

• Output Settings – Controls the on-screen display of a raster file, the printer 
output, and exporting choices. 

• Printer – Controls which printer information is used for all new windows.  
This printer can be the Windows default printer, or a printer you designate as
your MapInfo Preferred printer.  This choice can be overridden on a per 
window basis using either the File > Print, or File > Page Setup dialogs.

• Styles--Designate highlighting for selected and targeted objects, as well as 
designating default object styles for region, line, symbol, and text.

Files are stored on a per-user basis. See Appendix C, Data Setting and Management 
for file locations.
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To open any of the preferences:
1. Choose Options>Preferences. The Preferences dialog displays.
2. Click one of the preferences buttons. The specified preferences dialog 

displays.   
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System Setting Preferences
Use the System Setting preferences to control the default settings that affect how MI 
Pro interacts with your system.

 

Copy to Clipboard
Specify what items you want to copy to the clipboard: text, bitmaps, or metafiles. MI 
Pro now copies metafiles in Enhanced Metafile format (EMF). All three are copied to 
the clipboard by default. Clear the appropriate check box(es) to prevent the item from 
being copied to the clipboard. 

Color Defaults
This preference controls how MI Pro shades thematic map layers. By default, Monitor
Setting is selected. MI Pro uses the color settings of the monitor to shade the map 
when this option is selected. Click the Black & White button if you are using a color 
monitor and want to shade your thematic map in gray scale. Click the color button if 
you are using a black and white monitor and want to print a thematic map in color on 
a color printer.
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Aspect Ratio Adjustment
This setting enables you to adjust the screen size so that your printed map is the 
appropriate size. 

Paper and Layout Units
Use this setting to specify the units used when you measure the size of objects in a 
Layout window and the size of paper in the Print dialogs. The default is set to inches. 
You can choose: inches, picas, points, millimeters, and centimeters. 

Number of Undo Objects
Set the number of simultaneously altered objects for which Undo information will be 
saved. You cannot undo the following operations: Revert, Save, Save As, or Modify 
Table, or any operations whose effects are primarily cosmetic. The default is 10 undo 
operations. You can set it from 0 to 800. Setting the number of Undo objects to 0 
deactivates the Undo system. After one use of the Edit > Undo option, the option 
toggles to Edit > Redo.

Pre-Version 4 Symbols
Use this setting to indicate how you want to draw symbols from versions of MI Pro 
earlier than 4.0. Check the Display Using True Type Font box to draw vector symbols 
with characters from the MI Pro Symbols font. Clear the check box to draw vector 
symbols. By default, vector symbols are drawn. 

Date Window for 2-Digit Years
The default is set to Turn date windowing off, which will use the current century for 
2-digit years. 

If you click the Set date window to button, you can specify which century to apply to 
2-digit years. For example, if you enter the number 30 (the default) in the Set date 
window to box, the statements below the option indicate how the century is assigned 
based on the number you type in the box. For example, based on the number 30, 2-
digit years from 00–29 are set in the 21st century, and 2-digit years from 30–99 are set 
in the 20th century.  
apInfo Professional User�s Guide 95

Apple Inc. 
Exhibit 1021 

Page 107



Chapter 6: Working with Preferences
Map Window Preferences
The Map window preferences control the default settings for any new Map window 
created in MI Pro. Some of these preference settings can be overridden for the 
currently open Map window in the Map Options dialog (Map>Options).  These 
include the settings for resizing Map windows, specifying distance/area calculations, 
and displaying coordinates in degrees, minutes, seconds.

Default Projections
Designate a default table projection for creating new tables, importing MIF, MBI, and 
IMG files, and for Choose Projection options in dialogs. Override the defaults by 
accessing the Choose Projection option. This feature is not available for Universal 
Translator, ArcLink, or Importing DXF files.
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Use the Session Projection option to designate a default MapBasic projection for 
returning coordinate values using a MapBasic window or Update Column.  Compiled 

MapBasic applications are not affected by this preference.  

Setting Warning Display
By default, MI Pro displays messages prior to closing a table warning you of the loss 
of Cosmetic objects, map labels, and thematic layers if you do not save them to a table 
or workspace. You can turn off the display of these warning messages. To do so, clear 
the desired check boxes from the Warn Prior to Loss of group. 

Resizing Map Windows 
These options control the default behavior of Map windows when you resize them. 
The default setting is Fit Map to New Window. This setting draws the map to fit the 
resized window. You see the same view of the map that you saw before you resized 
the window. Click the Preserve Current Scale button to change the view of the map 
when the Map window is resized. As you shrink or enlarge the window, you will see 
a smaller or larger area of the map. 

This setting does not affect Map windows that are already open. To override the 
preference settings for the currently open Map window, choose Map>Options. 

Moving Duplicate Nodes
The Move Duplicate Nodes in settings specify whether MI Pro will move duplicate 
nodes when you use the Reshape command (Edit>Reshape) to edit objects that are 
adjacent to each other, such as regions. By default, MI Pro does not move duplicate 
nodes. To have MI Pro move duplicate nodes that are in the same layer when one of 
the connected nodes is moved, click the Same Layer button in the Move Duplicate 
Nodes in group. 

Setting Clip Region Method
Use these settings to specify how you want MI Pro to clip regions. You have three 
choices:

• Windows Device Clipping (all objects) – The clipping is controlled by the 
Windows Device Display. All objects (including points, labels, text, raster and 
grid images) will be clipped at the Clip Region boundary. This is the default 
setting.
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• Windows Device Clipping (no points, text) – Use this method to emulate the 
Erase Outside clipping method used in previous versions of MapInfo 
Professional. All objects are clipped using Erase Outside except points and 
labels. Points and labels will be completely displayed only if the point or label 
point lies inside the Clip Region object.  Text objects, raster files, and grid files 
are always displayed and never clipped. 

• Erase Outside (no points, text) – This method uses the MI Pro Erase Outside 
functionality. This clipping method is used in all versions prior to MI Pro 6.0.  
The Clip Region object is the Cutter object, and all other objects are Target 
objects for this operation.  All objects are clipped using  Erase Outside, 
excepts points and labels. In addition, points and labels will be completely 
displayed only if the point or label point lie inside the Clip Region object.  
Text objects are always displayed and never clipped. 

Distance/Area Calculations
Use these settings to specify the default type of distance/area calculation that MI Pro 
uses for new Map windows. Spherical is the default. Spherical calculations measure 
distance according to the curved surface of the Earth. The data is first converted to 
Latitude/Longitude and then a calculation is produced. Lat/Long data will always 
use spherical calculations. 

The Cartesian method performs calculations on data projected onto a flat plane. 
Cartesian coordinates (x,y) define the position of a point in two-dimensional space by 
its perpendicular projection onto two axes which are at right angles to each other. 
Long/Lat projections cannot use Cartesian calculations. 

To specify a calculation method for the currently active Map window, use the Map 
Options dialog (Map>Options). 

Displaying Metric Distance and Area Units
By default, MI Pro displays distance in miles and area in square miles. To use metric 
units, check the Metric Distance and Area Units box. MI Pro will then display distance 
in kilometers and area in square kilometers. 

Displaying Scrollbars and InfoTips
By default, MI Pro displays InfoTips. Clear the Show InfoTips check box to deactivate 
their display.

By default, MI Pro does not display scrollbars in Map windows. To display scrollbars, 
select the Scroll Bars check box. 

Select the Autoscroll check box to automatically activate the autoscroll feature.
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Automatic Zoom Layering for Raster and Grid Layers
Automatic zoom layering options for raster and grid layers can be set in the Map 
window preferences. Raster zoom layering is turned on by default, and grid zoom 
layering is off by default. 

3DMap Window Hardware Acceleration
This check box controls whether to use your video card acceleration capability to 
display 3DMaps. Clear the box to display the 3DMap without using your video card 
acceleration capability. Turning the acceleration off will reduce performance, but it 
will avoid failure with certain graphic adapters and drivers. 

Displaying Coordinates
By default, MI Pro displays coordinates in decimal degrees. MI Pro displays 
coordinates of objects in the Object Info dialogs, and of the cursor location in the 
status bar if that display option is selected. To change the format in which coordinates 
display, select one of the options in the Display Coordinates group. In addition to 
decimal degrees, you can display coordinates in degrees, minutes, seconds or in 
Military Grid Reference System format.  Coordinates are converted to the Military 
Grid Reference System format using the World Geodetic System (WGS) of 1984 
Ellipsoid.

To override this preference in individual maps, use the Map Options dialog 
(Map>Options).  Overrides to the default coordinate setting will be saved to your 
workspace. 

When Military Grid Reference System format is selected in either the Map window 
preferences or the Map Options dialogs, the format will display in the status bar, but 
not in the Object Info dialogs.  If you display any Object Info dialog for an object on a 
map that uses the Military Grid Reference System, the coordinates will be displayed 
in decimal degrees. 

Setting Snap Tolerance 
This setting specifies the default tolerance in pixels within which Snap to node 
operates when you are drawing objects (click the S key to turn Snap to node on). The 
default is 5 pixels. Type in a smaller value to obtain a tighter snap tolerance, so that 
you do not snap to other objects’ nodes as you draw. Type in a larger value to obtain a 
looser snap tolerance, when you want to snap to a node even though you are 
relatively far away from it. 
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Specifying a Grid Handler
MI Pro supplies a list box to select the output grid file format. By default, the MI Pro 
handler (*.mig) will be selected. The available formats depend on which grid handlers
are installed. When you change the grid file format, the file extension on the grid file 
name changes to reflect the selected format. 

Legend Window Preferences
These settings control the defaults for how titles are specified for all legend frames in 
the legend window, as well as the default text style attributes such as font and size. 
The settings correspond to the settings displayed in Step 2 of the legend wizard. These
defaults are used if there are no metadata keys in the table on which the legend frame 
is based. If metadata keys are present, the metadata defaults override the settings in 
Step 2 of the wizard and the Legend preferences.

 

Legend Frame Defaults
The Title Pattern box indicates the text that displays at the top of each legend frame. 
By default, the Title Pattern is “# Legend”, where ‘# ’ is the name of the layer on which 
the frame is based. So, if the frame is based on the States layer, the default Pattern title 
would be “States Legend.” You can change this pattern to “Legend of #” or simply 
”#.” You may wish to have no default pattern. In that case, leave the box blank.  
Choose a title pattern default that suits your needs. The #  character can be used in any
of the pattern text boxes as a shortcut key for the layer name. 

The Subtitle Pattern box is blank, by default, but you can set your own default title 
pattern for subtitles. 
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In the Style Name Pattern box, the default pattern is the ‘%‘ character. The Style Name 
is the text that describes each symbol in a legend frame. The % character is used as a 
placeholder for the type of object the legend symbol corresponds to: point, line, or 
region. You can type in your own default Style Name Pattern, either using the % 
character or not. For example, in a legend frame based on the States layer, a Style 
Name Pattern that reads “% of #” will display as “Region of States” next to the  
symbol in the legend. The % character can only be used in the Style Name Pattern box. 

To change the defaults of the style attributes for the titles the style name, or the legend 
frame border, click on the desired style box to display the corresponding style dialog 
and make your changes. 

For more information on legends and legend preferences, see Chapter 7, Mapping in 
Layers.

tartup Preferences
In general, the Startup preferences control how MI Pro behaves when you start the 
program, allowing you to control the MAPINFOW.WOR workspace, as well as 
whether printer information and queries are saved to workspaces

.

Saving and Loading MAPINFOW.WOR
These settings allow you to automatically save your work setup to the workspace, 
MAPINFOW.WOR, when you exit MI Pro, and will display that setup when you 
restart MI Pro. 
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To save your setup to the MAPINFOW.WOR workspace, check the Save 
MAPINFOW.WOR box. To display MAPINFOW.WOR when you enter MI Pro, check 
the Load MAPINFOW.WOR box. For this check box to be available, you must clear 
the Display Quick Start Dialog check box. 

Saving Queries in Workspaces
Check the Save Queries in Workspaces box so that queries you create during a 
mapping session through the SQL dialog will be saved to the workspace. 

Printer Information 
The Printer Information preferences enable you to specify whether you want your 
printer information to be stored in a workspace. The Save printer information into 
Workspaces check box saves the printer name, paper orientation, paper size, and the 
number of copies from your printer settings into the workspace. This also includes 
any overrides you might have made to the default printer settings in the Printer 
preferences.

When this preference is on, the workspace is written as a version 6.0 workspace. It is 
recommended that you leave this preference on. However, if you will be sharing 
workspaces with other users, particularly if they are using earlier versions of MI Pro, 
you may want to leave the preference turned off. 

To restore printer information from a workspace, check the Restore Printer 
Information to Workspaces box. When you open the workspace, the printer name, 
paper orientation, paper size, and the number of copies are restored.  This is useful if 
you are sharing workspaces with other MapInfo Professional (6.0 or later) users who 
are also using the same printers. If this preference is turned off, or if the printer 
indicated is not available, the printer settings for the workspace revert back to the 
default printer set in the Printer preferences. 

Default DBMS Connection
Specify a DBMS connection that will be opened each time you begin a MapInfo 
Professional session.

Quick Start Dialog
The Quick Start dialog, as explained in Chapter 5, displays automatically when you 
start MI Pro. 
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It is set to display by default, but you can set it so that it does not display at all when 
you start MI Pro. Clear the Display Quick Start Dialog check box to prevent it from 
displaying when you start subsequent MapInfo sessions. 

ddress Matching Preferences
Use the Address Matching preferences to specify the placement of the house number 
in addresses. The default setting is for house numbers to come before the street name. 
You can change it so that the house number comes after the street name.

   

irectory Preferences
The Directory preferences enable you to control in what directories MI Pro looks for 
files.
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Initial Directories for File Dialogs
Use this setting to specify the default directories that display in the File menu dialogs 
when you open or save different files. You can specify directories for: 

• Tables

• Remote Tables

• Workspaces

• MapBasic programs

• Import files

• DBMS SQL queries

• Theme templates

• Saved queries

• New grids

• Crystal Report files

• Graph support files

• Shapefile Tables

For example, to set a default directory for MapInfo to use when opening or saving a 
workspace, select Workspaces, and click the Modify button. Choose the drive and 
directory you want in the  Choose  Directory dialog and click OK. 

When you choose File > Open, you can select an icon from the MapInfo Places Bar.  
Click on the Workspace Directory icon to display the workspace directory you 
designated in this preference.

Additionally, use this preference to search for raster and grid tables.  If you open a 
*.TAB file for a raster or grid image and the image file cannot be found an attempt is 
made to find the image in the same location as the .TAB.  If the image file is not found,
it will then use the Search Directories.

Search Directories for Tables and Workspaces
Use this setting to specify search paths that MapInfo will use to look for tables 
referenced in workspaces or MapBasic programs that do not have fully qualified 
paths. To specify a search path, in Search Directories for Tables group, click Add. 
Specify a drive and directory in the Choose Directory dialog and click OK. You can set
up to four paths. Use the Up and Down keys to change the search order. Use the Add 
and Remove buttons to add or remove paths from the list. 
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utput Settings Preferences
The Output Settings allow you to control raster and grid file color settings for on-
screen display, printed output, and file export. In addition, you can also specify how 
you want to handle transparency in vector and raster files in both your printed output 
and exported files. Other printer settings enable you to specify an output method and 
whether to print a border around a Map window. 

You can override the settings in the Output settings preferences in the Advanced 
Printing dialog. These preferences are the default settings used in the Advanced 
Printing dialog. These new settings can then be saved in a workspace. 

Display Settings
The Display settings control the on-screen display of a raster or grid file. Check the 
Display Raster In True Color When Possible box to display raster and grid images in 
24-bit true color. This option can be executed when the image is 24-bit and the screen 
color depth is greater than 256 colors. 
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The Dither Method list enables you to choose a dither method when it is not possible 
to display the image in true color.   Choose from either the halftone or error diffusion 
dither methods.  The selected method will be used if a 24-bit image must be converted 
to 256 colors. This happens when the image is 24-bit, but the screen color depth of the 
monitor is less than 256 colors.

Printer Settings
The Output Method options give you the choice of printing your maps and layouts 
using the same method used in previous versions of MapInfo Professional (Print 
Directly to Device), or using the new Enhanced Metafile printing method (Print Using 
Enhanced Metafile). This process generates an enhanced metafile containing the print 
contents and sends the enhanced metafile to the printer. This option can result in 
much better printing performance without sacrificing quality, but your printer must 
be able to handle the metafile. 

A number of check boxes allow you to specify various output settings. These are: 

• Print Border For Map Window – Select this check box to place a black border 
around your output. 

• Internal Handling for Transparent Vector Fills and Symbols – Select this check 
box to have MapInfo handle transparent fill patterns and bitmap symbols for 
vector images internally.  Clear the box to have the printer handle them. 

• Use ROP Method  to Display Transparent Raster: ROP method determines 
how to display transparent images.  When this option is checked, the same 
method is used as is used for on-screen display of transparent images.  This 
method may  not be suitable for printed output. You should determine the 
setting appropriate to your output requirements. 

•  Print Raster in True Color When Possible – This is similar to the Display 
settings above, except it is applied to your printed output. Select the check 
box to print your raster and grid images in 24-bit true color, if possible. 

Also choose a dither method from the Dither Method list. Choose either halftone or 
error diffusion. The selected dithering method will be used when your image cannot 
be printed in 24-bit true color. 

The Printing settings are used as the defaults for the Advanced Printing dialog. To 
access them, choose File>Print. The Print dialog displays. Click the Advanced button 
to display the Advanced Printing dialog. Change the output settings as appropriate to 
override the preferences. Any changes you make will be saved to your workspace. 
When you open the workspace the next time, your changes will be restored to the 
dialog.  
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Window Export Settings
The Window Export settings are the same as those for your printed output. You can 
include a border around the contents of the exported file, specify internal handling of 
transparency in vector files (fill patterns and symbols), and raster and grid images, 
and use true color when possible in an exported raster file.  Just select the check boxes 
next to the settings you want to enable. 

These settings are used in the Advanced Export Window Options dialog (File>Save 
Window As>Advanced). To override the preferences for window export, click the 
Advanced button in the Save Window As dialog. The Advanced Export Window 
Options dialog displays. Change the export settings for your file as appropriate. 

rinter Preferences
Use the Printer preferences to specify the printer you want to use as the default for 
your work in MapInfo. You can use the Windows default printer, which is set in the 
Windows Control panel, or set up a MapInfo preferred printer.

 

If you select the Windows Default printer, MapInfo will always use the printer that is 
currently set as the default in Windows. The settings for that printer will display in 
the MapInfo Preferred Printer Setup group. You will not, however, be able to change 
them in the Printer Preferences dialog. To change the Windows default printer, go 
back to  the Windows Control Panel. 
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To set up a MapInfo preferred printer, click the MapInfo Preferred button. The options 
in the MapInfo Preferred Printer Setup group are activated. This enables you to 
specify a preferred  printer for new windows.  Select the printer name and path from 
the Name drop-down list. The printer status, type, and location display in the Status, 
Type, and Where fields. Next, specify a paper size, and choose the orientation you 
want: portrait or landscape. 

To use a printer other than the one indicated in the Printer preferences for a particular 
window (Map, Layout, etc.), choose either: 

• File>Print. You can change the printer you are using in the Print dialog, 
overriding the default printer settings. 

• File>Page Setup. In the Page Setup dialog, click the Printer to display the 
preferences dialog for the default printer. Select a different printer in the 
Name drop-down list. This will override the default printer set in the Printer 
preferences. 

Note:  The printer override applies only to the window you are currently 
printing. To actually change the default settings, you must go back to the 
Printer preferences and specify a new default printer.  
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tyles Preferences

Default Object Styles
Designate the default pattern, foreground, background and borders for objects.

Highlighting Objects
Specify the line and fill styles of selected and target objects, as well as highlighting 
specifications in the Map window. Additionally,  specify the style of selected and 
target Multipoint objects. The default settings are shown in the Style boxes of the 
Highlight Control group. Click on one of the boxes to display the corresponding style 
dialog and change its settings. 
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Mapping in Layers

This chapter presents the relationship between 
tables and maps and how they are layered to 
create the level of detail you want. It explains 
the Layer Control feature, shows some of the 
map display options in the Map menu, and 
discusses different types of map layers such as 
seamless, thematic, and raster, and their 
relationship with the other layers in your map. 
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Maps as Layers
You have already been introduced to the concept of computer maps as a collection of 
layers in the previous chapter. Each database table that contains graphic objects can be
displayed as a layer in a Map window. For example, you can display a table of 
customers, a table of streets, and a table of county boundaries.

Think of these layers as transparencies where each layer contains a different part of 
the map. The layers are stacked one on top of the other and allow you to see all 
aspects of the map at the same time. For example, one layer may contain country 
boundaries, a second layer may have symbols that represent capitals, and a third layer
might consist of text labels. Laying these transparencies one on top of the other builds 
a complete map.
If you have geographic locations associated with the records in your database, you 
can open it as a layer in a Map window. (If not, you can add them by geocoding your 
table, a process that is discussed in the next chapter.)

For example, you have a table of public telephone locations with information on 
frequency of use and maintenance records for Arlington, Virginia. Display the table in
a Map window. You can also display a table of city streets and a table of your service 
zones as additional layers in the same Map window. 

You can now see how many public telephones are in each service area just by counting

how many symbols appear within each boundary (or let MapInfo Professional® count 
them for you). MI Pro can thematically shade the boundaries according to the number 
of phones per area. 
112 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 123



Chapter 7: Mapping in Layers

M

C

The point markers for the calls can also be shaded. You can use different colors or 
symbols for the point markers to indicate the number of calls per phone. 

Now let’s get into the specifics of creating a map. 

reating a Map
Creating a map in MI Pro begins once you open your table(s). For instance, if you 
want to create a map consisting of a layer of U.S. cities and a layer of states, you can 
do it in one of several ways.

No Tables Open
Choose File > Open, and select the states table and the city_1k table. Remember, to 
select nonadjacent tables, hold down the Ctrl key as you click on each table. Choose 
Automatic from the Preferred View list, and Click OK. MI Pro places the layers in the 
correct order and displays the map. 

Table(s) Open but Not Displayed
When one or more of your tables is open, but is not displayed in your Map window, 
you can display them in two ways:

• Window > New Map Window
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If, for example, you opened both the states and the city_1k tables, but only displayed 
the states table in a Map window, you can display the city_1k table with the states 
table using the New Map Window command. 

Choose Window>New Map Window. Choose city_1k in the first list box, and choose 
states in the second list box. MI Pro draws the layers from the bottom up in the order 
you list them. To ensure that your boundaries do not cover your points, list the 
boundary layers below the point layers. Click OK. A new Map window of the city_1k 
and states tables displays.

• Map > Layer Control > Add

You can also go through the Layer Control dialog and add the layer(s) you want to the 
current map. For example, you opened both the states and the city_1k tables, but only 
displayed the states table in the Map window. When you open the Layer Control 
dialog, all the layers currently displaying in the Map window are listed in the dialog: 
the states layer and the Cosmetic layer. The Cosmetic layer is part of every Map 
window and is always the topmost layer. It is discussed later in this chapter. Click the 
Add button and choose the cities layer from the popup menu. Click OK. The city_1k 
layer is added to the Layer list in the Layer Control dialog. MI Pro automatically 
places it in its proper position, above the states layer. Click OK in Layer Control to 
display the cities. 

Note:  You cannot add a layer to a Map window unless the corresponding table is 
open. 

Creating a Duplicate Map Window
There are three ways to create a duplicate view of your Map window: 

• You can create a second view of your map with the Map>Clone View 
command. Clone View creates a duplicate Map window that you can then 
alter to create a different view of your map, e.g., a street map of a city and a 
zoomed in view of a major intersection, or use a different kind of thematic 
analysis for each view. It is particularly useful when you are creating a Layout 
and you want to present side-by-side views of the same location. 

Note:  Cloned windows in a workspace are written as MapBasic commands to the 
.WOR file. These command statements cannot exceed 32,000 bytes.

• Another way to create a duplicate Map window is to use the Drag Map 
Window tool. Drag the map to another part of your desktop and release the 
mouse. A duplicate Map window displays. 
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• You can also use the Copy Map Window command in the Edit menu to copy a 
Map window to the clipboard and then paste a copy of it back to your MI Pro 
desktop.

Clipping a Map
Map clipping enables you to clip a portion of your map and display it by itself. Any 
thematic maps, labels, or points displayed on the map will display only for the 
clipped area. You can also save the clipped map in a workspace. 

First, select the region you want to clip. It must be in a selectable layer. You can use 
any of the selection tools. Then choose Map>Set Clip Region or click the Set Clip 
Region button. The map redraws, displaying only the selected region. To revert back 
to the full map, click the Clip Region On/Off button or choose Map>Clip Region Off. 

To retrieve the clipped map, choose Map>Clip Set Region On or click the Clip Region 
On/Off button. MI Pro remembers the clipped map until you create a new one or 
discard the Map window. Using the Clip Region button, it is easy to toggle back and 
forth between the clipped and the full map. When you try to clip a region when one 
already exists, MI Pro will ask you if you want to replace the existing clip region.

Below is an example of a clip, using the country of Spain as the Clip Region. The 
Windows device clipping method was used, which clips all text, labels, points, raster 
and grid images at the clipping boundary. 
apInfo Professional User�s Guide 115

Apple Inc. 
Exhibit 1021 

Page 126



Chapter 7: Mapping in Layers
Clipping Methods
You can choose from three clipping methods. Set the default clipping method in the 
Map window preferences. This method will be used for all subsequent mapping 
sessions, until you go into the preferences to change it. The clipping method is also 
saved in a workspace. When you reopen the workspace, the clipping method you 
chose will be restored. See Chapter 6, Working with Preferences, for more 
information. 

To override the clipping method for the current Map window, use the Map Options 
dialog (Map>Options) to specify a different method. 

Select one of the following:

• Windows Device Clipping (all objects) – The clipping is controlled by the 
Windows Device Display. All objects (including points, labels, text, raster and 
grid images) will be clipped at the Clip Region boundary. This is the default 
setting.

• Windows Device Clipping (no points, text) – This method emulates the Erase 
Outside clipping method used in MI Pro Professional prior to version 6.0, but 
provides better performance. All objects are clipped using Windows Device 
Clipping except points and labels. Points and labels will be completely 
displayed only if the point or label point lie inside the Clip Region object. Text 
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objects, raster files, and grid files are always displayed and never clipped 
with this method. 

• Erase Outside (no points, text) – This method uses the MI Pro Erase Outside 
functionality. This clipping method is used in all versions prior to MI Pro 6.0. 
The Clip Region object is the Cutter object, and all other objects are Target 
objects for this operation. All objects are clipped using Erase Outside, excepts 
points and labels. In addition, points and labels will be completely displayed 
only if the point or label point lie inside the Clip Region object. Text objects 
are always displayed and never clipped with this method. 

ayer Control Dialog
The key to controlling your map layers is the Layer Control dialog. You can access it in 
two ways: Choose Map>Layer Control, or click the Layer Control button in the Main 
Toolbar. Layer Control enables you to manipulate the layers and their attributes to 
control the display of the map.

The dialog shows all the layers that make up the current Map window and the status 
of the layer attributes. These attributes are: visible, editable, selectable, and auto label. 
The icons above each check box column represent the attributes. ToolTips display over 
the attribute icons when you move your cursor over them to help familiarize yourself 
with each icon. It is easy to change a layer’s, or multiple layers’, attributes using the 
check boxes. You also have options available to change the Display and Label settings; 
modify any thematic maps you have displayed; and reorder, add, or remove layers. 
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Manipulating Layers for Display

Layer Visibility
The visible attribute in Layer Control controls whether a layer is visible on the map. 
For example, to make a layer invisible, clear the layer’s visible check box. The layer 
will no longer display in the Map window. The table, however, is still open. To make 
more than one layer invisible, select the layers you want. Use the Shift key to select 
contiguous layers. Use the Control key to select non contiguous layers. Select the 
visible check box for one of the selected layers. All the layers’ visible check boxes are 
cleared. When your map re-displays, the selected layers will no longer be visible. This
feature is especially useful when you want to focus on only one or two layers of a 
multi-layered map. 

Reordering Layers 
Map layers display in the order that they are listed in the Layer Control dialog, with 
the bottom layer drawn first and the top layer (which is always the Cosmetic Layer) 
drawn last. It is important to order your layers correctly. 

For example, you have a layer of customer points and a layer of census tracts. If the 
layers are incorrectly ordered in the Map window, MI Pro might draw the customer 
points first and then display the census tract layer second. Your points would be 
obscured by the census tract layer.

You can reorder how layers are displayed in a Map window two ways. You can still 
use the Reorder buttons. Select the layer(s) you want to reorder and choose either the 
Up or Down button to move the layer(s) to a position above or below its current 
position. Another way to do it is to click on the layer and drag it to its new position. 
When you click and drag a layer, the cursor changes. As you move the cursor, a 
marker displays to the left of the layers indicating the layer’s new position when you 
release the mouse. If you cannot move a layer to a particular position (e.g., attempting
to move a layer above the Cosmetic layer), the cursor changes to a circle with a slash 
through it to let you know that you cannot move the layer to the proposed position. 
You can also do this with multiple layers at a time. Since the Cosmetic layer is always 
the top layer, reordering has no effect on it.

Layer order is also important when you use the Select tool. The Select tool selects 
objects from the topmost Selectable layer. If you have several objects at the same 
location, it is difficult to select the exact one you want. You can reorder your layers in 
Layer Control so that the layer you want to select from is the new topmost layer.
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Ordering Objects in a Layer
MI Pro does not allow you to control the front-to-back ordering of objects within a 
single map layer. If you are editing a table, and you draw a line on top of a circle, the 
line might appear in front of or behind the circle; you cannot control whether it is in 
the front or the back. You can, however, control the front-to-back ordering of objects in 
a Layout window.

If you need to control the ordering of objects (e.g., you need to make sure that your 
lines display on top of your regions), put the different object types in separate layers. 
Put your line objects in one table, and put your region objects in another table. Then 
use the Layer Control dialog to order the layers.

Adding and Removing Layers
Using the multi-select functionality, it is very easy to add or remove multiple map 
layers. To add more than one layer to the map at a time, click the Add button. Select 
the layers you want from the list. Use the Shift key to select adjacent layers, and use 
the Control key to select nonadjacent layers. Click OK. The layers are added to the 
Layer list. MI Pro orders them for you automatically. Removing layers works 
similarly. Select the layer(s) you want to remove and click the Remove button. The 
selected layers are removed from the Layer list. Click OK in the Layer Control dialog 
to redisplay the map. 

Display settings for each layer are available in the Display Options dialog, discussed 
in the next section.

isplay Options
The Display Options dialog enables you to customize the display for each layer in a 
Map window. In Layer Control, either select a layer and click on the Display button, 
or double-click on the layer to bring up the Display Options dialog. There, you can 
change the default styles for the layer, set the zoom at which a layer displays, and 
show line direction, object nodes and centroids. 
apInfo Professional User�s Guide 119

Apple Inc. 
Exhibit 1021 

Page 130



Chapter 7: Mapping in Layers
Display Mode 
When you first open a Map window, boundaries, lines, points, and text are all 
displayed using defaults in the map file. You can change how objects display by using 
the Display Mode section of the Display Options dialog. 

For example, you want to change the display of your streets to dashed red line. In 
Layer Control choose the street layer and choose the Display button. This brings up 
the Display Options dialog. Select the Style Override check box to activate the Style 
Override button (large gray button). MI Pro only displays the override buttons that 
are appropriate for the type of objects in the layer. For example, if the layer contains 
streets, a line style override button displays. Click on it to access the Line Style dialog 
where you can change the width, style, and color of the streets. If the layer contains 
labels, a font style override button also displays.

For boundary layers, the Style Override button brings up the Region Style dialog 
where you can change both the fill and borders of boundaries. The Symbol Style 
dialog displays when you want to override the style for layers containing symbols or 
points. The Style Override is only in effect during the current work session, as are the 
other display settings. To make them permanent, save the table to a workspace. 

For raster layers, the Style Override button brings up the Adjust Image Styles dialog. 
where you can adjust the brightness, contrast, grayscale, translucency, and 
transparency.
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Zoom Layering 
Sometimes you want a map layer to display only at certain zoom levels. Zoom Layering 
controls the display of a map layer so that it displays only when the map’s zoom level 
falls within a preset distance.

For example, you have a layer of streets and a layer of ZIP Code boundaries. When 
you zoom out past 10 or so miles, the streets look like a black smudge in the window. 
This is because the zoom (window width) is too wide to show detailed street maps. 

Use Zoom Layering to tell MI Pro to display the street layer only when the zoom is set 
to a distance that allows you to see the street detail properly, for instance, less than 5 
miles.

The first map doesn’t have zoom layering set for its street layer. At a zoom of 15 miles 
across, notice how difficult it is to see any detail. The second map has zoom layering 
set to display the streets when the zoom is less than five miles. Therefore, the streets 
layer does not display when the window is set at 15 miles. 

To set zoom layering, select a layer in the Layer Control dialog, and choose the 
Display button. The Display Options dialog displays. Click the Display within Zoom 
Range box to activate the zoom distance boxes. Specify a minimum and maximum 
distance within which you want the layer to display. Note that you cannot change 
Display settings for more than one layer at a time. If you have more than one layer 
selected, the Display, Label, and Thematic options are unavailable.
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Different layers in the same Map window can be displayed at different zoom levels. 
For example, you have a layer of streets, a layer of county boundaries, and a layer of 
state boundaries. You want the streets layer to be visible only when the zoom level is 
less than eight miles. You want the county boundary layer to display when the zoom 
level falls between 20 miles and 200 miles. You want the states boundary layer to be 
visible only when the zoom level is greater than 100 miles. You can set a different 
zoom level for every layer in your Map window. 

The default zoom layering mode for raster and grid images can be set from the Map 
window preferences. Select the Automatic Raster Zoom Layering and Automatic Grid
Zoom Layering check boxes to activate automatic zoom layering for these images 
(Options > Preferences>Map Window).

Lines, Nodes, and Centroids
The Display Options dialog also allows you to display line directions, nodes, and 
object centroids. Check the Show Line Direction box whenever you want to show in 
what direction line objects are drawn. For example, on a street layer, displaying line 
direction helps you determine in what direction the street numbers go. Check the 
Show Nodes box to display the nodes of objects in a layer. This is helpful for many 
editing procedures. 

The Show Centroids box displays the centroids of each object in a layer. In MI Pro, a 
region’s centroid does not represent its center of mass. Instead, the centroid represents
the location used for automatic labeling, geocoding, and placement of thematic pie 
and bar charts. If you edit a map in Reshape mode, you can reposition region 
centroids by dragging them.

Editable and Selectable Layers 
To make changes to the graphic objects in a layer, you must make the layer editable. 
You can draw objects on that layer, add text, combine, or delete objects. Only one layer
per Map window can be editable at one time.

To make a layer editable, select the Editable check box that corresponds to the layer 
you want to make editable in the Layer Control dialog (choose Map > Layer Control, 
or click the Layer Control button in the Main toolbar). You can also control the 
editability of the layer via the Status Bar at the bottom of your screen. To change the 
editable layer from the Status Bar, click the Editing box to display a list of the layers 
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used in the Map window. Choose the layer you want to make editable. Its name 
displays in the Status Bar. To deactivate editability for all the layers, choose None. 

If you only want to select objects for further analysis rather than change the objects, 
make the layer selectable. More than one layer can be selectable at a time. If a layer is 
editable, it is automatically selectable. 

To make a layer selectable, select the Selectable check box that corresponds to the 
layer you want to make selectable. To make more than one layer at a time selectable, 
select the layers you want, and select the Selectable check box for one of the layers. All 
the selected layers are now selectable. The multi-select functionality does not work for 
the Editable attribute because only one layer at a a time can be editable in a Map 
window. 

For example, you want to find all customers who live within a fifty mile radius of 
Boston. To create this subset, the customer layer must be selectable. If the map also 
includes a layer of hospitals (which you do not want to include in the radius search), 
turn off the Selectable option for the hospital layer. 

Keep in mind that the Editable or Selectable options only apply to the Map window 
itself. You can always select objects using the Select or SQL Select commands 
regardless of whether a layer is selectable. 

Using the Select and Info Tools with Selectable Layers
As discussed above, the Select tool selects objects from the topmost Selectable layer. 
To select an object that is not in the top Selectable layer, you can turn off the Selectable 
option in Layer Control for every layer above the layer you want to select from. Using 
the multi-select functionality, you can do this in just a few steps. Select the layers, and 
select a Selectable check box for one of the layers. The Selectable attribute is cleared 
for the selected layers. As an alternative, you can leave all layers Selectable and use 
the Ctrl key in combination with the Select tool to cycle through each Selectable layer. 
The Select tool is discussed further in Chapter 9, Selecting.

When you click on a map location using the Info tool where multiple map objects 
overlap, the data tied to the objects each Selectable layer is displayed in the Info tool 
window. If you do not want the information for all layers to display, turn off 
Selectable for those layers in the Layer Control dialog. For more on the Info tool, see 
the MapInfo Professional Reference.
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You can also view an object’s label expression in an InfoTip when you use the Select, 
Info, or Label tools. InfoTips work very much like ToolTips. Using one of these tools, 
place your cursor over an object. An InfoTip displays the label expression for the 
object in the topmost selectable layer. To set InfoTips for a particular layer, adjust the 
Selectable attribute in the Layer Control dialog so that the Tips display for the layer 
you want. InfoTips are active by default, but you can turn them off in the Map 
window preferences (Options>Preferences>Map window). 

The Cosmetic Layer
Every Map window in MI Pro has a Cosmetic Layer. Think of the Cosmetic Layer as 
the blank transparency that lies on top of the other map layers (transparencies). It can 
store map titles and other graphic objects you create during a work session. The 
Cosmetic Layer is always the top layer of the map. You cannot remove the Cosmetic 
Layer, nor reorder it.

Working with the Cosmetic Layer
You can only make the Cosmetic Layer editable or selectable. Other Layer Control 
options (labeling, zoom layering, display mode) are not available for the Cosmetic 
Layer. To select fill patterns, line types, symbols, and text font for the Cosmetic Layer, 
use the Line Style, Region Style, Symbol Style and Text Style commands from the 
Options menu. If the Cosmetic Layer is editable, you can access the style options from 
the Drawing Toolbar.

The contents of the Cosmetic Layer are linked proportionally to the map. Map objects 
(except for symbols) and text in the Cosmetic Layer are proportionally linked to the 
zoom level of the map. If you draw objects in the Cosmetic Layer and then change the 
map’s zoom from 30 to 100 miles, the size of the objects will appear smaller.
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Removing Cosmetic Objects
To clear objects from the Cosmetic Layer, choose Map > Clear Cosmetic Layer. 

Saving Cosmetic Objects
The objects in the Cosmetic Layer are not automatically saved when you close a Map 
window. 

If you want to save objects drawn on the Cosmetic Layer, you must either save the 
table to a workspace or to a table. If you close the table without saving the Cosmetic 
objects first, MI Pro displays the Save Workspace Objects dialog and prompts you to 
do so. You can turn this prompt off in Map Window Preferences. 

You can also save the contents of the Cosmetic Layer to a table. Choose Map > Save 
Cosmetic Objects. You can either transfer the objects in the Cosmetic Layer to an 
existing layer on the map, or create a new layer. For more information on creating new 
layers, see New Table in the MapInfo Professional Reference. 

abeling Objects
The auto label attribute in Layer Control is, by default, cleared for map layers. To 
activate auto labels, simply select the check box for the layer you want to label. When 
you return to your Map window, the map will be labeled automatically. 

Even if you choose not to label your map, you can still see the value of an object’s 
label expression using InfoTips. 

If you prefer, you can label individual objects interactively using the Label tool from 
the Main toolbar. When you click on the Label tool, the cursor becomes a cross hair. 
Click wherever you want a label. MI Pro labels the location with information from the 
layer. If more than one layer is at that location, MI Pro will label with the information 
from the topmost layer.

Whether you choose to label objects automatically or with the Label tool, you control 
the display, content, position, and style of the labels within Layer Control in the Label 
Options dialog. For a complete explanation of labeling and the different options 
available, see Chapter 15, Labeling Your Map. 
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Seamless Map Layers
Use or create a seamless map layer to treat a group of base tables as if they were one. 
A seamless layer allows you to change display attributes, apply or change labeling or 
use the Layer control dialog for an entire group of tables at once. You can also retrieve
information using the Info tool, and select or browse any one of the layer’s base 
tables. A base table can be any regular MI Pro table. Grid layers cannot be made 
seamless.

This feature is especially useful when you want to display a vector or raster backdrop 
for your maps such as joining street or boundary maps. For example, you may have a 
seamless layer of county boundaries made up of several individual county tables.

Opening a Seamless Map Layer
MI Pro includes sample seamless maps or you can create your own. We’ll display a 
sample seamless map:

1. Choose File>Open.
2. From the mapinfo\data\USA\DC\seamless directory, choose Dcwater.

The following seamless map layer of water areas in Washington DC displays.

Notice at first glance that the seamless layer looks like any other MI Pro table. 
However, the Dcmetrow seamless map layer is made up of the following base tables:

• vaarliw.tabArlington Virginia water areas.

• vaalexw.tabAlexandria Virginia water ares.

• dcwashw.tabWashington DC water areas.
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The structure of each seamless layer includes the path name of each base table plus a 
description that defaults to the table name (alias). To view the table structure, turn the 
seamless layer off and display the seamless table in a browser. Refer to Turning the 
Seamless Layer On and Off.

Other sample seamless tables include dc_water and are in the mapinfo\data\USA\ 
seamless directory. 

Characteristics of a Seamless Layer
Since a seamless layer is actually made up of several base tables, MI Pro does treat it a 
little differently than a regular MI Pro table. You can use the following MI Pro features 
with a seamless map layer:

• Layer Control. Use any of the functions except Thematic Mapping from the 
Layer control dialog on your seamless layer. Add, Remove, or Reorder layers 
or set Display, Zoom Layering or Label options for the seamless layer (all base 
tables) at one time. However, you cannot make a seamless layer editable.

• Info Tool. Retrieve information about a particular object in a base table. 

• Select Tools. Select objects from the seamless layer. You can only select a 
group of objects if they reside in the same base table. Press the Shift key while 
clicking the Select Tool to do so. If you attempt to select several objects that 
reside in different base tables, MI Pro will only select objects in one base table. 
If you use the Marquee or Radius select tools and the selected area spreads 
across two different base tables, MI Pro selects the table in either the center of 
the circle or polygon.

• Browse Table. Display a Browser window of a particular seamless table. You 
will be prompted to select a base table. 
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Experimenting with a Seamless Layer
With the Dcwater seamless layer displayed, click the Layer Control button. The Layer 
Control dialog displays.

Notice the seamless layer is referred to by one name, dcwater, in the Layer Control 
dialog. You can add, remove or reorder seamless layers as if they were a conventional 
MI Pro layer. You can also set Label and Display options for all the tables in the 
seamless layer as if they were one table. Notice the editable option for the seamless 
layer is grayed.

Choose your seamless layer and experiment with order, display and labeling options.

To retrieve information from a seamless layer:
1. From the Main Toolbar, click the Info tool.
2. Click on the object for which you want information.

The Info Tool Window displays. It contains the information about the object 
you selected including the name of the base table in which it is stored.
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To browse the seamless layer:
1. Choose Window > New Browser Window. The Browse Table dialog displays.

Select a layer. The Select Base Table Dialog displays.

2. Type the name of the base table you want to browse. We typed XX an 
unknown table.

A Browser window with the base table you selected displays. If a base table 
matching your description is not found, a list of possibilities displays. Keep in 
mind, base tables are treated like any other MI Pro tables. Once a base table 
from a seamless table is browsed, it will be opened as any other regular MI 
Pro table. 
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Specifying Search Paths
You can set search paths that MI Pro will use to look for the component tables of a 
seamless layer. Choose Options > Preferences and click the Directories button. The 
Directory Preferences dialog displays. In the Search Directories for Tables group, click 
Add. Specify a drive and directory in the Choose Directory dialog and click OK. You 
can set up to four paths. Use the Up and Down keys to change the search order. Use 
the Add and Remove buttons to add or remove paths from the list. 

Turning Seamless Layers On and Off
If you need to edit the structure of your seamless layer, you’ll need to turn your 
seamless layer off. To turn your seamless layer off:

1. Choose Options > Show MapBasic Window. 

The MapBasic Window displays.

2. Type: set table tablename seamless off

MI Pro turns off the seamless layer. Display the table in a browser to view or 
edit its table structure. Use the Seamless Table Manager to add or create 
seamless tables.

To turn the seamless layer on:
1. Choose Options > Show MapBasic Window. The MapBasic Window displays.
2. Type: set table tablename seamless on

MI Pro turns the seamless layer on again. 

Creating/Compiling a Seamless Layer
To create your own seamless layer, run the Seamless Table Manager. Your seamless 
layer will be most useful if you use homogeneous tables that ideally have the same 
projection and the same number of columns. For example, you may want your 
seamless layer to contain several counties, each stored in a separate base table, or an 
interstate highway that runs between several states, each stored in a separate base 
table. If your tables are not homogeneous, maps and labels will not display correctly 
and map items will not be selectable. Grid tables cannot be made seamless.

To use the Seamless Manager:
1. Tools > Tool Manager.
2. Check the Loaded box next to the Seamless Table Manager tool. 
3. Click OK. The Seamless Table Manager tool is added to the Tools menu. 

The Seamless Manager will prompt you for information and create your 
seamless layer. 
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hematic and Raster Layers
When you create a thematic map in MI Pro, it is a layer just like any other. It is 
identified in Layer Control by its theme, for instance “State by Population” or 
“Customers by Sales.” You can turn the thematic layer display on or off and modify it 
directly through the Layer Control dialog rather than going to Map > Modify 
Thematic Map. 

For more information about creating and modifying thematic maps, see Chapter 11, 
Using Thematic Mapping to Analyze Your Data.

Raster images are also layers in MI Pro. They appear in the Layer Control dialog just 
like any other layer. The display style of raster images can now be changed on a per-
layer basis within the Layer Control dialog. Highlight the raster layer in the Layer list 
and click the Display button. In the Display Options dialog, select the Style Override 
check box and click the Style button. The Adjust Image Styles dialog displays, where 
you can make changes to the transparency, brightness, contrast, and translucency 
settings. 

For more information about working with raster images, see Chapter 19, Displaying 
Raster Images.
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Chapter 8: Geocoding
Geocoding

In all likelihood, you have data records that you 

want to display in MapInfo Professional®. After 
all, that is one of the main reasons for this 
program — to see how your data is distributed 
geographically so that you can make better 
decisions about your business. 

Before you can view your data on a map, you 
must first assign geographic coordinates to 
each record so MI Pro knows where to spot the 
record on the map. This process is known as 
geocoding.
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Geocoding: Assigning Coordinates to Your Records
To display your data records on a map, you must first assign X and Y coordinates to 
each record. MI Pro assigns these coordinates by matching geographic information in 
your database table to geographic information in another table (referred to as a search 

table) that already has X and Y coordinates associated with it. 

For example, you want to assign X and Y coordinates to a customer record whose 
address is 127 Winston Ave. MI Pro reads that address and looks for a matching 
address in the search table, such as a StreetPro table. (This search table already has X 
and Y coordinates associated with its records.)

When MI Pro matches 127 Winston Ave in your table to 127 Winston Ave in the search
table, it assigns the corresponding X and Y coordinates to your record. The geocoded 
point becomes part of your database. You can then view these points by displaying 
your table in a Map window. 
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eocoding Methods
Now let’s look at the variety of ways you can geocode your table. 

Geocoding by Address
When you geocode your table with street addresses, MI Pro matches the addresses in 
your table to the street names and address ranges in a StreetPro table (which is sold by 
MI Pro) and assigns X and Y coordinates to your records. When you display your 
records, MI Pro will spot the record at the location of the record’s address. MI Pro 
places the record on the proper side of the street, offsets it from the side of the street to 
the specified distance, and insets it from the end of the street the specified percentage 
of the line.

Geocoding by Boundary
In desktop mapping, the term boundary is used to designate enclosed regions or areas 
such as countries, cities, and ZIP Codes. When you geocode your table with 
boundaries, MI Pro matches the boundary name in your table with the boundary 
name in the search table. MI Pro assigns the boundary centroid X and Y coordinates to 
your data records. The centroid of a boundary is its approximate center point.

For example, you have a table of wholesale outlet stores. You want to assign X and Y 
coordinates to each record according to county. MI Pro reads the county name from 
your table, matches it with the county name in the search table, and assigns the 
county centroid coordinates to each of your records. The outlet locations will display 
at the county centroid in a Map window.

Geocoding by US_ZIPS.TAB (ZIP Code Centroid File)
US_ZIPS.TAB is a point file that is included with the base MI Pro package. The file 
consists of ZIP Code centroid points for every ZIP Code in the United States. This file 
can be used to geocode any database that includes ZIP Code information. 

You can use any of the above methods to geocode your records, or you can use a 
combination of address and boundary geocoding to increase the potential for a 
successful match. 
apInfo Professional User�s Guide 135

Apple Inc. 
Exhibit 1021 

Page 145



Chapter 8: Geocoding

 

Three Questions to Ask Before Geocoding
It is important to know your data and what you want to use it for before you select a 
method of geocoding. Ask yourself these questions:

What kind of geographic information do I have in my database? 

Do you have street addresses, towns, cities, ZIP Codes, states, countries? Do you have 
potentially ambiguous information? For example, if you have a database of customer 
street addresses, will you have 125 Main Street in Smithtown and a 125 Main Street in 
Nassau? If so, you may have to refine your search using town boundaries or ZIP 
Codes. 

What kind of maps do I have to work with? 

You will need computerized maps that are at the level of detail that match your data. 
For example, if you want to geocode a database of customers in specific counties by 
street address, you will need maps of the desired counties that go to street level. A 
map of the United States that only goes to a county level would not work for you. You
can purchase the appropriate maps for your geocoding application from MI Pro or 
your reseller.

How geographically accurate does the placement of my data have to be? 

Taking into account the first two questions, you must decide how accurate the 
geocoding must be. If you are trying to pinpoint the locations of cable wires, crime 
scenes, or fire hydrants, a high degree of accuracy is needed. In this case, you should 
geocode your data to street level.

If, however, you are going to use your data to thematically shade ZIP Code 
boundaries, town boundaries, county boundaries, state boundaries, or country 
boundaries, you do not need a high degree of accuracy. Therefore, geocoding against 
boundary files such as USZIPBDY is fine.  The USZIPBDY.TAB file is also included. 
Since this file does not include point ZIP codes (ZIP codes assigned to a single 
building or company), the hit rate may not be as good. Geocoding with US_ZIPS.TAB 
is generally preferable. 
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To assign X and Y coordinates to the records in your table, choose Geocode from the 
Table menu. MI Pro displays the Geocode dialog, where you enter the following 
information:

• The name of your table for which you want to assign X and Y coordinates. 

• The column in your table that contains the geographic information that will be 
used for matching.

• The name of the search table containing the geographic information that will 
be used for matching.

• The search table column containing the geographic information for matching:

The dialog also offers you the option of geocoding your data automatically or 
interactively. When you geocode a table automatically, MI Pro geocodes exact matches 
only and ignores all other records. It is the faster method, since MI Pro requires no 
user interaction once the geocoding process begins. When you geocode a table 
interactively, MI Pro pauses when it fails to match a record and lets you select from a 
list of close matches.

We recommend that you geocode your table automatically first and then go back and 
geocode interactively to match the remaining records. 
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Placement of Geocoded Points
When you are geocoding to street level (by address), you can specify certain aspects of
the resulting points’ position in relationship to the street. You can specify the offset of 
the point from the side of the street, and the inset of the point from the end of the 
street. 

Street Offset 
The street offset is the distance the geocoded point is set from the side of the street. To 
set this distance: 

1. Choose Table>Geocode. The Geocode dialog displays. Fill in the table and 
column information for the dialog. 

2. Click the Options button. The Geocode Options dialog displays.

 

3. In the Offset Address Location group, specify a distance and distance unit. If 
you choose 12 meters, the point will be offset 12 meters back from the side of 
the street. You can specify any distance from 0–32,767. 

4. At this point, you can specify a street inset, or click OK to return to the 
Geocode dialog. 
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Street Inset
The street inset is the distance a geocoded point is set from the end of the street. You 
can specify a distance, or you can set the inset to be a percentage of the length of the 
street. To avoid skewing the position of inset points, MI Pro performs a proportional 
calculation that insets the points located at either end of the street the specified 
percentage or distance, but that decreases the inset as point locations approach the 
center. Points located at the center of the street remain in their original position. To set 
the street inset: 

1. With the Geocode Options dialog still open, choose how you want to specify 
the street inset in the Inset Address Location group: as a percentage of the 
length of the street, or as a distance. Click the radio button next to the option 
you want. 

2. Specify one of the following:

Percentage–Specify a percentage to calculate the street inset. The percentage 
can be from 0–50.

Distance–Specify a distance and distance unit. You can specify any distance 
from 0–32,767.

3. Click OK to return to the Geocode dialog. Double-check your geocoding 
settings, and click OK to geocode the table. 

MI Pro uses the last inset and offset settings you specified as the default settings for 
your next session. 

If you specify a street offset of a given distance and set the street inset to zero, you 
may get unexpected, albeit correct, display results. Points located at the end of 
adjoining or intersecting streets might overlap each other. On your screen, they will 
look like they are located on the wrong street. If you specify a street inset, the problem 
will correct itself. 
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Approaching the 100% Hit Rate
MI Pro can rarely assign X and Y coordinates to all of your records on the first try, 
especially when geocoding to street level. It is not uncommon to have a geocoding hit 
rate of under 50% on your first attempt. The information in your database may not 
exactly match the information in the search table. MI Pro-based maps are updated 
regularly, but may not include the most recent changes (for example, new 
subdivisions or ZIP Code boundaries). 

And there can be other problems. The abbreviations that you use in your table may 
not match the abbreviations that MI Pro recognizes. For example, the records in your 
table may use abbreviations like Circ. for Circle and Pl. for Plaza. MI Pro only 
recognizes Circle or Cir for Circle and Plaza or Plz for Plaza. When it cannot match an 
abbreviation, it does not geocode the record.

That is why MI Pro gives you the option of geocoding your database interactively. 
There are a number of methods for geocoding records that don’t have an exact match. 
The following is a list of potential geocoding pitfalls and how to avoid or rectify them.

Spelling Errors in Your Data Records 
Keep in mind that MI Pro looks for exact matches. If the information in your database 
does not exactly match the information in the search table, MI Pro ignores that record 
during an automatic geocoding pass. Lasalle St and La Salle St are not exact matches 
nor are Main St and Maine St.

If you go through the geocoding process again using the interactive mode, MI Pro will 
give you a list of close alternatives. Choose the closest match by scrolling through the 
list with the Up and Down buttons. You can also choose Ignore if the correct 
alternative is not listed. 

MI Pro generates its list of close alternatives alphabetically. For example, if MI Pro 
cannot find Booker St in its database, it will generate a list of alternatives that are close
to Booker St alphabetically (Bookman St, Brooker Ave, Brooks St). However, if the 
spelling error occurs in the first letter of the address (Booker St should really be 
Zooker St), you will either have to use the Up and Down keys to scroll to the correct 
spelling or enter the correct spelling directly. 
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Incorrect Address Number in Your Data Records
If your record has an address number that does not match the one in the table you are 
matching against, MI Pro skips the address during automatic geocoding and gives 
you a list of known address ranges during interactive geocoding. Select the closest 
address range from the list or press Ignore to skip the record. Depending on the 
precision with which you want your records to spot on the map, choosing a close 
address range is probably fine.

You can also have MI Pro select the closest address from the list automatically. Select 
Options in the Geocode dialog. MI Pro gives you the option of assigning the closest 
address number when an exact match cannot be found. 

Choosing the closest address does not change the address in your table. MI Pro only 
uses the coordinates from that address to spot your record at that location.

Incompatible Abbreviations
If you geocode automatically and find that you have an extremely low hit rate, your 
database of street addresses may use abbreviations that MI Pro does not recognize. 
For example, all of your records might use Str as the abbreviation for Street. MI Pro, 
on the other hand, uses the abbreviation St for Street. Another example: Your database 
contains addresses that spell out the street numbers (127 Fourteenth St) while MI 
Pro’s table uses the numbers (127 14th St).

Instead of editing all your records, a potentially time-consuming task, you can change 
which abbreviations are recognized. There is an abbreviation file (mapinfow.abb) that 
you can modify so that MI Pro will recognize your abbreviations. For more, see the 
Advanced Geocoding appendix. 

Ambiguous Address Produces More Than One Location
Sometimes your table may contain records that have the same address, but lie in 
different towns. If you only geocode by street address, MI Pro cannot differentiate 
among the records to give each one unique coordinates. 

To solve this problem, MI Pro allows you to geocode against a boundary in addition to 
the street address to find the correct match. 

For example, you want to geocode your database of records in Cook County, Illinois. 
One address in the database reads 200 Washington St. Within the county of Cook, 
there are eight towns. Four of these towns have a Washington St. Three of the four 
towns have a 200 Washington St. 
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By telling MI Pro to search against the street table and a boundary table, there is a 
much better chance of finding a correct match. MI Pro can then differentiate between 
200 Washington St in Chicago and 200 Washington St in Urbana. 

To refine a search, select the column in your table that contains boundary information 
(TOWN, CITY, ZIPCODE). Next, select a MI Pro table that also contains that 
boundary information you need. If you purchased your county street map from MI 
Pro, two of the files included are filenames.tab (where filename is the state and county 
abbreviation), which contains the street information, and filenamemc.tab, which 
contains the town boundaries (minor civil divisions) for that county and 
filenamecb.tab (city boundaries).  Use these files to refine your search.

When refining your search, it is sometimes better to use ZIP Codes rather than town 
boundaries. Town boundaries tend to fluctuate more than ZIP Code boundaries. 
Furthermore, town boundaries are subject to regional interpretation. 

If refining the search with a boundary is still not enough, you can tell MapInfo 
Professional to search in additional boundaries for the match. Choose the Options 
button in the Geocode dialog to bring up the Geocoding Options dialog. Select the 
item that is labeled Use a match found in a different boundary.

Note:  Keep in mind that even though ZIP Codes are more effective for geocoding 
than town boundaries, you cannot use the US_ZIPS.TAB file that comes 
with MI Pro for refining your search because it is a point file. Searches can 
only be refined using boundaries. Use USZIPBDY.TAB for this purpose.
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A Note on Interactive Geocoding
When you geocode interactively and select any of the preceding options, you are not 

changing the data record. You are merely redirecting MI Pro to look for different 
information. 

For example, your data record reads Cherryville St. When you geocode interactively, 
you find that the data record should read Cherry Vale St. You select Cherry Vale St 
from the list of alternatives. Although MI Pro assigns X and Y coordinates from 
Cherry Vale St to that record, you have not altered the record in any way. To change 
the spelling in your database, you must edit the record in a Browser window. 

sing Result Codes
You can also create a field into which MI Pro writes a result code for each record in 
your geocoded table. A result code is a number indicating what steps MI Pro took to 
match the record or why the match failed. You can use these result codes to search for 
different types of geocoding problems. For more information on result codes, see the 
Advanced Geocoding appendix. 
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Manual Geocoding
Automatic and interactive geocoding work well for records that have easy matches. 
Sometimes, however, you know where a point should be on the map, but the location 
data does not allow for a match. Manual geocoding is the process of placing your data
records on the map by clicking its location on the map. Use the following steps to 
connect a browser record with a location on the map:

1. Open the table with the reference map in it. 
2. Open your table and add it to the current Map window.
3. Choose Map > Layer Control. Select your table and make that layer editable. 

Click OK.

4. Choose Window > New Browser Window. Select the table to geocode.
5. Choose Window > Tile Windows. You will now see the Map and Browser 

windows displayed side by side.

6. Scroll through the Browser to find the record that you would like to geocode. 
Click in the box to the left of the row to select the record. 

7. Click in the title bar of the Map window. The Symbol tool on the Drawing 
Toolbar is now available.

8. Select the Symbol tool.
9. Click on the map where you want the point placed for the selected record.

10. Choose File > Save. The selected record is now geocoded. Repeat steps 6–10 
for each record you would like to manually geocode. 
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isplaying Your Data on a Map
Once you have assigned X and Y coordinates to your records, you are ready to display 
these points on a map. Choose Window > New Map Window to open a new window 
with the table displayed or choose Map > Layer Control > Add to add the table to an 
existing Map window.

The geocoding operation permanently changes the table to include these new graphic 
objects. You do not need to save these objects again unless you make subsequent 
changes to them. 

To change the point symbols, choose Layer Control, highlight the layer, and choose 
Display. Click on the Style Override box to make the Style button active. Click on the 
Style button to bring up the Symbol Style dialog. Choose a new symbol or change the 
size and color of the existing symbol. Click OK twice to go back to the Map window. 
The layer redraws with the new symbol. Keep in mind this change only affects the 
work session. Changing the style through Layer Control does not affect the table, only 
the displayed layer.

To change the symbol style permanently, make the layer editable and select all the 
points in the layer (Query > Select, that satisfy obj). Choose Options > Symbol Style. 
Make the appropriate changes. When you are through, choose File > Save Table. 

ocating Data on the Map
Once you have assigned X and Y coordinates to your data records and displayed them 
on a map, you can use the Find command (Query>Find) to locate individual records 
or objects. 
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The Find dialog is very similar to the Geocode dialog. You can specify a table to 
search, a column to search, and an optional refining boundary column. Additional 
options provide the same options as in the Geocode Options dialog: offset and inset of 
address locations and fallback settings that give you more choices when an exact 
match cannot be found. As in the Geocode Options dialog, MI Pro remembers your 
Find Options settings and uses them as the default for your next session. If you have 
multiple windows open, select the Find in Front Window Only prompt to search in 
the front window

Once you have filled in the dialog, MI Pro prompts you to enter the object’s name (or 
geographic location) in a second dialog. MI Pro searches the table, highlights the 
found record in a Browser window, locates the object on the map, and marks it with a 
symbol as specified in the dialog. 

You can use the Find command only on an indexed field in a table. For more 
information on indexed fields, see Table Structure in the MapInfo Professional 
Reference. For more information on the Find command, see Find in the MapInfo 
Professional Reference. 

MI Pro shows the closest match when you type in a 
few characters and click OK.
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reating Points
You may have a file that contains X and Y coordinates that you want to display in MI 
Pro. While the geographic information exists in the table, no points have been created 
so you cannot display the table in a Map window. The Create Points command under 
the Table menu allows you to create points for each record in your database that has 
X-Y or longitude/latitude coordinate information. 

MI Pro uses the coordinate fields in your table to create point objects. Records that 
already have graphic objects associated with them will be skipped during the Create 
Points operation.

For example, you have a table showing transmitter tower locations that was created 
by recording coordinates using a global positioning system. You want to display the 
locations on a map in MI Pro. The table already has X and Y coordinate information. It 
cannot display in a Map window, however, until you create points for the file that MI 
Pro can read.

To create points: 
1. Open the table for which you want to create points.
2. Choose Table>Create Points. The Create Points dialog displays. 
3. Choose the appropriate table from the drop-down list. In the Get X and Y 

coordinate information lists, the lists default to XCOORD and YCOORD. 
4. The Multiply X and Y coordinates allows the user to place a multiplier on the 

coordinate columns if necessary. If you want to specify a projection other than 
longitude/latitude or the default Table Projection preference, choose 
projection. In some cases you will need to specify a negative multiplier 
depending on the locations quadrant. For locations in North America the X 
coordinate is negative. In Africa and Australia, the Y coordinate is negative. 
For locations in and around South America both coordinates are negative.
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5. Click OK. MI Pro updates the table to create point objects. 
6. To display the table, choose Window > New Map Window, or choose 

Map>Layer Control>Add to add the table to an existing map.

For more information on creating points, see Create Points in the MapInfo 
Professional Reference. 

Creating Points from an Excel or Lotus Table
To create points for an Excel or Lotus table:

1. Choose File > Open. 
2. In the Files of type drop-down list, choose the type of table that you want to 

open, Excel or Lotus. Click Open.
3. A dialog displays. Specify the portion of the worksheet you wish to access. 

You may use a named range or choose Other from the drop-down list and 
specify the rows and columns to include.

4. If your worksheet uses the first row for column names, select the Use Row 
Above box. Click OK. Remember to use the drop-down box to modify the 
range accordingly, such as "Al" to "AZ".

5. You now have a browser view of your worksheet in MI Pro. This table is 
currently a read-only table and cannot be edited in MI Pro. 

6. Next, make sure that your coordinate information is in decimal degrees (if 
longitude.latitude) and not in degrees, minutes, seconds. If your coordinates 
are in degrees, minutes, seconds format, go to the Degree Converter section 
later in this chapter. If it is a different coordinate system, it must be in numeric 
columns.
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7. Check your table structure to ensure that your coordinate columns are 
numeric. Many times, numeric columns containing coordinate information 
are brought in as character columns because the first row is used as a header. 
Choose Table > Maintenance > Table Structure. The Modify Table Structure 
dialog displays listing each field name and type. If the coordinate fields are 
decimal, integer or float, click OK and go to step 13. If your coordinate fields 
are listed as character, follow steps 8–11.

8. Choose File > Save Copy As. Give your table a new name, e.g., Samples2.tab. 
Click Save. A copy of your worksheet is saved. 

9. Choose File > Close and close the worksheet that was opened. 
10. Choose File > Open. Choose the new table that you saved, e.g., Samples2.tab. 

Click Open. An editable copy of your original worksheet displays.
11. Choose Table > Maintenance > Table Structure. The Modify Table Structure 

dialog displays. Select your coordinate columns and change the type to Float. 
Click OK.

12. You will be asked to verify the changes. Click OK. Your browser closes, 
indicating that the changes have been made. 

13. Next, determine whether your points are in longitude/latitude or in another 
projection. Follow the instructions in the next section for each of these cases. If 
you are unsure of what projection your coordinates are in, contact the source 
of the data. 

Creating Points, Longitude/Latitude
If your point information is in longitude/latitude, do the following: 

1. Examine the browser for your data to determine which columns contain the 
latitude coordinate (Y), and the longitude coordinate (X).

2. Determine the multiplier for the X and Y columns based on the quadrant of 
the Earth in which the points fall. For example, if the points are expected to 
fall in Kansas, the X value is expected to be between -102 and -94. In the above 
browser, the data for X (Lon) is close to +98. The multiplier should be -1 to 
create the points correctly. The Y (Lat) values are in the correct range and 
require a multiplier of +1 ( +1 will not change the value).

3. Choose Table > Create Points. 
apInfo Professional User�s Guide 149

Apple Inc. 
Exhibit 1021 

Page 159



Chapter 8: Geocoding
The Create Points dialog displays.

4. Insert the proper values in the Get X coordinates, Get Y Coordinates boxes, 
and the Multiply X and Multiply Y boxes. Click OK. 

Creating Points in a Projection
To create points using a projection, do the following:

1. Examine the browser for your data to determine which columns contain the 
latitude (Y) and longitude (X) coordinates. In the example below, the easting 
(x) and northing (y) values are in US State Plane Coordinate System (1927) 
Mass Mainland Zone.

 

2. Choose Table > Create Points.
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The Create Points dialog displays.

 

3. Click on the Projection button and choose the projection category and 
member. 

Click OK. 

Degree Converter 
The Degree Converter tool is part of the toolset that ships with MI Pro. It converts 
coordinate information to decimal degrees from a degrees, minutes, seconds format. It 
can also convert the columns back to degrees, minutes, seconds from decimal degrees. 

Before using this program, make sure that you have two new columns available to 
hold the converted data. You can also use the Degree Converter to convert a single 
Latitude/Longitude coordinate to either decimal degrees or d/m/s. 

To load the Degree Converter from the Tool Manager, choose Tools>Tool Manager and 
select the Loaded check box next to the name of the program. Degree Converter will 
be added to the Tools menu for your current session of MI Pro. To have the tool load 
automatically each time you open MI Pro, select the Autoload check box. 

You can also run this program with the Run MapBasic Program command, as well as 
any of the other tools in the Tool Manager. 
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Choose Tools>Run MapBasic Program, as shown below. Select dmscnvrt.mbx from 
the Tools directory, and click OK. The Degree Converter tool is added to the Tools 
menu. 

To use Degree Converter:
1. Choose Tools >Degree Converter. 
2. Choose Tools > Degree Converter > Convert Column to Decimal Degrees. The 

Convert DMS to Decimal Degrees dialog displays. Select the table containing 
the columns for conversion. Choose one of the columns containing the 
coordinate information. You will have to run the program once for the 
longitude (X) column and once for the latitude (Y) column.

3. Enter the DMS Separator. You should be able to look at your table and 
identify the character separating the degrees, minutes, and seconds. 
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4. Choose the column for the converted results. This must be a decimal or float 
field. Click OK.

5. Browse your table to see the new column of coordinate information in 
decimal degrees. Repeat this procedure for your other coordinate column. 
You are now ready to use the Table > Create Points command.

Note:  The Degree Converter may also be used to convert decimal degrees back to 
degrees, minutes, seconds. Use this functionality if you must return the 
data to its original format. 

ispersing Points
Depending on how you have geocoded your table, you may have several points that 
are placed at the same location, making it difficult to tell if you are viewing one point 
or many. For example, if you geocode a table of students by census tract, and view the 
results on your map, it appears that there is one dot at the center of each tract when 
there actually may be several there. To see all of your data, you may want to disperse 
the points over a small area. There are three methods for dispersing points: the 
Disperse Points tool (a utility that comes with MI Pro), equal dispersion, and 
dispersion to the right.

Disperse Points Tool 
The Disperse Points tool is a MapBasic program that ships with MI Pro. The program 
disperses points located at the same position. There are two methods for dispersing 
the points: systematically or randomly. Disperse Points is loaded from the Tool 
Manager: 

1. Choose Tools>Tool Manager. The Tool Manager dialog displays.
2. Select the Loaded check box next to the Disperse Points tool, and click OK. 

The Disperse Points tool is added to the Tools menu. 

To use Disperse Points: 
1. Choose Tools > Disperse > Disperse Points. A dialog displays showing your 

tables. Choose the table containing the points to be dispersed. Click OK. 
2. A warning displays suggesting that you save a copy of the table if you have 

not already done so. If you are working with a copy of the original table, click 
Continue.
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3. Choose the appropriate method for dispersing points and click OK. Each 
method is described below:

4. The Zoom Level dialog displays. Enter the zoom level at which you will 
typically view the table. This is so the dispersal distance can be customized to 
that particular zoom level. Click OK.

Note:  The program works slightly faster if you do not display the table you are 
dispersing.

  Warning  This program permanently changes the table. Save a copy of the table 

before running this program. 

Equal Dispersion
The equal dispersion method disperses points at equal distances from the center. 

1. First, select all of the points that have the same location. This can be done with 
either the Radius Search Select tool or the Marquee Select tool.

2. Choose Options >Show MapBasic Window to open the MapBasic window.
3. Click so that your cursor is in the MapBasic window. Type RANDOMIZE and 

press Enter.
4. Type UPDATE SELECTION SET OBJ = CREATEPOINT(CENTROIDX(OBJ) + 

(0.01)/(COS(CENTROIDY(OBJ) * .01745)))*(RND(1) - .5), CENTROIDY(OBJ) 
+ 0.01*(RND(1) - .5)) and press Enter.

Dispersion to the Right
The dispersion to the right method disperses points to the right of the point. 

1. First, select all of the points that have the same location. This can be done with 
either the Radius Search Select tool or the Marquee Select tool.

2. Choose Options > Show MapBasic Window to open the MapBasic window.

Systematically 
N,S,E,W,NE,SW,NW,SE: 

Points are dispersed roughly one symbol width 
away from the original point in eight possible 
directions.

Systematically “Around The 
Clock”

Points are dispersed roughly one symbol width 
away in a clockwise fashion.

Randomly Points are clustered around the original loca-
tion in a random pattern. In this case, the 
points can end up overlapping each other. 

Randomly with Call Out Lines Random dispersion with a callout line to 
indicate the original location of the point. 
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3. Click so that your cursor is in the MapBasic window. Type RANDOMIZE and 
press Enter.

4. Type UPDATE SELECTION SET OBJ = CREATEPOINT(CENTROIDX(OBJ) + 
0.01 * RND(1), CENTROIDY(OBJ)) and press Enter.

The table will be automatically updated. If the new Map window has not distributed 
the points satisfactorily, click on the title bar of the Map window choose Edit > Undo 
to restore the objects to their original positions.

To disperse points for the entire table, substitute your tablename in the above 
examples wherever it says SELECTION.

Note:  The dispersal weight, in the equation of the update statement above, is a 
number that regulates the object’s new X and Y coordinates. In the above 
example, the dispersal weight is 0.01 degrees (longitude and latitude). The 
maximum X or Y distance (in miles) that the point is dispersed is equal to 
(69 * the dispersal weight). The dispersal weight is adjustable — the larger 
the weight, the greater the dispersal distance. In the example above, the 
dispersal weight is about right for dispersing points on a county-wide or 
state-wide basis, but not for a street-level dispersal. If you find that your 
objects are not being dispersed enough or are dispersed too much, increase 
or decrease the weight. 

reating Points for Intersections
Many people working with street files are often interested in information that is 
located at intersections. For some, their only concern is the intersections. In MI Pro 
you can geocode to intersections in your street file with the Table > Geocode 
command, but it would be easier to work with a table that contained only 
intersections. For example, a municipality is interested in tracking the types of traffic 
control devices at each street intersection. It would be beneficial for them to make an 
entire layer that contains the intersection of every street.

To create points for every intersection in your table, do the following:
1. Choose File > Open and open your street file.
2. Make two copies of the street file and give each copy a new name. Choose File 

> Save Copy As and save your table under a new name. Repeat this step and 
save the file under another name.

3. Choose File > Open and open the two files that you created.
4. Choose Query > SQL Select. Fill in the following SQL Select statement. This 

query matches the two street files against each other where the streets 
intersect and are not the same named street.
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5. Choose File > Save Copy As and save the resulting table.
6. Open the newest table and ungeocode it. Choose Table > Maintenance > Table

Structure and clear the Table Is Mappable box.
7. Then geocode the unmapped table to one of the copies of the street file. 

Note:  You may have duplicate points at the same location if a street intersects 
another street of the same name more than once. 

Extracting Longitude and Latitude from a Geocoded Table
To extract the longitude and latitude coordinates from a geocoded table, you can 
either create a new table containing the latitude and longitude for each of the points in 
your original table, or use the update command to put the longitude and latitude into 
the original table. The original table must be geocoded for these processes to function 
correctly. 

Extracting Latitude and Longitude into a New Table 
In this example we will create a new table, called CUSCOORD, that contains the 
latitude and longitude for each of the points in the original table, Customer.

1. Choose File > Open and open the table as a Browser.
2. Choose Query > SQL Select and fill in the dialog as shown below.
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Note:  Any columns from the CUSTOMER table that you would like to appear in 
the CUSCOORD table should be listed in the Select Columns box; then add 
the centroidX(obj) and centroidY(obj) functions to this list.

3. Click OK to execute the query.
4. Choose File > Save Copy As and save the resulting CUSCOORD table.

Original Table:

Resulting Table:
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Extracting Latitude and Longitude into the Original Table 
The following process will let you update your original table with the latitude and 
longitude coordinates.

1. Under Table >Maintenance >Table Structure add two new columns to your 
table. Choose Add Field and name the columns. They should be defined as 
decimal (13,6). For this example, the columns are called Xcoord and Ycoord.

2. After adding the columns, click OK. When you return to your main MI Pro 
window, the file will not be displayed. To redisplay your table, choose 
Window > New Browser Window.

3. Next, choose Table > Update Column. Specify your table and your column to 
update. In the example below, we are updating the Xcoord column. The Get 
Value from Table portion of the dialog will be the same table as specified in 
the Table to Update box. In the Value portion of the dialog, you can type in 
Centroidx(obj) or you can click on the Assist Button to display the Expression 
dialog. There, click on Functions and choose Centroidx from the list and click 
OK.
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Fill in the Update Column dialog as shown below and click OK. 

4. Repeat step 3 to update the Ycoord column. Substitute Centroidy(obj) instead 
of Centroidx(obj). 

Table in a Projection Other than Longitude/Latitude
MI Pro maps have two attributes that affect the coordinates of objects within the map; 
these are the coordinate system of the map and the coordinate settings of the Map 
window. To correctly extract the x and y coordinates of a projected earth map, both the 
Map window and the map’s internal coordinates must reflect the same coordinate 
system. In MapBasic, the SET MAP statement sets the coordinate system for the Map 
window, while the COORDSYS clause sets the internal coordinates.

To extract coordinates from a projected map in the native coordinate system of the 
table: 

1. Display a map of the geographic area that you are working in.
2. Choose Options > Show MapBasic Window to open the MapBasic window. 
3. Type: "SET COORDSYS TABLE <TABLENAME>". Tablename is the table that 

you are extracting coordinates from.
4. Press Enter. This sets the internal MapBasic coordinate system equal to the 

table given.
5. Now update the x, y values with the CentroidX and CentroidY functions. 
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Using the Coordinate Extractor Tool
The Coordinate Extractor tool is another MapBasic program that ships with MI Pro. 
Coordinate Extractor offers you another way to display the coordinate information in 
your mappable table in a browser. The program extracts the coordinates from the 
objects in a table and places them in columns using the table’s native projection or a 
different one of your choice. It will also create the coordinate columns for you if you 
specify it. Coordinate Extractor is loaded from the Tool Manager: 

1. Choose Tools>Tool Manager. The Tool Manager dialog displays.
2. Select the Loaded check box next to the Coordinate Extractor tool, and click 

OK. The Coordinate Extractor tool is added to the Tools menu. 

To use the Coordinate Extractor: 
1. Choose Tools > Coordinate Extractor> Extract Coordinates. The Coordinate 

Extractor dialog displays. 
2. Select the table that you want to extract the points from. 
3. Indicate the columns you want to use for the X and Y coordinates, or click the 

Create new columns to hold coordinates button to have the tool add the 
columns. When you click this button, a dialog displays asking you to name 
the columns. 

4. Select the Browse Results check box to have the results displayed in a Browser 
window after the operation is completed. 

5. Click OK. 

The Coordinate Extractor tool can be used on mappable tables that contain at least one 
geographic object. The tool cannot be used on the following types of tables: 

It is recommended that you use float type columns for the coordinates. Other column 
types may not be able to fit all the coordinate information in the column. If you select 
character columns, the coordinate values will include six digits after the decimal 
place.

To take out the coordinate information after you have used Coordinate Extractor, 
revert the table. 

query read-only
seamless remote 
raster
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uide to Geocoding
This section includes some tasks that will be useful in handling records after you have 
geocoded your table. 

Selecting Points Not Geocoded
Your geocoded table may have records that did not geocode, or you may have added 
new data to your table that has yet to be geocoded. There is a simple selection that can 
be performed to get a Browser list of the records not geocoded.

1. Open your table if it is not open already, and choose Query > Select.
2. Fill in the dialog as displayed below. The expression used is “NOT OBJ.” This 

selects all of the records that are not objects, i.e., not geocoded. Click OK.

Locating Newly Geocoded Points
One of the most satisfying results of geocoding is seeing your points displayed 
correctly on the map. Depending on the settings of your map, newly geocoded points 
may or may not be visible immediately. Follow the steps below to attempt to locate 
newly geocoded points on the map.

1. Make sure that the Map window is active by clicking in its title bar.
2. Choose Map > Layer Control. Make sure that the table you geocoded is listed 

in the Layer Control dialog. If it is not listed, click the Add button and add 
that layer.

3. In the Layer Control dialog move the geocoded table to the top, just below the 
cosmetic layer, to ensure that the points are not obscured by any other layer.

4. Make sure that the geocoded layer is set to visible. Click OK and exit Layer 
Control.

If your points are still not visible, proceed to step 5.
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5. Choose Map > View Entire Layer. Select your table and click OK. This should 
put all of the points from your table in view. You may see that your points are
on the map, but are not in the location you expected them to be. If they seem 
misplaced, see the section on Ungeocoding a Table.

6. If your points still do not display, choose Map >Layer Control. Select the layer
containing your geocoded points, and click Display.

7. Select the Style Override check box and choose a symbol style that will stand 
out on your map. Click OK, and click OK again to exit Layer Control.

After following these steps, if you have not found the points that you geocoded, try to 
select all of the ungeocoded records as described in the section Selecting Points Not 
Geocoded.

Ungeocoding a Table or Selected Records
Ungeocoding is the process of removing objects that have been attached to data 
records. There are times when it will be necessary to ungeocode an entire table or 
selected records in a table. For example, you have geocoded a database of customers 
using US_ZIPS.TAB. Later, you want to geocode the database again, using street 
addresses instead of ZIP Code centroids since the geocoding will now be more 
precise. MI Pro allows you to delete all graphic objects associated with this table. You 
can then geocode your database again, using more specific coordinates. Ungeocoding 
only selected records from your table is useful when the location information changes
for a relatively small number of records, such as address changes in a geocoded list of 
customers. 

Ungeocoding a Table 
To ungeocode an entire table:

1. Choose Table > Maintenance > Table Structure. The Modify Table Structure 
dialog displays. 

2. Clear the Table Is Mappable check box. Click OK. 

  Warning  This action will remove all graphic objects from your table. This action 

cannot be undone. If you are unsure of losing your points, save a copy of the table 

first.

3. A warning dialog appears. If you are sure about removing all the objects, click
OK.

All graphic objects have now been removed from your table. 
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Make sure that you don’t ungeocode your source tables. Unless you have created a 
backup of that table, you will no longer be able to display that table as a map or use it 
for geocoding.

Ungeocoding Selected Records
To ungeocode selected records:

1. Display your geocoded table as a map, and select the records that you would 
like to ungeocode. 

2. Choose Map > Layer Control and set the layer to be editable.
3. Choose Edit > Clear Map Objects Only. This removes the object on the map 

while maintaining the record in the browser.

Note:  To undo this operation, choose Edit > Undo Deletion.
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Chapter 9: Selecting
Selecting

This chapter presents the ins and outs of 
selecting records from tables. As you use 

MapInfo Professional® you will find yourself 
selecting records quite often. This chapter 
covers an overview of selecting and the 
methods using tools from the Main toolbar. The 
discussion on selecting using queries is found 
in the next chapter. 
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What Is a Selection?
While MI Pro allows you to attach data to objects on a map, its true analytical power is 
its ability to group and organize data. Once your data is broken down into logical 
groups, you can analyze it based on one or more variables.

For example, you have a basket of fruit. You want to organize the fruit into different 
categories, based on one or more variables: 

• Put all the apples into one group

• Put all the citrus fruit into one group (oranges, lemons, grapefruit)

• Put all the fruit that begins with a vowel into one group (oranges, apples, 
apricots)

There are many different ways that you could group the fruit. Some fruit would fall 
into more than one category (oranges are citrus fruit and also begin with a vowel). 
You could also use more than one variable to group your fruit — put all the citrus fruit
that begins with a vowel into one group.

MI Pro can create similar groups with your data. MI Pro refers to these groups as 
selections. A selection is a subset of data that has been grouped together based on one 
or more variables. 
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For example, you have a table of customer records. You could create a subset of all 
customers who live within a 50 mile radius of Prague. Or, you could create a subset of 
all customers who purchased over $1000 of merchandise. Or, you could create a 
subset of all customers whose last name begins with the letter “B”.

The statements above used to create these subsets are known as queries. A query is just 
another word for a question — which of my customers spent more than $1,000? 
Which of my customers lives within 50 miles of Prague? 

As with the fruit example, there are many different ways to group your data. Some 
data records will obviously fall into more than one category. You could also use more 
than one variable to group your data. Which of my customers lives within 50 miles of 
Prague and purchased over $1000 of merchandise? 

haracteristics of Selections

Selections are temporary tables. When you make a selection, MI Pro creates this 
temporary table to store the records you’ve selected. 

You can perform many of the tasks with a selection table that you can perform with a 
permanent (base) table such as:

• View it in a Browser, a Map window (if it has graphic objects), a Graph or a 
Layout window. 

• Cut and copy it into the clipboard and paste it into another table, or even into 
another application.

• Use it to edit a table. If you want to edit only certain records in a table, you 
can get those records into a selection and then edit that selection.

• Make a further selection from it. 
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To convert selections into permanent tables, use File > Save Copy As. Once you’ve 
saved the temporary selection table as a permanent table, you can treat the new table 
like any other table. 

Selection tables are totally dependent on the table from which they were created. If 
you close a base table, all associated selection tables are deleted. 

Making Selections
MI Pro gives you a number of commands and tools for making selections. They fall 
into two categories:

• Selecting from the screen: Select tool, Radius Select tool, Boundary Select tool, 
Polygon Select tool, Marquee Select tool, Invert Selection tool,Select All 
command. To select records with the tools, click on or encircle the associated 
graphic objects. To select records from a layer at the same time, choose Query 
> Select All. 

• Selecting with queries: Select, SQL Select. When you select records with either
of these methods, you create a logical expression that MI Pro uses to select the 
records. For example, the expression SALES > 20000 means that MI Pro will 
select only those records with sales higher than $20,000. (Select and SQL 
Select will be explained in the next chapter).

Selecting from the Screen
To select objects from the screen, the layer that contains the objects must be Selectable. 
To make a layer Selectable, choose the Layer Control command from the Map menu 
and select the Selectable check box for that layer.

When you select map objects in a Selectable layer, MI Pro highlights the objects using 
the settings defined in the Highlight Control section of the Preferences dialog 
(Options menu). When you select map objects in an Editable layer, MI Pro places edit 
handles (little squares) around the extents of the object you selected.
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If you have more than one Selectable layer in a Map window, MI Pro selects objects 
from the topmost Selectable layer. For example, you have a Selectable layer of county 
boundaries and a Selectable layer of state boundaries. If the county boundaries are in 
the topmost layer in the Map window, MI Pro selects objects from the county layer. If 
the state boundaries are in the topmost layer in the Map window, MI Pro selects 
objects from the states layer. When you use the Select tool, MI Pro also displays 
InfoTips for the topmost Selectable layer. As you move your cursor over the objects, 
InfoTips display the object’s label expression. You can turn off the InfoTips in the Map 
window Preferences (Options>Preferences>Map window). 

Likewise, if you perform a boundary search, the boundary object that you want to 
search should be in the topmost layer. For example, you have a layer of ZIP Code 
boundaries and a layer of state boundaries. If you want to select all objects that fall 
within a ZIP Code boundary, the ZIP Code layer should be the topmost boundary 
layer. If you want to select all objects that fall within a given state, the state layer 
should be the topmost boundary layer. You can reorder the layers by choosing Map > 
Layer Control.

If you want to select objects from tables other than the topmost table, hold down the 
Ctrl key when you are selecting an object. For example, you have a layer of states, a 
layer of counties, and a layer of cities. All three layers are Selectable. You want to 
select objects in the states table, but it is the bottommost layer in the Map window. 
Hold down the Ctrl key and click on the map with the Select tool. You are now in the 
second layer. Hold down the Ctrl key and click on the map again with the Select tool. 
You are now selecting objects from the third layer, the states layer. 

nselecting Objects or Records
You may choose to:

• Unselect one object or record from a group of selected objects or records.

• Unselect a group of selected objects or records.

• Unselect all selected objects.

To cancel the selection of one object or record from a group of selected objects or 
records, hold down the Shift key and click on the object or record with the Select tool. 
When you click on it, the selection is cancelled.

To cancel the selection of all selected objects, you can either click on the Map window 
where there are no objects or choose the Unselect All command from the Query menu.
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Selecting Tools
MI Pro includes several tools on the Main toolbar to allow you to choose records for 
further viewing and analysis, including:

• Select tool

• Radius Select tool

• Marquee Select tool

• Polygon Select tool

• Boundary Select tool 

• Invert Selection tool

Each tool is discussed below.

 Select Tool 
Use the Select tool to select objects one at a time or to select all objects that are 
generally in the same area. You select an object by clicking on it. 

To select an object:
1. Make the layer that you want to select objects from Selectable (Map > Layer 

Control). 
2. Choose the Select button from the Main toolbar.
3. Click on an object in the Map window. If that object’s layer is Selectable, MI 

Pro highlights the object. If the layer is Editable, MI Pro puts edit handles 
around the extents of the object. If the layer is neither Editable nor Selectable, 
MI Pro does not allow you to select the object.

4. Choose Window > New Browser Window to display selected records in a 
Browser. Choose Selection from the list of tables. MI Pro creates a Browser of 
the new temporary table. To select records from the Browser, simply click on 
each record with the Select tool. 

To select multiple objects individually, click on the first object to select it. Hold down 
the Shift key and click on another object. MI Pro selects that object, too. If you select a 
second object without holding down the Shift key, MI Pro unselects the first object 
and selects the second object. 

When selecting a point object, you generally want to position the Select tool in the 
center of the symbol. However, some symbols have a hot spot that you must hit in 
order to select it. For example, the hot spot on the golf flag symbol is the base of the 
pole. 
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You can also move the selected object(s).  Hold down the mouse button and drag the 
object to its new location or press the up, down, left and right arrow keys to move the 
selected objects 1 screen pixel in the corresponding direction. If you press the Shift key 
when the arrow key is selected, the object will move 10 pixels. Since the moves are 
made in screen pixels, the zoom level affects how far the object is moved.

Finally, you can also rotate selected objects, select an object. The object is highlighted 
and bounded by four edit handles and a fifth handle below the lower right corner.  
Click on the fifth handle (rotate handle) and hold down the mouse button.  Rotate the 
highlighted box to the desired angle.  A rubber banding box is drawn representing the 
rotated object.  If the Shift key is pressed while the rubber banding box is being 
drawn, the rotation will be limited to 45 degree increments. The following objects 
types can be rotated:  Line, Polyline, Polygon, MultiPoint, Collection, Arc, Ellipse, 
Rectangle, Round Rect (Points cannot be rotated).

 Radius Select Tool 
The Radius Select tool is used to select all objects that fall within a given radius. For 
example, you have a table of blood donors and a table of blood donation sites. Using 
the Radius Select tool, you could create a temporary list of blood donors that live 
within a one-half-mile radius of each blood donation site.

Note that the Radius Select tool selects all objects whose centroid falls within the 
circle. The object doesn’t have to be completely bounded by the circle.
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To select objects within a radius:
1. Make the layer you want to select objects from Selectable (Map > Layer 

Control).
2. Choose the Radius Select tool from the Main toolbar. The cursor becomes a 

hand when moved over the Map window.
3. Click on a place on the map that you would like to use as the center point of 

your radius search. For example, if you want to select all the fire hydrants that 
fall within two miles of a fire station, click on the fire station and use that as 
the center point. 

4. Hold down the mouse button and drag the mouse away from the center 
point. MI Pro draws a circle around the point and reports the radius of the 
circle in the StatusBar (lower left corner of the screen).

5. When you have the desired radius release the mouse button. MI Pro 
highlights all map objects that fall within that circle.

6. To see a list of all the records that fall within that circle, choose New Browser 
Window from the Window menu. Choose Selection from the list of tables. MI 
Pro creates a Browser of the new selection table. 

  Marquee Select Tool
The Marquee Select tool is used to select objects within a rectangle. By clicking and 
dragging using the Marquee tool, you create a dotted rectangle, or marquee box 
around objects you want to select. All Selectable objects in the topmost Selectable 
layer will be included in the marquee box. To select objects from a layer below the 
topmost Selectable layer, in Layer Control, make sure it is Selectable and turn off 
Selectable for the layer(s) above.

To select objects within a rectangle:
1. Make the layer that you want to select objects from Selectable (Map > Layer 

Control).
2. Choose the Marquee Select tool from the Main toolbar. The cursor becomes a 

hand when moved over the Map window.
3. Click on a place on the map outside of the area you want to include in the 

marquee box.
4. Hold down the mouse button and drag the mouse to form a dotted rectangle 

around the points you want to select.
5. When you have reached the desired rectangle size release the mouse button. 

MI Pro highlights all map objects that fall within that rectangle.
6. To see a list of all the selected records, choose Window > New Browser 

Window. Choose Selection from the list of tables. MI Pro creates a Browser of 
the new selection table. 
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 Polygon Select Tool
The Polygon Select tool selects map objects within a polygon that you draw on a map. 

To select objects with the Polygon Select tool: 
1. Make the layer that you want to select from Selectable (Map>Layer Control). 
2. Choose the Polygon Select tool from the Main toolbar. The cursor becomes a 

pointing hand when moved over the Map window. 
3. Click anywhere on the map. This is the first end point of the polygon. Move 

the cursor over your map in any direction. A line is drawn from the point 
where you clicked to the cursor. Click to create another endpoint. Continue to 
move the cursor and click until you have the desired number of sides to your 
polygon. 

4. To close the polygon, make your last click as close as possible to the first click. 
MI Pro closes the polygon and selects the objects that are within it. 

 Boundary Select Tool 
If you want to select objects that fall within a given region or boundary, use the 
Boundary Select tool. When you use this tool, MI Pro selects all objects within any 
boundary on the map, such as state or county boundaries, police precincts, or sales 
territories. 

For example, you have a layer of states and a layer of retailers. Using the Boundary 
Select tool, you could click on a state and create a temporary list of all the retailers in 
that state.

To select objects within a region:
1. Make the layer that you want to select objects from Selectable (Map > Layer 

Control).
2. Choose the Boundary Select tool from the Main toolbar. The cursor becomes a 

cross hair when moved over the Map window.
3. Click within a boundary object. MI Pro selects all objects that fall within that 

boundary.
4. To see a list of all the records that fall within that boundary, choose Window > 

New Browser Window. Choose Selection from the list of tables. MI Pro creates 
a Browser of the new selection table. 
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The Invert Selection tool is a convenient way to select many objects at once. You 
simply select the few objects that you don’t want, and then invert the selection to 
select all the objects you do want. 

1. Make the map layer that you want to select from Selectable (Map>Layer 
Control).

2. Make the Select tool active, and click on one or two map objects. 
3. Click the Invert Selection tool. MI Pro selects all the objects that are not part of 

the current selection, and cancels the current selection.

You can also find Invert Selection in the Query menu. 

Other Search Methods
You can draw your own polygons and search for objects within them. For example, 
you have a table of city streets and a table of retail businesses. Since streets are made 
of lines and not boundaries, you cannot search within a city block. However, you 
could create boundaries by tracing the street map with the Polygon tool. You could 
then search for objects within that boundary.

You can also create search polygons with the Buffer command. The Buffer command 
is used to create boundaries around points, lines, or other boundaries. For example, 
you want to search for all customers who live within five miles of Interstate 90. Using 
the Buffer command, you could create a polygon that would encompass any area 
within five miles of Interstate 90.

You could even use the Buffer command to create a boundary around another 
boundary. For example, you want to search for all radio stations that are located 
within twenty miles of a given county. Using the Buffer command, you could create a 
polygon that would encompass any area within twenty miles of the county boundary. 

To perform a polygon search, two layers must be Selectable: the layer containing the 
objects you are selecting, and the layer containing the boundary you want to use in 
selecting those objects.
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Chapter 10: Selecting Using 
Queries
Selecting Using Queries

In the previous chapter, you learned how to 
make selections from the screen using tool 
buttons such as Radius Select and Boundary 
Select. In this chapter you will learn to make 
selections using the powerful query features in 

MapInfo Professional®: Select and SQL Select. 

Each section of the chapter is followed by a 
walk-through example of that section’s major 
concepts.

➤ Se

➤ M

➤ Wh

➤ Sa

➤ Qu

➤ De

➤ Cre

➤ Ag

➤ Gro

➤ Joi

➤ Ou

➤ S

➤ Se

➤ Fin

➤ Ca
Apple Inc. 
Exhibit 1021 

Page 184



Chapter 10: Selecting Using Queries
Selecting Using Queries
A query is just another word for a question.

There are two query builders available under the Query menu in MI Pro, Select and 
SQL Select.

In the case of Select, you have a table of information and you ask MI Pro to select a 
subset of it. For example, 

• Which of my customers spent more than $20,000? 

• Which of my customers live in Vermont? 

In the case of SQL Select, you have a table(s) of information and you ask MI Pro to:

• Derive new columns – columns that calculate new values based on the 
contents of your existing columns.

• Aggregate your data so that you see only a listing of subtotals instead of 
seeing your entire table.

• Combine two or more tables into one results table.

• Show only the columns and rows that interest you.

SQL query to determine homes affected by airport noise pollution
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Wh
at Is Select?
Select allows you to query a table. It allows you to select records and objects from a 
table according to their attributes. You can use it to highlight objects in a Map or  
Browser window that meet certain criteria. You can also create a results table that you 
can browse, map, or graph like any other table.

For instance, by formulating queries with Select, you can ask MI Pro to:

• Show only ZIP Code regions where the average household income is above 
$65,000.

• Show only ZIP Code regions where the median age is 42.

• Show only the ZIP Code regions where the household income is above 
$65,000 and the median age is 42.

• Show only records for all orders received in July or September.

• Show cities of over 100,000 people in Texas, California and Florida.

When you are working in a Browser, MI Pro highlights the records meeting the 
criteria of the query. When you are working in a Map window, the graphic objects of 
the chosen records are highlighted. When you are working in both windows, the 
objects in both are highlighted. In all cases, MI Pro automatically creates a working 
table called Selection that contains the results of the query. You can browse, map, or 
graph this table like any other table. The table can also be saved as a separate table 
with Save Copy As.

Creating Expressions
To perform a Select query, you must create an expression. An expression is a logical 
statement that is used to ask your question. For example, you have a table of 
apartments for rent. If you want to create a temporary table of all apartments that cost 
less than $800 a month, you could use the expression:

• RENT < 800

where RENT is the name of a numeric column that contains the per month rent rate. 

MI Pro searches the apartment table for all records that satisfy this condition and puts 
those records in a temporary table that you can map, browse, graph or carry out 
additional queries.

You can also perform mathematical operations on your data. For example, you want 
to create a temporary table of all apartments that have a total cost of less than $800. 
Total cost is equal to the sum of the rent and the monthly utilities. 
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You could use the expression:

• RENT + UTILITIES < 800

You are telling MI Pro to add the number in the RENT column and the number in the 
UTILITIES column and then compare that number to 800.

There are two ways of creating an expression. The first method is to type in the 
expression directly. When you are creating very simple expressions, this method is 
usually faster. The second method is to press the Assist button in the Select dialog and 
build your expression using the pop ups in the Expression dialog. This method is 
particularly useful when you are just learning how to build expressions or when you 
are building very complex expressions.

The Expression dialog gives you three pop ups that you can use to build your 
expression: columns, operators, and functions. Each is discussed below.

Columns
This pop up lists every column in the table from which you are selecting. If the table 
contains derived columns from previous queries, those columns will also be listed. 

Operators
This pop up contains mathematical and logical operation symbols. The mathematical 
operators in this pop up include addition, subtraction, multiplication, division, 
greater than, less than, and equal signs. You can use these symbols to create 
mathematical formulas. 

For example, from your table of sales representatives you want to select those sales 
representatives who, on the average, gross more than $2000 per month. Gross sales is 
computed by adding together sales and commission.

You have two columns in your table: TOTAL_SALES, which is total sales for the year 
for each representative and COMMISSION, which is total commission for the year for 
each representative. You could build the following expression:

• (TOTAL_SALES + COMMISSION) / 12 < 2000

This expression tells MI Pro to add the number in the TOTAL_SALES column with the 
number in the COMMISSION column. However, this gives you gross sales for the 
year. We want average gross sales for the month. Therefore, we divide the sum by 12, 
which will give us a monthly average. We then compare that figure with 2000. 
178 MapInfo Professional User�s Guide
Apple Inc. 

Exhibit 1021 
Page 187



Chapter 10: Selecting Using Queries

MapIn
The Operators pop up also includes logical operators conjunctions AND, NOT, OR 
and LIKE. The LIKE operator can be used with two wildcard characters: ’%’ and ’_’. 
The ’%’ character matches zero or more characters. The ’_’ character matches only one 
character. 

Functions
This pop up contains mathematical functions that take one or more parameters and 
return a value. You use functions to perform basic mathematical functions on the data 
in that column. For example:

• abs(<number>)

takes the absolute value of the numbers in the specified column. 

For example, a meteorologist wants to select all days where the temperature in her 
city was more than 10 degrees warmer or cooler than the national average. She has a 
column in her table, AVG_DIFF, that contains the difference between the national 
average and city average. She could create the following expression:

• AVG_DIFF < –10 Or AVG_DIFF > 10

This expression tells MI Pro to select all records that have an average difference less 
than -10 or greater than +10. However, she could also create the following expression:

• abs(AVG_DIFF) > 10

This expression tells MI Pro to select all records where the absolute value of the 
average difference is greater than ten.

The Functions pop up contains many other functions, including area, perimeter, sin, 
cos, and date-related functions. For a complete list of functions, see Appendix D, 
Creating Expressions, in the MapInfo Professional User’s Guide. 

Steps Using Select
In general the process for selecting objects using Select is:

1. Choose Select from the Query menu. 
2. Specify the table from which you want to select records.
3. Create a logical expression that will be used to select records. 
4. Choose a column on which to have the query sorted (optional). By default, 

the query is unsorted.
5. To see a list of the records you have selected, select the Browse Results check 

box. 
6. MI Pro creates a Browser of the new selection table. 
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MI Pro names the table Query1. It will name the next temporary selection table 
Query2. You can override MI Pro’s default name and give the selection a descriptive 
name. Type the new name into the Store Results in Table box. The table can also be 

saved as a separate table with Save Copy As.  

Example: Selecting
MI Pro makes finding information and locations easy. You can use the Select feature to 
create subset databases of your information. As an example, we will use the sample 
world table to select particular countries with a literacy rate greater than 90%.

Open the world.tab table, and choose Query > Select to display the Select dialog. 

Do the following:
1. Complete the Select dialog:

From the Select records from table drop-down list, choose World.

Click on Assist. The Expression dialog displays.

2. Complete the Expression dialog as shown in the following figure:

From the Columns drop-down list, choose Literacy.

From the Operators drop-down list, choose > (the greater than sign).
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Type 90.

Click Verify to confirm the syntax of your expression. Click OK to close the 
Verify dialog. 

Click OK to close the Expression dialog. The Select dialog redisplays.

Make sure the the Browse Results check box is selected.

3.  Click OK to select the countries.

MI Pro creates a Browser that contains the selections. Notice that the 
selections display in both the World map and Browser. 

ing a New Table Using a Subset of a File
Many of the data sets that are used with MI Pro include more objects and information 
than necessary for some projects. In many cases it is easier to work with a subset of the 
complete data product. For example, if you were tracking crime statistics for a certain 
county by census tract, you would not need the census tracts for the entire state. You 
could extract just the census tracts for the county. 

There are two ways to create a new table that will contain a subset of the records from 
an existing file. You can interactively select the objects representing the records you 
would like to put in the new table using one of the select tools. Or, you can use the 
SQL Select command to choose a subset of objects based on an SQL function. 

Saving the resulting table is the same procedure, whether you choose the objects 
interactively or use an SQL select statement.
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Note:  Many of the queries on the following pages can be done either by using 
Query > SQL Select or through the simpler Query > Select dialog. Because 
SQL Select is more versatile and more commonly used, the SQL Select 
dialog is used in the following examples.

Interactively Selecting Objects
1. Choose File > Open and open the table in a Map window.
2. Select the objects that will make up the subset with the Select tool, Radius 

Search Selector tool, or Polygon Search Selector tool. Shift-click to select 
multiple objects. Your map will look similar to the one below.

3. Choose File > Save Copy As and save the Selection table. The table can be 
saved with any filename. 

What Is SQL Select?
A selection is a subset of data rows in a table, chosen based on the contents of one or 
more columns from the table. You create selections by formulating questions, or 
queries, about your data. How many customers live in the state of Idaho? Which 
police precinct has the highest rate of violent crime? MI Pro stores the results of these 
questions in temporary tables called query tables. 

In the first part of this chapter, we discussed selections and query tables as a result of 
using Query > Select. We now turn our attention to an extremely powerful and useful 
feature in MI Pro, querying by SQL Select.
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While MI Pro’s Select command lets you formulate sophisticated queries, SQL Select 
goes even further. The records in the query table generated by the Select command 
don’t have any information in them that isn’t contained in the records of the base 
table. They are, in fact, the same records. They have been arranged so that they can be 
viewed together. 

With SQL Select you can create query tables containing information that was only 
implicit in the base table(s). 

The SQL Select dialog is one of the most elaborate ones in MI Pro. But don’t be 
intimidated. Once you learn what each box is used for, it is fairly simple to create 
powerful selection statements. You can type directly into the boxes or you can use the 
pop up menus on the right to enter items into the boxes.

The easiest way to describe the dialog is to walk you through an example, step-by-
step. This example uses data from the WORLD table included in MI Pro, so you can 
try out this SQL Select exercise yourself. We have included a brief description of the 
parts of the dialog with each step. A complete description of each box is given after 
the example. 

Example: Computing Population Density Using Area( ) 
In this example, we’ll use the world map to create a table of all the countries that have 
a population density of over 500 people per square mile. The following formula 
computes population density:

• POPULATION / AREA

While the world table has a population column (pop_1994), it does not include a 
column for country area. However, since the world table has graphic objects 
associated with the records, MI Pro can compute the total area for each country.

Open the world.tab table, and maximize its display by clicking the window’s 
maximize button. Choose Query > SQL Select to display the SQL Select dialog. 

To complete the SQL Select dialog, do the following:
1. In the From Tables box, choose WORLD from the Tables drop-down list. 

You can specify more than one table in an SQL statement. This example uses 
only one table, WORLD.

2. You should fill in the From Table box before you fill in the Select Columns 
box. MI Pro uses the tables in the From Tables box to generate the list of 
columns in the Columns drop-down list. 
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3. Place your cursor in the Select Columns box and delete the asterisk (*). In this 
example, we will specify a list of columns to be included in the resulting 
query table, instead of including all columns. 

Remember, the query table is the temporary table that MI Pro creates to store 
the results of the query. 

4. Select Country from the Columns drop-down list. 
5. Select pop_1994 from the Columns drop-down list.

Now, we need to compute population density. Remember, population density 
is computed by dividing population by area. There is no area column in the 
table. However, there is a function, Area, which will compute the area of any 
mappable object. Since the world table is mappable, MI Pro can compute the 
area of each country and, therefore, the population density of each country.

6. Select the division sign (/) from the Operators popup. 
7. Select Area from the Functions popup.

This will create a derived column. A derived column is a column that contains 
the results of calculations performed on another column or columns. When 
MI Pro creates the query table, it will include two columns: The Country 
column and the pop_1994/Area(obj, “sq mi”) column, which is our 
population density column. MI Pro includes a units statement with all 
geographic functions. If you wanted MI Pro to return the area in square 
kilometers, you would change “sq mi” to “sq km.” 

Now, we need to build an expression that will select only those countries 
whose population density is over 500 people per square mile. 

8. Tab to the Where Condition box. 
9. Select pop_1994 from the Columns drop-down list. 

10. Select the division sign (/) from the Operators drop-down list. 
11. Select Area from the Functions pop up. 
12. Select the greater than sign (>) from the Operators drop-down list. 
13. Type the number 500.

We have now built the expression “Select all countries whose population 
density (pop_1994/Area(obj, “sq mi”)) is more than (>) 500 people per square 
mile.”

14. Leave the Group by Columns box blank.
15. Tab to the Order by Columns box. 
16. Select Country from the Columns pop up.
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The Order by Columns box allows you to specify in which order the records 
in the query table will be displayed. By selecting Country, MI Pro will list the 
records in alphabetical order, according to country name.

17. Tab to the Into Table Named box. 
18. Type DENSITY.

By default, MI Pro names the query table Query1. Subsequent query tables 
will be named Query2, Query3, and so on. You can change the name of the 
query table by typing in a new table name in the Into Table Named box. MI 
Pro will name the query table DENSITY. 

19. Click Verify.

MI Pro checks the syntax of your SQL statement. If there are any errors in 
your statement, MI Pro gives you an error message telling you what the error 
is and which box contains the error.

20. Make sure that the Browse Results check box is selected.

MI Pro creates a Browser of the query table. If you do not select Browse 
Results, MI Pro still creates the temporary query table but doesn’t display it. 
To display the table, you would have to choose the Browse option in the 
Window menu and select DENSITY from the drop-down list.

21. Click OK.
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MI Pro creates the following table:

The first column contains the country name. The second column contains the 
population density. Note that the countries are listed in alphabetical order (Order By: 
Country) and the population density for each country listed is over 500 people per 
square mile (pop_1994/ Area(obj, “sq mi”) > 500).
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Example: Computing Population Density with SQL 

To set up an SQL Select statement that selects only those states with a high population 
density, do the following:

1. Choose File > Open Table and open the States table in a Map window.
2. Choose Query > SQL Select and fill in the SQL Select dialog as shown below.

This will create a new table, HIDENSTY, that contains only those states with a 
relatively high population density (population divided by total area). The 
asterisk (*) in the Select Columns box transfers all of the columns in the 
STATES table to the HIDENSTY table. 

3. Choose File > Save Copy As and save the Selection table. The table can be 
saved with any filename. 

ing Queries
Any query created using the Select or SQL Select commands can be saved as an MI 
Pro query table. Query tables consist of a .TAB file and a .QRY file. After you have 
executed a Select or SQL Select statement, choose File > Save Query to save the query 
as a table. When you open this table, the tables on which the query is based are re-
opened and the query is re-executed. 

Note:  Queries made against other queries cannot be saved as a table or in a 
workspace. 
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Saving Queries to Workspaces
You can also save queries in workspaces. When you open a workspace that contains a 
query, the query will execute and any windows created by the query will redisplay. 
Unlike saving a query as a table, a separate .TAB file is not created when you save a 
query to a workspace. 

Note:  To save queries in workspaces, the Save Queries in Workspaces check box 
must be selected in the Startup preferences (Options > Preferences > 
Startup). This check box is selected by default.

Query Templates
Query templates enable you to save Select or SQL Select statements as templates and 
reload them. This saves you the trouble of having to rebuild a query each time you 
want to use it. Both the Select and SQL Select dialogs have Load Template and Save 
Template options to enable you to do this easily. Query templates are useful for re-
creating a query with an updated version of the table used in the original query, or for 
executing a query on a table that has the same fields as the table on which the query 
statement was created. 

Saving a Template
After you have finished writing your Select or SQL Select query, click the Save 
Template button to save the query to a template, or query file. The Save Dialog to 
Query File displays. Give the query file a name, select a folder, and click Save. Query 
files are saved with a .QRY extension and are saved in the directory specified in the 
Directories preferences (Options > Preferences > Directories). 

Note:  The query does not need to be complete or syntactically correct to save it to 
a template.

Loading a Template
You can load any saved query template. To load a template, click the Load Template 
button. The Load Dialog From Query File dialog displays. It lists the .QRY files. Select 
the .QRY file you want to use, and click Open. The Select or SQL Select dialog 
displays with the values from the template already filled in. Simply execute your 
query to create the query browser. 
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A derived column is a column in a query table whose contents are created by 
applying an expression to the values of columns already existing in some base table. 
In the example above, population density was a derived column.

By default, the Select Columns box contains an asterisk (*), indicating that all of the 
columns in the base table are to be included in the query table. If you don’t want all of 
those columns, you should delete the asterisk and list only those columns that you 
want to use.

You aren’t limited to creating one derived column. You can create as many derived 
columns as you want. Note that the more derived columns you create, the longer it 
will take MI Pro to execute the query. 

You can also created derived columns based on the aggregate functions count, sum, 

avg, wtavg, max, and min. For example:

•  sum(Population).

would give you the population for the entire world. 

• sum(Area(obj), “sq mi”).

would give you the area for the entire world. 

ating Column Aliases
When MI Pro creates a derived column, it uses the expression itself as the name for 
that derived column. That can be awkward. You can, however, specify an alias for the 
column.

For example, the population density column in our DENSITY Browser was titled:

• Population / Area(obj, “sq mi”)

We can rename that column so that it is more descriptive. To rename the column, add 
the new name to the Select Columns box when you are listing the columns. The alias 
must follow the expression. It must also be separated from the expression by a blank 
space and enclosed in quotes. For example: 

• Country, Population / Area(obj, “sq mi”) “POP_DENSITY”

When MI Pro creates the temporary query table, the population density column will 
now be named POP_DENSITY. 
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You can use aliases to rename any column in a table, not just derived columns. For 
example, if each country in your table is a separate sales territory for your 
corporation, you might want to rename the Country column “TERRITORY”. The 
procedure is identical:

• Country “TERRITORY”, Population / Area(obj, “sq mi”) “POP_DENSITY”

Make sure mapinfo/data is the directory that displays in the Directories list box. 
If it is not, you may need to double-click on the data directory in the 
directories list box.

Example: Computing Total World Population Density
In this example, you will practice several SQL Select features: 

• Create derived columns based on an aggregate function.

• Rename columns by typing column aliases.

• Create a new results table based on the WORLD table.

• Perform SQL Select on the new table.

In this example, you have a table of world population statistics (WORLD). You would 
like to create a table that shows the population density of the entire world. Use the 
following formula:

• TOTAL POPULATION / TOTAL AREA

While the WORLD table does not have total population or total area columns, we can 
derive them by applying the sum() aggregate function to the Population column and 
the Area function. We will do this in our first query.

Open the world table, and maximize its display by clicking the window’s maximize 
button. 

Choose Query > SQL Select. The SQL Select dialog displays.

From the SQL Select dialog, do the following:
1. In the From Tables Box, choose WORLD from the Tables drop-down list.
2. Tab to the Select Columns box and delete the asterisk (*).
3. Select Sum from the Aggregates drop-down list. 
4. Select Population from the Columns drop-down list.

After you select Population, the cursor will be on the inside of the end 
parenthesis [)]. Move it to the outside with the right arrow key. 

Sum (Population) will create a derived column that will compute the total 
world population.
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5. Press the spacebar once and type the column alias “Total_Pop”.

Remember, an alias has to be separated from its expression by a blank space. 
The Sum(Population) column will appear in the results table as Total_Pop.

6. Select Sum from the Aggregates drop-down list. 
7. Select Area from the Functions drop-down list.

After you select Area, the cursor will be on the inside of the end parenthesis 
[)]. Move it to the outside with the right arrow key. 

Sum(Area) will create a derived column that will compute the total area.

8. Press the spacebar once and type a column alias “Total_Area”.

The Sum(Area(obj, “sq mi”)) column will appear in the results table as 
Total_Area.

9. Leave Where Condition, Group By Columns, and Order By Columns blank.
10. Tab to the Into Table Named box.

Type in TOT_POP_AREA as the name for this table.

11. Click Verify. Click OK.
12. Make sure that the Browse Results check box is selected.

13. Click OK.

MI Pro produces a query table named TOT_POP_AREA containing two columns. The 
first column will return a value for the total population and the second column will 
return a value for the total area.
fo Professional User�s Guide 191
Apple Inc. 

Exhibit 1021 
Page 200



Chapter 10: Selecting Using Queries
Now that we have the total population and total area, we can compute the world’s 
population density by performing an SQL Select on the TOT_POP_AREA table we 
just created. In this SQL Select, we will divide the total population by the total area.

Choose Query > SQL Select to display the SQL Select dialog.

Fill in the dialog as follows:
1. In the From Tables Box, choose TOTAL_POP_AREA from the Tables drop-

down list.
2. Tab to the Select Columns box and delete the information from our last query.
3. Select Total_Pop from the Columns drop-down list. 

Remember, Total_Pop is the column we created from our last query.

Notice that when you select Total_Pop, COL1 appears in the Select Columns 
field. This is the column number of that field. When choosing derived 
columns from a previous query, MI Pro uses the column number instead of 
the name. Columns can be referred to by name or number, where the number 
designates the order the column has in the Select Columns box. COL1 and 
COL2 refer to the first and second columns, respectively.

4. Select the division sign (/) from the Operators drop-down list.
5. Select Total_Area from the Columns drop-down list.

COL2 displays in the Select Columns field.

6. Leave Where Condition, Group By Columns, and Order By Columns blank.
7. Tab to the Into Table Named box.

Type WORLD_DENSITY as the name of this table.

8. Click Verify. Click OK.
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9. Make sure that the Browse Results check box is selected.

10. Click OK.

MI Pro produces a query table named WORLD_DENSITY that will return a value for 
the population density in people per square mile for the entire world.

regating Data
When you aggregate data, you perform a mathematical operation on all of a column’s 
values in all of the records in your table. Unlike the Select command, which only 
allows you to perform mathematical functions on individual records, SQL allows you 
to aggregate (or summarize) data across records. 

MI Pro looks for each unique set of data values in the specified column or columns and 
creates one row for each such unique set. When you aggregate data, you need to 
specify:

• How the records will be grouped. 

• How the data will be aggregated (summarized). 
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For example, you have a table of sales representatives and their sales figures for the 
past three months:

MI Pro could also compute the total sales for each representative by specifying in the 
SQL Select dialog:

• Select Columns: SALES_REP, sum(SALES)

• Group by Columns: SALES_REP

or MI Pro could compute the average sales for each representative:

• Select Columns: SALES_REP, avg(SALES)

• Group by Columns: SALES_REP

or MI Pro could compute the total sales for each month:

• Select Columns: MONTH, sum(SALES)

SALES_REP MONTH SALES

John May 1200

Cathy May 900

Julie May 1100

John June 900

Cathy June 1400

Julie June 600

John July 1200

Cathy July 700

Julie July 1000

SALES_REP sum(SALES)

John 3300

Cathy 3000

Julie 2700

SALES_REP avg(SALES)

John 1100

Cathy 1000

Julie 900
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• Group by Columns: MONTH

MI Pro has six aggregate functions:

• Count(*): counts the number of records in a group. It takes * as its argument 
because it applies to the record as a whole, and not to any particular field in 
the record.

• Sum (expression): calculates the sum of the values in <expression> for all the 
records in a group. 

• Average (expression): calculates the average of the values in <expression> for 
all the records in a group. 

• WtAvg (expression): calculates the weighted average of the values in 
<expression> for all the records in a group. 

• Max (expression): finds the highest value in <expression> for all records in a 
group. 

• Min (expression): finds the lowest value in <expression> for all records in a 
group. 

up by and Order by Clauses
You can group your SQL query by a particular column so that all rows that contain the 
same value are grouped together. Specify this column in the Group by column box in 
the SQL Select dialog. When used in conjunction with aggregate functions, rows with 
the same value in all grouping columns are treated as a group. Duplicate rows are 
suppressed and aggregate values are reported for derived columns based on the 
aggregate functions. Specify the column(s) by name or by position number as listed in 
the Select Columns box. When using derived columns, you must specify the column 
number.

Along the same lines, you can tell MI Pro to order the results of your query in a certain 
way. By default, MI Pro orders records by their ascending value (which is alphabetical 
for character fields). When you list more than one column, MI Pro orders the records 
by the first column. Records with identical values in the first Order by column are 
ordered by their values in the second Order By column. Like the Group By clause 
above, use column names or position number. For derived columns use the number. 
Do not use “col” with the position number.

MONTH sum(SALES)

May 3200

June 2900

July 2900
nfo Professional User�s Guide 195
Apple Inc. 

Exhibit 1021 
Page 204



Chapter 10: Selecting Using Queries
For more on Group By and Order By, see the discussion under SQL Select in the 
MapInfo Reference.

Joining Tables Using SQL Select
When performing an SQL Select operation with multiple tables, MI Pro needs to join 
information from the records in the various tables. You may have a map table 
containing only graphic objects and their names and a table of statistical data for some 
geographic region. You want to display the statistical data on the map table. You 
could use SQL Select to create a query table in which your statistical data and map 
data are joined in one table. 

Whenever you are working with multiple tables, you must put a statement in the 
Where Condition telling MI Pro how to match up the rows in the different tables. 

For example, you have the World table that contains countries and a table of economic 
statistics (Eco_Stats), also broken down by country. You want to create a temporary 
query table that contains both sets of data: 

• Select Columns: * (an asterisk indicates include all columns in the query table)

• From Tables: World, Eco_Stats

• Where Condition: World.Country = Eco_Stats.Country

The two columns that you want to match do not have to have the same name. For 
example, you have a table of international customers (Int_Cust) that contains a sales 
territory column (TERRITORY). This column contains continent names, since your 
company breaks up its sales territories according to continent. If you wanted to 
temporarily join the two tables:

• Select Columns: *

• From Tables: World, Int_Cust

• Where Condition: World.Continent = Int_Cust.TERRITORY 

Example: Total Population and Area by Continent 
Given that MI Pro can aggregate data, we could compute total population and total 
area for every continent in the world. We want to create a table with the following 
information:

• Number of countries per continent

• Total population per continent

• Total area of each continent
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We also want the continents to be listed in alphabetical order.

Open the world.tab table, and maximize its display by clicking the maximize button. 

Choose Query > SQL Select to display the SQL Select dialog, and do the following: 
1. In the From Tables Box, choose WORLD from the Tables drop-down list.
2. In the Select Columns box, choose Continent from the Columns drop-down 

list, and choose Count(*) from the Aggregates drop-down list. 

Press the spacebar once and type the column alias “COUNTRIES” as the 
column alias. Remember, an alias has to be separated from its expression by a 
blank space. The Continent Count(*)  column will appear in the results table 
as COUNTRIES. 

3. Select Sum from the Aggregates drop-down list. 
4. Select Population from the Columns drop-down list.

After you select Population, the cursor will be on the inside of the end 
parenthesis [)]. Move it to the outside with the right arrow key. 

Sum (Population) will create a derived column that will compute the total 
world population.

5. Press the spacebar once and type the column alias “Total_Pop”. The 
Sum(Population) column will appear in the results table as Total_Pop.

6. Select Sum from the Aggregates drop-down list. 
7. Select Area from the Functions drop-down list.

After you select Area, the cursor will be on the inside of the end parenthesis 
[)]. Move it to the outside with the right arrow key. 

Sum(Area) will create a derived column that will compute the total area.

8. Press the spacebar once and type a column alias “Total_Area”.

The Sum(Area(obj, “sq mi”)) column will appear in the results table as 
Total_Area.

9. In the Group by Columns box, choose Continent from the Columns drop-
down list.

10. In the Order by Columns box, choose Continent from the Columns drop-
down list.

11. In the Into Table Named box, type POPULATION as the name for this table.
12. The Count(*) counts all the records in the table. However, since we are 

grouping the countries according to continent, MI Pro reports the number of 
countries in each continent and puts it in at a column called COUNTRIES (the 
alias).
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The resulting query table is shown in the following figure.  

Where Condition
A number of enhancements to formulating the Where condition in SQL joins allows 
MI Pro to join tables in a more logical, simpler way. 
198 MapInfo Professional User�s Guide
Apple Inc. 

Exhibit 1021 
Page 207



Chapter 10: Selecting Using Queries

MapIn
Order of Fields
The order of fields used in the Join does not matter. Either of the following syntaxes is 
acceptable:

Select * from A,B where A.field1 = B.field1

Select * from A,B where B.field1 = A.field1

However, keep in mind that when you switch the order of geographic operands, the 
geographic operator must also change. The following statements will produce 
identical results:

Select * from states, cities where states.obj contains 
cities.obj

Select * from states, cities where cities.obj within 
states.obj

Order of Clauses
The order in which Join clauses are performed does not matter. For example, each of 
the following are valid clauses:

Select * from Us_custg,States,City_125 
where States.state = City_125.state and States.state = 
Us_custg.state and Us_custg.order_amt > 10000

Select * from Us_custg,States,City_125 
where States.state = City_125.state and States.state = 
City_125.state and Us_custg.order_amt > 10000

Select * from Us_custg,States,City_125 
where Us_custg.state = States.state and 
Us_custg.order_amt > 10000 and States.state = 
City_125.state

Error Handling
If an invalid Where condition that uses an OR as a logical operator is detected, MI Pro 
will indicate an error has occurred. Usually this error will display whenever MI Pro 
cannot find a join between two tables. For example, if you have specified the 
following incorrect condition:

Select * from A,B where A.field1 = B.field1  or A.field1 = 
B.field2

The error “No join specified between A and B. Invalid join 
condition in Where clause” displays.
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Outer Join
An SQL outer join refers to the process of joining data from a larger table and a 
smaller table where you would like the result to be all the records in the larger table 
joined to whatever records matched from the smaller table. A problem arises if this is 
done as a standard join. A standard join in SQL Select will yield a table of only those 
records that matched. You would like to have empty fields where there is no match. 
For example, suppose you have a table containing a listing of all of the apartments in 
a building. There is also a table containing records for each of the tenants. The tables 
each have a field with the apartment number in it. Your task is to generate a table of 
all of the apartments and the tenants occupying the apartments. Some of the 
apartments will be  vacant and have no match in the tenant field.

The first step is to create a subset of the data where you can successfully match the 
apartment to the tenant.

1. Choose Query > SQL Select. Set up the following SQL query: 

2. Click OK. Your selection appears as a query browser. You will need to save 
this query to a base table.

3. Choose File > Save Copy As. The Save Copy As dialog displays. Choose the 
appropriate directory for your file and name it RESULT.TAB. Click Save.

4. Choose File > Open Table and open the RESULT table. This table includes all 
of the records from both tables where there was a match.
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5. Next, you must select the records from the APARTMNTS table that had no 
match in the tenants table. Choose Query > SQL Select and set up the 
following SQL query: 

6. The resulting query table is a list of all of the apartments that are not in the 
RESULT table. To include these records in your RESULT table, you must 
append them. Choose Table > Append Rows to Table.

7. Append the last query table to the RESULT table. This will append the list of 
vacant apartments to the list of occupied apartments. See Chapter 22, 
Managing Your Tables, for more information on appending rows.  

ding Information within a Column of Data–the InStr 
ction

The InStr funtion is used to locate a substring within a larger string. This function is 
useful for searching a character field to find the position of a specific character or 
group of characters. It can also be used to find any occurrence of the substring. 

For example, you want to select all of the streets in the POINTS table that contain the 
word “Main” in the STREET column. 

Set up your SQL Select statement as follows:
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In the above example, if the InStr function finds the word "Main" anywhere in the 
STREET column of the Points table, it will return a value greater than zero (the 
position of the first letter of "Main" in the string being searched). 

The syntax of the INSTR function is as follows: 

INSTR ( position, string, substring)

where:

position is the starting position of the search

string is the text string or field containing the string to be searched

substring is the text string that you are searching for

For example, if you want to find the position of the word "test" in a given text string, 
the InStr function will look something like this: 

INSTR(1,”This is a test of the Instr function”,”test”)

When this statement is executed, the value 11 will be returned.

Note:  If the string that you are searching for does not exist in the larger string, the 
value 0 will be returned.

For more information, see Appendix D: Creating Expressions. 
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ecting Records from One Table That Are Not in Another
The following SQL statement allows you to select records from one table that are not 
in another table based on a field common to both tables. For example, if you have a 
table, STATE1 and want to select all of the records from STATE1 that are not in 
CITY125.

1. Choose Query > SQL Select.

Note:  The statement syntax is as follows:  NOT  columnname IN (SELECT 
columnname FROM secondtable)

2. This SQL statement produces a query of all records in the table STATE1.Tab 
that do not exist in CITY125.Tab.

ecting Even or Odd Records from a Table
Every record in a table has a sequential record number or a RowID. Suppose you want 
to select every other record from your table. The easiest way is to check the table 
through RowID.

To select records that have an odd record number, do the following:
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Choose Query > SQL Select. Fill in the dialog as shown below:

Note:  RowID is a function, not a column name in the Soils table

To select records that have an even record number do the following:

Choose Query > SQL Select. Fill in the dialog as shown below:

 

Note:  RowID is a function, not a column name in the Soils table. 
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ecting Highways from a StreetInfo Table
If you are using MI Pro StreetInfo products, you may want to create a separate layer of 
just the highway data. The following selection demonstrates a typical selection of 
highways.

1. Choose File > Open. Select your StreetInfo file. In this example, the table 
name is NYSHCHES.TAB.

2. Choose Query > SQL Select. Fill in the dialog as shown below.

This will create a new table called HIGHWAYS that contains all the primary 
roads  contained in the StreetInfo NYSCHES table.

3. Choose File > Save Copy As and save the HIGHWAYS table. The HIGHWAYS 
table can now be added to your map as a separate layer.

Note:  The above SQL Select statement selects all of the primary roads as defined 
by the CFCC codes. To determine the class of the streets that you want to 
select, use the Info tool on a few of the streets that you want to select, or 
refer to your StreetInfo documentation for explanations of the classes. 

ding All Records with Duplicate Values in a Column
Often data is entered into tables by many different users. Sometimes data is repeated, 
or there is common information in several different records. This section explains how 
to find all rows in a table that, for a given column, share a value with another row. 
This is accomplished by performing two SQL Select statements.
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The first SQL Select statement produces a query table with two columns. The first 
column is a list of all unique values in the data column and the second column lists 
the number of times that each unique value occurs. The second SQL statement 
compares each data column value with all rows in the Query table where the count is 
greater than one.

In the example below, there is a table EMPLOYEE that has two columns Id_Num and 
Name. To find the duplicate values, perform the two SQL Selects, modifying them 
where indicated.

1. Choose Query > SQL Select and fill in the dialog as shown below. 

Substitute the name of your data column for ID_Num and the name of your 
table for EMPLOYEE. The number 1 in the Group By Columns box will group 
the row by ID_Num (the first column). The 2 Desc in the Order by Columns 
box will arrange the records in descending order based on the values in the 
count(*) field (the second column).

This SQL Select statement returns a query table with two columns. The first 
column contains every identification number possessed by at least one 
employee. The second column contains the number of employees that have 
that identification number. The rows are sorted by the number of employees 
that have each id number (i.e., the count).

2. Next, choose Query > SQL Select and fill in the dialog as shown below. 
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Also, change EMPLOYEE to the name of your table and ID_Num to the name 
of your data column.

In the example, the SQL statement returns a query table containing all of the 
rows from EMPLOYEE with duplicated data column values. The where 
condition selects all rows from EMPLOYEE that have an identification 
number that is the same as one of the ID numbers in the Count_By_ID query 
table. This sub-select finds all identification numbers that occur more than 
once. 

culating the Distance to a Fixed Point
In MI Pro it is possible to calculate the distance from one point to another. This 
example shows how to calculate the distance from a fixed point to every point in a 
geocoded table and store the result in another table.  

1. Determine the location of the fixed point. To find the position of a symbol on 
the map, double-click on the symbol with the Select tool. In this example, the 
X value is -101.697209 and the Y value is 36.050036.

2. Choose Query > SQL Select and fill in the dialog as shown below, substituting 
your X and Y values for the values mentioned above. As in the previous SQL 
query, replace EMPLOYEE with the name of your table, and ID_Num with the 
name of the relevant column from your table.
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3. Click OK. The resulting query table contains last names and first names plus a 
new column called DISTANCE which records the distance between the fixed 
location (-101.697209, 36.050036) and the point associated with each row of 
the table. 

4. To save the results in a permanent table, choose File > Save Copy As, and save 
the CUSTDIST table. 
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Using Thematic Mapping to 

Analyze Your Data

Thematic mapping is a powerful way to 
analyze and visualize your data. You give 
graphic form to your data so that you can see it 
on a map. Patterns and trends that are almost 
impossible to detect in lists of data reveal 
themselves clearly when you use thematic 
shading to display the data on a map.

You can create thematic maps with MapInfo 

Professional® using the following methods: 
ranges of values, graduated symbols, dot 
density, individual values, bar and pie charts 
and continuous grid. There are also several 
variations on and options within these 
methods, such as bivariate thematic mapping 
and inflection point, that give you even more 
ways to analyze your data.
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What Is Thematic Mapping?
Thematic mapping is the process of enhancing your map according to a particular 
theme. At the cornerstone of the theme is the data in your table. Themes represent 
your data with shades of color, fill patterns, symbols, or bar and pie charts. 

With MapInfo Professional, you create different thematic maps by assigning these 
colors, patterns, or symbols to map objects according to specific values in your table. 
MI Pro’s bar and pie charts allow you to make data comparisons for each record.

The Thematic Map feature uses a series of three dialogs to help you choose the type of
thematic map you want, the table(s) and fields that will be used to construct the map, 
and a variety of options to customize your map. 

MI Pro’s thematic templates make it easy to start constructing a theme. Just choose a 
template that represents the type of thematic map you want. The templates are fully 
customizable and can be saved as new templates for future thematic mapping needs. 
More than 40 templates ship with MI Pro.

.
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Types of Thematic Maps
With MI Pro you can create seven types of thematic maps, as listed under Type in the 
Step 1 of 3 dialog, below.

Each has its own purpose and unique attributes. For example, using Ranges of Values, 
you could thematically shade a map of the world according to population density. 
You could shade the countries with graduated shades of red, the darkest red 
representing the most densely populated countries, and the palest red representing 
the least densely populated countries. At a glance you can see the distribution of the 
world’s population.

You are not limited to representing numeric values with thematic mapping. Nominal 
values also may be shaded thematically. For example, you have a table of 
underground cables. Those cables that haven’t been serviced in the past six months 
are labeled priority status. Using Individual Values, you can shade the cables 
according to their repair status. All records with the same value will be shaded the 
same.

See the individual sections later in this chapter for more information on each type of 
thematic map. 
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Planning Your Thematic Map
Before you create a thematic map, it is important to know about the elements that 
make up a thematic map and how they are put together. This section will discuss 
thematic variables, where you can obtain your data, using data from the same table or 
another table, and the arrangement and display of thematic layers.

Thematic Variables
The data that you display on your thematic map is called the thematic variable. 
Depending on the type of thematic analysis you are performing, your map can show 
one or more thematic variables. Ranges of values, grid shading, graduated symbols, 
dot density, and individual values maps all examine one variable. With bar or pie 
charts, you can display more than one thematic variable at a time. 

A thematic variable can also be an expression. Choose Expression from the field list in
place of a data field to construct a statement that derives information from the data in 
your table(s). Although an expression can be made up of more than one variable (e.g., 
POP_1990 – POP_1980), for purposes of thematic mapping, a complete expression is 
equivalent to one thematic variable. See Chapter 10, Selecting Using Queries, and 
Appendix D, Creating Expressions, for more detailed information.

You can also create bivariate thematic maps, where one map object, such as a symbol, 
represents two different pieces of data. The symbol color, for example, can represent 
one thematic variable, and the symbol size can represent another.

Where to Obtain the Data
Before you begin your thematic map, you need to decide what information you want 
to display and locate where that information resides. It can either be in the table on 
which you are basing the map, or it can be in another table. 

If the data is in the same table on which you are basing the map, choose the desired 
field directly in the Field list box in the Thematic – Step 2 of 3 dialog. 

If the data is in another table, you must first bring the data into the table on which 
you’re basing the thematic map. This requires creating a temporary column using 
Update Column. 

Each situation is described below.
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Using Data from the Same Table
If you are using data from the same table, choose the table and field on which you 
want to base your thematic map in the Thematic – Step 2 of 3 dialog.

For example, you have a table of parking meters that contains the location of the 
parking meter and the last time the parking meter was emptied. Using Individual 
Values you want to shade the parking meter symbols according to the last time each 
meter was emptied. MI Pro will assign a color to each time. In Step 2 of 3, choose the 
parking meter table as your table, and choose the field that contains the time each 
meter was emptied. 

Using Data from a Different Table
The Join feature within the Thematic – Step 2 of 3 dialog enables you to use data from 
other open tables to create a thematic map. Choose Join in the Field list box to display 
the Update Column dialog where you can create a temporary column in the base 
table. 

The temporary column can contain data taken directly from the other table, or you 
can aggregate the data to create derived information for the temporary column. 

For example, you have two tables: a table of county boundaries and a table of police 
stations. You want to shade the table of county boundaries according to the number of 
police stations in each county. 

To do this, all the information you want to use must be in the county table. Therefore, 
you must add police station data to this table. 

Using Update Column, you create a temporary column in the county boundaries table 
that will store the police station information. To create this column, the two tables 
must have a link so that MI Pro can access the data that goes into the temporary 
column. The link can either be a matching field (like county name), or you can make 
the link geographically (police stations contained within counties).

An example later in this chapter explains more about Update Column. 
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Thematic Layers
When you create a thematic map in MI Pro, the thematic shading is added to your 
map as a separate layer. It is drawn on top of the base map layer.

Separate Layers
Separating thematic layers from the base map layer provides you with several 
important options: 

• Graduated symbol thematic maps do not require that your base map contain 
point objects. Instead, graduated symbol objects are built regardless of the 
map object type. Therefore, even if your base map contains region or line 
objects, you will still be able to create a graduated symbols map.

• You can have multiple thematic layers per base map layer. In some cases, you 
do not have to add another base layer to the map to create another thematic 
layer. You can display more than one thematic layer at a time, as well as 
perform bivariate thematic mapping.

• You can use Layer Control to turn the display on or off for a given thematic 
layer. The layer it is based on can continue to display. You can also set 
individual zoom layers on thematic maps.

Ordering of Thematic Layers
To display thematic layers properly, they must be in a specific order. This is especially
important when you want to display more than one thematic layer at a time. For 
example, you would want pie or bar charts for an area map to display on top of 
regions that are shaded in order to see them. 

The following lists the order of map layers from top to bottom (note that map layers 
are drawn from the bottom up): 

1. Pies, Bars, or Graduated Symbol thematic layer.
2. Dot Density thematic layer.
3. Ranged thematic layer – where Color or Size Attributes are applied.
4. Ranged (or Individual Value) thematic layer – where All Attributes are 

applied. 
5. Major layer or base layer.
6. Grid thematic layer.

When you create a new thematic layer, MI Pro automatically inserts it into its proper 
place. 
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Displaying Thematic Layers
You can turn the display on and off for thematic layers the same way you can for other 
map layers. All the display settings in Layer Control are also applicable to thematic 
layers, enabling you to set a zoom level for each thematic layer. You can also access 
the Modify Thematic Layer dialog through Layer Control by clicking the Thematic 
button. 

Thematic layers are always drawn after their base layer. Therefore, they appear above 
their base layer in the Layer Control list, and are indented to distinguish them from 
other map layers. 

Thematic layers are displayed in the list with this naming convention: 

<Thematic type> with/by <variable-list>

The type of thematic map is noted first, followed by the list of variables used to create 
the map. For example, a pie thematic layer that uses commuting data is listed this 
way: 

Pies with ComAlone, ComCarpool...

The variable list is truncated if there is not enough room to display each variable used 
in your thematic analysis. 

ethods of Thematic Mapping
The following sections offer general information on the methods available for creating 
thematic maps. For more information on any of these methods and options, see the 
Create Thematic Map Command in the MapInfo Professional Reference or Thematic 
Mapping in the Online Help.
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Individual Values Maps

Individual Values maps show points, lines, or boundaries that are shaded by 
individual values contained in a particular field. You can use both numerical and 
nominal values in individual values maps. MI Pro gives each unique value its own 
color or symbol. When an individual values map uses symbol types, the symbols are 
taken from the base table. 

For example, a soft drink distributor maintains a table of the supermarkets that buy 
soft drinks from him. Each supermarket sells the distributor’s brand of soft drink for a
different price. If the distributor shades the supermarket points by price, using 
individual values, all stores that sell the soft drink for 49 cents are shaded one color, 
all stores that sell the soft drink for 51 cents are shaded another color, and so on. Each 
unique value is assigned its own color. The distributor is able to see the price 
distribution among the supermarkets and can determine where he should increase his
sales volume, based on the price. 
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If you are shading your points, lines or boundaries using nominal data, you can shade 
only by individual values. Nominal data is either non-numerical data (name, type of 
cuisine served, or brand of automobile sold) or numeric data where the numbers 
represent non-numeric data like an ID number. Dates are considered numeric data 
and can be used in both ranged and individual values maps.

For example, you have the results from a consumer survey. One question on the 
survey reads “What is your favorite Sunday afternoon activity?” The possible 
responses are:

1. Sleeping
2. Watching TV
3. Taking a drive
4. Reading
5. Playing or watching sports
6. Visiting museums or art galleries
7. Going to the movies

You want to shade each consumer point with the response for the favorite Sunday 
activity. The SUNDAY column of your table contains the number that corresponds to 
the consumer’s favorite activity. However, the numbers in this column do not 
represent quantitative values. Going to the movies is not greater than Playing or 
watching sports even though 7 > 5. When numbers are used as names instead of 
values, you must shade your objects by individual values. The numbers are only used 
to reference the pastimes so color can be assigned to them. 
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Ranged Maps

When you create a ranged thematic map, MI Pro groups all records into ranges and 
assigns each record’s object the color, symbol, or line for its corresponding range. For 
example, you have a table of weather stations for your television viewing area, and 
you want to shade the locations according to their reported snowfall amounts. 

With the Ranged map feature, MI Pro groups the snowfall amounts into ranges. For 
instance, all weather stations that received between zero and five inches of snowfall in
the past month are grouped into one range. Stations receiving between five and 10 
inches are in a separate range. Sites that received between 10 and 15 inches are in a 
third range, while those stations reporting greater than 15 inch snowfall amounts are 
in a fourth range. 

All records are assigned to a range and then assigned a color based on that range. For 
instance, the weather stations reporting the 15 plus inches of snow are shaded red. 
The other ranges are shaded in lighter shades of red with the last range in gray 
(default colors). When you display the map, the colors make it readily apparent which
locations received the most and least snow accumulation.
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Ranges are also useful when the size of the region is not directly related to the 
magnitude of the data values. In our population density example at the beginning of 
the chapter, countries that are small in size can be very densely populated, and 
countries that are large in size may not be densely populated. Differences like these 
are more readily apparent when the regions are shaded in this manner.

Types of Ranged Values
MI Pro can create ranges automatically using five methods: Equal Count, Equal 
Ranges, Natural Break, (Standard Deviation), Quantile, and Custom. To set ranges 
manually, use Custom. 

Equal Count has the same number of records in each range. If you want MI Pro to 
group 100 records into 4 ranges using Equal Count, MI Pro computes the ranges so 
that approximately 25 records fall into each range, depending on the rounding factor 
you set. 

When using Equal Count (or any other range method), it’s important to watch out for 
any extreme data values that might affect your thematic map (in statistics, these 
values are referred to as outliers). For example, if you tell MI Pro to shade according to 
Equal Count with this database:

Ben and Miguel are grouped in the same range (since they have the two lowest 
values). This may not produce the results you want since the value for Ben is so much 
lower than any of the other values. 

Equal Ranges divides records across ranges of equal size. For example, you have a 
field in your table with data values ranging from 1 to 100. You want to create a 
thematic map with four equal size ranges. MI Pro produces ranges 1–25, 25–50, 50–75, 
and 75–100. (Since ranges use "=>" and "<=", they need to overlap.) 

John 5000 Andrea 7000

Penny 6000 Kyle 5500

Miguel 4500 Angela 7500

Linda 5000 Elroy 6000

Ben 100 Mark 7000
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Keep in mind that MI Pro may create ranges with no data records, depending on the 
distribution of your data. For example, if you tell MI Pro to shade the following 
database according to Equal Ranges:

MI Pro creates four ranges (1–25, 25–50, 50–75, and 75–100). Notice, however, that 
only two of those ranges (1–25 and 75–100) actually contain records.

Natural Break and Quantile are two ways to show data that is not evenly distributed. 

Natural Break creates ranges according to an algorithm that uses the average of each 
range to distribute the data more evenly across the ranges. It distributes the values so 
that the average of each range is as close as possible to each of the range values in that 
range. This ensures that the ranges are well-represented by their averages, and that 
data values within each of the ranges are fairly close together. 

Quantiling enables you to build ranges that determine the distribution of a thematic 
variable across a segment of your data. For example, you can quantile state 
population by urban population to illustrate how urban population is distributed 
across the United States. Your legend will not indicate that you have used Quantile to 
build your ranges. You can customize the legend so that it shows which field you 
used to quantile the table. 

When you create ranges using Standard Deviation, the middle range breaks at the 
mean of your values, and the ranges above and below the middle range are one 
standard deviation above or below the mean. 

You can also define your own ranges using Custom. 

Customizing Range Styles and Inflection Point
When you customize range styles, you can choose which attributes to display on your 
map: color, size, or all attributes. The size attribute becomes available when you are 
working with point and line data. You can change the size of each symbol, or use 
graduated symbols to represent your ranges. 

John 100 Andrea 90

Penny 6 Kyle 1

Miguel 4 Angela 92

Linda 95 Elroy 89

Ben 10 Mark 10
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Another effective way to customize the display of ranges of data is by inserting an 
inflection point between ranges. An inflection point is a color style that provides you 
with a second interpolation of your data. This option is useful for showing two sets of 
contrasting information, like data that contains positive and negative values such as 
profit and loss figures, or population growth. 

The colors of the top and bottom ranges spread to, but never reach, the inflection 
point color. They only approach the inflection point. For example, if the inflection 
point is white, and the top and bottom range colors are blue and red respectively, the 
color spreads from blue to white, and from white to red. The ranges closest to the 
inflection point are either very pale blue or red, but they never actually become white.

See the example at the end of this chapter for more on using an inflection point.

For more information about customizing ranges and other Create Thematic Map 
options, see Create Thematic Map Command in the MapInfo Professional Reference. 

rid Surface Thematic Maps
MI Pro takes thematic mapping to a new level with a method that displays data as 
continuous color gradations across the map. This type of thematic mapping, known as 
grid mapping or surface theme mapping, is produced by an interpolation of point 
data from the source table. MI Pro generates a grid file from the data interpolation and 
displays it as a raster image in a Map window. 

Grid theme maps are appropriate analytical tools in traditional GIS environments and 
other industries where the data points have measured values that reflect those 
locations. For example, use grid shading to illustrate temperature changes, snowfall 
amounts, or change in elevation. The illustration below shows the light to dark 
gradual transition across the United States, which represents low to high average 
annual temperatures. The continuous shading allows you to derive measurements at 
places other than where measurements were taken. 
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Grid Image Files
Grid mapping produces a file type called a grid image. When you create a grid 
thematic map using MI Pro’s grid handler, MI Pro generates a default file name of 
tablename_fieldname with the extension .mig (e.g., Uselev_elevfeet.mig). In the Step 2 of 
3 dialog MI Pro displays the path and the root file name, where you can change it as 
necessary. 

You can have other grid file handlers installed. To set the default grid writeable 
handler, go to the Map window preferences (Options>Preferences>Map Window) 
and specify a grid handler. The available handler formats depend on what grid 
handlers have been installed. Changing the default grid handler will change the 
default file extension of the grid file name. 

Grid files are stored by default in the data directory specified as a preference (Options 
Preferences>Directories>New grids). Grid files can be opened from the File > Open 
command like other MI Pro supported file types. All other thematic layers are 
temporary and can only be saved in a workspace.
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When you open an MI Pro table that has a grid filename associated with it, MI Pro  
searches for the file if it cannot find it immediately. For example, the search capability 
can simplify opening tables if your .TAB file refers to an image that resides on a CD-
ROM drive, and different letters are used to designate the CD-ROM drive on different 
systems.

MI Pro uses the following search order:
1. Search for the file where specified by the FILE tag in the .TAB file.
2. Search for the file in the same directory as the .TAB file.
3. Search for the file in the Table Search path specified in the Directories 

preferences (Options>Preferences>Directories>Search Directories for Tables). 

MI Pro either opens the table as though it found the file in the specified location, or it 
will report an error because the file could not be found in any location.

Grid Handlers
MI Pro includes read-only grid handlers to support the direct opening of the 
following grid file formats: 

• DEM–USGS ASCII(*.dem)

• DTED–levels 1, 2, and 3 (*.dt0, *.dt1, *.dt2) 

• GTOPO30 (*.dem)

• Marconi (*.grd, *.grc)

You can open these grid file types directly from the Open dialog. You will see the file 
extensions listed next to the Grid Image file type in the Files of Type drop-down list in 
the bottom of the dialog. Because the handlers are read-only, they cannot be used to 
create grid files during the thematic mapping process. 

If the relief shading option is enabled, a separate file will be created to store the 
hillshade information. The hillshade file is stored in the same location as the grid file 
and has the same base name as the grid but with the extension ".mih". If the grid file is 
read-only, e.g., it’s located on a CD-ROM, the .mih files will be created in the same 
location as the .tab file. The .tab file will contain a new metadata key, for example: 

"\Grid\Hillshade File" = "d:\tmp\AntiochSouth.mih" 

Vertical Mapper Grid Handler
MI Pro also includes the Vertical Mapper Grid handler to enable users who do not 
have the full Vertical Mapper add-on product by Marconi to open, view, and print 
Vertical Mapper Grid (*.grd, *.grc) format files. 
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The Vertical Mapper Grid files can also be opened directly in MI Pro. The *.grd 
extension is listed with the other Grid Image formats in the Files of Type drop-down 
list. 

Currently, grids using the Vertical Mapper handler cannot be modified in the Modify 
Thematic Map dialog. They are read-only. They must be modified within Marconi 
original Vertical Mapper source application. In addition, you cannot create .grd or .grc 
files in MI Pro, however, you can convert *.grd fiels to *.mig files with Gridtools.mbx. 
You must use the Vertical Mapper application, which runs within MI Pro, to create 
them.  

Grid Interpolation
MI Pro provides two interpolators for creating grid themes: Inverse Distance 
Weighting (IDW) and Triangulated Irregular Network (TIN). 

IDW Interpolator

The IDW interpolator is best suited for data values that produce arbitrary values over 
the grid, that is, data that does not have any relationship or influence over 
neighboring data values, such as population. This method of interpolation also works 
well for sparse data. 

The IDW interpolator calculates the value of grid cells that cover the mapping area. 
Each data point value from your source table that is considered in the calculation for a 
cell value is weighted by its distance from the center of the cell. Because the 
interpolation is an inverse distance weighting calculation, the farther the point is from 
the cell, the less influence its value will have on the resulting cell value. 

MI Pro’s grid mapping process begins by determining the minimum bounding 
rectangle (MBR) of the source table. The grid is divided into equal sized square cells of 
some size. For example, using the Grid default template, the States table in MI Pro’s 
sample data set creates a grid dimension of 200 cells by 303 cells. By calculating the 
number of cells in the grid and knowing the dimension of the MBR, MI Pro 
determines that each cell needs to be 18.1 by 18.1 miles square. (Your cell size will be 
in whatever distance units you have set for the Map window. To change the units, go 
to Map > Options > Map Units). 
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The settings for the IDW interpolator are controlled via the Settings button in the Step 
3 of 3 dialog. The illustration above shows the settings for the States table if you are 
basing the grid theme on the Grid Default or Grid Gray Default templates that ship 
with MI Pro. Note the cell size number represents both the height and width of the 
cell. Any change to the cell size will result in an automatic update of the grid 
dimensions. 

With the cell size and the source points and values known, MI Pro calculates a value 
for each cell. This value is determined by calculating a distance-weighted average of 
the points that lie within the specified search radius. Points are inversely weighted by 
their distance from the center of the cell. 

In IDW, the exponent determines how much influence each point will have on the 
result. The higher the exponent the greater the influence closer points will have on the 
cell value. Exponents can range from one to 10.

You can also choose an aggregation method for the z-values of source data points that 
are in the same grid cell. Choose from: average, count, sum, min, and max.  

TIN Interpolator

The TIN interpolator works best for terrain data and for data points that have a linear 
progression or relationship to each other across the grid, such as temperature. 
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The TIN interpolator produces triangles from a network of points that more closely 
reproduces the original map terrain than the IDW interpolator. It draws lines between 
points, dividing them into triangles and connecting all the points that it can. It creates 
a mesh of connectivity so that the grid points can be interpolated. The interpolation is 
not influenced by the neighboring original data values, so you do not get the "false 
bumping" of data that you can get with the IDW interpolator. 

Included in the Grid templates in the Create Thematic Map–Step 1 of 3 dialog are two 
templates that work best with the TIN interpolator. The TIN interpolator settings are 
specified in the Step 3 of 3 dialog. Click the Settings button to display the TIN 
Interpolator Settings dialog.

As in the IDW interpolator, the cell size indicated in the TIN interpolator is square: the 
number represents both the height and width of the cell. The grid dimensions are 
automatically updated when the cell size is changed. 

The TIN settings can be manipulated to give more or less detail to the map terrain. 
The Tolerance setting controls whether closely spaced points are discarded. The 
tolerance is a fraction of the diagonal length of the bounding box of the points. 

The Distance value controls the output. For non-zero distance values, only edges or 
triangles contained within a sphere centered at mesh vertices are output. This is 
useful to constrain the triangulated irregular network to a specified distance; 
otherwise, the triangulation will cross concave regions.

The Feature Angle setting controls the angle (in degrees) that defines a sharp edge. 
This setting is used for smoothing the final grid. If the difference in angle across 
neighboring polygons is greater than this value, the shared edge is considered 
"sharp."  
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Grid Appearance
Once the cell values are calculated, MI Pro groups them into a color spectrum that is 
bounded by the minimum and maximum values in the table. The grid’s appearance is 
controlled in the Grid Appearance dialog, which you can access by clicking the Styles 
button in Step 3. 

Inflection Methods 
You can control how the color is spread by specifying an inflection method, and the 
number of inflection points. The Number of inflections drop-down list shows 
numbers 2–16, but you can type any number between 2 and 255. You can also apply a 
rounding factor to the inflection values. If the inflection method is based on cell count, 
you may not see the effects of the rounding factor until the inflection values are 
calculated. The inflection methods are listed below:

• Equal Cell Count–Sets the inflections so that approximately an equal number 
of grid cells fall between each inflection value.

• Equal Value Ranges–Spreads the inflections evenly between the minimum 
and maximum values of the data range.

• Custom Cell Count–Use this method to specify your own percentages.

• Custom Value Ranges–Use this method to specify your own values. 

The Grid default template assigns blue to the minimum value and red to the 
maximum value. These minimum and maximum values are also expressed as 
percentages of the range. These color settings/values are known as inflection points 
and will display in the legend with a particular color, value and percentage. If a cell 
has the exact value as the inflection point, it will display that color on the map. A cell 
value that falls between two inflection points displays with the color that is in 
between the colors of those inflection points.
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When you increase the number of inflections, MI Pro chooses default colors for the 
new inflections. The last inflection color remains the same. New ones are inserted 
between the new last inflection and the one before it. 

To change the color of an inflection point, double-click on the color swatch and choose 
a new color from the palette. To edit the inflection percentages/values, single or 
double-click on a value. You can type the new value right over the old value. 

Relief Shading
Relief shading allows you to shade your grid surface map according to a virtual light 
source. MI Pro adjusts the brightness of each grid cell based on its orientation to the 
light source. This enables you to take surface slope and direction into account relative 
to the direction of the light.

The brightness values that MI Pro assigns to each cell correspond to light striking the 
surface. The light source can be the sun shining on a topographic surface. The 
maximum brightness is assigned at points where the sun’s rays are perpendicular to 
the surface (the slope directly faces the light source). As the slope faces turn away 
from the light source, lower brightness values are assigned. 
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Grid Translucency
The translucency setting allows you to set how much you can see through the grid 
layer. For example, in a boundary map, you may want to be able to see the boundaries 
as well as the topological terrain. A translucency setting of 0% produces a completely 
opaque image. A setting of 100% produces a completely transparent image. Set the 
translucency according to how much of the details in the layers underneath the grid 
you want to see.  

Final Adjustments
You can make other color adjustments to your grid surface map. You can set the 
contrast and brightness level, or show the grid in gray scale. You can also invert the 
inflection colors using the Flip Colors button. 

Once the inflection settings, any relief shading, and other color settings are finalized, 
you are ready to produce the map. MI Pro generates the grid theme map layer as a 
raster image. The inflection points grade from one color to another in smooth 
transitions to illustrate the distribution of the data.  

Zoom Layering
Zoom layering for grid layers is now controlled in the Map window preferences. To 
change the zoom layering setting for a grid surface map that you are currently 
working with, go to the Map Options dialog (Map>Options) and either activate or 
turn off zoom layering. The setting is turned off by default. 

Working with Grid Theme Layers
The grid thematic layer is different from other thematic layers in that, once it is 
created, it is independent of its base layer. Because it is a type of raster image, it can be 
reordered in the Map window as a separate layer. If the data in the base layer changes, 
the grid will not automatically update. In that case, you must re-interpolate the grid. 
The layer displays in Layer Control with a default layer name of table name_fieldname.

Info Tool and InfoTips
You can use the Info tool to get information on individual grid cells. When the Map 
window is active, click on the Info tool button on the Main toolbar to select it and click 
on the map. The Info tool displays the surface grid’s name and the data value 
associated with it. The information in the Info tool window is read-only in this 
instance, as you cannot change the cell’s value. 
When InfoTips are active, hovering the cursor over a grid cell will display the cell’s 
value. 
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Grid Tools Utility
The Grid Tools utility contains three tools that help you get the most from your grid 
layers. 

Note:  Grid Tools replaces the DEM2Grid utility included in earlier versions of MI 
Pro.

Converting Grid Files

The Grid File Converter enables you to convert any grid file supported by a grid 
handler to an MI Pro grid file (.mig). You must provide a color file that defines the 
inflection points of the new grid file. The tool gives you the option of generating relief 
shading for the new file, and opening the file after the conversion. It replaces the 
DEM2Grid MapBasic utility included in earlier versions of MI Pro. 

To load Grid Tools, choose Tools>Tool Manager, and select the Loaded check box next 
to the Grid Tools utility. Then choose Tools>Grid Tools>Create MapInfo Grid from 
Other Grid File to display the dialog.

To select the input and output grid files and the color file, use the corresponding 
Browse buttons to navigate to their respective locations. Select the Relief shading 
check box to activate relief shading for the converted grid file. Click the Relief Shade 
Options button to display the Relief Shade Options dialog, where you can specify the 
angle of the light source and the vertical scale factor. Select the Open and Map Grid 
File check box to have MI Pro display the grid in a Map window. 
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Other Grid Tools

In addition to the Grid File Converter, Grid Tools enables you to create a MI Pro grid 
file from a table of points. This works best if the records in your table represent a 
regular grid of points. Choose Tools>Grid Tools>Create MapInfo Grid from Table of 
Objects to display the dialog. 

Finally, loading Grid Tools places a grid "info tool" on the Tools toolbar that you can 
use to display the x, y, and z coordinates of a mouse-click location in a grid layer. Click 
on the button to activate it, and then click anywhere on your grid layer to display the 
coordinates for that location. 

Clipping a Grid Map
MI Pro’s grid feature allows you to clip the grid map with a table of region objects. MI 
Pro generates a rectangular grid based on the MBR of the source table. In order for the 
grid boundary to follow the outline of your map boundary, specify that the grid be 
clipped by the map or another table of boundaries. MI Pro first creates a single object 
out of all objects in the clipping table and then clips the grid to match it. Set the 
clipping table in the Step 2 of 3 dialog under Grid Options. 
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If your source data points do not extend beyond your clipping region, your grid map 
will not be completed filled with grid cells. To avoid this, in the Interpolator Settings 
dialog for IDW Interpolation (reached by the Settings button in the Step 3 of 3 dialog), 
type a value in the Grid Border box to represents the miles you want added to the grid 
that will meet or exceed the source table’s MBR. This value will add the same amount 
to all four sides of the grid. 

3D Viewing 
MapInfo Professional contains a 3D viewing capability. Based on Microsoft’s 
implementation of OpenGL software graphics interface, it allows freehand tilt and 
rotation of the image. The traditional pan, zoom, and Info tools also operate in the 
3DMap window.

You can create a 3D view of any map that contains a continuous grid layer. For 
example, by importing digital elevation model (DEM) files or interpolate from a layer 
of points that contain elevation values. The image of any other layers will be draped 
over the 3D surface. Keep in mind, the 3D surface is not limited to representing 
elevation. It can also be used to show property value, sales potential, population 
density, air temperature, etc.

Areas with missing grid cells
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Use the Create 3DMap command (Map > Create 3DMap) to create a 3D view of a Grid 
Thematic map when the Grid Thematic map is in the active window. You can rotate, 
zoom, and pan the 3D view. Additionally, you can clone the 3D view.

The 3DMap window is a stand-alone window. Therefore, if you modify the tables in 
the Grid Thematic map used to create the 3DMap, choose the Refresh Grid Texture 
option in the 3DWindow menu to update the 3DMap. To change the settings in an 
existing 3DMap window, select Properties on the 3DWindow menu. 

Creating a 3DMap
To create a 3DMap:

1. Create a Grid Thematic map or open an existing grid layer. See Grid Surface 
Thematic Maps for more information.

2. Choose Map > Create 3DMap. The Create 3DMap dialog displays.
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From this dialog you can set:

Camera: Specify the camera position and orientation. 

Light: Designate the position and color of the light source. 

Appearance: Specify appearance attributes including Units, Resolution, and Scale. 
Units is only available when first creating a 3DMap. Resolution and scale are available 
later as well. 

To create a 3DMap using the default settings click OK. The 3D View of the map 
displays. 

The map below displays land elevations in the United States. It is available from the 
MI Pro CD. Open the Elev_ft.mig file from the NAmrca\USA\Grid folder. 
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The 3DWindow Menu
When the 3DMap is the active window, the 3DWindow menu displays in the menu 
bar. This menu also displays as a shortcut menu when you right-click in the 3DMap 
window. The 3DWindow menu contains the following commands: 

Refresh Texture: Regenerate the image that is used for the texture on the grid. If the 
tables used in the 3DMap change or objects are updated, use this option to refresh the 
map.

Clone View: Create a clone of the 3DMap window.

Previous View: Return to the previous view of the 3DMap.

View Entire Layer: Re-center the 3DMap in the window. If you zoom or pan the map 
from view, use this option to redisplay the map in the window.

Viewpoint Control: Displays the Viewpoint Control dialog. 

ViewPoint Control Dialog: In addition to duplicating the functionality you have with 
the selection and the zoom tools, the ViewPoint Control Dialog has a Mapper View 
button that will reposition the 3DMap window to match the view from the original 
Map window.
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WireFrame: Toggle between a wireframe and surface representation of the grid. This 
option is not saved to a workspace. Additionally, cloned 3DMap windows have the 
surface representation of the grid, even if the cloned window is in wireframe mode. 
You can also toggle the wireframe mode on and off with the ‘W’ key on the keyboard 
when the 3DMap window is active. Here is an example of a wireframe map:

Properties: Display the 3DMap Properties dialog displaying the current 3DMap 
settings. Use this dialog to modify the Light and Appearance settings of the active 
3DMap. Additionally, display this menu by right-clicking when in the 3DMap 
window. 
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Manipulating a 3DMap 
To manipulate the view of a 3DMap window, choose the Select tool. Click and hold 
the left mouse button in the 3DMap window. As you move the mouse the viewpoint 
will be rotated around the focal point. The Info, Grabber, and Zoom tools are available 
for use within the 3DMap window. The Info tool will return the grid elevation value 
at a selected point. 

rism Maps
Prism maps offer another way to create a three-dimensional view of your map. In a 
Prism map, the height of the geography is raised according to a specified column 
value from your table or a derived value from an expression—the greater the value, 
the higher the height of the geography. Each geography becomes a prism, allowing 
you to compare data values of objects relative to each other according to the height of 
each prism. 

Prism maps are created using region layers. Other closed objects such as rectangles, 
ellipses, and rounded rectangles are also included in the Prism map, as well as the 
region portion of  Collection objects. Point objects are not included in the Prism Map.

The prism effect does not interfere with the display of other components in a Map 
window, including other map layers, themes, or labels. When the Prism map is 
created, the image from the original Map window is "pasted" on the resulting 3D 
objects. 

Note:  Creating a Prism map from complex geographical objects (e.g. high 
resolution boundaries) requires a significant amount of memory and time. 
Memory resources may run out on some systems.

The 3DWindow menu is shared between 3DMaps and Prism maps. When a Prism 
map is the active Map window, the 3DWindow menu displays on the menu bar. 

The commands in the 3DWindow menu for Prism maps are the same as those for 
3DMaps. You can control the view of the map, create a duplicate view, and set the 
map’s point of view, enabling you to choose the angle that will best emphasize the 
prism effect of the raised geographies. 
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Creating a Prism Map
To create a Prism map: 

1. Make sure a Map window is the active window and that it contains a region 
layer.

2. Choose Map>Create Prism Map. The Create Prism Map dialog displays.

3. In the Choose Layer and Column group, choose the layer to map, and choose 
a column value. Only numeric columns from the layer you chose display in 
the dialog. 
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To use a character column, create an expression. Choose Expression from the 
Column drop-down list to display the Expression dialog. 

Select the character column you want to use, and use the Val() function to 
convert a character string to a numeric value. This function returns zero for 
any character string that has no numeric meaning.

4. In the Appearance group, specify the Background color. This color is used for 
the window’s background. Also specify the Light color. This color is the 
lighting for your map. It acts as a "cover" to the camera lens as it views the 
map.

5. In the Camera group, choose the camera’s position and orientation. The 
Horizontal Angle measures the rotation of the map around the center point of 
the grid. This value can range from 0–360 degrees. The Vertical Angle 
measures the rotation in elevation from the start point directly over the map. 
This value ranges from 0–90 degrees. 

6. Click OK. The Prism map displays in your Map window. 

Bivariate Prism Maps
Because prism maps preserve the display of other map elements, including themes, 
you can easily add a second theme to your prism map, such as ranges or individual 
values, to create a bivariate map.

Map and Browser Editing
If you change a row value of an object in a Prism map or edit an object directly in a 
Map window, the Prism map will reflect these changes.  For example, if you change a 
data value that was used directly in a Prism map, or as part of an expression that was 
used to calculate a value, the prism height of the corresponding objects will change to 
reflect the new value. This includes single row changes and column updates. 

When you move objects in a Prism map, the Prism map object that is based on the 
original object will also move. When you add objects to the Prism map, they will 
display flat because data values for new objects are initially set as zero.

Sometimes an object in a Prism map displays the incorrect texture or image.  This 
usually occurs when the geometry of an object has changed for some reason, for 
example, as a result of map clipping, moving the object, or adding or removing nodes.  
Use the Refresh Texture command in the 3DWindow menu or the shortcut menu in 
the Prism map window to correct the display.  
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Modifying a Prism Map
To modify a Prism map, choose Properties from the 3DWindow menu, or right-click to 
display the shortcut menu, and then choose Properties. The Prism Map Properties 
dialog displays.

In addition to modifying the Background and Light color settings, you can specify 
InfoTips and set a scale for the Z direction (vertical) of the map. 

The InfoTip information can come from any column in the table or valid expression. 
The values will display when you hover the cursor over an object using a tool that 
supports ToolTips.

A scale for the Z direction is calculated during the initial creation of the Prism map. If 
you decide to modify it, keep in mind that the values used for the prism height may 
greatly exceed the x and y dimensions. For example, in a Prism map of population, 
values could easily be in the millions. The scale must be small enough so that the 
objects can be viewed. A scale value >1 will exaggerate the topology in the Z 
direction; a value <1 will scale down the topological features in the Z direction.  
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raduated Symbol Maps

Graduated symbol maps use symbols to represent different values. You can use 
graduated symbols regardless of the type of map object with which you are working. 

For instance, use graduated symbols to show the number of housing units by city. 
When you select the graduated symbols option, MI Pro varies the size of each symbol 
according to the value in the sales order field. 

Or you can represent how much interest each customer has expressed in a given 
product by assigning a symbol whose size is proportional to the customer’s interest.

Graduated symbols maps work best when you use numeric data. If you are working 
with a layer of restaurants, it makes no sense to create graduated symbols based on 
the type of cuisine each restaurant serves. However, graduated symbols are 
appropriate when you want to show the number of hamburgers sold at 20 different 
fast food restaurants.
apInfo Professional User�s Guide 241

Apple Inc. 
Exhibit 1021 

Page 250



Chapter 11: Using Thematic Mapping to Analyze your Data

 

 

There are three attributes you can customize on a graduated symbols map: the color, 
type, and size of the symbol. To change the symbol’s attributes in Thenatic Step 3 of 3, 
choose Customize Settings and click on the symbol icon in the Customize Graduated 
Symbols dialog to access the Symbol Style dialog. The default symbol is a red circle. 

In the Customize Graduated Symbols dialog, the size of the symbol in the Symbol box
is the size for the value listed in the at Value box. All values between the high value 
and zero have interpolated point sizes. If you want the symbols at the low end to be 
larger, increase the point size.

You can also display symbols for negative data values. To change it, click Options in 
the Customize Graduated Symbols dialog. There is a separate symbol picker so that 
you can make this symbol as distinct from the symbol for positive values as you want.
When you click the icon a different Symbol Style dialog displays, enabling you to 
choose a different symbol type, change the color or the size, or change any 
combination of the three attributes. The default symbol for negative values is a blue 
circle, and all values between zero and the low value (a negative number) also have 
interpolated point sizes. 

Dot Density Maps
Dot density maps use dots to represent the data value associated with a boundary or 
region. The total number of dots in a region represents that region’s data value. If you 
have 10,000 senior citizens in a county, and each dot represents 100 senior citizens, 
there would be 100 dots in the county boundary. 

Dot density is particularly useful for showing raw data where one dot represents a 
large number of something: population, number of fast food restaurants, number of 
distributors who carry a brand of soda, etc. 

For example, if you have a table of age demographics broken down into ZIP Codes, 
you could use the dot density option to show the concentration of small children in 
each ZIP Code boundary.
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There are three customizing options for dot density maps. You can specify the value of 
one dot. For example, you have a table of population statistics, broken down by 
county. There are 20,000 high school students in Rensselaer County, New York. If you 
shade Rensselaer County according to the number of high school students using the 
dot density method, each dot could represent 200 students. In that case, there would 
be 100 dots in Rensselaer County. 

When you increase the value each dot represents, you decrease the number of dots 
that display on the map. You could modify your dot density map so that one dot 
represents 400 students. In that case, there would only be 50 dots in Rensselaer 
County. 

A second option is to change the size of the dots according to your needs, either large 
or small. If you are working with large populations, or large counts of something, 
make the dot size smaller so that the distribution of dots is easier to see. Conversely, if 
your working with a small data set, making the dot size larger might illustrate your 
analysis more clearly.

Note: Distribution of dots is random within the region. If you shade states according 
to population, the dots for New York are spread out throughout the state; they are not 
concentrated in New York City, where the majority of the state’s population lives. 
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Thirdly, in the Customize Dot Density Settings dialog, change the color of the dot to 
either red or black to add more variety to the final map. You can create multiple dot 
density maps on the same layer by varying these options. 

Bar Chart Maps
Unlike thematic maps for single variables such as ranges of values or graduated 
symbols, a thematic bar chart map allows you to examine more than one variable per 
record at a time. A bar chart is built for every map object at the centroid of the object, 
enabling you to analyze the thematic variables in a particular chart by comparing the 
height of the bars. You can also examine the same variable across all the charts in your
map. 

For example, you have a table of U.S. state boundaries containing 1980 and 1990 
population. Using bar charts, you can create a thematic map that displays a two-bar 
chart for each state: one bar representing 1980 population, and the other representing 
1990 population. You can compare the population growth within each state between 
1980 and 1990, or you can examine several states and compare one state’s population 
or population growth to another’s. For best results, use no more than four to six bars 
per bar chart in your analysis.
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You can customize the color of each bar, create a frame around each chart, and fill the 
empty space inside the frame with a pattern or color. In addition, you can change the 
bar chart’s orientation, such as displaying horizontal bars instead of vertical (the 
default). You can also control where to display the chart: over the object’s centroid (the 
default) or any of eight other locations. 

You can also change the type of bar chart. In our example, you can create a multi-bar 
chart, where each thematic variable has its own bar, or a stacked bar chart with each 
thematic variable on top of one another, or a graduated bar chart, where the bars are 
graduated in size based on some value. You can also scale the bars in a multi-bar chart 
independently from one another. To show negative values in a bar chart map, the bars 
extend in the opposite direction to the chart’s orientation. Note that negative values 
do not display in stacked bar charts. 
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Pie Chart Maps
Thematic mapping using pie charts also enables you to examine more than one 
variable per record at a time. Like comparing the height of the bars in bar charts, in 
pie charts you compare the wedges in a single pie, or examine a particular pie wedge 
across all of the pies. Pie charts also enable you to compare parts of a whole.

Both pie and bar charts are particularly useful for analyzing demographic data. For 
example, you have a table of demographic information for the United States. Your 
table shows the populations of several major demographic groups. Using pie charts, 
you can show the population of each demographic group, and see what fraction of the 
pie it makes up in each pie. This enables you to see the distribution of demographic 
groups on a per state basis, or across the entire United States. You can also look at one 
demographic group and see how the population of the group varies in different states.
For best results, use no more than four to six pie wedges per pie chart in your analysis.

You can customize the color of each pie wedge as well as the borders of the wedges 
and the whole pie. You can also specify the angle at which you want to place the first 
pie wedge, and whether the variables go in a clockwise or counterclockwise direction. 
Like bar charts, you can also change the pie’s orientation. The default is to place the 
pie over the centroid of the object.
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You can choose from graduated pies or half pies. Graduated pies will graduate the 
size of the pies according to the sum of their components. With half pies your data 
will be distributed across half a pie instead of a whole pie. 

sing Update Column with Thematic Mapping
As explained earlier in this chapter, you can use data from another table to construct 
your thematic map using Update Column. 

Update Column creates a temporary column in your base table and automatically 
inserts data into it for your map. This data can be a field taken directly from another 
table, or aggregated from other data.

For example, you have a table of U.S. state boundaries and a table of U.S. city point 
locations. Using ranges of values you want to shade the states table according to the 
percentage of each state’s population living in urban areas. For MI Pro to calculate this 
percentage, the population for the cities must be in the states table.

First, to use data from another table, make sure that both the base table and the table 
from which you want to obtain the data are open. Next, choose Create Thematic Map, 
and in the Thematic – Step 1 of 3 dialog choose Ranges. In the Thematic – Step 2 of 3 
dialog, choose states, since this is the table you want to shade. 

In the Field drop-down list, choose Join. The Update Column for Thematic dialog 
displays. Table to Update is already set to States, and Column to Update is 
automatically set to Add New Temporary Column.

Choose the city_125 table in the Get Value From Table box. If that is the only other 
table open, MI Pro automatically displays its title in the list box. 

When you create a temporary column for a thematic map, the field must be a numeric 
field. This is true for all thematic maps except individual values. 
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In our example, we are looking for the percentage of the population living in urban 
areas in the United States. To perform this calculation, we must obtain a total of the 
city_125 population – the total of the population of each city in a given state. The 
results are put into the temporary column. Therefore, In the Calculate box choose 
Sum. In the of box, choose Tot_pop. 

To put the data from the city_125 table into the temporary column of the states table, 
there must be a link between the two tables that MI Pro can use to access the data. MI 
Pro can often make this link automatically. In this example, both our tables have a 
state field. If you choose Join in the Update Column for Thematic dialog, you can see 
that MI Pro has already set up the Specify Join dialog with the STATE fields from both 
tables. If the join were not calculated automatically it would be necessary to specify 
the matching fields or geographic join.
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Choose OK. MI Pro calculates the sum and returns you to the Thematic – Step 2 of 3 
dialog. The Field list box displays the temporary column you created: SumOfTot_pop. 
The states table now contains all of the data you need to create your thematic map. 

Now, let’s create the map. We have all the data, but we still need to calculate the 
percentage. That information does not exist as a field in the table, so you must build 
an expression to derive it.

In the Thematic – Step 2 of 3 dialog, choose Expression in the Field list box to access 
the Expression dialog. The expression SumOfTot_pop/Pop_1990 * 100 will give you 
the answer as a percent. Choose Verify to ensure that your syntax is correct, and then 
choose OK. You are returned to the Thematic – Step 2 of 3 dialog, and the Field list box 
displays the expression you created. Choose Next to go on to the Thematic – Step 3 of 
3 dialog. 

Click the Ranges button and choose either Equal Count or Equal Ranges to customize 
the ranges, whichever gives you the best representation of your data. Use Round By 
to round to a decimal place or whole number. Customize the styles to best illustrate 
your analysis by clicking the Styles button.

When you choose OK, MI Pro displays the map in a Map window. 
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Bivariate Thematic Mapping
Bivariate thematic mapping uses point or line objects to represent two thematic 
variables. For example, a star can represent one variable, such as the number of 
teenagers, while a blue fill for the star represents their annual purchase amounts. 

To create a bivariate map in MI Pro, you create two thematic maps, and layer one over
the other so that the objects display two variables. 

Types of Maps and Variables
The only types of thematic maps suitable for bivariate mapping are ranged and 
individual values maps. You can choose between two combinations for a bivariate 
map, depending on your data:

• two ranged maps 

• one ranged map and one individual values map 

Prism maps can also be used for bivariate theme mapping. See the Prism Maps section
for more information.

If you have a non-numeric variable, one of your maps must be an individual values 
map. You cannot create a bivariate map with two non-numeric variables. 
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Displaying Attributes 
To display two variables within one symbol, it is important to choose a different 
symbol attribute for each variable. For example, you cannot choose color for both 
variables because one color will overwrite the other. Choose from the following 
combinations: 

• color and symbol type

• color and size

• size and symbol type

Symbol type should only be used for nominal or non-numeric data, as there is no 
inherent association between a symbol type and a quantity. 

Example of Bivariate Thematic Mapping
To illustrate this process, suppose as a sales manager you want to know which 
businesses have generated the most sales in your territory. You have a table of 
customers with their total sales and sales representative. 

First, you must decide what combination of thematic maps to use. Because you are 
working with sales representatives (non-numeric data) and total sales (numeric data), 
you must create both an individual values map and a ranged map. 

Second, decide how you want to display the data. You can use a combination of color 
and size attributes to display your thematic variables. You want to assign a color to 
each sales representative and use a different size symbol to represent each range of 
sales figures. Note that this is different than a graduated symbols map, where the 
symbol is scaled to one value. Here, the size of the symbol represents a range of 
values. 

Third, you must create a separate thematic map for each variable. For the Individual 
Values map, use the table of customers as the table and choose Sales_rep as the field to 
which to assign values. MI Pro assigns each sales representative a different color. 

Next, create a ranged thematic map that shows the customers’ total sales. Choose the 
customer table as the table, and choose Sales as the field. Divide the total sales into six 
ranges with approximately the same number of customers in each range. In the 
Thematic- Step 3 of 3 dialog choose the Ranges button, change the number of ranges 
to six, and verify that the type of range is set to Equal Count. 
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To show the ranges as sized symbols, choose Styles in the Thematic- Step 3 of 3 dialog. 
In the Autospread Group choose Size. The symbols in the Styles group change to 
graduated size. However, the only variable you want to display is size, as the 
symbols’ color is coming from the individual values map. Choose Options to display 
the Apply group and choose the Size button again. 

Note that the selection in the Apply group overrides any selection you make in the 
Autospread group. To specify or change which symbol attributes display, you must 
choose Options, and choose the Color or Size button in the Apply group.

The symbols become hollow circles that are graduated in size. Choose OK, and your 
ranged map draws over the individual values map. The symbol color from the 
individual values map indicates the sales representative, and the size of the symbol 
represents a range of total sales figures. The map legend lists the bivariate map as two 
separate thematic maps, in effect displaying two legends. The legend does not 
combine the two variables.

Note:   If you do not see both variables displayed on the map, make sure your 
variables did not overwrite each other. Also check Layer Control to see that 
the Display box is checked on both maps. 
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U
sing an Inflection Point with Thematic Mapping
In thematic mapping, an inflection point is a color style you insert between ranges. It 
provides a second way to interpret your data. 

The inflection point is placed where there is a distinct marker between the ranges of 
values above it and the ranges of values below it, or where a numeric shift in your 
data occurs. Most often, the inflection point is inserted as close to the zero value as 
possible, since zero marks the shift between positive and negative values, or at the 
mean of your data values.

The inflection point enables you to see this shift on your map. You see two different 
color spreads in your ranges. Instead of spreading toward each other, the top and 
bottom range colors both approach the color of the inflection point. 

Another type of inflection point map is a grid surface thematic map. Here every color 
that displays in the legend is an inflection point. Values that fall between these 
inflection points display with a blend of the two colors. This allows you to see a 
continuous gradation of color across the map. See Grid Surface Theme Maps earlier in 
this chapter for a discussion on this type of thematic map. 

Example of an Inflection Point Map 
To show positive and negative population growth in the United States, you can insert 
an inflection point close to where the zero value is in your ranges. The top and bottom 
range points will spread, or graduate, toward the inflection point: one for increased 
population, and one for decreased population.

Because of the many steps involved in creating an inflection point map, let’s start with 
a summary of the process:

1. From the thematic dialog, create an expression to show population growth. 
2. Create the ranges.
3. Determine where among the ranges the inflection point should lie.
4. Choose the style for the ranges.
5. Specify the range position for the inflection point.
6. Set the style for the inflection point.
7. When done, tell MI Pro to create the map.

Each step is discussed below.
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To show population growth, you must create an expression. In our example, the 
expression: (POP_1990 – POP_1980)/POP_1980 * 100 will give you the answer as a 
percent. Choose Expression from the drop-down list of the Thematic-Step 2 of 3 
dialog to create this expression. It will display in the Field list box in the Thematic – 
Step 2 of 3 dialog. Choose Next to go on to Step 3.

Choose Ranges to customize your ranges. When you use an inflection point, it is 
important that your data distribute well across the ranges. You may want to increase 
the number of ranges, or compare the distribution of the data between Equal Count, 
Equal Ranges and Natural Break to see which gives the best representation of your 
data. 

For our example, choose Equal Ranges, and set the number of ranges to 14. You may 
also want to use Custom to adjust the range values so that zero is the minimum value 
in one range, and the maximum value of the range below it. This is optional. Choose 
OK. You are returned to the Thematic – Step 3 of 3 dialog.

Examine the preview before you create the inflection point to locate where you want 
to place it. When you choose an inflection point, you must choose a number that 
identifies the position of a range in the legend. Count the ranges in the preview 
legend until you get to the range with a zero at one of its ends. If your Legend Label 
Order is Descending, count the ranges up from the bottom. If it is Ascending, count 
down from the top. 

Choose Styles in the Thematic – Step 3 of 3 dialog. The styles for each range display. 
You can keep the default color spread between the ranges (red to gray), or you can 
choose a different color spread. For this example, keep the top range at red, and 
change the bottom range to blue. Next, choose Options to display the Inflection 
group. In the Inflection at box, choose 2 for the second range, as you determined 
above. The default is None, meaning no inflection point.

To choose the style for the inflection point, click inside the Style box in the Inflection 
group. The Fill Style dialog displays. Select the color for the inflection point and click 
OK. The default style is a white fill with no pattern. 

When you have made all of your selections, choose OK. Preview your legend in the 
Thematic – Step 3 of 3 dialog. Your legend will not show explicitly where the 
inflection point is, as your range colors only approach the inflection point. You can, 
however, state what the inflection point is in the legend title or subtitle. Choose OK 
again to display your inflection point map. 
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C

odifying a Thematic Map
Once you create your theme, it is likely that you will want to change something about 
it. MI Pro provides two ways to reach the Modify Thematic dialog where you can 
customize a variety of settings, styles, and legend components. Choose Map > Modify 
Thematic Map or double-click on the theme’s legend frame within the legend window 
to display the dialog.

When you are modifying a map, a quick way to change a number of settings at once is 
to change the template of the current theme. Perhaps you want a different color 
spectrum for your range of values map. From the Modify Thematic Map dialog, click 
the Merge button in the Templates group. The Merge a Template into the Current 
Theme dialog displays with a list of the same type templates as your theme (all range 
of values templates, for example.) Choose the new template and click OK. The 
settings in this template will now be applied to your theme.

The Merge feature is only available once you have created the thematic map. 

ustomizing a Thematic Legend
When you create a thematic map, MI Pro automatically creates a legend that explains 
what the colors, symbols, or sizes represent. MI Pro offers two types of legend 
windows: the cartographic legend window that can display information about any 
layer in a Map window, and the theme legend window for thematic and graph layers. 
Each type is discussed below. 

Cartographic Legend Window
Style information about the layers in your map, whether they are thematic or not, can 
be displayed in a cartographic legend window. The layers can be in one legend 
window, or you can create a window for each layer. Each thematic or map layer 
legend resides in its own legend frame. You are not limited to the number of frames in 
a cartographic legend window. 

The following discussion will be limited to creating and customizing thematic 
legends. For a general discussion on cartographic legends, see Chapter 16.

To display a thematic legend in a cartographic legend window, create the thematic 
map in the normal way by following the three Create Thematic Map dialogs. By 
default, MI Pro creates a new cartographic legend window or adds your theme to a 
legend window if one exists for the Map window. 
apInfo Professional User�s Guide 255

Apple Inc. 
Exhibit 1021 

Page 264



Chapter 11: Using Thematic Mapping to Analyze your Data
If you want to display the legend in a particular legend window, at the Thematic – 
Step 3 of 3 dialog click the Legend button. The Customize Legend dialog displays. 
From the Into Window drop-down list, choose the name of the legend window. You 
can also choose to create a new window or to not add your theme to a legend window 
at all. 

From the Customize Legend dialog you can also change the look of the legend by 
editing the titles and subtitles. You can customize how MI Pro displays the ranges in 
the legend. For example, to make the ranges easier to read, you can summarize the 
top and bottom ranges, as shown below.

Note, however, that changing range labels in the legend does not change the actual 
ranges in the map. To combine ranges or create different ranges, you must recalculate 
them in the Modify Thematic Map > Customize Ranges dialog. 

You can quickly return to the Customize Legend dialog from the cartographic legend 
window by double-clicking on a legend frame or by right-clicking on the frame and 
choosing Properties. The Modify Thematic Map displays. Click the Legend button 
and you are back to the Customize Legend dialog to make any necessary changes.

Note, too, some of the other properties of the cartographic legend window. A right-
click on a selected legend frame displays a shortcut menu where you can add frames, 
refresh the legend styles or layout, delete the frame and show frame properties. Click 
on the Properties menu to return to the Modify Thematic Map dialog. If you right-
click outside a frame but within the legend window, the shortcut menu would refer to 
properties about the legend window, such as legend window title and scrollbar 
behavior.
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Theme Legend Window
The theme legend window is MI Pro’s original style legend that allows you to display 
legends for thematic maps and graphs only. MI Pro always creates a theme legend 
window for a thematic map, but its display is determined by the choice you make in 
the Customize Legend dialog and whether a theme legend window is already 
displayed. 

To display a thematic legend in this type of window, from the Create Thematic – Step 
3 of 3 dialog, click on the Legends button. At the Customize Legend dialog, choose No 
Window from the Into Window drop-down list. No Window refers to the cartographic 
legend window. By choosing No Window, your theme legend will not be placed in a 
new or existing cartographic legend window. Click OK twice and MI Pro generates 
the thematic map. To view the legend, choose Options > Show Theme Legend 
Window or click on the Show/Hide Legend button. If a theme legend window is 
already displayed, the new theme legend is added to it. 

If you wish to make changes to the look of the legend information, double-click on it 
in the window and the Customize Legend dialog displays. 

Selected cartographic 
legend frame 
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Use the theme legend window if you wish to embed your legend in a Map window. 
This is accomplished via the Legend Manager, a MapBasic application that you can 
add to your Tools menu. Go to the Tools Manager, choose Legend Manager, select the 
check box labeled loaded and click OK. For more information about customizing a 
legend, see Customizing a Legend under Create Thematic Map in the MapInfo 
Professional Reference and Cutomizing the Legend of a Thematic Map in MI Pro’s 
Online Help. 

Saving Your Thematic Settings
MI Pro provides a way to save your themes and the templates from which you created
them. 

Saving Thematic Map Layers
To save your thematic maps, use File > Save Workspace. A workspace is a listing of all
the tables and settings used in a map. When you open the workspace, MI Pro 
Professional opens the tables and re-creates the thematic map. If you close a table or 
Map window without saving your session to a workspace, MI Pro displays the Save 
Workspace Objects dialog and prompts you to do so. The dialog indicates what types 
of objects will be lost (e.g., thematic layers, label layers) if you do not save your 
session to a workspace. You can turn off the warning prompt in Map Window 
preferences.

Saving Thematic Templates
Every thematic map begins with a template from which you can then customize for 
your particular needs. These settings can be saved for future use. In the Create 
Thematic Map – Step 3 of 3, choose the Save As button in the Template group box. The
Save Theme to a Template dialog displays. To save your new settings to the exisiting 
template, click OK. To retain both the new and the original template, type a different 
name into the Name edit box. To recover any template that ships with MI Pro, copy it 
from the \THMTMPLT directory on the product CD. Templates have the extension 
.thm. In MI Pro 7.0 files are stored on a per-user basis. See Appendix C, Data Setting 
and Management, for file locations.
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For individual value themes you can also save the actual categories in a theme 
template.  For example, if you choose to build an individual value theme on a table to 
show land usage, you can assign a different region style to each type of land usage 
(commercial, forest, residential, farm land etc.).  You may then want to take those 
same assignments and apply them to another table.  You can do this by storing  the 
category in a template, it will be associated appropriately when the template is 
applied to the second table.

To save individual categories in a theme template when creating a new thematic map 
or for an existing thematic map, from the Modify Thematic Map dialog press the Save 
As button  and specify a template Name. Check the Save Individual Value Categories 
box and click OK. A template is saved that can be used to apply the stored individual 
categories to a second table.  When you choose Map > Create Thematic Map the 
template's name will appear in the Template Name field of the Create Thematic Map - 
Step 1 of 3 dialog box. 
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Chapter 12: Creating Graphs
Creating Graphs

The graphing feature in MapInfo Professional® 
enables you to create a myriad number of 
different graphs from 3-dimensional bar graphs 
to exploded pie graphs. Each type of graph has 
its own set of features that you can customize to 
emphasize a particular piece of information, or 
create the aesthetic look you want for your 
graph. These features, plus additional 
formatting options, give you full control of the 
look and content of the graph. 
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Graph Type Overview
You can choose from 10 different graph types. Each type of graph includes at least one
graph template that you can use to create your graph. Each graph type, with a brief 
description of each template, is explained below.

3D Graphs
The 3D graph option enables you to create a number of 3 dimensional graphs. Most of 
the 3D template options are variations of a bar graph. Choose from any of the 3D 
templates below for the look you want for your graph. Once you create the basic 
graph, many more customizing options enable you to finetune its appearance, 
particularly the 3D Viewing Angle feature, where you can set the angle at which your 
3D graph displays. 

3D Bar – A conventional bar graph in 3 dimensions.

3D Floating Cube – Each value being measured, such as population, is displayed as a 
cube. The value is indicated by the placement of the cube in the graph. Cubes that 
have higher values appear to float within the graph. 

3D Floating Sphere – This graph is the same as the 3D Floating Cube, except that each 
value being measured is displayed as a sphere.

3D Line – The values being measured for a category, such as a country or a city, are 
displayed as a continuous line across the axis. The line will dip and spike according to 
the values. 

3D Pyramid – Each value being measured is displayed as a 3-dimensional pyramid. 
This graph is based on a bar graph — the higher the value, the taller the pyramid. 

3D Round – This graph is the same as the 3D Bar graph, except that the values are 
displayed as cylinders instead of bars. 

Area Graphs
Area graphs enable you to view your graph series as an area, where the area from the 
X axis to the plot line of the data series is filled in with a pattern or color. You can 
choose from the following templates:

Clustered – A clustered area graph draws area risers overlapping each other to show 
the absolute relationship between data series. 
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Percent – The percent area graph is an area version of a pie graph. Each group 
calculates the percent of the total required for each series. The axis goes from 0 to 
100%.

Stacked – The area risers are stacked on top of each other. The axis is the cumulative 
total of all the groups. 

Bar Graphs
Clustered – The clustered bar graph is a side-by-side group of bars. This is the 
standard type of two-dimensional graph. 

Percent – The percent bar graph is a bar-graph representation of a pie graph. Each 
group calculates the percent of the total required for each series. The axis goes from 0 
to 100%.

Stacked – The stacked bar graph displays stacked groups of bars. Each stack is made 
up of all series in this group, added up to obtain a total. The axis is the total value of 
the cumulative points.  

Bubble Graphs
The bubble graph allows you to plot values on an X-Y axis and compare a third value, 
Z, by the size of the markers in the graph. The bubble graph requires three values per 
marker, X, Y, and Z, in that order. Another way to think of it is that the graph is an X-Y 
plot where the marker size depends on a third value, Z. 

Column Graphs
Clustered – Each group of columns for a category are clustered together. 

Percent – The percent column graph is a column-graph representation of a pie graph. 
Each group calculates the percent of the total required for each series. The axis goes 
from 0 to 100%. 

Stacked – The stacked column graph shows stacked groups of columns. Each stack is 
made up of all series in this group, added up to obtain a total. The axis is the total 
value of the cumulative points. 
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Histogram Graphs
Histograms show frequency distribution. This graph type groups your values into 
ranges based on value. It measures the number of data values that fall within each 
range. The ranges are displayed as bars. Choose from these templates:  

Horizontal – The orientation of the bars is horizontal. 

Vertical – The orientation of the bars is vertical. 

Line Graphs
Clustered – In a clustered line graph, lines draw on top of each other to show the 
absolute relationships between data series. 

Percent – The percent line graph is a line-graph representation of a pie graph. Each 
group calculates the percent of the total required for each series. The axis goes from 0 
to 100%. 

Stacked – In a stacked line graph, lines stack on top of each other. The axis is the 
cumulative total of the all the groups. 

Pie Graphs
Pie – The pie graph displays percentages of a total as pie wedges. 

Ring Pie – The ring pie graph is a variation of the standard pie graph. It looks like a 
ring or donut. The total of all the pie slices is placed in the center. 

Scatter Graphs
A scatter graph is a standard X-Y plot. It requires two values per marker, X and Y, in 
that order. 

Surface Graphs
Surface – The surface graph displays all data points as a surface, like a rolling wave. 

Surface with Sides – A variation of the surface graph, where the surfaces in the graph 
have  solid sides. 

Surface, Honeycombed – A variation of the surface graph, where the surfaces in the 
graph have a honeycombed look. 
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C
reating a Graph
As in earlier versions of MI Pro, you create a graph via the New Graph Window menu 
command in the Window menu. You choose tables and fields to graph similarly, but 
you are no longer limited to four fields, as you were in versions of the software prior 
to 5.5.

Using the Graph Wizard
Graphing in MI Pro is done through a 2-step graph wizard, similar to the Create 
Thematic Map wizard. To access the wizard and create a graph:

1. Choose Window>New Graph Window. The Create Graph – step 1 of 2 dialog 
displays.

Here, select the graph type and the graph template you would like to use. 

2. Click on one of the graph types shown in the Graph group. When you select a 
graph type, the templates for that graph type display in the Template group. 

3. Next, choose a template. Some graph types have several templates to choose 
from. Others, such as the bubble and scatter graph types, have only one 
template. 

4. Click Next when you have selected a template. The Create Graph – step 2 of 2 
dialog displays. 

Here, select the table and the fields from the table you want to graph. You can 
also choose what column you want to use for your labels. 
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5. Choose the table you want to graph from the Table drop-down list. The list 
displays the currently open tables. 

6. Next, choose the fields from the table you want to graph. Select a field from 
the Fields from Table list, and either double-click on it, or highlight it (single 
click) and click the Add button. Both methods will move the field to the Fields
for Graph list. You can use the Remove button in the same way to move fields 
back to the Fields from Table list. 

7. Arrange the fields in the desired order using the Up and Down buttons. Select
a field you want to move and use the Up and Down buttons to place it in the 
position you want. 
Some graph types use the first field for axis labels (bar, 3D, column), and 
other graph types use the order of the fields to determine X and Y values. In 
the case of bubble graphs, the field order also determines the Z value. 

8. If applicable, choose whether you want to graph your series by row or by 
column. This option is not available for bubble, histogram, or scatter graphs. 
Click the button next to the option you want. 

9. Click OK. Your graph displays in a Graph window. 

Editing Your Graph
Once you create the basic graph, your ability to customize it is limited only by your 
imagination. You have complete control over virtually every aspect of your graph and
every item in the Graph window. The customizing options available depend on the 
graph type you have selected. 
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Selecting Graph Objects
To select a graph object to format it, click on the object. When you make a graph 
selection, related graph objects may also be selected. For example, if you click on a 
series bar in a column graph, all the series bars and the corresponding legend marker 
will also be selected. If you select an axis label, all the labels on that axis will be 
selected. All the items that are selected will be altered when you make your selections.

Moving and Resizing Graph Objects
To move a graph object, click on it in the Graph window and drag it to the desired 
location. You can move the titles, data labels, and the legend. To resize the legend, 
select it to display legend handles. Click and drag on one of the edit handles to make 
the legend larger or smaller. 

The Graph Menu
The Graph menu contains all the editing options to customize your graph. When you 
create a graph, the Graph menu displays in the MI Pro menu bar. You can also access 
the Graph menu options by right-clicking in the Graph window to display a shortcut 
menu. 

Formatting Graph Objects
The formatting options (Graph>Formatting) allow you to customize the line and fill 
patterns of your graph objects and graph titles. You can also add color gradients, 
different textures, and pictures to your graph. You can quickly access the Formatting 
dialog by selecting a graph object and double-clicking in the Graph window. The 
formatting will apply to whatever object is selected in the Graph window. It could be 
the background, the titles, the axes, the graph series, graph markers, etc. The 
formatting options that display in the dialog depend on what element in the Graph 
window is selected.
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Layout and Display 
Go to the General Options command (Graph>General Options) to change the general 
options for the type of graph you are creating, as well as customize its display. The 
General tab displays options that enable you to customize the markers for the type of 
graph you selected. For 3D graphs, you can change the shape of the risers, and the gap 
between the risers. For pie graphs, you can create an exploded pie graph, as well as 
specify the pie’s rotation, tilt, and depth. For bubble graphs, you can customize the 
size and shape of the marker. In column graphs, you can customize the columns, etc. 
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Modifying Axis Attributes
The Grids and Scales dialog (Graph>Grids and Scales) is used to format graph axes, 
gridlines, and perform scaling. The tabs on the left of the dialog indicate the available 
axes in the graph: Category Axis, Y1 Axis, Y2 Axis (for dual-axes graphs), X Axis (for 
bubble and scatter graphs), and Series Axis (for 3D graphs). 
apInfo Professional User�s Guide 269

Apple Inc. 
Exhibit 1021 

Page 277



Chapter 12: Creating Graphs
When you select an axis tab, the tabs at the top of the dialog will change to reflect the 
available formatting options for that axis. Each axis is described below:

• Category Axis – All graph types, except bubble, histogram, and scatter 
graphs, have a category axis. The category axis defines the groups of items 
that are being graphed. When category axis labels are displayed, the labels are 
taken from the first row in your table.  

• Y1 Axis – All graph types except pie graphs have a Y1 axis, or primary 
numeric axis. This axis plots the values from the rows and columns in your 
table. 

• Y2 Axis – Area, bar, bubble, column, line, and scatter charts can be drawn on 
two numeric axes, Y1 and Y2. When a dual-axes graph is selected, MI Pro 
automatically divides the number of series in half and assigns half of the 
series to one axis and the other half to the second axis. The two axes can be 
drawn up or out from the same plane/base line or physically split into two 
separate sections on the graph. 

• X-Axis – Bubble, histogram, and scatter graphs include an X-axis. These 
graphs have two numeric axes—a Y1 axis that is drawn on the left side of the 
graph and an X axis that is drawn on the bottom of the graph frame. 

• Series Axis – A series axis is included only in 3D riser and 3D surface graphs. 
The series axis is also called a secondary ordinal or O2 axis. In 2-dimensional 
graphs, the series or rows of objects being graphed are shown in the legend 
area of the chart. In 3D graphs, these objects are shown on the series axis, 
which is on the lower left side of the 3D graph. 

Specifying Titles for Your Graph
Choose Graph>Titles to specify titles for your graph. In the Titles dialog, check the 
boxes next to the titles that you want to display in the graph. The text boxes next to 
those titles become available. You can use the default titles or create your own. Choose 
from these titles:

• Title – Displays the main title of the graph. The title is centered over the top of 
the graph.

• Subtitle – Displays the subtitle of the graph. The subtitle displays directly 
underneath the main title. 

• Footnote – Displays a note at the bottom right hand corner of the graph.

• Category title – Displays a title for the category axis of the graph. It is placed 
just above, below, or next to the category axis labels. 

• Value title (Y1) – Displays a title for the primary numeric (Y1) axis of your 
graph. You can use the title to explain what is being plotted on this axis.

• Value title (Y2) – Displays a title for the secondary numeric (Y2) axis of your 
graph. In dual-axes graphs, the primary (Y1) axis shows some of the groups 
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in your data, and the secondary numeric (Y2) axis plots other groups of data. 
You can use the title to explain what is being plotted on this axis. 

• X-Axis title – Displays a title for the X-axis, where applicable. Histogram, 
bubble, and scatter graphs include a numeric X-axis. 

• Series Axis – Displays series labels along the lower left side of a 3D graph. 
Series titles can further describe the information that is being graphed on this 
series axis. These titles normally correspond to the series labels displayed in 
the legend. 

All graphs can include a title, subtitle, and footnote. Most graphs can also include a 
Category Axis title and a numeric Y1-Axis title. Other axis titles may be available 
depending on the graph type. Titles can be moved from their default positions by 
clicking and dragging them to the desired position. To change other elements in the 
title, such as the font or the text color, select the title directly in the Graph window and 
choose the Formatting command in the Graph menu.  

diting Individual Graph Series
You can apply formatting changes to an individual series in your graph, as well as to 
the whole graph. The Series Options command in the Graph menu is available 
whenever a series is selected in your graph. If no series is selected, the message, “No 
series is selected” displays when you attempt to access the dialog. 
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To format an individual series;
1. Click on a riser (area, bar, line, marker, pie slice, etc.) or a legend marker to 

select a series.
2. Choose Graph>Series Options. The Series Options dialog displays.
3. Make the desired changes in each of the dialog tabs and click OK. You can 

also apply changes as you go by clicking the Apply button. The Apply 
operation applies your changes to the graph without closing the dialog. This 
enables you to see your changes in the Graph window, continue working, and 
experiment with different options without having to close and reopen the 
dialog.

4. Click OK when you are finished. 

The options available in the Series Options dialog depend on the graph type you have 
selected. Each of the dialog tabs is explained briefly below:

• General – Contains general formatting options for a series for each type of 
graph. For instance, in 3D column graphs, you can change the riser shape; in 
bubble graphs and other graph types that may use markers such as line 
graphs, you can change the shape of the markers. In pie graphs, you can 
manipulate the individual pie slices. You can detach a slice from the pie, 
delete a slice, or restore the pie back to its original state. In many graph types, 
you can also display the selected series as another graph type. For example, if 
you create a bar graph, you can change a selected series to display as a line or 
an area, contrasting that series to the rest of the series in the graph. 

• Data Labels – Specify whether you want to display data labels for the selected 
series and where you want to place the labels. Data labels show the actual 
values from your table.
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• Number – Specify how you want to display data label numbers. You can 
choose from a number of categories: general, number, currency, date, time, 
percentage, fraction, scientific, special, and custom. This tab is available when 
the Data Labels box is checked in the Data Labels tab. 

• Trendlines – Contains formatting and display options for trend lines. This tab 
is unavailable for 3D and pie graphs. You can display a trend line according to 
different types of regression: linear, logarithmic, polynomial, or exponential. 
You also have several other display options. You can display the equation 
used to create the trendline, show the coefficient values, or specify that the 
trend line display in the same color as the series.  

raphing Examples
This section of the chapter provides some examples of the types of customization you 
can have with your graphs. The first example illustrates some of the ways you can 
customize  a pie graph. The second example demonstrates how you can customize a 
3D graph using the 3D viewing angle feature. 

Exploding a Pie Graph
Creating a basic pie graph is easy using the Graph wizard. Simply select the 

table and the fields you want to graph. You can also graph a subset of a table, 

as shown below, by browsing the selection, and using the Save Copy As 

command to save the selection as a permanent .tab file. This example graphs 

selected states from the States table. 
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The General Options for pie graphs enable you manipulate the look and rotation of 
the pie slices easily. The left side of the dialog shows a preview of what the finished 
pie graph will look like. You can change the tilt, or the angle at which you view the 
pie. You can give the pie a 3D look by using the Pie Depth setting. 

You can also rotate the pie or explode the pie. When you explode the pie, you detach 
all the slices away from the center. You can also detach an individual slice away from 
the pie center using the Series Options (Graph>Series).  

The graph on the next page shows the same pie graph, based on the General Options 
settings indicated above. 
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3D Graphs - Using the 3D Viewing Angle 
The 3D Viewing Angle feature enables you to display your 3D graph at different 
angles, as well as customize other aspects of the graph’s position, such as its rotation 
and position in the Graph window. The 3D graph below graphs the same selection 
from the States table that was used in the pie graph, but graphs different columns of 
the table. Here, the angle of the 3D graph has been rotated, and the thickness of the 
walls of the 3D cube has been changed. 
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When you choose the 3D Viewing Angle option, a number of preset angles for your 
graph display. You can choose one of these, or use the Advanced options to create 
your own angle, position, and rotation. The Advanced portion of the dialog displays 
additional controls that allow you to scroll through the presets more quickly, and 
manipulate the angle and position of the graph manually. 

Use the controls along the bottom of the graph preview to scroll through the preset 
viewing angles. You can also select one from the drop-down list. 

Rotating Your 3D Graph
Use the options at the lower right of the dialog to manipulate the graph. In the Rotate 
tab, you can click directly on the arrows to rotate your graph in the direction indicated 
by the arrow. A preview of the graph in its new position displays above. You can also 
rotate the graph one click at a time using the X, Y, and Z buttons. 

Panning Your 3D Graph
Use the Pan tab options to move the graph across the window. Again, click directly on 
the arrows to move the graph in the direction indicated by the arrow, or use the X and 
Y buttons to move the graph one click at a time. Use the Zoom buttons to zoom the 
graph in and out.  
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Customizing Cube Walls
The Walls tab helps you change the dimensions of the 3D graph walls. You can alter 
the length and thickness of the walls directly using the arrow keys on the wall image 
on the left side of the tab, or use the X, Y, and Z buttons. 

Moving Your 3D Graph at an Angle
The Move tab options  are used to move the graph diagonally across the window. 
Click the arrows on the diagram in the Move tab to move the graph in the direction 
indicated by the arrow, or use the X, Y, and Z buttons. The X button moves your graph 
from the top left to the bottom right of the window. The Y button moves your graph 
from top to bottom. The Z button moves your graph from the bottom left to the top 
right of the window. 

Above, the same graph that was shown earlier is displayed here using a different 
preset angle. The walls of the cube have also been removed, as well as the values for 
the Value Axis,  in the Display Status tab of the General Options dialog. 

All of the 3D Viewing Angle options have been used in this graph. The graph has 
been rotated about 90 degrees from the earlier example. The Pan and Move options 
have also been used to position the graph. And the Walls option has been used to 
increase the thickness of the floor of the cube. 
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Selections in Graphs and Their Tables
Selections you make in your graphed table will also be highlighted in your Graph 
window. Conversely, using the new Graph Select tool, selections in the Graph 
window change the current selection in the graphed table. 

Table Selections
In a graphed table, any selections you make in the table with the Select tool will be 
reflected in the corresponding Graph window as long as the selected table row or map
object corresponds to an object in the graph. For example, in a bar graph, one or more 
of the bars will be highlighted. In a pie graph, one or more of the pie wedges will be 
highlighted. The selection in the Graph window uses the same pen and brush styles 
that are used to highlight selected objects in the Map window.

Using the Graph Select Tool
When you select objects in a Graph window using the Graph Select tool, you also 
change the current selection in the graphed table. Your Graph window selection must 
correspond to a row in the table. Your Graph window selection will be reflected in the 
Map or Browser window. 
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If you select an object in the Graph window that does not correspond to a row in the 
table, any other selections in the Graph window are cleared. As in other types of 
windows, selecting multiple objects by shift-clicking works the same way in Graph 
windows—either adding the target object to, or removing it from, the selection.

Note that selecting graph objects with the Graph Select tool is not the same process as 
selecting objects in the Graph window to edit the graph object. The default mode is to 
select graph objects with the Select tool in order to edit them. To select graph objects 
for the purpose of changing the selections in the table, you must use the Graph Select 
tool.

In some graph types, there is no relationship between the graph objects and the rows 
in the table, e.g., histograms. The Graph Select tool is unavailable for these graph 
types. Selections in the Graph window will not highlight any records or map objects 
in the table.  

aving Your Graph
Graphs are saved to workspaces. For each Graph window in the workspace, MI Pro 
will save a uniquely named .3tf file in the same directory as the workspace. The name 
of the graph file is:

<workspace name>, <window title>.3tf

The <workspace name> is the root name of the workspace being saved and <window 
title> is the title of the Graph window being saved. For example, if you save a 
workspace named “my ws.wor” and it contains a Graph window with the title, 
“Scatter Graph,” MI Pro creates the graph file “my ws, Scatter Graph.3tf” in the same 
directory as the original workspace, “my ws.wor.” 

raph Templates and Other Support Files
MI Pro stores the various graph template files in folders in the GraphSupport 
directory. The GraphSupport directory is located in the MI Pro directory by default in 
versions 6.0 and earlier. In MapInfo Professional 7.0 files are stored on a per-user 
basis. See Appendix C, Data and Settings Management, for file locations. Other 
support files containing numerous kinds of fill patterns, as well as the 3D viewing 
angle files, that help you format your graph are also located in this directory. 
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Each type of support file stored in the GraphSupport directory is listed in the table 
below, according to the name of the folder in which the files are stored: 

Location Preferences
Using the Directory preferences, you can change the location where MI Pro looks for 
all the support files. To do so:

1. Choose Options>Preferences>Directories. The Directory Preferences dialog 
displays.

2. In the Initial Directories for File Dialogs group, select Graph Support Files. 
3. Click Modify. The Choose Directory dialog displays. It shows the current 

location of the Graph Support files. Navigate to the directory where you want 
to store the files, and click OK. The new location of the files displays in the 
Initial Directories list. 

4. Click OK to close the Directory Preferences dialog. 

Although the location of the GraphSupport directory can be changed, the names and 
locations of the support file folders inside the GraphSupport directory cannot. MI Pro 
looks in the GraphSupport directory specifically for the appropriate support folders 
and files as listed above. 

Saving a Graph Template
You can easily add to the available set of templates when you create a graph by saving 
an existing Graph window as a template file. For example, you prefer the legend to 
display on the left side of the Graph window instead of on the right (the default 
position). You can make this modification in the Graph window and then choose 
Graph>Save As Template. 

Folder Name File Description

3D Viewing Angles Files correspond to the preset viewing angles available in the 3D 
Viewing Angle dialog (Graph>3D Viewing Angle).

Gradients Files correspond to the preset gradients available in the Choose 
Gradient dialog (Graph>Formatting>Fill tab).

Pictures Files correspond to the pictures available in the Choose Picture dialog
(Graph>Formatting>Fill tab). 

Templates Contains the available graphing  templates, listed in the Graph 
wizard (Create Graph – step 1 of 2 dialog). 

Textures Files correspond to the textures available in the Choose Gradient 
dialog (Graph>Formatting>Fill tab). 
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1. Make the modifications in the Graph window that you would like to save as a 
template. 

2. Choose Graph>Save As Template. The Save Graph Template dialog displays. 
It shows the template folder that corresponds to the type of graph you are 
saving as a template.

3. Name your graph template and click Save. 

The next time you create a Graph window, the saved template file will be available in 
the Graph wizard for that graph type. 

Note:    You can save a template file to a location other than the 
GraphSupport\Templates directory; however, it will not be available unless 
you save it to a folder in the Templates directory. 

Using Graphs From Earlier Versions of MI Pro
If you are using graphs created in versions of MI Pro prior to version 5.5, and you 
bring them into version 7.0,  you will not be able to use the new graphing options on 
those graphs. The pre-5.5 Graph menu displays for  these graphs. For information on 
the older graphing options, see the MapInfo Professional Reference. 
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OLE Embedding with MI Pro
MapInfo Professional’s OLE embedding capability turns your applications such as 
word processors and spreadsheets into “mini-MapInfo” programs where you can 
create, display and edit a map for presentation, reporting or publishing. OLE is a 
process known as Object Linking and Embedding whereby a server application (such 
as MI Pro) provides information that is stored in a client application that can accept 
OLE information (such as a word processor). MI Pro’s OLE embedding functionality 
allows you to embed a Map window in any application that accepts OLE objects and 
use some of MI Pro’s features to create, display and edit the map directly in that 
application. 

OLE Terms
Before we get into the how-to’s of embedding maps, let’s define some common OLE 
terms.

Object: Any information that is embedded through OLE, whether it is a map, chart, 
spreadsheet data, sound effect, or text. With MI Pro’s OLE embedding, you embed a 
Map window as the object.

Embedding: Inserting an OLE object from a server (e.g., MI Pro) into a container 
application (e.g., Microsoft Word) to allow editing and output in the context of other 
information. An embedded object is a copy of the object from the server. Once in the 
container, the object is no longer linked to the source object from which it came.

Embedding vs. Linking: An embedded item is stored as part of the document that 
contains it. A linked item stores its data in a separate file. MI Pro only supports the 
embedding aspect of OLE. 

Container or Client: The application that accepts (contains) the embedded OLE 
object. Examples of containers include word processors, spreadsheet programs, 
databases, and presentation packages.

Server: The source application that creates OLE objects for use by a container. MI Pro 
is the server that creates the MapInfo Map object that can be embedded in OLE 
containers such as Microsoft Word or Excel.
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Live object vs. static image of object: Embedding an object in a container using OLE 
means the object is “live;” that is, you can edit the object in some manner using the 
features of the server from which the object came. The container must accept the 
object as a live object. If it cannot, only a static picture (bitmap or metafile) will be 
embedded. 

Activation: An embedded object must be activated to allow editing. This means that 
the server program from which it was created must be running in the background 
while you are working in the container application. To activate an object, double-click 
on it. Depending on the program, the menu bar of the application will change to 
reflect the available features of the server, or the application will open a separate 
window.

apInfo Map Object
You may find you want to include a map in your presentation or report that lets you 
convey statistical information geographically. MI Pro OLE Embedding enables you to 
embed a map window, known as the MapInfo Map Object, that shows all your data 
layers alongside other information such as charts and graphs, tabular data and text. 

With MI Pro OLE Embedding you can build the map directly in your OLE container 
application, or you can create it in MI Pro and drag the Map window into your 
application for additional editing or output. Because the MapInfo Map Object is a live 
OLE object, you are in fact running MI Pro in the background. When the Map window 
is active in the container, the menu and toolbar of your application change to reflect 
the MI Pro features that become available. This subset of features is called MapInfo 
Map. (Some OLE containers will create a separate window for the object.) With the 
click of a button or by choosing a menu command, you have MI Pro functionality in 
your application where you need it. 

apping with MapInfo Map
MapInfo Map provides a variety of map display, viewing and editing capabilities, 
including: 

• Opening multiple tables at once

• Controlling individual layer properties such as display and labeling

• Creating and modifying thematic maps

• Manipulating the Map window view

• Finding information associated with a map layer

• Controlling map projection and units
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Because MapInfo Map is a subset of MI Pro features, using them in your container 
application is the same as using them in MI Pro. So, Layer Control and Thematic 
Mapping work the same way whether you are creating a map in MI Pro or in your 
word processor.

Let’s look in more detail about what you can do with MapInfo Map.

Tools and Menu Commands
MapInfo Map allows you to create, display and edit map layers in a Map window 
directly in your OLE container application such as Microsoft Word or Corel Draw. You
can also bring over an existing Map window from MI Pro to your container via Drag 
and Drop or by pasting from the clipboard. When the Map window is embedded in 
the container and is active, MapInfo Map is running and replaces much of your 
application’s menu bar with its own menu and tool bar. From there you can access the 
power and flexibility of MI Pro. 

Tools 
MapInfo Map’s Toolbar consists of seven tools to help you change the view of your 
Map window, get information associated with a layer, and access MapInfo Map help 
topics. These tools include: the Grabber, Zoom In, Zoom Out, Info Tool, Change View,
Drag Map Window, and Help. When you activate the map, these tools replace any 
tools the container application displays. 

Menus
MapInfo Map replaces all container menus except File and Window with five MI Pro 
menus: Edit, View, Table, Map and Help. Under each menu, selected MI Pro features 
have been included, as outlined below.

Edit: Copy, Paste. Allows you to copy a Map window to the clipboard to transfer it 
back to MI Pro or an OLE application.

View: Toolbar, Legend. Controls the display of the Toolbar and thematic map legend 
(if any).

Table: Open, Close, Close All. Allows you to open and close multiple tables at the 
same time.
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Map: Find*, Layer Control, Create Thematic Map, Modify Thematic Map, Change 

View, Previous View, View Entire Layer, Options, Redraw Window. Most of 
MapInfo Map’s functionality is found here where you can locate objects, control the 
display and look of each map layer, analyze and display data thematically, and 
manipulate the view of the map contents within the Map window.

Help: Help Topics, About MapInfo Map. Direct access to instructions on embedding 
a MapInfo Map in OLE applications.

Shortcut Menu
A shortcut menu is available while you are editing your embedded MapInfo Map in 
another application. To access it, click the right mouse button. Choose from Layer 
Control, Change View, Previous View and View Entire Layer.

Limitations
Although MapInfo Map enables you to build a map very easily in your container 
application, not all of MI Pro’s features are available in the context of map embedding. 
Among them are editing map objects such as regions or polylines, querying a table for 
further analysis, geocoding to a table in the Map window, or displaying tables in other 
types of windows (Browser, Graph or Layout windows). 

However, with MI Pro’s drag and drop capabilities you can still perform these 
functions in MI Pro and bring over the Map window to your OLE container 
application for final viewing, formatting and editing enhancements. 

hings to Know Before You Start

System Requirements
MapInfo Map is an OLE server application that runs under 32-bit MI Pro. You must 
install MI Pro 32-bit to engage MapInfo Map. On the client side, only container 
applications that support OLE embedded objects can run MapInfo Map. 

Registering OLE Objects with Containers
Once MI Pro has been installed on your system, the MapInfo Map Object will be 
registered automatically and listed as a choice in the Object dialog of any container 
application that accepts OLE objects. 
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Embedding a MapInfo Map
Now that you have had an introduction to MapInfo Map Object and what it can do for 
you as you work in another application, let’s get down to the specifics of embedding 
an OLE object.

Getting Started
Although containers vary in their handling of OLE objects, there are some behaviors 
that are common to all. There are three ways that containers accept embedded OLE 
objects such as a Map window:

• Insert > Object where you can choose the object to embed from a list.

• Edit > Paste (or Paste Special) to embed an object that was previously copied 
to the Clipboard.

• Drag and drop from the application to the container using the Drag Map 
Window tool.

The method you choose depends on which application you are in at the moment 
(server or client) and how much you want to do to create the final map. 

Creating a New Map Window in Your Container
You just decided that adding a map to your presentation will lend great support to 
some conclusions you have reached about your data. In this case, you will need to 
build the map from scratch in your presentation application. The instructions below 
apply to any type of container application. 

To embed a MapInfo Map Object in your application:
1. Position the cursor where you wish to place the Map window. 
2. Choose Insert > Object (will be under Edit > Insert > Object in some 

applications). 

A dialog displays listing all OLE objects the application can accept.
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3. Highlight the MapInfo Map item and click OK. A default Map window of the 
world and MapInfo logo displays. The Map window is also in an active state 
(surrounded by a hatched border), meaning that MI Pro is running in the 
background. Your application’s menu has changed to reflect MapInfo Map 
Object’s menu. 

4. To begin building your map, choose Table > Open. The Open MapInfo Table 
dialog displays. 

5. Choose a table from the appropriate directory. Shift-click or control-click to 
choose additional tables to be opened at the same time. Click OK when you 
are through.
The tables display as map layers in the Map window. You can now label the 
layers, change the display, create or modify thematic layers, resize or 
reposition the Map window, or prepare the document for final output. 

Bringing a Map Window into Your Application
You have been working long and hard on a map in MI Pro that would really give your 
sales report some visual interest. Since the map is nearly complete, it is more efficient 
to copy it to your text document instead of making a new map in your word 
processor. You can either copy the Map window to the Clipboard or use the Drag Map 
Window tool to embed it directly in your document.
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To copy a Map window from MI Pro using the Clipboard: 
1. In MI Pro, make the Map window active and choose Edit > Copy Map 

Window. The object is copied to the Clipboard. Note: To copy the Map 
window all objects on the map must be de-selected. If there are any objects 
selected, the Copy Map Window command will not be available. 

2. Switch to your container application and position your cursor at the location 
where you want to place the map.

3. Choose Edit > Paste to paste from the Clipboard to your document. The Map 
window displays. 

Note:   The map is not active at this time. If you want to make changes to the map 
content, such as changing the view, creating a thematic layer or adding 
labels, you will need to start MapInfo Map. Double-click on the map to 
activate it and start MapInfo Map. 

If you only want to resize or reposition the object within your document, you 
do not need to start MapInfo Map. Select and change the inactive object 
according to the methods for your application.

In many OLE applications you can also choose Edit > Paste Special to paste the 
MapInfo Map into your document. Paste Special allows you to choose from three 
types of objects: the MapInfo Map object which can be activated and edited; Picture, a 
graphic image format that cannot be edited; and Bitmap format, also a non-editable 
graphic image. See your application for more on Paste Special.

To copy a Map window from MI Pro using the Drag Map Window tool :
1. With both MI Pro and your container application running, adjust their 

placement on the screen so that you can see them side by side (To tile MI Pro 
and another application running under Windows, click on the taskbar with 
the right mouse button and choose Tile Vertically). Position your cursor in 
your container where you want to place the map.

2. In MI Pro, make the Map window active. Click on the Drag Map Window tool 
on the Toolbar. The cursor becomes a hand and handle, indicating you can 
begin the drag operation.

3. Click anywhere within the Map window (except the title bar). The cursor 
changes to the hand grasping the handle for the “dragging” operation.

4. Drag the cursor to the container and click at the point where you want to drop 
the map. When positioned over a valid drop target, the cursor changes again 
to the DropCopy cursor. If the position cannot accept the object, the cursor 
will display a circle with a slash through it.
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This operation will only drag and drop a copy of the object. Moving and linking are 
not available with MI Pro OLE Embedding. You may find that for some container 
applications (for example, Microsoft Excel) you must use the Control key in 
combination with the Drag cursor to copy the object.

The Map window is not active after you drop it in the container. Double-click on it to 
activate the map if you want to do further editing.

apInfo Map Features
Now that you know the mechanics of activating MapInfo Map and copying the Map 
window between MI Pro and your container application, let’s look more closely at 
MapInfo Map’s features. 

This section presents brief summaries of MapInfo Map’s menu commands and tools. 
Be sure to refer to other chapters in this User’s Guide and the rest of the MI Pro 
documentation set for more complete discussions. 
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Edit Menu

Copy, Paste
These commands allow you to place the Map window on the clipboard to transfer it 
to MI Pro or another OLE application.

View Menu

Toolbar
Display or hide the Toolbar on the menu. To disconnect the Toolbar from the menu, 
click and drag it to another location. 

Legend
Display or hide the legend associated with a thematic layer. 

Table Menu

Open MapInfo Table
If you have inserted a new MapInfo Map Object in your document (using Insert > 
Object), choose Table > Open Table to begin building your map. The Open MapInfo 
Table dialog displays where you choose one or more tables to open (.tab format only).

Close Table, Close All
Choose Table > Close or Close All to close any or all map layers. The Close dialog 
allows you to close multiple tables at one time. 
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Find
Use the Find command to locate and mark specific map objects in the Map window. 
From the first Find dialog, specify the table and column that contains the object you 
wish to locate. At the second Find dialog, type the name of the object. When MapInfo 
Map locates the object, it marks the location with a symbol. If the object was not 
previously in view, MapInfo Map redraws the Map window with the object in its 
center.

Layer Control
Control how your map layers look and act from the Layer Control dialog. Change the 
layer order, add or remove layers, access the Display Options, Label Options and the 
Modify Thematic Map dialogs. Make layers zoom layered by clicking on the 
appropriate check box. You cannot make any map layers editable or selectable with 
MapInfo Map. 

Create/Modify Thematic Map
You can analyze your data directly in your application via the Create/Modify 
Thematic Map commands. Choose them if you want to add or change a thematic map 
based on a layer in your Map window. You can build any of six types of thematic 
maps (ranged, graduated symbol, dot density, pie graphs, bar graphs, or individual 
value). Thematic mapping gives you a great deal of control from choosing the type of 
map that best illustrates your data, to how the data is calculated, how the data is 
visually presented, and how the map is customized. Thematic mapping is thoroughly 
discussed in this User’s Guide, the MapInfo Professional Reference and Online Help.

When you create a thematic map in MapInfo Map, a legend is created and placed in 
the Map window. If the thematic map is modified, the legend automatically resizes 
itself to accommodate the changes in thematic content. You can reposition the legend 
anywhere within the Map window by dragging it to a new location; however, you 
cannot resize it.

Change View
This command allows you to specify the settings for viewing the Map window, 
including window width, map scale, map resizing and center point. 
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Previous View
If you have changed the view of your Map window at least once during the work 
session, the Previous View command is active, allowing you to return to the last view.

View Entire Layer
This command allows you to see the entire layer (or layers) in the Map window. 

Options
The Options command allows you to change the map units for the Map window, 
including coordinate units, distance and area units, or the projection of the map. 

Redraw Window
This command allows you to redraw the Map window. Use it to refresh the map after 
you press ESC to stop an earlier map redraw. 

Help Menu

Help Topics
Refer to this command to learn about embedding a MapInfo Map Object in your 
applications. 

About MapInfo Map
The dialog describes the product version and contains your license information 
(name, organization and serial number). Click the Tech Support button for 
information on contacting MapInfo Technical Support. 

Tools
When MapInfo Map is active, the following tools are available on the application’s 
menu bar:

 Grabber tool: Use this to reposition the map contents within the active Map 
window by clicking and dragging the map in the appropriate direction. This is the 
default tool.
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 Zoom–in/out tools: Use the Zoom-in tool to get a closer view of the 
map contents. Use the Zoom-out tool to get a wider view. Click on the map with either 
tool or draw a marquee box to change the zoom.

 Info tool: Use this to view the tabular data associated with map objects. Click 
on the map. The Info tool window displays on your screen showing the objects and 
the associated data at that point. Note: The Info tool window is not embedded in your 
container like the Map window. You cannot incorporate the Info tool window into 
your document. It is a temporary window only available when the map object is 
active. 

 Change View tool: Use this to access the Change View dialog (see Map > 
Change View above).

 Drag Map Window tool: Use this to transfer a copy of your active Map 
window to MapInfo or to another OLE container. During the process, the cursor will 
change to indicate the three stages of drag and drop: “begin drag,” “dragging,” and 
“drop copy.” For more on using Drag and Drop, see the section Bringing a Map from 
MI Pro into Your Application.

 Help button: Use this to access help topics about embedding a MapInfo map. 

esizing and Repositioning an Embedded Map Window
Once you have your Map window in your container, you may find it necessary to 
resize or reposition it in your document. This is accomplished by the container 
application itself, not MapInfo Map, so use whatever methods the application 
supports such as select, cut and paste. 

Note:  In some containers the object must be inactive for any changes to take 
effect. 
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For example, in Microsoft Word, click outside the object to deactivate it. MapInfo Map
closes and you are returned to the normal Word screen. Click once on the object to 
select it. With the cursor over one corner of the image, drag it diagonally to enlarge or 
reduce the size of the image (this method retains the correct proportions). Release the 
mouse button when you reach the desired size. 

In Microsoft Excel, you can simply drag a corner of the Map window to resize it. The 
Map window can be either active or inactive during resizing.

For changing the view of the map contents, the object must be active. Use MapInfo 
Map’s Change View button to re-display the map at a different scale or position. Use 
the Grabber tool to bring a different part of the map into view.

Printing Your Document with an Embedded MapInfo Object
When using Print or Print Preview in a document containing an embedded MapInfo 
map, we recommend that you first make the map inactive (click outside the map). 
This will allow your container to display or print the current map object. This is 
especially true if you make any changes to the map object immediately before you 
print or preview. 

Saving Your Map
Once your Map window is embedded in your application, all you need to do to save it 
is to save your document. The next time you open the document, the Map window 
will display in its inactive state. If you want to edit the map at that time, simply 
double-click on it to activate the map object. Note: This is only possible if you reopen 
the document on the system that has both your application and 32-bit MapInfo 
installed.

If you wish to save the tables that make up the map for future use in MI Pro, you will 
need to drag and drop the Map window, or copy it to the clipboard and paste it, back 
into MI Pro. Then save the tables before leaving MI Pro. If you have created a thematic 
map or labels, you will need to save the session to a workspace to save the thematic 
and label settings. You may wish to save the Map window as a workspace regardless 
of what type of map you have created for easy start-up next time.
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haring Documents Containing Embedded Maps
Once you have created a map in your document, you may want to share it with a 
colleague. Or you might want to use it on another system. When the document is 
opened on another system, the MapInfo Map Object displays as a metafile, or picture 
of the map, in the inactive state. The map is like any other graphic image at this point. 
If no map editing is necessary, the document can be printed, reformatted, reorganized, 
and saved with no special handling required for the map. The map itself can even be 
resized or repositioned. You cannot, however, change the content of the map since it is 
not an active OLE object. 

To activate the map for editing on another system, your colleague must have access to 
32-bit MI Pro and the data used to create the map. Double-click on the map to activate 
the OLE object. MI Pro will prompt for the location of the data files if it cannot find the 
original location. If the data is not available, cancel out of the Locate Data dialog. The 
metafile image is replaced with the MI Pro world map in the active state. To retrieve 
the original metafile image, close the document without saving and reopening it. 

Note:   Sharing MI Pro and map data on other systems is limited to the extent of 
your license agreement(s).

apInfo Map Objects vs. Data Map Objects 
Microsoft Data Map is a feature of Microsoft Excel for Windows 97. Data Map allows 
you to create thematically shaded maps based on data in Excel worksheets. MapInfo 
Corporation developed Data Map in conjunction with Microsoft Corporation. 

When you use Data Map to create a map, the map is an embedded OLE object. 
However, Data Map OLE objects are different than MapInfo OLE objects. The 
following list describes some of the differences: 

• Data Map works with data that you select from a Microsoft Excel worksheet, 
or import from a Microsoft Access database; MI Pro works with data from MI 
Pro tables. 

• Data Map provides only a small subset of MI Pro’s features. For example, 
Data Map does not allow you to perform geographic queries, such as finding 
a street address. Also, Data Map’s editing capabilities are limited to simple 
operations, such as adding annotations to the map. Data Map’s main use is 
creating thematic maps; thematic mapping is but one of MI Pro’s many uses. 

• Data Map objects can only be edited by using the Data Map software; to 
launch Data Map, double-click the Data Map object. MapInfo map objects can 
only be edited by using MapInfo Map. In other words, the two object types are 
not interchangeable — you cannot edit a Data Map object in MapInfo Map. 
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Using MapInfo Tables with Data Map 
Data Map uses MI Pro tables. All of the sample maps provided with Data Map are 
actually MI Pro tables. 

If you have created your own MI Pro tables, you can use your tables in Data Map. 
However, before you can display your table in Data Map, you must set up your table 
using the Data Map Data Installer. To launch the Data Installer, double-click the file 
DATAINST.EXE. (To locate this file, click the Windows  Start button, and then click 
Find.) Once you have launched the Data Installer, complete the dialog boxes that 
appear on the screen. 

Note that some MI Pro tables cannot be used with Data Map. Specifically: 

• Data Map cannot display raster image underlay tables. 

• Data Map cannot display a table that is actually defined as a relational join of 
other tables (such as a MapInfo StreetInfo table). To use a street table with 
Data Map, use MI Pro’s Save Copy As command, which saves a street table in 
a “flat” form that Data Map can use. 

• Data Map cannot display point objects that use MI Pro “Custom” symbol 
styles. (Custom symbols are selected by displaying MI Pro’s Symbol Style 
dialog box, and then selecting “Custom Symbols” from the Font drop-down 
list.) If your MI Pro table contains points with custom symbol styles, those 
points will be invisible in Data Map. 

For more information about Data Map, see the Data Map online Help. For more 
information about the Data Installer, see the Data Installer online Help. 
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Chapter 14: Internet 
Connectivity
Internet Connectivity

MapInfo Professional® contains options that 
allow you to bring the Internet into your 
mapping sessions, and to bring your maps to 
the Internet. 

Using active objects and the new HotLink tool, 
you can now launch files and Internet URLs 
directly from objects or labels on your map. 
Active objects provide you with a powerful 
display tool that allows you to bring 
information from the Web and other 
applications together in your map. 

These additional sources of information can 
give your analysis or presentation greater 
impact. For example, you can link a location on 
your map to a Web site that gives more 
information about the location or to an image 
file that shows certain aspects of the location in 
more detail. 

In addition, you can use the maps you create in 
MI Pro in your Web pages. The new HTML 
Image Map tool converts a MI Pro map into an 
HTML image map. Visitors to your Web page 
will be able to click on any region to link to 
other HTML pages specific to that region.

➤ 

➤ 

➤ 

➤ 

➤ 
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Active Objects
Active objects are map objects that are associated with files or URLs. The file can be a 
bitmap, a MI Pro workspace or table, a MapBasic program, or any type of executable 
file whose extension is associated with an application installed on your 
system.

Using the HotLink Tool 
Use the HotLink tool in the Main toolbar to launch the active objects on your map. 
The HotLink tool can be used with almost any layer that contains map objects or 
labels. It is not available for thematic, grid, raster, or cosmetic layers. 

The active object in this map (red triangle) is linked to a 
webcam website that displays an erupting volcano.
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Options in Layer Control enable you to control whether the active object is launched 
from a map object or label. 

 To launch an active object:
1. Click the HotLink button. Notice that the cursor displays as a pointing hand. 
2. Move the cursor over the map. When you pass the cursor over an active 

object, the cursor changes to a hand holding a lightening bolt, as 

shown.  

The link associated with the object or label displays in the Status bar. 

3. Click the active object to launch the file, URL, workspace, etc. 

You must have active objects in your table for the HotLink tool to be active. You can 
easily set up your table for active objects in just a few steps. See the next section for 
how to make the appropriate modifications. 

reating Active Objects
To use active objects in your map, you must create a column in your table to store the 
file link information.

Modifying Your Table
Make sure the table that you want to contain an active object is open, and do the 
following:

1. Choose Table>Maintenance>Table Structure. The View/Modify Table 
Structure dialog displays. 

2. Choose Add Field. Add a character field to contain the active object text. 
Make the length of the field long enough for the active object text, and name 
the field. 

3. Click OK to complete the field addition.
4. Open the table in a Browser window (Window>New Browser Window). 
5. Enter the appropriate file link text in the new field for each row in the table. 
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Now that your table contains the active objects, you need to set the HotLink options 
for the table. 

Setting HotLink Options
To specify how the HotLink tool will launch the active object: 

1. Display the table containing the active objects as a map (Window>New Map 
Window), if it is not already. 

2. Choose Map>Layer Control. The Layer Control dialog displays. Select the 
layer that contains the active objects. This enables the HotLink button. 

3. Click the HotLink button. The HotLink Options for the table display. 
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4. Choose the Filename Expression from the drop-down list. This is the name of 
the field you added to hold the file link information. 

You can also use an expression that concatenates two or more fields to define 
the file link. For example, in a map of the United States, you can use this 
expression:

 “http://www.” + State_Name + “.com”

5. To add the table path to the filename before launching it, check the File 
locations are relative to table location box. 

6. In the Activate on group, choose how you want the active object to launch 
when you click the object with the HotLink tool. 

Labels–Choose Labels to launch the active object when you click the HotLink 
tool on an object’s label. 

Objects–Choose Objects to launch the active object when you click the 
HotLink tool on an object. 

Labels & Objects–Choose Labels & Objects to launch the active object when 
you click the HotLink tool on either an object or its label. 

7. Check the Save options to metadata box to save the HotLink options to the 
table’s metadata. 

8. Click OK. 
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Adding the Path to the Filename
If you want MI Pro to add the table path to filenames before launching them, check 
the File locations are relative to table location box. This is useful if you are distributing 
tables containing HotLinks to files located in the same directory. Regardless of where 
the data is installed, the HotLinks will work. If the box is not checked, MI Pro 
launches the file without modifying the name. 

Note:  Active objects that are URLs are not modified before they are launched, 
regardless of whether the box is checked. 

Saving HotLink Options to Metadata
Check the Save options to table metadata box to save the HotLink options to the 
table’s metadata. Every time you open the table, the HotLink options will be restored. 
This check box is not available if the table is read only or if metadata operations are 
not supported on the table type, e.g., Street Works tables. 

If you do not check the box, the HotLink settings will be lost when you close the table, 
unless you save your session to a workspace. 

The settings are added to the.tab file in the Metadata area. The syntax for the HotLink 
settings is as follows: 

“\ActiveObject” = “”

“\ActiveObject\Expr” =  (where the field or expression is stored)

“\ActiveObject\Mode” = (type of object from which to launch active object)

Entries can be one of the following:

“HOTLINK_MODE_OBJ”

“HOTLINK_MODE_LABEL”

“HOTLINK_MODE_BOTH”

“\ActiveObject\Relative” = (relative to path)

Entries can be one of the following:

“TRUE”

“FALSE”

Note:  The HotLink options are written to metadata when you click OK in the 
HotLink Options dialog. If you click Cancel in the Layer Control dialog, the 
HotLink Options you set are not applied to the Map window. However, the 
options are still in the metadata. 
304 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 311



Chapter 14: Internet Connectivity

M

U

H

sing the HotLink Tool in Browser Windows
If you have saved the HotLink options to the table’s metadata, then you can also use 
the HotLink tool in the Browser window. Just click on the HotLink tool to activate it, 
move the cursor to the field you have set up for your active objects, and click on any 
of the links. 

Note:  The HotLink tool is available in a Browser window only when the HotLink 
settings are saved to the table’s metadata. Saving your session to a 
workspace without saving the HotLink settings to metadata will not work 
because there are no user interface settings for using the HotLink tool in a 
Browser.

When you open a new Browser window, MI Pro reads the table’s metadata to 
determine if the HotLink filename expression matches any of the Browser’s field 
expressions. If so, the text in that field is underlined, to indicate an active object. The 
HotLink tool will be available for that Browser window and you can select links from 
it. 

If the HotLink filename expression is not a table column name, you can create a 
HotLink field in the Pick Fields dialog, using the HotLink filename expression as the 
field expression. You cannot edit data in a Browser window while the HotLink tool is 
active, but you can select rows and move or resize Browser fields. 

TML Image Maps
Using the HTML Image Map tool, you can convert a MI Pro Map window into an 
HTML image that can then be added to a Web page. The HTML Image Map tool 
supports:

• Point, arc, line, ellipse, rectangle, rounded rectangle, and polyline objects, in 
addition to the original support for polygon and region layers. 

• Hotlinks and hyperlinks.

• Multiple layers.

• Ability to combine landing pages into a single HTML page. 

Options in the application allow you to specify a title and copyright information for 
the Web page, specify an image size and file format (JPG or PNG), designate a column 
for tooltips, and create HTML landing pages for each object on the map. 
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The HTML Image Map tool is a MapBasic application that ships with MapInfo 
Professional. It is available through the Tool Manager (Tools>Tool Manager). To add 
the Image Map tool:

1. Choose Tools>Tool Manager. The Tool Manager dialog displays.
2. Check the Loaded box for the HTML Image Map tool. If you want the HTML 

Image Map tool to load automatically every time you start MI Pro, check the 
Autoload box as well. 

3. Click OK. The HTML Image Map menu item is added to the Tools menu. 

To create an HTML image map:
1. In MapInfo Professional, open the table(s) you want to use for your map. 
2. Arrange the layers the way you want them in a Map window, and set the 

zoom, projection, and other display attributes. 
3. Choose Tools>HTML Image Map. The HTML Image Map dialog displays. 
4. Select the layers for your image map. Use the Add and Add All buttons to 

move selected layers to the Layers in image map list. Use the Remove and 
Remove All buttons to move layers back to the Layers not in image map list. 

5. Select the column that will be used for your map’s tooltips for each layer. 
6. Choose a title for your Web page and enter it in the Web page title box. 
7. In the Image group, enter the copyright text. Click the handy copyright 

button to insert the copyright symbol into your copyright notice. Specify a 
size, image format, and clip resolution for your HTML image map. 

8. Specify a name and location for the HTML image map file in the HTML file 
name box. Click the Browse button to navigate to the location you want. 

9. Check the Create HTML landing pages for each object box to create landing 
pages. 

10. Check the Populate landing pages with record content box to use columns in 
your table as the content for the landing pages. 

11. Click the Columns button. The Choose Columns dialog displays. Choose the 
columns you want to include in the landing pages, and customize the column 
text. Customization options are explained in the next section. Click OK. 

12. Click OK again to generate the HTML image map. 
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TML Landing Pages
The Landing Pages option allows you to click on any region in the HTML image map 
and link to a new HTML landing page specific to that region. You can put whatever 
content you want into the landing pages, including column information from your 
table. The user interface enables you to select the columns you want to use and 
customize the text. 

Selecting Columns
You can select which columns you want to display on the landing page. Check the 
Populate landing pages with record content box to activate the Columns button. Click 
the Columns button to display the Choose Columns dialog. You can add individual 
columns or all the columns from your table. By default all the columns in the table are 
selected and appear in the Columns on landing page list. 

To remove a column from the landing page content, click on a column to highlight it 
and click Remove. The column name appears in the Columns not on landing page list. 

Using Column Name Aliases
You can use column aliases from your table’s metadata as the basis of the content of 
your landing pages. 

To bring your column alias metadata into the Choose Columns dialog, click the Load 
from metadata button. The column aliases display in the Column name alias list. Now 
you can edit the column aliases so that the content of the landing page is what you 
want. 

To edit a column name alias, click on an alias from the Column name alias list to 
highlight it, and then click the Edit button. You can make any text changes you want; 
it is completely customizable. 

Additional buttons in the dialog, Upper Case, Proper Case, and Remove ‘_’, allow you 
specify the case of the column text, or remove underscores from column name aliases. 
Note: These buttons will change all the column name aliases in the list. 

In addition, you can save your edits back to the table’s metadata. Click the Save to 
metadata button when you have finished editing the column aliases. 
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ToolTips
When you hover your cursor over a region or polygon in your HTML image map, a 
tooltip displays. The tooltip information comes from the column you selected in the 
dialog. 
308 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 315



Chapter 

Label Design 

Automatic Labeling 

Interactive Labeling 

Removing Labels 

Packing a Table

Saving Labels 

Advanced Labeling Tasks 
Using Labeler.mbx

15
Chapter 15: Labeling Your 
Map
Labeling Your Map

The labeling features in MapInfo Professional® 
make it easier for you to display, edit, and save 
labels. You can specify whether to display 
labels automatically when you display the map 
or display the map without labels. You can edit 
automatic labels, use the customizing options 
to make your labels unique, and create 
individual labels with the Label tool. Text 
enhancements such as haloing, and more 
positioning options enable you to get the 
precise look you want for your labels.

➤ 

➤ 

➤ 

➤ 

➤ 

➤ 

➤ 
Apple Inc. 
Exhibit 1021 

Page 316



Chapter 15: Labeling Your Map

 

 

 

Label Design
The design of the label feature in MI Pro is important for understanding how to create 
and manipulate labels on your map. Most important among the design elements are 
the following:

• Labels are not drawn to the Cosmetic layer. 

• Labels are attributes of geographic objects in the map layer. The text is based 
on data associated with that object. 

• Labels are always selectable and editable.

• Labels are saved to a workspace.

Labels are attributes of geographic objects in the map layer. They are not drawn to the 
Cosmetic layer, as in previous versions of MI Pro, and they are not Cosmetic objects. 
Their drawn location is based on the location of the geographic object’s centroid and 
additional information such as anchor point and offset controlled in the Label Options
dialog. 

As attributes, labels are dynamically connected to their map objects. If the layer is 
closed or is made invisible, the labels no longer display. If the data or geographic 
information changes, the labels change. If you create an expression for your labels and
change the expression, the current labels are dynamically replaced with new ones. 

Labels are always selectable and editable, so you do not have to make the map layer 
editable or selectable to work with them. And, since labels are not Cosmetic objects, 
you do not have to remember to make the Cosmetic layer selectable or editable to 
label your map. They are already part of the map layer.

Saving labels is easy. Because labels are attributes of the map object, you do not have 
to remember to save them to a separate table. Any label edits you have pending, or 
changes you have made to the Label Options settings, are easily saved to a workspace.

You can label your map automatically through Layer Control, in the Label Options 
dialog. All global settings for labels are controlled in the Label Options dialog.
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When you label your map automatically, or interactively using the Label tool, the 
content of the labels is determined by the data associated with the geographic object. 
You can obtain the labels from the columns in your table, or the derived result of an 
expression using the column information. If the column information or an expression 
does not suit your needs, you can edit the label content or type in new text. See 
Editing Labels later in this chapter. 

Text you create yourself using the Text tool is a text object and behaves like other 
objects you draw on your map such as squares and circles. Although labels are no 
longer text objects, text objects are still useful for additional map annotation such as 
titles. For information on text objects, see Chapter 17, Drawing and Editing Your Map. 

The Autolabeler utility, available from the Tool Manager (Tools>Tool Manager), 
creates labels as text objects in the Cosmetic Layer, emulating the way labeling 
worked in MapInfo 3.0. This application may be useful if you need to create labels 
that can be transferred to a permanent table. In addition, you can create text objects 
and convert labels into text objects using another tool from the Tool Manager set, the 
Labeler utility, which is explained later in this chapter. 

Labeling with a Column
The content of labels is controlled in the Label with drop down list in the Label 
Options dialog. You can label an object with any column from its associated table. For 
example, you can label the states table with the state name, abbreviation, 1990 
population, or any other field in the states table. Simply choose a column from the list, 
and the objects in that layer will be labeled with the information contained in that 
column. 

Labeling with Expressions
You can also label objects with an expression. Select Expression from the drop-down 
list in the Label Options dialog. Create the expression in the Expression dialog. You 
can type the expression directly or use the drop-down lists to create it. 
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For example, you want to label the countries of Africa with their name and population 
density on two lines. Your table contains the country names and population figures 
for each country. To figure the population density, divide population by each 
country’s area. You can let MapInfo calculate the area of each country using the Area 
function in the Expression dialog. To create the expression, in Layer Control, highlight 
the Africa table and choose the Label button. Select Expression from the Label with 
drop-down list in the Label Options dialog. The Expression dialog displays. Using the 
drop-down lists, create the following expression:

• Country + Chr$(13) + POPULATION / Area(Object, “sq mi”)

The Chr$(13) function tells MapInfo to add a carriage return to the first line. Now 
using the Label tool, click on a country. MapInfo labels it with the result of the 
expression. 

Example of callout labels created with an 
expression
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A
utomatic Labeling
In addition to label content, you control the position, display and look of automatic 
labels in Layer Control. The settings in the Label Options dialog allow you to set 
conditions for displaying labels, in what style they will display, and in what position 
for all the objects in the layer. 

Controlling Label Display
The Auto Label attribute in Layer Control is off by default for all map layers. To 
activate labels for a layer(s), select the layer or layers and check the Auto Label box. 
When you return to your map, labels display for all layers you selected. 

You can easily turn the display of automatic labels on or off. In Layer Control, clear 
the Label attribute to turn labeling off. Any settings you have specified in the Label 
Options dialog will be deactivated. You can also go into the Label Options dialog and 
click Off in the Visibility group. Either way, when you go back to your map, the labels 
no longer display. These settings also apply to labels you have edited.
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To specify the maximum number of labels you want to display on your map, type the 
number in the Maximum labels box. 

The check boxes on the right side of the Visibility group control which labels display 
and determine how they appear on the map. Check the Allow Duplicate Text box to 
allow duplicate labels for different objects to display, e.g., Portland, OR and Portland, 
ME. This option is also used with street maps to label street segments individually.  
Check the Allow Overlapping Text box to allow labels to be drawn on top of each 
other. Check the Label Partial Objects box to label polylines and objects whose 
centroids are not visible in the Map window. 

Overlapping Labels
When labeling  a dense table of streets such as a StreetPro Display layer, only a few of 
the streets will be labeled when the map is zoomed out.

Other labels will not be displayed because they overlap labels that are have been 
given higher priority on the map.

In a table sorted alphabetically by street (like the StreetPro Display layer) this often 
means that streets with names beginning with A, B, or C are almost the only labeled 
streets on your map.  Labeling effectively gives a small side street like "Aberdeen 
Street" priority over "State Highway 177" or other major roads that might actually be 
useful in navigating or orienting a viewer.   This will be true for any dense StreetPro 
Display layer.

Labels are displayed following the order of records in the table.  To change the order 
of priority for displaying labels, it is currently necessary to save a copy of the table in 
question, sorted in order of priority -- most important record first -- and use that table 
for labeling instead of the original.

Zoom-layering Labels
You can also display labels within a specified zoom range, much the same way that 
you display map layers within a certain zoom range. Select a layer, click Label, and in 
the Label Options dialog, click the Display within range button. This activates the Min 
and Max zoom boxes. Fill in the minimum and maximum zoom distances in the 
appropriate boxes. 
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Label Size
Label size does not change with zoom or scale changes. Labels display at the size you 
specify at all zoom levels as well as on printed output. Labels are never hidden behind 
other geographic objects because they are always the last objects drawn on the map.

Label Position
Use the Anchor Point and Offset options to specify the label’s placement. 

The anchor point is the label’s position relative to the map object. Click on one of the 
buttons to select an anchor point. The table below describes each of the nine anchor 
point buttons.

Anchor Point 
Button Position Description

Top Left Places the label above and to the left of the anchor point.

Top Center Centers the label directly above the anchor point.

Top Right Places the label above and to the right of the 
anchor point.

Left Places the label directly to the left of the anchor point.

Center Centers the label at the anchor point.

Right Places the label directly to the right of the anchor point.

Below Left Places the label below and to the left of the anchor point.

Below Center Centers the label directly below the anchor point.
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The anchor point is an ongoing attribute of the label. For example, if you anchor a 
point object’s label at Center Left and you increase the label’s font size, the text will 
grow to the left. This way, the text can never overwrite the point. 

The default anchor point varies with the type of map object you are labeling:

• Regions default to Center.

• Lines default to Above Center.

• Points default to Right.

If you are working with a layer that has line objects such as a street map, check the 
Rotate Label with Line box to position the labels parallel to the lines. 

Label offset is how far away a label is from its anchor point. Specify the number of 
points you want the label to be from the anchor point in the Label Offset box.

The label’s anchor point and offset move a label with respect to its current location 
and the current zoom. Whenever you want to make minor adjustments to the label’s 
position, you should use these two options. 

You can also select and drag a label to move it, but this is not recommended because 
you are actually moving the label location on the map. If you drag a label a few pixels, 
the distance you move it is in the current map units, regardless of the zoom. For 
example, if you are displaying a map of the United States and drag New York state’s 
label a few pixels, at that zoom, the label looks fine. However, if the Map Units 
distance is in miles and you zoom in on New York state, the label will display much 
farther away than at the previous zoom. 

Creating Callouts
Callouts are labels with lines pointing to the objects they are labeling. They are very 
useful when there are many labels in a relatively small area. For example, you are 
labeling a map of Asia. There are many small countries that are relatively close 
together. If you tried to label all the countries, the labels would overlap and be 
difficult to read. 

Below Right Places the label below and to the right of the
anchor point.

Anchor Point 
Button Position Description
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To create callouts, set the Label Lines option in the Layer Control > Label Options 
dialog to Simple or Arrow for the layer that you want to label. Click the line style 
button to choose the style of line you want for your callouts. On the map, select a label 
with the Select tool and drag it away from its anchor point. When you release the 
mouse, MI Pro draws a line from the label to the anchor point. 

You can move the endpoint of the callout to position it more precisely. Select the label 
and drag the edit handle at the end of the callout to its new position. 

Note:  As in previous versions, you can double-click on the text and set the label 
line in the Text Object dialog. 

Label Styles
The Text Style dialog gives you a number of choices for label and text object styles. 
You can also change the styles of multiple selected labels at a time. 

To make style changes for all the labels, click on the Style button in the Label Options 
dialog to display the Text Style dialog. 

To change the styles of a selected label or labels, select the label(s) and either choose 
Options>Text Style, or click the Text Style button in the Drawing toolbar to display the 
Text Style dialog. If you change the styles of multiple labels at once, hold down the 
Shift key as you select each label.

Make the style changes you want. When you return to the map, the selected labels 
display with the style changes you specified. The available styles are explained in the 
table below.

Option Description

Bold Uses bold text to create the label.

Italic Uses italic text to create the label.

Underline Places a line underneath the text.

All Caps TEXT DISPLAYS IN ALL CAPITAL LETTERS.

Shadow Creates a shadow behind the text. (not shown)

Expanded A  s p a c e  i s  p l a c e d  b e t w e e n  e a c h  c h a r a c t e r  i n  t h e  
l a b e l  o r  t e x t  o b j e c  t.
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There are also three background options. Click None to have no background. Choose 
Halo to create a halo effect around the text. This puts the text into relief from whatever
it covers (e.g., part of a region, or a street, etc.). Use Box to create a background box 
behind the text. 

When you choose either the Box or Halo backgrounds, the Color list is activated. Click 
on it to choose a color for the halo or the background. A palette of colors choices will 
display. The color you choose corresponds to the button that is currently activated. 
The color will display in the box and in the Sample. 

Interactive Labeling
Although you will probably do most of your labeling automatically, you will need 
interactive labeling to edit and create individual labels. 

Editing Labels
It is very easy to edit individual labels, either those you have displayed automatically 
or those you have created interactively with the Label tool. Using the Select tool, 
double-click on the label. The Label Style dialog displays. The changes you make in 
Label Style dialog apply only to the selected label. Changes you want to apply to all 
the labels must be done through Layer Control in the Label Options dialog

. 

The Label Style dialog allows you to make changes to the text, position, and angle of 
the labels. You can also make changes to callouts, add, or delete them. 

To change the label content, simply type the new label text into the Text box. The other
controls in this dialog work the same way as in the Label Options dialog. 
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Moving a selected label is the same as moving other objects; simply drag them with 
the mouse. If you move a label that has a callout, the line will reappear automatically 
after you move the label. 

You can also rotate the label manually about its anchor point. When you select the 
label, use the rotation edit handle that appears to the lower right of the label. 

Creating Labels with the Label Tool 
Use the Label tool to create individual labels. First, make sure that the layer 
containing the objects you want to label is selectable. Click on the Label tool to 
activate it, and click on a map object. MI Pro labels the object with the column or 
expression you specified for that layer in the Map > Layer Control > Label Options 
dialog. Remember that InfoTips are active for the Label tool, so you can view the 
object’s label before you actually label the object. 

emoving Labels
The easiest way to remove all labels in a layer is to use the Visibility controls in the 
Label Options dialog. Click the Off button to turn the display of the labels off. It will 
disable the display of all the labels in that layer, both automatic and interactive. 

If you are displaying only edited labels or those you have created with the Label tool, 
choose Map > Clear Custom Labels to remove the labels. You will be prompted to 
discard the custom labels and revert back to the default settings. Click Discard. Your 
labels will revert back to the automatic labels. If you do not want any labels to display, 
turn Visibility off.

Only use the Delete key or Edit > Clear command to delete individual labels from a 
Map window. This is useful if you have a number of edited labels. You can delete the 
one you don’t want and still keep the rest of your edited labels. It is not recommended 
that you use these options to delete more than a few labels from the map. 

To replace labels already displaying with new ones, do not delete the old ones first. 
You will get unexpected results if you do this. For example, if you create labels with 
an expression and want to change the expression, do not delete the labels first. Simply 
change the expression in the Label Options dialog. If you delete the labels first, you 
are deleting the label for the object, not a piece of text. So, if you go to create labels 
with a different expression, they will not display because by deleting the old labels, 
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you have edited the table so that it does not display labels for these objects. Choose 
Map > Clear Custom Labels to revert back to the default settings. 

Packing a Table
Note that packing a table that contains customized labels can corrupt the labels. For 
example, you delete one or more rows from your table and save the table. Then you 
create a map with customized labels and save the labels to a workspace. You pack the 
table to purge the deleted rows. Since the Pack command closes the Map window, 
you’ll need to reload the workspace. When you do so, your labels are corrupted. 

This problem occurs most often when the deleted rows are located near the top of the 
Browser. To avoid the problem, pack the table before you create the labels.

Saving Labels
Whenever you manually edit automatic labels (including deleting with Edit > Clear 
or the Delete key), change the settings on automatic labels, or create labels with the 
Label tool, you will need to save your map to a workspace to have them display in 
your next session. 

For example, label settings are deactivated by default. You check the Auto label 
attribute in Layer Control to display automatic labels on your map and do not save 
the change when you close the table. The next time you display your map, the labels 
do not display because the settings go back to the defaults. As with the other Layer 
Control options, label settings are temporary unless you save the table to a 
workspace.

Manually edited labels and labels created with the Label tool behave differently. 
These are edits to the table, not temporary settings. If you close a window or a table 
and you have label edits pending, MI Pro will specifically prompt you to save the 
session to a workspace.

This also applies to labels you have deleted using Edit > Clear or the Delete key. You 
may not have any labels visible on your map, but because deleting a label is an editing
operation, MI Pro will ask you if you want to save the edits to a workspace.
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U
sing Text Objects
While labels in MI Pro are attributes of the map layer, text objects look like labels but 
behave like other annotations you draw on the map. They are stored in the Cosmetic 
layer, and you can save them to a table.

The Labeler tool in the MI Pro Tool Manager helps you use text objects to perform 
several common labeling tasks: 

• Convert labels into text objects, so that they can be saved in a permanent 
table. 

• Create labels for only the currently-selected objects.

• Draw text objects one at a time using the Text Label button. This allows you to 
create multiple annotations for a single map feature, which is something you 
cannot do using labels. 

Saving Labels as Text Objects 
If you have a Map window with labels, you may want to convert those labels into text 
objects, so that you can save the labels in a permanent table. You will also want to 
convert labels into text objects if you want your labels to grow larger as you zoom in. 
Text objects grow larger as you zoom in; labels do not. 

1. Choose Tools>Tool Manager. 
2. Locate the Labeler tool in the list and check the Load box. 
3. Click OK. The Labeler tool is added to Tools menu. 

The Labeler tool also adds a custom toolbar button, Text Label, to the Tools toolbar. 

To have the Labeler tool load automatically every time you open MI Pro, check the 
Autoload box next to the utility. The next time you run MI Pro, the Labeler tool will be 
on the Tools menu. 

To convert the labels on your map to text, do the following: 
1. Run the Labeler tool. 
2. Make the Map window the active window. 
3. On the Tools menu, choose Label Functions > Transfer Current Labels. 
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MI Pro displays the Transfer Labels dialog box, which gives you the following 
options: 

When you click OK, MI Pro converts the labels for the selected layer into text objects. 

If you display the Layer Control dialog, you will notice that the layer’s Auto Label 
check box is no longer checked. The Labeler utility automatically clears the box to 
prevent map features from looking like they are labeled twice. (If the Auto Label box 
remained checked, MI Pro would display both a label and a text annotation for each 
map feature, causing the map to appear to be labeled twice.)

Labeling the Current Selection 
At times, you may want to label only the rows that are currently selected. To label the 
selected rows, do the following: 

1. Run the Labeler utility. 
2. Make the Map window the active window. 
3. On the Tools menu, choose Label Functions > Label Selection. 

MI Pro draws a text annotation for each of the selected map objects. Note that these 
annotations are text objects, not labels. 

Option Description

From Layer Lets you choose which layer’s labels are converted.

To Layer Lets you choose where to store the labels after they are 
converted into text objects. 
If you choose <New> from the list, MI Pro creates a new table 
to store the text objects. (MI Pro prompts you to type in the 
table’s name after you click OK.) 

Include Hidden Labels When you create autolabels and manually delete some of those
labels, MI Pro considers each of the deleted labels to be hidden.
If you want to create a text object for each of the hidden labels, 
check the box; otherwise, clear the box. 

Transfer Labels From: 
   Map View
   Layout View 

This option is available if the Map window appears in a 
Layout. If you are using autolabels, the Layout window might 
display different labels than the Map window, because MI Pro 
tries to fit as many autolabels as will fit in the view. Click Map 
View or Layout View to choose whether MI Pro creates text 
objects that match the Map window or the Layout window 
labels. 
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Creating Manual Text Labels 
Although the Labeler utility lets you convert labels into text, you might find that it is 
easier to simply create text objects from the beginning. If you annotate your map 
using text objects (not labels), then you will never have to worry about converting 
your labels to text. 

The Labeler utility creates a custom button, Text Label, on the Tools toolbar. To use the 
Text Label button, do the following: 

1. Run the Labeler utility.
2. Make the Map window the active window. 
3. On the Tools toolbar, choose the Text Label button. 
4. Click on an object in the map. 

When you click on the map object, MI Pro draws a text object for it. Because the 
annotation is a text object, you can edit it in ways that you cannot edit labels. 

For example, suppose you are labeling a highway map. If you use the standard Label 
button, you will find that you can only label a highway polyline once, because each 
polyline can have only one label. However, if you use the Text Label button, you can 
create multiple text annotations for a single highway. 
apInfo Professional User�s Guide 323

Apple Inc. 
Exhibit 1021 

Page 330



Chapter 

Cartographic Legends 

Creating a Cartographic 
Legend 

Legend Wizard in Detail 

Modifying a Cartographic 
Legend 

16
Chapter 16: Creating a 
Cartographic Legend
Creating a Cartographic Legend

You can utilize the cartographic legend feature 
in a variety of ways. This feature enables you to 
create a legend for any map layer(s) in your 
Map window. Many of the elements in the 
cartographic legend and legend window can be 
customized, allowing you to enhance your map 
presentation. You have the added proficiency of 
being able to use the table metadata in your 
cartographic legend text as well as save legend 
attributes to the metadata. You are also able to 
align all of the legend frames in your Map 
window. Furthermore, the cartographic legend 
feature has the ability to join tables “on-the-
fly”, thus allowing you to obtain legend feature 
descriptions from another table while you are 
creating the legend. 

➤ 

➤ 

➤ 

➤ 
Apple Inc. 
Exhibit 1021 

Page 331



Chapter 16: Creating a Cartographic Legend

 

Cartographic Legends
Cartographic legends are based on the map layers in your Map window. Each legend 
in the legend window corresponds to a layer on the map, and each legend is enclosed 
in a legend frame within the legend window. The attributes for each legend frame, 
such as the title and label styles can now be derived from several sources. These are: 

• Map table metadata 

• Map table attributes

• Joined tables

• Manual creation 

A legend frame is another way to refer to a particular layer’s legend. You can create an
individual legend window for each layer in your map, or you can have several legend 
frames in one legend window. The properties for each legend frame can be edited 
individually.

Creating a Cartographic Legend
It is easy to create a cartographic legend using the Create Legend wizard. This section 
runs through the procedure of creating a legend quickly, and is followed by more 
detailed information about the options in the Create Legend dialogs. In this example, 
we’ll create a cartographic legend for a landmark map of upstate New York, shown 
below. 
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To create a cartographic legend:
1. Make sure your Map window is active and choose Map > Create Legend. The 

Create Legend – Step 1 of 3 dialog displays.

2. Select the layers you want to include in the legend using the Add and 
Remove buttons. Each layer corresponds to one frame in the legend. To 
remove a layer, click on the layer in the Legend Frames group to select it and 
click the Remove button. In our example, we’ll remove the Usa, Us_cnty, and 
Us_cty 8k layers. That will leave only the landmarks and highways layers in 
the legend.   

3. The frames appear in the legend in the order in which they appear in the 
Legend Frames group. You can change the order of the legend frames using 
the Up and Down buttons. 
apInfo Professional User�s Guide 327

Apple Inc. 
Exhibit 1021 

Page 333



Chapter 16: Creating a Cartographic Legend
4. Click Next. The Create Legend – Step 2 of 3 dialog displays. 

5. Use this dialog to set default options across all frames in the legend. Change 
the legend properties and legend frame defaults as you wish. In our example, 
we’ll change the Legend window title to New York Legend, and leave the 
other default options as is. 

6. Click Next. The Create Legend – Step3 of 3 dialog displays. 
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7. The Legend Frames group on the left displays all the frames selected in Step 
1. Each frame corresponds to a map layer. Select a frame from the list (you can 
only select one frame at a time). Select the Landmrks layer first. 
The frame’s default attribute settings display in the boxes on the right. Notice 

that the defaults used are the settings in Step 2. The ‘# ’ character from the 

default settings is replaced with the name of the layer. 

8. Select attributes for each legend frame, or use the default values. The default 
values are based on legend metadata keys in the underlying table, or, if no 
metadata keys exist, on the Legend Frame Defaults from Step 2 of the wizard. 
In our example, we’ll specify Landmarks for the frame title, obtain the legend 
styles from unique values in the Landmark column, and label the legend 
styles with the text information in the Landmark column. 
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9. Continue in the same manner for the Us_hiway legend frame. 
For the Us_hiway layer, enter Highways as the title, click the unique map 

styles button, and choose Expression in the Label styles with box. The Expres-

sion dialog displays. 

10. Type “Highway” in the text box, and click OK. It displays in the Label Style 
with box. 
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11. If you want to save your settings for the title, subtitle, the styles column, and 
the styles label for the selected frame to the table metadata, click the Save 
frame settings to Metadata button.

12. Click Finish when you have selected the desired attributes for each legend 
frame.

The cartographic legend displays on your screen. 
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Legend Wizard in Detail

Step 1 - Selecting Layers
The layers listed in the Legend Frames group of the Create Legend – Step 1 of 3 dialog 
are all the layers that will be included in your legend. All the layers in your Map 
window are included by default. 

Use the Up and Down buttons to reorder the layers in this list. To exclude a layer from
the legend, click the layer in the Legend Frames group and click the Remove button. 
The layer is added to the Layers group and will not be included in the legend. If you 
change your mind, select the layer in the Layers group, and click Add. The layer goes 
back to the Legend Frames group for inclusion in the legend. 

Step 2 - Defining Window Properties and Frame Defaults
In Step 2 of the Create Legend wizard, you specify the settings for your Legend 
window and the default settings for the legend frames. 
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Legend Window Properties
The legend properties pertain to the legend window. You can change the default 
window title, specify whether the legend window contains scrollbars, and specify the 
orientation of the legend window. 

The default window title is based on the layers in the Map window. The default will 
be: “Legend of <layer1>, <layer2>, <layer3>... .” To change the window title, enter the 
title you want into the Window Title box. Scrollbars for the legend window are 
displayed by default. To deactivate their display, clear the Scroll Bars check box. To 
specify the orientation of legend frames in the window, click the button next to the 
orientation you desire: portrait or landscape. 

Legend Frame Defaults
The Legend Frame defaults are used when there are no metadata keys in the 
underlying table. These settings show the default values for the legend text, style, and 
the border style of the legend frame. You can change the default values for any legend 
you are currently working with. Unlike metadata defaults, which can be different for 
each legend frame, these settings apply to all the frames in the legend. 
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Creating a Legend Frame Title 
Use the Title Pattern box to specify a title for the legend frame and its text style. Notice 
the # character in the Title box. It is a placeholder for the name of the layer on which 
the frame is based. For instance, if you are creating a legend for the Austrlia layer, “#  
Legend” in the Title box will display as “Austrlia Legend” in the legend, where #  is 
the name of the layer. The name of the layer will display in whatever position you put 
the # character. 

To create a title with the #  character in it, precede it with the ‘\’ character. For 
example, “Northeast \#” displays as “Northeast # .” Click the Style button next to the 
Title Pattern box to display the Text Style dialog. Here, specify the font, color, size, and 
type of emphasis of the text in your legend title. 

Creating a Legend Frame Subtitle
Specify a subtitle for the legend frame in the Subtitle Pattern box. Use the #  and ‘\’ 
characters in the same manner as you did in the Title Pattern box. Click the Style 
button next to the Subtitle Pattern box to specify the style of the text in the subtitle. 

Creating Text for Legend Symbols
Use the Style Name Pattern box to specify the text that displays next to each symbol in 
a legend frame. Use the % character to include the symbol type: point, line, or region 
in the style name text. It acts as a placeholder for the type of symbol displayed and is 
used the same way as the #  character. The #  character can also be used in this box. 
Again, to create text with these characters in it, precede the characters with the ‘\’ 
character. Click the Style button next to the Style Name Pattern to change the style of 
the text. 

Note:   Although the #  character can be used in all three text boxes in the legend 
frame properties, the % character can only be used in the Style Name 
Pattern box.

Designating Border Style
Check the Border Style box to place a border around your legend frames. To change 
the border style, click the Style button next to the check box to display the Line Style 
dialog. Here you can specify the line type, color, and width for the frame border.

To change the Legend Frame defaults for all subsequent mapping sessions, use the 
Legend window preferences (Options > Preferences > Legend Window). 
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Step 3 - Legend Attributes
The Create Legend wizard allows you to create attribute-driven legends. This makes 
creating text descriptions easier because they can be automatically generated from 
values in an attribute column. In addition, the process by which the legend is 
generated can be saved to the map table metadata in the underlying map layer, or 
from a joined table. The metadata is then used as the default attribute settings for the 
selected legend frame. These settings can be different for each frame. The metadata 
defaults override the Legend Frame defaults in Step 2 of the wizard. If no metadata 
keys exist in the table, the Legend Frame defaults from Step 2 are used as the default 
values. 

Selecting Attributes
Select attributes for one legend frame at a time. Click on a legend frame in the Legend 
Frames list to select it. The default settings for the selected frame display on the right 
side of the Step 3 dialog. 

The title and subtitle text is derived either from the table’s metadata, or if there are no 
metadata keys for the table, from the defaults indicated in Step 2 of the Create Legend 
wizard. You can type in a new title or subtitle or use the default settings. 
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Legend Styles
The legend styles are the symbols used in the legend to identify the map features. 
Each type of object: point, line, or region displays its own symbol in the legend. Point 
objects are represented by point symbols, line objects by lines, and region objects by 
boxes. In addition, support for the new multipoint and collection objects has been 
added to the cartographic legend feature. Multipoint objects will display as a point 
symbol in the legend. A collection object will display a combination of symbols 
indicating the different object types it contains.

 

Displaying Legend Symbols
You can display your legend symbols according to unique map styles or from unique 
values in a column. When you select unique map styles, one legend symbol for each 
unique map style is displayed in the legend frame. When you select unique values in 
column, a legend symbol displays for each unique value in the selected column. This 
creates multiple symbols of the same type. If you are creating a legend based on the 
Aus_caps cities using the Sit-ups table and you select the column Place_Name, a 
symbol for each capital city will display. You can then label each symbol according to 
Place_Name, or any other column, to have the column value display next to each 
symbol. 

Labeling Legend Symbols
You can label your legend symbols in several ways. You can use the Style Name 
pattern indicated in Step 2 of the Create Legend wizard. You can also provide more 
description using column values from your table, as noted above. The column can be 
any column in the table, or it can be one that you create specifically for this purpose. 
You can then write your own feature descriptions for each item in the table.

Example of a Cartographic Legend for a 
collection of points, polylines and regions.
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To create a label based on a value derived from your table, use an expression. You can 
also perform a join, enabling you to add a temporary column from another table that 
you can use for your feature descriptions. 

To create an expression, choose Expression from the Label Styles with drop-down list. 
Write your expression in the Expression dialog, and click OK. When you click Finish 
in the Step 3 dialog. The results of the expression are the labels for your legend 
symbols. Note that an expression can be multi-line.

To join tables, choose Join from the Label styles with drop-down list, select Join. (Note 
that the Join option is only available when there are at least two tables open.) The 
Update Column dialog displays. Choose the table you want to join to, specify the 
matching columns, choose the temporary column you want to add to the table, and 
click OK. You can now use this column for your feature descriptions. Again, this 
column can be any column value, or one that you create. This column is saved 
automatically in the workspace. 

Note:   If the temporary column name is saved to legend metadata, but the 
temporary column isn’t saved in the workspace (e.g. you close tables and 
undo the join), you’ll get an error when you re-create the legend from 
metadata. You must either redo the join to get the temporary column, or 
choose a different label expression for the legend text. 

Saving Legend Attributes to Metadata
To save your current attribute settings to the table’s metadata, click the Save frame 
settings to Metadata button. This overrides the metadata defaults. Your settings 
become the new metadata defaults for the selected legend frame. 

For a complete discussion of metadata support in cartographic legends, see the 
MapInfo Professional Reference. 

Other Legend Attribute Considerations
If you select a theme layer, the title and subtitle currently set for the thematic legend 
will display. You can change the title and subtitle text, but the other controls are not 
available. Changing the theme legend’s title and subtitle affects all occurrences of the 
thematic legend. In addition, fonts specified in Step 2 of the Create Legend wizard are 
not applied to thematic legends. 
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If you have Display Style Override activated in a layer, (Map>Layer Control>Display 
button>Display Options), the column and label fields will be ignored when the 
legend is created. Step 3 of the Create Legend wizard will indicate whether Display 
Style Override has been activated for the selected legend frame. If the Style Overrides 
are turned off for a map layer and the legend is refreshed, it will be refreshed 
according to the column and label originally set. 

MapInfo Professional® contains metadata keys for labels for layers that have Display 
Style Override activated, but they must be put in manually. 

Modifying a Cartographic Legend
Creating a cartographic legend places a Legend menu on the menu bar. Use the 
commands in the Legend menu to add frames and modify the legend window 
properties. The Legend menu behaves the same way as menus for other types of 
windows. The active window determines what type of window menu is available, so 
when the legend window is active the Legend menu appears in the menu bar. 

Adding Frames to a Cartographic Legend
Adding frames to a cartographic legend you have already created is easy. The 
procedure is the same as for creating the legend, except that you are just adding 
frames to it. Do the following: 

1. Choose Legend>Add Frames or right click to display the shortcut menu and 
click Add Frames. The Add Frames – Step 1 of 3 dialog displays. 
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2. The Legend Frames list displays the map layers in your Map window that are 
not currently included in your legend. The Us_cnty, Usa, and Us_cty 8k layers 
display in the box. Let’s remove the Usa and Us_cty 8k layers. Click on the 
layer you want to remove and click the Remove button.

3. Click Next. The Add Frames – Step 2 of 3 dialog displays. 

Here, specify the legend window properties and legend frame defaults as you 

did in the Create Legend wizard. The legend frame defaults you specify here 

are used if there are no metadata keys in the table. 

4. Click Next. The Add Frames – Step 3 of 3 dialog displays. 
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The default values that display for the frame title and subtitle are taken either 

from the defaults you specified in Step 2, or the table’s metadata. As in the 

Create Legend wizard, you specify attributes for one frame at a time. 

This dialog works exactly the same way as choosing styles for the initial cre-

ation of the legend. You can select either a column, the Style Name Pattern 

(the default settings in Step 2), Expression, or Join. 

5. Enter Area Counties as the title for the Legend frame. 
6. Click the unique map styles button. 
7. In the Label styles with box, choose Expression. In the Expression dialog, 

type: “Albany and Rennselaer” and click OK.   
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8. To save your frame settings to the table’s metadata, click the Save frame 
settings to Metadata button. These settings become the new legend frame 
defaults. 

9. Click Finish. Your legend redisplays with the added frame(s). 
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Modifying Legend Window Properties
To modify the Legend window properties, choose Legend>Window Properties. You 
can also double-click in the legend window, outside of a legend frame to display the 
dialog. The Legend window properties are for the entire Legend window. You can 
change the window title, include scrollbars, or activate Autoscroll and Smart Pan. 

For the New York Legend, clear the Scroll Bars box to remove the scoll bars. 

Modifying a Legend Frame
To modify a particular legend frame, right click on the frame you want to change. The 
frame is selected and a shortcut menu displays. Click Properties to display the Legend 
Frame Properties dialog. You can also double-click on the legend frame to display the 
Legend Frame Properties. 

This example shows the frame properties for the Landmrks layer. 
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You can edit the title, subtitle, legend symbol text, as well as the title and subtitle text 
styles, the border style, and the styles of the legend symbol text. When you edit 
legend symbol text, you can add multi-line text in the Edit selected text box. 

Let’s choose a different font for the frame title. Click the font style button for the Title 
to display the Text Style dialog. Choose a different font, a larger font size, and check 
the bold box. Click OK when you are finished with the modifications. 

Go into the legend frame properties for each of the other frames and make the same 
modifications to the title font. 
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This is what the legend now looks like. The scrollbars have been removed and the 
frame title text has been modified. 

Note:   If you modify a legend for a thematic map (a theme legend), clicking the 
Properties option in the shortcut menu displays the Modify Thematic Map 
dialog. Click the Legend button to modify the theme legend. See Chapter 11 
for details on thematic mapping and theme legends. 

Deleting Frames
You might decide that you want to remove one or more of your legend frames from 
the legend. To delete a frame, right-click inside the frame you want to remove to 
display the shortcut menu. Click Delete. Here is the updated legend. 
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Refreshing Frames
If any edits you make in the legend cause changes to the formatting in the window, 
choose Legend>Refresh (or right-click to display the short cut menu and click 
Refresh). 

The Refresh Legend dialog displays. You can refresh the legend styles, the layout, and 
the alignment. 

When you refresh the legend styles, MI Pro adds new styles associated with t he 
legend and removes obsolete styles. 

If the layout mode is changed from Portrait to Landscape, or vice versa, or from 
Custom to Portrait or Landscape, MI Pro resizes the window to a default size that’s 
based on the layout mode (similar to the initial window you get when you first create 
a Portrait or Landscape legend).

When you refresh the alignment, your legend styles and text are aligned across all 
frames in the legend, regardless of the orientation of the window. For new legend 
windows, this means style centroids across all frames will be lined up and style labels 
across all frames will be lined up. When new frames are added, the style centroid and 
label offset are remembered.

If editing or adding frames to an existing legend causes frame(s) to be formatted 
differently than other frames in the same window, users can use the Legend>Refresh 
dialog to re-align styles and text across all frames.

To demonstrate how frame alignment works, go back to the Legend Frame properties 
and make some changes to the size of the symbol text in each frame. The legend now 
looks like the legend on the left, in the illustrations, below. 
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Choose Legend>Refresh and make sure Refresh alignment is checked. The legend is 
re-aligned across all of the frames. The legend now looks like the legend on the right 
in the illustration. 
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You can easily revert the legend symbol text back to its original size through the 
Frame properties. Here is how the legend looks with the map. 
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Drawing and Editing Your Map

The drawing and editing capabilities in 

MapInfo Professional® allow you to create and 
customize an unlimited variety of objects for 
your maps. Easy-to-use drawing tools and 
commands are accessible from the Drawing 
Toolbar. You can also display nodes, line 
directions and centroids to give you better 
control when editing objects. 
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Drawing and Editing Tools
MapInfo Professional has a complete set of drawing tools and editing commands. 
These tools allow you to draw and modify objects on your map. You can also use 
these tools to customize the colors, fill patterns, line types, symbols, and text on your 
map. 

However, these tools and commands give you more than the ability to modify your 
map. You can draw a variety of objects that you can use to perform powerful 
geographic analyses. For example, you can draw circles, polygons, and other 
bounded objects. You can then search for records within those boundaries. 

Drawing Tools
There are nine drawing tools, each located in the Drawing Toolbar:

Icon Tool Description

Arc tool Use the Arc tool to create arcs. You can change 
an arc’s angle and its endpoints. To draw a 
circular arc, hold down the Shift key while 
using the Arc tool.

Ellipse tool Use the Ellipse tool to create ellipses. The 
ellipse is drawn from the center outward at the 
point where you click. To draw a circle, hold 
down the Shift key while dragging the ellipse 
cursor. To begin an ellipse (or circle) from a 
“corner,” use the Ctrl key in combination with 
the Ellipse tool.

Line tool Use the Line tool to draw straight lines (streets, 
pipelines, cables). To draw a horizontal, 
vertical or 45° line, hold down the Shift key 
when using the Line tool. Note that borders 
around regions or boundaries are not lines. 
Therefore, if you use the Line tool to draw a 
square, MapInfo Professional does not 
recognize the square as a region. You cannot 
shade its interior or perform searches within it.

Polygon tool Unlike the Ellipse, Rectangle, and Rounded 
Rectangle tools (which only create shapes), the 
Polygon tool creates regions. You can perform 
many more editing functions with regions, 
such as merging and reshaping. 
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Drawing and Editing Commands
The Drawing Toolbar contains six additional buttons to aid you in drawing and 
editing. 

Polyline tool Similar to the Polygon tool in that polylines 
can be reshaped and smoothed (replacing 
angles with curves). Neither option is available 
with objects drawn with the Line tool.

Rectangle tool Use the Rectangle tool to create rectangle 
shapes. To draw a square, hold down the Shift 
key while using the Rectangle tool. The object 
is drawn from a corner. To draw a rectangle 
centered on the point at which you click, use 
the Ctrl key with the Rectangle tool.

Rounded Rectangle 
tool

Use the Rounded Rectangle tool to create 
rectangles with rounded corners. To draw a 
rounded square, hold down the Shift key. As 
with the Rectangle tool, use the Ctrl key with 
the Rounded Rectangle tool to draw the object 
from the center outward.

Symbol tool Use the Symbol tool to create point markers.

Text tool Use the Text tool to draw alphanumeric text. 
You can customize the font, point size, and 
rotation angle. You can also create text by using 
MI Pro’s labeling tools and commands. 

Icon Tool Description

Reshape button Toggle in and out of Reshape mode with this 
button when you want to add, delete, or move 
nodes in an editable layer (also available on the 
Edit menu).

Add Node button The Add Node button allows you to put 
additional nodes on an object for more precise 
editing.

Line Style button Displays the Line Style dialog where you can 
change the color, width, and type of selected 
line objects or set new defaults for future 
objects.

Icon Tool Description
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Making the Layer Editable 
Before you can draw on any layer in MapInfo Professional, you need to make that 
layer editable. The drawing tools are unavailable on the toolbar until a map layer is 
made editable. These rules also hold true for the Cosmetic Layer. 

To make a layer editable, choose Layer Control from the Map menu or click the Layer 
Control button in the Main toolbar. Choose the appropriate layer and select the 
corresponding check box to make it editable. You can also change the editable layer 
via the Status Bar. Click the Editing box to display a list of the layers used in the Map 
window, then select the layer you want to make editable. Choose None to deactivate 
editability for all the layers. Only one layer per Map window can be editable at a time.

How to Make a Read-Only Table Editable
If you are working with tables that were opened from Excel, Lotus, or ASCII files, you 
may have noticed that they come in as read-only tables. Because the files are not in 
native MapInfo Professional formats or standard DBF format, MapInfo Professional is
unable to edit the tabular information contained in these tables. 

Region Style button Displays the Region Style dialog where you 
can change the fill pattern and border of 
selected region objects or set new defaults for 
future objects.

Symbol Style button Displays the Symbol Style dialog where you 
can change the symbol type, color, and size of 
selected symbol objects or set new defaults for 
future objects.

Text Style button Displays the Text Style dialog where you can 
change the font, size, color, and attributes of 
selected text or set new defaults for future text 
and labels. 

Icon Tool Description
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If you wish to modify the table information, you must save a copy of the table.
1. With your table opened, choose File > Save Copy As. In this example, we will 

save a copy of an Excel file named Sites.

2. Choose a new name for the file. Click Save.
3. There is now a copy of the Excel file saved in MapInfo Professional native 

format. Open the new file, and you will have full edit capabilities. 

rawing Objects
Drawing objects in MapInfo Professional is easy. Once you have made the layer 
editable, choose the appropriate tool. Using the shape tools, you can draw arcs, 
ellipses, circles, lines, rectangles, and rounded rectangles on your map. You can either 
draw the object directly on the Cosmetic Layer (and save it to another or new layer 
later) or make a map layer editable now and draw the objects there. 

Once you have drawn the object, you can move the object, delete it, copy it to the 
Clipboard, or paste it to another Map window. 

Also, you can delete the last node of the object by pressing the Backspace key.  If there 
is only one node left in the object, it will not be deleted.

Using the Ruler Window as You Draw
The Ruler window will show the distance of line segments as you draw, as well as the 
cumulative distance of the drawn object. If necessary, a rubber-banding line displays 
to show what points are being used to computer the distance. The Ruler window also 
displays what type of calculation is used to compute the distance: Spherical or 
Cartesian. The type of calculation depends on the projection of the map. The 
following drawing tools will display a rubber-banding line:

• Arc
• Ellipse
• Rectangle
• Rounded Rectangle
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You can also use the Ruler window with the Marquee Select and Radius Select tools. 
Just click the Ruler tool to display the Ruler window. 

If the Ruler window is not active, the drawing and selection tools noted above do not 
display distance. The rubber-banding line does not display. 

Object Styles
MapInfo Professional draws objects using the default color, fill pattern, line type, 
symbol, and text settings for the layer you are drawing on. The default style can be set 
using Options > Preferences > Styles > Default Object Styles. To change the style of an 
existing object, make the layer editable, select the object and choose the appropriate 
style command from the Options menu. (The style commands are also available on 
the Drawing Toolbar.) These commands also set the styles for any subsequent objects 
to be drawn on the layer. 

For closed shapes such as circles and squares, you can change the fill pattern and 
color, the style and color of the border, and the line width of the border. For arcs and 
lines, you can change the type of line, its color, and the width of the line. In addition, 
you can use interleaved line styles to create the appearance of intersections for 
overlapping intersections and lines within a single layer. Interleaved line styles are 
available for use with lines of the same style and color (they can be different widths). 
Interleaved line styles are not available for solid lines or borders.

Any edits to an object’s default settings will be applied during the entire work session 
until you make new changes. To save the settings, you must save the table where the 
object resides.

You can also change the display of an object in Layer Control. In the Layer Control 
dialog, click the Display button to bring up the Display Options dialog. Click the Style 
Override check box. The Style Override button becomes active. Click the Style button 
to bring up the appropriate Style dialog. 

Note:   The settings you specify through the Display Options dialog are 
temporary unless you save the table to a workspace. For more information 
on the Display Options dialog, see Chapter 7, Mapping in Layers. 
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Printing Fill Patterns
When you are printing objects you have drawn, some fill patterns displayed in the 
Region Style dialog print faster than others. Specifically, the fill patterns on the top 
row of the pattern palette print the fastest. The difference in printing speed varies 
from printer to printer. The fill patterns on the top row are also the ones most likely to 
plot correctly on pen plotters, although results depend on which plotter driver you 
use. 

Polygons and Polylines
Drawing polygons is different than drawing other shapes because you are creating a 
region on which you can perform other editing operations.

For instance, you want to create school districts for your map. You have a street map 
of your town to guide you in defining the school district boundaries. Choose the 
Polygon tool. The tool becomes a cross hair. Click on a starting point for the polygon. 
Continue to click to add segments to the polygon. When you are ready to complete 
the object, double-click on the last end point. You can delete the last node by pressing 
the Backspace key.  If there is only one node left in the object it will not be deleted.
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You can then use the Combine command to combine this region with another, reshape
the region, etc. 

Polylines are made up of multiple line segments that are treated as one object. Unlike 
lines created with the Line tool, you can smooth polylines into a continuous curve 
using the Objects > Smooth command. Again, you can delete the last node by pressing
the Backspace key.  If there is only one node left in the object it will not be deleted. 

Drawing Symbols
To draw symbols, make the layer you want to draw the symbols to editable and 
choose the Symbol tool. Place the cursor where you want the symbol to be and click. 
The symbol displays using the default symbol style settings. 

To change the symbol’s style, select the symbol and click the Symbol Style button, or 
choose Options > Symbol Style. The Symbol Style dialog displays, where you can 
change the symbol, font, color, and size, as well as create background effects and bold 
face for symbols. 

Make the desired changes, and click OK. The symbol displays with the style changes 
you specified. These settings also apply to any subsequent symbols you draw until 
you change the settings. 
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Supported Fonts
You have many options when drawing symbols. We support a number of TrueType 
fonts that carry their own symbol sets. We have also organized a number of symbol 
fonts around different industries, such as real estate and transportation, making it 
easy for you to find the symbols you need. 

The MapInfo Professional Symbols font is the same set of symbols offered in previous 
versions of MapInfo Professional, but the symbols are now a TrueType font. The 
MapInfo Professional 3.0 Compatible font contains the same symbols offered in 
previous versions of MapInfo Professional in the same vector format. When you use 
these symbols, the Background and Effects options in the Symbol Style dialog are 
unavailable. Please see the MapInfo Professional Reference for a complete list of 
symbol fonts. 

Warning: If you are creating a map that will be used by MapInfo Professional 3.0 
users, avoid using TrueType symbols and custom symbols. Limit your point objects to 
the symbols in the MapInfo Professional 3.0 Compatible symbol set.

If you create a table that contains TrueType symbols or custom symbols, and you 
display the table using MapInfo Professional 3.0, the symbols will be invisible. If you 
then edit the table using MapInfo Professional 3.0, the point objects may be lost.

Custom Symbols
You can also use your own custom bitmaps as symbols in MapInfo Professional. They 
will appear in the Font list as Custom Symbols. 

To have custom symbols appear in the Font list, you must have already saved the 
symbols as bitmaps in the CUSTSYMB directory, which is in the application data 
directory created during installation. If you add bitmap files to the CUSTSYMB 
directory during a MapInfo Professional session, the new bitmaps will not display in 
the Symbol Style dialog until you click the Reload button.
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Changing Styles
When you change the style of a custom symbol, the Effects options in the Symbol 
Style dialog are different. 

You can either show a background or apply a color. Show Background displays the 
custom symbol with the background color with which it was created. Apply Color 
replaces all non-white pixels with a color you choose from the color palette. The 
Background options are grayed.

Symbol Sizes and Colors
You can create various sized bitmaps (e.g., 64x64, 32x32, 16x16). The smaller ones will 
look better at smaller font sizes because they won’t need to be compressed. The larger 
ones will look better at larger font sizes because they have more pixels and more 
detail. 

For Win 32, the total size of the bitmap can be no larger than 128K.

For custom symbols, 256 colors are supported. 

Drawing Text
Although the labeling feature takes care of most of your text needs, you will still need 
to create text objects with the Text tool to annotate your map or layout (e.g., map titles
and subtitles). Unlike labels, text objects have no connection to data. 
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To create text, make sure the layer you want to draw the text to is editable and choose 
the Text tool. The cursor changes to an I-beam. Place the cursor where you want the 
text to be and type in the text you want. 

To change the style of the text, select the text with the Select tool, and click the Text 
Style button, or choose Options > Text Style. The Text Style dialog displays where you 
can change the font, the size, color and create various effects such as haloing or drop 
shadows. These settings will remain in effect for any text you subsequently draw on 
the map until you change them. For a complete description of the Text Style dialog, 
see either Chapter 15, Labeling Your Map, or the MapInfo Professional Reference. 

To save changes, choose Save from the File menu. To save objects drawn to the 
Cosmetic Layer, choose Save Cosmetic Objects from the Map menu. 

diting Objects
In all likelihood, you will need to change or edit some of the objects you have drawn 
or mapped. Make the layer that you want to edit editable (Map > Layer Control). To 
edit an object, select the object with the Select tool. If the object is a line, edit handles 
appear at either endpoint. If the object is a boundary or region, edit handles appear at 
the outer corners of the object. You can drag the object to a new position or change its 
line style, fill pattern, or symbol.

To delete an object, click on the object with the Select tool. Choose Clear or Cut from 
the Edit menu, or press the Delete key. MI Pro deletes the object. 

To view an object’s nodes, centroids, and line direction when editing and drawing, set 
the conditions in the Layer Control > Display Options dialog.

Positioning and Sizing
To move an object to a new location, click on the object to select it, and hold down the 
mouse button for at least one second. The cursor turns into a four-headed arrow. Drag 
the object to its new location and release the button. The object maintains its shape. 

If you click on the object to select it, you can then press the up, down, left and right 
arrow keys to move the selected objects 1 screen pixel in the corresponding direction. 
If you press the Shift key when the arrow key is selected, the object will move 10 
pixels.  
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Also, if you click on the on the fifth edit handle (rotate handle) and hold down the 
mouse button, you can rotate the highlighted box to the desired angle.  A rubber 
banding box is drawn representing the rotated object.  If the shift key is pressed while 
the rubber banding box is being drawn, the rotation will be limited to 45 degree 
increments.

Object Attributes
When you double-click on a region, line, point or text object with the Select tool, 
MapInfo Professional displays an Object Attribute dialog. This dialog gives you the 
object’s size, its position, and other information specific to the object. For example, if 
you double-click on a region, MapInfo Professional displays the perimeter, centroid, 
and area. It also shows the type of distance calculation that was used to obtain these 
values. 

If the layer is Selectable but not editable, you can only view these attributes. If the 
layer is also editable, then you can change these attributes by typing new values into 
the text boxes of the dialog. The illustration above shows the Object Attribute dialog 
for a region object in an editable layer. You can also access this dialog by choosing Edit 
> Get Info.

Changing an object’s size and position with the Object Attribute dialog box gives you 
much greater control over its exact size and position than you have through drawing 
it on the screen. For example, you have a list of ten radio towers and their X and Y 
coordinates. You could geocode these points using the Create Points command. 
However, if you bring up the Points Object Attribute dialog and type the new X and Y 
coordinates, you can create ten points with the Symbol tool and then individually 
place them in the correct location.
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You can also use the Text Object Attribute dialog to change the point’s actual text. For 
example, you have typed the title “World Population” on a Map window. You want to 
fix your typographical error. Bring up the Object Attribute dialog for the text object. 
You can correct your error in the box that displays the text. 

For more information on using the Object Attribute dialog to edit your objects, see Get 
Info in the MapInfo Professional Reference. 

eshaping Objects
You can reshape regions, polylines, lines, arcs and points. A region is an object created 
with the Polygon tool. You cannot reshape objects created with the Rectangle tool, the 
Rounded Rectangle tool, or the Ellipse tool. 

To reshape an object, select a single object with the Select tool and choose Edit > 
Reshape, or use the Reshape button on the Drawing Toolbar. You are now in Reshape 
mode. MapInfo Professional draws nodes at every juncture where two polyline or 
polygon line segments meet. To reshape the object, move the nodes, add nodes, or 
delete nodes from the object.

To move a node, click on it and, while holding down the mouse button, drag the node 
to the desired location. The line segments connected to the node are moved to a new 
position. To add a node, click on the Add Node tool from the Drawing Toolbar, 
position the cursor where you want to add the node, and click the mouse button. 
MapInfo Professional adds a node. You can now move this node or delete it, just as 
you would any node. To delete a node, position the cursor over the node, click on it, 
and press the Delete key.

Note that the maximum number of nodes for regions and polylines is 1,048,572 nodes 
for a single polygon region or polyline. The limit drops by seven nodes for every two 
additional polygons. If an object with more than 32K nodes is saved and the table is 
read in a version of MapInfo Professional prior to version 4.5, the object(s) will not be 
visible. Objects in the table that do not exceed the 32K limit will be visible. 

The Reshape command is very useful when you are creating sales territories or other 
merged boundaries. For example, you are merging ZIP Code boundaries together to 
create school districts. Some ZIP Code boundaries fall into more than one school 
district. Use the Reshape command to reshape the school district to incorporate a 
section of a ZIP Code boundary.
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Moving the Endpoints of an Arc
You can also change the endpoints of an arc with the Reshape command. Select the arc 
with the Select tool and choose Reshape. Grab either end of the arc and move it to the 
desired location. Reshaping an arc will not change the shape of the ellipse that it is 
part of, merely its endpoints.

Selecting Multiple Nodes
Reshape mode allows you to easily select nodes of an existing object and copy and 
paste them, drag them to reshape the object, delete them, etc. To trace an existing 
object, we recommend that you use the autotrace feature, which is explained in the 
next section, Snap to Nodes. The following illustrations show how to copy the border 
between Kentucky and Indiana.

1) Select the object. Turn on Reshape 
mode. The nodes display.

2) Select the nodes you want to copy.

3) After Edit > Copy, Paste, the new 
object displays with edit handles.

4) Click and drag the object to move 
to another location.
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Select Kentucky to enable Reshape mode. Select the first node with the Select tool. 
Shift-click on the last node to be copied. MapInfo selects all nodes in between 
following the shortest route between nodes. (To select all nodes except those between 
the shortest distance, use Ctrl-click with the Select tool.) Choose Edit > Copy to copy 
the nodes to the clipboard. Paste the duplicate nodes onto the map using Edit > Paste. 
The object you copied is drawn on top of the original object as a polyline. To move the 
polyline click on it, hold down the mouse button, and drag the polyline to a new 
location. 

For more information on reshaping objects, see Reshape in the MapInfo Professional 
Reference.  

nap to Nodes
Not only can nodes be used to reshape an object, they can also be used to align one 
object to another object. MapInfo Professional refers to this process as snapping to a 
node. 

In the Map window, regions, polylines, lines, arcs and rectangles all have nodes that 
can be attached (or snapped) to each other. When the Snap to Nodes option is 
enabled, MapInfo Professional searches for these nodes as you move a node. MapInfo 
Professional automatically snaps the cursor to a node in an object when the cursor 
comes within a certain distance of the node. 

To activate Snap to Nodes, press the S key. The status bar displays with the word 
“SNAP” when Snap mode is activated. It acts like a toggle on/off switch. You can set 
the snap tolerance in pixels in the Map Window Preferences dialog (Options > 
Preferences). The Snap Tolerance field allows you to specify a tolerance within which 
snap operates. For example, if you set the snap tolerance to 3 pixels, whenever you 
move the cursor within 3 pixels of a node, the cursor will snap to the node.

Snap to Nodes applies to all selectable layers—this is useful if you are drawing an 
object in one layer and want to attach it to an object in another layer. If you do not 
want to snap to objects in certain layers, make those layers unselectable.
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Move Duplicate Nodes
In most maps, nodes of various objects are usually connected, especially for adjoining 
streets and boundaries that share a common border. Using the Move Duplicate Nodes 
Option under Map Window Preferences, you can specify where MapInfo Professional 
looks for connected nodes in order to move them in unison. Choose the None of the 
Layers button to turn the option off. Choose the Same Layer button so that connected 
nodes in the same layer are moved when one of them is moved.

Tracing Existing Objects
MapInfo Professional now makes it much easier to trace an existing polygon/polyline 
network, e.g., the United States. The new autotrace feature allows you to trace the 
nodes of another polyline or polygon. Autotrace is available when Snap mode is 
turned on. Note that you can only use autotrace on existing polylines and polygons. 
You cannot autotrace rectangles, ellipses, arcs, or other shapes made with the drawing 
tools.

To autotrace a polyline/polygon, do the following:
1. Turn on Snap mode (click the S key), and click on a node of the polyline/

polygon you want to autotrace.
2. Move the mouse to another node of the same object. 

For polylines, hold down the Shift key and click.

For polygons, hold down the Ctrl key and click.

3. Do one of the following:   

For polylines, hold down the Shift key and click.

For polygons, hold down either the Shift or Ctrl key and click.

As soon as you press either the Shift or Ctrl key, MI Pro highlights the path to 
be autotraced. When you click, MI Pro automatically traces all the segments 
between the two nodes and adds them to the polyline/polygon you are 
drawing.

Note: The Shift key autotraces the shorter path between the two nodes (the 
path with the lessor number of nodes), and the Ctrl key autotraces the longer 
path (the path with the greater number of nodes). Autotrace works the same 
way as when you are selecting multiple nodes in Reshape mode.
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You can only autotrace one object at a time. The second node you Shift/Ctrl-click on 
must belong to the same object as the first node. If it belongs to a different object, 
MapInfo Professional will draw a straight line between the two nodes. If you click on 
a node that’s shared by two objects (e.g., a shared border), you can begin autotracing 
from either polygon. 

moothing/Unsmoothing Lines
You can use the Smooth command to convert polyline angles into polyline curves. 
Click on a polyline with the Select tool and choose Objects > Smooth. MapInfo 
Professional smooths the line so that it appears to be one continuous line with curves 
instead of angles. To undo the process choose either the Undo Smooth command or 
the Objects > Unsmooth command.

Both the Smooth and Unsmooth command can be used only on polylines. A polyline 
is a line drawn with the Polyline tool. Smooth and Unsmooth do not work with 
objects drawn with the Line tool. If you attempt to smooth or unsmooth any object 
besides a polyline, MapInfo Professional gives you a warning message.

onverting to Regions and Polylines
You may find it necessary, on occasion, to change an object into a polyline or a 
polyline into a region during an editing session. You can do so simply by selecting the 
object and choosing either Objects > Convert to Region or Convert to Polyline.

For instance, you select a group of nodes that you want to copy and paste elsewhere 
on your map. MapInfo Professional treats the group as a polyline and copies it to the 
clipboard. After you paste the polyline on your map, you can convert it to a region by 
choosing Objects > Convert to Region. 

If you want to create a buffer zone within one mile of a boundary, meaning you want 
a zone that extends one mile from the boundary to the outside and to the inside, you 
must first convert the region to a polyline and then create the buffer. If you first create 
the buffer on the region, you will include too much territory in the buffer (the entire 
region in the buffer plus the one mile buffer that extends outside of the region).

Converting objects to polylines and regions allows you to perform node-editing 
operations on objects that ordinarily do not allow node editing. For example, you 
cannot add nodes to a rectangle object. If, however, you first convert the rectangle into 
a polyline or region, you can then add nodes to the object.
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Editing Street Maps (StreetInfo)
MapInfo Professional sells street maps for every county in the United States. If you 
have purchased any of these StreetInfo maps, you will need to know how to edit 
them. You can add and delete streets, rename streets, or edit existing streets.

We have included a StreetInfo file with your sample data. This map contains streets in
San Francisco, California (sf_strts.tab). 

StreetInfo files are read-only files; you can’t change them. But, associated with each 
StreetInfo file are two files that you can change: sf_strt1.tab and sf_strt2.tab. sf_strt1 
contains the graphic information about the streets and address ranges for each 
segment (hence, we’ll call it the segments file). sf_strt2 contains the street names (we’ll
call it the names file). 

These two files are associated through a field called MI_REFNUM, which contains a 
reference number. A segment with a reference number 23 in sf_strt1 will be associated
with the name in sf_strt2 that has the same reference number.

The other fields in the segments file are:

FromLeftStarting point of address numbers, left side of the street.

ToLeftEnding point of address numbers, left side of the street.

FromRightStarting point of address numbers, right side of the street.

ToRightEnding point of address numbers, right side of street.

TypeThese numbers indicate the type of street or highway.

Adding a Segment to an Existing Street
Let’s assume you want to add a segment to an existing street or want to add a street 
for which a name already exists. 

When you want to add a segment to an existing street, you already know that the 
street name is in the name file.

Adding a street where the name already exists isn’t as odd a situation as you might 
imagine since StreetInfo maps are county-wide. You might want to add Poplar St to 
one town. If another town already has a Poplar St, then you don’t need to add that 
name to the name file since it contains all the names used in the county. To find out 
whether a name already exists in the name file, use the Find command from the 
Query menu.
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In either case the basic idea is that you have to add a new record to the segments file 
and associate that record to the name file through the reference number. Assume we 
are working in the San Francisco files; the procedure is the same for any StreetInfo file.

1. Choose File > Open to open the Dcwashs, Dc_strts, and Dc_zip files.
2. Choose Layer Control from the Map menu. Make the dcwash layer Editable 

and the dc_strts layer Selectable.
3. Using the Find command or the Info tool, locate the street you want to edit. 

Click on the street with the Info tool. Scroll through 
the Info window until you locate the MI_REFNUM (MI Pro reference 
number) field. Make a note of that number.

4. Go to the Dcwashs layer in the Map window and draw the new segment. By 
setting the Snap to Node mode, MI Pro will guide you to connect the node 
from the existing street with the node from the new segment.

5. Click on the new segment with the Info tool. Type the appropriate textual 
information, address ranges, street type, and MI Pro reference number.

6. Repeat the process for each additional new segment. 
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Adding a New Street
Now let’s consider the case where you want to add a completely new street. Since the 
street is new, you have to make changes in both dcwashs1 and dcwashs2. The 
following procedure will work with any StreetInfo file.

1. Open Dc_strts and Dcwashs1 in a Map window.
2. Open Dcwashs2 as a Browser and make it the active window.
3. Choose New Row from the Edit menu. Scroll down to the bottom of the 

Browser. MI Pro appends an empty row to the Browser. 
4. Type the name of the street into the empty record.
5. The new street name also needs a corresponding MI_REFNUM. The easiest 

way to select a reference number is to keep these numbers continuous. Simply 
add 1 to the last MI_REFNUM listed in the Browser. Use that number as the 
MI_REFNUM for your new street name.

6. Choose Layer Control from the Map menu. Make the Dcwashs1 layer 
Editable and the Dc_strts layer Selectable.

7. Draw the new segment on the Dcwashs1 layer.
8. Click on the new segment with the Info tool. Type the appropriate textual 

information, address ranges, street type, and the new MI Pro reference 
number.

9. Repeat the process for each additional new segment. 

Renaming a Street
If you want to rename a street, simply change its name in the name file (Dcwashs2). 
Note that changing a name in that way affects all segments that reference it. 

For instance, if you want to change the name of Broadway in one town, you have to 
make sure there aren’t other towns in the county that also have a Broadway. If there 
are, then you have to add the new street name to the names file and give it a reference 
number. You would then go into the segments file and give the new reference number 
to those segments you want to change. 

If you want to rename only a part of the street, you have to add a new record to the 
names file, give that record a new reference number, and then assign that new 
reference number to the appropriate segments in the segments file. 

How do you find those segments? One way would be to call up a Map window of the 
town and select the segments using the Select tool. Those segment records will then be 
highlighted in the Browser, where you can change their reference number.
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You can change the street colors and line types in StreetInfo maps. For example you 
might want to do this to indicate streets under repair or all streets that make up a 
sanitation pickup route. 

1. Open Dcwashs1 in a Map window.
2. Choose Layer Control from the Map menu. Make the Dcwashs1 layer 

Editable.
3. Select all the streets you want to change.
4. Choose Options > Line Style. 
5. Select a line width, line style, and color.
6. To save your changes, choose the Save command from the File menu. 

You can use any method to select the streets, depending on the nature of the 
situation. You can use the Select tool to click on the segments, one-by-one. 
You could also use the Radius Select, Marquee Select or Boundary Select 
tools, or the SQL Select or Select commands. 

7. From the Create New Table dialog, type tuttest in the file name box and click 
OK. 
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Redistricting

One popular use of MapInfo Professional® is to 
group map objects with a common field into 
districts or territories. MapInfo Professional’s 
Redistricting feature allows you to create new 
districts, realign existing districts, all the while 
doing calculations of the attached data on the 
fly for instant analysis and decision-making. 
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What Is Redistricting?
Redistricting is the process of grouping map objects into districts in order to perform 
aggregate calculations on the data to provide totals of net values for the districts. MI 
Pro creates an individual value thematic map where the variable is the district name. 
The color-coded map shows the geographic extent of the districts. A special Districts 
Browser displays the districts in tabular form.

But that is only one part of the redistricting process. The real power lies in the Districts
Browser where you can see on-the-fly updates of district record counts and data totals
when you click on a map object and assign it to another district. This allows you to 
perform visual “what if” analysis to achieve district realignments, a process 
sometimes referred to as load balancing.

When you are satisfied with the distribution, you can make the district assignments 
permanent. Later, as the need arises, you can change the assignments and try out new 
distributions.

Redistricting does not create new map objects or permanently change the style of the 
map objects. Redistricting is simply a dynamic grouping tool that displays map 
objects that share the same district information as a group. While the map objects are 
not permanently affected, you can make the district assignments permanent by saving
the table. 

You can redistrict any mappable table containing region, line, or point objects. The 
redistrict map will reflect the appropriate fill, line, or symbol style for the objects. The 
Redistricter limits the number of districts in a table to 594.
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hat Can I Use Redistricting For?
You can use redistricting in a wide variety of applications such as creating and 
managing sales territories, school or voter districts, emergency service coverage areas, 
delivery routes, natural resource management areas, etc. Use it wherever there is a 
high degree of fluctuating data and the need to try out different realignment 
scenarios.

You can use redistricting whether you need to create districts from scratch or realign 
existing districts. 

Before we get into the process, however, there are two key concepts to introduce: the 
Districts Browser and Target District.

istricts Browser
The Districts Browser is the key to the process of creating and changing districts. 
While looking like other Browsers in MI Pro, the Districts Browser is actually a 
dynamic window that allows you to make changes to the groups and recalculates 
total values on the fly. You can immediately see the results of your changes. You then 
have the option to make the changes permanent or continue to try out new district 
realignments.

The Browser window lists the districts as specified in your table, the record count for 
each district, and aggregate expression columns that contain the net total values of 
your data. You specify these columns in the Redistricting dialog when you begin the 
redistricting session.
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The Target District 
The target district is the selected record shown in the Districts Browser. One record is 
always selected as the target. In redistricting, the target district receives the map 
object(s) that you assign from another district(s). MI Pro automatically sets the target 
district to be the first district in the Browser, but you can change it to any district you 
desire by clicking on a district record’s selection box in the first column of the 
Browser. 

There are three ways to set the target district:

• Select a record from the Districts Browser.

• Select a map object in the Map window, make the Browser active, and choose 
Redistricter > Set Target District From Map. The district that owns the map 
object becomes the target district.

• Select a map object, make the Browser active, and choose the Set Target 
District from Map+ button.

The target district is identified in the Districts Browser as the selected record. The 
target district is also identified on the StatusBar in the lower left corner of the screen. 

It is very easy to select a target district in the Browser when you have a small number 
of districts. However, when you have many districts (the limit is 594), you may find it 
quicker to select a map object and choose the Set Target District From Map command 
or button. If your default setting is Most Recently Used (under Redistrict > Options), 
when you select a map object that is out of view in the Browser, MI Pro will bring the 
corresponding record up near the top of the Browser. You can then use any of the 
three methods described above to set the target district. 

To change the target district, simply select another district in the Browser or select a 
map object in a different district and choose Set Target District From Map.

There is always one (and only one) target district selected at a time. You cannot 
unselect the district by using Query > Unselect All.

When you select map objects, MI Pro temporarily assigns them to the target district 
and recalculates the totals for each district. The changes are instantly reflected in the 
Districts Browser. The object count for the target district increases as do the totals for 
the data columns to reflect the addition of the selected objects. At the same time, the 
object count and data totals for the source district decrease to reflect the removal of 
the object from that district. 
374 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 378



Chapter 18: Redistricting

M

U
sing Redistricting
In general, the redistricting process follows these steps:

1. Choose Window > New Redistrict Window. Specify your table and field 
choices in the Redistrict dialog. MI Pro displays a color-coded map and 
Districts Browser.

2. Select the target district, if necessary.
3. Select the map object(s) that you want to go into the target district.
4. Observe the changes to the data values in the Districts Browser.
5. Assign map objects to the target district.

The process is about the same whether you want to create new districts from scratch 
or make changes to a table of existing districts. The two situations are discussed 
below. 

Creating New Districts
If you do not have any established districts in your table, you can create them as you 
go during the redistricting session. You should first, however, prepare your table to 
store the new district names by adding an empty column to your table. To do so, 
choose Table > Maintenance > Table Structure. (See Table Structure in the MI Pro 
Reference for instructions.)

With that done, choose Window > New Redistrict Window. The Redistrict dialog 
displays. Choose your table from the drop-down list. Choose the district field from its 
drop-down list. The district field is the empty field you created in your table to hold 
the district names. 
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A powerful feature of redistricting is the ability to calculate net total values from the 
data in your table. Any numeric field can be aggregated by sum or percent during the 
redistricting session. The Available fields list shows you what calculations are 
possible for the given table. Choose from this list and click the Add >> button to move 
the expression to the Fields to Browse list. Only those items listed in the Fields to 
Browse list will be acted upon and displayed in the Districts Browser.

You can reorder the fields using the Up and Down buttons to list them in a certain 
order in the Browser. When you are satisfied with the choices in the dialog, click OK. 
MI Pro performs the redistricting operation. 

When processing is finished, MI Pro displays a map of your table with a single color 
and a Districts Browser with a placeholder for a district entry. This is because you told 
MI Pro to carry out the redistricting on a column with an empty field.

 

To create another district, make sure the Districts Browser is active so that the 
Redistrict menu is available on the menu bar. Choose Redistrict > Add District. The 
new district displays in the Browser with the name DistrictN, where N is the next 
higher number. Continue to add districts until you feel you have enough to begin 
reassigning objects to them. Enlarge the Browser, if necessary, to see the new district 
records.

Note: each district you add will display with a generic name DistrictN, where N is the 
next higher number. To change the names, highlight the name and type in the new 
name.

To begin building your districts, make one of them the target district. Next, select map 
objects in the Map window to add objects to the new district. Notice how the values in 
the target district increase as the object(s) are selected. 
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At this point the objects are only temporarily assigned to the district. When you have 
made all the additions to the district that you want for the moment, make the Districts 
Browser active and choose Redistrict > Assign Selected Objects to make the 

assignment permanent. (You can also choose the Assign Selected Objects  button 
from the Main toolbar.) You cannot build another district until you complete the 
current one. 

Note:  You must save the table at the end of the redistricting session to retain the 
new districts.

Continue to add and assign objects to districts until you have created as many 
districts as you need. You can now see the geographic extent of each color-coded 
district in the map window. You can also see the results of the expression calculations 
in the Browser showing the new total values for each district. 

Now you can reassign districts to more equitably distribute resources, to include or 
exclude certain information, whatever your needs call for. 

Reassigning Existing Districts
If you already have districts in your table, or have a column that contains values that 
are shared among the records, you can use those as the basis for your districts. When 
you activate the Redistricter, these values display as color-coded districts on a map. 

For example, choose a column that contains information that will make up groups of 
more than one record each, such as sales reps, ZIP Codes, area codes, states. If you 
choose a column containing unique values like customer names you will create 
districts that only contain one record each, not very useful for creating districts. 

Note: When you perform redistricting, MI Pro alters the values in whatever column 
you choose. You may want to make a copy of the column so that you retain the 
column values. In addition, do not name your tables “Districts.” MI Pro uses 
“Districts” internally as a system table when beginning a redistricting session.

Choose Window > New Redistrict Window to start the redistricting session. In the 
Redistrict dialog, specify your table and field that contains the district names. From 
the Available Fields list, choose the fields you want displayed during redistricting. 
Reorder the fields as necessary. The fields will display in the Districts Browser in the 
order specified in the Fields to Browse list. Click OK. MI Pro creates an individual 
value theme and the Districts Browser.
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Now to begin the actual redistricting, or load-balancing, set the district that you want 
to add objects to as the target district. Select the map object(s) and watch the data 
change in the Districts Browser. You can select objects from more than one district and 
assign them to the same target district. Simply shift-click each additional map object 
after the first one. 

As you choose map objects, the Browser immediately reflects the changes among the 
districts with new counts per district and new totals based on expressions you 
specified in the Redistrict dialog, such as the sum or percent of a column value. 

When you are satisfied with the reassigned objects for the target district, choose 
Redistrict > Assign Selected Objects to make the changes permanent. You can now 
choose a different target object and add other map objects to it. Continue until you are 
satisfied with the new distribution of map objects. 

Before realignment, children under 4 were 
unevenly distributed among the districts.
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edistricter Options
To control the order of districts in the Districts Browser, choose Redistrict > Options. 
The Redistricter Options dialog displays. Choose your preferred sort order from 
among: most recently used, alphabetical, or unordered. You can also choose to show 
the Browser grid lines and save the options as your default. 

As mentioned earlier, the Most Recently Used option can greatly aid you if you have 
more districts than the Districts Browser can display in a window. Whenever you 
select a map object that belongs to a district that is not currently visible in the Browser, 
MI Pro will move that record near the top of the Browser window. You can then more 
easily set the new target district or view the changes in the data fields as you carry out 
your load-balancing scenario.

Changing the display of your districts is simple. Click on the fill pattern, line style, or 
symbol in the Districts Browser that represents the district. The Region Style, Line 
Style, or Symbol Style dialog displays, where you can change the tools used to display 
the district. 

After adding the selected objects to the 
target district, the Southwest and 

Northwest districts contain about the same 
percentage of children under 4.
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To save the style changes, you must save the redistricting session as a workspace. File 
> Save Table will not save the style changes. File > Save will only save the district 
assignment changes. The styles belong to a thematic layer, not to the table itself. The 
district changes are applied to the table and, thus, can be saved to the table. 

A Word about Records with No Graphic Objects
Redistricting involves grouping map objects into districts. If you are redistricting a 
table that contains records that do not have graphic objects associated with them, keep
in mind that MI Pro includes them as well in the Districts Browser. You cannot assign 
these records to new districts. They will affect your data calculations when you move 
objects into new districts. 

If you have numerous records without graphic objects in your table, it may be best to 
create and save a subset of the table and run the Redistricter on the new table.

Saving New Districts
Once you have settled on the new districts, you must save the changes to the table 
that contains the districts using File > Save Table. This will save the objects with the 
new district name. 

If you created new districts, you can change the generic DistrictN names before 
saving the table.

Exiting the Redistricter
To end the redistricting session, close the Districts Browser window. The redistrict 
thematic layer will be removed from the Map window. Note: You must end the 
current redistricting session before beginning a new one.

Creating New Objects
Keep in mind that MI Pro’s redistricting operation does not actually create new map 
objects. If you want to combine objects in a district into a single object you must use 
Table > Combine Objects Using Column. You will be prompted to save the table first 
before proceeding with the combine. For details, see Combine Objects Using Column 
in Chapter 20, Geographic Analysis, and in the MapInfo Professional Reference.

Note:   You can only use Combine Objects Using Column for two dimensional 
objects such as regions.
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Displaying Raster Images

Raster images enable you to create detailed 
backdrops for your vector maps, which you can 
then use as reference points while you edit the  
map layer. You can bring paper maps or aerial 

photographs into MapInfo Professional® to use 
as a foundation for your MI Pro map, or bring 
in other graphic images that support your map, 
such as a logo.  Image display is even more 
robust with the addition of support for 
translucent images and the ability to adjust 
image display style on a per-layer basis.  
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What Is a Raster Image?
A raster image is a computerized picture. If you have a raster image file, you can 
overlay additional MapInfo Professional data, such as street maps and customer 
locations, on top of the image. Raster images consist of rows of tiny dots (pixels). They 
are sometimes known as bitmaps. In contrast, objects in vector images contain 
coordinate-based data structures represented by x and y coordinates (most of MI Pro’s
data is in vector format).

In MapInfo Professional, raster images are used as display layers only. They cannot 
have any data attached to them like vector map images. Raster images are particularly
well-suited for use as a backdrop for vector map layers because they provide a much 
greater level of detail than vector maps.  

Obtaining Raster Image Files
There are a number of ways you can obtain raster image files. If you have a scanner 
and scanner software, you can use the scanner to create raster image files. MapInfo 
Professional can read and display the raster image files created with the scanner 
software. 
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Some graphics software packages let you save or export images into raster file 
formats, such as TIFF (Tagged Image File Format). So if you can create a TIFF file with 
your draw or paint package, you can display it in MI Pro. 

You can also purchase raster images from MapInfo Professional or other commercial 
vendors. Some vendors also offer scanning services. 

ses for Raster Images

Bringing Images into MI Pro
Using raster image files, you can bring paper maps, photographs, and other graphic 
images into MapInfo Professional. For example, if you work with paper maps, you 
probably want to use those paper maps as the foundation for the maps you create in 
MapInfo Professional. Once you scan your paper map into a raster image file, you 
then can display it in a Map window.

As a Backdrop for MapInfo Professional Maps
Using a raster image as the base layer of your map gives you a detailed backdrop for 
your other map layers. You can easily change the size, scale, or center point of the 
displayed image. For example, if you want to enlarge part of the image, use the Zoom-
in tool. Keep in mind, however, that as you increase the image’s size, the display will 
become grainier if you exceed a 1-1 pixel ratio. Each pixel in the image becomes more 
distinct, causing the image to look more like a series of blocks instead of the intended 
picture.  

As a Stand-Alone Image
You may have a satellite image of topography that would be impossible to duplicate 
as a vector image that you want to use for a presentation. You can display the image in 
MapInfo Professional and then incorporate it into a page layout. See Chapter 21, 
Working with Layouts for information on how to copy windows into frames in a 
Layout.
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Map Editing
Once you have superimposed map layers on top of your raster image, you can use the 
raster image as a reference while you edit your map layers. The process of editing 
based on a screen image is known as heads-up digitizing. (To minimize image 
distortion, only digitize from map images with known projections or rectified aerial 
photographs.)

Placing a Logo on a Page Layout
Most raster images displayed in MapInfo Professional are images of paper maps or 
aerial photographs, but almost any image can be scanned and made into a raster 
image. For example, with an image like your company logo, you can open and 
display the raster file in MapInfo Professional without registering it because control 
point coordinates are irrelevant. You can then place it in a frame in a Layout window 
and incorporate the logo into your page layout.

What Types of Raster Images Can MapInfo Professional 
Display?

File Formats  
There are many different raster image file formats. MI Pro can read the following 
types of raster files: 

• filename.GIF (Graphics Interchange Format) 

• filename.JPG (JPEG format)

• filename.JP2 (JPEG 2000 format)

• filename.TIF (Tagged Image File Format)

• filename.PCX (ZSoft Paintbrush) 

• filename.BMP (Windows bitmap) 

• filename.TGA (Targa) 

• filename.BIL (SPOT satellite images)

• filename.SID (MrSID format)

• filename.WMF (Windows Metafile format)

• filename.EMF (Enhanced Metafile) format

• filename.PNG (Portable Network Graphics format)

• filename.PSD (Photoshop 3.0)

• filename.ECW (ECW 2.0 format handler)
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• filename.GEN (ADRG format)

• filename.GEN (ASRP format)

• filename.* (CADRG format)

• filename.* (CIB format)

• filename.NTF (NITF format)

Color Options
MapInfo Professional can read the following types of raster images: 

• Monochrome images: Each pixel in a monochrome image can be displayed 
using two colors, usually black and white. These images take up the least 
amount of space and will display the fastest. In MI Pro monochrome images 
can also display as two different shades of gray.

• Gray-scale images: Each pixel in a gray-scale image can be black, white, or a 
shade of gray. 

• Color images: Each pixel in a color image can be any color from a palette of 
available colors. The set of available colors depends in part on the image file 
format and the source of the image. An 8-bit image contains eight bits, or one 
byte, of information for each pixel; this means that the image has a palette of 
256 different colors. A 24-bit image contains twenty-four bits, or three bytes, 
of information per pixel, which means that the image has a palette of over 16 
million colors. MI Pro now supports 24-bit, True Color display, with 
transparency. 

For best results when viewing a raster image, we recommend using a high resolution 
video display. 

pening a Raster Image 
When you open a raster file, you need to know about a process called raster image 
registration. Using a vector map as a reference, you identify the coordinates of control 
points on the vector map and match them with equivalent points on the raster image. 
This coordinate information allows MI Pro to determine the position, scale and 
rotation of the image so that you can overlay vector data on top of the image. The 
coordinate information is stored in a TAB file created during the registration process. 
The TAB file enables you to re-open the raster file in MI Pro format. The registration 
process is explained in more detail in the next section. 

You usually register the image the first time you open it. However, you do not need to 
register the image if you do not plan to use vector data with it, or if it already contains 
georegistration information.  
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 Raster images usually fall into one of three categories: 

• A fully registered image, containing control points and a projection (e.g., 
GeoTIFF file).

• A partially registered image containing control points, but missing a 
projection (e.g., an image with an associated World file).

• An unregistered image missing control points and a projection.

Once the image is registered, opening it again requires a slightly different procedure. 
Opening both unregistered and registered images is explained below.

Unregistered Images 
In MapInfo Professional, you can open an unregistered raster image and display it 
directly in a Map window without manually registering the image. This is useful 
whenever accurate control point coordinates are unnecessary, such as when the image 
is not a map (e.g., a logo) or when you are using a stand-alone image.  

To open an unregistered raster image without manually registering it:
1. Choose File>Open. The Open dialog displays.
2. In the List Files of Type drop-down list, choose Raster Image.
3. Select the file you want to open, and choose Open. A dialog displays asking 

you if you want to display the unregistered image. Choose Display. The 
image displays in a Map window.

A TAB file is created for the image using non-earth coordinates. MI Pro will use 
dummy registration points to position the image. 

If you decide later that you want to use the image with a vector map, you can re-
register the image. Follow steps 1 and 2 above. Since a TAB file has already been 
created for the image, MI Pro will tell you that a table definition already exists and ask 
you if you want to overwrite it. Choose Register to proceed to the Image Registration 
dialog and register the image.

Georeferenced Raster Images 
MI Pro includes support for the direct opening of georeferenced raster images. 
Georegistration information consists of three or more control points and a projection. 
Any raster image that contains complete georegistration information can be opened 
directly in MI Pro using the File>Open command. 

If the raster handler for the image can return all the georegistration information, a 
.TAB file can automatically be created. For example, MI Pro’s tiff.rhl raster handler 
can return georegistration information for GeoTIFF files. 
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To open a georeferenced image: 
1. Choose File>Open. The Open dialog displays. 
2. In the List Files of Type drop-down list, choose Raster image.
3. Select the file you want to open, and choose Open. Your image displays in a 

Map window. 

Additional support has also been included for World files (*.tfw). World files contain 
control point information, but no projection. When you open a raster image that does 
not contain registration information, the raster engine will search for a World file 
associated with it to obtain control points for the image. MI Pro will then display the 
Choose Projection dialog, where you can specify a projection and open the image. 

If there is no registration information and no World file associated with the image, the 
Display/Register dialog displays. You can either display the unregistered image, or 
register it. As explained above, when opening unregistered images, the Display 
option creates a .TAB file for the image using a non-earth projection and dummy 
control points. The Register option displays the Image Registration dialog, where you 
register the image.   

Registered Images
You only have to register a raster image once. Once a .TAB file has been created for it, 
you can open the image like any other MI Pro table each subsequent time you open 
the file. 

The sample raster image files included with MapInfo Professional have already been 
registered (contain a TAB file). If you purchased a raster image from another source, it 
may already have a TAB file attached. You will not need to register these images 
either.

To open a registered raster image: 
1. Choose File > Open. 
2. Leave the File Format as it is (MapInfo). The registration process already 

created a MI Pro readable file (TAB file). 
3. Choose the table file (e.g. Parcels.tab) from the list in the dialog. (The TAB file 

contains the control point information supplied during the registration 
process.) 

4. Choose Open. MI Pro opens the raster image table and displays the image in a 
Map window. 
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File Search When Opening Tables
When you open a MapInfo Professional table that contains a raster or grid file, MI Pro 
searches for the file if it cannot find it immediately. For example, the search capability 
can simplify opening tables if your .TAB file refers to an image that resides on a CD-
ROM drive, and different letters are used to designate the CD-ROM drive on different 
systems.

MapInfo Professional uses the following search order:
1. Search for the file where specified by the FILE tag in the .TAB file.
2. Search for the file in the same directory as the .TAB file.
3. Search for the file in the Table Search path specified in the Directories 

preferences (Options>Preferences>Directories>Search Directories for Tables).

MI Pro either opens the table as though it found the file in the specified location, or it 
will report an error because the file could not be found in any location.

Registering a Raster Image 
If you want to overlay vector data on top of a raster image, then you must first register 
the image so that MapInfo Professional can position it properly in a Map window. You
do this in the Image Registration dialog. Here, you identify control point coordinates, 
as well as specify the projection of the raster image. 

It is very important to provide accurate control point information when registering a 
raster image. MI Pro displays raster images without distorting or rotating them. 
However, when overlaying vector data, MI Pro does distort and rotate the vector data 
so both layers can line up properly. Choose control points that can be easily identified 
and selected, such as street intersections.

Specifying the correct projection of the raster image when you register it is also 
important for accurate display. Images that do not have known projections such as 
unrectified aerial photographs are not suitable for use with vector data. 

There are two ways to register a raster image in MI Pro. Each involves specifying the 
map coordinates of control points on a reference map and matching them with 
equivalent points on the raster image. To determine map coordinates, you can:

• Identify a point’s coordinates from the paper map.

• Determine a point’s coordinates on screen and automatically transfer the 
information to the Image Registration dialog.
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Identifying Coordinates from the Paper Map 
If you scanned in the image from a paper map, the map most likely contains a 
graticule (latitude and longitude grid). You can choose the coordinates for prominent 
features and enter them in the Image Registration dialog. Follow the steps below:

1. Choose File > Open  and Raster Image file format to open the raster file. 
Choose a raster image file and choose Open. The Display/Register dialog 
displays. Select Register. The Image Registration dialog displays. A preview 
of the raster image appears in the lower half of the dialog.

2. Choose the Projection button to specify the image’s projection. It is important 
to use the proper projection for the image to minimize image distortion when 
overlaying vector map layers. You cannot change the projection from the Map 
window.

3. Click on a point in the preview image. The Add Control Point dialog appears. 
Specify the coordinates from the paper map in the dialog. The location of each 
point is marked on the preview image with a  “+” symbol. Enter at least three 
control points (more if you do not know the projection or the image does not 
have a projection, such as an aerial photograph). Click OK to display the 
raster image.

Note:   Zoom in or out on the preview image using the + and - buttons 
underneath the image. Zooming in on the image may help you obtain 
greater accuracy in control point location. 

Determining Coordinates on Screen 
To transfer the coordinates automatically, you need a vector map of the same image. 
You can display the vector map side by side with the Image Registration dialog, 
which shows a preview of the raster image. By clicking on a prominent feature in the 
vector map you can determine its coordinates. This information is then transferred to 
the dialog as a control point. Follow the steps below:

1. Choose File > Open and Raster Image file format. Choose the raster image file 
and choose Open. The Display/Register dialog displays. Select Register. The 
Image Registration dialog displays. A preview of the raster image appears in 
the lower half of the dialog.

2. Choose the Projection button to specify the image’s projection. If you do not 
set the projection, MI Pro defaults to Longitude/Latitude or to the default 
table projection set by using Options > Preferences > Map Window 
Prefernces.
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3. To begin adding control points, click on a location in the preview. The Add 
Control Point dialog displays showing the point’s location in pixels. Click 
OK. The point with no X and Y coordinates is listed in the Image Registration 
dialog. (We will specify the coordinates in a moment.)

4. Choose at least three more control points in the same way. Use the scroll bars 
to move to other areas of the image. Choose points that can be easily 
identified and selected in a Map window.
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5. Open the corresponding vector map table in a Map window. You may have to 
move the Image Registration dialog aside to access the Map window.

6. Choose Table > Raster > Select Control Points from Map. 
7. Highlight Pt. 1 in the Image Registration dialog. Click on the equivalent point 

in the Map window. The Add Control Point dialog displays showing the Map 
X and Y coordinates for the vector point location. Click OK to accept the 
coordinates. MI Pro transfers them to the Image Registration dialog.

8. Repeat step 7 for the remaining control points.
9. After all control points have been defined, click OK in the Image Registration 

dialog. The raster image will display in the Map window under the vector 
layer.
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Converting D/M/S Coordinates to Decimal Degrees
If you are entering map coordinates in degrees, you must enter decimal degrees as 
opposed to degree/minute/second (d/m/s) coordinates. For example, to specify the 
coordinates 40 degrees, 30 minutes, enter 40.5 degrees. Be sure to use negative 
numbers when specifying west longitude and south latitude coordinates.

MapInfo Professional includes the Degree Converter program in its tool set, which 
easily converts coordinates from d/m/s to decimal degrees, and vice versa. To run the 
Degree Converter, choose Tools>Tool Manager and check the Loaded box next to the 
name of the program. Degree Converter will be added to the Tools menu for your 
current session of MI Pro. To have the tool load automatically each time you open MI 
Pro, check the Autoload box. You can also use the Degree Converter to convert a 
single Latitude/Longitude coordinate to either decimal degrees or d/m/s. 

If you are registering a raster image that does not use longitude and latitude 
coordinates, specify the appropriate projection in the Image Registration dialog and 
enter your coordinates in the native units of that coordinate system. For instance, if 
you are registering a UTM map image, enter the coordinates in meters.

Registration Error Values
After you register the image, the Image Registration dialog may display an error 
value in pixels for a control point. This value is the difference between the control 
point location on the image and the X and Y coordinates you specified in the Add 
Control Point dialog. It is important to keep the error value as small as possible. A 
large error value will cause the raster image to line up improperly with the vector 
overlays. Make sure that you are as precise as possible with your control point 
choices. You should display your image using a high resolution for best results. 
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Add more control points to improve the registration. To do this, choose Table > Raster 
> Modify Image Registration. Choose the New button from the Image Registration 
dialog and choose another point. Choose the equivalent point in the Map window to 
transfer the coordinates to the registration dialog. We recommend adding points near 
the center of the raster image and in areas where the match is the poorest.

Modifying Control Points
If you must adjust the coordinates of a control point because the error is unacceptable, 
highlight the point in the Image Registration dialog and choose another location for it 
in the Map window. To delete control points, choose the Delete button. 

isplay Options
You can display more than one raster image in a window at a time. This is limited 
only by your computer’s memory. However, if you want to digitize from the raster 
image, it is best to use only one image in a Map window. This is because two raster 
images will probably have slightly different rotations. 

When using two raster images with different projections, keep in mind that MapInfo 
Professional will use the projection of the image that takes up the larger portion of the 
Map window. This means that the second image is only positioned approximately.

Adjusting Color
Once you have displayed a raster image file in a Map window, you can make 
adjustments to the colors in the image. Choose Table > Raster > Adjust Image Styles to 
change the settings for that .TAB file. Choose Map > Layer Control > Display > Style 
Override to adjust the raster style only in this Map window. The Adjust Image Styles 
dialog lets you set the contrast and brightness of the image, set translucency, display 
color raster images in shades of gray, and make one color in the image transparent. 
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Using the Adjust Image Styles dialog does not modify the raster image file; instead, it 
changes the way MapInfo Professional displays the raster image file. If you change an 
image’s display style, MapInfo Professional records the new display style in the table 
file (e.g. parcels.tab) or in the workspace for per layer styles, but MI Pro does not alter 
the contents of the raster image file (parcels.gif) in any way.

If you change an image’s display style and choose OK, the new display style is 
applied immediately. It will also affect all Map windows in which the image is 
displayed if you select Table > Raster > Adjust Image Styles. You do not need to 
choose File > Save to save the changes.

Contrast and Brightness
Adjusting a raster image’s contrast and brightness can help make your map more 
readable. When you overlay additional map layers on top of your raster image, you 
may find it hard to tell which lines are part of the raster image and which lines are 
part of the additional layers. Changing the contrast and brightness can make it easier 
to differentiate the separate layers. 

To soften the appearance of a raster image: 
1. Choose Table > Raster > Adjust Image Styles. The Adjust Image Styles dialog 

displays. 
394 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 398



Chapter 19: Displaying Raster Images

M

2. Set the Contrast scroll bar to a low setting, such as 30%. (The default Contrast 
setting is 50%.) 

3. Set the Brightness scroll bar to a high setting, such as 70%. (The default 
Brightness setting is 50%.) 

4. Examine the image preview in the lower half of the dialog. If the new display 
style suits your needs, choose OK. If you want to go back to the previous 
display style, choose Cancel. 

Changing from Color to Grayscale
It is very easy to change a color raster image to grayscale. In the Conversions group of 
the Adjust Image Styles dialog, click the Grayscale button. To change it back, click the 
Original Image button. 

Transparent Color
You can also make one color in the image transparent. Making a color transparent will 
make the parts of the map displayed under that color visible. In the Adjust Image 
Styles dialog, check the Transparent box to activate the Select Color button. Click 
Select Color. To select the color you want to be transparent, click on the color in the 
preview image. The color you selected appears in a box next to the left of the Select 
Color button. The transparent color will display as white in the preview image. When 
you redisplay the image in the Map window, the selected color will be transparent.  

Translucent Color
MapInfo Professional provides the ability to display a translucent raster image. 
Translucent images allow you to partially see through them, enabling you to lay 
translucent raster images over other layers so that details of the layers below are 
partially visible. An image set to 0% translucency is completely opaque; an image set 
to 100% translucency is completely transparent. 
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Style Override
MapInfo Professional provides the ability to change the display style for raster and 
grid images on a per-layer basis through the Layer Control dialog. The Style override 
option for raster images works the same way as it does for other map layers. Just 
choose Map>Layer Control, and select a raster layer in the Layer list. Click the 
Display button. The Display Options dialog for the image displays. Select the Style 
Override check box and click on the Style button below it. The Adjust Image Styles 
dialog displays. You can change any of the raster image style settings. 

Zoom Layering
Zoom layering for raster images  controlled from preferences ( Options > Preferences 
> Map Windows > Automatic Raster Zoom Layering). To change the zoom layering 
setting for a raster layer that you are currently working with, go to the Display 
Options dialog (Map>Layer Control > Display) and to either activate or turn off zoom
layering. The setting is turned on by default. 

Limitations
Many of MI Pro’s features cannot be applied to raster image tables. As a general rule, 
you cannot use MI Pro to modify a raster image file. Specific limitations of raster 
tables are described below. 

Data 
A raster table does not have columns, therefore, you cannot attach text or numeric 
data directly to a raster table, and you cannot perform queries, such as Find, on a 
raster table. You can, however, overlay a conventional (vector-based) MI Pro table on 
top of the raster image, and attach data to the conventional table. 

Map Projections
When a raster image file is displayed in a Map window, the Map window 
automatically adopts the map projection used by the raster image. You cannot reset 
the projection of the Map window.  

If two raster images in a Map window use different map projections, MI Pro will use 
the projection of the map that takes up the larger portion of the Map window. 
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The Map window will redraw slowly when you overlay other map layers on top of a 
raster image. The map redraws slowly because MI Pro is re-calculating map 
coordinates so that the vector map objects conform to the projection of the raster 
image.

Printing/Exporting Translucent Images
When printing or exporting a translucent raster image, you’ll want to take advantage 
of Advanced options.

Choose File > Print or File>Save Window As and click on Advanced:

Print/Export Border

Select to include the black rectangle border when exporting.

Internal Handling for Transparent Vector Fills and Symbols

Select to allow MI Pro to perform special handling when exporting transparent fill 
patterns or transparent bitmap symbols. If unchecked, the process is handled by 
Windows.

Use ROP Method to Display Transparent Raster

Use this option if the output format is a metafile (EMF or WMF). Using the ROP 
method allows any underlying data to be rendered in the original form.  For example, 
vector data that is under transparent pixels will not be rasterized.  In metafiles, using 
ROP method will not draw any data in the areas of the raster pixels, allowing the 
background to be truly transparent.

Print/Export Raster In True Color When Possible

Use 24-bit true color to print raster and grid images.  This is possible when the image 
is 24 bit and the printer supports more than 256 colors.

Dither Method

Choose when it is necessary to convert a 24 image to 256 colors, use either halftone or 
error diffusion. This option is used when printing raster and grid images. Dithering 
occurs if "Print Raster In True Color When Possible" is disabled or if the printer color 
depth is 256 colors or less.

In the MI Pro advanced printing options the, "Print Directly to Device" option does 
not work correctly for translucent images. Select "Print Using EMF Method" instead.

Storage
Each raster table can contain only one raster image file. You cannot add rows to a 
raster table, and you cannot append additional raster image files to the table. 
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Geographic Analysis

Much of the reason you use MapInfo 

Professional® is to perform geographic analyses 
on your data. This chapter takes a look at some 
sophisticated analysis features and tools that 
allow you to edit objects and their data, create 
buffer zones to isolate the area you want, and 
combine objects to create new regions.
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Set Target Editing Model
With MI Pro’s advanced editing functionality, you can now combine, split, erase map 
objects, and overlay nodes using a “Set Target–Apply Action” editing model. This 
model allows you to use objects from the same table or another table to create new 
objects. Sophisticated data aggregation methods allow you to calculate new data 
values that match the new objects. 

 

The Set Target editing model in MI Pro allows you to set a map object as the target for 
editing, then create a modifying object that will act as the cookie cutter that overlays 
the target and performs the editing action on the target. Set Target is located under the
Objects menu. 

The Set Target model for editing map objects can be broadly described as a three-step 
process:

1. Set the object you want to edit as the target.
2. Choose and select another object or objects to act as the modifying object for 

the editing operation.
3. Perform the edit operation (combine, split, erase, erase outside, or overlay 

nodes).

Buffered retail locations showing market penetration
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A new object (or objects) is created in place of the target object.

The following table describes valid cutter/target objects for supported object 
processing operations:

You are not limited to working with map objects in the same layer. While the target 
objects must be in the Editable layer, you can choose the modifying objects from 
another layer. 

The set target process is essentially the same whether you want to combine objects 
together or create more objects by splitting objects or erasing portions of objects. Each 
operation is discussed individually later in this chapter.

In addition to creating new map objects, the Set Target model allows you to control 
how the data associated with the target object will be transferred to the new object or 
objects. The next section discusses a number of data aggregation and disaggregation 
methods that give you tremendous flexibility with editing map objects. 

Object Type Overlay Nodes Split, Erase, 
Erase Outside Combine

Cutter Target Cutter Target Target
Other 
non-

target

Closed X X X X X X

Linear X X X X X

Text

Points X X X

Multipoints X X X

Collections X X X
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Aggregating and Disaggregating Data
If you have data attached to map objects that will be edited, you can proportion the 
data for each field to match the new object(s). This is called data aggregation or 
disaggregation, depending on whether you are combining or splitting objects. MI Pro 
calculates new data values for the object depending on how you specify the 
aggregation or disaggregation.

When combining objects, you can choose from several methods of data aggregation, 
including:

• Sum – adds the field values from the original objects to create a total for the 
field in the new object.

• Average – averages the field values from the original objects.

• Weighted average – gives more weight to one value over another when 
averaging. You can choose a numeric field in your table as the weighting 
factor or choose area (where the weighted average is based on the relative 
geographic area of the regions to be combined).

• Value – stores a specific value in the field of the new object.

• No change – maintains the value of the target object in the new object.

When splitting or erasing portions of a map object, you can choose from:

• Blank – removes the original value of the target object.

• Value – maintains the original value of the target object.

• Area proportion – removes a portion of the original value based on the size of 
the new object.

With any of the editing operations under Set Target, you can elect not to bring over 
any data at all by choosing the No Data checkbox. For instance, you are only editing 
map objects for presentation purposes and do not need any data associated with the 
objects.

The data aggregation (or disaggregation) dialog displays after you have set the target,
chosen the modifying object, and chosen an editing operation. You must specify how 
you want the data calculated for each field. Once you are satisfied with the 
aggregation method, you can carry out the editing operation. 
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C
ombining Objects with Set Target 
Combine allows you to combine separate map objects into a single object. By using 
Combine with Set Target, you can use objects from another layer as the modifying 
object for editing. It is also useful when one object is more important than the others 
you are combining it with, for instance, when adding islands to a mainland region. 
Using Combine with Set Target allows the mainland region to retain its name after the 
objects are combined.

You can only set one object as the target at a time when using Combine with Set 
Target. The modifying object can consist of more than one object. 

To combine map objects using Set Target:
1. Select one object in an Editable layer to be the target object.
2. Choose Objects > Set Target. The object displays in a different style to indicate 

that it is the target object.
3. Select (or create and select) one or more map objects from any layer in the 

Map window. This is the modifying object.
4. Choose Objects > Combine. The Data Aggregation dialog displays.
5. Choose the appropriate aggregation method (or No Data) for each field in the 

Destination list. Shift-click to apply the same method to consecutive fields or 
control-click for non-consecutive fields. When you have chosen the 
aggregation methods, click OK. 
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MI Pro will compute the new object and display it as a single object. Use the Info tool 
to view the aggregated data (if any) associated with the object.

Keep in mind that the Objects Combine command works with selected map objects. 
To apply the combine operation to an entire table, use Query > Select All. To combine 
into groups rather than objects, or output to a separate table, use Combine Objects 
Using Column, (Table menu), which is explained at the end of this chapter. 
404 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 407



Chapter 20: Geographic Analysis

M

S
plitting Objects

Splitting Objects allows you to divide the target object into smaller objects, using 
another object as a cutter. 

For instance, use Split to separate a large territory into smaller units. 

To split map objects using Set Target:
1. Select the object(s) in an Editable layer to be the target.
2. Choose Objects > Set Target. The object(s) displays in a different style to 

indicate that it is the target object.
3. Select (or create and select) one or more map objects from any layer in the 

Map window to be the cutter object. The object must be a closed object.
4. Choose Objects > Split. The Data Disaggregation dialog displays.
5. Choose the appropriate disaggregation method (or No Data) for each field in 

the Destination list. Shift-click to apply the same method to consecutive fields 
or control-click for non-consecutive fields. Click OK. 

MapInfo Professional will compute the new objects and display them. Use the Info 
tool to view the disaggregated data (if any) of the split objects. 
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Splitting Map Objects Using a PolyLine 
You can split points, multipoints, and collections, as well as closed objects (regions, 
ellipses, rectangles, and rounded rectangles), and linear objects (polylines, lines and 
arcs) using the Polyline Split command.

As mentioned previously, splitting objects requires that the cutter be a closed object. 
With Split Using Polyline, the polyline cutter will first be transformed into a regioin 
suitable for the cutter operation. The region created will be displayed for acceptance.  
The polyline(s) used as the cutter must be contiguous and non-branching. In general, 
if the cutter polylines were to be combined, the result would be a one single section 
polyline.  If the cutters are not polylines, and are not contiguous and non-branching, 
then an error will occur, and the operation will be cancelled.

You cannot use Polyline Split on text objects or to cut objects that are not in editable 
layers. To split a map object:  

1. Make the Target Table editable from Map > Layer Control,  or by picking the 
editable layer in the Editing box in the bottom tray.

2. Select the object(s) to be used as targets for editing using the selection tools or 
by using Query > Select or Query > SQL Select.

3.  Set the objects as targets by choosing Objects > Set Target, or by using the 
MapBasic Set Target On statement.

4. Create the cutting object(s) (or use objects from the same or different layer).  
The cutter object(s) must be contiguous, non-branching polylines.

5. Select the cutting object.
6. Choose Objects > Polyline Split. 
7. A region object is created from the polyline to be used as the cutter object. A 

dialog displays prompting you to, "Split marked target using selected region 
cutter?" 

Note:  Only objects that intersect the original polyline will remain as targets.    
Some objects may be removed from the list of target objects.

Select Cancel to remove the region and cancel the operation.

8. Choose Next to display the Data Disaggregation dialog. The Data 
Disaggregation splits the data associated with a map object into smaller parts 
to match the new map objects. For example, you may want to split a state into 
regions and have the data previously associated with the entrie state 
proportioned for each new region. Complete the Data Diaggregation dialog.

9. Click OK.  The target object(s) will now be split into smaller map objects.  

After splitting the target object(s), MapInfo Professional deletes the original target 
from the table. The new objects are appended to the end of the table. 
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E
rasing Objects
You have two choices in the Objects menu when you want to remove some portion of 
the target map object. Use Objects > Erase to erase the portion of the target object that 
is overlapped by the cutter object. Use Objects > Erase Outside to remove the portion 
of the target object that is not overlapped by the cutter object.

For example, to add a lake to a region, create the lake as the cutter, position it 
appropriately and use the Erase command to remove that portion of the target object 
under the lake.

Both the Erase and Erase Outside commands support point, multipoint, and 
collection objects. 

To erase map objects using Set Target:
1. Select the object(s) in an Editable layer to be the target.
2. Choose Objects > Set Target. The object(s) displays in a different style to 

indicate that it is the target object.
3. Select (or create and select) one or more map objects from any layer in the 

Map window to be the cutter object. The object must be a closed object.
4. Choose Objects > Erase (or Erase Outside). The Data Disaggregation dialog 

displays.
5. Choose the appropriate disaggregation method (or No Data) for each field in 

the Destination list. Shift-click to apply the same method to consecutive fields 
or control-click for non-consecutive fields. Click OK.
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MapInfo Professional will compute the new object and display it. Use the Info tool to 
view the disaggregated data (if any) of the split objects. 

Overlaying Nodes
Overlay Nodes allows you to add nodes to the target objects at the points where the 
target intersects the cutter object. 

For instance, when adding streets to a map that cross existing streets at intersections, 
use the Overlay Nodes command on the new street to add nodes that exactly overlay 
the nodes from the existing street.

To overlay nodes with Set Target:
1. Select the object(s) in an Editable layer as the target. This is the object to which

you want to add nodes. The objects may be closed or linear objects.
2. Choose Objects > Set Target. The object(s) displays in a different style to 

indicate that it is the target object.
3. Select as the modifying object one or more map objects that intersects the 

target from any layer in the Map window. The cutter object may be closed or 
linear objects.

4. Choose Objects > Overlay Nodes. 

MapInfo Professional adds the intersecting nodes to the target object(s). 

Note:  No data aggregation or disaggregation is performed with Overlay Nodes. 
The data after the operation remains unchanged. 

End result of Set Target - Erase. 
Circular object is removed.

End result of Set Target - Erase Outside. All 
but circular object is removed.
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C
reating Territories by Combining Objects
Creating territories is one of the most common tasks performed with MapInfo 
Professional. Most people create territories by combining two or more smaller regions 
to create a larger one. Police departments combine ZIP Code boundaries to create 
precinct boundaries. Sales managers combine county boundaries or state boundaries 
to create sales territories. Political analysts combine census tract boundaries to create 
voting districts.

Remember, when you are combining regions, you are also combining the data 
associated with the regions. If you combine regions without somehow aggregating 
the data associated with the regions, that data will be lost. For some applications, you 
might not want to save your data. For example, you are merging census tract 
boundaries to create school districts. The census tract data is of no interest to you; you 
merely want the boundaries. There is no reason to aggregate the data.

However, for most tasks, you’ll want to save the data associated with the regions. For 
example, you have a layer of states. You want to combine the state boundaries to 
create sales territories. Each state record includes a field, TOT_SALES, that contains 
the total sales for the previous year. You would ultimately like to sum up the 
TOT_SALES field for each state in a given sales territory.

MapInfo Professional gives you two methods for combining regions. The first 
method, Combine, works with objects that are selected. The second method, Combine 
Objects Using Column, is used to combine objects into groups based on a specified 
column. 

Combining Selected Objects
When you choose Objects > Combine, MapInfo Professional performs two operations:

• MI Pro geographically combines the selected objects. The new object 
represents the geographical union of the original objects. Thus, if you select 
two adjacent region objects and choose Combine, MI Pro combines the 
regions into a single object, and the border between the regions disappears.

• MI Pro performs data aggregation. As described earlier in this chapter, data 
aggregation is a process where MI Pro calculates what the column values for 
the new object should be, based on sums or averages of the original objects.

Your setup of the Layer Control dialog depends on whether you want to copy the 
result object to another layer (and, thus, save the original objects) or combine the 
objects in the original layer (and, thus, lose the original objects).
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If you want to copy the result object, make the region’s layer Selectable and another 
layer Editable. Specify a target object, then select the objects using any selection 
method and choose Objects > Combine. This will display the Data Aggregation dialog 
where you tell MI Pro how to combine the data. Fill in this dialog and click OK to 
combine the objects to combine the objects’ data. This method was discussed earlier in 
this chapter. 

 If you want to combine objects in the original layer, make sure that the layer is 
editable, select the objects in the layer, and choose Objects>Combine. Do not set a 
target. The data Aggregation dialog displays. After the operation is complete, a new 
object will be added to the layer, and the original objects will be deleted. 

Combining Objects Using Column
Combine Objects Using Column allows you to modify geographic data to create new 
map objects that contain data about the group. This feature is similar to redistricting 
in that it groups objects together, but goes beyond redistricting to combine a copy of 
the relevant objects while leaving the original objects untouched. To access Combine 
Objects Using Column, choose Table > Combine Objects Using Column. 

For example, you have a layer of states. You want to combine the state boundaries to 
create sales territories. The data record associated with each state looks like this:

• SALES_REP: Sales representative assigned to that state

• CUSTOMERS: Number of customers per state

• AVG_SALES: Average spent per customer

You would like to aggregate the data in the following manner:

• SALES_REP: Combine all records that list Benita as the sales representative

• CUSTOMERS Sum up the number of customers in the sales territory

• AVG_SALES: Average the amount spent per customer in the sales territory

SALES_REP STATE CUSTOMERS AVG_SALES

Benita West Virginia 1782 24231.4

Benita Ohio 121 33265.0
410 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 413



Chapter 20: Geographic Analysis

M

When performing a Combine Objects Using Column operation, you must specify 
which column contains the grouping information. In the preceding example, the 
grouping information is located in the SALES_REP column. We want to combine all of 
Benita’s individual territories into one large territory. By choosing the SALES_REP 
column from the Group Objects By Column popup, MI Pro combines all records that 
have common data in the column. In other words, MI Pro combines all records that 
have the same sales representative. 

You will need to specify the table and the grouping column. If you choose <New> 
from the Store results in table  drop-down list to create a new table for the combined 
objects you will be prompted with a series of dialogs to create a new table. Refer to the 
New Table command in the MapInfo Professional Reference for more information.  If 
you specified an existing table, you need to tell MI Pro how to combine the data. To 
aggregate your data, press the Next button to display the Data Aggregation dialog 
box.
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Once you have completed both dialogs, press OK. MI Pro combines the records based 
on the column specified in the Group Objects By Column drop-down list. MI Pro also 
aggregates the data and combines any objects associated with the records. For more 
information on aggregating data, see Combine Objects Using Column in the MapInfo 
Professional Reference. 

Creating a Voronoi Polygon
The Voronoi polygon is a partition of space into cells.  Voronoi takes points as input 
and produces regions (cells) as output where each cell contains exactly one point. 
Each cell is an area in which the contained points are closer to the enclosed site than to
any others.  Use Voronoi to generate these polygons from a designated set of points. It
is useful for dividing areas of responsibilities for field offices or possibly postal zones. 
It utlimately gives you the areas that are closest to your point of interest.  You can 
create a Voronoi polygon within the same layer, or select points from one layer and 
place the Voronoi polygon in another layer.

To create a Voronoi polygon:
1. Make a selection containing at least three points.  The Voronoi polygon is 

constrained by the bounding box of the selected points.  If a target region is 
specified, this region is used to constrain the polygon.

2. Choose Objects > Voronoi.  The Voronoi Field Values dialog displays.
3. Select a column name(s) from the list in the upper half of the dialog.  Click on 

a column name to select a single column.  Shift-click to select a group of 
column names. Use control-click to de-select a column.

4. Click the Data Fields No Change radio button to leave the selected columns 
unchanged.  

5. Click the Value radio button to enter an appropriate value which will be 
stored in the new row. 

6. Check the No Data box to show blank values in the table of the newly created 
regions.
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The following is a sample of a Voronoi polygon used in northern Africa:  

ultipoint and Collection Objects
The Multipoint and Collection object types allow you to group multiple objects into a 
single object. One way to create multipoints and collections is by using the Combine 
command (Objects>Combine). These new object types aid in the translation and live 
access of other GIS data formats, such as ArcView Shape Files, and are more 
compatible with GIS standards. 

A Multipoint object consists of a number of points that have been grouped into a 
single object. The Multipoint object displays in a Browser window as a single record, 
and all the points within the object have the same symbol. One method you can use to 
create a multipoint object is to select a group of point objects and combine them.

A Collection object consists of multipoint objects, zero or one polyline objects, and 
zero or one region objects that have been grouped into a single object.

MI Pro automatically converts homogeneous Collection objects to a more specific 
type, e.g., a Collection object that contains only polylines is automatically converted to 
a multi-polyline object.

To create a Multipoint or Collection object using Combine: 
1. Make the layer that you are going to select from editable if it is not already. 
2. Select the objects you want to combine. 
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3. Choose Objects>Combine. The Data Aggregation dialog displays. 

4. Select the column(s) that you want to use in the aggregation and an 
aggregation method. 

5. Click OK. The objects are combined into a single object.  

Any point obejcts selected are combined to form a multipoint object. Any 
polyline objects selected are combined to form a  a new region object. The 
resulting multipoint (if one exists), polyline (if one exists) and region (if one 
exists) are grouped together to form a new collection object. See Combining 
Objects with New Object Types.

For an existing multipoint or collection object, you may need to change its styles or 
view the bounds information. To do so, either double-click on the object, or right-click 
on the object to display the shortcut menu and choose Get Info. The Object Info dialog 
for the selected object displays. If the object is not editable, the controls in the Object 
Info dialog are read only. 

In multipoint objects, you can change the style of the symbol that represents the 
multipoint. Click the Style button to display the Symbol Style dialog.
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In a collection object, you can change the styles of the different object types in your 
collection. Click on the corresponding Style button for each object type you want to 
change. 
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Combining Objects with Multipoint and Collection Objects 
The Combine command has been enhanced to make use of the Multipoint and 
Collection object types introduced in MapInfo Professional 6.5. Points, Multipoints, 
and Collections can now be used as input objects in a Combine operation. Previously, 
both objects had to be either linear objects (lines, polylines, or arcs) and produce 
polylines as output; or both input objects had to be closed (regions, rectangles, 
rounded rectangles, or ellipses) and produce regions as output. 

In addition, heterogeneous combines are now possible using any combination of 
input objects, including Multipoints and Collections. 

Note:  Text objects cannot be used as input in a Combine operation. 

The result of such a Combine is a Collection object. 

Multipoint Objects
If you are combining point or Multipoint objects, the Combine operation produces a 
single Multipoint object comprising all input points. 

Combining points is similar to other Combine operations in that the symbol style of 
the resulting object is the same as that of the first object to be combined. This object is 
normally the first object, in row order, of the table being combined. 
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Collection Objects
The result of a Combine operation that uses heterogeneous object types as input is a 
Collection object. The input objects of a Collection object can be a mix of any of the 
following:

• Point or multipoint objects (zero-dimensional)

• Linear objects – lines, polylines, and arcs (one-dimensional)

• Closed objects – regions, rectangles, rounded rectangles, and ellipses (two-
dimensional)

• Collection objects

Heterogeneous Combine operations take place in stages. First, all objects of the same 
dimension are combined separately. The Combine operations are done in the 
following manner:

• All point and Multipoint objects, as well as the Multipoint component of any 
Collection object, in the input are combined into a new Multipoint object. 

• All line, polyline, and arc objects, as well as the polyline component of any 
Collection objects, in the input are combined into a new polyline object.

• All regions, rectangles, rounded rectangles, and ellipses, as well as the region 
component of any Collection objects, in the input are combined into a new 
region object. 

Note:  As in other Combine operations that involve rounded rectangles, all 
rounded rectangles are treated as rectangles. 

The resulting Multipoint, polyline, and/or region objects are then assembled into a 
new Collection object. 

The styles for the new Collection object are derived from the styles of the separate 
Combine operations. These styles are assigned according to the style of the first object, 
in row order, of the table being combined. Keep in mind that the row order of an 
object may have nothing to do with the order in which you selected the objects for the 
Collection. 

For example, the style of a Multipoint component of a Collection object is the style of 
the first point, Multipoint, or Multipoint component of a Collection encountered in 
the input, in row order. The style of a polyline component of a Collection object is the 
style of the first linear object or polyline component of a Collection encountered in the 
input, in row order. The style of a region component of a Collection object is the style 
of the first closed object or the region component of a Collection encountered in the 
input, in row order. 
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Object Processing and Manipulation
The operations in this section do not make use of a target object to perform analysis or 
data aggregation. These tasks use selections as input to create new objects so that you 
can perform further mapping operations on those objects. The output is placed in the 
editable layer. The original input objects remain unchanged. 

Enclosing Objects
The Enclose command enables you take polyline objects and create regions from the 
polygonal areas formed by the intersecting polylines. You can form a new region 
network anyplace where the polylines form an enclosed area. For example, you could 
create regions from a road network, where the regions would be the parcels of land 
between the roads. 

You can also use the Enclose command with region objects. 

This command is modeled after the Combine command, but has two important 
differences: 

• Combine always produces one object, while Enclose may produce many 
objects. 

• No data aggregation is performed with the Enclose command. 

To use the Enclose command, your Map window must be active, it must contain an 
editable layer, and objects in the editable layer must be selected. Below is a highway 
map of the greater New York City metropolitan area. A number of the highways have
been selected. 
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To form regions from the selected polylines: 
1. In the active Map window, make the layer you want to select from editable. 
2. Select the objects you want to enclose. 
3. Choose Objects>Enclose. The Create Region Objects from Enclosed Areas 

dialog displays. 
4. To ignore region objects in the operation, leave the box checked. To include 

region objects, clear the box. If regions are to be used as input objects, they are 
automatically converted to polylines for the Enclose operation. 

5. Your map displays. The newly formed polygons are selected. 
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Enclose preserves the original objects. The selected objects are used as the input 
objects, and the results of the operation are placed in the current editable layer in the 
active Map window. 

When you include regions and other closed objects in the Enclose command (regions, 
rectangles, rounded rectangles, and ellipses), the input regions are considered 
polylines for the purposes of this operation. The regions are converted to polyline 
objects, and then the Enclose operation is performed. It is the same as if you were to 
first convert any closed objects to polyline objects, and then perform the Enclose 
operation. 

If your selection contains objects that are not linear and are not closed (e.g., points, 
multipoints, collections or text objects), you will get an error. If the selection contains 
closed objects, and the Ignore Region Objects box is checked, then these closed objects 
will be ignored.  
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Checking Regions
You can check region maps for possibly incorrect data with the Check Regions 
command. Check Regions detects errors in your data that may produce problems or 
incorrect results when various operations are performed.

Check Regions acts on the currently selected objects. The objects must reside in one 
layer, and they must all be closed objects. Results are placed in the current editable 
layer in the active Map window. No data aggregation or disaggregation is performed 
and no data is associated with the objects created. 

The Self-Intersection Detection option enables you to check your regions for self 
intersections. When you use this option, Check Regions creates a point at the location 
where the data may be incorrect. To change the symbol used to indicate self 
intersections, click the Style button in the Self-Intersection Detection group to display 
the Symbol Style dialog, You can make the desired changes here. 

The Overlap Detection option checks the data for places where regions overlap each 
other. When you use this option, Check Regions creates regions that represent any 
areas of overlap. To change the fill of the overlap regions, click the Style button in the 
Overlap Detection group to display the Region Style dialog. You can make the desired 
changes here. 

The Gap Detection option checks the data for places where region boundaries do not 
line up, causing a space or gap between regions. Some gaps in boundary data may be 
naturally occuring, such as a lake. Generally, gaps that are errors are caused by 
misaligned boundaries, and are generally small. A maximon gap area must be entered 
for gap detection. Gaps larger than this area are ignored and not flagged. This should 
help differentiate natural gaps, such as lakes, from misalignment errors. To change the 
fill of the gap regions, click the Style button in Gap Detection group to display the 
Region Style dialog.

To use the Check Regions command:
1. Make sure your Map window is active and that you have an editable layer. 
2. Select the region object(s) that you want to check. 
3. Choose Objects>Check Regions. The Check Region Objects dialog displays. 
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4. To check for self-intersections, check the Detect Self-Intersection box. The 
symbol style button will be available. The check box is set by default.

5. To check for region overlaps, check the Detect Overlays box. The Style button 
for Overlap Detection becomes available. The check box is cleared by default. 

6. To check for gaps, check the Detect Gaps box. The Region Style button, the 
Maximum Gap Area, and the Area Units will become active. The check box is 
cleared by default.

7. Click the Symbol Style button to change the symbol style used to indicate the 
location style of the self intersections. 

If you specified Overlap Detection, click the Region Style button to change the 
fill pattern for the regions that represent the areas of overlap. 

8. Click OK. Your map redraws, and the self intersections, overlapping regions 
and gaps, if specified, are displayed. If you specified Gap Dection, check the 
Region Style button in the Gap Detection group to change the fill pattern and 
color used to represent gaps.

The settings are retained per session and per layer. When you close MI Pro and reopen 
the program, the Overlap Detection check box is reset to the default. If you select 
another layer, Overlap Detection is also reset to the default (not selected). This per-
session and per-layer scheme is also used in other operations such as Buffer and 
Convex Hull. 

Note:   Check Regions does not correct your data; it only shows the location of the 
incorrect data. 
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Cleaning Objects
The Clean command available from the Objects menu enables you to remove any self-
intersections in your region data and optionally alter region data to remove overlaps 
and/or gaps. Clean is available whenever there are objects selected, and the table that 
the objects are in is editable. 

Note:  All of the objects selected must be closed objects (e.g., regions, rectangles, 
rounded rectangles or ellipses).

To use the Clean command: 
1. Open any Map window that includes a region layer.
2. Make the region layer editable if it is not already (Map>Layer Control).
3. Select the objects that you want to clean. Ideally, all the objects in the table 

would be selected. 
4. Choose Objects>Clean. The Clean Objects dialog displays. 

5. Select the Enable Overlap Removal check box to remove any overlapping 
areas. The area of overlap will be retained in the region that has the largest 
area; the overlap will be removed from any other overlapping regions. 

6. Select the Enable Gap Removal check box to remove any gaps between 
regions, where the area of the gap is less than the area provided. The area of 
the gap will be added to the region with the largest area that touches the gap. 
Specify a maximum gap area and the area units you want to use. 

7. Click OK. 
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There are several things you should be aware of when using the Clean command. 
Although Clean works on a selection of objects, it is designed to be used on an entire 
table at once. If clean is used on a selection, rather than on the whole table, problems 
can occur. For example, if not all the objects are included in the Clean operation, some 
of the object intersections can be missed, and data problems can remain. 

In addition, Clean could introduce new overlaps and gaps if not all of the objects in 
the table are used as input. The Clean operation places new nodes at the point of each 
intersection it encounters. The presence of these nodes can slightly change the size 
and shape of objects, although you would have to be zoomed in very close to the site 
of the new nodes to notice it. These slight alterations have the potential to create small 
gaps and overlaps in what were previously common boundaries with other objects 
not included in the Clean operation.

Clean also removes the overlap when one object is completely inside another, 
however, if one object is completely inside another object, the object which is inside 
(often smaller than the containing object) remains, while a hole is punched in the 
containing object.  The result does not contain any overlaps. 
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Snapping Nodes and Thinning Objects
The Snap/Thin command enables you to set snap tolerances for nodes in different 
objects, and node and polygon thinning settings for your data. Snap/Thin also 
removes any self-intersections and overlaps in region data. 

The Snap/Thin command has three main functions:

• The Inter-Object Node Snap – Snaps nodes from different objects together. 

• The Node Thinning/Generalization – Removes nodes from objects while 
retaining their shape. When you thin region objects, shared boundaries are 
retained. 

• Polygon Area Thinning – Removes small polygons from selection.

Snap/Thin is available whenever objects are selected in an editable table. The selected 
objects must either be all closed objects or all linear objects. Snap/Thin cannot be used 
on a selection that contains a mix of closed and linear objects. 

Inter-Object Node Snap
In addition to snapping nodes of different objects together, Inter-Object Node Snap 
enables you to eliminate small overlaps and gaps in region objects as well as connect 
polyline objects that are close, but do not touch each other. 

The End Node tolerance setting is the tolerance value for the end nodes of a polyline. 
If there is another node in the same object or a different object that is within the 
specified tolerance of an end node of a polyline, one or both of these nodes will be 
snapped together so that they occupy the same point. The Internal Node tolerance is 
used for all other non-end point nodes of a polyline. 
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For polylines, the End Node tolerance must be greater than or equal to the Internal 
Node tolerance. You will receive a warning message if they are not. In many instances, 
the End Node and Internal Node tolerances should be set to the same value, although 
they can be set separately. 

For regions, the designation of end nodes and internal nodes is irrelevant, since the 
nodes of regions form closed loops. Therefore, when you specify tolerance settings for 
regions, the End Nodes Tolerance box is unavailable. The only tolerance value you 
specify is the Internal Node Tolerance. This value is used for all nodes in region 
objects. 

Specify the unit of measurement for the snap tolerance in the Tolerance Units drop-
down list. 

Node Thinning and Generalization
In node thinning and generalization, nodes are removed using a 3-Node Co-linear 
Deviation value. This value is determined by connecting three nodes to form a 
triangle and measuring the perpendicular distance between the second node and the 
line segment connecting the first and third nodes. If this distance is less than or equal 
to the 3-Node Co-linear Deviation distance, the three points are considered co-linear 
and the middle (second) point is removed from the object. 
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The Node Separation tolerance is used to thin nodes within an object that are close 
together. If two successive nodes in an object are closer than the Distance tolerance, 
then one of the nodes is removed from the object. Set the unit of measurement for the 
Thinning/Generalization values in the Distance Units drop-down list. 

Polygon Area Thinning
In polygon area thinning, polygons that are smaller in area than the Minimum Area 
value will automatically be removed. The polygon can be part of a multi-polygon 
region, in which case only that polygon is removed from the region, and the rest of the 
polygons in the region are retained. Set the unit of measurement polygon thinning in 
the Area Units drop-down list.

To use Snap/Thin:
1. Open a Map window containing the layer whose objects you want to work 

with.
2. Make sure the layer is editable (Map>Layer Control). 
3. Select the objects you want to manipulate. 
4. Choose Objects>Snap/Thin. The Set Values for Snap & Thinning dialog 

displays. 

5. Specify the Inter-Object Node Snap settings. Select the Enable Node Snap 
check box to activate the settings. 

6. Specify the End Node, Internal Node, and the Tolerance units.
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7. Specify the Node Thinning/Generalization settings. Select the Enable Node 
Thinning/Generalization check box to activate the settings. 

8. Specify the 3-Node Co-linear Deviation, Node Separation, and Distance Units 
values.

9. Specify the Polygon Area Thinning settings. Select the Polygon Area 
Thinning check box to activate the settings. 

10. Specify the Minimum Area and Area Units for the polygons to be removed. 

Note:  Distance measurements for all three Snap/Thin operations are calculated 
using the Cartesian method. Tables that are in a Latitude/Longitude 
coordinate system will not measure these tolerances accurately.

Snap/Thin will clean bad data (self-intersections and overlaps), even if no Snap or 
Thin values are used. It uses a related, but not identical, mechanism as is used in 
Objects>Clean command, and thus may produce similar, but different, results than 
can be obtained using Objects>Clean. For example, overlapping polygons will have 
the overlap removed, but which region retains the overlap, and which region it is 
removed from will often be different from Objects>Clean, and is generally not easily 
determined before the operation.  

Disaggregating Selected Objects
The Disaggregation feature disaggregates selected objects into their component parts. 

You can use Collections as input, ignoring all other objects, to produce a region object, 
a polyline object, and a multipoint object, if each exists in the Collection. As many as 
three new objects will be created from disaggregating the Collection. 

You can also break any multi-part object into its components: 

• Regions produce new region objects with one polygon per object. Optionally, 
holes (interior boundaries) of the original object can be retained as a hole in 
the result object. Otherwise, a hole will produce a separate, single (solid) 
polygon region.

• Polylines produce new Polyline objects with one single segment polyline per 
object.

• Multipoint objects produce Point objects, with one new Point object produced 
for each node in the Multipoint.

• Collections will be recursively broken up. If a Collection contains a region, 
then that region will be broken up into multiple region objects as noted above. 
If the Collection contains a polyline, then it will be broken up into multiple 
polyline objects as noted above. If the Collection contains a Multipoint, then it 
will be broken up into point objects as noted above.
428 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 431



Chapter 20: Geographic Analysis

M

All other object types, including Points, Lines, Arcs, Rectangles, Rounded Rectangles, 
and Ellipses, will remain unchanged.

To disaggregate objects:
1. Select the objects you want to disaggregate. 
2. Choose Objects>Disaggregate. The Disaggregate Objects dialog displays. 
3. Choose one of the following: 

Select the All Objects button to break up a multi-part object into its 
component parts.

Select the Collections Only button to break up Collection objects. 

4. If you selected All Objects, check the Retain Holes in Region box to retain 
holes in the output objects. If you do not select the check box, a series of single 
polygon region objects will be produced, one object for each polygon in the 
original object. Holes, or interior boundaries, will produce solid polygon 
regions. No output region object will contain any holes. 

5. Choose Next. The Data Disaggregation dialog displays. 
6. Select the No Data check box to prevent columns from the input table being 

carried to the output table. 
7. Select a Disaggregation method: Value, Blank, or Area Proportion. 
8. Click OK.   

Buffering
You would like to search for all underground cable wires that are buried within 440 
yards of Interstate 90. Or, you would like to contact all families with pre-school age 
children who live within five miles of a proposed school district. You know that you 
can search within regions for objects. But how do you create regions that fit the above 
descriptions? You create buffers.

Creating Buffers
A buffer is a region that surrounds a line object, another region, symbol, or any other 
object in a Map window. For example, you can create a buffer region that surrounds 
Interstate 90 by 440 yards on either side. You can create a buffer region that surrounds 
the proposed school district by five miles on all borders. Both the 440 yards and five 
miles are their respective regions’ buffer radii. The table of buffers is then joined to 
data associated with the original objects buffered.
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To create a buffer, make the layer editable, and select the object or objects on which 
you will base your buffer region. Choose  Objects > Buffer. To create a buffer:

• Specify a buffer radius: either a constant value, a data field from the table, or 
an expression.

• Set the number of segments per circle. 

Once MI Pro has created the buffer region, it puts it in the editable layer.

Buffer Radius
The buffer radius determines the dimensions of the buffer region. For example, if you 
want to create a region that covers an area one mile on either side of a freeway, set 
your buffer radius to 1 mile. If you choose to use a field from the table or an 
expression, MI Pro will calculate the radius of the buffer based on that value.

You can set the radius to be a constant value or you can choose a data value from the 
table to be used as the radius. For example, to create buffers around major cities that 
reflect the size of their population, choose the population field as the value. 
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You can go even farther to calculate the buffer radius using an expression. For 
instance, you want to create buffers around cities showing the population density. 
Since you do not have a field containing population density, you will need to write an 
expression that can calculate density from population and area. This is no different 
than writing an expression for thematic mapping or query selection. 

Number of Segments per Circle
The number of segments per circle determines the level of detail in the buffer region. 
The more segments per circle, the higher the level of detail. The default level is 12 
segments per circle.

Buffer Width Distance
MI Pro’s buffering feature calculates the buffer width to create a buffer that is some 
measured distance from the outline of the object. MI Pro calculates this distance using 
either the Spherical or Cartesian method.

Spherical calculations measure distance according to the curved surface of the Earth. 
This means that the distance from the boundary of the original object to the boundary 
of the new buffered object may vary from node to node. 

Cartesian calculations measure distance on data that has been projected onto a flat, X-
Y plane. This produces buffers that are exact in width, as long as the data is not in a 
Latitude/Longitude projection. 

The availability of the Spherical and Cartesian buttons depends on the type of 
calculation that is appropriate to the table’s projection. The Cartesian button will not 
be available if the table is in a Latitude/Longitude projection. Conversely, the 
Spherical button will not be available if the table is in a Non-Earth projection. 

For more detailed information on MI Pro’s distance calculations, see the MapInfo 
Professional Reference. 

Buffer Methods
You can create a single buffer to include all selected objects, or create individual 
buffers for each object. 

There are two ways you can buffer multiple objects at the same time. The first method 
is to create one buffer for all objects. Buffers are produced around each input object, 
and the resulting buffer objects are combined into a single output object. 
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A more powerful method is to create one buffer for each object. For example, you 
have a layer of satellite offices. You would like to create a five-mile radius buffer 
around every satellite office symbol. You select all office symbols (with either the 
Select All command or Select tool), choose Objects > Buffer, and select the option One 
buffer for each object. MI Pro creates five mile buffer polygons around each point. 
With this method, MI Pro considers the resulting buffers as individual region objects. 
The final combine operation is not performed.

Once you create a buffer region, you can search for objects within it, as with any other 
boundary.

To buffer objects:
1. Select the objects that you want to buffer. Make sure there is an editable layer 

in the mapper. The output buffered objects will be placed in that layer.
2. Choose Objects > Buffer. The Buffer dialog displays.

3. Select appropriate buffer radius, segments per circle, distance type calculation 
to use, and buffer method as described.
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4. Press the Next button. The Standard Aggregation dialog displays.

Note:  If the editable layer is the Cosmetic layer,  the Data Aggregation dialog will 
not display. The OK button displays in place of the Next button. Press OK 
to begin the buffer operation. 

5. After setting the appropriate data aggregation parameters, press OK. New 
objects will be created in the editable layer. The original objects will remain 
unchanged.

Concentric Ring Buffers
You can create concentric ring buffers around one or more objects easily using the 
Concentric Ring Buffer tool. This tool is accessed via the MI Pro Tool Manager: 

1. Choose Tools>Tool Manager. The Tool Manager dialog displays. 
2. Find the Concentric Ring Buffer Tool in the list, and check the Loaded and 

Autoload boxes next to it. 
3. Click OK. The tool is added to the Tools menu, and will be loaded 

automatically each time you start MI Pro. 

To create concentric ring buffers: 

4. Select the object(s) you want to place buffers around.
5. Choose Tools>Concentric Ring Buffers>Create Ring Buffers. 

The Concentric Ring Buffers dialog displays. 

6. Specify the radius for each buffer ring, from smallest to largest. To do so, type 
the first radius into the radius box, and specify the units in the Units drop-
down list. Click the Add Ring button to add the radius to the Buffer Radii list. 
Proceed in this manner for each radius, keeping in mind to go from smallest 
to largest. 
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7. Specify the table in which you want to store the buffers. This table will 
include columns containing the ring number, radius value, radius units, area, 
and area units for each ring. 

8. When you have finished the buffer settings, click OK. 

You can change the smoothness setting of the buffer, as well as change or delete rings 
in the Buffer Radii list. To change the style of a buffer ring, select it in the Buffer Radii 
list, and use the style buttons to change the fill pattern and line style for the buffer. 
You can also aggregate data within each buffer ring using the Calculate Ring Statistics 
command. 

Convex Hull Objects
The Convex Hull command provides another means of creating a polygon around a 
selected object or objects. Convex Hull is similar to creating a buffer in several ways. 
Like a buffer, the Convex Hull command always creates an object from the input 
objects, and it will place the result objects into the editable layer. In addition, you have 
a choice to create one convex hull object from all of the input objects, or to create one 
convex hull object for each input object.

The resulting region object(s) are based on the nodes from the input object. The 
Convex Hull operation can be thought of as an operator that places a rubber band 
around all of the points. It consists of a minimal set of points such that all other points 
lie on or inside the polygon. Since the polygon is convex, no interior angles are greater 
than 180 degrees. No attribute data is aggregated in this operation. 

To use Convex Hull, a Map window must be active, it must have an editable layer, 
and objects in the editable layer must be selected. Otherwise, the command is not 
available. 
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To create convex hull objects: 
1. Choose Objects>Convex Hull. The Create Convex Hull dialog displays. 

2. Select the type of convex hull objects you want to create. You have two 
options: 

•  The One output object for all input objects button is the default setting. It 

creates one convex hull object around all of the selected objects.

• The One output object for each input object button creates a convex hull 

object around each selected object.

3. Click OK. Your map redisplays. The convex hull object(s) is displayed over 
the input objects. 

The convex hull object is selected when it displays. To change the fill of the convex 
hull object, do one of the following: 

• Double-click on it to display the Region Object dialog. Click on the Style icon 
at the bottom of the dialog to display the Region Style dialog. Make any 
changes you like and click OK. 

• Select the convex hull object, if it is not already, and choose Options>Region 
Style. The Region Style dialog displays. Make the changes you want and click 
OK. 
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Working with Layouts

Once you have created the perfect map, 

MapInfo Professional® gives you the tools you 
need to create high-quality presentations or 
output. Using the Layout window, you can 
create and customize a page layout that shows 
off your maps, browsers and graphs. Display 
improvements in the Layout and printed 
output ensure that your Map, Browser, and 
Legend have been made in the way Map, 
Browser, and Legend windows display in the 
Layout and in your printed output so that your 
results are better than ever.
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What Is the Layout Window?
MI Pro’s Layout window is a page layout feature that allows you to combine your 
Map, Browser and Graph windows on a page and arrange them for output. You can 
add any currently open window to the layout and move and resize it to find the best 
look to show off your work. Add text such as titles and labels to pull the entire 
presentation together

. 

While you can print individual Map, Browser, and Graph windows directly without 
the Layout window (File > Print), you can only print a thematic legend by first adding
it to a Layout window. You can also print the data contained in the Info tool, statistics 
and message windows from the Layout Window.

The Layout window is available as soon as you open MI Pro. Choose Window > New 
Layout window to access it. When the Layout window is active, MI Pro puts a Layout 
menu on the menu bar, allowing access to a number of layout features.

When you add your windows to the Layout window, MI Pro places them inside 
layout frames. Using frames to hold your maps and browsers allows you to resize and
reposition your windows with ease. The contents of the frame match the contents of 
the corresponding Map, Browser or Graph window. 

The Layout window provides dynamic linking between it and a parent window. For 
instance, if you change the zoom in a Map window, that map will be updated in the 
Layout window once you make the Layout window active again.
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The rest of this chapter is devoted to learning how best to create a layout, move 
around in the Layout window, and customize your layout using a variety of options.

reating Map Windows
The first step in generating quality output is creating good Map windows. MI Pro is 
set up to do a great deal of on-screen data entry, object editing, geocoding, and 
geographic analysis. There are many windows available to work with that can be 
easily arranged on the screen. When you prepare any MI Pro window for output 
through a Layout window, you must change the way you think of using MI Pro. For 
example, in a MI Pro session, if you want two views of a map, you may simply use the 
Grabber tool and shift to a different location, and then return via Map > Previous 
View. To get two views of the same map for a Layout, you must have two separate 
Map windows. There are many techniques that can be used to prepare the windows 
to make output easier.

Creating Multiple Views of the Same Map
One very popular way to display maps is to have a detailed map with an inset of an 
overview map representing the general area. For example, government planners have 
a detailed flood plain map thematically shaded for an area around a major city. They 
want to include an inset map showing the location of that city in relation to the entire 
region. We can simulate this exercise with the WORLD.TAB table included with MI 
Pro.

1. Open the WORLD.TAB and WORLDCAP.TAB tables from the MapInfo/
Data/World directory. The tables display in a Map window. 

2. Choose the area you want to show in detail and zoom in on it. 
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The Map window now contains the detailed view. 

3. As stated previously, there must be a separate Map window for each view 
you want to include in a layout. Instead of re-opening the tables to re-create 
the Map window, you can use Map > Clone View to create a duplicate Map 
window. Choose Map > Clone View.

4. A new Map window displays. Zoom out on this map to create the overview 
map.

Note:   The new Map window is independent of the original Map window. You 
may add or remove layers without changing the original map. 
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Getting Labels Right
There are many considerations in getting labels to look good on your maps. As with 
changing views of the map, there is a significant difference between using labels in a 
MI Pro session and using them in a layout. Labeling in a MI Pro session is best 
handled using the Auto Label check box in Layer Control.

When you create a map to place in a Layout window, you usually need to spend more 
time making your labels look aesthetically pleasing. It is also more likely that you will 
want to save these labels to a separate layer. With the default labeling, label styles can 
be changed; however, customized labels are not saved in their own layer for future 
use or editing. To create labels that can be easily saved, use Autolabel.mbx or 
Labeler.mbx. These MapBasic applications allow you to create labels that can be saved 
to a separate layer for future use.

Autolabeler Tool
This application gives you the same labeling functionality as in MapInfo 3.0. This 
MapBasic application lets the user determine what layer to autolabel. The labels are 
drawn in the Cosmetic layer where they can then be edited and saved.

Labeler Tool 
While labels in MI Pro are attributes of the map layer, text objects look like labels but 
behave like other annotations you draw on the map. The text objects are stored in the 
Cosmetic layer, and you can save them to a table.

The Labeler utility available from the Tool Manager (Tools>Tool Manager) helps you 
use text objects to perform several common labeling tasks: 

• Convert labels into text objects, so that they can be saved in a permanent 

table. 

• Create labels for only the currently-selected objects.

• Draw text objects one at a time using the Text Label button. This allows 

you to create multiple annotations for a single map feature, which is 

something you cannot do using labels. 
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Rotating Labels
The RotateLabel tool contains support for labels in Layouts. Load the tool through the 
Tool Manager, make the Map window active, and choose Tools>Rotate Labels. Make 
sure that you select the Prepare labels for use in Layout window check box when you 
are setting your Rotate Label options. 

Using Legends in a Layout
You can use both cartographic and theme legends in your layout. Both types of 
windows display in the layout at the same size as they do on the MI Pro desktop. 
When you resize a legend frame to make it smaller, it crops the legend rather than 
shrinking it to fit. The text styles (e.g., font, size) used in the cartographic and theme 
legend windows are preserved in the layout. 

Adding a legend to the Layout window is a different process, depending on the type 
of legend. You can add a theme legend to a layout even when no theme legend is 
displayed in the MI Pro desktop. To do this, make sure the Layout window is active 
and click the Frame button. In the Layout window, click and drag to draw the frame 
for your theme legend. When you release the mouse, the Frame Object dialog 
displays. In the Window drop-down list, select the theme legend and click OK. The 
theme legend displays in the layout frame. This is also how you add other types of 
windows on your desktop to the current layout.

In cartographic legends, you must create the legend on your desktop using the Map > 
Create Legend command before you can add it to the Layout window. 

Creating a Layout
Creating a layout involves adding your Map, Legend, Graph, and Browser windows 
to the Layout window, positioning these items where you want them, and adding any
annotations such as text and titles so that your final layout presents the message you 
want to send. 

Adding Open Windows to a Layout
First, decide what you want to put in the Layout window. You can choose whether 
you want to display all, some, or none of your open windows. When you choose 
Window > New Layout Window, a dialog displays, prompting you to choose which 
windows to add to the layout. 
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You bring your windows into the Layout window by adding them to placeholders, or 
frames. A frame is a graphic object through which you can view a window. Each 
frame may contain the contents of one Map, Graph, Browser, or Legend window. 

At the New Layout Window dialog, you have three options. You can add one frame to 
the layout, add frames for all currently open windows, or create a blank Layout 
window (no frames). 

Each situation is described below.

Since a frame is a graphic object, you can:

• Reposition it using the Select tool.

• Change its fill, and the linestyle of its border.

• Copy or cut the frame and paste it into another Layout window.

You can also position frames so that they overlap one another or overlap other 
graphic objects.

To change which window is displayed in a frame, double-click on the frame with the 
Select tool. Use the drop-down list in the Frame Object dialog to change the frame’s 
contents.

Situation Description

One Frame for Window MI Pro places a single open frame in the center of the layout. You 
select the contents of this frame through the drop-down menu that 
lists all open windows. 

If you choose a Map or Graph window from this list and there is an 
active map legend, MI Pro automatically places the legend in the 
layout. You can reposition or delete this legend from the layout. 
Legends are positioned in the same way as Map, Browser, and Graph 
windows. Their relative locations are preserved on the screen. 

Frames for all 
Currently open 
Windows

This option tells MI Pro to place all open windows in the layout. Since 
MI Pro places windows in the approximate location and size as they 
appear in the MI Pro window, you should arrange and size the 
windows before you bring them into the layout.

No Frames If you prefer, you can create a blank layout by choosing the No 
Frames option. If you do not have any windows open, choosing New 
Layout Window automatically creates a blank layout. The New 
Layout Window dialog does not display.
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Adding Windows to Current Layout � Using the Frame Tool  
After you have created a layout using the Window > New Layout Window 
command, you may decide that you want to add other windows from your 
desktop to the layout. You do not have to create a new layout to do this. You 
can also create frames by hand to contain other windows. Use the Frame tool 
to draw window frames where you want them. The Frame tool is available 
when the Layout window is active. 

To add a window to a layout you are already working with, make sure the 
Layout window is active and click the Frame button. The Frame tool is 
activated. In the Layout window, click and drag to draw the frame for the 
new window. When you release the mouse, the Frame Object dialog displays. 
In the Window drop-down list, select the window you want to add and click 
OK. The window displays in the layout frame. If you draw a frame when no 
windows are open, MI Pro places a blank frame in the Layout window.

Adding a Maximized Map Window to a Layout
You can place a maximized Map window into a frame in a Layout. The frame 
object’s dimensions are created according to the Map window’s size instead 
of the page layout size. MI Pro also allows the map’s image to completely fill 
the frame, preserving the map’s center and zoom settings. If you double-click 
on the frame, you will notice that the Fill Frame with Map check box in the 
Frame Object dialog is checked. This allows the map image to fill the entire 
frame. The box is checked by default for all Map windows in frames.

Moving Frames
Once you have brought in the windows you wish to include in the layout, you can 
reposition or resize them to create a professional looking product. 

To move a frame, click on the frame with the Select tool and hold down the mouse 
button. When the cursor becomes a four-headed arrow (after about one second), drag 
the frame to the new location and release the mouse button. 
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Aligning Layout Objects
MI Pro includes a command to help you perfectly align objects in the Layout window. 
You can align objects to each other horizontally and vertically or to the Layout 
window itself. 

Choose the objects you want to align and choose Layout > Align Objects. The Align 
Object dialog displays. Specify the appropriate vertical and horizontal alignment. 
Choose from:

Each alignment can be performed with respect to each object or to the entire layout. 
When you choose the entire layout, the objects are aligned with respect to the top, 
bottom, left, and right edges or margins of the layout. 

If you want to align objects with respect to each other, the objects are aligned with 
respect to an imaginary rectangle, called the bounding rectangle, that completely 
encloses the objects. The horizontal and vertical settings you choose position the 
objects at the top, bottom, left, right, and horizontal or vertical center lines of the 
bounding rectangle, rather than at the edges of the layout. 

The Distribute option tells MI Pro to distribute the vertical and horizontal space 
between objects evenly.

You can perform multiple alignments in one layout. 

Examples of Aligning Objects
Consider this example. You have several elements in the Layout window: one large 
map, one small map showing a different view, a browser, and some text. You have 
them in the general position you want, but you want to line them up precisely to 
make a professional looking layout. In this case you want to align the objects with 
respect to each other

Horizontal Alignment Vertical Alignment

Don’t change alignment Don’t change alignment

Align left edges of Align top edges of

Align center of Align center of

Align right edges of Align bottom edges of 

Distribute Distribute
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To align the small map and text that are located side by side below the large map, 
select the small map first. Shift-click to select the text without cancelling the selection 
of the small map. (You can also use the Marquee Select tool to select both at once.) 
Choose Layout > Align Objects. Align the two objects so that they are vertically 
centered with respect to each other. In the Align Objects dialog, disregard the 
horizontal component for the moment (make sure it says Don’t change) and choose 
Align Center of from the drop-down list in the vertical component. Choose with 
respect to each other and click OK.

The layout readjusts by moving the objects vertically to show the centers of the map 
and text lined up with each other. 
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Now you want to align the large and small maps so that their left edges are 
horizontally aligned with respect to each other. Select the two objects and choose 
Layout > Align Objects. In the Align Objects dialog choose Align left edges of and 
with respect to each other in the horizontal component. In the vertical component 
choose Don’t change. Click OK. 

The map now shows the left edges of the two maps in alignment.

As a final alignment, you want to align the right edges of the large map and the 
browser. Select the objects and specify Align right edges of the selected objects with 
respect to each other.

Your layout now looks like this: 
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Working in the Layout Window
The Layout window functionality includes a number of options to help make it easier 
to design and create your layouts. 

Getting Around in the Layout Window
The Layout window includes a rule along the top and left side of the window to assist
you when resizing and positioning frames. To hide the rule, by choose Layout > 
Options. The Layout Display Options dialog displays. Clear the Show Rules box.

If you are creating a multi-page layout, MI Pro displays the page breaks by default. If 
you wish to turn off the page breaks, clear the Show Page Breaks box in the Options 
dialog.

Controlling Zoom Level
MI Pro displays the Layout window at a zoom level that is a fraction of the actual size 
of the printed layout. The zoom level is represented as a percent of actual size in the 
lower left corner of the status bar. 

In order to better position or resize layout objects, you may want to change the zoom 
level of the Layout window to see more detail. Keep in mind that you are changing 
the overall zoom of the Layout window, not the zoom of individual windows in 
frames. (If you want to change the zoom level on a frame containing a Map window, 
change the zoom for the Map window itself.)

There are four ways to change the zoom level of the Layout window:

• Use the Zoom-in and Zoom-out tools. These tools work exactly as they do in 
the Map window. You can click on the Layout window with the tools or draw
a marquee box around the areas of the Layout window.

• Choose Layout > Change Zoom to set the zoom. You can set the zoom 
anywhere between 6.3% and 800%.

• Use the number keys (1–8) on your keyboard to set the zoom level. As the 
numbers increase, the zoom increases geometrically. For example, press 1 to 
get a zoom of 6.3%, press 2 to get a zoom of 12.5%, and press 3 to get a zoom 
of 25%. (Remember to use the number keypad, and make sure Num Lock is 
on.)

• Use the View commands in the Layout menu: View Actual Size, View Entire 
Layout, Previous View. 
448 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 450



Chapter 21: Working with Layouts

M

M

Ordering Overlapping Objects
You may add enough windows to the Layout window to cause objects to overlap one 
another. In the Layout window all objects are ordered from front to back. Think of 
them as being stacked in the Layout. When you draw a new object, it is automatically 
the frontmost object, even if it is not overlapping any other objects in the layout. 

In order to display your objects properly, you may need to bring an object forward in 
front of other objects. 

You can use the Bring to Front and Send to Back commands to change the order of 
objects. Click on an object with the Select tool. Choose the Bring to Front option to 
move the object into the foreground. Choose the Send to Back object to move the 
object into the background.

When you select an object using the Control key along with the Select tool, MI Pro 
selects the object one layer down. Selecting again chooses the next layer.

ap Scale
One of the most difficult tasks in generating good output is setting the scale of the 
map. There are two ways to set the map scale. The first method is to choose Map > 
Change View. This scale setting affects the on-screen scale of your map according to 
your monitor size. This scale setting isn’t used as often, because generally the scale on 
screen does not need to be exact. Use the on-screen scale when you are making a 
presentation that will be viewed directly in MI Pro.

Accurate scale is more important on the printed map. To get the correct scale for 
output, you must coordinate the Map window with the Layout window. You must 
also decide on the desired end result. For example, you may want a map that has a 
1:25000 scale and fits in a nine inch Layout frame. If this is the case, you will have to 
alter the zoom level of your map to fit these conditions. Or, in the case where you 
must show a set distance across the map, you may have to allow for a larger page size. 
The following two formulas will help you set the right map zoom, scale, and frame 
width.

Set Scale with a Limited Frame Size
The following formula calculates the zoom that must be set in your Map window in 
order to have a map meet set scale and frame width criteria.

((Frame Width in Inches * Scale)/12) /5280 = Map Zoom in Miles
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For example, you need to make a map that will be in a scale of 1:24000 and fit in an 
eight inch frame. You need to determine the zoom level that will accommodate the 
map scale and frame width. Calculate the following:

((8 * 24000) / 12) / 5280) = 3.03
Then use Map > Change View and enter 3.03 miles as your new zoom level.

Set Scale with a Limit on Map Zoom
The following formula calculates the number of inches to make the frame for a map in 
order to meet set scale and zoom level criteria.

(Map Zoom in Miles * 5280 * 12) / Scale = Necessary Frame Width
For example, you need to make a map that will be in a scale of 1:100000, and you must 
view a twenty mile zoom level. You need to determine the frame size that will 
accommodate the scale and zoom. Calculate the following:

(20 * 5280 * 12) / 100000 = 12.67
Your frame needs to be 12.67 inches wide. If your printer is not large enough to handle 
this, change your layout size to spread over two pages.

Creating a Simple Scalebar
If you want to include scale on your map or layout for a general reference of distances, 
use the Scalebar tool. The Scalebar tool includes the ability to draw a scale bar in the 
Layout window. 
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To load the ScaleBar utility:
1. Choose Tools > Tool Manager. 
2. Scroll down the Tools list and check the box that will load the ScaleBar 

program. The program is added to the Tools menu. A ScaleBar tool  is 
also added to the Tools menu.

Now you are ready to draw the scalebar. When you create a scalebar in a layout, the 
Adjust font size to match scale check box is only available in the Set up ScaleBar 
options. Choose Tools>Scalebar>Set up ScaleBar to select this option before you 
proceed. To draw the scalebar:

1. Choose Tools > ScaleBar > Draw ScaleBar. This option automatically positions 
the scalebar in the lower left corner of the Layout window. 

2. A Warning dialog displays, telling you that the Layout frame and the 
associated Map window are not currently set up to print to scale. You can 
adjust the Layout frame or the Map window, or ignore the message. Check 
the box if you do not want to receive warnings about the scale again.  The 
Draw Distance Scale in Mapper dialog displays. 

3. Choose the width of the scale bar and the aspect ratio. Set the text style and 
fill colors. Click OK. The scalebar is drawn to your Layout window in the 
lower left corner. 

If you select the Curve scale bar with latitude lines check box, the scalebar is 
accurate only along its curve and only if the Spherical calculation method is 
used. If you do not select the check box, the scalebar is accurate straight 
across, but only if the Cartesian calculation method is used. Check the Map 
Options dialog (Map>Options) to see which distance calculation method is in 
use for your Map window.

The ScaleBar tool that is placed on the Tools toolbar when the ScaleBar utility is 
loaded enables you to create a scalebar and position the left edge of it anywhere on 
your layout. Click the ScaleBar tool, and click on the Layout where you want to 
position the left edge of the scalebar. Follow steps 2–4 above to complete the scalebar. 

Note:  The objects that make up the scalebar are drawn to the Cosmetic layer. To 
move the scalebar, make sure that all of the objects are selected, and click 
and drag the scalebar to a new location.
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Customizing a Layout
You have tremendous flexibility in designing your layout in MI Pro. You can choose 
whether to display the contents of a layout frame at all times, set margins and number
of pages for the layout, add text, and create drop shadows around layout objects.

Displaying a Window in a Frame
You can control how a window displays in a layout frame. Choose Options from the 
Layout menu. MI Pro displays the Layout Display Options dialog. There are three 
options that control how windows display in frames: Always, Only When Layout 
window is Active, and Never.

Status Description

Always MI Pro always displays the contents of the frames in the Layout 
window. This option allows you to make changes in the Map or 
Browser window, and view those changes in the corresponding frame
in the layout. This applies even when the Layout window is not 
active, useful when you are doing precision work in another window.

Only when Layout 
window is Active

MI Pro only displays the contents of frames when the Layout window
is the active window. When another window is active, MI Pro 
displays the titles of windows in the frames.

Never MI Pro never displays the contents of the frames. It only displays the
titles of the windows in the frames. Choose this option when 
rearranging or resizing frames. This option allows you to reposition 
and resize frames quickly without waiting for each one to redraw. 
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Setting Margins and Number of Pages
To set layout margins, choose File>Page Setup. The Page Setup dialog displays. 

Specify the margins you want for your layout. The screenshot above shows 1-inch 
margins: left, right, top, and bottom. The dotted lines around the sample page in the 
dialog indicate the margins. 

Click OK to return to the Layout window. A gray area displays around the edge of the 
layout, indicating the margin. Layout objects can extend into the margin, but you may 
not be able to print those objects.
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MI Pro also allows you to create multi-page layouts. The layout will be printed in 
pieces that you can then assemble to make a large layout. To create a multi-page 
layout, specify in the Layout Display Options dialog how many pages high and how 
many pages wide you want the layout to be. The pages are tiled with the interior 
margins hidden.

For example, in order to show the appropriate level of detail on your map of city 
streets, you want to print the map measuring 10 inches high by 15 inches wide. Since 
this size map will not fit on a single page, either at portrait (8 1/2 x 11 inches) or 
landscape (11 x 8 1/2 inches) orientation, you will need to specify a multi-page layout. 
In the Options dialog, choose 2 pages for the width and 1 page for the height of the 
layout (for portrait printing) MI Pro will print the 10x15 inch map across the two 
pages. 

You can experiment with different arrangements in the Layout window. MI Pro uses 
dotted boxes to differentiate among pages in a multi-page layout. If you do not want 
MI Pro to display these page breaks, clear the Show Page Breaks box.

Customizing Text 
You will most likely want to annotate your layout titles or labels for individual layout 
components. Use the Text tool on the Drawing Toolbar for this. To customize the text, 
select the text and choose Options > Text Style. You can change the size, color, and 
style of the font and add a background color to make the text stand out on the page. 
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You can also rotate the text by selecting it and grabbing the rotating text handle that 
appears off the lower right corner of the text object. Move it to a new angle and release 
the mouse button. 

Double-click on the text object to display the Text Object dialog for even more options, 
such as justification, line spacing, and adding a label line.

Creating Drop Shadows
You can create drop shadows around objects in a layout such as rectangles, rounded 
rectangles, and circles to add a three-dimensional look. Choose the object(s) you wish 
to enhance with a drop shadow and choose Layout > Create Drop Shadow. Specify 
the amount of horizontal and vertical offset you want in the Create Drop Shadow 
dialog.

Keep in mind that the shadow is not linked to the object, so if you move or resize the 
object the shadow does not change. It is best to add drop shadows to objects after you 
have finished positioning and sizing them.

To change the drop shadow’s fill pattern or line style, select the drop shadow and 
choose Options > Region Style.

North Arrows  
Add a North Arrow to a Map or Layout window and  optionally, add a Magnetic 
Declination Arrow. Use the North Arrow tool from the Tool Manager or use the North 
Arrow button on the Tools Toolbar to draw a rectangle and place the North Arrow at 
the specified location.

The NorthArrow.mbx is found in the Tools > Tool Manager, it is not autoloaded by 
default. When the North Arrow is loaded, it displays as the Tools > North Arrow 
menu option and as a button on the Tools toolbar.

1. Choose Tools > North Arrow.

2. Choose Setup North Arrow to establish defaults for inserting a North Arrow.

OR

Choose  Draw North Arrow to insert a North Arrow using the defaults already 
designated in Setup North Arrow, or to override those defaults.

OR

Choose  Tool Toolbar > North Arrow button.
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The North Arrow Dialog displays

Specify any of the following options:.

Select Arrow Style As you choose a number, the corresponding arrow style displays in 
the preview box.

Choose a style for the Foreground brush, Foreground pen, 
Background brush, and Background pen. 

Rotate North Arrow 
to match projection.

Available in a Map Window only.

Point North Arrow 
to top of map.

Stretch the North Arrow to fit the contents of the drawn arrow. 
Available in a both the Map and Layout Window when using the 
North Arrow button. 

Use aspect ratio of 
rectangle you draw.

Draw the North Arrow at the original aspect. 
Available in a both the Map and Layout Window when using the 
North Arrow button.

Use aspect ratio of 
selected North 
Arrow.

Available in a both the Map and Layout Window when using the 
North Arrow button.

Magnetic 
Declination

Check to display a Magnetic Declination arrow in addition to the 
north arrow.  Display the Magnetic Declination dialog.
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Adding a Logo
As you complete your Layout, you may be required to add information such as the 
creation date, author, and project name. This can be accomplished with MI Pro’s 
drawing tools. You may also want to add a logo to your final map. MI Pro will let you 
add a raster image containing your logo. To add a logo to your Layout window:

1. Set up your Layout window with the map and any other information you 
would like to include. 

2. Choose File > Open. Set the Preferred View to New Mapper. Change the File 
Type to Raster. Switch to the directory containing your logo, and select the file 
name. Click Open. 

3. A MI Pro dialog displays asking if you would like to register the image or 
simply display the image. Click the Display button. Your logo displays in its 
own Map window.

4. Click in the title bar of your Layout window to make it the active window. 
5. Using the Frame tool from the Drawing toolbar, create a frame where you 

want to place your logo. 
6. The Frame Object dialog box displays. In the Window box, choose the name 

of the Map window containing your logo. Click OK.
7. Your logo displays in the frame. 
8. To remove the Frame’s border, select it and choose Options > Region Style. Set 

the border style to N and click OK.

Insertion Corner Choose which corner in which to place the North Arrow: NorthWest, 
NorthEast, SouthEast, SouthWest.
This is not available if the North Arrow is enabled using the North 
Arrow button; the Arrow is placed at the cursor location. 

Size North Arrow to 
be this percentage of 
window size

Enter percentage number.
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Creating and Saving a Layout Template
A layout template is a layout with empty frames. You can reuse a template, placing 
new windows in the frames with each use. Any titles and other annotations you add 
to the layout will be preserved from one session to the next, as will the window 
frames. 

To create a template, first close all windows and any tables that are open. Choose New
Layout Window from the Window menu. MI Pro creates a blank layout. Place your 
frames, titles, labels, or other graphic objects into the layout. When you are finished, 
save your template to a workspace. When you are ready to use the layout template, 
open the workspace. 

Printing a Layout
Now that you have completed your professional looking layout, printing is a simple 
matter.

Page Setup
First check that your page setup is what you want. Any changes to the page setup will 
likely affect the layout, so it is a good idea to view the effect of the changes on your 
layout before printing. Choose File > Page Setup. Here, you can specify the page 
orientation (portrait or landscape) and margins. You can also specify the paper size 
and its source. 

In addition, you can override your default printer setting and choose a different 
printer for this print job. Click the Printer button to display the Page Setup dialog for 
your printer. The printer that initially displays is the default printer that you set in the 
Printer preferences (Options>Preferences>Printer). This will either be the Windows 
default printer, or the MI Pro preferred printer that you selected. Make any changes 
you want to the printer and its properties, and click OK. The settings available in the 
Printer Properties dialog will vary according to the printer you are using. 
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Printing Options
When you are ready to print, make sure the Layout window is active and choose File 
> Print. The Print dialog displays. Choose the number of copies you want to print and 
whether you want all pages or a specific range of pages to print. As in the Page Setup 
dialog, the Print dialog also allows you to override the default printer settings. Click 
the Name drop-down list in the Print dialog to select a different printer. All of the 
printers available on your system display in the list. You can specify printer properties 
here as well, plus specify whether to print to a file. 

Use the new advanced print settings to take advantage of additional output options 
that help you control transparency and color, particularly for raster images.

Note:   Changes you make to these settings override the default settings in the 
Output preferences for this printing job. 

In the Print dialog, click the Advanced button. The Advanced Printing Options dialog 
displays. 

Indicate whether you want to print your Layout using the new Enhanced Metafile 
format, or with the method used in previous versions of MI Pro (Print Directly to 
Device). 
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Next, indicate how you want to handle transparency. If you have transparent vector 
fill patterns and symbols, check the Internal Handling for Transparent Vector Fills and
Symbols box to have MI Pro handle the transparency internally. If you are using 
transparency in a raster image, clear the Use ROP Method to Display Transparent 
Raster box to have MI Pro handle the transparency internally. The image will be 
broken down into small rectangular regions that do not contain transparency. It is 
recommended that you check this option because printers do not always handle 
transparent raster images correctly. 

Note:   This method may produce large plot files. 

If you are using 24-bit, true color raster images, check the Print Raster in True Color 
When Possible box, and select a dither method from the Dither Method drop-down 
list. 

The Print Border for Map Window check box is not available for Layout windows. 

You can control the border for each frame by selecting the frame and setting Options >
Region Style.

Electronic Output
More and more often, users want to save their maps electronically to files rather than 
print them on paper. MI Pro offers many choices for electronic map output. 

Exporting a Layout
The easiest way to make electronic copies of maps and layouts from MI Pro is to use 
the File > Save Window As command. You can export to Windows Bitmap, Windows 
Metafile, Windows Enhanced Metafile, JPEG File Interchange Format, JPEG 2000, 
Portable Network Graphics Format, Tagged Image file Format(TIFF), CMYK, and 
Photoshop 3.0. 

When using the Save Window As command, keep in mind that all additions and edits 
must be made in the Map window. When you have the Map window the way you 
want it, then create the Layout window.

You can use the new advanced export options to produce better quality output. The 
same transparency and raster options available when you print your Layout are also 
available when you export the Layout. Click the Advanced button in the Save 
Window As dialog to display the Advanced Exporting Options dialog. The same 
check box settings are available. 
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As with the advanced print options, changes you make to the advanced export 
settings override the default settings in the Output preferences for this export 
operation. See Chapter 6, Working with Preferences for more complete information. 

Creating an Encapsulated Postscript File
If the available Save Window As formats are not appropriate for your needs, or you 
want to use the options in the Layout window, you may want to send your output to 
an encapsulated postscript (EPS) file. This file type is widely used by service bureaus 
and print shops. 

There is not a set export or save command for EPS files. You must set up a postscript 
printer driver and print the map or layout to a file. Do the following:

1. From the Windows Control Panel, select Printers.
2. In Printer Setup choose Add Printer. The Add Printer Wizard will display. 
3. Follow the wizard for the setup. Choose a postscript printer from the printer 

list, and select FILE as the available port. The print driver may have an option 
to specify EPS that should be enabled.

4. Once the postscript driver is installed on your system, you will use that 
printer to print the map or layout to a file from MI Pro.

5. In MI Pro, once you have created your map, choose File > Print. The Print 
dialog displays.

6. Under printer name, select the postscript printer. Click OK.
7. The Print to File dialog displays. Give your file a name and choose Save. You 

will now have an encapsulated postscript file. 
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Managing Your Tables

Database tables are the foundation of many 

tasks in MapInfo Professional®. They provide 
the basic framework from which you create 
maps and analyze data. You have already been 
introduced to the concept of tables in Chapter 
4. This chapter focuses on the business of 
maintaining your tables. It begins, however, 
with a basic primer on databases. For learning 
about querying tables, see Chapter 10, Selecting 
Using Queries.
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What Is a Database?
A database is a collection of information organized so that it can be readily accessed 
through a computer. Databases in MI Pro are often referred to as tables. 

To understand MI Pro, you need a basic understanding of database organization, in 
particular, three fundamental concepts: record, field, and index.

Consider the following list of typical address information.

Each row in the list contains information about one person. In database terms, each 
row is a record. Each record contains several different kinds of information about the 
person. Those different kinds of information are called fields. The fields correspond to
the columns so that the table shown above contains four different fields (LastName, 
FirstName, Address, and ZIPCode). 

Database fields are ordered (first, second, third, fourth, etc.), and the basic convention 
is that the first field is displayed as the first column in the database. The second field 
is in the column to the right of the first, and so on to the last field, which is displayed 
in the rightmost column.

Notice, however, that this table isn’t listed in the order in which address book entries 
are usually listed, which is alphabetical. Databases use indices to speed the querying 
process. Without indices it would be tedious to find anything in a database with 
hundreds of records, not to mention databases with thousands and tens of thousands 
of records.

A database index works on the same principle as a book index. A book index lists 
topics that appear in the book. The index entries are arranged in alphabetical order, 
making it easy for us to find the topic we want. When we find the topic, we also find a
page number (or several page numbers) and we go to those pages in the book to read 
about the topic. The page number acts as a pointer to the location of the information.

LastName FirstName Address ZIPCode

Fraser Mark 212 Hudson St 12205

Donaldson Eva 459 Yates St 12208

Espinosa Kim 200 Broadway 12180

Smith Charles 1 Redbird Ln 12065

Chang Elizabeth 53 Crescent Rd 12077
464 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 465



Chapter 22: Managing Your Tables

M

M

Database indices work in a similar way, except that they generally work behind the 
scenes. You don’t ever see them. But the computer constructs them and allows you to 
use them in your work.

The physical order of records in a database is not generally meaningful; it is simply 
the order in which the records were entered into the database. Just as the book index is 
a list of topics arranged in alphabetic order, a database index is a list of pointers that 
allows the computer to work with the records in some coherent order. That order, of 
course, must come from the information in the records themselves. The list of pointers 
corresponds, or is keyed, to a field in the database. An index allows the computer to 
work with the records according to the order of items in the key field.

An index speeds up the process of searching through the database for information. In 
fact, MI Pro requires a field to be indexed in order to use the Query > Find command. 
Indices are also used to improve performance in SQL Select and joins. 

I Pro Tables
Now that you understand a little more about databases, let’s put it in the context of 
MI Pro. 

In MI Pro you can work with a variety of table types. Data tables are like the address 
table we just discussed. Most tables in MI Pro are of this type. Further subdividing 
this class of tables are data tables that contain graphic objects (map objects) and data 
tables that do not (such as spreadsheets or external database tables).

Raster tables are graphic images that you can display in a Map window. These 
computerized pictures do not have the same table structure of record, field, and index 
as data tables do, and therefore, will not be discussed in this chapter. For more on 
raster images, see Chapter 19, Displaying Raster Images.  You can also work with Grid 
files.

The following information applies to data tables.
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Linked Tables
A linked table is a special kind of MI Pro table that is downloaded from a remote 
database and retains links to its remote database table. 

You can perform most operations on a linked table that you do for a regular MI Pro 
table. For instance, you can view, edit, copy, save, and rename a linked table just as 
you could a regular MI Pro table. However, there are some things you can’t do to a 
linked table. For instance, you can’t pack a linked table. You also can’t modify the 
table structure of a linked table (but you can modify its MI Pro index structure). 

You have live access to remote databases, enabling you to make changes to your 
remote database directly. To learn about linked tables and find out about live DBMS/
remote database access, see Chapter 23, Accessing Remote Database Data.

Creating a New Table
As you learned in Chapter 4, you can bring in data tables from several outside 
sources: dBASE, Excel, Access, Lotus 1–2–3, Shapefiles, Grid and delimited ASCII.

You can also create your own database directly in MI Pro. These databases can be 
opened and displayed as maps (providing they contain graphic objects), Browsers, or 
graphs.

To create a new table in MI Pro:
1. Choose File > New Table. The New Table dialog displays. 

2. Choose Open New Browser so that the new table will be open in its 
traditional tabular form in a window. 

3. Choose OK. The New Table Structure dialog displays. 
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4. Choose Add Field to begin building the database’s structure. Give the field a 
name, type, width, and specify whether the field will be indexed. 

5. Continue to add fields until you have the number you want. 
6. Use the Up and Down buttons to reorder the fields. Keep in mind that the 

order of fields in this dialog (top to bottom) will actually display as columns 
(left to right) in the Browser window.

7. Choose Create. The Create New Table dialog displays. 

8. Specify a location for the new table in the Save in box. 
9. Enter a name for the table in the File Name box. 

10.  Specify the file type in the Save as type drop-down list. You can choose from 
the following formats: 

• MapInfo (*.tab)

• MapInfo version 2.x (*.tab)

• dBASE DBF (*.tab)

• Microsoft Access (*.tab)
11. Click Save. If you chose either of the MI Pro formats, MI Pro creates your 

table. You are finished. If you chose dBASE DBF, proceed to step 12. 
12. If you chose dBASE DBF, the dBASE DBF Information dialog displays, asking 

you to specify a file character set. Choose the one appropriate for your 
language and click OK. Click Save in the Create New Table dialog. MI Pro 
creates the new table. You are finished. 
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Note:   Do not use “Districts” as a name for your base tables. MI Pro uses 
“Districts” internally as a system table when beginning a redistricting 
session. 

See the section on Microsoft Access Tables later in this chapter for information on 
creating a new Access table. 

Working with Spreadsheets
When you have a table that is based on a spreadsheet or database, MI Pro does not 
require that you create a new table or import the data. MI Pro works with the original 
.DBF (or .XLS) file, which saves time and disk space. The first time you open the file, 
MI Pro creates a .TAB file. After that, the .TAB file will appear on the list of files 
available to open.

There are some limitations, however, when working with spreadsheet data: 

• You cannot change the structure of a table that was based on a spreadsheet 
file.

• You cannot edit a table based on a spreadsheet.

To work around these limitations, use Save Copy As before making any changes. See 
Saving a Table, below. 

Also, MI Pro will now open Excel files that contain columns that have been formated 
as zip codes, as strings, so they can be used to join other MI Pro tables to perform 
geocoding

If you import Excel spreadsheets that contain string functions such as LEFT, MID, 
RIGHT, STR, perform the following:

1.  Select the cells containing the string functions in question (or the entire 
worksheet).

2. Choose Edit > Copy.
3. Choose Edit > Paste Special > Values.
4. To retain the formulas in the original Excel spreadsheet, save the revised 

spreadsheet under a different name.
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Several improvements have been added to MI Pro’s support of Microsoft Access 
tables. As before, both MI Pro and MapBasic enable you to open Microsoft Access 
tables directly from the Open Table dialog (File>Open). With MI Pro Professional 6.0, 
this support now includes both Access 2000 tables and Access ’95/’97 tables. You will 
notice this support when you create a new Access table and when you save an 
existing table as an Access table. Control the Save Access Table dialog enables you to 
choose the version of Access that you want to save the database to. 

In addition, multi-user support has been implemented for Access tables. This support 
includes the ability for multiple users to read, add, update, and delete records from an 
Access table. Some table operations from the Maintenance sub-menu are not 
supported (Table>Maintenance). These are: Pack, Rename, Delete, and Alter Table 
Structure. 

You can also use Access databases on read-only media; however, the table must have 
an autonumber column that is uniquely indexed. 

Opening Shapefiles
You can open ESRI®  Shapefiles directly from the Open dialog.

To open a shapefile:
1. Choose File > Open. The Open dialog display.
2. In the Files of type drop-down list, choose Shapefile (.shp).
3. Select the shapefile to open; press Open.
4. Specify name and location of newly created TAB file. By default, the TAB file 

location is the directory specified in Preferences. The name of the TAB file is 
the same name as that of the Shapefile. 

5. Press Save: the Shapefile Information dialog displays.  This information is 
only required the first time a shapefile is opened. The default Styles and 
default Projection designated in Options > Preferences are used. 

Access Table Requirements
Before opening a Microsoft Access table in MI Pro, the Access table must meet the 
following requirements:

• A table in Access must have an autonumber column with a unique index or 
primary key set on that column. Otherwise, MI Pro will alter the table to fit 
this requirement.
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• The Access table being brought into MI Pro must be a flat Access table, i.e., 
the table must not contain fields that point to data in other Access tables.

• Memo, OLE, and Replication ID field types from an Access table will not be 
brought into MI Pro.

• Text field length cannot exceed 254 characters. If the length exceeds 254 
characters, the field is brought in as read-only.

• Zero length strings are not allowed. 

Opening a Microsoft Access Table in MI Pro
To open an Access table in MI Pro, do the following:

1. Choose File > Open. The Open dialog displays.

2. Choose Microsoft Access Database from the Files of type menu. The Access 
databases (.mdb) for the specified location display.

3. Choose an Access database to open. If database security is turned on, you will 
be prompted to give the password for the database.
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The Open Access Table dialog displays the tables for the opened database.

4. Choose an Access table or tables to open. The table or tables are opened in MI 
Pro. 

MI Pro handles Access files the same way it handles opening files in other formats in 
MI Pro. After you open the Access table in MI Pro for the first time, MI Pro creates a 
definition for the table and gives it a .TAB extension. This enables you to it treat it like 
any other MI Pro table. The next time you open the file, you would open it as you 
would any other MI Pro table. 

Please note that even though the table now has the .TAB extension in MI Pro, your 
data is still in your original Access database table and is not a duplicate. 

Creating an Access Table
Creating a Microsoft Access table has several additional steps than creating a MI Pro 
table. To create an Access table, first perform steps 1–10 in the Creating a New Table 
section of this chapter. The Create New Table dialog should be on your screen, as 
shown below. Do the following:
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1. In the Save in field, specify the location where you want to create the MI Pro 
table definition of your Access file. The MI Pro table definition is the .tab file. 
It is used by MI Pro to keep information about an Access file registered in MI 
Pro.

2. In the Save As Type field choose Microsoft Access Database.
3. Click Save in the Create New Table dialog. The Save Access Table dialog 

displays. The default database displays in the dialog. The default is 
determined by the name of the .tab file you entered. The default has the same 
name as the .tab file. A database for this file may or may not exist. 
472 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 473



Chapter 22: Managing Your Tables

M

If the database you specified does not exist, the Save Access Table dialog 
enables you to specify the version of Microsoft Access you want to use for the 
database. Choose either Microsoft Access 2000 or Microsoft Access ’95/’97 
from the Version drop-down list.

If a database does exist, the Save Access Table dialog indicates the version of 
the database. It also lists the tables in the database.
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4. To create your table in the default database, use the default file name or enter 
a new one in the Enter the name of the new Access table box. The default file 
name is the same name specified in the Create New Table dialog. Click OK. 
MI Pro creates the new table to the default database.   

To create your table in a database other than the default, proceed to step 5. 

5. Click the Database button. The Select Access Database dialog displays. 

6. In the Save in drop-down list, specify the location of the Access database. This 
is where you will create the table.

7. Click on the database you want to create the table in. The name displays in 
the File Name box. To specify a new database, enter the name in the File name 
box. 

8. Choose Save. The Save Access Table dialog displays again. 

If you chose an existing database, the name and version display in the dialog. 
Any tables already in the database are listed in the Existing Tables box. 

If you specified a new database, select the database version from the Version 
drop-down list. Choose either Access 2000 or Access ’95/’97. 

9. The file name you chose in the Create New table dialog is displayed in the 
Enter the name of the new Access table box. You can use this name or specify 
a different name. Click OK. MI Pro creates the table as a Microsoft Access 
table in the database you specified. 
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Saving Access and MI Pro Tables
You can save a MI Pro table as an Access table, save an Access table as a MI Pro table, 
and save an Access table as an Access table using the File > Save Copy As menu 
command.

Saving a MI Pro Table as an Access Table
To save a MI Pro table as an Access table, do the following:

1. Choose File > Save Copy As. The Save Copy of Table As dialog displays.

2. In the Save in field, specify the location where you want to save the MI Pro 
table definition of your Access file. The MI Pro table definition is the .tab file. 
It is used by MI Pro to keep information about an Access file registered in MI 
Pro.

3. In the Save As Type field choose Microsoft Access Database.
4. Choose Save. The Save Access Table dialog displays. The default database 

displays in the dialog. The default is determined by the .tab file you selected. 
It has the same name as the .tab file. A database for this file may or may not 
exist. 

If the database you specified does not exist, the Save Access Table dialog 
enables you to specify the version of Microsoft Access you want to use for the 
database. Choose either Microsoft Access 2000 or Microsoft Access ’95/’97 
from the Version drop-down list.
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If a database does exist, the Save Access Table dialog indicates the version of 
the database, as shown below. It also lists the tables in the database. 
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5. To save your table to the default database, use the default file name or enter a 
new one in the Enter the name of the new Access table box. The default file 
name is the same name specified in the Save Copy As dialog. Click OK. MI 
Pro saves the new table to the default database.   

To save your table to a database other than the default, proceed to step 6. 

6. Click the Database button. The Select Access Database dialog displays. 

7. In the Save in drop-down list, specify the location of the Access database. This 
is where you will save the table.

8. Click on the database you want to save the table in. The name displays in the 
File Name box. To specify a new database, enter the name in the File name 
box. 

9. Choose Save. The Save Access Table dialog displays again. 

If you chose an existing database, the name and version display in the dialog. 
Any tables already in the database are listed in the Existing Tables box. 

If you specified a new database, select the database version from the Version 
drop-down list. Choose either Access 2000 or Access ’95/’97. 

10. If you want to use a different file name, enter the name in the Enter the name 
of the new Access table box, and click OK. MI Pro saves the table as a 
Microsoft Access table in the database you specified. 
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Saving an Access Table as a MI Pro Table
Use the Save Copy As command as you normally would to save the Access table as a 
MI Pro table.

Saving an Access Table as Another Access Table
This option is used to save an Access table to a different database. The process is 
similar to saving a native MI Pro table. Use the Save Copy of Table As dialog to 
specify the database path and name, then use the Save Access Table dialog to specify 
the name of the new table.

Limitations of the Direct Access Feature
The following limitations apply to the direct Access feature:

• There is no decimal data type support. If you modify the table structure of a 
Microsoft Access table within MI Pro and change a FLOAT type to a 
DECIMAL, the type changes to FLOAT.

• The MapBasic Pack Table statement will save a copy of the original Microsoft 
Access table without columns that MI Pro does not support. If a MS Access 
table has a MEMO, OLE, or LONG BINARY type column, it will be lost 
during a pack.

• Compact your database. Each time a table is renamed disk space is used up. 
The space used up is the space the original table was taking up. MI Pro 
renames the table when the structure is altered and when the rename 
statement is issued. An Access database may be compacted using the ODBC 
Administrator or Microsoft Access. To compact a MS Access database using 
the ODBC Administrator, see the ODBC Administrator’s online help for 
compact database. To compact a MS Access database using Microsoft Access, 
see Access’s online help for Compact a database to de-fragment and free disk 
space.

• MI Pro can only use and create Access tables compatible with Microsoft 
Access ’95, ’97, and 2000.

• Access recognizes Time in a Date/Time field. MI Pro only recognizes Dates. 
Therefore, any Time value is translated by MI Pro to 12/30/1899. 
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iewing or Modifying a Table
You can make changes to the structure of your table directly in MI Pro. You can add or 
remove fields, change the order, name, type, width, or index of any field. You can also 
specify or determine the projection of the table from this dialog. You can also check if 
the table is mappable (contains map objects).

To view or change the structure of the table: 
1. Choose Table > Maintenance > Table Structure. The View/Modify Table 

Structure dialog displays. 
2. Make the appropriate changes, or if you are simply viewing the structure use 

the scroll bars on the right of the field list to view the information about each 
field.

Keep in mind that you can only view the structure of a spreadsheet file that you bring 
into MI Pro.

aving a Table or a Copy of a Table
To save changes to map objects or data, you must save the table. To do so, choose File 
> Save Table. A dialog displays asking you to choose which table you want to save.

You can also save a copy of the table under a new name, using Save Copy As. This, in 
essence, creates a new table. This is helpful in several instances:

• When you want to retain any changes while preserving the original table. 

• When you want to save a table with a temporary column (from Update 
Column).

• When you want to create a new table before you make editing changes to the 
original table.

• When saving spreadsheet files that you wish to modify in MI Pro.

• When you want to save a table in a different projection.

• When you want to save table in a format compatible with MapInfo Version 2.

To save a copy of the table: 
1. Choose File > Save Copy As. The Save Copy of Table dialog displays. 
2. Choose the file to save and click OK.
3. Give the file a new name.

The original table remains unchanged and open for all further changes. The new table 
does not open immediately after its creation, but can be opened for use at any time.
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When choosing a name for your new table that begins with a number, MI Pro adds an
underscore to the beginning of the table name. For instance, your table 1streets.tab. 
will become _1streets.tab. 

Saving a copy of a raster table only saves a copy of the *.TAB file, not the image. You 
cannot change the projection of a raster or grid table by using Save Copy As. You 
must use Table > Raster > Modify Image Registration.

Since MI Pro supports long filenames, it is easier to give the new table a name that is 
descriptive and at the same time distinguishes it from the original file.

Note:  MI Pro does not maintain some objects when saving a copy of a Version 3.0
table in Version 2.x format. These objects include multiple polyline objects 
and polygons/polylines containing more than 8,000 nodes. In addition, 
region objects containing donut objects, while maintained, are handled 
differently in MapInfo 2.x.

Copying and Renaming a Table
Because a MI Pro table consists of two or more component files (states.tab, states.dat, 
states.map, etc.), all of these files for a particular table must be in the same directory. If
you move any of the component files to a different directory, you must move all of 
them. When you want to back up a table to diskette, you must back up all of the 
component files. 

Because each table has at least two files associated with it, you cannot change one file 
name without changing all the other associated file names. Otherwise, MI Pro would 
not know where to find all the files that constitute the table. Therefore, do not use a 
DOS command to rename files. 

To rename a table: 
1. Choose Table > Maintenance > Rename Table. The Rename Table dialog 

displays. 
2. Choose the table to rename and click OK.
3. Choose a new name for the table and click OK.

When you rename a table using this command, MI Pro also renames all associated 
files. 

Keep in mind that renaming a table will affect any workspaces that contain the 
original table. If you rename a table, you must also edit the workspace file (.wor) in a 
text editor or word processor to change the name of the table to reflect the new table 
name. You can also rename the table before you build the workspace.
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Renaming a raster file only changes the *.TAB file name. Renaming a grid file changes 
both the *.TAB and grid file name.

reating a Report for Your Data
MapInfo Professional includes the full report-writing functionality of Crystal Reports. 
Crystal Reports enables you to create reports of your tabular data. The Crystal 
Reports User’s Guide is included online so that you can get the most from this 
program. 

To create a report:
1. Choose Tools > Crystal Reports > New Report. The New Report dialog 

displays. It lists all the open tables.
2. Click on the table you want to create a report for, and click Report. The 

Crystal Reports user interface displays. 
3. In Crystal Reports, Choose Report > Report Expert to display the Create 

Report Expert dialog. The Report Expert walks you through the selection of 
data, fields, fields to sort by, fields to total, and styles for your report. Click 
Preview Sample to see a sample of your report on the screen. 

4. Choose File > Print to print your report. 

For information on creating a report using the program’s full complement of features, 
please consult the Crystal Reports User’s Guide. If you haven’t installed it on your 
system, see Chapter 2, Installation for information on how to do so. 

ppending Rows to a Table
Use Table > Append Rows to Table when you want to attach the records from one 
table to another. The two tables should have the same set of columns in the same 
order.

To append data to another table:
1. Choose Table > Append Rows to Table. The dialog displays.
2. Specify the table containing the records you want appended.
3. Specify the table to which the records will be appended and click OK.
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If the corresponding columns do not have the same data type, a best fit is done to 
convert the data to the appropriate type. If the order of the columns is not the same 
between the two tables, use Table > Maintenance > Table Structure to reorder the 
columns before using Append Rows to Table.

Note:  If tables are mappable, the bounds of the map in one table must be large 
enough to allow objects from the other table to fit within it. Otherwise, the 
objects will be  distorted to the bounds of the Mapper. Use the Check/Set 
Coordsys Bounds tool to alter the map bounds of the table if this occurs.

Deleting a Table
Deleting a table allows you to remove the .tab file and all component files associated 
with the table. 

To delete a table:
1. Choose Table > Maintenance > Delete Table. 
2. Choose the table to delete and click OK.

A message displays to inform you that the table will be permanently deleted and the 
operation cannot be undone.

3. Click OK and MI Pro deletes the table. 

Deleting a raster table will only delete the *.TAB file. Deleting a grid file removes both
the *.TAB and grid file.

Packing a Table
Packing a table allows you to compress tables to take up less disk space. You can 
choose to pack only tabular data or graphic objects or both. Packing tabular data 
removes deleted records.

When you pack a table, MI Pro requires that you have twice as much free space as the 
table takes up to handle a copy of the database as a scratch file.

To pack a table:
1. Choose Table > Maintenance > Pack Table. The Pack Table dialog displays. 
2. Choose the appropriate table and whether you want to pack tabular or 

graphic data, or both. 
3. Click OK.

Note: Packing a table can corrupt customized labels saved to a workspace. If you are 
going to be working with customized labels, pack the table before you create the 
labels. 
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dding Data to a Table
One important operation in maintaining tables is the ability to update the data 
contained in the table. MI Pro’s Update Column feature allows you to: 

• Add a temporary column or update an existing column with data from 
another table.

• Update a subset of a table.

• Place graphics information into visible columns.

Adding a Temporary Column to a Table
Often you will need to bring data from one table into another. In MI Pro you can either 
create a temporary column in the table you wish to update or update an existing 
column. In both cases, use Table > Update Column to bring over the information 
automatically. 

Note: If you plan to update a table with data from another to create a thematic map, 
you can access the Update Column dialog directly from the thematic dialog. See 
Chapter 11, Using Thematic Mapping to Analyze Your Data, for details.

You have tremendous flexibility with how and what information is transferred, such 
as performing aggregate functions to transfer averages, minima, maxima, sums, 
weighted averages, and proportional sums. You can also create expressions to derive 
additional information from the data.

Once the information is transferred, any changes you make to the original table will 
be automatically updated in the temporary column. To save the temporary column, 
use File > Save Copy As. You can also save the information if the table is part of a 
workspace that you save. If the information is saved with Save Copy As, the values 
will remain the same. If saved in a workspace, the column is recomputed whenever 
the workspace is opened. Also, the Update Column dialog remembers the column 
that was updated and the expression that was used for updating the column, the last 
time the update was run.

For example, you want to calculate the sum of your customers’ order amounts and 
report the information by state. Update Column creates a temporary column in the 
states table to store the information from the customer table. During the operation 
each customer’s order amount is calculated with other customers from the same state. 
A Browser of the states table will show the sum of order amount by state. 

To do this, choose Table > Update Column and fill in the Update Column dialog as 
shown below:
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Notice the Join button is activated when you select Add new temporary colum. In this 
example the Join operation will match columns in each table based on a common 
column name (where State from table STATES matches State from table CUSTOMER). 
In other situations you can match information based on common geography.

At the Calculate list box, choose Sum from the list that includes Value, Avg, Count, 
Min, Max, Sum, WtAvg, Proportion Sum, Proportion Avg, and Proportion WtAvg. 
(For a discussion of these functions, see Aggregating Data with Update Column later 
in this chapter.)

At the Of list box, MI Pro automatically defaults to the first numeric field in the table 
when you choose any function other than value.

Click OK when through. MI Pro updates the STATES table and reports the order 
amount by state in a Browser. 

When the order amount of a customer changes, you can simply make the change in 
the CUSTOMER table. MI Pro automatically updates the sum of the order amount for 
that state in the STATES table. To save the temporary column, choose File > Save Copy 
As. 
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Updating a Subset of a Table
For a quick visual way to update your table, select the objects in the Map window and 
use Update Column to update the table with the new value. This is useful when you 
want to update a number of objects with the same value. 

For instance, you want to include Southeast in the District column of the states table. 
First create the District column (Table > Maintenance > Table Structure). Add a field 
for Districts. Re-display the states table in a Map window. Select the appropriate states 
with the Marquee tool (or other selection method). Choose Table > Update Column 
and fill in the dialog as illustrated below. Be sure to put the value in quotes so MI Pro 
does not treat it as a new column name.

Click OK. MI Pro creates a query table of the southeastern states with the District 
column containing the value Southeast. Be sure to save the table to preserve the new 
information.
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Parsing Data from One Column to Multiple Columns
If you have imported data into MI Pro from another format, there is always the chance 
that the data will not come in exactly the way you want it. In some instances, items 
that should appear in separate columns may be put together in one column. The 
following is a series of column updates that parses one column of full names (first, 
middle, and last) into three parts. It works even if there is no middle name, or if there 
is only a last name. 

1. Choose File > Open and open the table to be modified. 
2. Next, you need to add three new columns to your table. Choose Table > 

Maintenance > Table Structure. Add two character columns of size 15. Call 
them FIRST and MIDDLE. Then add a character column called LAST of size 
30.

3. First put the full name into the column called LAST by choosing Table > 
Update Column. Fill in the Update Column dialog as shown below.

The Column to update is LAST, and we get the Value from the column that 
has the full name in it. Remember we are only working with one table, so the 
Table to Update and Get Value From Table should be the same table. In the 
following example, the table is TABLE1 and the full name column is 
your_full_name_column. You should fill in your own values for these two 
items.
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4. To parse the first name out of the full name column, choose Table > Update 
Column. Fill in the Update Column dialog as shown below.

The Column to Update is FIRST, and the Value is: left$(LAST, instr(1,LAST,” “)).

5. To parse the last name out of the full name column, choose Table > Update 
Column. Fill in the Update Column dialog as shown below.

The Column to update is LAST, and the Value is: Right$(LAST, Len(LAST)-
Instr(1,LAST,” “)).
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6. To parse the middle name out of the full name column, choose Table > Update 
Column. Fill in the Update Column dialog as shown below.

Update the MIDDLE column with the Value: Left$(LAST, Instr(1,LAST,” “)).

7. Then update the LAST column again by choosing Table > Update Column 
and filling in the dialog as shown below.

The Value is: Right$(LAST, Len(LAST)-Instr(1,LAST,” “)). 
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Placing Graphic Information in Visible Columns
Update Column is also useful to put graphic information into columns so that it is 
visible. Tables that contain map objects store the graphic information about these 
objects invisibly. By using Update Column, you can bring some of that information 
into a column so it can be viewed in a Browser. Update Column with CentroidX(Obj), 
CentroidY uses the Session Projection Preferences (if set), otherwise it defaults to 
Longitude/Latitude.

For example, you want to display the longitude and latitude coordinates of a table of 
radio station point locations in a Browser. In this example, you are only working with 
one table, RADIOLOC. But you still use the same Update Column dialog as in the 
Add Temporary Column example.

If you first view the table structure (Table > Maintenance > Table Structure), you do 
not see any fields that contain longitude and latitude coordinates since that 
information is kept internal to the table. Before you can update the table, you must 
add two columns (for instance, call them Long and Lat) to contain the coordinates. 
When you change the structure of the table in this way, the table will be removed from 
any open window. The table is still open, however, and ready for updating.

Choose Table > Update Column and specify RADIOLOC as the table to update and as 
the Get Value From Table. Choose Long as the Column to Update. In the Value box 
you must specify an expression to retrieve the longitude. Click on the Assist button to 
bring up the Expression dialog. From the Functions drop-down list choose CentroidX. 
MI Pro returns the expression CentroidX(obj). Click OK to return to the Update 
Column dialog. The expression is now stated in the Value box. Click OK. MI Pro 
calculates the information and places a longitude coordinate for each radio station in 
the Long column.
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Repeat the process to retrieve the latitude coordinates using the expression 
CentroidY(obj). Choose File > Save Table to permanently store the coordinates in the 
RADIOLOC table.

Note:   If you edit the objects, which, in effect, changes the coordinates, you must 
go back into the columns to make the changes. It will not automatically 
update. 

Aggregating Data with Update Column
MI Pro provides a number of powerful aggregating functions that allow you to derive 
new information. These features are available in Table > Update Column when you 
specify two tables in the Update Column dialog. The aggregate expressions include 
Average, Count, Minimum, Maximum, Sum, Weighted Average, Proportion Sum, 
Proportion Average, and Proportion Weighted Average. Each is defined below.

Aggregate expressions Description

Average Calculates the average of the values for all records in a group.

Count Counts the number of records in a group.

Minimum Finds the lowest value for all records in a group.

Maximum Finds the highest value for all records in a group.

Sum Calculates the sum of the values for all records in a group.
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Note that average, count, min, max, sum, and weighted average operate on data 
values only. The proportion functions take geographic relationships into account. 

Example Using Proportion Sum and Proportion Average
To illustrate the proportion sum and proportion average functions, consider this 
example.

You want to determine what proportion of the population in your county is covered 
by a flood zone. You have two tables: a Towns table that contains town boundaries 
and population statistics, and a Flood table that contains a region object (circle in 
illustration) that represents the area of past flooding. 

The flood zone covers three towns. As shown in the following illustration, MI Pro 
calculates the proportion of the population in those three towns that is within the 
flood zone and reports the sum in a temporary column in the Flood table. Similarly, 
MI Pro calculates the proportion average of property values for the same areas. 

Proportion sum is best used for raw data (population, housing units, etc.) while 
proportion average is used for derived data (median income, average housing costs, 
etc).

Weighted Average Gives more weight to one value over another when averaging.

Proportion Sum A sum calculation that is adjusted based on how much of one 
object is within another object. 

Proportion Average An average calculation that is adjusted based on how much of 
one object is within another object.

Proportion Weighted 
Average

A weighted average calculation that is adjusted based on how 
much of one object is within another object.

Aggregate expressions Description
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Example Using Proportion Weighted Average
Proportion Weighted Average is similar to proportion average except that you add a 
weighting factor to the average calculation. That weighting factor is another data 
column in your table.

For example, you want to find the best location in the area to build a new upscale 
shopping mall. You believe the mall will draw people from a 20-mile radius. You are 
considering five potential sites and you want to place the mall where you can find the 
optimum combination of population and income.

To do this, create a temporary column in your Mall table with data from your Towns 
table that contains the proportion of each town’s population affected by the potential 
mall. Use the median income for each town as the weighing factor. In this example MI 
Pro determines the join automatically to be where the town boundaries intersect the 
20-mile buffers around the potential sites. 
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The best location of the mall will be at the site that returns the highest value of the 
temporary column, as shown in the Browser below. 
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Accessing Remote Database 

Data

MapInfo Professional®  enables you to access 
remote database data through its ODBC 
connectivity support and the Oracle Spatial 
Object support. The MI Pro ODBC connectivity 
support supplies many ODBC drivers that you 
can easily install.  Oracle spatial databases 
enable you to store spatial objects with your 
conventional data in the same database. This 
enables you to read and write geographies in 
Oracle Spatial without the need for a 
middleware product such as MI Pro’s 
SpatialWare, or SDE. You also gain better 
performance through the Oracle Call Interface 
(OCI). In addition, Oracle applications can 
make use of this same spatial or non-spatial 
data through other interfaces (ODBC, OCI, 
JDBC, PL/SQL, HTTP, IIOP, etc.) or use other 
spatial or non-spatial tools (MapInfo 
Professional, ArcView, Intergraph, Excel, Forte, 
Formida, etc.).
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Prerequisites for Accessing Remote Databases
MI Pro DBMS connectivity requires many pieces to be in place to function properly.

MI Pro does not install the following:

• Your database management system of choice (Oracle, MS Access, Informix,  
etc.) — required only if your DBMS is on the same PC as MI Pro.

• Network support as required by your DBMS (Oracle-SQL*NET; MS Access-
none required).

MI Pro installs the following as part of the custom installation process:

• (Optionally) Merant’s ODBC drivers

• MI Pro ODBC support

If the prerequisites which MI Pro does not install are not in place when you install the 
MI Pro portion of the DBMS support, various warning messages will appear 
explaining that you do not have the required DLLs. It is safe to finish your MI Pro 
installation, then add the prerequisite support. You can then customize your data 
sources in the DBMS Administrator instead of returning to the MI Pro installation 
media.

Oracle Spatial Support
Oracle Spatial is an implementation of a spatial database from Oracle Corporation. 
You can install it in addition to the MI Pro ODBC Connectivity component. Although 
it has some similarities to the previous Oracle SDO relational implementation, it is 
significantly different. Oracle Spatial maintains the Oracle SDO implementation via a 
relational schema. However, MI Pro does not support the Oracle SDO relational 
schema via the Oracle Call Interface (OCI). MI Pro does support simultaneous 
connections to Oracle Spatial through the OCI and to other databases through ODBC. 
MI Pro does not support downloading Oracle spatial geometry tables via ODBC using
the current ODBC drivers from Merant. 

For information on how MI Pro handles Oracle’s geometry types, and how Oracle 
handles MI Pro’s data types, see Appendix F, DBMS Connectivity Support.

Oracle Spatial Requirements
To connect to Oracle Spatial within MI Pro, you must have the Oracle Spatial, v.8. 1.6, 
or v.8.1.7, 9i client installed. See your Oracle documentation for detailed information. 
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Oracle 8.1.7
MI Pro’s implementation of  v.8.1.7 of Oracle Spatial does contain any significant 
changes from from v.8.1.6. 

Oracle 8.1.6 Overview
Revision 8.1.6 of Oracle Spatial has undergone some significant internal changes since 
v. 8.1.5.  Here is a summary of the changes: 

• New format for spatial objects

• New requirement for ordering nodes of polygons

• New metadata tables

Oracle 8.1.6 also supports the 8.1.5 format of their spatial object. 

Oracle9i Overview

MI Pro Support
MI Pro supports  Oracle Spatial, v. 8.1.6, v.8.1.7, 9i with the same functionality that it 
supported for v. 8.1.6. It will read and write spatial tables from the database and 
execute spatial queries against them. 

MI Pro GIS Extension Cartridge
MapInfo Professional supports the GIS Extension Cartridge by allowing GIS 
Extension functions to be passed through to the server for execution. For example, 
users can send an MI Pro GIS Extension style query through either MapBasic or by 
entering it in the expert box of the Open DBMS dialog. See your SpatialWare 
documentation for details of the GIS Extension functions.  

Installing DBMS Support
To install the MI Pro product component of DBMS support, select DBMS Support 
when installing MI Pro. If you already installed MI Pro without DBMS support, you 
can re-run the MI Pro installation to install it. You can install either the MI Pro ODBC 
Connectivity support, or the Oracle Spatial Object Support for MI Pro, or both. 

To install DBMS Support:
1. Insert the MapInfo Professional CD. The MapInfo CD Browser displays. 
2. Choose Install Products.
3. Choose DBMS Support. 
4. Click Yes to accept the software agreement.
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5. Select the product and click Next.
6. Enter the path.
7. Select the DBMS Components to install. You can install the MapInfo ODBC 

Connectivity component, the Oracle Spatial Object Support for MapInfo, or 
both. 

8. Select the Program Folder. MapInfo is the default. Click Next to begin loading
the DBMS setup files. When setup is complete, the DBMS Driver installer 
appears for you to install the drivers you will use. You can select drivers now 
or install drivers at a later time by running the MDAC/DAO/ODBC Installer 
from the Add/Remove Programs group in the Windows Control Panel. 

9. Click Finish to complete installation of DBMS Support. 

Installing ODBC Drivers
When you installed the MapInfo ODBC Connectivity support through the DBMS 
support installation process, the ODBC drivers  you selected were put on your hard 
drive in a compressed format. They will be uncompressed and installed automatically
with the MapInfo Professional DBMS Installer.

You can also use the DAO/ODBC Installer any time you need to install additional 
drivers. You do not need to return to the MapInfo Professional CD to install drivers. 
You must, however, have DBMS support installed to use the  Installer. 

To install an ODBC driver:
1. Run the DAO/ODBC Installer in the Add/Remove Programs group in the 

Windows Control Panel.  
2. Click Next to continue with the Setup.
3. The following dialog displays.
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4. Select the corresponding check boxes next to the drivers you want to install. 
To cancel a selection, clear the check mark by clicking the driver again. Click 
Next to complete the driver installation.

After installing the drivers, you can begin creating data sources.  

reating New Data Sources

Configuring Data Sources
To access data from the different databases, you must set up a DBMS data source for 
each database you want to access. An exception to this is Oracle  Spatial. No data 
source is used when connecting using OCI. A DBMS data source contains the 
information you need to access that database. For example, an SQL Server data source 
names the SQL Server database, the server on which it resides, and the network used 
to access that server. You create a data source for each SQL database whose data you 
want to download into a MI Pro linked table using the ODBC Administrator.

Configuring data sources involves associating a DBMS driver with a data source. This 
association is what enables MI Pro to connect to and find the data defined with a 
particular data source. 
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To create a new data source:
1. Run the ODBC Administrator. You can start the Administrator from the 

Windows Control Panel. When you start the ODBC Administrator, the ODBC 
Data Source Administrator dialog displays. 

2. Click the Add button. The Create New Data Source dialog displays. It 
displays a list of all the installed drivers, including the driver name, version, 
and manufacturer. 

3. Click on the driver you want to associate with the database to select it. 
4. Click Finish. A driver-specific Setup dialog box for the data source appears. 

(The source of this dialog is the ODBC Administrator.)

Since each driver is different, each data source requires a different 
configuration. Because of this, each data source has a unique Setup dialog 
box.

In general, configuration usually includes the data source name, description, 
and server name. Optional configurations might include server list, default 
logon ID and application name. (Refer to the Merant DataDirect ODBC 
Drivers Online Help topic, Configuring Data Sources, for the data source you 
want to configure.) There is a help file for each driver distributed as part of MI 
Pro and is located in the Windows system directory. The help files are named 
as follows:  MIdrv17.HLP, where drv is the name of a driver. For example, 
MIINF17.HLP is the help for Informix. 

5. Type the required information about the data source in the Setup dialog. 
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6. Click OK when you have finished configuring your data source. The driver 
writes these values to the ODBC.INI file. These values are now the defaults 
whenever you connect to the data source.

You can also create a data source on the fly when you are connecting to a data source. 
See Connecting to a Data Source, in the Downloading Linked Tables section of this 

chapter for more information. 

toring and Retrieving Spatial Data in a Remote Database
To use your remote database tables with MI Pro most effectively, you need to set them 
up so that you can store coordinates or more complex spatial data and then retrieve 
them. This will also allow you to geocode your remote table and assign coordinates to 
each record in the table.  

There are four prerequisites for storing and retrieving spatial objects in a DBMS table: 

• Coordinate values for the objects must be stored in columns of the remote 
table as numbers, or as a spatial column if the database supports it, such as 
SpatialWare, Oracle Spatial, or Sybase.

• A spatial index column may be included to increase performance on queries 
against the coordinates.

•  You must create a special table on the DBMS system known as the 
MapInfo_MapCatalog. You create only one catalog per database.

• You must supply information about mappable tables to the MapInfo 
MapCatalog using the Make Table Mappable command.

Prerequisite 1 – Storing Coordinate Values in a Remote Table
The coordinate values for the spatial data must be stored in columns of the remote 
table.  This is a data creation task and can be done at any time. Possible methods for 
adding the spatial columns include:

• There may already be existing data.

• Use the MI Pro EasyLoader application to upload an MI Pro table to any of 
the databases supported by MI Pro.

• Make a remote table mappable in order to geocode. See, “Making a DBMS 
Table Mappable (In order to Geocode Table)” later in this chapter.

• Add coordinate values to an MI Pro table, export it to a text file, and import it 
to your database.
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MI Pro EasyLoader  
The MI Pro upload utility, MI Pro EasyLoader, uploads MapInfo .tab files into a 
database table. This is a stand-alone, client-side utility that is specific to MI Pro data 
sets. A DBMS link is used on the client side for data transfer.  EasyLoader now 
supports all MapInfo-supported databases. 

EasyLoader runs on Windows 98, Windows NT, Windows 2000, Windows XP 
Professional and Windows XP Home, and supports connections to the following 
spatial Database Management Systems:

• INFORMIX–Dynamic Server (IDS) with the SpatialWare DataBlade (The IUS 
driver must have a version of 2.8 or higher.) 

• Oracle Spatial version 8.1.6 or later

• SpatialWare 4.6  for SQL Server

EasyLoader has been expanded to run with the following spatial schemas on standard 
databases:

• XY tables (Oracle, Informix, Access, SQL Server)

• MICODE tables (Oracle, Informix, Access, SQL Server)

These schemas utilize spatial points in standard databases.

EasyLoader is packaged on both MapInfo Professional and SpatialWare CDs. On 
SpatialWare CDs, EasyLoader software is located under the ”pc” subdirectory. 

To run the EasyLoader upload utility, copy it from the SpatialWare CD onto a  
Windows 98, Windows NT, Windows 2000, Windows XP Professional, Windows XP 
Home platform, and then run the ”EasyLoader.exe” executable file. 

In MI Pro, EasyLoader is installed to the Tools directory and can be run very easily 
from the Tool Manager:  

1. Choose Tools>Tool Manager. The Tool Manager dialog displays.
2. Choose EasyLoader from the Tools List and select the Loaded check box. 

Select the Autoload box to load the tool automatically when you start MI Pro. 
3. Click OK. The EasyLoader utility is added to the Tools menu. 
4. Choose Tools>EasyLoader to open the utility. 

When you open the utility, the MI Pro EasyLoader dialog displays. The user interface 
enables you to connect to a server (using ODBC) or Oracle Spatial server and select 
the tables that you want to upload.  
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When you connect to a server using ODBC, you will be asked to select a data source. 
To connect to the Oracle Spatial server, you must have the Oracle client installed. 

When you have connected to a server, the Tables button becomes available. It displays 
a dialog that enables you to select the MI Pro tables to upload.  The selected tables 
display in the MI Pro tables list. To change the tables in this list, you must use the 
Tables button.

The Upload button becomes available after you have selected the tables to upload. Be 
sure to specify your table options before you upload the tables. The Options are 
described below: 

• Append to Table–The MI Pro table will be appended to the server table if the 
server table exists and the structure of the two tables match.  Otherwise, you 
will get an error and the table will not be uploaded.

• Replace/Create Table–The server table of the same name is first dropped if it 
exists, then a new table is created to match the MI Pro table being uploaded. 
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• Append All to One Table–All MI Pro tables listed are uploaded to a single 
server table.  The server table name is the one visible in the Server Table box.  
This feature is meant to be used to upload tables with the same structure and 
symbology to one table.  For example, instead of creating a new table for each 
street layer, select the Append All to One check box, and only one table will 
be created.  Then all of the tables will be appended to this table.  Note: It is 
possible that some tables will not be appended if their structure differs.

When used with the Append to Table option, the tables will all be appended 
to the existing server table.

When used with the Replace/Create Table option, the server table will be 
dropped, a new table created, and all tables listed will be appended to that 
one.

Note: All tables should have the same projection.

• Grant Public Access to Table–PUBLIC is granted all access to the server table.

• Exclusive Use of Table–You can speed up load time on large tables 
significantly if you know that you will be the only one attempting to update 
the table. Note, however, that specifying this option does not guarantee that 
the loader will obtain exclusive use, you must guarantee that to the loader.

The loader checks on the current maximum value of the primary key column 
(prinx) after each commit to ensure that it detects any other entries that may 
have been made by other processes. This option will prevent that check from 
occurring, which can make a significant change to the run time for large 
tables.

• Create Unique Index–A unique index is created on the column sw_member 
for SpatialWare or mi_prinx for Oracle Spatial. The mi_prinx column is a 
sequential number that is generated by the loader.

• Create Spatial Index–For SpatialWare tables the index is created on the 
geometry column and is called hg<table_name>ind. A spatial index is created 
and Update Statistics is executed after an rtree index is created for 
SpatialWare.

For Oracle Spatial tables the spatial index is created on the geometry column 
and is called <table_name>_SX. The index tiling level is based on the 
SDO_TUNE.ESTIMATE_TILING_LEVEL function. For tables with fewer than 
7500 rows, the tiling level is restricted to 8. After the index is built the 
ANALYZE table function is run on the index table.

You may also build your own spatial index to suit your specific needs. If you 
choose to do this, clear this check box to save time in loading.
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For more information on how to run EasyLoader, please view the online help 

provided with this utility, ”EasyLoader.HLP”. 

Prerequisite 2 – Creating a Spatial Index Column
To increase performance on queries against the coordinates, a spatial index column 
can be included. This is done as part of the sample upload applications, if it is desired. 
This is a data creation task and can be done at any time.

Prerequisite 3 – Creating a MapInfo_MapCatalog
Use EasyLoader to create a MapInfo_MapCatalog or DBMS cataolog utility described 
in the next section. 

MI Pro stores information about where the spatial columns are located in a special 
table on the DBMS known as the MapInfo_MapCatalog. There must be one catalog 
per database. The application MIODBCAT.MBX can be used to create this catalog for 
each database: Oracle 8, 9, Informix, SQL Server, and MSAccess respectively. These 
applications will need to be customized for any other DBMS, or you can follow the 
procedure for manually creating a map catalog.

This is a one-time only task per database and is required before any tables on that 
database can be mapped in MI Pro.  

Automatically Creating a MapInfo_MapCatalog
To create a MapCatalog automatically, use the DBMS Catalog utility 
(MIODBCAT.mbx).  This utility is part of the toolset that ships with MapInfo 
Professional and is available from the Tool Manager. To load the utility, choose Tools > 
Tool Manager. In the Tool Manager dialog, select the Loaded check box next to the 
DBMS Catalog tool and click OK. The tool is now located as a command in the Tools 
menu for the current MI Pro session. To have the tool load automatically every time 
you start MI Pro, select the Autoload check box next to the tool. 

To use DBMS Catalog:
1. Choose Tools > MapInfo DBMS Catalog to create the catalog. 

The following dialog displays:
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2. Click Create Catalog, and select the database for which you want to create a 
MapCatalog.

Manually Creating a MapInfo_MapCatalog
If you need to manually create the MapInfo_MapCatalog, it should be created by your 
database administrator.

1. Create the user MAPINFO with the PASSWORD  ***** in the specific database 
where the mappable tables are located. 

2. Create the table MAPINFO_MAPCATALOG in the database.

The Create table statement needs to be equivalent to this MI Pro create 
statement for the specific remote database.

Create Table MAPINFO_MAPCATALOG(

SPATIALTYPE         Float,

TABLENAME           Char(32),

OWNERNAME           Char(32),

SPATIALCOLUMN       Char(32),

DB_X_LL             Float,

DB_Y_LL             Float,

DB_X_UR             Float,

DB_Y_UR             Float,

COORDINATESYSTEM    Char(254),

SYMBOL              Char(254),

XCOLUMNNAME         Char(32),

YCOLUMNNAME         Char(32),

RENDITIONTYPE       Integer),

RENDITIONCOLUMN     VarChar(32),

RENDITIONTABLE      VarChar(32),

NUMBER_ROWS         Integer
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It is important that the structure of the table is exactly like this statement. The 
only substitution that can be made is for the databases that support varchar or 
text data types. These data types can be substituted for the Char data type.

3. Create a unique index on the TABLENAME and the OWNERNAME, so only 
one table for each owner can be made mappable.

4. Grant Select, Update, and Insert privileges on the
 MAPINFO_MAPCATALOG to Public. This allows the users to make the 
table mappable. The delete privilege should be reserved for database 
administrators.

Spatial Index Types
 The table below lists the supported Spatial Index types.  

Updating Data Bounds in the MapInfo_MapCatalog
The MapInfo_MapCatalog currently contains the bounds of the data within the table. 
This is used to determine the map view if the table is opened as the first map in a 
window. The bounds are set either by the EasyLoader when the data is loaded or from 
the MapInfo Professional tool, Set Minimum Bounding Rectangle utility. 

In previous version of MI Pro, the bounds were not reset if new objects outside the 
current bounds were added to the table. The bounds are now automatically adjusted 
when inserting or updating spatial objects. If the object is outside the MBR, it will 
expand the MBR and update the MapInfo_MapCatalog.  Deleting objects from the 
table does not alter the bounds. 

Prerequisite 4 – Making a Remote Table Mappable in MI Pro
MI Pro holds catalog information about mappable tables from the Make Table 
Mappable command. Creating the entry for a table is a once-per-table task and is 
required before this specific table can be mapped in MI Pro.

Spatial Index Type Type Number

MapInfo MICODE schema (any database) 1

XY schema (any database) 4

MapInfo IUS_MM_SW 9

MapInfo IUS_MM_XY 10

Spatialware blade for IUS 11

Oracle  Spatial 13 
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The Make DBMS Table Mappable command makes a remote SQL database table 
(DBMS table) mappable in MI Pro. Any MI Pro table may be displayed in a Browser, 
but only a mappable table may have graphical objects attached. Only mappable tables 
may be displayed in Map windows.

In the Make DBMS Table Mappable command you provide MI Pro with the following 
information from the remote database table so that the table can be mapped in MI Pro:

• The column(s) containing the spatial data to map the table (not applicable to 
relational Oracle SDO).

• The projection used by the remote database table.

• The spatial index column from the remote database table (used by MI Pro to 
speed access of the spatial data and improve performance).

• The symbol to use for objects.

• Per row styles, if your table is set up for it, and the MapInfo_ MapCatalog has 
the appropriate column structure.

• Object type for Spatial databases. 

MI Pro takes this information and stores it in a table called the MapInfo_MapCatalog. 
Every time you use a DBMS table MI Pro checks the catalog to see if the table is 
mappable. As a result, you only have to make a DBMS table mappable one time. It 
will always remain mappable. However, one spatial index column entry per table is 
allowed in the Map Catalog. Therefore, only one spatial column can be mappable at a 
time. If the table has more than one spatial column and you want to map another 
spatial column, you must drop the spatial column currently in the Map Catalog and 
make the table mappable using the new column.

MakIng a DBMS Table Mappable
To make a DBMS table mappable:

1. Choose Table > Maintenance > Make DBMS Table Mappable. The Select 
DBMS Table dialog displays. Here, you select the DBMS table you want to 
make mappable.

2. Open the appropriate remote connection if you hav not done so already. The 
Open Table dialog displays. 
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Connection Type This is either ODBC or Oracle for Oracle Spatial.

Places Bar Quickly access the specified directory. There are four MapInfo 
Professional Places options: Tables; Workspaces; Import Files; Remote 
Tables. Designate each directory path in Options > Preferences> 
Directories.

If the operating system is Windows 2000, select MapInfo Places to 
display MapInfo Professional specific folders, or choose Standard 
Places to display the default places.

Owner This field is present only for data sources that make use of owners 
(such as Oracle). This field allows you to list tables owned by 
different users. 

Filter Tables The Filter button lets the user select which types of tables to list. The 
default shows Tables, View, and Synonyms, and hides System tables.

New Connection 
button

Press this button to display a series of dialogs to establish a new 
connection. Refer to Open DBMS Connection for more information.

File name Type or select the filename you want to make mappable.
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Once you have selected a DBMS Table, the Make Table Mappable dialog displays.

MI Pro supports long filenames. This allows you to use up to 260 
characters when naming your file. In addition, any one name within 
your directory path can be up to 255 characters.  You can insert spaces
in the filename and long filenames can have more than one “.” in 
them. When using more than one “.”, you must remember to type in 
the file extension in order to save the file correctly.
For example you can name a table as follows: 
     \\soup\for.lunch.today.and.everyday.tab       

Files of type If there are multiple existing connections open, the last made 
connection displays in the Connection type box. To change 
connections, choose a connection from the pull-down list. 

Database Highlight the name of the table you want to select to make mappable.

OK Selects the table to make mappable and brings up the Make DBMS 
Table dialog.

Cancel Cancels the selection.

Help Access online help.

Connection Type This is either ODBC or Oracle for Oracle Spatial.
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Index Type The spatial index type of the column that has the spatial information 
in the DBMS table. The spatial index provides a fast way for MI Pro to 
access the spatial data in the table. The four index types to choose 
from are SpatialWare, Oracle Spatial, IUS SW Blade, IUS MM XY 
Blade, IUS MM SW Blade, MI Pro, and XY Coordinates (i.e., no 
index).

Index Column Required for all index types except XY Coordinates. Select the name 
of the spatial column, or, in the case of a MI Pro index type, the name 
of the MICODE column.

X Coordinate, Y 
Coordinate

Required only if you selected the XY coordinate or MI Pro index type. 
Select the X and Y columns that contain the point data you wish to 
map.

Object Type For spatial databases, select point, linear, or region object types. 
(Defaults to point object type for Oracle SDO, MI Pro, and XY 
Coordinates index types.)

- point: indicates the table only can contain point objects
- linear: indicates the table can only contain lines and polylines 
- region: indicates the table can only contain region objects

Object Style Depends on the object types that the mappable table can contain. You 
can set the default style that the objects will use for display when they 
are downloaded.

Symbol Displays the Symbol Style dialog where you can select a default 
symbol for the point data.

Line Displays the Line Style dialog where you can select a default symbol 
for the line data.

Region Displays the Region Style dialog where you can select a default 
symbol for the region data.

Per Row Styles Activates per row styles for the table, which enables you to use  
different object styles on the remote table. You can modify the 
styles of individual objects or groups of objects and save them 
to the DBMS table. 

OK Make the DBMS table mappable with the chosen spatial data.

Cancel Cancel the operation.

Help Access online help.

Projection Activates the Choose Projection dialog. Specify the projection for the 
DBMS table. The projection must match the projection used by the 
corresponding remote database table. For information on the Choose 
Projection dialog, see “Projection Button.”
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Making a DBMS Table Mappable (In order to Geocode Table)
1. Add two numeric columns in the Table on the database server to hold the X 

coordinates and one for the Y coordinates.
2. In MI Pro, choose Table >Maintenance > Make DBMS Table Mappable. Select 

the table you want to make mappable.
3. The Make Table Mappable dialog will appear. Choose XY Coordinates for the 

Index Type, X column for the X Coordinate and the Y column for the Y 
Coordinate.

If your MapCatalog has the capability to support styles, you can set up the 
table to use per row styles. Simply select the Per Row Styles check box and 
choose the column that you want to obtain the style attributes.  The only 
column types available for use with the Per Row Styles option are character or 
varchar columns.

This option is only available when the MapCatalog has the structure to 
support styles. It must contain the columns RENDITIONTYPE, 
RENDITIONCOLUMN, and RENDITIONTABLE.

4. Next, Open the remote table in MI Pro using File >Open. You will get a blank 
mapper. Then use Table > Geocode to geocode your records. 

5. Once you have completed geocoding use File >Save Table to save the changes 
to the remote database. 
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Answer “Yes” to Refreshing the table in order to see your points.

Using Per Row Styles
Per Row Styles allows the use of different object styles on a remote database. You can 
modify the styles of individual objects or groups of objects and save them to a DBMS 
table. 

To use Per Row Styles, the DBMS table must be set up correctly, and your MapInfo 
MapCatalog must have the appropriate structure:

• The MapCatalog must contain columns that support the use of styles. They 
are: RENDITIONTYPE, RENDITIONCOLUMN, and RENDITIONTABLE. If 
you have created the MapCatalog with EasyLoader version 6.6 or later, these 
columns are already in the MapCatalog. If you are using a pre-v. 6.6 version of 
the MapCatalog, a script is provided that will alter the definition of the 
MapCatalog to include these columns. Adding these new columns will not 
cause problems for older versions of MapInfo Professional, MapX, or 
MapXtreme.

• The map table itself must have a character column wide enough to store the 
complete style string. Style strings vary in width. We recommend a minimum 
of 50 characters be provided. If you plan to use custom symbols, which use 
much longer strings, allow 200 characters. 

• The entry for the table in the MapCatalog must be set correctly. This means 
that the RENDITIONTYPE is 1, and the RENDITIONCOLUMN contains the 
name of the column that will contain the style string. This entry is set by 
EasyLoader 6.6 or later if the MapCatalog contains the new columns, or it 
may be set using the Make Table Mappable function.
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Changing the Symbol Style in a Mappable DBMS Table
The Change DBMS Table Symbol command allows you to change the symbol 
attributes for the point objects in a mappable DBMS table. 

1. Choose Table > Maintenance > Change DBMS Table Symbol. The Select 
DBMS Table is displayed. The dialog will only display mappable DBMS 
tables.

2. Once you have selected a DBMS Table, the Change Table Object Style dialog 
appears.

Use the dialog to specify new style attributes for the objects in the selected 
table. 

3. You must close, reopen, and refresh the linked table for the style change to 
take effect.

DBMS Tables and Linked Tables
A linked table is a special kind of MI Pro table that is downloaded from a remote 
database and retains links to its remote database table. The alternative is a Live Access
table, which is described later in the chapter. 

You can perform most operations on a linked table that you do for a regular MI Pro 
table. For instance, you can view, edit, copy, save, and rename a linked table just as 
you could a regular MI Pro table. However, there are some things you can’t do to a 
linked table. For instance, you cannot pack a linked table, nor can you modify the 
table structure of a linked table (but you can modify its MI Pro index structure). 

Tables can be downloaded from a relational database management system such as 
Oracle, or Access. These downloaded tables can be used standalone or remain linked 
to the original server database. You can use these linked tables to rerun queries on a 
regular basis. After editing in MI Pro, the data in a linked table can be saved to the 
relational database management system in a manner that resolves any multi-editing 
conflicts. 

MI Pro stores information about a linked table that is hidden from the user. This 
information is known as metadata. MI Pro uses metadata to store information about 
the linked table that is needed to manage transactions between MI Pro and the server 
database. Two of the most important kinds of information stored in the metadata 
include the connection string and the query you build from the DBMS Table Wizard, 
or Expert dialog. 
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O
pening a DBMS Table 

Choosing a Table
Use the  New Connection button from the Open  dialog or click the Open DBMS Table 
button from the DBMS Toolbar to make a connection to a database. A series of dialogs 
will assist you in opening a DBMS table.  

The dialog sequence that displays depends on what DBMS support components you 
have installed:

• Choose a Connection Type from the Connection Type list.  

• Open a connection to the DBMS source.

• Select the table to open.

• Specify table options such as Column filter, Row filter, etc.  

The Open DBMS Connection dialog displays and prompts you to select a table from 
the connected data source:

1. Choose a Connection Type from the Connection Type list. The connection 
types that appear in the list depend on what types of DBMS Support you 
have installed: MapInfo ODBC, Oracle, or both. 

2. To make a new connection, click the New button. If your connection type is 
MapInfo ODBC, the Select Data Source dialog displays. 
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ODBC

File  Data Source Displays all file DSNs (data source names)  and subdirectories contained 
within the directory displayed in the Look In box. Double-clicking a DSN 
connects to the data source.

Look In Displays the current directory for which the subdirectories and file DSNs 
are displayed in the window below. Clicking the down arrow to the right 
of the text box displays the entire directory structure.

DSN Name Displays the file DSN name selected in the File Data Sources list, or you 
can enter a new file DSN name.

New Adds a new file data source. If you click this button, the Create New Data 
Source dialog box appears with a list of drivers. Choose the driver for 
which you are adding a file DSN. After you click Next, you may specify 
the keywords for the file DSN.  See the section “Creating New Data 
Sources,” above, for instructions on creating a new data source. 

OK Closes the Administrator dialog box, and connects to the file data source 
that is highlighted in the list or entered in the DSN Name text box. You do 
not have to click OK to accept changes to the File Data Sources list. 
Changes to the list are accepted once the OK button in the Data Source 
Setup dialog box has been clicked.

Cancel Closes the Administrator dialog box without connecting to the file data 
source. Changes to the File Data Sources list are not rejected if the Cancel 
button is clicked.

Help Displays Help.
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If your connection type is Oracle Spatial, the MI Pro Oracle Connect dialog displays.

Enter the server name, user name, and password, and then click OK. 

When you have chosen or created a connection the Open DBMS dialog 
displays. It contains a list of tables for that connection, which displays in the 
Tables field. The directory path of the database connection or the database 
name also displays. This field is not present for data sources that do not 
provide this information. 

3. Click the name of the table you want to download to highlight it. 
4. As an optional step, use the Filter button to select which types of tables to list. 

The default shows Tables, View, and Synonyms, and hides System tables. 
5. Click Open. 

For data sources that make use of owners, such as Oracle, the Owner field is activated. 
It allows you to list tables owned by different users. 
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Open DBMS Table Options
The Open DBMS Table Options displays. When you selected a table in the first dialog, 
in effect, you selected all the rows and columns in that table. In this dialog you will be 
selecting the columns that contain the data to be downloaded. By default, all columns 
will be downloaded.

The default location of the *.TAB file is set in Remote Tables preferences.
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 Once the data to be downloaded has been determined, you can specify the path name 
for the local table in the MI Pro TAB file location path.  Click the Column Filter button  
if you want only certain columns downloaded. The Column Picker dialog displays.

1. Move the columns you want from the table from the Available group to the 
Selected group using the arrow buttons. The single arrow keys move one 
selected column at a time. The double arrow buttons move all the columns at 
once from one list to the other. 

2. Change the order of the selected columns in the Selected list using the Up and 
Down buttons. Click on a column to highlight it, and then move it up or 
down in the list by clicking the appropriate button.

3. If you wish, click the Expert button to create a SQL query that selects data 
from the table. 

4. Click OK. 

If the table is mappable, the Available list also displays an additional column called 
“OBJECT,” which refers to the spatial column. You can select it to download point 
objects from the table. If the table is spatialized, it will download lines and polygons 
depending on what the table contains.

At the initial display of this dialog, an asterisk (*) appears in the Selected list. If you 
leave the asterisk, all the columns will be selected from the table. 
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Click the Row button to restrict the downloading of data from rows that match the 
criteria you specify. (This is the same as specifying the WHERE clause in a SQL query.)  
If you select no filtering criteria in this dialog, all rows will be selected. The Row 
Picker dialog displays.

1. In the Column list, choose the column(s) from which you want to filter rows.

If you are filtering rows for one column, select a column, operator, and value. 
If filtering rows on more than one column, select a column from the next 
drop-down list. This will also activate  the next row of fields for data entry.

2. Choose how you would like to filter the rows using the Operator and Value 
boxes. These are explained below. 

3. You can also click the Expert button to bypass the wizard and write a SQL 
query to select the rows from the table. 

4. Click OK when you have finished filtering the rows. 

The Operator list boxes contain all supported operator symbols for their 
corresponding selected column. The list of operators will vary depending on the type 
of the selected column. For example, the operators <, >, and = (among others) will be 
available for numeric columns, but object columns will have only the operator 
WITHIN.

The type of the Value control also varies depending on the column type.

For object columns, this control will be a list box containing the values 
CURRENT_MAPPER and SELECTION.

For all other column types, this control will be an edit box, allowing the user to enter 
the proper type of data.
520 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 520



Chapter 23: Accessing Remote Database Data

M

If you select an object column using the ‘within’ operator, MI Pro returns only the 
objects from the server that are within the selection. In previous versions, if the 
selection contained multiple objects MI Pro generated a query using the MBR of the 
objects. This would usually return more data than expected. Now multiple objects are 
automatically combined into a single object before performing the spatial query, 
which returns the correct results. The object is stored in the  .tab file so that it is re-
used the next time you open the .tab file to the remote database. 

String values are enclosed in single quotes, e.g., ‘New York.’ Numerical values are 
entered without any quotes. For example, for a numeric column, the user might select 
the operator >, and enter a value of 0. This would select only rows in which that 
column contained a value greater than 0.

There are two wildcard characters that can be used with the LIKE operator: ‘%’ and 
‘_’. The ‘%’ wildcard character matches zero or more characters. The ‘_’ wildcard 
character matches only one character.

When rows are being filtered from more than one column, Conjunction becomes 
available. Choose one of these boolean operators: AND, OR, AND NOT, OR NOT.

Completing the Open DBMS Table Options Dialog
To complete the dialog:

1. Select the Download data (Linked Table) option to download the data and 
make it into a linked table. Clear the box for  live access. (See “Creating Live 
Remote DBMS Access,” below.)

2. For live access, the Cache check box is displayed. Select the Cache check box 
to keep attributes and objects that have been read in memory. If you perform 
an operation such as zooming in they do not need to be fetched from the 
database (since MI Pro looks in memory for a record you may not see the 
latest updates). If cache is on, another user’s updates may not appear until the 
cache is invalidated by a pan or zoom out operation. If you clear the Cache 
check box, all data will be fetched from the database whenever it is needed. It 
will give the most up to date data but it will be less efficient because it must 
be re-read from a database. (See “Creating Live Remote DBMS Access,” 
below.)

3. Click OK to save the data to the table you specified. 
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When Is a DBMS Table Read-Only?
 The DBMS table can be read-only under any of the following circumstances:

• The data downloaded from the server database is not editable.

• There are no editable columns in the data downloaded from the server 
database.

• The data downloaded from the server database does not contain a primary 
index.

If the data downloaded from the server database does not contain a primary index, 
you can create one. Then the table will become editable. The next section explains 
how to create a primary index on a remote table from MI Pro.

When Is a DBMS Spatial Object Read-Only?
The spatial object itself may not be editable. 

A DBMS table’s spatial objects may not be editable under the following 
circumstances:

• Spatial data is not actually stored in a column on the table. This would 
happen if a function were used on the spatial data that generated spatial data, 
such as buffering the object on the server. 

• Spatial data is three-dimensional. 

Downloading DBMS Tables
Downloading a DBMS table involves the following steps:

• Connect to a database.

• Select which table to download from the database.

• Select which columns to download from the table.

• Select which rows to download from the table.

• Save the table locally to MI Pro as a linked table. 

Creating Live Remote DBMS Access
You can access data live from remote databases. Follow the same procedure for 
connecting to a data source, and then open a DBMS table for downloading into an MI 
Pro linked table using the DBMS wizard. 
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To Create Live Remote DBMS Access:
When the Open DBMS Table Options displays:

1. Select the Live Access option. The Cache check box is enabled.  
2. For live access, the Cache check box is displayed. Select the Cache check box 

to keep attributes and objects that have been read in memory. If you perform 
an operation such as zooming  in they do not need to be fetched from the 
database. (Since MI Pro looks in memory for a record you will not see the 
latest updates.) If cache is on, another user’s updates may not appear until the 
cache is invalidated by a pan or zooming out. Clear the Cache check box and 
all data will be fetched from the database. This will give the most up-to-date 
data, but it is less efficient because the data must be re-read from the database. 

3. Click OK button and a .tab file is created. 

Completion of the dialog will write the tab file and open it. The next time you want to 
open the table, open the tab file.

Before accessing a table live from a remote database, it is highly recommended that 
you first open a map table (e.g., states.tab) for the database table. If you don’t open a 
map table, the entire database table will be downloaded all at once, which could take 
a long time. 

Open a map table and zoom in to an area that corresponds to a subset of rows you 
wish to see from the database table. For example, if you want to download rows 
pertaining to Florida, zoom in to Florida on the map. As a result, when you open the 
database table, only rows within the Map window’s MBR (minimum bounding 
rectangle), in this case Florida, will be downloaded.

Limitations
This is a list of known problems/issues with live access:

• Every table must have a single unique key column. 
• FastEdit is not supported.
• With MS ACCESS if the key is character, it will not display rows where the 

key value is less than the full column width e.g., if the key is char(5) the value 
’aaaa’ will look like a deleted row.

• Changes made by another user are not visible until the data is refreshed from 
the server. In addition, if cache is on another user’s updates may not appear 
until the cache is invalidated by a pan or zooming out.

• There will be a problem if a client-side join (through the SQL Select menu 
item or MapBasic) is performed against two or more SpatialWare  tables that 
are stored in different coordinate systems. This is inefficient (it is better to do 
the join in the SQL statement that defines the table), but it is a problem in the 
current release.
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Live Access to SpatialWare 4.6 also has some limitations: 

• Performance may be slower when downloading using Live Access.

• Deleting records creates problems. Records are deleted; however, the table 
structure is not packed, causing problems with selecting and labeling. 

Bound Objects in SpatialWare Spatial Queries 
For both linked and live access tables, Spatial objects in SpatialWare and Oracle 
Spatial queries are now submitted as a bound (binary) object. This change has been 
made for all implementations of SpatialWare: Oracle, Informix, and Oracle Spatial. 
Previously, a string was generated for the object. Because of the limitations on the 
string size, polygon complexity was also limited. Submitting spatial objects as bound 
objects removes this limitation. 

The string describing the spatial object will be stored in the .tab files and 
reconstructed into a bound object when the table is opened. The SW SPW lib will be 
used to construct the bound object from the SpatialWare string. 

Creating a Primary Index on a Remote Table
There are three ways you can create a unique (primary) index on a remote table from 
MI Pro.

• Use the DBMS SQL Builder tool available from the Tool Manager. Choose 
Tools>Tool Manager, and select the Loaded check box next to the DBMS SQL 
Builder tool. Click OK. The tool is now located as a command in the Tools 
menu. To run it, choose Tools>DBMS SQL Builder.  
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• Using the Expert option in the DBMS Connectivity wizard. Type the 
following: CREATE UNIQUE INDEX new-index-name ON table-
name(index-column)

• Open the MapBasic Window and type the following MapBasic commands:

DIM hdbc as integer (enter)

DIM stmt as integer (enter)

hdbc=Server_Connect(”ODBC”,”DBMS=remote database 
name”,”DLG=1”)

stmt=Server_Execute(hdbc,”CREATE UNIQUE INDEX new–index–
name ON table–name(index–column)”)
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Live Access Performance with Large DBMS Tables
Opening large tables of a quarter million or more rows using the DBMS Live Access 
method has traditionally been slow. Even when you are displaying a very small 
number of rows in a Map window it can take several minutes. 

Most of this time is used to perform a row count on the table and to order the rows by 
primary key. MI Pro uses the table’s row count internally. To prevent MI Pro from 
having to count the rows, a new tool, DBMS Count Rows in Table, has been developed
that will virtually eliminate the initial startup time on the table. The DBMS Count 
Rows tool updates the number of rows and stores the total in the MapCatalog.  

To utilize the tool, the MapCatalog definition for existing MapCatalogs must be 
modified to include a new integer column, NUMBER_ROWS. Using the SQL tool 
supported by your database, execute this statement to add the column:

ALTER TABLE MAPINO.MAPINFO_MAPCATALOG

ADD NUMBER_ROWS NUMBER

In new installations of MapInfo Professional 6.5 or later,EasyLoader will add the 
NUMBER_ROWS column when it creates the MapCatalog.

To load the tool, choose Tools>ToolManager. Select the Loaded check box next to the 
DBMS Count Rows in Table tool, and click OK. The tool is now located as a command 
in the Tools menu. To use DBMS Count Rows: 

1. Choose Tools>DBMS MIRowCnt. The DBMS MIRowCnt dialog displays. 
2. Specify the database connection, the owner name, and the table name. 
3. Click OK. The rows in the table are counted and the total is placed in the 

MapCatalog. 
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Limitations
This method of determining the number of rows is not appropriate for all tables. It 
works best on large tables, where the number of rows remains stable; that is, new 
insertions or deletions in the table do not occur on a regular basis. 

In this case, a large table is defined as one that approaches a quarter of a million rows 
or more, or a table that takes a long time to open using the Live Access method. 

If the total number of rows stored in the MapCatalog is out of sync with the actual 
number of rows in the table, problems occur. The map will always include all of the 
map objects, but other things may not work correctly. For example:

• The row count displayed in the Browser will be incorrect. 

• The MapBasic statement to fetch last will not return the correct row.

• Thematic maps, particularly ranged thematic maps, may be wrong.
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Entering SQL Queries with the Expert Button
In the Open DBMS Table Options, Expert Mode, the SQL view button can be used to 
invoke the following dialog:

This dialog allows the user to enter queries much more complex than the wizard 
allows using the standard DBMS SQL syntax. 

To type in multi-line formatted SQL, do the following:

• To get a new line press ENTER.

• To tab press <CTRL> TAB.

• To cut and paste from the clipboard, use <CTRL> X to cut, <CTRL> C to copy,
and <CTRL> V to paste.
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uilding Queries on Remote Database Tables with DBMS SQL 
uilder 

The DBMS SQL Builder utility can also be used to generate queries on remote 
database tables. 

1. To load this program, choose Tools > Tool Manager. Select the Loaded check 
box next to the DBMS SQL Builder tool. 

2. Click OK. The tool is added to the Tools menu. 

To have this tool load automatically every time you open MI Pro, select the Autoload 
check box. 

To run the DBMS SQL Builder:
1. Choose Tools> DBMS SQL Builder. The following dialog displays:

OK Press to move to the final dialog of the wizard.

Cancel Press to cancel the query. You will be returned to the step in the wizard where 
you originally invoked the Expert dialog.

Load Press to load an SQL statement that has been saved in a file. The Load button 
activates the Load SQL Query dialog. This dialog provides you with access to 
existing files containing SQL statements (*.sql files). When you load an SQL 
file, its format will be preserved.

Save Press to save the SQL statement in a file for later use. The Save button 
activates the Save SQL Query dialog. Use this dialog to save newly 
constructed SQL statements, or modifications to existing statements. When 
you save an SQL file, its format will be preserved.

Once saved, the SQL statement appears in the list of available *.sql  files in the 
Load SQL Query dialog. 

Last Query Press to load the last query that was executed in this session of MI Pro.

Help Press for online help.  
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2. Click on the Build Query button. Another dialog will display:

3. Click on the white box to the right of From Tables, and use the Table button 
to choose what table to query.

4. Click on the white box to the right of Select Columns, and use the Columns 
button to select the columns to be viewed. The asterisk (*) indicates all 
columns.

5. Click on the white box to the right of Where Conditions: Enter in the 
condition of the query.
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6. Once the query statements have been entered in, click the Run button. This 
will return you to the MapInfo DBMS SQL Runner dialog box. In this dialog 
box, the query you built will be in the SQL Statement box.

7. Click on the Execute button to run the query. Choose the fetch type in the next 
dialog:

Preview allows you to view the table without bringing it into MI Pro.

Download brings the query table into MI Pro.   
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Saving a DBMS Table
You save changes to an MI Pro linked or live table the same way you save a regular MI
Pro table, with the File > Save Table command.

Saving a linked or live table results saves the records on the remote database. But 
before MI Pro allows records from a linked table to be updated, it evaluates the 
records in a process called conflict resolution.  

Conflict Resolution for Linked or Live Tables 
Because the records in a remote table are from a remote database, it is possible that 
other users may have changed or deleted them on the remote database since the table 
was downloaded into MI Pro. As a result, conflicts may exist between the data 
residing on the remote database and the new data that you want to upload to the 
remote database.

When saving a remote table, if MI Pro finds conflicts between the data on the remote 
database and any records in the remote table since it was downloaded, the Resolve 
Conflicts dialog automatically displays. Use this dialog to resolve conflicts as 
explained below.

This process will be invoked whenever an attempt to save a remote table detects a 
conflict in an update. The dialog allows the user to choose which fields from the 
conflicting records will be used to update the database. Three instances of the record 
being updated must be considered:

• The original server state of the record (the record as it appeared when initially
extracted from the database).

• The current local state of the record (the record as it appears in the session of 
MI Pro making the update, possibly after editing by the user).

• The current server state of the record (the record as it appears in the database 
at the time of the update).

A conflict exists when the original state of the record does not match the server state. 
This implies that another user has updated this database since it was extracted by MI 
Pro.

The conflict resolution dialog will display once for each conflicting record. At any 
point in this process, the user may choose to leave this interactive mode and have the 
rest of the conflicts resolved automatically. In that case, the user has the choice of 
using all local values or all server values to resolve the conflicts in the records. 
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For each conflict found during a commit, the user will be presented with a modal 
dialog box. This box will display enough information for the user to decide which 
data values to use to update the row in question.

Type of conflict Default resolution

Value changed on 
server, 
local value unchanged

Use server value

Value changed on 
server, local value 
changed

 Use local value

Column Shows the name of the column in the record that has data which is in 
conflict and needs to be resolved.

If the column name is too long and does not fit into the list box, a 
truncated representation will be shown instead. Its full value is 
displayed in the Column field, below.
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Original DBMS Shows the original data as it appeared when extracted from the 
database.

If the original data is too long and does not fit into the list box, a 
truncated representation will be shown instead. Its full value can be 
displayed in the Original field, below.

Current MI Pro Shows the data as it appears in the MI Pro linked table you are trying 
to save.

The MI Pro field will be blank if the record has been deleted from the 
MI Pro database.

If the data from the MI Pro linked table is too long and does not fit into 
the list box, a truncated representation will be shown instead. Its full 
value can be displayed in the MI Pro field, below.

Current DBMS Shows data as it appears in the remote database at the time of the 
update. (This data might have been changed by another user since it 
was downloaded into an MI Pro linked table.)

The Current field will be blank if the record has been deleted on the 
remote database, after being downloaded into an MI Pro linked table.

If the current data from the remote database is too long and does not fit 
into the list box, a truncated representation will be shown instead. Its 
full value can be displayed in the Current field, below.

Current MI Pro Check this box to update the remote database with the value from the 
MI Pro linked table.

If the current record on the database or the MI Pro record was deleted, 
then this check box is not available. Instead, you must use the MI Pro 
or Current button, below.

Current DBMS Select to retain the current value on the remote database.

If the current record on the database or the MI Pro record was deleted, 
then this check box is not available. Instead, you must use the MI Pro 
or Current button, described below.

MI Pro button This button selects all the MI Pro values. If the record you are trying to 
resolve was deleted from the MI Pro database, selecting the MI Pro 
button will delete the record from the remote database.

If the record you are trying to resolve was deleted from the remote 
database, selecting the MI Pro button will insert the new record into 
the remote database.
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efreshing a Linked Table
You can refresh a MI Pro linked table with the most recent data residing on the remote 
database for that linked table.

You can refresh a linked table two ways. Use the Refresh DBMS Table button on the 
DBMS toolbar, or do the following:

1. Choose Table > Maintenance > Refresh DBMS Table. The Refresh Table dialog 
displays.

2. Choose the name of the table to be refreshed from the refresh table list.
3. Choose OK. The specified table is refreshed.

Current button This button selects all the current DBMS values. If the record you are 
trying to resolve was deleted from the MI Pro database, selecting the 
Current button will ignore the deletion and retain the current record in 
the remote database.

If the record you are trying to resolve was deleted from the remote 
database, selecting the MI Pro button will insert the new record into 
the remote database.

Column Shows the full name of the column highlighted in the list box.

Original DBMS Shows the full value of the original data highlighted in the list box.

Current MI Pro Shows the full value of the MI Pro data highlighted in the list box.

Current DBMS Shows the full value of the current remote database data highlighted in 
the list box.

OK Causes the selected values to be used for the update of this record.

Stop Commit The Stop Commit button terminates the entire update. A second dialog 
box will pop up to confirm that this is what the user really wants.

Help Accesses online help.

Automatic The Automatic button causes the interactive conflict resolution to end. 
A dialog displays that allows you to select which of the automatic 
conflict-resolution modes will be used for the remainder of this 
update. One of two automatic modes can be selected from the dialog. 
You can accept MI Pro values, or the values currently residing on the 
remote database. 
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Unlinking a Table from a Remote Database
You can unlink a table from its remote database with the Unlink DBMS Table 
command. Unlinking a table removes the link to the remote database. This command 
does not work if edits are pending on the linked table. You must first update any 
pending edits with the Save Table command. The table linkage is removed. Fields that
were marked non-editable are now editable. The end product is a normal MI Pro base 
table.

To unlink a table:
1. Choose Table > Maintenance > Unlink DBMS Table. The Unlink Table dialog 

displays.
2. Choose the name of the table to be unlinked from the Unlink table list.
3. Choose OK. The specified table is unlinked.

Disconnecting from a Remote Database
Disconnecting from a remote database server is now a simple operation. You can do 
one of two things: 

• Click the DBMS Disconnect button.

• Choose File>Close DBMS Connection. 

Both operations display the Close DBMS Connection dialog. The Connection list 
displays all the open connections. Select the connections(s) you want to close and click
OK. The selected connections(s) will close. 
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Chapter 24: Using the 
MapBasic Window
Using the MapBasic Window

This chapter allows advanced MapInfo 

Professional® users to go behind the scenes and 
take advantage of functions that enhance the 
use of MI Pro through the MapBasic window. 

MapBasic® is MI Pro’s programming language 
that allows you to customize and automate MI 
Pro functionality. When MapBasic was created, 
the MapBasic Window feature was added to MI 
Pro as a means of testing and debugging code 
for an application. It became apparent that the 
MapBasic window is also a useful tool to MI 
Pro users for doing certain tasks such as 
complex selections and queries based on object 
information.

➤ 

➤ 
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The MapBasic window is limited to selected commands from the MapBasic 
programming language. The MapBasic window can take commands line by line. It 
does not include the capability for looping, interapplication communication, and 
other more complex commands. If you find yourself using the MapBasic window 
often, you may want to consider transferring your code to a MapBasic application that
will automate the process.

The MapBasic Reference is available as a PDF file on the MapInfo Professional CD. 
Refer to the Reference for more complete information on the statements used in this 
chapter. You can also find the listing of MapBasic defines (MAPBASIC.DEF) in the 
Appendix C of the MapBasic Reference Guide. Owners of MapBasic have complete 
printed documentation for all statements and functions included in the language. 

Accessing the MapBasic Window
To access the MapBasic window, choose Options > Show MapBasic Window. The 
MapBasic window displays on your screen. As with any other window, you may 
resize it or move it to a new location. The window allows you to enter MapBasic code 
or to view MapBasic code as it is generated by MI Pro. To see how MI Pro carries out a 
select statement, open the MapBasic window and then open the World table. Choose 
Query > Select. Put in the expression Pop_1994 > 1000000. Make sure that the Browse 
Results box is checked. Click OK. The syntax for these commands appears in the 
MapBasic window as follows:

Open Table ”C:\MAPINFO\DATA\WORLD\World.tab” Interactive

Map From World

select * from World where Pop_1994 > 1000000 into 
Selection

browse * from Selection

The first line is a result of opening the World table. The second line of code is written 
automatically because the World table displays in a Map window by default. The 
third line is the syntax for the select statement. The fourth line is the result of checking 
the Browse results box. 

You can also enter MapBasic commands into the MapBasic window. Position your 
cursor under the browse from Selection line. Type the following:

Map from Selection
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Press Enter after the line, and the command executes. You should see your selection 
displayed in a Map window.

As stated before, the MapBasic window was primarily designed to assist MapBasic 
programmers. You can statements and functions in the MapBasic window such as 
Buffer( ) function or Insert statement

Refer to the  MapBasic Reference Guide in an easy to navigate PDF format on the 
MapInfo Professional CD to find the appropriate usage and syntax for these 
statements and functions. It provides  a comprehensive guide to MapBasic 
programming statements and functions along with examples. Choose the appropriate 
option from the CD Browser to access the Reference. 

xamples

Converting a Table of Coordinates to a Table of Lines
The following steps can be used to create lines for each record in a table. You must 
have a column for each of the necessary coordinates. It is suggested that you make 
any changes on a copy of your table. If there are already objects in a Map window for 
this table, they will be lost.

1. Choose Options > Show MapBasic Window. The MapBasic window appears 
on the screen. 

2. Type the following command in the window:

update point_table set obj=createline(Start_X, 
Start_Y,End_X,End_Y)

Where point_table is the copy of your original table, Start_X is the column containing 
the first X coordinate, Start_Y is the column containing the first Y coordinate, End_X is 
the column containing the second X coordinate, and End_Y is the column containing 
the second Y coordinate. These columns will be the names that you have already 
specified in your table.

MI Pro will go row by row through your table and create a line object based on the 
information in that row. You will not see a change in the table until you redraw the 
window or open a new Map window for it.

Trouble Shooting
Before you proceed with the update make sure that the table in which the lines will be 
stored is mappable. To make the table mappable, choose Table > Maintenance > Table 
Structure and check the Table is Mappable box.
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If your map is projected, the line objects may not be created properly. To work around 
this situation, see the Set Coordsys statement in the MapBasic Reference to change the 
MapBasic coordinate system. 

Creating Circles Around Points Using the MapBasic Window
The following createcircle command can be used to convert a table of points to a table 
of circular regions. This command is similar to creating buffers on a point layer. It 
differs, however, from buffering in that it actually converts the point objects into 
circles. It is suggested that you make any changes on a copy of your table. If there are 
already objects in a Map window for this table, they will be lost.

1. Choose Options > Show MapBasic Window.
2. Type the following line in the window:

update tablename set obj=createcircle(centroidx(obj),centroidy(obj),radius)

Where tablename is the name of the copy of the table, and radius is the radius 
of the circle in current system units.

The table will then be automatically updated. 

Trouble Shooting
This command modifies the object column of your table. The command replaces the 
point object with circular objects. If you wish to undo this operation, make sure  the 
Map window is active choose Edit > Undo or use File > Revert Table and revert the 
table to the last time it was saved.

The final parameter in the MapBasic command, 10 in this example, is the radius of the 
newly created buffers, in miles. This figure is adjustable. If you perform the command 
and find that the radius is too small or too large, perform the command again, with a 
different radius.

 If your map is projected, the circular objects may not be created properly.

 If you wish to convert a table of circular objects back to a table of points, run the 
MapBasic command:

Update tablename set 
obj=Buffer(obj,smoothness,distance,units)
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Using the ObjectInfo Function to Describe Graphical Object Types
The Objectinfo command is used to return the type of graphic object associated with 
each row. Each object type is represented by a small integer. MI Pro has 12 types of 
objects. They are listed in the Objectinfo function section in the MapBasic Reference.

To determine the different types of objects in a single layer, do the following:
1. Choose Options > Show MapBasic Window. The MapBasic window appears 

on the screen.
2. Enter the following SQL Select command:

Select ObjectInfo (obj,1) from tablename

Where obj refers to the object associated with the row of the table, 1 is the 
code to return the object type, and tablename is your table.

3. Choose Window > New Browser Window. Choose to browse selection. A list 
of the number codes for each object type appear. 

Selecting All Records of a Specific Object Type 
1. Choose Options > Show MapBasic Window. 
2. Type the following SQL Select statement: 

Select * from tablename where str$(obj)=”objecttype”

Where tablename is your table and objecttype is the type of object you wish to 
select. To determine the type of an object, double-click on the object. A dialog 
box displays with the region type listed.

3. Choose to browse or map the selection of these objects.

Selecting Streets by Color Using SQL Select
To select all streets from a StreetInfo or Streetworks file by the width, pattern, and 
color of the line segment, do the following:

1. With your street file open, choose Options > Show MapBasic Window. The 
MapBasic Window displays on the screen.

2. To select thin red lines, type the following

Str$(ObjectInfo(obj,2))=”Pen (2, 2, 16711680)”
apInfo Professional User�s Guide 541

Apple Inc. 
Exhibit 1021 

Page 541



Chapter 24: Using the MapBasic Window
Display Characteristic

Street Feature

Pen Width will always be returned as a number from 1–7. One is the narrowest and 7 
is the widest. These numbers correspond to the lines you would see in the pull down 
menu under Options > Line Style > Width.

The pattern will be returned as a number from 1 to 77. These numbers correspond to 
the patterns you see in the pull down menu under Options > Line Style >Style going 
left to right. 

Finding the Angle from a Horizontal
The following procedure finds the angle (angle A in the example below) between a 
line that connects two given points and a horizontal line. This is done by creating a 
right triangle where the hypotenuse is the line between the two points and the 
adjacent is the line between the origin point and a point on the horizontal directly 
below or above the destination point. After you find the hypotenuse and adjacent 
distances, you can find the angle by taking the arc cosine of the adjacent divided by 
the hypotenuse.

Note:  The angle will be calculated using a Cartesian coordinate system. For some 
projections, a calculated 90 degree angle may be obviously different from a 
"right angle" on the projected map

Description of Object Graphic Object Details Pen (width, pattern, color)

Primary highways Thin red line Pen (2,2,16711680)

All other roads Thin black line Pen (1,2,0)

Railroads Thin Black railroad Pen (1,26,0)
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The two points will be referred to as the origin and the destination. The origin is the 
point that is on the horizontal line. The destination is the other point. In the example 
below, Hartford is the origin. It lies on the imaginary horizontal line. Boston is the 
destination. The hypotenuse is the distance from Hartford to Boston; the adjacent is 
the distance from Hartford to the point where the horizontal intersects the vertical 
dotted line that passes through Boston.

1. Choose Options > Show MapBasic Window and open the MapBasic window.
2. Double-click on the origin point (Hartford). MI Pro opens a Point Object 

window that shows the coordinate information. Write down the X and Y 
coordinates. These coordinates will be referred to as OriginX and OriginY.

3. Double-click on the destination point (Boston). MI Pro opens a Point Object 
window that shows the coordinate information. Write down the X and Y 
coordinates. These coordinates will be referred to as DestX and DestY.

4. In the MapBasic Window, type and run the following command:

 Print Distance(OriginX, OriginY, DestX, DestY, ”mi”)

Substitute the values you find in step 2 and 3 for OriginX, OriginY, DestX, and 
DestY. MI Pro returns the distance between the origin and destination points 
in a Message window. The value is the hypotenuse of the triangle.

5. In the MapBasic window, type and run the following command:

Print Distance(OriginX, OriginY, DestX, OriginY, ”mi”)

Substitute the values you find in step 2 and 3 for OriginX, OriginY, DestX and 
DestY. MI Pro returns the distance between the origin and a point on the 
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horizontal directly below the destination point. MI Pro will display the 
distance in a Message window. The value is the adjacent of the triangle.

6. Finally, find the angle with the following MapBasic command:

Print(ACOS(Adjacent/Hypotenuse)*57.2958)

Substitute the values that you found in step 4 and 5 for adjacent and 
hypotenuse. MI Pro returns the angle in degrees. MI Pro will print the angle 
in a Message window.

If you would like to find the angle in radians, omit the multiplication at the 
end of the statement, leaving:

 Print(ACOS(Adjacent/Hypotenuse))

If, instead of two points, you have one line that has the destination and origin 
as endpoints, do the following instead of steps 2 and 3:

Double-click on the line object. MI Pro opens a window that shows the 
coordinate information. Write down the Start Point and End Point X and Y 
coordinates.

Determine whether the Start Point or the End Point is higher, that is, which 
point has a more northerly Y coordinate.

If the destination is above the origin (like the example above), then the 
destination will have the coordinates of the most northerly point (determined 
in the previous step). The origin would then take the coordinates of the other 
endpoint of the line.

If the origin is above the destination, then it takes the coordinates of the more 
northerly point.

Continue with step 4.  
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Finding Floating Windows
Floating windows are the special windows in MI Pro that sit on top of the Map, 
Browser, Graph, and Layout windows. These windows are the Info window, Statistics 
window, buttonpads, ruler, and message window. You can move these windows 
around and place them off to the side of the screen. Occasionally, one of these 
windows may be shifted out of view. Using the MapBasic window, you can easily 
bring these windows back to the center of you screen. This example uses the Info 
window. Other special windows are listed in the Set Window statement in the 
MapBasic Reference.

1. Choose Options > Show MapBasic Window. The MapBasic window displays 
on your screen.

2. Type the following code into the window:

Set Window Info Position (1.5,2.0) Units ”in”

The Info window should now appear in the center of your screen.  

Setting the Default Zoom for a Map
When you open a map in MI Pro, it displays in the default view every time, even 
though you probably changed the zoom when you last opened the map. You can 
change the default zoom for a map with the Set Map statement.

For example, if you open the standard world map that ships with MI Pro, it displays 
with the whole world in view, by default. You frequently use the world map to view 
just the European countries and would like the map to display in that view every time 
you open it. To change the map’s default zoom, do the following:

1. Choose Options > Show MapBasic Window. The MapBasic window displays 
on your screen.

2. Open the World map.
3. Set the zoom level and position of your map to view Europe only.
4. In the MapBasic window, enter the following command:

Set Map Layer 1 Default Zoom

5. Close the World table.
6. Re-open the World table. It opens in the zoom level that you set.
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Projections and Coordinate 

Systems

How do you flatten the curved surface of the 
earth so that you can draw maps on flat pieces 
of paper and (nearly) flat computer screens? 
You use a projection. A projection is a system 
that defines how to flatten objects. MapInfo 

Professional® allows you to display your maps 
in different projections. This chapter 
concentrates on the simpler tasks you can 
perform with projections: adding ocean and 
grid layers, changing a map’s projection, and 
saving a map with a new projection. 
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What Is a Projection?
When you transfer objects from the spherical world to the relatively flat computer 
screen, there is bound to be some distortion. 

Think about it in terms of an orange. If you write the phrase “Think Visually with 
MapInfo” on an orange with a felt-tipped marker, the words look relatively normal. 
However, when you peel the orange and flatten it out, the words are barely legible. 
When words or objects drawn on a round surface are transferred to a flat surface some
distortion must occur.

A projection is a method of reducing the distortion that occurs when objects from a 
spherical surface are displayed on a flat surface. There are many different types of 
projections, each designed to reduce the amount of distortion for a given area

Notice the difference between the two maps below. While the first one flattens Alaska,
the second shows Alaska’s true size. The relative distance between the continental US,
Alaska, and Hawaii is very different in the two pictures. The border between the 
continental US and Canada is much more representative of a curved surface in the 
second projection.

Projections are most often used for:

• Digitizing a map that has an explicit projection.

• importing a DXF file that has an explicit projection.

• Running a GIS application that requires the geographic precision of a given 
projection.

• Cosmetically altering your map for output.

Mollweide (Equal-Area)
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Projections are not used for:

• Non-earth maps, whose coordinates do not have any reference to locations on 
earth. 

rojection vs. Coordinate System
You may hear the term coordinate system when talking about projection. A 
coordinate system is a set of parameters that tells you how to interpret the locational 
coordinates for objects. One of those parameters is projection. Although the terms are 
often used interchangeably, projection is only one part of a coordinate system. 

Projection relates to how the objects display on a flat surface. A coordinate system 
tells you what projection is being used for the map, along with other reference 
information.

In MI Pro’s Choose Projection dialog, you are in fact choosing more than a particular 
map projection. You are choosing a coordinate system.

MI Pro’s default map projection (Longitude/Latitude) is actually an equidistant 
cylindrical projection, using longitude/latitude coordinates. This projection is called 
Longitude/Latitude to convey that when you choose it, you will be working in 
degrees long/lat. 

using Longitude/Latitude using Azimuth Equidistant (North Pole) Projection 
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For a discussion of the parameters that make up a coordinate system and instructions 
on how to create your own, see Appendix H in the MapInfo Professional User’s Guide, 
Creating Your Own Coordinate System.

Earth and Non-Earth Maps

Earth maps and non-earth maps generally require different treatment. The following 
section on projections apply only to earth maps.

An earth map contains objects that have a particular location on the earth’s surface. 
All maps that MI Pro sells are earth maps. Coordinates typically represent an object’s 
location in longitude and latitude, although other coordinate systems (using various 
projections) may be used instead.

Use earth maps to:

• Overlay your map onto any maps that MI Pro supplies.

• Use or change projections.

• Specify objects on the map in terms of longitude and latitude.

A non-earth map contains objects that have no specific location on the earth’s surface.
Floor plans are typical examples of non-earth maps. Even though the floor plan 
describes a building that may be located somewhere on the earth, the coordinates of 
objects in the floor plan are generally not referenced to positions on the earth. Rather, 
the object’s coordinates are referenced to the floor plan itself, generally representing 
distance from the lower left corner of the floor plan.

Sinusoidal (Equal-Area)
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Floor plan: example of a non-earth map

A non-earth map has a coordinate system, but since its map points are not referenced 
to locations on earth, the coordinate system does not contain a projection.  

hoosing Projections for Display
As mentioned earlier, all projections create some sort of distortion. For example, some 
projections distort the relative area of regions. Two regions that have the same area on 
the earth will appear to have different areas on the map. Other projections, such as 
“equal area” projections, show regions with the correct area relationships (two regions 
that have the same area on the earth will have the same area on the map). However, 
equal area projections distort the shapes of regions, usually by flattening map objects 
near the North and South Poles.

“Conformal” projections (such as Mercator and Lambert Conformal Conic) show the 
shapes of small features accurately, but distort the shapes and areas of large regions. 
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For example, on the earth the area of Greenland is approximately 1/8 the area of 
South America. However, on a Mercator map, Greenland and South America appear 
to have the same area. While detailed areas of Greenland’s coastline are displayed 
with the correct shape, Greenland’s shape, as a whole, is distorted out of proportion. 

If you are not familiar with the different projections (or you are changing projections 
for strictly cosmetic purposes), choosing the optimal projection for display may 
involve some trial and error. You cannot destroy or damage your data by displaying 
maps in different projections. Technically, you can apply any projection to any earth 
map. However, we offer these general guidelines:

• If you are creating a thematic map on regions (countries), an equal-area 
projection is recommended, especially if you are mapping the entire world. 

• Use the Projections of the World for maps of the entire world. They are 
generally unsuitable for mapping smaller areas.

• Use the U.S. State Plane Coordinate Systems for maps of the respective states. 
You should not use them for mapping different states or other countries. 

Projection Tips
Keep the following points in mind when displaying and saving maps with different 
projections.

• Every earth map table in MI Pro is stored in a particular projection, known as 
its native projection. 

• When you display a table in a different projection, new coordinates are 
calculated to display each object in that map. These coordinates are only used 

MercatorLongitude/Latitude

Greenland

South America
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to display the table in the current Map window; the coordinates in the table 
itself are not affected. 

For example, assume you are viewing the States table and want to display it 
in the Mercator projection. Choose the Projection button on the Map > 
Options menu to choose the Mercator projection. MI Pro redraws the Map 
window using the new projection. If you open another Map window of the 
States table, it will open in its native projection.

• MI Pro calculates distance and area using the method that is appropriate to 
the projection of the Map window (Spherical or Cartesian). Non-earth 
projections use only Cartesian calculations. Long/Lat projections use only 
Spherical calculations. Changing the Map window’s projection may affect 
what type of calculation method is available for use in the Map Options 
dialog (Map>Options).

• After you choose a projection for a Map window, any layer added to that 
window will be displayed with that projection. 

If you select Map > Options > Projection, MI Pro will apply the new projec-
tion to all layers in the Map window. If you add an additional layer to the 
Map window, MI Pro will apply the new projection to that layer.

• If you save a map layer with a new projection, do not delete the old map. 

You can convert a map from its native projection to some other projection, but 
you can’t always convert it back accurately. Use File > Save Copy As. Choose 
the Projection button and choose the new projection.

• When you display a map table in a projection other than its native projection, 
it takes more time to draw the map. That is because the projection is being 
done on the fly. MI Pro must calculate new coordinate values for each object 
in the map.

When projections are calculated on the fly, it can take up to ten times longer to 
display your map. If you plan on using a desired projection often, you should 
save a copy of the map with the new projection. 

• Do not edit maps while you are changing projections. 
apInfo Professional User�s Guide 553

Apple Inc. 
Exhibit 1021 

Page 552



Chapter 25: Projections and Coordinate Systems

 

When a map is being projected on the fly, editing that map can have unpre-
dictable results. Furthermore, MI Pro has to redraw, and therefore re-project, 
the map after each edit. This is very time consuming. For these reasons, we 
don’t recommend editing such maps. You should make your edits before you 
project the map or save the map in the desired projection before editing. 

• If you open a new Map window that contains several tables with different 
projections, MI Pro will display the layers using the projection of the topmost 
layer. To change the Map window projection, choose Map > Options > 
Projection. 

Raster Images and Projection
Raster images, like other map tables, have a particular projection. When you first 
register the image in MI Pro, you must specify its projection. There are, however, some
things to keep in mind when dealing with raster images and projections. 

• In raster images with non-earth projections, to change the projection of the 
image you must re-register it. 

• If you have a raster image in a Map window, the Map window takes on the 
projection of the raster image, whether or not you have other map tables 
displayed in the window.

Robinson
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• When you have two raster images in the same Map window that have 
different projections, MI Pro will use the projection of the image that takes up 
the greater portion of the window. If you change the view of the Map window 
using the Grabber tool or scroll bars causing the other image to dominate the 
window, MI Pro will maintain the projection of the first image. If, however, 
you use Change View, Previous View, Redraw Window, or the Zoom-In/Out 
tools, MI Pro changes to display the images using the projection of the second 
image.

For more on raster images, see Chapter 19, Displaying Raster Images.

hoosing a Projection 

Digitizing
When digitizing a projected map, use the Projection button in Digitizer Setup to 
specify the projection of your paper map. Once you have finished digitizing a map, 
use File > Save Copy As to save the table to any other projection. For more 
information on digitizing, see Chapter 26, Digitizing with MI Pro, and Digitizer Setup 
in the MapInfo Professional Reference.

Importing
When importing a MIF file, the CoordSys line of the file specifies the projection of the 
map. If there is no CoordSys line in your MIF file, MapInfo assumes the coordinates 
are in longitude/latitude. When importing a DXF file, MapInfo presents a series of 
dialogs to specify the projection. For more information on importing files, see Import 
in the MapInfo Professional Reference.

Creating a New Table
To specify the projection for a new table, choose the Projection button from the Create 
Table Structure dialog that displays when you choose File > New Table. If you do not 
choose a projection, your table will use the default Table projection. For more on 
creating a new table, see Chapter 22, Managing Your Tables, or see New Table in the 
MapInfo Professional Reference.

Creating Points
When creating new points in MI Pro, you specify which coordinate system these new 
points are in by choosing the Projection button in the Create Points dialog. For more 
on creating points, see Chapter 8, Putting Your Data on the Map, or see Create Points 
in the MapInfoProfessional Reference.
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Displaying Raster Images
When you want to bring in a raster image to display in MapInfo, you must first 
register the image and specify its projection so that MapInfo can display it properly. 
To specify the projection of the paper map, choose the Projection button from the 
Image Registration dialog. If you cannot determine the image’s projection, use the 
default map projection (Longitude/Latitude). For more on registering raster images, 
see Chapter 19, Displaying Raster Images, or see Register Raster Images in the 
MapInfo Professional Reference.  

Displaying a Map with a Different Projection
To display a map with a new projection, choose Map > Options > Projection. The 
Choose Projection dialog displays. Choose the desired projection. MI Pro displays all 
layers in the Map window with the new projection. When you set a projection for a 
Map window, all future layers added to that window will display with the new 
projection.

Eckert VI (Equal-Area)
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aving a Map with a Different Projection
If you want to do extensive work with a table, but want to work with it using some 
projection other than its native one, use Save Copy As to create a new table having a 
different native projection. 

Open the table and choose File > Save Copy As. Choose the desired table from the list 
and press OK. MI Pro displays the Save Copy As dialog. Click on Projection. Choose 
the desired projection and press OK. MI Pro returns to the Save Copy As dialog. Click 
on Save.

Note:  MI Pro does not perform any conversions between non-earth and earth 
projections via the Save Copy As command. 

MI Pro creates a new table containing the same geographic objects. However, the 
coordinates have been converted to display the objects in the new format. The new 
projection becomes the native projection for the new table. When you display the 
table in a Map window, it will display rapidly with this new projection.

Whenever you save a map to another projection, you should preserve the original 
map. Do not erase the original in order to save disk space. The process of projecting a 
map is often not completely reversible. You can convert a map from its native 

projection to some other projection, but you can’t always convert it back accurately. 

If you convert a map back to the projection you started from, some coordinate points 
may be missing, especially near the poles.
apInfo Professional User�s Guide 557

Apple Inc. 
Exhibit 1021 

Page 556



Chapter 25: Projections and Coordinate Systems

 

 

Using the Ocean and Grid Tables
MI Pro supplies tables that you can use in conjunction with projections. 

You can use the Ocean table as a background layer when using world projections. You
can use the grid15 table to put a coordinate grid on your map (this grid is often called 
the graticule). The number in the table’s name specifies the grid spacing,  i.e., 15 
degrees.

The MAPINFOW.PRJ File
MI Pro stores information about coordinate systems and projections in a file called 
MapInfo.prj. The file contains the values that define each coordinate system MI Pro 
supports, more than 300 such systems.

To review the MAPINFOW.PRJ file, use a text editor or word processor. Each 
coordinate system is identified by name, followed by the values that represent the 
coordinate system parameters, including projection, datum, origin, standard parallels,
azimuth, scale factor, false eastings and false northings, and range. Each coordinate 
system is on a separate line, and each parameter value is separated by a comma, as in 
the following examples:

Stereographic
558 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 557



Chapter 25: Projections and Coordinate Systems

M

You can review the MapInfow.prj file by using a text editor or word processor. Each 
coordinate system is identified by name, followed by the values that represent the 
coordinate system parameters, including projection, datum, origin, standard parallels, 
azimuth, scale factor, false northings and false eastings, and range. Each coordinate 
system is on a separate line and each parameter value is separated by a comma, as in 
the following examples:

“Sinusoidal (Equal Area)”, 16, 62, 7, 0
“New Zealand Map Grid”, 18, 31, 7, 173, –41, 2510000, 
6023150

If a particular coordinate system is not listed in the file, you can add it to the file 
yourself, providing MI Pro supports the projection. See Appendix F in the MapInfo 
Professional User’s Guide for instructions on creating your own coordinate system. 

Specifying Coordinate System Bounds
You can specify the bounds for coordinate systems in the MAPINFOW.PRJ file. To do 
so, add 2000 to the projection number and list the bounds after the projection 
parameters.  The general form is:

name, projectionnum + 2000, projection parameters, x1, 
y1, x2, y2

For example, to define a UTM Zone 10 coordinate system with bounds of (100000, 
400000) to (200000, 450000), use this line:

“UTM Zone 10”, 2008, 74, 7, -123, 0, 0.9996, 500000, 0, 
100000, 400000, 200000, 450000

To define a Longitude / Latitude coordinate system with bounds of (-50, 30) to (-48, 
35), use this line:

“Longitude / Latitude”, 2000, 0, -50, 30, -48, 35

You can also define a coordinate system with bounds and an affine transformation. In 
that case, add 3000 to the projection number, and list the bounds after the affine 
transformation constants.  The general form is:

name, projectionnum + 3000, projection parameters, unit-
num, A, B, C, D, E, F, x1, y1, x2, y2

See the MapBasic Reference for a discussion of affine transformation in the Coord Sys 
section. 
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Digitizing with MapInfo 

Professional

Sometimes the only way to bring a map into 

MapInfo Professional® is to trace the map by 
hand. Using MI Pro’s digitizing feature, you 
can trace the details of a paper map with a puck 
and a digitizing tablet and record the tracings 
as a vector image (object with geographic 
coordinates) that can then be displayed in MI 
Pro as a map layer. Since they are vector 
images, digitized maps allow you to use all of 
MI Pro’s powerful functionary with them. 
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Digitized Maps vs. Raster Images
While digitizing is a time-consuming process, it has some advantages over scanned 
raster images, particularly if you want to use the map for geographic analysis.

Digitizing a map creates a vector image that is just like any other MI Pro map layer. 
Each feature you digitize becomes a map object that you can edit, move, customize, or 
attach data to. You can include as much detail as you want to trace from the paper 
map. 

A raster map, on the other hand, is simply a graphic image that is used for display 
purposes only. You cannot edit or attach data to it. It is used as a backdrop for other 
map layers. Its main advantage over digitizing is input speed. 

For more on raster images, see Chapter 19, Displaying Raster Images.

Digitizing Requirements
Digitizing in MI Pro requires special equipment and setup so that MI Pro can read the 
information from the paper map. 

Digitizing Tablet and Puck
To digitize in MI Pro you will need a digitizing tablet and a puck. A digitizing tablet is
the surface that you attach the map to for tracing. The puck is the device with which 
you trace the map. It is a lot like a mouse.

MI Pro supports the GRASS interface. 

Digitizer Drivers
You will also need the appropriate device driver or interface that MI Pro recognizes. 
MI Pro supports the following digitizer drivers: 

• VTI Tablet Interface (version 2.10 or later)

• Wintab

VTI allows you to use a variety of commercial digitizers. It includes a control panel 
applet that allows you to configure your digitizer and a template editor and loader 
that allows direct access to MI Pro’s menu items from the digitizing tablet. Versions 
2.10 or later also allow caching of digitizer events. Users with version 1.0 will need to 
upgrade or switch to Wintab. If you have installed an older version of VTI, MI Pro 
displays the following message on startup and continues running, but with digitizing 
disabled: “Virtual Tablet Interface must be version 2.10 or later for use with MI Pro.”
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You will need to obtain the digitizer driver from a third party — either Digitizer 
Technology (for VTI) or the tablet manufacturer (for Wintab). In most cases, the tablet 
will come with a Wintab driver. 

Digitizer Technology Company provides both sales and support for the Virtual Tablet 
Interface. Their address is:

Digitizer Technology Company
16541 Redmond Way, Suite 195C
Redmond, WA 98052 USA
Tel: (425) 868–3246

WWW: http://www.vtablet.com

The latest VTI and Wintab drivers support digitizing under Windows XP Home, 
Windows XP Professional, Windows 2000, Windows NT, and Windows 95/98. 

Source Map
You can digitize any paper map, aerial photo, or drawing that you can affix to a 
digitizing tablet and trace the map features by hand. 

etting Up the Digitizing Equipment
Connect your digitizing tablet and puck according to manufacturer’s instructions.

Connect your digitizing tablet and puck according to the manufacturer’s instructions 
and install the appropriate device driver.

Attach your paper map securely to the digitizing tablet. It is very important that the 
map not be moved during the digitizing session, or it will invalidate any control 
points you have established for the map. 

igitizer Setup
To communicate the tracings on the paper map to MI Pro properly, you must provide 
some information about your map. In the Digitizer Setup dialog, you specify control 
points for your map, the map projection and appropriate map units, and configure the 
buttons on your digitizing puck. Choose Map > Digitizer Setup to begin. The Digitizer 
Setup dialog displays. Each part of the dialog is discussed below.
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Map Projection
Maps are drawn using a particular projection, or distortion, of the earth’s surface to 
maintain the relationship of the curved earth’s features on a flat piece of paper. When 
you digitize a map using MI Pro, you must specify the projection so that MI Pro can 
take the map’s distortion into consideration and maintain the correct relationship 
among the map features. 

You cannot change the projection after you have begun to digitize, so make sure you 
set it correctly now. Click the Projection button in the Digitizer Setup dialog to select a 
projection. In general, the projection is specified in the map legend. MI Pro supports a 
wide variety of projections. The default projection is specified in the Table Projection 
Preference. For aerial photographs, use Longitude/Latitude as the projection. 

Map Units
In addition to knowing the projection, you must specify the map units used for the 
coordinate system. For instance, a map in the Longitude/Latitude projection will 
show map coordinates in degrees. 

If you do not have coordinates for the map, you will need to digitize it as a non-earth 
map, which means points on the image will only be relative to each other, not to 
points on the earth. Create a non-earth map table first and display it in the active Map 
window. 

Specify the map units from the Map Units drop-down list in the dialog that matches 
the coordinate units on the paper map. Degrees will always be available for earth 
maps. In addition, other map units may be available if you have identified the map in 
a projection other than Longitude/Latitude. 

Entering Control Points
For MI Pro to make a digitized copy of your paper map, it must be able to correctly 
interpret the location of the digitizing puck on the tablet as you trace the map. To do 
this, you must first set the parameters by specifying locational coordinates for several 
control points on the map. To set a control point, choose a point on the tablet and click 
a button on the puck. Type the coordinates that correspond to that point in the 
Digitizer Setup dialog. 

To add, edit, remove, or clear all control points, choose the appropriate button in the 
Digitizer Setup dialog. A dialog appears for each button to walk you through the 
steps.
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For instance, to add a control point, choose Add. The Pick Tablet Point dialog displays 
telling you to choose a point on the tablet and click a digitizer button. Now the Add 
Control Point dialog displays prompting you for a label (optional) and the map 
coordinates for the point. When you are through, click OK. Repeat this process for 
each control point you enter. 

Keep in mind that you must enter the coordinates in the units you specified in the 
Digitizer Setup dialog. If your map unit is in degrees, be sure to type in the 
coordinates as decimal degrees. For a discussion on converting degrees, minutes, and 
seconds to decimal degrees see Converting Coordinates in the Appendix.

Editing Control Points
To edit a control point, choose the point from the list of control points in the Digitizer 
Setup dialog and press the Edit button. The Edit Control Point dialog displays. Make 
the appropriate changes to the label or X and Y coordinates.
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You can also change the tablet position of the point through this dialog. For instance, 
if the coordinates are correct, but you realized that you clicked on the wrong point on 
the tablet, you can choose the Tablet X-Y button in the Edit Control Point dialog. This 
is easier than adding a new control point and removing the incorrect one.

You can also remove a control point by highlighting the point in the Setup dialog and 
choosing the Remove button. To remove all points and reset the projection to that of 
the active Map window, choose Clear All.

Saving Control Points
You can save your control points to a workspace. This is helpful if you must interrupt 
the session before you have finished entering your control points. When you open the 
workspace later, MI Pro automatically turns digitizer mode on. There are some cases 
where MI Pro will not be able to turn on digitizer mode. They are the following: 

• If there are less than 3 control points entered in the workspace. You will need 
to enter at least 1 or 2 more control points in Digitizer Setup.

• If your control points run in a straight line. You must enter control points that 
are at different angles from each other. 

• The digitizer size or resolution has changed since the workspace was saved. 
You will need to enter new control points in Digitizer Setup. 

These problems do not, however, prevent the workspace from opening. 

Control Point Error
You should use at least four control points when digitizing a paper map. When 
digitizing an aerial photograph or an image without a projection, you might want to 
use 30 or more control points. 
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MI Pro uses the control points to perform an affine transformation, whereby the 
digitized objects are skewed, shifted and scaled to fit the control point locations. 

MI Pro determines the relative positions of the control points based on the coordinates 
you specify. It can then determine where those points should be on the tablet. MI Pro 
then calculates an error estimate that is the difference between where the point should 
be on the tablet and where you actually clicked. 

The error estimates give you an idea of how accurate the resulting computer map will 
be. Error values should be quite small, on the same scale as the resolution of your 
digitizer. In most cases errors should be in thousandths or hundredths of an inch. 
Those errors approaching a tenth of an inch are probably too large. 

To minimize the likelihood of a high error estimate, increase the number of control 
points and be as precise as possible when specifying the coordinates for control 
points. Double-check that you specified the correct projection in Digitizer Setup. 

Configuring Digitizer Buttons
To configure the buttons on your digitizing puck, click Buttons in the Digitizer Setup 
dialog. The dialog that displays will instruct you to click the digitizer button that you 
want to use as the main button and then to click the digitizer button that you want to 
use as the double-click button. 
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If you only have one button on the puck, you will use it for both drawing and 
completing the polyline/polygon. A single click enters a point when drawing an 
object; a double-click completes the object. Note: If you use the same button for single-
clicking and double-clicking, MI Pro may mistake rapid single-clicks as a double-
click.

Digitizer Mode
MI Pro automatically turns digitizer mode on after you have entered three or more 
control points. Not only does it turn on automatically, but with the additional 
capabilities now available in digitizer mode, there is little reason to turn it off. 
Digitizer mode no longer locks you in. You do not have to exit from digitizer mode to 
do something else. You can now do anything in digitizer mode that you can do in 
mouse mode: open tables and windows, use any of the tools, use the mouse, etc.   

You can still, however, turn digitizer mode off and on with the D key. Again, similar to
when you have saved control points to a workspace, MI Pro will not turn digitizer 
mode on if you have only entered one or two control points or if your control points 
run in a straight line. 

The details of the new digitizer mode functionality is explained below. 

Using Tools with the Digitizer
You can use any of the tools with the digitizer. You are no longer limited to just the 
drawing tools, as you were in version 3.0. Now, for instance, you can zoom in on the 
area you are digitizing with the Zoom in tool, use the Ruler tool to measure distances, 
or add nodes, etc. without ever having to leave digitizer mode. 

Mouse Cursor
You can now use the mouse and the digitizer at the same time. The mouse is always 
active, even when digitizer mode is on. So you no longer need to exit from digitizer 
mode to use the mouse. The mouse cursor is always visible, and can always be 
controlled with the mouse. Its appearance depends on which tool is selected. 

You can also control the mouse with the digitizer using the mouse emulation 
capability of the digitizer driver (this must be configured outside of MI Pro). If 
digitizer mode is off, or if digitizer mode is on and a Map window is not active, the 
digitizer controls the mouse. If a Map window is active and digitizer mode is on, the 
digitizer controls the digitizer cursor.
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Digitizer Cursor
The digitizer cursor is now a large cross hair that covers the entire width and height of 
the Map window. Its appearance does not change to indicate which tool is selected. It 
is always a large cross hair, making it much easier to see.   

The digitizer cursor is always visible as long as a Map window is active. For example, 
if you decide to open a Browser window while you are in digitizer mode and work in 
the Browser, digitizer mode will still be on, but because the Browser is now the active 
window, you won’t see the digitizer cursor.

The status bar only displays the digitizer cursor location if you choose to display it 
(Map > Options). This is different than MI Pro 3.0, where the cursor location always 
displayed in the status bar while digitizer mode was on. 

igitizing Your Map
Once you have specified the control points, projection and map units of your map and 
have determined that the error for control points is acceptable, you are ready to 
digitize your map. 

To begin digitizing:
1. Make the Map window active and make a layer editable.
2. Choose any tool.
3. Choose Map > Change View to set the zoom of the Map window to be larger 

than the area of the map you are digitizing. This will keep the cursor in view 
during digitizing.

4. In the Change View dialog, specify the X and Y coordinates of a point that 
generally falls in the center of the map to be digitized. 

5. Click OK. The Map window now shows roughly the same area as your paper 
map. If you have entered at least three control points in the Digitizer Setup 
dialog, digitizer mode should be on, and the digitizer cursor should appear in 
the Map window. 

6. Press the D key to turn on digitizing mode. The cross hair cursor now 
becomes a cross hair. 

7. Begin tracing the map. 

Note:  MI Pro does not support digitizing in stream mode. 
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Tracing Existing Objects
MI Pro makes it much easier to trace an existing polygon network, e.g., the United 
States. The new autotrace feature allows you to easily trace the nodes of an object 
when using the Polyline or Polygon tools. This makes it easier to digitize objects that 
share a border because you don’t have to re-digitize the shared portion of the border. 
You can autotrace it. 

Autotrace is available when Snap mode is turned on. Note that you can only use 
autotrace with existing polylines and polygons. You cannot autotrace rectangles, 
ellipses, arcs, or other shapes made with the drawing tools.

To autotrace a polyline/polygon while digitizing, do the following:
1. Activate Snap mode (press the S key), and click on a node of the polyline/

polygon you want to autotrace.
2. Move the puck to another node of the same object. 
3. Do one of the following:   

For polylines, hold down the Shift key and click.

For polygons, hold down either the Shift or Ctrl key and click.

As soon as you press either the Shift or Ctrl key, MI Pro highlights the path to 
be autotraced. When you click, MI Pro automatically traces all the segments 
between the two nodes and adds them to the polyline/polygon you are 
drawing.

Note: The Shift key autotraces the shorter path between the two nodes (the 
path with the lessor number of nodes), and the Ctrl key autotraces the longer 
path (the path with the greater number of nodes). Autotrace works the same 
way as when you are selecting multiple nodes in Reshape mode.

You can only autotrace one object at a time. The second node you Shift/Ctrl-click on 
must belong to the same object as the first node. If it belongs to a different object, MI 
Pro will draw a straight line between the two nodes. If you click on a node that’s 
shared by two objects (e.g., a shared border), you can begin autotracing from either 
polygon. 
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roubleshooting Tips

Digitizer Mode – D Key
You must be in digitizer mode when you begin to trace your paper map. This is so MI 
Pro can recognize the coordinates and place the map in the correct geographic context. 
If you trace the map in mouse mode, you are only drawing objects that do not have 
any tie to your paper map.

You are in digitizer mode when you click the D key or when you have entered at least 
three control points in the Digitizer Setup dialog. You should see the digitizer cursor 
in the Map window. It is a large cross hair that covers the entire width and height of 
the Map window. A Map window must be active for the digitizer cursor to display. 
The StatusBar will also say DIG when you are digitizer mode. 

Digitized Map Does Not Display in Expected Location
If your map does not display in its proper geographic location, it is likely that you did 
not specify the appropriate negative degree coordinates for your control points. If you 
zoom out to view the entire world, you will see your points in a different area.

At the Digitizer Setup dialog, be sure to specify negative coordinates if your map 
includes west longitude and/or south latitudes. For instance, for maps in the United 
States, you should specify a negative X coordinate. For Africa, the Y coordinate is 
negative. For South America, both coordinates are negative. (For Europe, both 
coordinates are positive).

If you still do not see your map in the expected location, it could be due to bad control 
points, incorrect projection, or map units, etc.

High Error for Control Points
A high control point error means that MI Pro thinks there is a discrepancy between 
the point you chose on the tablet and where the point should be, based on the 
coordinates you specified. This can lead to inaccurate maps.

To reduce the error, edit the control point to be more precise with your click. Check to 
make sure the coordinates you entered are correct. You can also increase the number 
of control points. 
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Distances Do Not Measure Properly
If you measured a segment on the tablet using the puck and Ruler tool, you will come 
up with inaccurate results. The only way you can measure a segment is to first digitize 
it, then use the Ruler tool to measure it on screen. 

If you still have bad results, it could be due to a setup problem (check projection and 
map units), control point problem (high error estimate, recheck coordinates), or 
inaccurate digitizing. 

When Switching to Digitizer Mode, the Digitizer Cursor Does Not 
Appear
If you do not see the cursor when you switch into digitizer mode, check to make sure 
the coordinates are correct. You may need to specify negative coordinates (see 
Digitized Map does not Display in Expected Location, above).

Other things to do:

Set the center of the map to be one of your control points. In the Change View dialog 
you can specify the coordinates of a point that falls in the general center of your paper 
map. 

Put the cursor exactly on one of the control points. 

Digitizer Cursor Jumps Off Screen When Digitizing
This happens when your Map window is set at a much different zoom than the map 
you are digitizing. Increase the active zoom to better reflect the area being digitized. 
For instance, if the map you want to digitize is 300 miles across, set the Map window 
zoom to about 300 using Map > Change View.

You do not have to see the digitizer cross hair to digitize, but it is helpful. View Entire 
Layer may also help, if working with a pre-existing map. It is also possible that the 
digitizing tablet is damaged and has empty spots. 

Digitizer is Connected but Digitizer Setup is Unavailable 
Check the following: 

• MI Pro supports the digitizing tablet you are using.

• Make sure the tablet is turned on and is correctly connected to the computer.

• The digitizer driver is properly installed. 

• The tablet is properly configured.
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• The right tablet/driver combination is being used.

• There is no problem with the tablet, the connection, or the connecting cables.

If the tablet works with other applications or is being used as a mouse pointer in 
windows, and everything listed above checks out fine, there may be a problem with 
our support of the tablet. If possible, configure the tablet to emulate different tablets 
supported by MI Pro. Make sure the system.ini file is updated to reflect the changes, 
and restart Windows each time a change is made to the system.ini.

If the tablet works with other applications or is being used as a mouse pointer in 
windows, and everything listed above checks out fine, there may be a problem with 
our support of the tablet. If possible, configure the tablet to emulate different tablets 
supported by MI Pro.

Digitizing Two Maps
You must set control points for each map individually, even if the maps are adjacent.

imitations
The Snap to nodes feature is available while digitizing. However, the snap tolerance is a 
pixel value that is based on the current zoom level of the Map window. Press the S key 
to turn Snap mode off. 

Auto polygon closure does not work in digitizing. You must click on the button you 
set up to close a polygon (or double-click on the button if you only have one digitizing 
button). 

If you change the zoom level of your map, or scroll in the Map window after you have 
selected your digitizer points and then switch into digitizer mode, your cursor may 
disappear from the screen, because the location in the map corresponding to the puck 
is no longer visible in the Map window. The active Map window view must 
correspond to the view represented on the paper map to see the cursor when in 
digitizer mode. Zoom out to see the cursor again. 
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Appendix A: MapInfo® Connections

There are many resources available for furthering your MapInfo knowledge and skills. Through 
Web sites, User Groups, and additional literature, you can improve your desktop mapping 
skills and improve your performance. This sections provides a list of some of these resources 
and give a brief description of each.

MapInfo on the Web

Thoen�s Web
Thoen’s Web is a web page authored by MapInfo Partner Bill Thoen. There are many links to 
GIS information in general and specific links to MapInfo resources. You can reach Thoen’s Web 
at:

http:/www.gisnet.com/gis/

Useful Sites for MapInfo Users
This page was developed by Marjorie Roswell and contains a wide variety of mapping resource 
links around the world. There are many MapInfo links as well as general geography links. You 
can reach Marjorie Roswell’s site at:

http://research.umbc.edu/~roswell/mipage.html

MapInfo-L
MapInfo-L is a mailing list monitored by Bill Thoen. MapInfo-L is one of the best resources for 
users to post and answer questions among themselves. Please follow the directions below 
closely to subscribe or unsubscribe to this free service.

To subscribe to MapInfo-L, send e-mail to: 

majordomo@lists.directionsmag.com

The subject should be left blank. The first line of the message should be: 

subscribe MAPINFO-L

To unsubscribe from MapInfo-L send e-mail to: 

majordomo@lists.directionsmag.com

The subject should be left blank. The first line of the message should be: 

unsubscribe MAPINFO-L

To obtain help on MapInfo-L, send e-mail to: 

majordomo@lists.directionsmag.com
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The subject should be left blank. The first line of the message should be: 

help MAPINFO-L

To post messages to MapInfo-L, send e-mail to: 

MAPINFO-L@lists.directionsmag.com

Note:  Any messages sent to the list can be read by anyone on the list.

Additional Reading
The following books are available to MapInfo users:

Johnson, Ian. Understanding MapInfo: A Structured Guide 

Sydney, Australia: Archaeological Computing Laboratory, 1996.

Daniel, Larry, Paula Loree, and Angela Whitener. Inside MapInfo Professional. Sante Fe: 

OnWord Press, 1996. 
576 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 573



Appendix B: Advanced Geocoding
Appendix B: Advanced Geocoding

To improve geocoding performance, you need to understand how MapInfo 

Professional® geocodes. The most complex scenario is for geocoding a street address, 
but the same considerations apply for geocoding to regions, such as ZIP Codes or 
counties. The difference is that regions geocoding does not involve the address 
number part of the process.

How MapInfo Geocodes
The objective of geocoding is to place point objects into your database. Let us call this 
table the target table. The geographical coordinates are from a source table, which is a 
mappable table. To geocode a record:

• MapInfo has to match an address in the target table with an address in the 
source table.

-and-

• Get geographic coordinates from the source table and use them to create a 
point object in the target table.

All of the problems in geocoding occur in the first step, matching addresses in the 
source and target tables.

Street addresses typically consist of two or three components:

• Street number.

• Street name.

• Apartment, Suite, Floor, Room number or some other piece of information. 
Many addresses do not have this component.

MapInfo has one procedure for dealing with the street number and another procedure 
for dealing with the street name. MapInfo deals with the third component, if present, 
as though it were a part of the street name.

Automatic and Interactive Modes
MapInfo has two geocoding modes:  automatic and interactive. The process MapInfo 
uses to match target addresses with source addresses is the same in both modes. 

Automatic mode matches addresses based on the choices in the Geocode dialog box. 
Interactive mode stops at each address that does not meet the geocode parameters 
and permits the user to assist in the matching process.

In most cases, the best geocoding strategy is to:
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• Geocode in automatic mode.

then

• Geocode in interactive mode to deal with the records MapInfo was unable to 
handle automatically.

The purpose of this appendix is to develop strategies for improving MapInfo’s 
performance on automatic geocoding, thereby reducing the number of records you 
must handle interactively.  

Exact Match
When MapInfo geocodes, it attempts to find an exact match between source and 
target street names. That means that the addresses must be the same, character for 
character. However, matching is not case sensitive; upper and lower case letters are 
successfully matched with one another. MapInfo does not get an exact match in many 
cases and can use a file of abbreviation equivalences to improve its “hit rate”. Once 
you understand the various ways in which a match can fail, you are in a better 
position to understand what you can do to improve things.

The table below illustrates exact matching. The first column contains a street name 
from a target table and the second column contains the corresponding street name 
from a source table. The third column says why they do not match. The fourth column 
indicates whether the particular problem is one which can be corrected through using 
the abbreviation equivalence file. This table assumes that the addresses are the 
contents of a single column in a table. While the street number would often be in the 
same column, we don’t indicate street numbers here because they are handled 
differently than street names.

Target Address Source 
Address Comment

Correctable 
with 
Abbreviation 
File?

LaSal St LaSalle St “LaSal” is the wrong spelling. No

La Salle St LaSalle St “La Salle” is the wrong spelling. No

LaSalle Ave LaSalle St “Ave” does not match “St”. No

LaSalle Street LaSalle St “Street” does not match “St”. Yes

LaSalle Ave LaSalle Av “Ave” does not match “Av”. Yes
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MapInfo’s matching process is not case-sensitive; it does not care whether a letter is 
upper case or lower case. This means that MapInfo treats the following as the same:  
Main, MAIN, main, maIN.

There are various ways of dealing with these issues. MapInfo has a file of substitute 
abbreviations which you can use to deal with many of these cases, which will be 
discussed later.

he Matching Process

Matching Street Names
MapInfo begins by comparing the street address in the target table with the street 
addresses in the source table. When it finds an exact match, it may be finished or it 
may have to deal with region information, such as town, county, or ZIP Code area.

LaSalle St. LaSalle St The target address has a period after 
“St”. That period is not in the source 
and causes the match to fail.

Yes

LaSalle LaSalle St “St” is missing from target. No

LaSalle St LaSalle Target has “St” and source does not. No

LaSalle St North LaSalle St Target has “North,” which is not in 
source.

No

LaSalle St North LaSalle St N Target has “North” instead of “N”. Yes

North LaSalle St N LaSalle St Target has “North” instead of “N”. Yes

North LaSalle St LaSalle St Target has “North,” which is not in 
source.

No

LaSalle St Apt 3 LaSalle St Target has an apartment number 
which does not match anything in 
the source.

Yes

Tenth St 10th St “Tenth” and “10th” do not match. Yes

10th Av Tenth Av “10th” and “Tenth” do not match. Yes

Saint John’s Lane St John’s Lane “Saint” and “St” do not match. Yes

Target Address Source 
Address Comment

Correctable 
with 
Abbreviation 
File?
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When MapInfo cannot match the street name for a particular row, it applies the 
abbreviation file to the target address. This file consists of pairs of items, such as 
“STREET ST” and “AVE AV”. When MapInfo finds “STREET” in a target address, it 
changes it into “ST”; similarly it changes “AVE” to “AV”. MapInfo doesn’t actually 
change your data in the target table. It substitutes abbreviations only for the purpose 
of making matches. The substitution is only effective during the matching process. 
The address in your table remains the same.

Once MapInfo has made an abbreviation substitution it attempts to match the 
resulting street name against the street names in the source table. When it fails to find 
an exact match at this point it:

• Moves to the next row (when it is geocoding in automatic mode).

• Presents you with the closest matches (when it is geocoding in interactive 
mode). You then pick the best match. MapInfo then goes to the next row.

At this point MapInfo will have done the best it can at identifying street names. The 
next step is to deal with address numbers for those addresses where it has matched a 
name.  

Matching Address Numbers
Given that MapInfo has identified a street, it now has to deal with street numbers. 
MapInfo stores address ranges with each street segment. MapInfo takes the street 
number from the target address and compares it to the ranges for each segment in the 
source table. For example, assume that we are trying to match “343 LaSalle St”. 
MapInfo stores the beginning and ending address for each segment, differentiating 
between left and right sides of the street, as follows:

To match “343 LaSalle St” MapInfo would scan the address ranges until it finds the 
one where “343” goes. Since 343 is between 333 and 375, MapInfo will locate this 
address on that street segment (the middle one in the table). 

Name FromLeft ToLeft FromRight

ToRight LaSalle St 269 331

268 330 LaSalle St 333

375 332 374 LaSalle St

377 401 376 400
580 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 577



Appendix B: Advanced Geocoding

M

Once MapInfo has matched an address number to a street segment it moves to the 
next row. When it fails to match a target street number to an address range on the 
appropriate street it:

• Moves to the next row if it is geocoding in automatic mode.

• Presents you with the closest matches if it is geocoding in interactive mode. 
You then pick the best match. MapInfo will then go to the next row.

At this point MapInfo will have done the best it can at locating address numbers. Note 
that one of the options (on the Geocode Options dialog) is to have MapInfo 
automatically pick the closest address range in those cases where there is no exact 
match—Use The Closest Address Number. For example, you might have “412” as an 
address number, but no range which includes that number. However, there is a range 
which goes from 346 to 400. Since that is the range closest to 412, that is where 
MapInfo will geocode 412 if you have chosen this particular option.

The next step is to deal with addresses which have been located on more than one 
street. 

Matching to Region
When MapInfo is geocoding it checks to see how many occurrences of the target 
address exist. If there is more than one, MapInfo must decide which source address to 
use. If the user’s target table has a column with region data, MapInfo can refine 
geocoding within a boundary. 

For example, assume that  you are geocoding a database of records in Cook county, 
Illinois. The address in the database reads 200 Washington St. Within the county of 
Cook, there are eight towns. Four of these towns have a Washington St. Three of the 
four have a 200 Washington St. MapInfo must now place the target address in the 
appropriate town. MapInfo uses region information to do this. MapInfo now matches 
a region designation for the target address against the region designator for the source 
addresses.
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When you originally set up your geocoding operation, you had an opportunity to 
specify a region (boundary) to use in refining your geocoding operation:

You could use any one of several different region types, including county name, town 
name, and ZIP Code. Since almost all addresses contain ZIP Codes, this is the most 
reliable way to refine your search.

When you set MapInfo to use ZIP Codes to refine its address matching, MapInfo will 
match the ZIP Code of the target address against the ZIP Code of the various 
matching source addresses. When it finds the correct match, it is finished with the 
geocoding process. MapInfo can now get coordinate information from the source 
table and use it to place a point object into the target table.

However, once MapInfo has completed this process, many addresses may be 
unmatched. You can match each one of them individually by geocoding in interactive 
mode. However, if you are working with a large database, you want to do as little of 
this as possible. There are other ways of improving MapInfo’s geocoding 
performance. 
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In the Geocode Options dialog, you can specify that MapInfo automatically pick a 
different boundary, providing there is only one, from the one you specify (Use A 
Match Found In A Different Boundary). You might have had MapInfo geocode 
addresses to Northtown. One particular address, “223 Locust Ct.” is not in 
Northtown, but it is in Westville, and no place else. In this case, MapInfo would 
geocode “223 Locust Ct. “ to Westville. However, if MapInfo had found a “223 Locust 
Ct.” in Westville and another one in Center Valley, it would not geocode the address 
to either town. It would leave “223 Locust Ct.” ungeocoded.

Return Codes
When you are using the result code option (in Geocode Options dialog)  MapInfo will 
generate a code for each record. These codes indicate the steps MapInfo took to 
geocode the record, whether or not the geocoding was successful, and whether or not 
the match was exact. You can use return codes to diagnose MapInfo’s geocoding 
performance. It will help you spot “false positives” resulting from using various 
geocoding options and to analyze why some records have not been geocoded. See the 
section on Result Codes, for information on these codes.

roubleshooting

Problems with Abbreviations and Substitutions
Your target table may contain address components which MapInfo cannot handle 
with its abbreviation file. For example:

You can deal with this problem in two ways:

• Edit addresses in your target table so that it contains items MapInfo can 
handle.

or

• Edit MapInfo’s abbreviation file so that it can deal with your addresses.

Ave. Does not recognize the period.

Suite Does not recognize this at all.

WK Does not recognize this at all.

# Does not recognize this at all.
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In many cases, the second alternative is easier. MapInfo’s abbreviation file (see below) 
consists of pairs of items. The second item in each line is the abbreviation for the first. 
In working with street files MapInfo searches through the address file to match an 
item in a target address with the first element in one of the pairs in the abbreviation 
file. When it finds a match it replaces the matching items with the proper 
abbreviation.

MapInfo supplies the following abbreviation file:

!Version 3.0

FIRST   1ST

SECOND  2ND

THIRD   3RD

FOURTH  4TH

FIFTH   5TH

SIXTH   6TH

SEVENTH 7TH

EIGHTH  8TH

NINTH   9TH

TENTH  10TH

NORTH  N

SOUTH  S

EAST   E

WEST   W

ALLEY     AL

AVENUE    AV

AVE       AV

BOULEVARD BLVD

BRIDGE    BR

CIRCLE    CIR

COURT     CT

DRIVE     DR
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EXTENSION EXT

HIGHWAY   HWY

INTERSTATE I

LANE      LN

MOUNT     MT

PARK      PK

PARKWAY   PKWY

PLACE     PL

PLAZA     PLZ

POINT     PT

RAILROAD  RR

ROAD      RD

ROUTE     RT

SAINT     ST

SQUARE    SQ

STREET    ST

STR       ST

TERRACE   TER

!EOLNOSPACE            

,                      

;             

#         

!EOLSPACE              

FLOOR                  

SUITE                 

“P.O. BOX”             

!NOSPACE               

.                     

\”                     
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\!                     

\\                     

!SPACE                

“STATE HIGHWAY”STHWY” 

“N ST”NORTH ST”

”S ST”SOUTH ST”

”E ST”EAST ST”

”W ST”WEST ST”

”N AV”NORTH AV”

”S AV”SOUTH AV”

”E AV”EAST AV”

”W AV”WEST AV”

You can make additions to this file to take care of various problems. Most importantly, 
you can make several different kinds of additions. MapInfo recognizes four classes of 
substitution items and it interprets these classes differently. Each class is preceded by 
the keyword used to identify it in the abbreviation file:

In order for MapInfo to know how to interpret a line, or set of lines, in the 
abbreviation file, you have to precede the line with the keyword which indicates the 
appropriate interpretation strategy.

When all of the entries in the abbreviation file use the default interpretation, there is 
no need to precede any of them with a keyword. When there is no keyword at the 
beginning of the abbreviation file, MapInfo will treat the initial entries as requiring the 
default interpretation. Once you add other types of substitution pairs, however, you 
have to start adding keywords. 

Substitution Class Keyword

Space-delimited simple substitution !SPACE

Simple truncation !EOLNOSPACE

Space-delimited truncation !EOLSPACE

Simple substitution !NOSPACE
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Space-Delimited Simple Substitution
Space-delimited simple substitution is MapInfo’s default. What that means is this:  
MapInfo compares spaced-delimited tokens in target addresses with the rows in the 
address file. A space-delimited token is a string of characters with a space before and 
a space after. For example, MapInfo will replace “Ave”  with “Av” in “Park Ave” but it 
will not change “Avery Blvd” to “Avry Blvd.”  Both street names contain the string 
“Ave”. But that string is bordered by spaces only in “Park Ave”, not in “Avery Blvd.”  
In “Avery Blvd”, “Ave” is followed by “r”, not by a space.

All of the entries in the abbreviation file will receive this default interpretation. You 
can add other items to receive the same treatment. For example, you might want to 
add the pair “WK WALK” so that MapInfo knows to interpret “WK” in a target 
address as though it were “WALK”. Similarly, you might want to add a pair such as:  
“CIRCLE CIR”. 

Use the keyword “!SPACE” to indicate space-delimited simple substitution. Entries 
following “!SPACE” are given the default interpretation (this allows you to arrange 
the Abb.file contents in some other order). When MapInfo encounters another 
keyword, it switches to the indicated interpretation strategy. 

Simple Truncation
In simple truncation, MapInfo finds an item in the address and simply ignores it and 
everything after it. These items do not have to be space-delimited. This strategy is 
useful for dealing with addresses such as:

123 Appian Way, Mail Stop 829

7305 Van Zandt #  23

In the first case, you want MapInfo to ignore the comma and everything after it. In the 
second case you want MapInfo to ignore the number sign and everything after it. To 
deal with such cases add the following to your abbreviation file:

!EOLNOSPACE

,

#

“!EOLNOSPACE” is the keyword indicating that the following items are to be treated 
as cases of simple truncation. After that we have one line with a comma and one with 
a number sign. Whenever MapInfo encounters a comma or a number sign in an 
address it will ignore it and everything after. The examples become:
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123 Appian Way

7305 Van Zandt

Space-Delimited Truncation
In space-delimited truncation MapInfo looks for items which are space delimited and 
eliminates those items and everything following. For example:

73 Appian Way Suite 829

3033 Van Zandt Room 202

To deal with such cases add the following to your abbreviation file:

!EOLSPACE

SUITE

ROOM

“!EOLSPACE” is the keyword indicating that the following items are to be treated as 
cases of simple truncation. After that we have one line with “Suite”and one with a 
“ROOM”. Whenever MapInfo encounters those tokens it will truncate the address. 
The examples become:

73 Appian Way 

3033 Van Zandt

Simple Substitution
MapInfo uses simple substitution to remove items from an address and otherwise 
does nothing. Use it to deal with:

433 Van-Rensselaer

91 St Albans’

The goal is to strip out the hyphen and the apostrophe. Make the following entries to 
the abbreviation file:

!NOSPACE

–

’

“NOSPACE” is the keyword calling for simple substitution, and the hyphen and 
apostrophe on the following lines are the tokens to be removed. The examples 
become:
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369 VanRensselaer 

91 St Albans

Legitimate Spaces
There are cases where you want to indicate a substitution in which the searched for 
string contains spaces. You can use double quotes in such cases. Place a double quote:

• at the beginning of the line

and

• between the searched for string and the substitution

and

• at the end of the line.

For example, you might want to substitute “STHWY” for “State Highway”. To do 
that, use the following line:

”State Highway”STHWY”

This provides a solution to a subtle problem, that of street names which match items 
in the abbreviation file. For example, “North St” and “Park Av” both have initial 
strings which match terms in the abbreviation file. Consequently, MapInfo will 
substitute “N” for “North” to yield “N St” and “Pk” for “Park” to yield “Pk Av.”  You 
could add the following lines to the Abbreviation file to rectify these substitutions:

”N ST”North ST”

”PK AV”PARK AV”

Note that these lines have to come after the entries which substitute “N” for “North” 
and “PK” for “Park”. If they came before, they would have no effect. Thus:  

...

...

NORTH  N

...

...

PARK PK

...

...
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”N ST”NORTH ST”

”PK AV”PARK AV”

...

...

When MapInfo encounters NORTH N it will turn NORTH ST into N ST. When it 
encounters “N ST”NORTH ST” it will then turn N ST into NORTH ST. PARK AV is 
treated similarly. 

Special Characters
MapInfo uses the exclamation point (!), the double quote (”) and the backslash (\) as 
special characters. These characters tell MapInfo how to treat strings which follow 
them, but are not themselves ordinarily treated as characters in substitution strings. 
The exclamation point tells MapInfo that the string should not be interpreted as an 
abbreviation. The double quote tells MapInfo that spaces in the string are legitimate. 
And the backslash tells MapInfo to treat a special character as an ordinary character.

When you want to use any of these in a line where they are to be treated as simple 
characters, precede them by a backslash. Thus:

\!

\”

\\ 

Adding Lines to the Abbreviation File
You can add a new item to the file by adding a new row. The order in which you add 
rows is not significant, except in those cases where you expect one substitution pair to 
compensate for the effects of another. The number of spaces between the first and 
second items in a row is not significant either. 

The abbreviation file is a simple ASCII file — MAPINFOW.ABB. You can edit it in any 
text editor or word processor. Open the file and make your additions, adding 
keywords as necessary.

Spelling Errors in Street Names  
When your target table has an address name spelled differently than the source table, 
MapInfo cannot make a match. There are three possibilities to consider:

• Geocode interactively. 
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When you are geocoding interactively, MapInfo displays a dialog that lists close 
alternatives.

Use the Up and Down keys to scroll through the list and choose a street. 

• Edit the target table.

When you think there are too many errors in your target table, you can edit the target 
table before geocoding it. MapInfo’s Update Column function is useful for editing 
tables.

However, it is possible that the street is spelled incorrectly in the source table. 

• Edit the street name in the source table.  

Alternate Street Names, Street Name has Changed
Since a street name may change, your map will reflect the old name and so it will not 
match addresses which employ the new name. You can edit the map to reflect the 
name change, but then it will not reflect addresses using the old name. You want to be 
able to match addresses using both the old and new names.

You can deal with the problem by adding another row to the file of street names, as 
follows:

1. Open the filename.tab file – the street name file of your street map (not the 
segment file).

2. Find the row with the street name you want an alternate for and note its 
MI_REFNUM value.
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3. Add a new row with the alternate name AND the same MI_REFNUM as the 
primary name.

4. Save and close the file.

MapInfo will now recognize both names in addresses being geocoded.

Incorrect Address Ranges 
When a target record has an address which is not in any of the ranges in the source 
table, MapInfo will not be able to match it. Such an address might fall into a gap in 
range numbers or it might be beyond the ends of the ranges. There are three 
possibilities for handling this problem:

• You can enable the option to Use The Closest Address Number in the 
Geocode Options dialog. MapInfo will then geocode unmatched address 
numbers to the closest existing range, placing the record at the center of that 
range.

or

• You can deal with such cases in Interactive mode. MapInfo will give you a list 
of known address ranges. Select the closest address range from the list or click 
on Ignore to ignore the record.

or

• It is possible that the address is for a street segment that was added after your 
source map was made. In that case, you may want to edit the source map so 
that it reflects the full range of addresses for that street.

Post Office Boxes 
StreetInfo tables do not contain Post Office boxes. When your database contains Post 
Office boxes, you will not be able to geocode them to a StreetInfo table. You have to 
geocode these records in a different way.

For example, if you know that a table contains many addresses with Post Office boxes, 
you could first select all the rows containing Post Office boxes and geocode those 
rows to ZIP Code. Then you can geocode the remaining records to street address.

To find all the addresses containing Post Office Box numbers you need to have some 
way of identifying them. One plausible indicator is the word “box”. Use MapInfo’s 
InString$ function to select all records containing the substring “ Box ”. Note the 
spaces on either side of “box”. By telling MapInfo that we want those spaces, we make 
sure we will not include, for example, addresses on Boxwood Street. Using either 
Select or SQL Select, you want all records which meet this test:
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InString$(1,ADDRESS,” BOX ”)>0

The number “1” tells MapInfo to search address entries starting with the first 
character. “ADDRESS” is the column containing the street address. “ BOX ” is the 
substring MapInfo is searching for. When MapInfo finds “ BOX ” in an address, it 
returns a number indicating the position of the first character of “ BOX ” in the 
address. It follows that, for any record where the value of Instring$ is greater than 
zero, that address contains 

” Box ”.

You can now geocode this Selection to ZIP Code. That will take care of those records. 
Then you can geocode the whole database to addresses. Since those with Post Office 
boxes have already been geocoded, MapInfo will skip over them.

Inaccurate Town Names
MapInfo’s last geocoding step is to determine in which region to place a matched 
street address. MapInfo only takes this step if you have so specified when you set up 
the geocoding process. It is common to use town or city name as the refining 
boundary. This causes problems because people often do not use the town name 
which the Census Bureau assigns to their address. Since almost all electronic maps of 
the United States are based on Census Bureau maps, this will cause problems. 

For example, the address “50 Wolf Rd., Albany, NY” is actually in the town of Colonie. 
Thus the address town name in the target address will not match the appropriate 
town in the source file against which it is being geocoded. 

One way to deal with this problem is to enable the Try Searching In A Different 
Boundary option on the Geocode Options dialog. When this option is enabled, 
MapInfo will geocode an address to whatever boundary that address is in, providing 
that address is in only one boundary. When the address is in more than one boundary, 
the geocoding will fail.

Another way to deal with this problem is to use the ZIP Code as the refining 
boundary, rather than the town or city name.

Using Result Codes
Specify a numeric field (Geocode Options dialog) in which MapInfo will write a code 
indicating which steps were taken to geocode the record or why the record did not 
match. These codes can be very useful in catching “false positive” matches and in 
improving the “hit” rate by diagnosing problems and correcting them.
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The return code is a three-digit number, with each digit indicating a particular aspect 
of the geocoding operation. MapInfo “scores” each record on each aspect and adds 
the three numbers together to get the result code for that record. For example, a result 
code of 122 means:

• The address was found in one other boundary:  100

• The exact address range was not found:  20

• Abbreviation file substitutions were made:  2

The tables below indicate the significance of each element in the code.

The return codes have been designed so that non-matches will have a negative value 
and matches will have a positive value. A record which has not been tried will have a 
return code of zero. 

Codes indicating how MapInfo has treated street names appear in the one’s place of 
the result code.

<0 Not matched

  0 Not tried

  1 Exact match

>1 Inexact match

1 Exact match found

2 Abbreviation file applied

3 (-) Exact match not found

4 (-) No street specified

5 User picked a name from the list

00 Exact address range and side of street found

10 Address range found, but could not determine side of street

20 (+/-) Address range not found, but within minimum and maximum ranges

30 (+/-) Address range not found, but beyond minimum and maximum ranges

40 (+/-) Address range not specified, but matched to minimum range

50 (-) Streets do not intersect

60 (-) Signifies the row has no object

70 User picked an address from the list
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Codes indicating how MapInfo has treated address ranges appear in the ten’s place of 
the result code.

Codes indicating how MapInfo has treated refining boundaries appear in the 
hundred’s place of the result code.

Once you have result codes, you need to find out how your records were handled. 
You can use the following SQL Select statement to find out which result codes 
appeared in your table and how many records were returned with each code value:

The resulting query table will have a row for each different three-digit result code and 
a count of how many records had that code. You can then use Select or SQL Select to 
select all the records with a particular code. You can then browse these various 
selections and determine how to handle each class of records.

Refining-Boundary Codes

100 (+/-) Address range found in only one boundary other than specified boundary

200 (-) Address range found in more than one boundary other than specified 
boundary

300 (+/-) No boundary specified, but found in only one

400 (-) No boundary specified, and found in more than one

500 Exact street address found more than once in the specified boundary

 600 User picked a boundary from the list

1000000 (+/-) User typed something new

Select columns Result_Code, count(*)

from tables SomeData

group by columns Result_Code
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Examples of Codes
675  User pick street name, address range, and boundary.

101  Exact match found in exactly one boundary other than boundary specified. 
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Appendix C: Data and Settings Management

Upgrading Applications from Versions Prior to 7.0

MapInfo Professional® Data and Settings 
Management � Application Data Files
Application data (appdata) files are the non-executable data files that MapInfo 
Professional uses during execution. The following files/directories are considered 
appdata:

Prior to version 6.5 these files were kept in the Windows directory or the Program 
directory, and MapInfo Professional searched those directories for the appdata files. 
Since the introduction of version 6.5, the strategy is to install application data files in a 
per-user location, and also search for them in other areas to allow support for sharing 
application data files between MapInfo versions/products. 

Filename Description

mapinfow.prf Preference file

mapinfow.wor Default workspace

startup.wor Startup workspace

mapinfow.clr Color file

mapinfow.pen Pen file

mapinfow.fnt Symbol file

custsymb Custom symbol directory

thmtmplt Theme template directory

graphsupport Graph support directory
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Now the application searches for appdata files in the following directories, in this 
order:

appdata_dir
local_appdata_dir
pref_dir
common_appdata (new in version 7.0)
program_dir

Note:  Refer to the Glossary for definitions of each of these directory types.

The following table gives the default (installed) location for each appdata file in 
version 7.0:

After installation, you can manually move appdata files between the predefined 
locations. For example, by manually relocating mapinfow.prj a user can share one 
customized projection file between different versions of MapInfo Professional.

The default installed location of one or more of the appdata files/directories can be 
modified by defining a mode.ini file prior to the installation. See Chapter 2, 
Installation for particulars on the mode.ini file.

Filename Default installed 
location

mapinfow.clr appdata_dir

mapinfow.pen appdata_dir

mapinfow.fnt appdata_dir

mapinfow.abb program_dir

mapinfow.prj program_dir

mapinfow.mnu program_dir

custsymb appdata_dir

thmtmplt appdata_dir

graphsupport common_appdata_dir

mapinfo.prf pref_dir*

*This file is not created during installation. It is created the first time you 
exit MapInfo Professional.
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Registry Changes
MapInfo Professional's use of the registry must be organized to allow each user to 
work with their own data. The following changes were made to support this 
organization:

• The Tool Manager entries are now installed under HKEY_CURRENT_USER.

• The graph engine now stores custom colors and number formats under 
HKEY_CURRENT_USER.

A Glossary for Upgrading Applications
 You will find the following definitions useful:

<user profile root>

The root of the user directory structure. Each user has write access to the 
subdirectories of this area. The location varies depending on the Windows 
version:

Windows 2000/XP: c:\Documents and Settings\<username>

Windows 98: <Windows dir>

Windows NT 4.0: <Windows dir>\profiles\<username>

pref_dir

MI Pro writes out mapinfow.prf and mapinfow.wor by default.

6.0: Windows directory

6.5 (and following): <user profile root>\Application 
Data\MapInfo\MapInfo. If this directory does not exist at startup, then MI 
Pro creates it.

program_dir

In 6.0 MI Pro expects to find many of the appdata files in this location.

6.0: location of mapinfow.exe

6.5 (and following): location of mapinfow.exe
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appdata_dir

This is a per-user directory. Many of the appdata files will be installed in this 
location.

6.0: n/a

6.5 (and following): <user profile root>\Application 

Data\MapInfo\MapInfo\Professional\6501. 

Note:  If this directory does not exist at startup, MI Pro does not create it. 
Programmers must not assume this represents a valid path.

local_appdata_dir

This is also a per-user directory, similar to appdata_dir, except files here do 
not roam.

6.0: n/a

6.5 (and following): <user profile root>Local Settings\Application 

Data\MapInfo\MapInfo\Professional\650*.

Note:  If this directory does not exist at startup MI Pro does not create it. 
Programmers must not assume this represents a valid path.

common appdata_dir

This directory is shared by all users on a machine (new in version 7.0)

6.0: n/a

6.5: n/a

7.0: <userprofile root>\All Users\Application Data\MapInfo\
          MapInfo\Professional\700

 

1.Version number: 6.5=650, 7.0=700, etc.
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Formulating expressions is something like writing sentences. There is a vocabulary of 
words from which you can draw, and these words have to be combined according to 
syntactic rules. The syntax of expressions is much simpler than the syntax of English, 
and the vocabulary is vastly smaller. However, most of us have been using English for 
years and so it seems easy and natural whereas formulating expressions is, at first, 
sometimes a bit difficult.

However, just as English has simple sentences and complex sentences, so there are 
simple expressions and complex ones. Even if you don’t get the hang of formulating 

complex expressions, you can still use all the MapInfo Professional® commands that 
use expressions. That is because formulating simple expressions is very easy and, at 
the same time, allows you to work with your data in powerful ways.

Constructing Expressions

Simple Expressions
You formulate expressions using column (field) names and constants (i.e. specific data 
values), on the one hand, and functions and operators, on the other. Think of the 
column names and constants as nouns, and functions and operators as verbs, 
prepositions and conjunctions. You always need at least one column name or a 
constant in an expression. How many operators and functions you need depends on 
what you want to do with your expression.

The simplest possible expression consists of a column name, for example:
1. POP_1990

2. STATE

You could use such an expression in Thematic Mapping to indicate what data is to be 
represented on the map. In Update Column such an expression would tell MapInfo 
Professional what data to use in updating a column in the target table. 

Here are some slightly more complex expressions:

3. POP_1990 > 17893

4. POP_1990 <= POP_1980

5. COUNTY <> ”Orange”

6. POP_1980 * 1.2

7. POP_1990 / TOTAL_AREA

8. round(POP_1990/TOTAL_AREA,.1)
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The first three examples use comparison operators. The first tests to see whether the 
1990 population is greater than (>) some constant (17893). The second tests to see 
whether the value of one column, POP_1990, is less than or equal to (<=) the value of 
another column, POP_1980. The third tests to see whether or not the county is Orange. 
When the county does not equal (<>) “Orange” the record is selected. You could use 
any of these expressions in Select or in the Where Condition clause of SQL Select. 
These commands allow you to select a subset of the records in a table. The expression 
defines the characteristics of the subset.

Examples 6 and 7 use arithmetic operators. Example 6 multiplies (*) the value of 
POP_1980 by a constant (1.2) while example 7 divides one column, POP_1990, by the 
value of another column, AREA. 

Example 8 uses the round function to round the value of the expression “POP_1990/
TOTAL_AREA” to the nearest tenth (.1). 

Expressions 6, 7 and 8 don’t have comparison operators and therefore they would not 
be suitable for use in Select or in the Where Condition clause of SQL Select. However, 
you could use them alone in Thematic Mapping, Update Column, or Select columns 
in SQL Select. 

Complex Expressions
Now consider examples 9 and 10, that are a bit more complex than 1 through 8:

9. POP_1990 > POP_1980*1.2

10. round((POP_1980*1.2)/TOTAL_AREA,.1)

We created expression 9 by taking expression 3 and replacing the constant “17893” 
with the whole of expression 6. Similarly, we created expression 10 by taking 
expression 8 and replacing “POP_1990” with expression 6.

In general, you create complex expressions by combining simple expressions. Perhaps 
the best way to learn how to do this is look at some of the examples we have provided 
(above and following) and create your own expressions based on those examples. 
However, there are two very general techniques for creating complex expressions.

• Replace a column name or a specific value with a simple expression.

• Combine expressions using logical operators (and, not, or).

Example six illustrates the first technique. There are many examples of the second 
technique throughout this entry. See particularly the discussion following “Logical 
Operators”.
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Entering Specific Values (Constants)
When entering specific character strings, numbers, and dates into expressions, you 
need to follow certain conventions.

Character Strings
When typing a particular string into an expression, you should enclose it in double 
quotes so that MapInfo Professional knows to treat it as a string, rather than treating it 
as a column name. Examples 11 and 12 are valid string constants, but 13 and 14 are 
not.

11. ”Orange”
12. ”New York”
13. Orange
14. New York

Numbers 
When entering specific numerical values, do not use thousands separators or 
currency symbols (such as dollar signs) or any characters other than numerals, the 
decimal sign (.) or commas (,) and the minus sign for negative numbers. 

Dates 
Dates consist of a month, a day, and an optional year. The year is specified by two or 
four digits and should be enclosed in double quotes. The components of a date can be 
separated by hyphens or slashes. The following are valid data constants:

15. ”1–20–92”
16. ”01/20/1992”
17. ”1/20”  
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Operators

Mathematical operators:

Note that you can:

• Add numbers to dates to yield another date,

• Subtract a number from a date to yield another date,

• Subtract a date from a date to yield a number.

When you add numbers to dates, or subtract numbers from dates, MapInfo 
Professional treats the numbers as specifying a number of days. If you want to add or 
subtract a week, you would use the number 7. When you want to add or subtract a 
month, you could use 30 or 31. When MapInfo Professional subtracts a date from a 

date, the resulting number indicates a number of days.  

String operator:

Strings must be enclosed in double quotes. Consider the following example:

”Ms.” + Last_Name

When MapInfo Professional evaluates this as part of an expression it places “Ms. “in 
front of each last name. Note that the string constant (“Ms. “) is in quotes. Similarly,

”Hello,” + ”world”

gives you “Hello, world.” And

”4”+”5”

gives you “45.”

Operator Description Example
+ plus A + B
- minus A - B (subtraction)

-A (negative)
* times A * B
/ divided by A / B
^ exponentiation A ^ B
\ integer division A\B

mod modulo arithmetic A mod B

+ “concatenation” — connects strings and string expressions.
& (can be used if preceeded by a space)
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Comparison operators:

Numerical Comparison
Numerical comparisons are based on the numerical values of the expressions and 
numerical constants. 

English: All rows where the household income is above $65,000.

18. HH_INC>65000
Comment: Don’t add the dollar sign or comma. MapInfo Professional doesn’t know 
what to do with it and gives you an error message. 

English: All rows where the median age is 42.

19. MED_AGE=42
Comment: This expression selects only those records where the median age is exactly 
42. When your median age data contains a decimal portion (which is the case for 
MapInfo Professional-supplied demographic data) then it is unlikely that there are 
many regions with a median age of exactly 42. 

The following expression gives you better results:

20. Round(MED_AGE, 1)=42
Comment: The function “round(somenumber, somenumber)” rounds the first number in 
the way specified by the second. In this example, the first number is the median age 
(MED_AGE) and the second is 1, indicating that median age is to be rounded to the 
nearest whole number.

English: All rows where the amount does not equal $23,000.

21. AMOUNT<>23000
Comment: You might want to use the Round function, as in 10, if you are not 

concerned that the value be exactly 23000. 

Operators Description
= “equals” 

<> “not equals”
> “greater than”
< “less than”

>= “greater than or equal to”
<= “less than or equal to”
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String Comparison
String comparisons are based on the exact character content of the string.  In this case 
“>” means “alphabetically greater than” (i.e. comes after in the alphabet) and “<” 
means “alphabetically less than.” 

When typing a string into an expression, you should enclose it in quotes so that 
MapInfo Professional knows to treat it as a string, rather than treating it as a column 
name.

English: All rows where the vendor is Acme.

22. VENDOR=”Acme”
Comment: Note that Acme is in quotes so that MapInfo Professional knows to treat it 
literally (as a character string) rather than to search for a column named Acme. 

English: All rows where the vendor is not Acme.

23. VENDOR<>”Acme”

Date Comparison
English: All entries received on October 9, 1991.

24. RECEIVED=”10–9–91”
Note:  
• The date is enclosed in quotes. 

• It is in the form: Month, Day, Year. 

• The numbers in the data are separated by  a hyphen or  a slash (/). 

• Two characters were used for the year. You can also use four characters (1991).

English: All received after October 9, 1991.

25. RECEIVED>”10–9–91”
Comment: This expression does not select those received on October 9, 1991. When 
you want them as well:

26. RECEIVED>=”10–9–91”
English: Records for all received before August.

27. Month(RECEIVED)<8
Comment: This expression uses the Month function to extract the month in the date. It 
doesn’t specify any particular year. When your database has records for several years, 
this expression does not pay attention to the particular year. 
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Logical Comparison
English: All that have shipped.

28. Shipped
Comment: The column “Shipped” is a logical column. It contains “T” for true, or yes, 
and “F” for false, or no. When an order is shipped, it is marked “T”. Otherwise, it is 
not shipped. For orders that are shipped, expression 28 evaluates to true. For orders 
not shipped it evaluates to false.

English: All that have not shipped.

29. Str$(Shipped)=”F”
30. Not Shipped  

Geographic operators
MapInfo Professional has several geographic operators. Use them to select objects on 
the basis of their spatial relationship to some other object. MapInfo Professional has a 
special keyword you use with geographical operators: “obj” or “object”. This 
keyword tells MapInfo Professional that it has to get values based on the graphical 
objects in the table rather than the tabular data. 

The geographic operators go between the objects being specified. Select the 
geographic operators from the Operators menu.

Here are the geographic operators:

Contains Object A Contains object B if B’s centroid is anywhere within A’s boundary.

Contains Entire Object A Contains Entire object B if B’s boundary is entirely within A’s 
boundary.

Contains Part Object A Contains Part object B if B’s boundary is partly within A’s 
boundary.

Within Object A is Within object B if its centroid is inside B’s boundary.

Entirely Within Object A is Entirely Within object B if A’s boundary is entirely within B’s 
boundary.

Partly Within Object A is Partly Within object B if A’s boundary is partly within B’s 
boundary.

Intersects Object A Intersects object B if they have at least one point in common.
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“Contains Part” and “Partly Within” are exactly equivalent to “Intersects” -- these are 
all treated the same way by MapInfo Professional, so the standard syntax “Intersects” 
is almost universally used.

“Contains” and “Within” are concerned only with objects' centroids.

“Contains Entire” and “Entirely Within” are concerned with the area covered by a 
region object; the location of the centroid doesn't matter.

✭ - Object Centroid

Thus, if A, B, C, and D are all regions:

Object A contains Object B

Object A intersects Object B

Object A does not intersect Object C

Object B does not contain Object A

Object B intersects Object A

Object B intersects Object C

Object C contains Object D

Object C contains entire Object D

Object C intersects Object D

Object D does not contain Object C

Object D entirely within Object C

✭  A

✭ B

✭ C
✭ D
608 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 605



Appendix D: Creating Expressions

M

If A, B, C, and D are all polylines, then the Contains and Within operators are not 
applicable, but:

Object B intersects Object A

Object B intersects Object C

Object C does not intersect Object D

Object D does not intersect Object C

Similarly, a polyline can not contain a point, but it can intersect a point; a point can not 
be within a polyline, but it can intersect a polyline.

Note:  MapInfo Professional can perform a simple Contains or Within 
comparison more rapidly than a Contains Entire or Entirely Within. 
Therefore, unless you must be absolutely sure that objects are completely 
inside other objects you should use Contains and Within rather than 
Contains Entire or Entirely Within.

Logical operators:

“And”, “or”, and “not” are logical operators. You use them to combine expressions in 
Select and the Where Condition clause of SQL Select. MapInfo Professional treats each 
such expression as a test which it applies to each record in the table. For each test it 
gets a yes/no (true/false) answer. MapInfo Professional uses the logical operators to 
tell it how to combine the individual yes/no answers into an overall yes/no answer: 
Does the current record meet the selection condition?

Suppose you want to select all properties that are worth $250,000 or more and are in 
Columbia county. Each record has to meet two criteria, each of which can be 
formulated as a simple expression:

31. VALUE >= 250000
32. COUNTY = ”Columbia”

Operator Description
and is “true” if (and only if) both of its arguments (the expressions it joins 

together) are true. A record must satisfy both of these conditions if it is to be 
selected.

or is “true” if either one, or both, of its arguments (the expressions it joins 
together) are true. A record need satisfy only one of these conditions if it is to 
be selected. It is also selected if both of its conditions are satisfied.

not is “true” if its argument (the expression it applies to) is false. A record is 
selected if it does not meet the stated condition.
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You could perform one selection for all properties worth $250,000 or more. Then you 
could perform another selection on that result, looking for all properties in Columbia 
county. However, it is easier to combine the two operations into one using the logical 
operator “and”.

33. COUNTY = ”Columbia” and VALUE >= 250000
When MapInfo Professional examines a record to see whether or not it meets the 
condition set by this expression, it makes the two tests: Does COUNTY equal 
Columbia? Is the VALUE equal to or greater than 250000? When the answer to both of 
these questions is true (or yes), then the record is accepted into the current selection. 
When the answer to one or both of the questions is no (or false), then the record is not 
accepted into the current selection.

Now, what if you want all properties worth $250,000 or more and not in Columbia 
county? You can use “not” to negate the first clause of expression 33, yielding 
expression 34:

34. not (COUNTY=”Columbia”) and VALUE>=250000
Only records where the county is not Columbia satisfy the first clause of expression 
34. Now consider expression 35:

35. not (COUNTY=”Columbia” and VALUE>=250000)
Expression 35 is simply the negation of expression 33. Any record that would satisfy 
33 does not satisfy 35. Any record that does not satisfy 33 satisfies 35.

You can use “or” when you want to specify alternative conditions, such as:

36. COUNTY=”Columbia” or COUNTY=”Greene” 
Any record evaluated against this condition is accepted if its county is any one of the 
two specified counties. One could, of course, use numerical tests as well. For example:

37. TOTAL_AREA>40 or VALUE>250000
This tests to see whether the area is greater than 40 or the value is greater than 250000. 
When either one is true of a record, then that record is accepted into the selection.

In formulating expressions using logical operators you have to be careful how you use 
them. The following expression, while it seems OK, does not work:

38. COUNTY=”Columbia” or ”Greene”
Judging from its English translation—COUNTY equals Columbia or Greene—this 
expression should operate just like expression 36 and give us any record containing 
Columbia County or Greene County. But the rules of computational logic and the 
rules of English are a bit different. 
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When MapInfo Professional reads expressions it reads them from left to right. One of 
the things it has to do is to determine how the items in the expression are grouped. 
Think of this operation as inserting parentheses into the expression. MapInfo 
Professional reads expression 35 as though it were grouped like expression 39 (below) 
which is what we intend. It reads expression 38 as though it were grouped like 40 
(below) which is not at all what we want.

39. (COUNTY=”Columbia”) or (COUNTY=”Greene”)
40. (COUNTY=”Columbia”) or (”Greene”)

Both 39 and 40 have the same first clause. But their second clauses (after the “or”) are 
quite different. The second clause of 40 is simply a literal string, “Greene.” By 
convention, MapInfo Professional evaluates a record against a literal string as being 

true if that record is not blank. When MapInfo Professional evaluates records against 
expression 40, all non-blank records are evaluated as true and be accepted into the 
selection. It does not make any difference how a record evaluates on the first clause. 
Any non-blank record evaluates true on the second clause, and one “true” is all it 
takes to evaluate the entire expression as true.

Let us consider one final example, which is the negation of expression 36:

41. not (COUNTY=”Greene” or COUNTY=”Columbia”)
Expression 39 is satisfied if the county is Greene or if it is Columbia, but not if it is 
Montgomery or Warren. Expression 41 is satisfied by any county other than Greene or 
Columbia, including Montogomery and Warren.

Numeric Clauses
English: All the household income is above $65,000 and the median age is 42.

42. HH_INC>=65000 and Round(MED_AGE, 1)=42
Comment: This expression simply consists of two clauses. The clauses are connected 
by “and”, that means that both clauses must be true of a record for it to be selected.

English: All with a price between $50,000 and $100,000.

43. PRICE>=50000 and PRICE<=100000
Comment: Now we are setting two conditions that a record must satisfy in order to be 
selected. By using the operators “greater than or equal to” (>=) and “less than or equal 
to” (<=) we ensure that the records with the exact prices of $50,000 and $100,000 are 
selected. When we had simply used “greater than” (>) and “less than” (<), the 
expression would select $50,001 and $99,999 but not $50,000 or $100,000.
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English: All with a price between $50,000 and $100,000 or between $150,000 and 
$200,000.

44. (PRICE>=50000 and PRICE<=100000) or (PRICE>=150000 and 
PRICE<=200000)

Comment: This expression has the overall form: (expression1) or (expression2). Each of 
these expressions has the same form as expression 36. When a row meets the 
condition specified by either expression1 or expression2, MapInfo Professional puts the 
row into the selection.

String Clauses
English: All customers from N to Q.

45. LAST_NAME >= ”N” and LAST_NAME <”R”
Comment: The first part of the expression checks for names that are either 
alphabetically equal to “n” or that are alphabetically greater than (after) “n”. The 
second part of the expression checks for names that are alphabetically less than 
(before) “r”. Any name starting with letters “n” through “q” satisfies this condition.

English: All customers from N to Z.

Note:  MapInfo Professional comparison operators for strings are not case-
sensitive.

46. LAST_NAME >= ”N”
Comment: Since “z” is the last letter in the alphabet, there is no need to test for it. 
There cannot be any customers with a last name starting with some letter beyond “z”.

English: All customers whose last name begins with C.

47. LAST_NAME>=”C” and LAST_NAME<”D”
Comment: The logic of this expression is the same as the logic for expression 48.

English: All customers whose last name is between “Ce . . .” and “Cn . . .”

48. LAST_NAME=>”CE” and LAST_NAME<”CO”
Comment: The logic of this expression is the same as the logic for expression 46.

English: All not from Texas.

49. not STATE=”TX”
Comment: The expression causes MapInfo Professional to check the contents of the 

STATE column. When there is an entry other than “TX” the row is selected.  
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Date Clauses
English: Records for all received in August 1990

50. Month(RECEIVED)=8 and Year(RECEIVED)=1990
Comment: In this expression we specify the year explicitly, using the 
“year(<somecolumn>)” function to extract it from the date.

51. RECEIVED>=”8–1–90” and RECEIVED<=”8–31–90”
Comment: In this expression we don’t explicitly ask for month and year. Instead, we 
rethink a bit and use an expression that might more accurately be rendered in English 
as: Records for all received on or after August 1, 1990 and on or before August 31, 
1990. The two expressions give equivalent results, but they are formulated differently.

English: Records for all received in July or September

52. Month(RECEIVED)=7 or Month(RECEIVED)=9
Comment: As in a previous example, no year for the dates. Depending on the data in 
your table and what you’re trying to achieve, that may or may not be a problem. 
When you want to specify the year:

English: Records for all received in July or September of 1989

53. month(RECEIVED)=any(7, 9) and year(RECEIVED)=89
Comment: The first clause of this expression uses the keyword “any”, discussed 
below. The first clause is satisfied if any of the items in parenthesis match the month 
received — in this case, the months of July and September. 

Keywords
MapInfo Professional supports the use of keywords “any”, “all”, “in” and “between”. 
These keywords must be typed into expressions.

Use “any” to select any item in a set of items. 

54. ABBR = any(”AL”, ”MN”, ”TX”)
Expression 54 is true of any record where the state is Alabama, Minnesota, or Texas.

To understand the use of “all” consider expression 55:

55. ABBR <> all(”AL”, ”MN”, ”TX”)
This statement says: Give me all orders where the state does not equal Alabama, 
Minnesota, or Texas. It selects all orders except those from Alabama, Minnesota or 
Texas. Consider what would happen if we issued 56:

56. ABBR <> any(”AL”, ”MN”, ”TX”)
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Orders from Alabama would be selected because they are not from either Minnesota 
or Texas; and orders from Minnesota and Texas would be selected for a similar reason. 

This example, shows the use of “in”:

57. ABBR in(”AL”, ”MN”, ”TX”)
This produces the same result as 54. 

Note that “in” is equivalent to “=any” and “not in” is equivalent to “<>all”.

Finally, consider 58 and 59, which illustrate “between”:

58. PRICE between 50000 and 100000
59. (PRICE between 50000 and 100000) or (PRICE between 150000 

and 200000)

These are equivalent to expressions 43 and 44 respectively. You can also use between 
with character strings (such as are in examples 48, 50, and 51).

Operator Precedence
When MapInfo Professional evaluates expressions it needs to know which 
components of an expression to evaluate first. This is called precedence. By 
convention, certain operators are assigned different levels of precedence. Those with 
the highest level are evaluated first. The following table lists MapInfo Professional’s 
operators in the order in which they are evaluated. Operators at the same level of 
precedence are evaluated from left to right. Exponentiation evaluates from the right. 
This affects expressions with multiple exponents:   2 ^ -3 ^ -4 =  2 ^ ( - (3 ^ (-4)))

Highest Priority:

parenthesis
exponentiation
negation
multiplication, division
addition, subtraction
geographic operators
comparison operators
Not
And

Lowest Priority:

Or
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For example, the expression 3+4*2 produces a result of 11. That is because 
multiplication has a higher precedence than addition and is performed first, in effect:

3+4*2=

3+8=

11

We can add parenthesis to force MapInfo Professional to do the addition first:

(3+4)*2=

7*2=

14

Now consider expression 60, which is intended to select all records July or September 
of 1989.

60. year(RECEIVED)=89 and month(RECEIVED)=7 or 
month(RECEIVED)=9

Because “and” has higher precedence than “or”, MapInfo Professional treats this 
expression as though “year(RECEIVED)=89 and month(RECEIVED)=7” was enclosed 
in parentheses. 

61. (year(RECEIVED)=89 and month(RECEIVED)=7) or 
month(RECEIVED)=9

In this case, any record for July of 89 or for September of any year would be selected. 
That’s probably not what you want. However, by adding parentheses to the second 
expression, you can get what you want:

62. year(RECEIVED)=89 and (month(RECEIVED)=7 or 
month(RECEIVED)=9)

In this expression, the parentheses tell MapInfo Professional that 
“month(RECEIVED)=7” and “month(RECEIVED)=9” are alternatives in the second 
clause of the expression. MapInfo Professional treats this the same as it treats number 
21 above.

Note:  When you are not sure how MapInfo Professional evaluates an expression 
with several operators, you should use parentheses to group elements as 
you want them. 
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Functions
Functions take data values and perform some operation on them to produce a new 
value. Functions have the following form:

SomeFunction(parameters)

Most of MapInfo Professional’s functions take one or two parameters. A parameter 
can be a column or it can be another expression.

MapInfo Professional uses the keyword “obj” or “object” with the geographic 
functions: Area, CentroidX, CentroidY, ObjectLen, Perimeter. This keyword tells 
MapInfo Professional that it has to get values based on the graphical objects in the 
table rather than the tabular data. 

Abs
Syntax: Abs(num_expr)

Action: Returns the absolute value of a numerical expression. When the expression 
has a value greater than zero, Abs returns that value. When the expression has a value
less than zero, Abs returns a value equal to the value of the expression multiplied by 
negative one.

Example: Consider the following expression:

63. Abs(numA-numB)
(returns the absolute difference between numA and numB, regardless of 
which is larger)

The following illustrates how Abs works:

Abs(5) = 5

Abs(-3) = 3

Abs(-0.02) = 0.02

Area
Syntax: Area(obj, units) 

Action: Returns the area of the object. 0 is returned if the object has no area or there is 
no object for the record. Arcs, text, points, lines, and polylines do not have areas.
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When you choose Area from a menu the “obj” keyword is placed between the 
parentheses along with the current unit in double-quotes. In most cases the current 
unit is square miles. When you want area to be in some other unit, you should type 
the unit in, between quotes. 

Examples: To select all rows for objects that have an area greater than 59 square miles:

64. Area(obj,”sq mi”)>59
To calculate the population density for an object:

65. Population/Area(obj,”sq mi”)
To select all rows for objects with a population density less than 250 people per unit 
area:

66. Population/Area(obj,”sq mi”)<250
When you want the area in hectares:

67. Area(obj,”hectare”)
When you want the area in square kilometers:

68. Area(obj,”sq km”)

The units available are: Unit Name
square miles “sq mi”

square kilometers “sq km”
square inches “sq in”

square feet “sq ft”
square survey feet “sq survey ft”

square yards “sq yd”
square millimeters “sq mm”
square centimeters “sq cm”

square meters “sq m”
square chains “sq ch”

square links “sq li”
square rods “sq rd”

perches “perch”
roods “rood”
acres “acre”

hectares “hectare”
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CentroidX
Syntax: CentroidX(object)

Action: Returns the x coordinate of the centroid of the object, which is the longitude 
value for earth maps. The centroid is usually the center of the object’s minimum 
bounding rectangle (MBR). 

The value is in decimal degrees if the coordinates are latitudes and longitudes. The 
value is in whatever units were specified for the table if its coordinates are not 
latitudes and longitudes.

Examples: To select all objects west of New York City:

69. CentroidX(obj)<-73.997890
To select all objects east of New York City:

70. CentroidX(obj)>-73.997890
To select all objects northeast of New York City:

CentroidY
Syntax: CentroidY(object)

Action: Returns the y centroid of the object, which is the latitude value for earth maps.

The value is in decimal degrees if the coordinates are latitudes and longitudes. The 
value is in whatever units were specified for the table if its coordinates are not 
latitudes and longitudes.

Examples: To select all objects north of New York City:

71. CentroidY(obj)>40.750450
To select all objects south of New York City:

72. CentroidY(obj)<40.750450
73. CentroidX(obj)>-73.997890 and CentroidY(obj)>40.750450

The first clause in the expression selects objects east of New York City while the 
second clause in the expression selects objects north of New York City. Because the 
two clauses are joined by “and” an object must satisfy both clauses to be selected.
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To select all objects that are either north or east of New York City:

74. CentroidX(obj)>-73.997890 or CentroidY(obj)>40.750450
The first clause in the expression selects objects east of New York City while the 
second clause in the expression selects objects north of New York City. Because the 
two clauses are joined by “or” an object needs to satisfy only one of them in order to 

be selected. 

Chr$
Syntax: Chr$(num_expr)

Action: Chr$ interprets the value of num_expr as a character value. It returns the 
character corresponding to that value. Accordingly, num_expr should be an integer 
between 0 and 255. 

Example: You might want to have labels with information on two lines. You can use 
Chr$ to insert a carriage return into a label expression. The ANSI value for a carriage 
return is 13. Assume that you want the first line of a label to be a country name and 
the second line of a label to be the county population. 

The following expression produces that result:

75. Proper$(County)+Chr$(13)+Population
Note:  Some BASIC languages use the convention Chr$(10) to represent a line 

feed. MapBasic allows you to specify either Chr$(13) or Chr$(10).

Cos
Syntax: Cos(num_expr)

Action: The Cos function returns the cosine of the value of a numeric expression, 
where that expression represents an angle expressed in radians.

CurDate
Syntax: CurDate()

Action:  Returns a date value representing the current date.

Examples: To enter the current date into a column:

76. CurDate()
You might use this in conjunction with Update Column where you want to enter the 
current date into some column.
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To select all received 30 or more days ago:

77. Received<=CurDate()-30

Day
Syntax: Day(datefield)

Action: Returns the day of the month from the date. The day is represented as an 
integer from one (1) to thirty-one (31).

Examples: To select all rows where the date is the first of the month:

78. Day(date)=1
To select all rows where the day is Friday and the date is not the thirteenth:

79. Weekday(date)=6 and Day(date)<>13
This expression has two clauses. The first clause uses the Weekday function to select 
records where the day of the week is a Friday. The second clauses uses the Day 
function to select records where the day of the month does not equal (<>) 13. Since the 
two clauses are connected by “and” both clauses must be true for a row to be selected.  

Distance
Syntax: Distance(x1, y1, x2, y2, units)

x1 and x2 are East-West (Longitude) coordinates for earth maps
y1 and y2 are North-South (Latitude) coordinates for earth maps
Units is the current distance unit

Action: Calculates the distance between two points. 

When you choose Distance from a menu the “obj” keyword is placed between the 
parentheses along with the current unit in double-quotes. In most cases the current 
unit is miles. When you want distance to be in some other unit, you should type the 
unit in, between quotes. The units available are:

Unit Name Unit Represented 
“mi” miles
“km” kilometers
“in” inches
“ft” feet

“survey ft” survey feet
“li” links
“rd” rods
“ch” chains
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Examples: To calculate the distance between some objects and New York City, located 
at -73.997890 longitude and 40.750450 latitude:

80. Distance(-73.997890, 40.750450, CentroidX(obj), 
CentroidY(obj),”mi”)

To select all objects west of New York and not more than 20 miles from it:

81. CentroidX(obj)<-73.997890 and Distance(-73.997890, 
40.750450, CentroidX(obj), CentroidY(obj),”mi”)<=20

This expression has two clauses. The first clause specifies that an object must be west 
of New York to be selected. The second clause specifies that an object must be no more 
than twenty miles from New York in order to be selected. Since the two clauses are 
connected by “and” both must be true if an object is to be selected.

Format$
Syntax: Format$ ( value , pattern ) 

value is a numeric expression
pattern is a string that specifies how to format the results 

Action: Produces a string representation of the numeric value num_expr. 

Examples: The Format$( ) function produces a specially-formatted character string 
that incorporates a numeric value (specified by the value parameter). The Format$( ) 
function can embed a variety of formatting characters (e.g. currency symbols such as 
$, %, periods, and commas) to make the result string more readable or more 
aesthetically pleasing. Given a numeric value such as 12345.67 , your program can use 
the Format$( ) function to produce formatted results, such as $12,345.67 .

“yd” yards
“mm” millimeters
“cm” centimeters
“m” meters

“nmi” nautical miles (1 nautical mile 
represents 1852 meters)

Unit Name Unit Represented 
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The Format$( ) function’s value parameter represents the numeric value that you want 
to format. The pattern parameter is a string of code characters, carefully chosen (by 
you) to produce a particular type of formatted result. The pattern string should 
include one or more special format characters, such as #  , 0, % , the comma character, 
the period, or the semicolon character; these characters control how the results looks. 
The pattern string can also include one or more cosmetic characters, such as $ , - , ( , or 
) , to make the results more attractive.  

The table below summarizes the format characters. 

pattern 
control 
characters

Role in formatting results

# The result includes one or more digits from the value. However, if the control 
string contains one or more #  characters to the left of the decimal place, and the 
value is between zero and one, the formatted result string may not include a 
zero before the decimal place. 

0 A digit placeholder similar to the #  character; however, if the control string 
contains one or more 0 characters to the left of the decimal place, and the value 
is between zero and one, the formatted result string includes a zero before the 
decimal place. 

. The period character is used in conjunction with the #  character. When the 
pattern string includes a period character, then the number of #  characters to 
the right of the period dictates the number of decimal places that the result 
string displays.

, When you include a comma character before the first #  character, the result 
string includes a comma every three digits to the left of the decimal place. The 
number ten million would appear as “10,000,000” rather than “10000000”. 

% The result represents the value multiplied by one hundred; a value of 0.75 
produces a result string of “75%”. When you wish to include a percent sign in 
your result, but you do not want MapBasic to multiply the value by one 
hundred, place a \ (backslash) character before the percent sign (see below)

E+ The result is formatted according to scientific notation; for example, the value 
1234 produce the result “1.234e+03”.  When the exponent is positive, a plus 
sign appears after the “e”.  When the exponent is negative (which is the case 
for fractional numbers), a minus sign appears after the “e”. 

E- This string of control characters functions just as the “E+” string, except that 
the result never shows a plus sign following the “e”. 

; By including a semicolon in your pattern string, you can specify one format for 
positive numbers and another format for negative numbers. The semicolon 
should appear after the first set of format characters, and before the second set 
of format characters.  The second set of format characters applies to negative 
numbers. If the pattern string includes a second semicolon, the third format 
string (following the second semicolon) will be used to format the special-case 
value of 0 (zero).
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In the table below, the left column shows sample strings that you could use as the 
Format$( ) function’s pattern parameter. The middle column shows sample numbers, 
such as you might use as the value parameter. The right column shows the results that 
Format$( ) would return, given the parameters from the left columns. 

- When your pattern string includes both positive and negative formats in this 
fashion, the result does not automatically include a minus sign. When you 
wish to include a minus sign in the results, you should include a “-” character 
in the second set of format characters. See examples in table below. 

\ When the backslash character appears in a pattern string, MapBasic does not 
perform any special processing for the character that follows the backslash. 
This allows you to include special characters (such as the percent sign) in the 
results, without causing the special formatting actions described above. 

Pattern value parameter Format$( ) returns: 
“,#” 12345 ”12,345” 
“,#” -12345 ”-12,345”
“$#” 12345 ”$12345” 
“$#” -12345 ”-$12345”
“$,#” 12345 ”$12,345”
“$,#” -12345 ”-$12,345” 
“$,# .##” 12345.678 ”$12,345.68” 
“$,# .##” -12345.678 ”-$12,345.68” 
“$,# .## ;($,# .##)” 12345.678 ”$12,345.68”
“$,# .## ;($,# .##)” -12345.678 ”($12,345.68)”
“,#.###” 12345.6789 ”12,345.679” 
“,#.#” 12345.6789 ”12,345.7” 
“#.#” 12345.6789 ”12345.7” 
“#.###E+##” 12345.6789 ”1.235e+04”
“#.###E+##” -12345.6789 ”-1.235e+04”
“#.###E+##” 0.054321 ”5.432e-02” 
“#.###E-##” 12345.6789 ”1.235e04”
“#.###E-##” 0.054321 ”5.432e-02” 
“#%” 0.054321 ”5%” 
“#.##%” 0.054321 ”5.43%” 
“#.##\%” 0.054321 ”.05%” 
“0.##\%” 0.054321 ”0.05%”  

pattern 
control 
characters

Role in formatting results
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InStr
Syntax: InStr(position, string, substring)

Action: InStr tests whether of not some string has a specific substring. MapInfo 
Professional searches string starting at the character position specified by position. 
When position is one, MapInfo Professional starts searching at the beginning of string. 
When it has the value  6, MapInfo Professional starts searching at the sixth character 
in string. 

When string contains substring, InStr returns the character position where substring 
starts. 

Note:  When string does not contain substring, InStr returns zero.

Example: You are preparing to geocode a file and you want to identify all the entries 
with Post Office boxes for addresses. That means you want all entries that have the 
string “box” in their address column. They may also have “P.O.”, but you cannot be 
sure of that. Nor can you be sure of how “box” is capitalized in the entries. Here is 
your expression:

82. InStr(1,UCase$(ADDRESS),”BOX”)>0
This expression directs MapInfo Professional to search the Address column for the 
string “BOX”. All entries containing this string are selected.

For example, If your data looks like this:

  “This is a test of the insert function.”  

You want to find the position of “test.”  The INSTR function will look like this:

INSTR(1,”This is a test of the insert function”,”test”)

When this statement is executed, the value 11 will be returned.

Note:  If the string that you are searching for does not exist, the value 0 will be 
returned. 
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Int
Syntax: Int(num_expr)

Action: Returns the nearest integer that is less than or equal to the specified value 
(num_expr).

Examples: The following table shows how Int treats various values:

When you apply Int to a Logical variable type, it will produce a 1 if the Logical value 
is TRUE, or 0 if the Logical value is FALSE.

It is also possible to evaluate logical expressions with Int.  For example,

83.  Int(STATE_NAME="Maine") 
returns an integer value of 1 if the State_Name column or variable contains the string 
"Maine", or an integer value of 0 if State_Name contains any other string value.

LCase$
Syntax: LCase$(string)

Action: Returns the lower case of the string.

Examples: Consider the following expression:

84. LCase$(CITY)
The following table shows how LCase$ converts an input string (from a column in 
your table) into a returned string:

Number Int(Number)
5.2 5

5.999 5
-7.8 -8
-7.2 -8

Input String Returned String
NEW YORK new york
New yorK new york
new york new york  
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Left$
Syntax: Left$(string, number)

Action: Returns a string that consists of the leftmost number of characters in string.

Examples: Consider the following expression:

85. Left$(CITY,5)
The following table shows how that expression converts an input string into a 
returned string:

Now consider the following expression, where Phone is a column containing 
telephone numbers prefixed by area codes:

86. Left$(PHONE,3)=”404”
This expression selects all rows where the first three digits of the phone number are 
“404”. Note that the Phone column contains character data and therefore the 
comparison value, 404, has to be in quotes so MapInfo Professional knows to treat it 
as a character string.

see also: Right$, Mid$

Len
Syntax: Len(string) 

Action: Returns the number of characters in a string.

LTrim$
Syntax: LTrim$(string)

Action: LTrim$ removes any non-printing characters (e.g. spaces, TABs) from the 
beginning of string.

see also: RTrim$

Input String Returned String
New York City New Y

Denver Denve
Singapore Singa
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Maximum
Syntax: Maximum(num_expr, num_expr)

Action: Maximum returns the larger of two numbers.

Example: To find the highest address number for a street segment in a StreetInfo file:

87. Maximum(TOLEFT,TORIGHT)
ToLeft is the highest address number on the left side of a segment and ToRight is the 
highest address number of the right side of a segment.

Mid$
Syntax: Mid$(string, position, length)

string is a character expression
position is an integer indicating a starting position in string
length is an integer indicating the number of characters to extract

Action: Mid$ returns a string of a set length, starting at given position, in a specified 
string.

Examples: Consider the following expression:

88. Mid$(CITY,5,4)
The following table shows how that expression converts an input string into a 
returned string:

Note:  The expression only returned two characters from “Denver”. That is 
because “Denver” is too short to have a four-character string starting at its 
fifth character.

Minimum
Syntax: Minimum(num_expr, num_expr)

Action: Minimum returns the smaller of two numbers.

Examples: To find the lowest address number for a street segment in a StreetInfo file:

89. Minimum(FROMLEFT,FROMRIGHT)
FromLeft is the highest address number on the left side of a segment and FromRight is 
the highest address number of the right side of a segment.

Input String Returned String
New York City York
Denver er
Singapore apor
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Month
Syntax: Month(datefield)

Action: Returns the month of the date as a number, 1 through 12.

Examples: To select all received in August:

90. Month(received)=8
 To select all received before August:

91. Month(received)<8
To select all received in August 1990:

92. Month(received)=8 and Year(received)=1990
This expression has two clauses. The first specifies that the month must be August 
and the second that the year must be 1990. The clauses are connected by the AND 
operator and so both must be True for a row to be selected.

To select all received in August or September:

93. Month(received)=8 or Month(received)=9
This expression has two clauses. The first selects rows where the month is August and 
the second selects rows where the month is September. Since the clauses are 
connected by “or” only one must be True for a row to be selected.

To select all received in August or September:

94. Month(received)=any(8,9)
This expression achieves the same result as 92, but is formulated using the keyword 
“any”. 

To select all received in August or September of 1990:

95. Month(received)=any(8,9) and Year(received)=1990
This expression has two clauses. The first selects rows where the month is August or 
September and the second selects rows where the year is 1990. The clauses are 
connected by the AND operator and so both must be True for a row to be selected.

ObjectLen
Syntax: ObjectLen(obj, unit) 

Action: Returns the length of lines and polylines. Returns a value of 0 for other 
objects. 
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When you choose ObjectLen from a menu the “obj” keyword is placed between the 
parentheses along with the current unit in double-quotes. In most cases the current 
unit is miles. When you want length to be in some other unit, you should type the unit 
using double quotes. The units available are:

Examples: To calculate the length of an object:

96. ObjectLen(obj, ”mi”)
To have the length calculated in kilometers:

97. ObjectLen(obj, ”km”)
To have the length calculated in nautical miles:

98. ObjectLen(obj, ”nmi”)
When you wanted to convert from kilometers to miles you would use a conversion 
factor of .621.

To select all objects more than 10 miles long:

99. ObjectLen(obj, ”mi”)>10 

Perimeter
Syntax: Perimeter(obj, unit)

Action: Returns the perimeter of the object for regions, ellipses, rectangles, and 
rounded rectangles. When you choose Perimeter from a menu the “obj” keyword is 
placed between the parentheses along with the current unit in double-quotes. In most 
cases the current unit is miles. 

Unit Name Unit Represented 
“mi” miles

“km” kilometers
“in” inches
“ft” feet

“survey ft” survey feet
“yd” yards

“mm” millimeters
“cm” centimeters

“li” links
“rd” rods
“ch” chains
“m” meters

“nmi” nautical miles 
(1 nautical mile = 1852 meters)
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When you want perimeter to be in some other unit, you should type the unit using 
double quotes. See the table above for the available units.

Examples: To calculate the perimeter of an object:

100. Perimeter(obj, ”mi”)
To calculate the perimeter in kilometers:

101. Perimeter(obj, ”km”)
To calculate the Perimeter in meters”

102. Perimeter(obj, ”m”)
To select all objects with a perimeter greater than 35 miles long:

103. Perimeter(obj, ”mi”)>35 

Proper$
Syntax: Proper$(string)

Action: Returns a string that has the first letter of each word capitalized and all other 
letters lowercase. 

Examples:  Consider the following expression:

104. Proper$(CITY)
This table shows how the Proper$ function reformats a column in your table:

Right$( )
Syntax: Right$ (string_expr, num_expr)

Action: Returns part or all of a string beginning at the right end of the string.

Example:

105. Right$(CITY, 4)

Original text Reformatted text
NEW YORK New York
New yorK New York
new york New York
New York New York 
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The following table shows how that expression converts an input string into a 
returned string:

see also: Left$, Mid$

Round
Syntax: Round(number1, number2)

Action: Returns the rounded number1. number2 specifies how to round it. 

Examples: Consider the following expression:

106. Round(number1,number2)
The table below gives examples. The first column contains the function arguments 
(number1, number2) and the second column contains the rounded result.

To select all rows where the median age is 42, you might use the following expression:

107. Round(MED_AGE, 1)=42
Depending on your data, this expression may give better results than one that 
compares median age directly with a target value (MED_AGE=42). The median age 
column in MapInfo Professional’s states table has the median age calculated to one 
decimal place. When we compare those values directly with 42 MapInfo Professional 
would not select records where the median age is, for example, 41.7, 42.1, or 42.4. Yet 
we probably want those records. By rounding the median age value to a whole 
number, we can get those values.

Input String Returned String
New York City City

Denver nver
Singapore pore

Arguments Rounded Number
14347,10000 10000
14347, 100 14300
14347, 10 14350
12.18353, .1 12.20000
12.18353, .001 12.18400
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RTrim$
Syntax: RTrim$(string)

Action: RTrim$ removes any white-space characters (e.g. spaces, and TABs) from the 
end of string.

see also: LTrim$

Sin
Syntax: Sin(num_expr)

Action: The Sin function returns the sine of the value of a numeric expression, where 
that expression represents an angle expressed in radians.

Str$
Syntax: Str$(expr)

Action: Str$ converts a numerical expression into a string that represents it. When the 
numerical expression is negative the first character in the string with be a negative 
sign (-). The first character returned for a positive value is the first number. If the 
expression is an object, Str$() returns a string describing the type of object (e.g., 
“region”). If the expression is a Logical (true/false) value, Str$ returns "T" for true or 
"F" for false.

 When applied to a Float variable type, Str$ will produce a text string representing the 
floating-point number rounded to:

• six digits of precision (total of 6 non-zero digits, including any number of 
leading or trailing zeroes depending on the location of the decimal point) if 
the number is less than 100,000.

• the nearest .01 (hundredth) if the number is greater than 100,000.

 If you need to control the number of digits of accuracy displayed in a string, use the 
Format$() function.

UCase$
Syntax: UCase$(string)

Action: Returns the upper case of the string.

Examples: Consider the following expression:

108. UCase$(CITY)
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The following table shows how it converts an input string (from a column in your 
table) into a returned string:

see also: Lcase$, Proper$

Val
Syntax: Val(char_expr)

Action: The Val function extracts a numerical value from a character expression. It 
ignores any tabs, spaces, and line feeds at the start of a string and then tries to 
interpret the first sequence of numeric characters as a numerical value. It stops 
processing the string as soon as it finds a non-numeric character.  

Note:  Except that it will also accept a minus (hyphen) sign and a decimal point 
(period), e.g., Val (”-9.9”) = -9.9. When the first character after initial tabs, 
spaces, and line feeds is not a numeric character, Val returns a value of zero.

Examples: The following table illustrates how Val extracts a numerical value from an 
input string:

Weekday
Syntax: Weekday(datefield)

Action: Returns the day of the week from the data. The day is given as a number 
between 1 and 7. 1 is Sunday and 7 is Saturday.

Examples: To select all rows where the weekday is Wednesday:

109. Weekday(date)=4
To select all rows where the weekday is Wednesday, Thursday, or Friday:

110. Weekday(date)=any(4,5,6)

Input String Returned String
NEW YORK NEW YORK
New yorK NEW YORK
new york NEW YORK

char_expr Val(char_expr)
12 thousand 12
52 - 62 Brunswick 52
Eighteen 0
Box 239 0  
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The “any” keyword directs MapInfo Professional to select any row where the week 
day is one of the specified days.

To select all rows where the day is Friday and the month is July:

111. Weekday(date)=6 and Month(date)=7
This expression has two clauses. The first clause uses the Weekday function to select 
records where the day of the week is a Friday. The second clause uses the Month 
function to select records where the month is July. Since the two clauses are connected 
by the AND operator, both clauses must be True for a row to be selected.

Year
Syntax: Year(datefield)

Action: Returns the year of the date.

Examples: To find all orders received in 1990:

112. Year(date)=1990
To find all orders received in 1990 or 1991:

113. Year(date)=any(1990,1991)
To find all orders received between 1985 and 1990, including those orders received in 
1985 and 1990:

114. Year(date)>=1985 and Year(date)<=1990
This expression has two clauses. The first selects all rows where the date is 1985 or 
greater. The second clause selects all rows where the date is 1990 or less. Both clauses 
must be satisfied for a row to be selected. 
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Appendix E: Registering SPOT Images

SPOT images are satellite (raster) images of the earth. SPOT Image Corporation offers these 
images under the name SPOTView™. SPOT images work well with MapInfo Professional® and 
are particularly useful when scant vector data is available for a geographic region, or when you 
want to super-impose vector data on top of a highly accurate raster backdrop. Additionally, 
MapInfo works with the Geospot™, format.

This appendix describes how to use information in SPOT and Geospot™ files to register the 
image in MapInfo. The advantage of using this information in this way is the increased 
accuracy that can be achieved over manually aligning the image with vector data.

This appendix assumes you have some familiarity with manually registering raster images. If 
the subject is new to you, see Register Raster Image earlier in this reference.

The process described here is not foolproof. Because of inaccuracies in the header file settings or 
problems in companion vector data, you may occasionally need to manually readjust the 
control points using the Register Raster Image dialog. Refer to Register Raster Image earlier.

Part of registering a SPOT image is assigning the proper coordinate system. The standard 
coordinate systems for most US SPOT images are Universal Transverse Mercator and State 
Plane. But in other cases a SPOT image may use a different coordinate system and may even 
require that you add a new coordinate system to MapInfo. This appendix will help you identify 
what settings to use for a SPOT image, as well as when to add a coordinate system to MapInfo, 
should you need to.

SPOT Image Files
A SPOT image consists of several files, not all of which are required by MapInfo. Here are the 
files that MapInfo uses:

.HDR file–A header file in ASCII form that contains information about the image’s size, 
coordinate system,(SPOTView™ only) and location on the earth.

.BIL file–A binary file that contains the image’s raw raster data.

.CLR file–A palette file that contains a list of suggested colors to be used with the image. This 
file is only provided with color images, and MapInfo reads the contents of this file when 
present.

A report (.REP) file in ASCII form also accompanies each Geospot™ product. Although 
MapInfo does not read this file, you may find that it too contains useful information for 
registering the image, particularly image rotation and coordinate system information.
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Gathering Coordinate System and Control Point 
Information
Like other raster images, registering a SPOT image involves choosing a coordinate system and 
assigning at least three control points in the Register Raster Image Dialog. Before doing so, you 
must gather the appropriate information from settings in the image’s .HDR/.REP files.

If you open a SPOTView™ image’s .HDR file using an ASCII editor, you’ll see that it contains 
settings like the following. The settings for your image will likely differ. 

SPOTView™ Settings
! GIS FORMAT HEADER FILE

! IDENTIFICATION BLOCK

PRODUCT_NAME        SPOTView Custom Frame Special Change Detection

FORMAT_VERSION      1.5

MAP_FRAME           22’ X 30’

SCENE_ID            2_595272_910701_165923_2X

!                   2_595272_930410_171958_2P

!                   2_595272_930729_170345_2X

IMAGE_DATE          01 JUL 91

!                   10 APR 93

!                   29 JUL 93

CORRECTION_LEVEL    TER

! IMAGE INFORMATION BLOCK

NCOLS               4276

NROWS               4251

ULXMAP              522147

ULYMAP              4086917

MAPUNITS            Meters

XDIM                10.00

YDIM                10.00

NBANDS              3

NBITS               8

LAYOUT              BIL

BYTEORDER           I

SKIPBYTES           0

BANDROWBYTES        4276

TOTALROWBYTES       12828

BAND_RGB            321

! MAP INFORMATION BLOCK

MAP_NAME            St Louis, MO  Change Detection

UL_LON/LAT         

LR_LON/LAT       
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PROJECTION          Albers Equal Area

ORIGIN_LON          W 96,30,00

ORIGIN_LAT          N 00,00,00

STD_PARALLEL_1      N 36,36,00

STD_PARALLEL_2      N 43,00,00

DATUM               NAD27

Geospot™ Settings
The .HDR and .REP files will contain settings similar to these.

(.HDR file contains the following)

! GIS FORMAT HEADER FILE

! COORDINATE BLOCK

PRODUCT_NAME        SPOTView Custom Frame Special Change Detection

FORMAT_VERSION      1.5

MAP_FRAME           22’ X 30’

SCENE_ID            2_595272_910701_165923_2X

!                   2_595272_930410_171958_2P

!                   2_595272_930729_170345_2X

IMAGE_DATE          01 JUL 91

!                   10 APR 93

!                   29 JUL 93

CORRECTION_LEVEL    TER

! IMAGE INFORMATION BLOCK

NCOLS               4276

NROWS               4251

ULXMAP              522147

ULYMAP              4086917

MAPUNITS            Meters

XDIM                10.00

YDIM                10.00

NBANDS              3

NBITS               8

LAYOUT              BIL

BYTEORDER           I

SKIPBYTES           0

BANDROWBYTES        4276

TOTALROWBYTES       12828

BAND_RGB            321

! CARTOGRAPHIC PARAMETER BLOCK (REP file)

(not in .REP file)

MAP_NAME            St Louis, MO  Change Detection
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UL_LON/LAT         

LR_LON/LAT        

PROJ_ID       Albers Equal Area

PROJ_MERIDIAN         W 96,30,00

PROJ_PARALLEL    N 00,00,00

STD_PROJ_PARALLEL_1      N 36,36,00

STD_PROJ_PARALLEL_2      N 43,00,00

DATUM               NAD27

Coordinate System Information  (SPOTView™ only)

The first step in registering a SPOT image is assigning the appropriate coordinate system. The 
image’s .HDR file should contain all the information you need to determine the proper 
coordinate system.

Occasionally you’ll want to open a SPOT image that uses a coordinate system not currently 
supported in MapInfo. When this is the case, you’ll need to modify MapInfo’s list of supported 
coordinate systems by adding a new line to the MAPINFOW.PRJ file; this is an ASCII file that 
can be easily modified with a text editor. Appendix F: Creating Your Own Coordinate System gives 
a complete description of how to edit this file and what elements to use within a line for a given 
coordinate system.

For example, in the sample .HDR files settings above, the PROJECTION and DATUM settings 
might lead you to believe that one of MapInfo’s standard Albers Equal-Area Conic coordinate 
systems would be appropriate for the sample SPOT image. But if you examine the 
MAPINFOW.PRJ file, you’ll see that the Albers Equal-Area Conic coordinate system lines look 
like this.

”--- North American Coordinate Systems ---”

”Albers Equal-Area Conic (North America)”, 9, 62, 7, -96, 23, 20, 
60, 0, 0

”Albers Equal-Area Conic (Continental US)”, 9, 62, 7, -96, 23, 
29.5, 45.5, 0, 0

”Albers Equal-Area Conic (Alaska)”, 9, 63, 7, -154, 50, 55, 65, 0, 
0

”Albers Equal-Area Conic (Hawaii)”, 9, 62, 7, -157, 3, 8, 18, 0, 0

Comparing the origin and standard parallel settings (arguments 4 through 7) to the  
ORIGIN_LON, ORIGIN_LAT, STD_PARALLEL_1,  and STD_PARALLEL_2 settings in the 
.HDR file shown above, you’ll see that they do not match up. In this case, you would need to 
add a line like this to the MAPINFOW.PRJ file:

”Albers Equal-Area Conic (St. Louis)”, 9, 62, 7, -96.5, 0, 36.6, 
43, 0, 0

See Appendix F for more details on each element of this entry. Note that when adding a new 
coordinate system for an image, if a required setting is missing from the .HDR file, enter zero in 
its place. In the sample line above, for example, zero was used for the False Easting and False 
Northing settings—the final two arguments on the line.
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Control Point Information 
ULXMAP, ULYMAP, XDIM, and YDIM are the settings within the .HDR file that are used for 
determining a SPOT image’s three control points. PIXEL_ROTATION_SIN and

PIXEL_ROTATION_COS are optional rotation settings within the image’s .REP file; this file is 
only present with  Geospot products. If a .REP file is not present or the .REP file does not 
contain any PIXEL_ROTATION_SIN and PIXEL_ROTATION_COS settings, here are the values 
to use for these settings when calculating control points:

PIXEL_ROTATION_SIN = 0

PIXEL_ROTATION_COS = 1

The following table shows the pixel coordinates and corresponding equations for determining 
the three control points. The column on the right of the table shows the results of calculating the 
control points using the sample data from above. In this case, the image has no .REP file.

Notice that the control points are at the top left corner of the image (0,0), one pixel to the left 
(1,0), and one pixel below (0,1); no additional accuracy is gained by choosing control points that 
are any further apart. Here are the settings you would enter in the Register Raster Image dialog 
when registering the sample SPOT image:

See Register Raster Image earlier in this reference if it is unclear to you where to enter this 
information.

You can contact SPOT Image Corporation directly for more information on SPOT images and 
the SPOTView product line.

SPOT Image Corporation
1897 Preston White Drive
Reston, VA 22091-4368
Phone (703)620-2200

Fax (703)648-1813 

Image X,Y Equation Example
0,0 ULXMAP,ULYMAP 522147,4086917
1,0 ULXMAP + PIXEL_ROTATION_COS * XDIM, 

ULYMAP + PIXEL_ROTATION_SIN * XDIM
522157,4086917

0,1 ULXMAP + PIXEL_ROTATION_SIN * YDIM, 
ULYMAP - PIXEL_ROTATION_COS * YDIM

522147,4086907

Label Map X Map Y Image X Image Y

Pt 1 522147 m 4086917 m 0 0

Pt 2 522157 m 4086917 m 1 0

Pt 3 522147 m 4086907 m 0 1
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MapInfo Professional® ODBC Connectivity 
Support

Supported Data Types
These are the ODBC data types that MapInfo supports:

• SQL_BIT

• SQL_TINYINT

• SQL_SMALLINT

• SQL_INTEGER:

• SQL_REAL

• SQL_BIGINT

• SQL_DECIMAL

• SQL_DOUBLE

• SQL_FLOAT

• SQL_NUMERIC

• SQL_BINARY

• SQL_LONGVARBINARY

• SQL_VARBINARY

• SQL_LONGVARCHAR

• SQL_DATE

• SQL_TYPE_DATE

• SQL_TIMESTAMP

• SQL_TYPE_TIMESTAMP

• SQL_TIME

• SQL_TYPE_TIME

• SQL_CHAR

• SQL_VARCHAR
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The MapInfo Redistributed ODBC Drivers
MapInfo Professional ODBC Access is built using a set of DLLs redistributed from Merant.  
They are installed in the Windows System directory; however, the normal rules for finding and 
loading executables apply.  

Driver Installation
The MapInfo Professional driver installation allows you to install drivers redistributed by 
MapInfo.  

Licensing
1. The redistributed Merant ODBC Drivers are only licensed to be used by the MapInfo 

application.  

2. They may not be used by other ODBC applications.  

3. The drivers created when you install these drivers intentionally are labeled “MapInfo 
<database name>.” This is to signal that this driver is only for use within MapInfo.  

4. If you do use it elsewhere you will get a warning message at connect time that you are 
not licensed to use this ODBC datasource in this application, but it will let you 
continue.  This message will also be displayed after every 50 or so records fetched 
from this datasource.

5. The critical side effect is that it also places an entry in the ODBC.INI entry for that 
datasource.  This will then prevent MapInfo from using this datasource in the future 
without receiving the same message.

6. If you get an unlicensed message when using a datasource from within MapInfo:

• Edit the ODBC.INI and remove all keys for QEWSD.

• If there is a key for your INI filename (ODBC.INI), then this key will 

point to the place in the registry containing the information that the INI 

file would normally contain.  If you wish to use the INI file, delete this 

key.
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Managing Datasources with the ODBC 
Administrator

What Is the ODBC Administrator?
The ODBC Administrator is a utility freely distributed by Microsoft for managing your ODBC 
drivers and datasources. 

Run from your Windows or windows\system directory ODBCADM.EXE (ODBCADM32.EXE 
is the 32 bit version forWindows 98, Windows NT, or Windows 2000, Win XP Professional, and 
Win XP Home.

Note:  If  you try to add a new datasource with a driver that requires additional software 
that is not installed you get the following message:  

The setup routines for the <driver name> driver could not be loaded.  You may be low on 
memory and need to quit a few applications.

This means that the driver DLL could not be loaded, most likely because it could not load 
dependent DLLs.

To get a useful message indicating which DLL is required but not found, try DLLMGR.EXE, or 
double-check that you have properly installed all required drivers and your path is set correctly.

ODBC.INI and ODBCINST.INI (Registry Keys)
For Windows 98, WINDOWS NT, Windows 2000, Win XP Professional, and Win XP Home,

 these are the Registry Keys:

HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI

HKEY_CURRENT_USER\SOFTWARE\ODBC\ODBC.INI

ODBCINST.INI contains the list of the installed and registered drivers.

ODBC.INI contains the list of datasources that use the drivers.  These are what are presented 
during a connect dialog.

To access data from you database, you must have an appropriate ODBC driver installed and an 
ODBC datasource set up for that driver.

To see the list of available datasources, run the ODBC Administrator.  The list displayed is the 
same list of available datasources provided by the MapInfo OPEN ODBC Table Connection 
dialog.

To ensure an existing datasource is valid, select it and press Setup.  This will try to load any 
prerequisite drivers and verify that they are available. Ensure that the driver is set up correctly.  
For File base databases, the  setup usually points to a default directory where the files are 
located.  For server databases, some form of network information is required.  The Oracle 
TNSNAME, server host name, TCP\IP address, and port are examples of required files for 
Oracle databases.
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Setting Up an MS Access Datasource   
The prerequisite is to have the MS Access Driver installed. 

To check:

1. Use the ODBC Administrator and look for an Access datasource.  Pick it and press 
Setup to ensure it is configures as desired.

2. If one is not there, press Add... and see if the Access driver is installed.
Install the MS Access drivers. These are included with MS Access, MS Office Professional, 
ODBC SDK, Visual C++,  MapInfo Professional or purchased separately.

To verify if this is the required version of this driver:

1. Run the ODBC Administrator.

2. Press the Drivers button.

3. Select MS Access Driver (*.mdb).

4. Press About.

5. Check that Version is the latest.
To add a new MS Access DataSource:

1. Run the ODBC Administrator.

2. Press the Add button.

3. Select MS Access Driver (*.mdb) and press OK.

4. Type in a name for the datasource  (This is the name that appears in the list when you 
connect from MapInfo).

5. Press Select to specify a specific MS Access database you wish to use.
If you do not select a database for this datasource, you will be prompted during the connect to 
do so.  MapInfo will provide a sample MS Access database. 

Setting Up an Oracle Datasource
Prerequisites: Oracle client, TCP\IP, and Oracle SQL*Net are installed and operational

Verify that TCP\IP is installed OK : PING.EXE

The service to the database must be configured. Run the configuration utility that Oracle 
provides to configure the service. The utility is called Net 8 Configuration Assistant for v. 8.1.6, 
v. 8.1.7 or later, and Net  Configuration Assistant for 9i.
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MapInfo_MapCatalog
• Oracle Spatial will be a spatial schema, number 13. It provides support for 

points, lines, and polygon spatial types.

• MapInfo will still support XY and MICODE index types via ODBC 
connection

• MapInfo will not support HH_CODE and the old version of SDO index types

• Linked Table – same as the other databases

• Live table – same as the other databases

• Editing – same as the other databases 

Oracle Spatial Functionality

Introduction
Oracle Spatial is a new implementation of a Spatial Database from Oracle. It has some 
similarities to the previous Oracle SDO implementation, but is significantly different. Oracle is 
also maintaining the Oracle SDO implementation as well as  Oracle Spatial. MapInfo will not 
support the older Oracle SDO relational schema via Oracle data.  MapInfo will support 
simultaneous connections to Oracle through OCI and others databases through ODBC.  
MapInfo will not support downloading Spatial geometry tables via ODBC using the current 
ODBC driver from Merant.

Handling Data Types
Insert and Update support is the same as for EasyLoader.  See the EasyLoader specification for 
details:

Conversion of Oracle Spatial Objects to MapInfo
Oracle Spatial supports some geometry types that MapInfo will need to convert in order to 
display the geometry. 
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The new MapInfo Professional object types, Multipoint and Collection, are translated into 
Oracle MULTIPOINT and COLLECTION objects, respectively, via the Oracle OCI and vice 
versa. However, Oracle’s COLLECTION object is broader in scope than MapInfo’s Collection 
object. The MapInfo Collection allows one region, one polyline, and one Multipoint. Therefore, 
converting between MapInfo to Oracle and from Oracle to MapInfo may not produce a one-to-
one conversion. The table below illustrates the realtionship between Oracle and MapInfo 
objects.   

MapInfo will be able to download some or all of an Oracle Spatial table through either a spatial 
query or attribute query.  Spatial Query supports both a rectangular arc query and a Spatial 
query on a selected object(s).

Note:  To select a Multipoint object within a region (e.g., Select Object within Selection), 
the first point of the Multipoint object must be within the region. Otherwise, the 
Select statement will fail. The same rule applies to Collections containing Multipoint 
objects. Lines and Polygons in Collections should work correctly.  

Oracle Spatial 
Geometry Type

Converted to 
MapInfo Type Comments

Circular Arc Polyline Oracle Spatial Circular Arcs are made up of 
three coordinates, (starting point, any point 
on the arc and ending point)  MapInfo will 
use these three points to form a polyline 
representing the arc.

Circle Region Circles are made up of three coordinates on 
the circumference of the circle.  MapInfo will 
use these three points to form a circular 
region. 

Rectangle Region

MULTIPOINT Multipoint

COLLECTION
{Point (cluster), Line 
String, Multiple Line 
String, Polygon, 
Multiple Polygon}

Collection {Multipoint, 
Polyline, Region

Unknown or invalid 
geometries or user 
defined.

Oracle Spatial currently does not have a 
mechanism to check the validity of objects.  
MapInfo will perform some geometry 
checks.  If MapInfo detects an invalid or an 
unknown geometry, it will return a null 
object to prevent errors.  No error message 
will display to notify users of the null 
geometries.
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Supported Data Types

Non-Spatial Datatypes

MapInfo captures many Oracle data types and translates them into MapInfo native types. 
When the column is updated, Oracle data makes sure that the data being bound is translated 
into the column format (i.e., MapInfo can bind a character as a long and send it through to 
Oracle and on the other end it will be translated into a long number in the table).

from Oracle Spatial to MapInfo

RAW, LONG RAW BinaryString up to 127 bytes shown as Hex 
characters

Named type MIObject

Named Object type (SDO_GEOM) MIObject

BLOB, CLOB Not Supported

CHAR, VARCHAR, LONG, LONG 
VARCHAR

Character

Number, Decimal If no scale or precision: Float    Else Decimal

INTEGER Integer

FLOAT Float

DATE Date
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Spatial Objects

Working with Oracle Spatial Tables
Whenever you load an Oracle Spatial table via EasyLoader, an entry will automatically be 
inserted into the MapInfo_MapCatalog, and into USER_SDO_GEOM_METADATA (v. 8.1.6 or 
later). These two files are Oracle-specific dictionary tables.

Note, however, when you drop an Oracle Spatial table that these entries are not removed. To 
manually remove these entries, you would issue SQL commands such as the ones below:

SQL> CONNECT ops$joe

Connected.

SQL> DROP TABLE states;

Table dropped.

For v. 8.1.6 or later: 

DELETE FROM user_sdo_geom_metadata where table_name = ’STATES’;

1 row deleted.

SQL> DELETE FROM mapinfo.mapinfo_mapcatalog where ownername = ’JOE’ 
and tablename = ’STATES’;

1 row deleted.

SQL> COMMIT;

Commit complete.

SQL> 

from Oracle Spatial: GTYPES to MapInfo
0  UNKNOWN_GEOMETRY (Spatial ignores this geometry.) NULL
1  POINT Geometry contains one point. Point
2  LINESTRING Geometry contains one line string. Line (if only 2 pts) 

or Polyline if >2 pts)
3  POLYGON Geometry contains one polygon. Region
4  Collection Geometry is a heterogeneous collection of 
elements.

Collection

5  MULTIPOINT Geometry has multiple points. Multipoint
6  MULTILINESTRING Geometry has multiple line strings. Polyline
7  MULTIPOLYGON Geometry has multiple polygons 
(more than one exterior boundary).

Region

NULL object NULL object  
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Requirements for Editable Linked Tables
You can edit a linked table.  When you save the edits, they are committed to the server database 
as well as to the linked table.

The following conditions must be met to edit a linked table:

1. You must select from a single table.

2. You must have update access to the table.

3. The table must have a unique index or a primary key constraint defined.

4. You must include at least one editable field in the column selection list.
If a linked table is editable, you will be able to pick fields within the table and edit them.  For 
mappable linked tables, you can edit the objects as well.

Only some fields in a linked table may be editable.  You will be prevented from making edits to 
non-editable fields.

A field of an ODBC Linked table will not be editable if:

• It is a read-only column in the result set (as indicated by the ODBC 
DataSource).

• It is a long character datatype in the ODBC Database (width > 254). 

• It is a BINARY datatype in the ODBC Database  (returned as a string of 
Hexadecimal characters).

• It is a TIME datatype in the ODBC Database (returned as a MapInfo Date, 
displayed as blank).

Extra fields may be included in the linked table for updates.

These are the primary key or unique index columns.  They enable updates to be reliably 
committed to the server table.  If you insert a new row or edit an existing row, the value in these 
fields must be unique within the ODBC Database table or you will receive an error during the 
commit.
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Editing SpatialWare Tables

Cannot Upload Object 
If you edit a mappable SpatialWare table and try to insert MapInfo Ellipse, Rounded Rectangle, 
or Arc objects into it, the message “Cannot Upload Object—format is not supported in 
SpatialWare (Ellipse, Rounded Rectangle, or Arc)” displays. This is because you are trying to 
insert objects that are not supported. To fix the problem, delete these objects from the table or 
transform them to polylines or regions. To determine which objects have to be deleted or 
transformed, run a query in the MapInfo SQL Select dialog and specify “obj” in the Select 
Column clause. The resulting query will tell you the types of objects in the table.  Select the 
objects you wish to delete or transform and display the selection in an editable layer in a Map 
window.  To delete the objects, use the Clear Map Objects Only option in the Edit menu.  To 
transform the objects, use the Convert to Regions or Convert to Polylines option in the Objects 
menu.  For best results, transform Ellipse and Rounded Rectangles into regions, and transform 
Arcs into polylines.

If you make a SpatialWare table mappable with the Object Type default of Point and try to 
insert a Line or Region object into it, the same message “Cannot Upload Object—format is not 
supported in SpatialWare (Ellipse, Rounded Rectangle, or Arc)” displays. This is because you 
are trying to insert objects other than a point. You need to make the table mappable with the 
Object type specified as ALL. To fix the problem, delete the table from the Map Catalog using 
the Delete Entry option in the application MIODBCAT.MBX, described in Chapter 21 of the 
MapInfo Professional User’s Guide,  “Accessing Remote Database Data.” Then re-add the table 
to the Map Catalog with an Object type of ALL using the Make Table Mappable option.

Controlling SpatialWare Object Size in the 
Registry
There is a new optional entry in the Registry that controls the size of an object that can be 
downloaded from an SpatialWare database.

1. In the Registry, go to the following directory level: 

HKEY_LOCAL_MACHINE\SOFTWARE\MAPINFO\MAPINFO

2. Add the following string value:  MIDB_BLOB_SIZE.

3. Add a value. Although the value is stored in the registry as a string, the value you 
enter must contain all numbers.  The default value for Win 32 is 131072 (128K).  
However, limitation is based on system memory. 

If your Registry entry is too low, the entire object will not download and the following error 
message displays:

“Some objects were lost—they were too large to download. Increase Registry entry for 

\MAPINFO\MAPINFO\MIDB_BLOB_SIZE.”
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Appendix G: Converting Coordinates

You can enter longitude and latitude coordinate values for points directly into your database. 
When you do this, you must enter the coordinates in decimal degrees; MapInfo Professional® 
does not recognize coordinates entered in degrees, minutes, and seconds. Point coordinates 
entered in degrees, minutes, and seconds appear as incorrect locations on your map.

Degrees, Minutes, and Seconds Converted to Decimal 
Degrees
All it takes is some division to obtain the decimal form from a coordinate that is written in 
degrees, minutes, and seconds. The formula to use is:

Decimal Degrees 

For example, to convert  42 degrees 45i 30I to decimal degrees:

DECIMAL DEGREES

= 42.7583333 

The number 42.7583333 is the decimal degree equivalent of the original number that was in 
degrees, minutes, and seconds. 

Decimal Degrees to Degrees, Minutes, Seconds 
This is best explained with an example. To obtain degrees, first take the whole number from the 
coordinate. For, 75.213458 decimal degrees:

DEGREES = 75

To obtain minutes:

MINUTES = (0.213458 * 60)

(Where .213458 is the decimal part of the entire decimal degree coordinate)

= (12.807480)

MINUTES = 12

To obtain seconds:

SECONDS = (0.807480 * 60)

(Where .807480 is the decimal part of the immediately previous calculation)

= (48.4488) (You can keep decimal digits, such as 48.45 seconds)

The final result: 75.213458 = 75 degrees 12i 48I
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Appendix H: Creating Your Own Coordinate System

MapInfo Professional® provides a large number of predefined coordinate systems. 
However, you may want to use another coordinate system. You create a new 
coordinate system by changing the parameters of one of the predefined systems or by 
defining a new coordinate system from scratch. This section tells you what those 
parameters are and how to make the changes.

Projections and Coordinate Systems
While the terms “projection” and “coordinate system” are often used interchangeably, 
they do not have the same meaning. A projection is an equation or set of equations 
containing a set of parameters—the exact number and nature of the parameters 
depends on the projection. When each of those parameters has been assigned a 
specific value, the result is a coordinate system. The items listed in the Choose 
Projection dialog are coordinate systems.

Projection is the method of reducing the distortion of curved earth features on a flat 
paper map or computer screen. A coordinate system is a collection of parameters that 
describe coordinates. One of the parameters is projection.

Elements of a Coordinate System
This section briefly defines the elements of a coordinate system. The first element in 
defining a coordinate system is the set of equations for the system’s projection. The 
elements after that are the parameters for the projection. None of the coordinate 
systems require all of these parameters.
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Projections and Their Parameters
The following table indicates the parameters applicable to each projection. The 
parameters are listed in the order they appear in the relevant coordinate system lines 
in the MAPINFOW.PRJ file.

* MapInfo supports the Azimuthal Equidistant and Lambert Azimuth Equal-Area projections in the polar aspect only. The Origin Latitude for 
these projections must be either 90 or -90.
† Versions of MapInfo prior to 6.0 support the Azimuthal Equidistant and Lambert Azimuthal Equal-Area projections in the polar aspect only.
The Origin Latitude for these projections must be either 90 or -90. An Oblique Azimuthal Equidistant projection was introduced in version 6.0 
that supports all Origin Latitudes, including the poles. For version 6.5 a new Lambert Azimuthal Equal-Area projection has been added that 
also supports all Origin Latitudes, including the poles. 
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Albers Equal-Area Conic X X X X X X X X

Azimuthal Equidistant X X X    X * X

Cassini-Soldner X X X X X X

Cylindrical Equal Area X X X X

Double Stereographic X X X X X X X

Eckert IV X X X

Eckert VI X X X

Equidistant Conic X X X X X X X X

Gall X X X

Hotine Oblique Mercator X X X X X X X X

Lambert Azimuthal Equal-Area X X X    X † X

Lambert Conformal Conic X X X X X X X X

Longitude-Latitude X

Mercator X X X

Miller X X X

Mollweide X X X

New Zealand Map Grid X X X X X X

Polyconic X X X X X X

Regional Mercator X X X X

Robinson X X X

Sinusoidal X X X

Stereographic X X X X X X X

Swiss Oblique Mercator X X X X X X

Transverse Mercator X X X X X X X
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Projection
The projection is the equation or equations used by a coordinate system. The 
following list names the projections MapInfo uses and gives the number used to 
identify the projection in the MAPINFOW.PRJ file:

Number Projection

9 Albers Equal-Area Conic

28 Azimuthal Equidistant (all origin latitudes)

5 Azimuthal Equidistant (polar aspect only)

30 Cassini-Soldner

2 Cylindrical Equal-Area

31 Double Stereographic

14 Eckert IV

15 Eckert VI

6 Equidistant Conic, also known as Simple Conic

17 Gall

7 Hotine Oblique Mercator

4 Lambert Azimuthal Equal-Area (polar aspect only)

29 Lambert Azimuthal Equal-Area

3 Lambert Conformal Conic

19 Lambert Conformal Conic (modified for Belgium 1972)

1 Longitude/Latitude

10 Mercator

11 Miller Cylindrical

13 Mollweide

18 New Zealand Map Grid

27 Polyconic

26 Regional Mercator

12 Robinson

16 Sinusoidal

20 Stereographic

25 Swiss Oblique Mercator

8 Transverse Mercator, (also known as Gauss-Kruger)
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Projection numbers in the MAPINFOW.PRJ may be modified by the addition of a 
constant value to the base number listed in the Projection table, above. Valid values 
and their meanings are tabulated below:

Example:

Assume you want to work with a simple system based on the Transverse Mercator 
projection and using the NAD 1983 datum. You might have a line such as the 
following in your MAPINFOW.PRJ file: 

"UTM Zone 1 (NAD 83)", 8, 74, 7, -177, 0, 0.9996, 500000, 0

Now let’s say that you want a system based on this, but with an affine transformation 
specified by the following parameters (see "Affine Transformations" later in this 
appendix): Units=meters; A=0.5; B=-0.866; C=0; D=0.866; E=0.5; and F=0. The 
required line in the MAPINFOW.PRJ file is: 

"UTM Zone 1 (NAD 83) - rotated 60 degrees", 1008, 74, 7, -177, 0, 0.9996, 
500000, 0, 7, 0.5, -0.866, 0, 0.866, 0.5, 0

Alternatively, if you want to bound the system to (x1, y1, x2, y2)=(-500000, 0, 500000, 
1000000), the required line is: 

21 Transverse Mercator, (modified for Danish System 34 Jylland-Fyn)

22 Transverse Mercator, (modified for Danish System 34 Sjaelland)

23 Transverse Mercator, (modified for Danish System 34/45 Bornholm) 

24 Transverse Mercator, (modified for Finnish KKJ) 

Constant Meaning Parameters

1000 System has affine transformations Affine units specifier and coefficients 
appear after the regular parameters for 
the system.

2000 System has explicit bounds Bounds appear after the regular 
parameters for the system.

3000 System with both affine and bounds Affine parameters follow system’s 
parameters; bounds follow affine 
parameters.

Number Projection
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"UTM Zone 1 (NAD 83) - bounded", 2008, 74, 7, -177, 0, 0.9996, 500000, 0, 
-500000, 0, 500000, 1000000

To customize the system using both of these modifications, the line is: 

"UTM Zone 1 (NAD 83) - rotated and bounded", 3008, 74, 7, -177, 0, 0.9996, 
500000, 0, 7, 0.5, -0.866, 0, 0.866, 0.5, 0, -500000, 0, 500000, 1000000

 Datum
The datum is established by tying a reference ellipsoid to a particular point on the 
earth. The following table lists these details for each datum:

• The number used to identify the datum in the MAPINFOW.PRJ file.

• The datum’s name

• The maps for which the datum is typically used

• The datum’s reference ellipsoid

See Appendix I for further information on special datums 999 and 9999.

Number Datum Area Ellipsoid

1 Adindan Ethiopia, Mali, Senegal, 
Sudan

Clarke 1880

2 Afgooye Somalia Krassovsky

1007 AGD 66, 7 parameter Australia, A.C.T. Australian National

1008 AGD 66, 7 parameter Australia, Tasmania Australian National

1009 AGD 66, 7 parameter Australia, Victoria/NSW Australian National

1006 AGD 84, 7 parameter Australia Australian National

3 Ain el Abd 1970 Bahrain Island International

118 American Samoa American Samoa Islands Clarke 1866

4 Anna 1 Astro 1965 Cocos Islands Australian National

119 Antigua Island Astro 1943 Antigua, Leeward 
Islands

Clarke 1880

5 Arc 1950 Botswana, Lesotho, 
Malawi, Swaziland, 
Zaire, Zambia, 
Zimbabwe

Clarke 1880

6 Arc 1960 Kenya, Tanzania Clarke 1880

7 Ascension Island 1958 Ascension Island International
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9 Astro B4 Sorol Atoll Tern Island International

8 Astro Beacon “E” Iwo Jima Island International

10 Astro DOS 71/4 St. Helena Island International

11 Astronomic Station 1952 Marcus Island International

151 ATS77 (Average Terrestrial 
System 1977)

Canada ATS77

12 Australian Geodetic 1966 
(AGD 66)

Australia and Tasmania 
Island

Australian National

13 Australian Geodetic 1984 
(AGD 84)

Australia and Tasmania 
Island

Australian National

151 Average Terrestrial System 
1977 (ATS77)

120 Ayabelle Lighthouse Djibouti Clarke 1880

110 Belgium Belgium International

14 Bellevue (IGN) Efate and Erromango 
Islands

International

15 Bermuda 1957 Bermuda Islands Clarke 1866

16 Bogota Observatory Colombia International

121 Bukit Rimpah Bangka and Belitung 
Islands (Indonesia)

Bessel 1841

17 Campo Inchauspe Argentina International

18 Canton Astro 1966 Phoenix Islands International

19 Cape South Africa Clarke 1880

20 Cape Canaveral Florida and Bahama 
Islands

Clarke 1866

1005 Cape, 7 parameter South Africa WGS 84

21 Carthage Tunisia Clarke 1880

22 Chatham 1971 Chatham Island (New 
Zealand)

International

23 Chua Astro Paraguay International

122 Co-Ordinate System 1937 of 
Estonia

Estonia Bessel 1841

24 Corrego Alegre Brazil International

123 Dabola Guinea Clarke 1880

Number Datum Area Ellipsoid
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124 Deception Island Deception Island, 
Antarctica

Clarke 1880

1000 Deutsches Hauptdreicksnetz 
(DHDN)

Germany Bessel

25 Djakarta (Batavia) Sumatra Island 
(Indonesia)

Bessel 1841

26 DOS 1968 Gizo Island (New 
Georgia Islands)

International

27 Easter Island 1967 Easter Island International

115 EUREF 89 Europe GRS 80

28 European 1950 (ED 50) Austria, Belgium, 
Denmark, Finland, 
France, Germany, 
Gibraltar, Greece, Italy, 
Luxembourg, 
Netherlands, Norway, 
Portugal, Spain, Sweden, 
Switzerland

International

29 European 1979 (ED 79) Austria, Finland, 
Netherlands, Norway, 
Spain, Sweden, 
Switzerland

International

108 European 1987 (ED 87) Europe International

125 Fort Thomas 1955 Nevis, St. Kitts, Leeward 
Islands

Clarke 1880

30 Gandajika Base Republic of Maldives International

116 GDA 94 Australia GRS 80

32 Geodetic Reference System 
1967 (GRS 67)

Worldwide GRS 67

33 Geodetic Reference System 
1980 (GRS 80)

Worldwide GRS 80

126 Graciosa Base SW 1948 Faial, Graciosa, Pico, Sao 
Jorge, and Terceira 
Islands (Azores)

International 1924

34 Guam 1963 Guam Island Clarke 1866

35 GUX 1 Astro Guadalcanal Island International

150 Hartbeesthoek 94 South Africa WGS 84

Number Datum Area Ellipsoid
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127 Herat North Afghanistan International 1924

128 Hermannskogel Yugoslavia (Prior to 
1990), Slovenia, Croatia, 
Bosnia and 
Herzegovina, Serbia

Bessel 1841

36 Hito XVIII 1963 South Chile (near 53°S) International

37 Hjorsey 1955 Iceland International

38 Hong Kong 1963 Hong Kong International

1004 Hungarian Datum (HD 72) Hungary GRS 67

39 Hu-Tzu-Shan Taiwan International

40 Indian Thailand and Vietnam Everest (India 1830)

41 Indian Bangladesh, India, 
Nepal

Everest (India 1830)

129 Indian Pakistan Everest (Pakistan)

130 Indian 1954 Thailand Everest (India 1830)

131 Indian 1960 Vietnam Everest (India 1830)

132 Indian 1975 Thailand Everest (India 1830)

133 Indonesian 1974 Indonesia Indonesian 1974

42 Ireland 1965 Ireland Modified Airy

134 ISTS 061 Astro 1968 South Georgia Island International 1924

43 ISTS 073 Astro 1969 Diego Garcia International

152 Japanese Geodetic Datum 
2000 (JGD2000)

Japan GRS80

44 Johnston Island 1961 Johnston Island International

45 Kandawala Sri Lanka Everest (India 1830)

46 Kerguelen Island Kerguelen Island International

47 Kertau 1948 West Malaysia and 
Singapore

Everest (W. Malaysia 
and Singapore 1948)

135 Kusaie Astro 1951 Caroline Islands, 
Federated States of 
Micronesia

International 1924

48 L.C. 5 Astro Cayman Brac Island Clarke 1866

136 Leigon Ghana Clarke 1880

Number Datum Area Ellipsoid
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49 Liberia 1964 Liberia Clarke 1880

113 Lisboa (DLx) Portugal International

50 Luzon Philippines (excluding 
Mindanao Island)

Clarke 1866

51 Luzon Mindanao Island Clarke 1866

52 Mahe 1971 Mahe Island Clarke 1880

53 Marco Astro Salvage Islands International

54 Massawa Eritrea (Ethiopia) Bessel 1841

114 Melrica 1973 (D73) Portugal International

55 Merchich Morocco Clarke 1880

56 Midway Astro 1961 Midway Island International

57 Minna Nigeria Clarke 1880

137 Montserrat Island Astro 1958 Montserrat, Leeward 
Islands

Clarke 1880

138 M’Poraloko Gabon Clarke 1880

58 Nahrwan Masirah Island (Oman) Clarke 1880

59 Nahrwan United Arab Emirates Clarke 1880

60 Nahrwan Saudi Arabia Clarke 1880

61 Naparima, BWI Trinidad and Tobago International

109 Netherlands Netherlands Bessel

31 New Zealand Geodetic Datum 
1949 (NZGD 49)

New Zealand International

62 North American 1927
(NAD 27)

Continental US Clarke 1866

63 North American 1927
(NAD 27)

Alaska Clarke 1866

64 North American 1927
(NAD 27)

Bahamas (excluding San 
Salvador Island)

Clarke 1866

65 North American 1927
(NAD 27)

San Salvador Island Clarke 1866

66 North American 1927
(NAD 27)

Canada (including 
Newfoundland Island)

Clarke 1866

67 North American 1927
(NAD 27)

Canal Zone Clarke 1866

Number Datum Area Ellipsoid
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68 North American 1927
(NAD 27)

Caribbean (Turks and 
Caicos Islands)

Clarke 1866

69 North American 1927
(NAD 27)

Central America (Belize, 
Costa Rica, El Salvador, 
Guatemala, Honduras, 
Nicaragua)

Clarke 1866

70 North American 1927
(NAD 27)

Cuba Clarke 1866

71 North American 1927
(NAD 27)

Greenland (Hayes 
Peninsula)

Clarke 1866

72 North American 1927
(NAD 27)

Mexico Clarke 1866

73 North American 1927
(NAD 27)

Michigan (used only for 
State Plane Coordinate 
System 1927)

Modified Clarke 1866

74 North American 1983
(NAD 83)

Alaska, Canada, Central 
America, Continental 
US, Mexico

GRS 80

139 North Sahara 1959 Algeria Clarke 1880

107 Nouvelle Triangulation 
Francaise (NTF) Greenwich 
Prime Meridian

France Modified Clarke 1880

1002 Nouvelle Triangulation 
Francaise (NTF) Paris Prime 
Meridian

France Modified Clarke 1880

111 NWGL 10 Worldwide WGS 72

117 NZGD 2000 New Zealand GRS 80

1010 NZGD 49, 7 parameter New Zealand International

75 Observatorio 1966 Corvo and Flores Islands 
(Azores)

International

140 Observatorio Meteorologico 
1939

Corvo and Flores Islands 
(Azores)

International 1924

76 Old Egyptian Egypt Helmert 1906

77 Old Hawaiian Hawaii Clarke 1866

78 Oman Oman Clarke 1880

Number Datum Area Ellipsoid
662 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 657



Appendix H: Creating Your Own Coordinate System

M

79 Ordnance Survey of Great 
Britain 1936

England, Isle of Man, 
Scotland, Shetland 
Islands, Wales

Airy

80 Pico de las Nieves Canary Islands International

81 Pitcairn Astro 1967 Pitcairn Island International

141 Point 58 Burkina Faso and Niger Clarke 1880

142 Pointe Noire 1948 Congo Clarke 1880

143 Porto Santo 1936 Porto Santo and 
Madeiras Islands

International 1924

1000 Potsdam Germany Bessel

82 Provisional South American 
1956

Bolivia, Chile, Colombia, 
Ecuador, Guyana, Peru, 
Venezuela

International

36 Provisional South Chilean 
1963

South Chile (near 53°S) International

83 Puerto Rico Puerto Rico and Virgin 
Islands

Clarke 1866

1001 Pulkovo 1942 Germany Krassovsky

1012 PZ90 Russia PZ90

84 Qatar National Qatar International

85 Qornoq South Greenland International

1000 Rauenberg Germany Bessel

86 Reunion Mascarene Island International

112 Rikets Triangulering 1990 
(RT 90)

Sweden Bessel

1011 Rikets Triangulering 1990 
(RT 90), 7 parameter

Sweden Bessel

87 Rome 1940 Sardinia Island International

88 Santo (DOS) Espirito Santo Island International

89 São Braz São Miguel, Santa Maria 
Islands (Azores)

International

90 Sapper Hill 1943 East Falkland Island International

91 Schwarzeck Namibia Modified Bessel 1841

144 Selvagem Grande 1938 Salvage Islands International 1924

Number Datum Area Ellipsoid
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145 Sierra Leone 1960 Sierra Leone Clarke 1880

146 S-JTSK Czech Republic Bessel 1841

1013 SK42 Russia PZ90

1024 SK95 Russia PZ90

92 South American 1969 Argentina, Bolivia, 
Brazil, Chile, Colombia, 
Ecuador, Guyana, 
Paraguay, Peru, 
Venezuela, Trinidad, and 
Tobago

South American 1969

93 South Asia Singapore Modified Fischer 1960

94 Southeast Base Porto Santo and Madeira 
Islands

International

95 Southwest Base Faial, Graciosa, Pico, Sao 
Jorge,  Terceira Islands 
(Azores)

International

1003 Switzerland (CH 1903) Switzerland Bessel

147 Tananarive Observatory 1925 Madagascar International 1924

96 Timbalai 1948 Brunei and East 
Malaysia (Sarawak and 
Sabah)

Everest (India 1830)

97 Tokyo Japan, Korea, Okinawa Bessel 1841

98 Tristan Astro 1968 Tristan da Cunha International

99 Viti Levu 1916 Viti Levu Island (Fiji 
Islands)

Clarke 1880

148 Voirol 1874 Tunisia/Algeria Clarke 1880

149 Voirol 1960 Algeria Clarke 1880

100 Wake-Eniwetok 1960 Marshall Islands Hough

101 World Geodetic System 1960 
(WGS 60)

Worldwide WGS 60

102 World Geodetic System 1966 
(WGS 66)

Worldwide WGS 66

103 World Geodetic System 1972 
(WGS 72)

Worldwide WGS 72

104 World Geodetic System 1984 
(WGS 84)

Worldwide WGS 84

Number Datum Area Ellipsoid
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Units
The following table lists the available coordinate units and the number used to 
identify the unit in the MAPINFOW.PRJ file:

*One International Foot equals exactly 30.48 cm.
**One Nautical Mile equals exactly 1852 meters.
***One US Survey Foot equals exactly 12/39.37 meters, or approximately 30.48006 cm.

Coordinate System Origin
The origin is the point specified in longitude and latitude from which all coordinates 
are referenced. It is chosen to optimize the accuracy of a particular coordinate system. 
As we move north from the origin, Y increases. X increases as we move east. These 
coordinate values are generally called northings and eastings.

105 Yacare Uruguay International

106 Zanderij Surinam International 

Number Units

6 Centimeters

31 Chains

3 Feet (also called International Feet)*

2 Inches

1 Kilometers

30 Links

7 Meters

0 Miles

5 Millimeters

9 Nautical Miles**

32 Rods

8 US Survey Feet (used for 1927 State Plane)***

4 Yards

Number Datum Area Ellipsoid
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For the Transverse Mercator projection the origin’s longitude defines the central 
meridian. In constructing the Transverse Mercator projection a cylinder is positioned 
tangent to the earth. The central meridian is the line of tangency. The scale of the 
projected map is true along the central meridian.

In creating a Hotine Oblique Mercator projection it is necessary to specify a great 
circle that is not the equator nor a meridian. MapInfo does this by specifying one 
point on the ellipsoid and an azimuth from that point. That point is the origin of the 
coordinate system. 

Standard Parallels (Conic Projections)
In conic projections a cone is passed through the earth intersecting it along two 
parallels of latitude. These are the standard parallels. One is to the north and one is to 
the south of the projection zone. To use a single standard parallel specify that latitude 
twice. Both are expressed in degrees of latitude.

Oblique Azimuth (Hotine Oblique Mercator)
When specifying a great circle (Hotine Oblique Mercator) using a point and an 
azimuth (arc), the azimuth is called the Oblique Azimuth and is expressed in degrees.

Scale Factor (Transverse Mercator)
A scale factor is applied to cylindrical coordinates to average scale error over the 
central area of the map while reducing the error along the east and west boundaries. 
The scale factor has the effect of recessing the cylinder into the earth so that it has two 
lines of intersection. Scale is true along these lines of intersection.

You may see the scale factor expressed as a ratio, such as 1:25000. In this case it is 
generally called the scale reduction. The relationship between scale factor and scale 
reduction is:

scale factor = 1-scale reduction

In this case the scale factor would be 1-(1/25000) or 0.99996.
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False Northings and False Eastings
Calculating coordinates is easier if negative numbers aren’t involved. To eliminate 
this problem in calculating State Plane and Universal Transverse Mercator 
coordinates, it is common to add measurement offsets to the northings and eastings. 
These offsets are called False Northings and False Eastings. They are expressed in 
coordinate units, not degrees. (The coordinate units are specified by the Units 
parameter.)

Range (Azimuthal Projections)
The range specifies, in degrees, how much of the earth you are seeing. The range can 
be between 1 and 180. When you specify 90, you see a hemisphere. When you specify 
180 you see the whole earth, though much of it is very distorted.

Polyconic Projection
The following description is copied from “Map Projections – A Working Manual”, 
USGS Professional Paper 1395, by John P. Snyder.

The Polyconic projection, usually called the American Polyconic in Europe, achieved 
its name because the curvature of the circular arc for each parallel on the map is the 
same as it would be following the unrolling of a cone which had been wrapped 
around the the globe tangent to the particular parallel of latitude, with the parallel 
traced onto the cone. Thus, there are many (”poly-”) cones involved, rather than the 
single cone of each regular conic projection.

The Polyconic projection is neither equal-area nor conformal. Along the central 
meridian, however, it is both distortion free and true to scale. Each parallel is true to 
scale, but the meridians are lengthened by various amounts to cross each parallel at 
the correct position along the parallel, so that no parallel is standard in the sense of 
having conformality (or correct angles), except at the central meridian. Near the 
central meridian, distortion is extremely small.

This projection is not intended for mapping large areas. The conversion algorithms 
used break down when mapping wide longitude ranges. For example, World.tab, 
from the sample data shipped with MapInfo Professional, may exhibit anomalies if 
reprojected using Polyconic. 
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Editing the MAPINFOW.PRJ File
The MAPINFOW.PRJ file lists the parameters for each coordinate system on a 
separate line, as in the following examples:

“Mollweide (Equal Area)”, 13, 62, 7, 0

“Albers Equal–Area Conic (Alaska)”, 9, 63, 7, –154, 50, 
55, 65, 0, 0

“Alabama,Western Zone (1983)”, 8, 74, 7,–87.5, 30.0, 
0.9999333333, 600000, 0

“UTM Zone 9 (NAD 27 for Canada)”, 8, 66, 7, –129, 0, 
0.9996, 500000, 0

The first element in each list is the name of the coordinate system in quotes. The 
second element in each list is the number that identifies the projection. The remaining 
elements in the list are the parameter values for that particular coordinate system. The 
elements follow the order as outlined in the table “Elements of a Coordinate System” 
at the beginning of this appendix. Each element is separated by commas. 

To create your own coordinate system you will need to add a new entry to the 
MAPINFOW.PRJ file that lists the appropriate elements. The process is described 
below. 

Creating a New Coordinate System
To create a new coordinate system for use in MapInfo: 

1. Open MAPINFOW.PRJ in a text editor or word processor.
2. On a separate line, and following the convention of the other entries list the 

name for the new coordinate system in quotes, followed by a comma.
3. Add the apprpriate numbers for each parameter that pertains to your 

coordinate system. The order of parameters is important. See the table 
“Elements of a Coordinate System” at the beginning of this appendix for the 
parameters for your coordinate system. Separate each parameter with a 
comma.

4. If necessary, move your new coordinate system to the appropriate place in the
list of coordinate systems. For instance, if the new coordinate system applys 
to a hemisphere, put it in the “Projections of a Hemisphere” group.

5. Save your edited MAPINFOW.PRJ file.
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Example of a New Coordinate System
To illustrate this process, consider the following parameters for a coordinate system 
that you want to add to the MAPINFOW.PRJ file:

1. Open MAPINFOW.PRJ in a text editor or word processor.
2. On an empty line, put the name of your new coordinate system in quotes, 

followed by a comma.
3. Enter the following information to represent your coordinate system:

6, 74, 7, -90.5, 30, 10.33333, 50, 10000000, 500000

4. Move the entry to its appropriate place among like coordinate systems, if 
necessary.

5. Save your edited MAPINFOW.PRJ file.

You can now use your custom coordinate system just as you would use any of the 
coordinate systems that come with MapInfo.

Things to keep in mind when editing the MAPINFOW.PRJ file:

• When specifying projection, datum and units, use the number that represents 
the parameter. These numbers are listed in the table for each parameter earlier 
in this appendix. In our example, 6 represents Equidistant Conic projection; 
74 represents NAD 83 datum, and 7 represents meters.

• You must record the coordinates in decimal degrees. See Appendix G for 
instructions on converting degrees, minutes, seconds, into decimal degrees.

• Remember to include a negative sign for west longitudes and south latitudes. 

• You must list the origin longitude first in the MAPINFOW.PRJ file even 
though it is commonly seen elsewhere following the latitude.

• Carry out decimals to at least five (5) places for greater accuracy.

• Do not use commas to represent thousands or millions in large numbers. 
Only use commas to separate parameters from one another.

Projection: Equidistant Conic

Datum: NAD 83

Units: meters

Origin: 30°N, 90°30′W

Standard Parallels: 10°20′N and 50°N

False Easting: 10,000,000 m

False Northing: 500,000 m
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There are other ways you can edit this file. When you want a shorter list remove 
coordinate systems from the file. You can also change the names, change group 
headings and reorder the file to suit your needs. 

Note:   Group headings are distinguished by the hyphen at the beginning of the 
name. Names of coordinate systems cannot begin with a hyphen or a space.

Affine Transformations
MapInfo provides the ability to define rotated or skewed coordinate systems by 
allowing an optional affine transformation in any coordinate system definition. You 
can also define a coordinate system with bounds and an affine transformation. In that 
case, add 3000 to the projection number, enter the Affine parameters (A,B,C,D,E,F) 
and then list the bounds (x1,y1,x2,y2). The general form is:

Name, Projection Number + 3000, projection components 
(see previous section), Affine units, A, B, C, D, E, F, 
x1, y1, x2, y2

An example of a Mapinfow.prj line with a rotated Affine transformation might look 
like this with the affine parameters in Bold and bounds in Italics:

”Equal Area for GA (NAD 27)”, 3009, 62, 7, -96, 23, 29.5, 45.5, 0, 0, 7, -0.00000000001, 1, 

-116.071, -1, -0.00000000001, -50.5312, -6972009.20702, -16901023.2253, 26829936.181, 

16900922.1627

Description 
An affine transformation has the following form:

x’ = Ax + By + C

y’ = Dx + Ey + F

In these equations, the base coordinates (x, y) are transformed to produce the derived 
coordinates (x’, y’). The six constants A through F determine the effect of the 
transformation and we use the post multiply method for homogenous 2D coordinate 
systems. 

This can be considered a matrix operation as follows:

A B C X X’

D E F * Y = Y’

0 0 1 1 1
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Where (X,Y) and (X’,Y’) are as defined above.

To do various types of affine transformations the values of A, B, B, D, E, and F need to 
be determined. It is fairly easy to define the basic Transformations: Translations, 
Rotations, Scaling in X, Scaling in Y, Shearing in X and Shearing in Y which can be 
done using an Affine Transformation.

Translation:  C and F are the values you want (0, 0) to go to, A=E=1 and B=D=0. So to 
move the coordinate system so the origin is at (5, 2) the values would be: A=1, B=0, 
C=5, D=0, E=1, and F=2.

Rotation about the origin:  A=E=cos(angle to rotate), -B=D=sin(angle to rotate), 
C=F=0. So to rotate 60 degree counterclockwise around the origin, A=.5, B=-.866, C=0, 
D= .866, E= .5, and F=0.

To Scale in the X direction:  A is the scale you want to use. E =1 and the rest are 0. So to 
scale to 3 times the size in the X direction the values would be A=3, B=0, C=0, D=0, E= 
1, F=0.

To Scale in the Y direction:  E is the scale you want to use. A =1 and the rest are 0. So to 
scale to 5 times the size in the Y direction the values would be A=1, B=0, C=0, D=0, 
E=5, F=0.

To Scale Overall just make sure that A and E are equal.

To Shear in the X direction:  A = E = 1, B is the shear factor and the rest are 0. So to 
Shear by 5 units in the X direction then A=1, B=5, C=0, D=0, E=1, F=0. 

To Shear in the Y direction:  A = E = 1, D is the Shear factor and the rest are 0. So to 
Shear by 4 units in the Y direction then A=1, B=0, C=0, D=4, E=1, F=0. 

Now to get a general affine transformation, do a pre-matrix multiplication of the basic 
pieces of the transformation. Make sure that you put the first operation on the right. 
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So to Translate to (5,2) Rotate 60 degrees and then Shear 5 units in Y, set up and 
multiply the following matrices:

Multiplying these out gives the following matrix:

Therefore, the required values are: A=.5, B=-.866, C=0.768, D=3.366, E=-3.83, F=9.17. 

Frequently Asked Questions on Projections
Question:  ”How do I convert a coordinate system with units in meters to use feet?”

 Answer:  You will need to edit the Mapinfow.prj file to modify the same projection in 
a different measurement system and adjust the False Eastings and Northings used for
the difference. 

 For example below, the first line is the original projection expressed in meters. The 
second line is a copied modification of the first, where the units were changed from 
”7” (meters) to ”8” (feet) indicating this coordinate system is now using feet, and the 
False Easting (2000000) and Northing (500000) components were  divided  by .3048 to 
convert them from meters to feet.

 Example:

 ”California, Zone I (1983)\p26941”, 3, 74, 7, -122, 39.3333333333, 40, 41.6666666667, 
2000000, 500000

”California, Zone I FT (1983)\p26941”, 3, 74, 8 , -122, 39.3333333333, 40, 
41.6666666667, 6561679.7, 164041.99

 Question:  ”I chose Longitude/Latitude (NAD 83) as my projection; however, 
whenever I look at the Choose Projection dialog, it keeps saying Longitude/Latitude 
(GRS 80). Why won’t my projection change?”

1 0 0 0.5 -0.866 0 1 0 5

5 1 0 * 0.866 0.5 0 * 0 1 2

0 0 1 0 0 1 0 0 1

0.5 -0.866 0.768

3.366 -3.83 9.17

0 0 1
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 Answer:   The GRS 80 datum is exactly identical to NAD 83 datum. MapInfo uses the 
numeric parameters, not the name, to decide which coordinate system to highlight in 
the Choose Projection dialog. Since GRS 80 has the same numeric parameters as NAD 
83, and GRS 80 comes earlier in the list, MapInfo chooses GRS 80 instead of NAD 83. 
(There are several other datums identical to GRS 80, e.g., EUREF 89, GDA 94, etc.)

or More Information on Projections
The first three publications listed below are relatively short pamphlets. The last two 
are substantial books. We’ve also given addresses and phone numbers for the 
American Congress of Surveying and Mapping (the pamphlets) and the U.S. 
Geological Survey (the books).

American Cartographic Association. Choosing a World Map—Attributes, Distortions, 

Classes, Aspects. Falls Church, VA: American Congress on Surveying and Mapping. 
Special Publication No. 2. 1988.

American Cartographic Association. Matching the Map Projection the Need. Falls 
Church, VA: American Congress on Surveying and Mapping. Special Publication No. 
3. 1991.

American Cartographic Association. Which Map is Best? Projections for World Maps. 
Falls Church, VA: American Congress on Surveying and Mapping. Special Publication 
No. 1. 1986.

John P. Snyder. Map Projections—A Working Manual. Washington: U.S. Geological 
Survey Professional Paper 1395. 1987

John P. Snyder and Philip M. Voxland. An Album of Map Projections. Washington: U.S. 
Geological Survey Professional Paper 1453. 1989.

Contact Information
American Congress on Surveying and Mapping
5410 Grosvenor Lane, Suite 100
Bethesda, MD 20814?2212
(301) 493-0200
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Earth Science Information Center
U.S. Geological Survey
507 National Center
Reston, VA 22092
(703) 860-6045 or (800) USA-MAPS

Peter H. Dana of the Department of Geography, University of Texas at Austin has also 
put up an incredible website for explanations of Map projections, Geodetic Datums, 
and Coordinate systems. It is a valuable as many of these explanations were also 
presented using MapInfo Professional. The materials may be used for study, research, 
and education, but please credit the author:

 Peter H. Dana, The Geographer’s Craft Project, Department of Geography, The 
University of Texas at Austin. 

For Geodetic Datum information and explanations, go to  
http://www.colorado.edu/geography/gcraft/notes/datum/datum.html

For Information on Coordinate systems and other principles, go to

http://www.colorado.edu/geography/gcraft/notes/coordsys/coordsys.html

For Information on Map Projections go to

http://www.colorado.edu/geography/gcraft/notes/mapproj/mapproj.html  
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Conversion

A datum is a mathematical description of the earth’s shape and orientation.  Because 
the earth’s shape is not uniform, there are many different local datums used in 
different parts of the world.  These local datums provide a close approximation to the 
earth’s surface in a particular area.

Each Earth coordinate system uses a specific datum to approximate the earth’s 

surface.  If two coordinate systems use different datums, then MapInfo Professional® 
must perform a datum transformation when it converts coordinates from one 
coordinate system to the other.  MapInfo uses the Bursa-Wolfe datum transformation 
method, which is generally accurate to within 10 meters.  (When MapInfo converts 
between two coordinate systems that use the same datum, no datum transformation 
is performed, and the results are generally accurate to within 0.1 meter.)

Most coordinate systems use one of MapInfo’s predefined datums, listed in Appendix 
F.  If you need to use a datum that isn’t in the list, and you know what the datum’s 
mathematical parameters are, then you can define the coordinate system using a 
custom datum.  MapInfo uses the following information to define a datum:

• An ellipsoid, also called a spheroid.  This is an ellipse rotated around its 
minor axis to form a three-dimensional surface.  The ellipsoid is described by 
two mathematical parameters:  the length, in meters, of its semi-major axis 
(denoted by the letter a) and its degree of flattening (denoted by the letter f).  
MapInfo supports over 40 predefined ellipsoids, which are listed in a table 
below.

• Three shift parameters specifying the distance, in meters, to shift the ellipsoid 
along each of its axes.  These parameters are usually denoted by dX, dY, and 
dZ.  You may also see them denoted by DX, DY, and DZ, or by u, v, and w.

• Three rotation parameters specifying the angle, in arc-seconds, to rotate the 
ellipsoid around each of its axes.  These parameters are usually denoted by 
EX, EY, and EZ.  You may also see them denoted by eX, eY, and eZ, or by e, y, 
and w.

• A scale correction factor specifying the amount, in parts per million, to adjust 
the size of the ellipsoid.  This parameter is denoted by the letter m, or 
sometimes k.

• The longitude of the prime meridian, in degrees east of Greenwich.  The 
prime meridian specifies which location on earth is assigned longitude 0°.  
Most datums use Greenwich as the prime meridian, so this parameter is 
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usually zero.  However, some datums use a different location as the prime 
meridian.  For example, the NTF datum uses Paris as its prime meridian, 
which is 2.33722917 degrees east of Greenwich.  If you use the NTF datum in 
a coordinate system, all longitudes in that coordinate system are relative to 
Paris instead of Greenwich.

You can define a custom datum in any coordinate system definition.  Appendix F 
describes how to define a coordinate system.  To define a custom datum in a 
coordinate system, you use datum number 9999 followed by the datum parameters, 
in this order:

9999, EllipsoidNumber, dX, dY, dZ, EX, EY, EZ, m, PrimeMeridian

Some datums specify only an ellipsoid and shift parameters (dX, dY, dZ), with no 
rotation parameters, scale correction, or prime meridian.  In those cases, you can use 
datum number 999 instead of 9999, to simplify the definition:

999, EllipsoidNumber, dX, dY, dZ

The ellipsoid number must be chosen from the following list.  Currently, there is no 
way to define a custom ellipsoid.  If you need to use an ellipsoid that does not appear 
on this list, please notify MapInfo Technical Support so that we can add your ellipsoid 
to a future MapInfo release.

Two ellipsoids have been added. These are: Everest Pakistan #50, and ATS 77 
(Average Terrestrial System) #51.

The ellipsoid names for Everest ellipsoids have been standardized according to NIMA 
specs to conform to the most current standards used in in the GIS and mapping 
communities.

The name changes are summarized below: 

The additions and the new names are reflected in the full chart below. 

Ellipsoid # Old Name    New Name/NIMA Designation  

11 Everest (1830)  Everest (India 1830)

17 Everest (Kertau)  Everest (W. Malaysia and Singapore 1948)

39 Everest (Timbalai) Everest (Brunei and East Malaysia (Sabah 
and Sarawak))

48 Everest (West Malaysia) Everest (West Malaysia 1969)

40 Everest (Kalianpur) Everest (India 1956)
676 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 671



Appendix I: Defining Custom Datums/Datum Conversion

M

Number Ellipsoid a 1/f

9 Airy 1930 6377563.396 299.3249646

13 Airy 1930 (modified for Ireland 1965) 6377340.189 299.3249646

51 ATS7 77 6378135.0 298.257

2 Australian 6378160.0 298.25

10 Bessel 1841 6377397.155 299.1528128

35 Bessel 1841 (modified for NGO 1948) 6377492.0176 299.15281

14 Bessel 1841 (modified for Schwarzeck) 6377483.865 299.1528128

36 Clarke 1858 6378293.639 294.26068

7 Clarke 1866 6378206.4 294.9786982

8 Clarke 1866 (modified for Michigan) 6378450.047484481 294.9786982

6 Clarke 1880 6378249.145 293.465

15 Clarke 1880 (modified for Arc 1950) 6378249.145326 293.4663076

30 Clarke 1880 (modified for IGN) 6378249.2 293.4660213

37 Clarke 1880 (modified for Jamaica) 6378249.136 293.46631

16 Clarke 1880 (modified for Merchich) 6378249.2 293.46598

38 Clarke 1880 (modified for Palestine) 6378300.79 293.46623

39 Everest (Brunei and East Malaysia 
(Sabah and Sarawak))

6377298.556 300.8017

11 Everest (India 1830) 6377276.345 300.8017

40 Everest (India 1956) 6377301.243 300.80174

50 Everest (Pakistan) 6377309.613 300.8017

17 Everest (W. Malaysia and Singapore 
1948)

6377304.063 300.8017

48 Everest (West Malaysia 1969) 6377295.664 300.8017

18 Fischer 1960 6378166.0 298.3

19 Fischer 1960 (modified for South Asia) 6378155.0 298.3

20 Fischer 1968 6378150.0 298.3

21 GRS 67 6378160.0 298.247167427

0 GRS 80 6378137.0 298.257222101

5 Hayford 6378388.0 297.0
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22 Helmert 1906 6378200.0 298.3

23 Hough 6378270.0 297.0

31 IAG 75 6378140.0 298.257222   

41 Indonesian 6378160.0 298.247

4 International 1924 6378388.0 297.0

49 Irish (WOFO) 6377542.178 299.325

3 Krassovsky 6378245.0 298.3

32 MERIT 83 6378137.0 298.257

33 New International 1967 6378157.5 298.25

43 NWL 10D 6378135.0 298.26

42 NWL 9D 6378145.0 298.25

44 OSU86F 6378136.2 298.25722

45 OSU91A 6378136.3 298.25722

46 Plessis 1817 6376523.0 308.64

52 PZ90 6378136.0 298.257839303

24 South American 6378160.0 298.25

12 Sphere 6370997.0 0.0          

47 Struve 1860 6378297.0 294.73

34 Walbeck 6376896.0 302.78

25 War Office 6378300.583 296.0

26 WGS 60 6378165.0 298.3

27 WGS 66 6378145.0 298.25

1 WGS 72 6378135.0 298.26

28 WGS 84 6378137.0 298.257223563

Number Ellipsoid a 1/f
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The shift and rotation parameters describe the ellipsoid’s orientation in space, as 
compared to the WGS 84 datum.  It’s important to make sure that these parameters 
have the correct signs (positive or negative).  Usually, a document describing a local 
datum will list the parameters required to convert coordinates from the local datum to 
WGS 84.  (This is the same as saying that the parameters were derived by subtracting 
the local datum from WGS 84.)  In that case, you can use the parameters exactly as 
they appear in the document.  However, if you have a document that lists parameters 
for converting coordinates in the opposite direction — from WGS 84 to the local 
datum — then you must reverse the signs of the shift, rotation, and scale correction 
parameters.

It’s also very important to list the parameters in the correct order.  Some documents 
list the rotation parameters with EZ first, like this:  EZ, EY, EX.  In those cases, you must 

reverse the order of the rotation parameters when defining the custom datum.  This is 
especially easy to overlook when your document uses Greek letters to denote the 
parameters.  If the document lists the parameters in order as  w, y, e, then you must 
reverse their order in the custom datum definition.

Here’s an example of a local datum description (we’ll call it LD-1) as it might appear 
in a technical article:

LD-1 ellipsoid:  International

a 6378388.0 m

f 1 / 297.0

Converting from WGS 84 to LD-1

DX 93.5 m

DY 103.5 m

DZ 123.3 m

eX -0.25??

eY 0.11??

eZ 0.07?? 

m -2.1 ppm
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This datum uses the International ellipsoid, which is number 4 in the ellipsoid table 
above.  The other parameters describe a conversion from WGS 84 to the local datum, 
so we must reverse their signs.  No prime meridian is listed, so we can assume that 
Greenwich is used.  The custom datum definition in MapInfo would look like this:

9999, 4, -93.5, -103.5, -123.3, 0.25, -0.11, -0.07, 2.1, 0

You can insert this string of numbers in place of the datum number in any line in the 
MAPINFOW.PRJ file.  For example, you could define the following coordinate 
systems using this custom datum: 

Note:   Strings must be entered on a single line.

”Longitude / Latitude (LD-1)”, 1, 9999, 4, -93.5, -103.5, 
-123.3, 0.25, -0.11, -0.07, 2.1, 0

”UTM Zone 30 (LD-1)”, 8, 9999, 4, -93.5, -103.5, -123.3, 
0.25, -0.11, -0.07, 2.1, 0, 7, -3, 0, 0.9996, 500000, 0

Here’s another sample local datum description, called LD-2 this time:

LD-2 ellipsoid:  Krassovsky

a 6378245.0 m

f 1 / 298.3

Converting from LD-2 to WGS 84

u +24 m

v –123 m

w –94 m

w +0.13??

y +0.25??

e -0.02??

m +1.1 ⋅ 10-6

This datum uses the Krassovsky ellipsoid, which is number 3 in the ellipsoid table 
above.  We do not need to reverse the signs of the parameters, since they describe a 
conversion from the local datum to WGS 84.  However, the rotation parameters are 
listed with w first, so we must reverse their order in the custom datum definition:

9999, 3, 24, -123, -94, -0.02, 0.25, 0.13, 1.1, 0
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Here’s a final example, LD-3, that provides only the ellipsoid and shift parameters:

LD-3 ellipsoid:  Clarke 1880

a 6378249.145 m

f 1 / 293.465

WGS 84 minus local datum LD-3

dX -7 m

dY 36 m

dZ 225 m

This datum uses the Clarke 1880 ellipsoid, which is number 6 in the ellipsoid table 
above.  We do not need to reverse the signs of the parameters or worry about the 
order of the rotation parameters (since they aren’t present).  In this case, you can use 
datum number 999 instead of 9999 in the custom datum definition. These two 
defintions are equivalent, and you can use either one:

999, 6, -7, 36, 225

9999, 6, -7, 36, 225, 0, 0, 0, 0, 0

As with the other custom datum defintions, you would insert one of these defintions 
in place of the datum number in a MAPINFOW.PRJ line, as follows:

”Longitude / Latitude (LD-3)”, 1, 999, 6, -7, 36, 225

”UTM Zone 30 (LD-3)”, 8, 999, 6, -7, 36, 225, 7, -3, 0, 
0.9996, 500000, 0 
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Datum Conversion
When converting coordinates from one datum to another, MapInfo has used the 
Molodensky (3-parameter) and Bursa-Wolfe (7-parameter) methods. These are 
general-purpose methods that can convert coordinates from any datum to any other 
datum.

After the NAD 83 datum was introduced, NOAA developed a program called 
NADCON, which stands for North American Datum CONversion.  This is a very 
specialized program that converts coordinates only from NAD 27 to NAD 83 and vice 
versa.  For this specialized task, it’s much more accurate than the Molodensky 
general-purpose method; NADCON is accurate to about 0.1 meter, and Molodensky 
is accurate to only 10–30 meters.  Most U.S. government agencies, including the 
Census Bureau, have standardized on NADCON for converting between NAD 27 and
NAD 83.

Beginning with MapInfo 4.1.2, the NADCON algorithm is used to convert coordinates
between NAD 27 and NAD 83 if those coordinates lie within the areas covered by 
NADCON (United States, Puerto Rico, and the Virgin Islands).  If the coordinates lie 
outside those areas, or if they use datums other than NAD 27 or NAD 83, MapInfo 
uses the Molodensky or Bursa-Wolfe conversion methods.

Due to the file access required, the NADCON conversion method can be slightly 
slower than the Molodensky method.  If you want to turn off the NADCON 
conversion, add a “NADCON” entry to the registry. The registry entry should have 
this path:

HKEY_LOCAL_MACHINE\Software\MapInfo\MapInfo\Common\NADCON

If this entry is set to zero, then the Molodensky conversion method will be used 
instead of NADCON.

If using the 16-bit version of MapInfo, add this line to the [MAPINFO COMMON] 
section in MAPINFO.INI to turn off the NADCON conversion:

NADCON=0
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Appendix J: MapInfo® Data Interchange Format

This appendix describes the data interchange format for MapInfo Professional®. In 
this appendix, you will find information on:

MIF File Header

MIF Data Section

Pen, Brush, Symbol, and Font Codes in MIF

MID File

This versatile format allows generic data to be attached to a variety of graphical items.  
Since it is ASCII,  it is editable, relatively easy to generate, and works on all platforms 
supported by MapInfo. Perhaps the best way to understand the MapInfo Interchange 
Format (MIF) is to study the sample file at the end of this appendix in conjunction 
with the explanation of the file format. You can also create samples of your own by 
exporting files to MIF and then examining those files in a text editor.

MapInfo data is in two files — the graphics reside in a .MIF file and textual data is 
contained in a .MID file. The textual data is delimited data, with one row per record 
and either Carriage Return, Carriage Return plus Line Feed, or Line Feed between 
lines. The MIF file has two areas — the file header area and the data section. 
Information on how to create MapInfo tables is in the header; the graphical object 
definitions are in the data section. 
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MIF File Header
This is a description of MIF file header with optional information in square brackets.

VERSION n

NAME

[ no spaces allowed in the column name ]

Charset ”characterSetName”  

[ DELIMITER ”<c>” ]  

[ UNIQUE n,n.. ]  

[ INDEX  n,n.. ]

[ COORDSYS...]

[ TRANSFORM...]

COLUMNS n   

  <name> <type>

  <name> <type>

.

.

DATA

Version
• TAB files are always saved as 300 unless noted below.

• WOR files are always saved as 400 unless noted below.

• Once a table is 'upgraded' to a later version, MapInfo Professional does not 
'downgrade' it to an earlier version if the feature which forced the 'upgrade' is
removed.

• Workspaces are written fresh each time, and so can be 'downgraded' if there 
are no features that require the 'upgrade'.

• MIF/MID files created by exporting TAB files from MapInfo Professional 
match the version of the TAB file.

• Pen(0,0,0) and Brush(0,0,0) which were valid in 4.1 are not valid in 4.5 and 
later.

• Line widths in points are encoded in the Pen clause by multiplying the line 
width value by 10 and adding 10 do the result (.2 -> 12, 1.0 -> 20, etc.). This 
forces a 450 in the MIF file header.
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F

V

N

4

4

4

 

4

 

• Interleaved line styles are encoded in the Pen clause by increasing the line 
style value by 128.  This does not force a 450 workspace, appears to be 4.x 
compatible, and gets a 400.

ile versions:

ersion

umber

 TAB  MIF - 

MID

WOR Action

00

X Table is a linked ODBC table

X X X Table uses interleaved line styles or objects in the 
cosmetic layer containing interleaved line styles

X Saved queries (controlled by 'Save Queries in 
Workspaces' check box in 
Options>Preferences>Startup dialog) are 
implemented as straight Select statements

10

X X Table uses MS Access DB's

50

X X  Region and polyline objects, that have more than 
32K nodes 

!edit_version 450 and !version 300

X X Table uses point sized line widths

X X Table is a query table

X Workspaces that specify dot density color (shade 
... density... color)

X Workspaces that specify Line width in points (Pen 
(12,x,x))

     X      X Table uses a Datum or ellipsoid released in a 
specific version

 *  See release notes for new datums and new 
ellipsoids

52

X X   Regional Mercator projection - (#26)
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Version

Number

 TAB  MIF - 

MID

WOR Action

500

X X Table specifies a 'grid' file 
(*.MIG, raster style = 6 1)

X Workspaces that contain surface thematic layers 
(inflect)

X Workspaces that contain cartographic legends 
(Create Cartographic Legend)

550

X X  Polyconic projection - (#27)

X X  Irish (WOFO) ellipsoid - (#49)

X X Table is a linked\live Oracle 8i table

 X Workspaces with Oracle 8i connection 
information

X Workspaces that include surface thematics with 
Hillshading

     X      X Table uses a Datum or ellipsoid released in a 
specific version

 *  See release notes for new datums and new 
ellipsoids

600

X X  Azimuthal Equidistant projection, Oblique  
aspect - #(28)

X X  Everest (Pakistan) ellipsoid - #(50)

X X  ATS 77 ellipsoid - #(51)
686 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 681



Appendix J: MapInfo Data Interchange Format

M

V
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6

6

ersion

umber

 TAB  MIF - 

MID

WOR Action

00

 New Datums introduced in Version 6.0. Their 
numbers are in a range 115-150 (115 and 150 
included) and 1004-1011 (1004 and 1011 included)

600, since MiPro writes Datum number if all the 
parameters match to the parameters of our 
internal Datum table. Also note, that we write the 
FIRST datum number with these parameters, that 
we find in our internal table. That means that if 
for example table was created using Datums 
EUREF89 (115), GDA94  (116)or NZGD2000 (117), 
the MIF file will have Datum GRS 80 (33) written 
into it and MIF file version would not be 
incremented

Since MiPro does not write datum number into 
TAB file, version will be incremented only if 
ellipsoid is new.

X Workspace includes Advanced Printer settings

X Workspace includes a Hotlink

X Workspace includes a 3D Mapper window

X Workspaces that include new clip region settings

    X     X Table uses a Datum or ellipsoid released in a 
specific version

 *  See release notes for new datums and new 
ellipsoids

50

X X New object types: Multipoint and Collection

(actually !edit_version 650 and !version 300)

X X Cassini-Soldner projection (number 30)

X X Lambert Azimuthal Equal-Area projection - 
Oblique aspect(number 29)

X Cassini-Soldner projection for the map window
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Version

Number

 TAB  MIF - 

MID

WOR Action

650

X Lambert Azimuthal Equal-Area projection 
(Oblique aspect) for the map window

X New object types (Multipoint and Collection) 
created in a cosmetic layer or in a layout

X Save a workspace with a Prism Map

700

X Tab file linked to a ShapeFile

X X X #152 - JGD2000 datum used in Japan.

#1012 - PZ90 datum based on PZ90 ellipsoid. This 
datum is used in Russia.

#1013 - SK42 datum based on PZ90 ellipsoid. This 
datum is used in Russia.

#1014 - SK95 datum based on PZ90 ellipsoid. This 
datum is used in Russia.

"Longitude / Latitude (Russia PZ90)", 1, 1012

"Longitude / Latitude (Russia SK42)", 1, 1013

"Longitude / Latitude (Russia SK95)", 1, 1014

Double Stereographic projection. 

New datum - ATS77 (which uses ATS77 
ellipsoid). 

Prince Edward Island and New Brunswick 
Projection

   X ROP Method selected for advanced options for 
Save Window As or Printing
688 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 683



Appendix J: MapInfo Data Interchange Format

M

Charset 
The Charset clause specifies which character set was used to create text in the table. 
For example: Specify “WindowsLatin1” to indicate that the file was created using the 
Windows US & Western Europe character set; specify “MacRoman” to specify the 
Macintosh US & Western Europe character set; or specify “Neutral” to avoid 
converting the text into another character set. If you are not using one of these 
character sets, you can determine the correct syntax for your character set by 
exporting a table and examining the .MIF file in a text editor. 

Delimiter
Specify the delimiting character in quotation marks, for example:  

DELIMITER ”;”  

The default delimiter is Tab; if you are using the default, you do not need the 
DELIMITER line.

Unique 
Specify a number. This number refers to a database column; 3 is the third column, 7 is 
the seventh column, and so forth. What happens to columns in the UNIQUE list is 
subtle. For example, imagine that you have a database with highways in it. Each 
highway has only one name, but it might be represented by several segments. You 
would put the NAME column in the UNIQUE list, while the column containing data 
for the individual segments would not be in that list. This has the effect of creating 
two related tables; one with names, and one with the other attributes of the objects. 
This is how MapInfo’s various street maps (StreetInfo) are prepared.

Index
To indicate that columns in the table are indexed, include a number (or a comma-
separated list of numbers) in the Index clause. Each number refers to a database 
column; 3 is the third column, 7 is the seventh column, and so forth. Columns in the 
INDEX list will have indexes prepared for them.

CoordSys Clause
Specify the COORDSYS clause to note that the data is not stored in longitude/latitude 
form. When no COORDSYS clause is specified, data is assumed to be stored in 
longitude/latitude forms.
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All coordinates are stored with respect to the northeast quadrant. The coordinates for 
points in the United States have a negative X while coordinates for points in Europe 
(east of Greenwich) have a positive X. Coordinates for points in the Northern 
hemisphere have a positive Y while coordinates for points in the Southern hemisphere 
have a negative Y.

Syntax1
CoordSys Earth 

[ Projection type, 
 datum, 
 unitname 
[ ,  origin_longitude] 
[ ,  origin_latitude  ] 
[ ,  standard_parallel_1  [ ,  standard_parallel_2 

] ] 
[ ,  azimuth ] 
[ ,  scale_factor ]
[ ,  false_easting ] 
[ ,  false_northing]
[ ,  range ]  ] 

[ Affine Units unitname, A, B C, D, E, F ]
[ Bounds ( minx, miny) ( maxx, maxy) ]

Syntax2

CoordSys Nonearth  
[ Affine Units unitname, A, B C, D, E, F ]
Units  unitname
Bounds ( minx, miny) ( maxx, maxy) 

Syntax3

CoordSys  Layout  Units  paperunitname  

Syntax4

CoordSys  Table  tablename  

Syntax5

CoordSys  Window   window_id  

type is a positive integer value representing which coordinate system to use

datum is a positive integer value identifying which datum to reference

unitname is a string representing a distance unit of measure (e.g. -m" for 

meters); for a list of unit names, see Set Distance Units
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origin_longitude is a float longitude value, in degrees

origin_latitude is a float latitude value, in degrees

standard_parallel_1 and standard_parallel_2 are float latitude values, in degrees

azimuth is a float angle measurement, in degrees

scale_factor is a float scale factor

range is a float value from 1 to 180, dictating how much of the Earth will be seen

minx is a float specifying the minimum x value

miny is a float specifying the minimum y value

maxx is a float specifying the maximum x value

maxy is a float specifying the maximum y value

paperunitname  is a string representing a paper unit of measure (e.g. -in" for 

inches); for a list of unit names, see Set Paper Units

tablename  is the name of an open table

window_id  is an Integer window identifier corresponding to a Map or Layout 

window

A  performs scaling or stretching along the X axis.

B  performs rotation or skewing along the X axis.

C  performs shifting along the X axis.

D  performs scaling or stretching along the Y axis.

E  performs rotation or skewing along the Y axis.

F  performs shifting along the Y axis.
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Transform Clause
When you have MIF files with coordinates stored with respect to the northwest 
quadrant (quadrant 2), you can transform them to the northeast quadrant 
(quadrant 1) with a transform clause. 

The transform clause has the following syntax:

TRANSFORM Xmultiplier, Ymultiplier, Xdisplacement, 
Ydisplacement

To transform quadrant 2 data into quadrant 1 data, use the following transform 
clause:

TRANSFORM -1,0,0,0

The zeroes instruct MapInfo to ignore that parameter.

When you have an application which creates MIF files in quadrant 2, you can:

• Add the TRANSFORM clause to the MIF files

• Change the application so that it creates coordinates in quadrant 1

• Change the application so that it adds a TRANSFORM clause to the MIF files

Columns
Specify the number of columns. Then, for each column, create a row containing the 
column name, the column type, and, for character and decimal columns, a number to 
indicate the width of the field. 

Note:  Field names cannot have spaces.

Valid column types are:  

• char (width)
• integer (which is 4 bytes)
• smallint (which is 2 bytes, so it can only store numbers between -32767 and 

+32767)
• decimal (width,decimals)
• float
• date
• logical

Quadrant 2:
Northwest Quadrant

Quadrant 1:
Northeast Quadrant

Quadrant 3:
Southwest Quadrant

Quadrant 4:
Southeast Quadrant
692 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 687



Appendix J: MapInfo Data Interchange Format

M

M

This is an example of the columns section of the header:

COLUMNS  3

STATE char (15)

POPULATION integer

AREA decimal (8,4)

For the database specified in this header, the MID file has three columns: 

• a 15 character field that represents the STATE column, 

• an integer field that represents the POPULATION column, 

• an AREA column that consists of a decimal field with up to 8 total characters 
(digits, decimals points, and optional sign) and 4 digits after the decimal. 

IF Data Section
The data section of the MIF file follows the header and must be introduced with 
DATA on a single line:

DATA       

The data section of the MIF file can have any number of graphical primitives, one for 
each graphic object. MapInfo matches up entries in the MIF and MID files, associating 
the first object in the MIF file with the first row in the MID file, the second object in the 
MIF file with the second row in the MID file, and so on. 

When there is no graphic object corresponding to a particular row in the MID file, a 
“blank” object (NONE) must be written as a place holder in the corresponding place 
in the MIF file. 

NONE        

The graphical objects that can be specified are:

point

line

polyline

region

arc

text

rectangle
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rounded rectangle 

ellipse

multipoint 

collection

A point object takes two parameters; an X coordinate and a Y coordinate. As an 
option, specify the symbol that represents the point. Symbols are designated by 
numbers. If you omit the SYMBOL clause, the current symbol is used.

POINT   x y        

  [ SYMBOL (shape, color, size)]  

Each MapInfo version supports variations on the SYMBOL clause; see Symbol 
discussion later in this appendix. 

A line objects requires four parameters; an X and a Y coordinate for each end point. 
As an option, specify a pen type. When no pen type is specified, the current pen type 
is used.

LINE   x1 y1 x2 y2  

  [ PEN (width, pattern, color)]

A polyline object consists of one or more sections. If the polyline has more than one 
section, include the MULTIPLE keyword, followed by the number of sections. For 
each section, specify a numpts argument (which indicates the number of nodes in that 
section), followed by an x/y coordinate pair for each node. Use the optional PEN 
clause (described later in this appendix) to specify the line style. If you include the 
optional SMOOTH keyword, the polyline is smoothed. 

PLINE  [ MULTIPLE  numsections ] 

  numpts1

 x1 y1

 x2 y2

:

[  numpts2

 x1 y1

 x2 y2     ]

:  
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  [ PEN (width, pattern, color)]

  [ SMOOTH ] 

A region object consists of one or more polygons. Specify the number of polygons 
through the numpolygons argument (immediately after the REGION keyword). For 
each polygon, specify a numpts argument (which indicates the number of nodes in 
that polygon), followed by an x/y coordinate pair for each node. Use the optional 
PEN and BRUSH clauses (described later in this appendix) to specify the object’s 
style. Use the optional CENTER clause to define the object’s centroid explicitly. The 
centroid must be within the object.

REGION  numpolygons  

  numpts1       

    x1 y1  

    x2 y2  

      :

[  numpts2 

    x1 y1  

    x2 y2  ]

     :

  [ PEN (width, pattern, color)]

  [ BRUSH (pattern, forecolor, backcolor)]

  [ CENTER x y ] 

An arc requires the diagonally opposite corners of its bounding rectangle and the 
beginning (a) and ending (b) angles of the arc in degrees, moving counter-clockwise 
with zero at three o’clock. As an option, specify the pen type. (An arc specifies a 
section of an ellipse, the corners of which are determined by the bounding rectangle.)

ARC  x1 y1 x2 y2 

  a b  

  [ PEN (width, pattern, color)]
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A text object consists of a text string, up to 255 characters long. To make the text string 
wrap onto multiple lines, insert the characters \n within the textstring argument (e.g. 
“First line \nSecond line \nThird line”). The x1, y1, x2, and y2 arguments specify the 
location of the text on the map. Spacing can be 1.0 (single spacing), 1.5, or 2.0 (double 
spacing). Use the Font clause (described later in this appendix) to control the typeface, 
etc. 

TEXT  ”textstring”

  x1 y1 x2 y2  

   [ FONT...]

[ Spacing {1.0 | 1.5 | 2.0}]

[ Justify {Left | Center | Right}]

[ Angle text_angle]

[ Label Line {simple | arrow} x y ]

A rectangle requires the coordinates of the diagonally opposite corners. As an option, 
specify pen and brush types. 

RECT  x1 y1 x2 y2

  [ PEN (width, pattern, color)]

  [ BRUSH (pattern, forecolor, backcolor)]

A rounded rectangle requires the coordinates of the diagonally opposite corners and 
the degree of rounding (a). As an option, specify pen and brush types. Degree of 
rounding is expressed in coordinate units.

ROUNDRECT  x1 y1 x2 y2

  a  

  [ PEN (width, pattern, color)]

  [ BRUSH (pattern, forecolor, backcolor)]

An ellipse object requires the coordinates of the diagonally opposite corners of its 
bounding rectangle. As an option, specify pen and brush types.

ELLIPSE x1 y1 x2 y2

  [ PEN (width, pattern, color)]

  [ BRUSH (pattern, forecolor, backcolor)]  
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A multipoint object takes multiple parametrics, consisting of xy coordinate pairs. The 
number of points is indicated by the num_points parameter as an option, specify the 
symbol that represents the multipoint. Symbols are designed by numbers. If you omit 
the SYMBOL claus4e, the current symbol is used. 

MULTIPOINT num_points

   x1 y1  x2 y2  x3 y3 ...

EXAMPLE:

Multipoint  7

-3.113504 10.532464

-2.113504 11.532464

-1.113504 12.532464

-0.113504 14.532464

-4.113504 11.532464

-0.113504 8.532464

0.886496 13.532464

    Symbol (35,0,12) 

Collection format

Collection num_parts

Region

.......

Pline

......

Multipoint

..........

A collection object takes multiple parameters, consisting of the parameters of the 
object types included in the collection. Individual formats for the Region, Pline, and 
Multipoint parts of the collection are the same as those for the corresponding object 
type. The num_parts parameter is required if the number of parts in the collection is 
less than three. If this number is omitted, it is assumed that the collection contains all 
three parts. In exports, MapInfo always writes this number into the MIF file.
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COLLECTION num_parts

Region

Pline

Multipoint

EXAMPLE:

Collection 3

Region  3

  5

4.850832 10.077456

5.850832 11.077456

6.850832 13.077456

12.850832 19.077456

4.850832 10.077456

  4

-5.149168 0.077456

-4.149168 1.077456

-3.149168 3.077456

-5.149168 0.077456

  4

14.850832 20.077456

15.850832 21.077456

16.850832 23.077456

14.850832 20.077456

    Pen (1,2,0) 

    Brush (2,16777215,16777215)

    Center 8.850832 14.577456

Pline 3

-7.149168 0.077456
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P

-3.149168 -2.922544

-2.149168 2.077456

    Pen (1,2,0) 

Multipoint  2

-6.149168 -0.922544

-5.149168 0.077456

    Symbol (35,0,12) 

en Styles
The Pen clause specifies the width, pattern, and color of a linear object, such as a line, 
polyline arc, or the border of a region. The Pen clause has the following syntax: 

PEN (width, pattern, color)

Width is a number from 1 to 7. 1–7 is the width in screen pixels. 11–2047 are values 
that will be converted to points:

penwidth = (number of points * 10) + 10

0 is only valid when the pen pattern is 1 for invisible lines. 

Color is an integer, representing a 24-bit RGB color value. 

Pattern is an integer from 1 to 118; pattern number 1 is invisible. The pattern number 
corresponds to a pen number in the pen file.  The pen file can be modified using a pen 
editor. 

Valid pen numbers are from 1 to maximum number of pens in the pen file, which 
should not exceed 127.  If a pen style is interleaved, 128 will be added to the pen 
number.  Interleaved styles are in the range 129–255.  Because the pen file can be 
modified, and interleaved can be specified, the pen pattern can be a number between 
1–255.
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The following table lists the available line styles by default:
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B
rush Styles
Brush specifies the pattern, foreground color, and background color of a filled object, 
such as a circle or region. The Brush clause has the following syntax: 

Brush (pattern, forecolor  [, backcolor ]) 

The forecolor and backcolor arguments are both integers, representing 24-bit RGB 
color values. 

Pattern is a number from 1 to 71. Note: Pattern number 1 is “no fill,” and pattern 
number 2 is a solid fill. Pattern numbers 9–11 are reserved. The following table 
illustrates the available styles:

Tip: To specify a transparent fill style, use pattern number three or larger, and omit the 
backcolor argument. For example: Brush( 5,  255 ) 
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Symbol Styles
The Symbol clause specifies the appearance of a Point object. There are three different 
forms of the Symbol clause, described below. 

Symbol Clause-MapInfo 3.0 Syntax
The Symbol clause specifies the appearance of a Point object. There are three different 
forms of the Symbol clause. To specify a symbol style using “Old MapInfo Symbols” 
(the symbols that were used in earlier versions of MapInfo), use the following syntax: 

SYMBOL (shape, color, size)

The shape argument is an integer value, 31 or larger; 31 represents a blank symbol (i.e.
the object will not be visible). The standard set of symbols includes symbols 32 
through 67, inclusive, but the user can customize the symbol set by using the Symbol 
application. 

The color argument is an integer representing a 24-bit RGB color value. 

The size argument is an integer from 1 to 48, representing a point size. 

The following table lists the default symbols provided with MapInfo: 
702 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 697



Appendix J: MapInfo Data Interchange Format

M

Symbol Clause – TrueType Font Syntax
To specify a symbol style based on a character from a TrueType font, use the following 
syntax: 

SYMBOL (shape, color, size, fontname, fontstyle, 
rotation) 

The fontname argument is a text string that identifies the name of a font (e.g. 
“Wingdings”).

The fontstyle argument is an integer that controls settings such as Bold. The following 
table lists the values you can use as fontstyle. 

To specify two or more style attributes, add the values from the left column. For 
example, to specify Bold and Drop Shadow, use 33. 

The rotation argument is a floating-point number, representing a rotation angle, in 
degrees. 

Symbol clause – Custom Bitmap File Syntax
To specify a symbol style based on a character from a TrueType font, use the following 
syntax: 

SYMBOL (filename, color, size, customstyle)

The filename argument is a text string that identifies a bitmap file (e.g. “Arrow.BMP”) 
in the CustSymb directory. 

fontstyle value Effect on Symbol style

0 Plain text

1 Bold text 

16 Black border around symbol

32 Drop shadow

256 White border around symbol
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The customstyle argument is an integer that controls whether color and background 
attributes are used. The following table lists the values you can use as customstyle: 

Font Styles
The Font clause specifies the appearance (typeface, color, etc.) of text objects. The Font 
clause has the following syntax:

FONT (”fontname”, style, size, forecolor [, backcolor] )

Fontname in double quotation marks is the typeface to be displayed. Style is the text 
attribute of the typeface as shown in the following table. Size must be 0 in a MIF file, 
because each text object on a Map is attached to the map itself (thus the text size 
chagnes as you zoom in or out). Forecolor is an integer representing a 24-bit RGB 
color. The background color is optional; if you include it, MapInfo fills the area behind
the text with the color you specify. 

To specify two or more style attributes, add the values from the left column. For 
example, to specify Bold and All Caps, use 513.

customstyle value Effect on Symbol style

0 Both the Show Background setting and the Apply Color setting are 
off; symbol appears in default state. White pixels in the bitmap 
appear transparent, allowing whatever is behind the symbol to show
through. 

1 The Show Background settings is on; white pixels in the image are 
opaque. 

2 The Apply Color setting is on; non-white colors in the image are 
replaced with the Symbol’s color value. 

3 Both Show Background and Apply Color settings are on. 

style value Effect on Font Appearance 
0 Plain
1 Bold 
2 Italic
4 Underline
16 Outline (only supported on the Macintosh) 
32 Shadow
256 Halo
512 All Caps

1024 Expanded 
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C
olors
Colors are often defined in relative concentrations of red, green, and blue. Each color 
is a number from 0 to 255, inclusive; the RGB value of a color is calculated by the 
following formula:

(red * 65536) + (green * 256) + blue

These are some often used colors and their values:

Red:  16711680

Green:  65280

Blue:  255

Cyan:  65535

Magenta:  16711935

Yellow:  16776960
Black:  0  

MID File
The MID file contains data, one record of data per row, delimited by the character 
specified in the delimiter statement. The default delimiter is Tab. Each row in the MID 
file is associated with a corresponding object in the MIF file; first row with first object, 
second row with second object.

If delimiter character is included as part of the data in a field, enclose the field in 
quotation marks.

The MID file is an optional file. When there is no MID file, all fields are blank. 
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Australia
Source: Copyright and Intellectual Property in the attached data sets rests with one of 

the following: The Australian Government represented by the Australian 
Bureau of Statistics; The Government of New South Wales represented by 
The Land Information Centre. MapInfo Australia Pty Ltd and PSMA 
Australia Ltd.

Data: Locations of the state boundaries and capitals and over 4000 major and minor 
cities.  Map of major rivers and major roads.
Local government area boundary for Manly.
Tasmania area boundaries, feature points and water boundaries. 
Map of New South Wales.
Sydney feature points, rivers, suburbs, towns, census collection district and 
postcode boundaries, and customer database.
Component street table and grid surrounding for Sydney. Streetworks 
samples

Source: MapInfo from Digital Chart of the World

Data: Generalized map of major highways

Source: SPOT Image Corporation © CNES 1995

Data: Raster map of Sydney

Source: MapInfo Corporation from National Imagery and Mapping Agency (NIMA)

Data: Country boundary

Source: Hervey Bay City Council, 2000

Data: Point Vernon and Hervey Bay, Australia

China
Source: MapInfo from Digital Chart of the World

Data: Over 5,000 major and minor cities and major highways.

Source: MapInfo Corporation from National Imagery and Mapping Agency (NIMA)

Data: Country and surrounding country boundaries.
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Japan
Source: GisNET data licensed to MapInfo by GISdata Limited. © GDC Ltd 1993

Data: Water, highway, rivers, lakes and major railroads. 

Source: MapInfo from Digital Chart of the World.

Data: 142 major and minor cities including all prefecture capitals. 

Source: MapInfo Corporation from National Imagery and Mapping Agency (NIMA)

Data: Country boundary.

India
Source: Risk Management Solutions, Inc

Data:  State, country and district boundaries.

Source: MapInfo from Digital Chart of the World

Data: Major and minor cities and state capitals.

Europe

Austria, Belgium, Denmark, Deutschland, Espana, 
France, Italy, Netherlands, Norway, Portugal, Sweden, 
Switzerland, United Kingdom.
Source: 2001 Tele Atlas B.V. 's-Hertogenbosch. All Rights Reserved.

Data: StreetPro Austria, Belgium, Denmark, Deutschland, Espana, France, Italy, 
Netherlands, Norway, Portugal, Sweden, and Switzerland.

Source: GisNET data licensed to MapInfo by GISdata Limited. © GDC Ltd 1993

Data: Water and highway/roadway maps.

Source: MapInfo Corporation from National Imagery and Mapping Agency (NIMA)

Data:  Country Boundaries (Austria, Belgium, Denmark, Deutschland, Espana, 
France, Italy, Netherlands, Norway, Portugal, Sweden, Switzerland, Europe 
and United Kingdom.)

Great Britain
Source: 2001 Tele Atlas B.V. 's-Hertogenbosch. All Rights Reserved. This product 

includes mapping data licensed from Ordnance Survey (R). (c) Crown 2001. 
License number 100020348

Data: StreetPro Great Britain
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North America 

Canada
Source: Geographic Data Technology Canada 

Data: (Prince Edward Island) Airports, Census subdivisions, Major Primary and 
Secondary Highways, Institutions, Large Areas land use, Parks,  Road 
Buffers,  Streets, Transportation points, Urban Agglomeration, Province, 
Railways, Utility lines and Water areas.

Source: MapInfo from Digital Chart of the World

Data: Over 3000 major and minor cities and generalized map of major highways.

Source: MapInfo Corporation

Data: Country and Province boundaries and surrounding water. 

Mexico
Source: MapInfo Corporation

Data: Surrounding water and country boundary.

Source: MapInfo from the Bureau of Transportation Statistics

Data: State boundaries.

Source: MapInfo from Digital Chart of the World

Data: Generalized map of major highways and locations of all state capitals, major 
and minor cities.

United States, DC
Source: 1997 Geographic Data Technology, Inc. ©

Data: ZIP code boundaries.

Source: MapInfo Canada

Data: 2000 Demographic data Blockgroup.

Source: 2001 Geographic Data Technology, Inc. ©

Data: StreetPro and 5 digit ZIP codes

Source: © MapInfo Corporation 2001.  Aerial Photography used with permission of 
RSC Group, LLC 2001.  All rights reserved.

Data: 5 mile by 5 mile area of 1m and 3m ground resolution raster images.

Source: MapInfo Corporation
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Data: Shields in StreetPro. Listing of NPA/NXXs covered in DC. Competitive, 
Local Exchange Carriers (CLEC), Personal Communications Services (PCS) 
markets, cellular telephone service areas as defined by the FCC, Local 
Exchange Carriers (LEC), Local Access Transport Areas (LATAs), 
Competitive Local Exchange Carriers (CLEC), rate center locations and wire 
center serving boundaries, Point Of Presence (POP) locations for long 
distance telephone carriers. Area Codes. POPINFO and ObstacleInfo.
Point file showing wireless (Cellular, Paging, PCS and SMR) switch locations.
Records of hurricanes between 1988 - 1996
Gas, electric utilities and cable franchise areas. 
StreetInfo and Streetworks - component tables. 
Wireless samples for Sprint, ATT, Bell Atlantic, PGNT_P, PGMT_P, Nextel 
and GTE.
Current hazardous waste notifiers, Superfund Cleanup and National Priority 
List sites as defined by the EPS

United States
Source: 1997- 1998 Schlosser Geographic Systems, Inc. ©

Data: Orthophoto Image of Seattle Airport.

Source: 2001 Geographic Data Technology, Inc. ©

Data: ZIP code boundaries and ZIP code points.

Source: MapInfo Canada

Data: 1990 Demographics by states and counties.

Source: MapInfo Corporation

Data: Sample customer database in various database formats. State boundaries 
with the states of Alaska and Hawaii inset.

Source: MapInfo from Digital Chart of the World

Data: Location of the state capitals and the location of 8875 cities. Point elevation 
data in feet and meters.

Source: MapInfo from NOAA

Data: Annual temperature and rainfall.

Source: MapInfo from the Bureau of Transportation Statistics

Data: A very generalized version of the Roadnet interstate data

Source: MapInfo from the US Census Bureau
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Data: Updated County boundaries from Census 2000 including Puerto Rico. Map 
containing the location of 125 major cities and locations of 208,857 points of 
interest and landmarks.

Source: MapInfo from USGS

Data: MapInfo grid file of Washington DC – East and West

Source: Public Domain - OSU

Data: MapInfo grid file of Mt. St. Helens before and after eruption. MapInfo grid 
file of Crater Lake, Oregon

Source: Sure!MAPS ® RASTER © HTI 1995

Data: Raster image of Alaska, DC, Big Bend TX, Florida, Gulf Coast, Mid-Atlantic, 
Mississippi River, North Central, Northeastern US, Northern US  
Northwestern US, Rockies, Southwestern US. 
Seamless raster of 50 US states.

World
Source: MapInfo Corporation

Data: Military Grid Reference System 84 NL to 80 SL, North & South Polar Regions. 
Grid of latitude and longitude at 15 degree increments.

Source: MapInfo from Digital Chart of the World

Data: Location of world capitals and point locations for major and minor cities.

Source: MapInfo Corporation from National Imagery and Mapping Agency (NIMA)
Data: World Boundaries.
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Alias
The name assigned to an expression or a column when you are working in the Select 
Columns field in the SQL Select dialog. This name appears as the column title for that 
expression or column in a Browser.

Application
A computer program used for a particular kind of work, such as word processing. 
Application is often interchangeable with the word program.

ASCII
The acronym for American Standard Code for Information Interchange. ASCII is a 
standard code used in most microcomputers, computer terminals, and printers for 
representing characters as numbers. It not only includes printable characters, but also 
control codes to indicate carriage return, backspace, and so forth.

Axis
Used in a graph, these are graduated lines bordering the plot area of a graph. Location 
coordinates are measured relative to the axes. By convention the X-axis is horizontal, 
the Y-axis is vertical.

Bar Chart Map
A type of thematic map that displays a bar chart of thematic variables for each record 
in a table from which the map is based.

Base Map
Usually the dominant or underlying layer in a given map. (These are typically the data 

layers that MapInfo® offers as ready products.) Users usually layer their own data on top 
of these base maps or use these base maps to geocode or to make new layers. 
Examples are joining industry data to zip code boundaries for analysis and then 
combining arrangements of the ZIP Codes into new territory layers.
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Base Table
A permanent table, as opposed to a query table, which is temporary. Unlike query 
tables, you can edit the contents of base tables, and you can change their structure (by 
editing, deleting, reordering columns and adding or deleting graphic objects). See 
Query Table. 

Bitmap
A screen image displayed as an array of dots or bits. Software usually generates either 
bit-mapped (raster) or object-oriented (vectored) files. MapInfo can work with both.

Boundary Region
In GIS a boundary is a region on a map enclosed by a border. Cambria County, 
Manitoba, and Argentina would all be represented as boundaries on a map. Note that 
a single boundary could encompass several polygons. Thus, Indonesia is a single 
boundary but consists of many polygons.

Browser
A window for viewing a table (or database, spreadsheet or text file) in tabular form.

Buffer 
A type of proximity analysis where areas or zones of a given distance are generated 
around selected map objects. Buffers are user-defined or can be generated for a set of 
objects based on those objects’ attribute values. The resulting buffer zones form region 
objects representing the area that is within the specified buffer distance from the 
object.

Cadastral
A map set used to graphically define the cadastre or land ownership in a given area. A 
tax map is an example of a cadastral map. The land registration, assessment roles, and 
tax maps comprise the cadastre.
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Cartesian
A coordinate system using an x,y scale not tied to any “real-world” system. Most 
CAD drawing uses this method of registering objects (e.g., a drawing of a ball-bearing 
assembly, floor plans). If a drawing uses Cartesian coordinates, one corner of the 
drawing probably has coordinates 0, 0. 

Cartesian Coordinates
The conventional representation of geometric objects by x and y values on a plane. 

Cartographic Legend
A MapInfo legend window that enables you to display cartographic information for 
any map layer in the Map window. 

Cartography
The art and science of making maps. In GIS it is also the graphic presentation and 
visual interpretation of data.

Centroid
Usually the center of a map object. For most map objects, the centroid is located at the 
middle of the object (the location halfway between the northern and southern extents 
and halfway between the eastern and western extents of the object). In some cases, the 
centroid is not at the middle point because there is a restriction that the centroid must 
be located on the object itself. Thus, in the case of a crescent-shaped region object, the 
middle point of the object may actually lie outside the limits of the region; however, 
the centroid is always within the limits of the region. 

In MapInfo, the centroid represents the location used for automatic labeling, 
geocoding, and placement of thematic pie and bar charts. If you edit a map in 
Reshape mode, you can reposition region centroids by dragging them. 

Check Box
A small square box that appears in a dialog box. You can click in the check box or on 
the text in order to select the option. Check boxes are generally present when multiple 
options can be selected at one time. 
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Command
A word or phrase, usually found in a menu, that displays a dialog box and/or carries 
out an action.

Conflict Resolution
When conflicts exist between the data residing on a remote database and new data 
that you want to upload to the remote database via a MapInfo linked table. The 
conflict resolution process is invoked whenever an attempt to save the linked table 
detects a conflict in an update.

Control Points
The points on a raster image whose coordinates serve as a reference for associating 
earth coordinates with any location on the image. See Registration. 

Coordinate
An x,y location in a Cartesian coordinate system, or a Latitude, Longitude location in 
an earth coordinate system. Coordinates represent locations on a map relative to other 
locations. Earth coordinate systems may use the equator and the Greenwich prime 
meridian as fixed reference points. Plane coordinate systems describe a two-
dimensional x,y location in terms of distance from a fixed reference and are usually in 
the first quadrant so that all coordinates are positive numbers.

Coordinate System
A coordinate system is used to create a numerical representation of geometric objects. 
Each point in a geometric object is represented by a pair of numbers. Those numbers 
are the coordinates for that point. In cartography, coordinate systems are closely 
related to projections. You create a coordinate system by supplying specific values for 
the parameters of a projection. See Cartesian Coordinates, Projection, Spherical 
Coordinates.

Cosmetic Layer
The topmost layer of a Map window. Objects may be placed in this layer such as map 
titles and  graphic objects. It is always displayed, and all objects placed in the 
Cosmetic Layer must be saved to a new or existing layer.
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Data Aggregation
A process that occurs when combining separate map objects into a single object. 
MapInfo calculates what the column values for the new object should be, based on 
sums or averages of the values of the original objects.

Data Disaggregation
A process that occurs when splitting a map object(s) into smaller parts where MapInfo 
splits the data associated with the map object(s) into smaller parts to match the new 
map objects.

Data Sources
An ODBC data source is an SQL database and the information you need to access that 
database. For example, an SQL Server data source is the SQL Server database, the 
server on which it resides, and the network used to access that server. 

Database
Any organized collection of data. The term is often used to refer to a single file or table 
of information in MapInfo.

Decimal Degree
The decimal representation of fractions of degrees. Many paper maps express 
coordinates in degrees, minutes, seconds (e.g., 40_30i10I), where minutes and seconds 
are fractions of degrees. 30 minutes equal half a degree, and 30 seconds equal half a 
minute. MapInfo, however, expresses coordinates in decimal degrees (e.g., 72.558 
degrees), where fractions of degrees are expressed as decimals. Thus, the longitude: 40 
degrees, 30 minutes, would be expressed in MapInfo as 40.5 degrees.

Default
The value or option used in the absence of explicit specification. Often the original 
setting or value for a variable. 
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Degrees Longitude, Degrees Latitude, Decimal Degrees
Degrees (longitude and latitude) are coordinates used to represent locations on the 
surface of the earth. Longitude, or X-coordinate, represents a location’s east-west 
position, where any location west of the prime meridian has a negative X value. 
Latitude, or Y-coordinate, represents a location’s north-south position, where any 
location south of the equator has a negative Y value. 

Derived Column
In a table created through the SQL Select, a derived column is one created by using an 
expression. The column is derived in the sense that it isn’t just a copy of the data in 
one of the tables being accessed by the SQL Select command.

Derived Field
The same as a derived column.

Deselect
The process of undoing a selection. The object or area you deselect will not be affected 
by subsequent commands. Performed by selecting another area, by clicking in a blank 
area, or by executing the Unselect All command.

Digitizer, Digitizing Tablet  
An electronic device that lets you trace a paper map into a GIS or CAD package. The 
digitizer consists of a table (or tablet) onto which you attach a paper map. You then 
can trace the map by moving a hand-held, mouse-like device known as a cursor, or 
puck, across the surface. Digitizing a map produces vector data as the end result.

Districts Browser
A special browser that displays when redistricting. It differs from other Browser 
windows in the following respects: one row can only be selected at one time, one row 
is always selected, and the selected row becomes the target district into which you can 
add other objects.
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Dot Density Map 
A type of thematic map that carries information by showing a large number of tiny 
dots, wherein each dot represents some specific unit quantity. For example, for a 
population dot density map each dot might represent 10,000 people. 

Drawing Toolbar
A MapInfo window containing twelve buttons that access tools for drawing and 
modifying objects on your map or layout.

Edit Handle
The small boxes that appear at the four corners of the minimum bounding rectangle of 
an object in an editable layer of a Map window or in a Layout window.

Export
The process whereby a program saves information in a file to be used by another 
program.

Expression
A statement containing two parts: 1) column names and constants (i.e., specific data 
values), and 2) functions (e.g., area) and operators (e.g., +, -, >), in order to extract or 
derive information from a database. Expressions are used in Select, SQL Select, Update 

Column, Create Thematic Map, and Label with Column. 

Field
A field in a table corresponds to a column in a Browser. A field contains a specific type 
of information about an object, such as, name, abbreviation, land area, price, 
population, and so forth. The record for each object consists of that object’s values for 
each of the fields in the database.

File
A collection of information that has been given a name and is stored on some 
electronic medium such as a tape or disk. A file can be a document or an application.
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Fill Pattern
The design and color used to fill a closed object.

Font
A character set based on a particular style used for text characters.

Generalization
The process of simplifying a data set to a size that can be easily manipulated and 
represented. For example, a river may have many twists and turns; however, if a map 
covers a very large area, the river may be represented as a straight line. Similarly, in a 
map of a very large area, a city might be represented as a point marker. 

Geocode
The process of assigning X and Y coordinates to records in a table or database so that 
the records can be displayed as objects on a map. 

Geographic Information System (GIS)
An organized collection of computer hardware and software designed to efficiently 
create, manipulate, analyze, and display all types of geographically or spatially 
referenced data. A GIS allows complex spatial operations that are very difficult to do 
otherwise.

Graduated Symbols Map 
A type of thematic map that shows symbols (point objects) in a variety of sizes to 
indicate which objects have higher or lower numerical values. 

Graph window
A window that displays numerical data in the form of a graph.

Graticule 
A grid of horizontal (latitude) and vertical (longitude) lines displayed on an earth 
map, spaced at a regular distance (e.g., every five degrees, every fifteen degrees). 
Used to establish a frame of reference.
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Grid Surface Map
A type of thematic map that displays data as continuous color gradations across the 
map. This type of thematic map is produced by an interpolation of point data from the 
source table. A grid file from the data interpolation is generated and is displays as a 
raster image in a Map window. 

Heads-Up Digitizing
A method of digitizing where the user creates vector objects by tracing over a raster 
image displayed on the screen. Thus, heads-up digitizing does not require a digitizing 
tablet. 

Help Button Bar
A bar located at the top of the Help Window that contains buttons you use to move to 
Help topics. 

Hot Views
MapInfo technology that automatically updates all the windows you have open for a 
particular table when you make a change in any one of the windows. For example, if 
an item is selected in a Map window, it will be selected in all other Map windows and 
Browsers you have open for that table.

Import
The process whereby a program loads a file that is the output of another program.

Individual Values Map
A type of thematic map that shades records according to individual values.

Join
The process of creating a relational link between two tables (databases). 

Jump
Text graphics or parts of graphics that provide links to other Help topics or more 
information on the current Help topic.
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Latitude
The horizontal lines on a map that increase from 0 degrees at the Equator to 90 
degrees at both the North (+90.0 degrees) and South (-90.0 degrees) poles. Used to 
describe the North-South position of a point as measured usually in degrees or 
decimal degrees above or below the equator. 

Layer
Basic building block of MapInfo maps. A MapInfo map typically consists of several 
superimposed layers (e.g., a layer of street data superimposed over a layer of county 
or ZIP Code boundaries). When a table appears in a Map window, it occupies a layer 
in that Map window. Typically, each map layer corresponds to one open table; there is 
also a special Cosmetic Layer that contains map objects representing temporary map 
annotations (e.g., labels). See Cosmetic Layer.

Layout Window
A window where you arrange and annotate the contents of one or several windows 
for printing.

Legend Window 
A window that displays the key to the different colors, shapes, or fill patterns used on 
the map. A legend can also include a scale. See Cartographic Legend and Theme 
Legend

Line, Line Object
A map object defined by a set of sequential coordinates that may represent the 
generalized shape of a geographic feature (e.g., street centerlines, railroads, cables). A 
MapInfo street map is a collection of thousands of line objects. 

Linked Table
A linked table is a special kind of MapInfo table that is downloaded from a remote 
database and retains links to its remote database table. You can perform most 
operations on a linked table that you do for a regular MapInfo table.
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Longitude
The vertical lines on a map, running from the North to South poles, used to describe 
the east-west position of a point. The position is reported as the number of degrees 
east (to -180.0 degrees) or west (to +180.0 degrees) of the prime meridian (0 degrees). 
Lines of longitude are farthest apart at the Equator and intersect at both poles, and 
therefore, are not parallel.

Longitude/Latitude
MapInfo’s default coordinate system for representing geographic objects in a map.

Main Toolbar
A window containing buttons for choosing tools, accessing dialogs, and showing or 
hiding windows.

Map Scale
A statement of a measure of the map and the equivalent measure on the earth. Often 
expressed as a representative ratio of distance, such as 1:10,000. This means that one 
unit of distance on the map (e.g., one inch) represents 10,000 of the same units of 
distance on the earth.

The term scale must be used carefully. Technically, a map of a single city block is large–

scale (e.g., 1:12,000), while a map of an entire country is small–scale (e.g., 1:1,000,000). A 
1:1,000,000 map is considered small-scale because of the small numeric value obtained 
when you divide 1 by 1,000,000. 

Map Segment
In a street map, a segment is a single section of the street. In urban maps, segments are 
generally one block long. Address ranges are stored at the segment level.

MapBasic
The programming language used to customize and/or automate MapInfo. To create 
MapBasic applications, you need the MapBasic compiler, which is a separate product. 
However, you do not need the MapBasic compiler to run a compiled MapBasic 
application.
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Map window
A window that allows you to view a table as a map.

Meridian
A line or a portion of a line running from the North to the South pole. A longitudinal 
line.

Minimum Bounding Rectangle (MBR) 
For any given map object, the smallest rectangle that completely encompasses the 
object. 

Native Projection
The projection in which a map’s coordinate points are stored. MapInfo allows you to 
display maps in other projections, but not as fast as displaying maps in their native 
projection.

Node 
An end-point of a line object, or an end-point of a line segment which is part of a 
polyline or region object. 

Non-Earth Map
A map in which objects are not explicitly referenced to locations on the earth’s surface. 
Floor plans are typical examples.

ODBC Drivers
An ODBC driver is a dynamic-link library (.DLL) file that MapInfo uses to connect to 
an SQL database. Each type of SQL database requires a different ODBC driver.

ODBC Table
An ODBC table is a table residing in a remote SQL database.
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Outer Join
A type of multi-table join where all the records in the specified tables are included in 
the result table, even records that do not match the join criteria. MapInfo does not 
perform outer joins.

Pack
The process of compressing MapInfo tables so that they use less disk space.

Pie Chart Map
A type of thematic map that displays a pie chart of thematic variables for each record 
in the table from which the map is based.

Pin Map, Push-Pin Map 
A type of map named after the practice of inserting push-pins into a wall map. A pin 
map features point objects. Geocoding a database is one way of creating a pin map. 

Pixel 
The acronym for picture element. The smallest dot that can be displayed on a 
computer screen. If a screen is described as having a resolution of 1,024 x 768, the 
screen shows 1,024 pixels from right to left, and 768 pixels from top to bottom. Each 
character, object, or line on the screen is composed of numerous pixels.

Point, Point Object
A map object defined by a single X,Y coordinate pair. Each point object is represented 
by a symbol style (e.g., circle, square, triangle, etc.). 

Point Size
A unit of measurement equal to 1/72 of an inch. Used to measure character size.

Pointer
An arrow-shaped cursor on the screen that can be manipulated by a mouse.
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Polygon, Polygon Object
A simple bounded region, simple in the sense that it does not consist of more than one 
polygon (where a boundary can consist of more than one polygon). The Polygon tool 
creates a single polygon. 

Polygon Overlay
A spatial operation that merges overlapping polygons from two layers to analyze 
those intersected areas or to create a third layer of new polygons.

Polyline, Polyline Object
A linetype object made up of many line segments. It contains more than two nodes, 
that is, more than its end points. The Polyline tool creates a single polyline. In 
contrast, the Line tool only draws a single straight line (that is, a line defined by two 
nodes).

Projection
A mathematical model that transforms the locations of features on the earth’s surface 
to locations on a two-dimensional surface, such as a paper map. Since a map is an 
attempt to represent a spherical object (the earth) on a flat surface, all projections have 
some degree of distortion. A map projection can preserve area, distance, shape or 
direction but only a globe can preserve all of these attributes. Some projections (e.g., 
Mercator) produce maps well suited for navigation. Other projections (e.g., equal-area 
projections, such as Lambert) produce maps well suited for visual analysis. 

Query Table
A temporary table produced as the result of a Select, SQL Query, or by choosing 
objects in a Map window or records in a Browser and mapping, graphing, or 
browsing that selection. You cannot make edits and structural changes on query 
tables, but you can edit a selected set of rows in your source table through a query 
table. See Selection and Source Table.

Ranged Map
A type of thematic map that displays data according to ranges set by the user. The 
ranges are shaded using colors or patterns.
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Raster Image
A type of computerized picture consisting of row after row of tiny dots (pixels).  
Raster images are sometimes known as bitmaps. Aerial photographs and satellite 
imagery are common types of raster data found in GIS. See Scanning, Vector Image. 

A type of computerized picture consisting of row after row of tiny dots (pixels). Raster 
images are sometimes known as bitmaps. Aerial photographs and satellite imagery 
are common types of raster data found in GIS. A computer image can be represented 
in raster format or in vector format. See Scanning. 

Record
All the information about one object in a database or table. A record in a table 
corresponds to a row in a Browser.

Redistricting
The process of assigning map objects to groups. As you assign map objects, MapInfo 
automatically calculates totals for each group and displays the totals in a special 
Districts Browser. This process is sometimes known as load-balancing.

Region, Region Object 
An enclosed area defined by one or more polygons. If a region contains one or more 
lakes or islands, each lake or island is a separate polygon. 

Registration
Usually the first stage of the digitizing process or when opening a raster image for the 
first time in MapInfo. Before you can digitize a paper map or work with a raster 
image, you must point to several control points across the map, and enter their 
coordinates (e.g., longitude, latitude). After you have registered the map, MapInfo can 
associate a longitude, latitude position with any point on the map surface; this allows 
MapInfo to perform area and distance calculations, and overlay multiple map layers 
in a single map. CAD systems as well as GIS systems utilize this process. See Control 
Points.

Scale Bar
A map element that graphically depicts the map scale (e.g., 0 —— 5 —— 10 km).
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Scanning
The process of inputting data into a raster format using an optical device called a 
scanner.

Scroll Bar
Bars along the right and bottom sides of each window that allow you to scroll the 
window view. Clicking on the shaded area moves one window screen at a time. 

Selection
A data item or set of data items chosen for inspection and/or analysis. Regardless of 
the kinds of windows on the screen, selections can be made using the Select and SQL 
Select Query commands in MapInfo’s Query menu. In Browsers and Map windows, 
items can be placed in the selection set by clicking on them individually. Map 
windows also have special tools for selecting multiple items on a spatial basis.

Snap To Nodes
A feature that helps in drawing, moving and positioning map objects. In Snap mode 
(S key) the cursor snaps to a node of a map object when it comes within a certain 
distance. 

Spatial Analysis
An operation that examines data with the intent to extract or create new data that 
fulfills some required condition or conditions. It includes such GIS functions as 
polygon overlay or buffer generation and the concepts of contains, intersects, within 
or adjacent.

Spherical Coordinates
Latitude and longitude values that represent objects on the surface of the globe.

SQL Query
The selection of information from a database according to the textual attributes and 
object relationships of the items. In MapInfo, queries are created with the SQL Select 
and Select commands or with MapBasic commands in the MapBasic window.
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Standard Deviation
A measurement of the variation of a set of data values around the mean.

Standard Toolbar
A window containing buttons for quick access to the most commonly used menu 
commands such as Cut, Copy, and Paste.

Statistics Window
A window containing the sum and average of all numeric fields for the currently 
selected objects/records. The number of records selected is also displayed. As the 
selection changes, the data is re-tallied, and the statistics window updates 
automatically.

StatusBar
A bar at the bottom of the screen that displays messages that help in using MapInfo. 
The StatusBar also displays messages that pertain to the active window. In a Map 
window, the StatusBar indicates what layer is editable, the zoom display of the map, 
and the status of Snap and Digitizing modes. In a Browser window, the StatusBar 
indicates the number of records currently displaying and the total number of records. 
In a Layout window, the StatusBar indicates the zoom display as a percentage of the 
actual size of the map.

Structured Query Language (SQL)
A standard language used for analyzing information stored in relational databases. 
MapInfo’s database engine is based on the SQL standard.

Subselect
A select statement that is placed inside the Where Condition field of the SQL Select 
dialog. MapInfo first evaluates the subselect and then uses the results of the subselect 
to evaluate the main SQL Select statement.

Symbol, Symbol Object
A small, relatively simple shape (e.g., square, circle, star, push-pin) used to 
graphically represent a point object (e.g., a customer location). 
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Table
MapInfo databases are organized as tables. Tables are made up of rows and columns. 
Each row contains information about a particular geographic feature, event, etc. Each 
column contains a particular kind of information about the items in the table. 
MapInfo can contain graphic objects representing geographic objects. Such tables can 
be displayed as maps. 

See Base table and Query table.

Table Row
In a table, a row contains all the information for a single item. It corresponds to a 
record in a table.

Target District
The district that is selected in a Districts Browser to be affected by subsequent 
redistricting operations.

Text Cursor
A blinking vertical bar that shows the position where text can be edited, inserted, or 
deleted.

Thematic Layer
A layer containing the thematic settings for a map layer. Thematic layers are drawn 
directly over the map layer on which the thematic settings are based. They are also 
drawn in a particular order, depending on the number of thematic layers you have 
and the type of thematic map objects you are creating. 

Thematic Map 
A type of map that uses a variety of graphic styles (e.g., colors or fill patterns) to 
graphically display information about the map’s underlying data. Thus, a thematic 
map of sales territories might show one region in deep red (to indicate the region has 
a large number of customers), while showing another region in very pale red (to 
indicate the region has relatively few customers). 
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Thematic Shading
Map objects — points, lines, regions — that have been shaded, using a pattern and/or 
color, according to some point of information about the object, or theme (population, 
size, annual rainfall, date, and so forth). 

Thematic Variable
The data values displayed on a thematic map. A thematic variable can be a field or 
expression.

Theme Legend
MapInfo’s original style legend that allows you to display legends for thematic maps 
and graphs. MapInfo automatically creates a theme legend window for a thematic 
map. Customize its display through the Modify Thematic Map dialog. See 
Cartographic Legend.  

Toolbars
MapInfo windows that contain a variety of buttons used to access tools and 
commands for mapping and drawing. There are four Toolbars: the Standard Toolbar 
provides tools for commonly performed tasks, the Main Toolbar provides primary 
tools (e.g., Zoom-in, Select, Info, etc.) and the Drawing Toolbar contains all drawing 
tools. The Tools Toolbar contains the Run MapBasic Program and the Show/Hide 
MapBasic Window buttons. All four Toolbars may be reshaped and hidden.

Transformation
The process of converting coverage coordinates from one coordinate system to 
another through programmatic translation. The transformation of CAD generated 
Cartesian coordinates into earth coordinates is an example.

Ungeocode
The process of removing X and Y coordinates from records in a table or database. Can 
also describe a table that has not been geocoded, e.g., an ungeocoded table.
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Vector Image
A coordinate-based data structure commonly used to represent map features. Each 
object is represented as a list of sequential x,y coordinates. Attributes may be 
associated with the objects. See Raster Image.

A coordinate-based data structure commonly used to represent map features. Each 
object is represented as a list of sequential x,y coordinates. Attributes may be 
associated with the objects. A computer image can be represented in vector format or 
in raster format. 

Weighted Average
An average that gives more weight to one value over another when averaging. 

Window
In MapInfo, Map windows, Browser windows, Graph windows and Layout windows 
are the major types of windows. They display the data stored in tables. The Toolbars, 
map legends, and the Info tool window are other types of windows.

Workspace
A saved configuration of open MapInfo tables and windows. 

Zoom Layering
A setting that determines the range (e.g., 0–3 miles, 2–5 miles, etc.) at which a layer is 
visible in a Map window.
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Index

Numerics
D graphs

templates 262
using 3D viewing angles 275–277

DMaps
3DWindow menu 235–236
creating 233–234
manipulating view 237
using three dimensional view 232–233
video card acceleration 99

DWindow menu
3DMaps 235–236
Prism maps 240

A
bbreviation file 590
bs function

in expressions 616
ccess datasources

setting up 644
ccessing drawing tool buttons 352
ccessing remote databases

configuring data sources 499–501
opening DBMS tables 515–522
prerequisites 496
refreshing linked tables 535
saving DBMS tables 532–535
unlinking 536

ctive objects
creating 301–304

dding
control points 389–391
data to a table 483–490
layers to a Map window 113–114
nodes 351, 361–363
rows to a browser window 68–69
temporary columns 483–484
windows to a layout 442
control points

See also Registering a raster image
ddress matching preferences 103
DRG format files

raster format 385
dvanced geocoding 577–596
ffine transformations

coordinate systems 670–672
digitizing 566

Aggregating data
combining objects 402
functions 195
redistricting 375–377
Update Column command 490–493
with SQL Select command 193–195
 See also Editing objects

Alias
defined 713
using with SQL Select command 189

Aligning objects
in a layout 445–447
snap to nodes 363–365

Angles
determining from horizontal via MapBasic 

542–544
Appending rows to a table 481
Application data (appdata) files 597–600

modifying mapinfow.prf for 7.0 directories 16
per-user install 17
specifying location 29–30

Arc objects
drawing tool button 350
Reshape mode 362

Area calculations
setting default 98

Area function
in expressions 616–617

Area graphs
templates 262

Area units of measure
Map window preferences 98

Arrow keys
positioning selected objects 359

ASCII files
defined 713

ASRP format files
raster format 385

Assign Selected Object button
redistricting 376

Assigning X and Y coordinates to records
geocoding 134–135

Attributes
displaying bivariate thematic map variables 

250–251
graduated symbols 242
legend 335–338
object 360–361
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Autolabeler tool
creating labels as text objects 311, 441

Automatic geocoding 137, 577–578
Automatic labeling 313–318
Autoscroll feature

with Microsoft Intellimouse 9
Autotrace

digitizing 570
tracing existing objects 364–365

Axis
changing attributes in graphs 269–270
defined 713

Azimuthal projections
range 667

B
Bar chart maps

defined 244–245, 713
Bar graphs

templates 263
Base maps

defined 713
Base tables

defined 714
BIL files

raster format 384
Bitmap symbols

MIF file syntax 703
Bitmaps

custom symbols 357–358
defined 714
See also Raster images

Bivariate thematic maps 250–252
Blue Marble Graphics

installing global positioning software 25
BMP files

file export format 81
raster format 384

Bound objects 524
Boundaries

geocoding by 135

Boundary regions
defined 714

Boundary Select tool button
using 173

Bring to Front command 449
Browser windows

browsing a table 68–69
defined 714
displaying tables in row and column format 

48
showing/hiding 68–69
StatusBar 7–8
using HotLink tool button 305

Brush styles
MIF file syntax 701

Bubble graphs
templates 263

Buffer regions
calculating radii 430–431
concentric ring buffers 433–434
creating 429–434
creating search polygons 174
data aggregation 34
defined 714
segments per circle 431

C
Cadastral

defined 714
CADRG format files

raster format 385
Calculating buffer radii 430–431
Callout lines

with labels 316–317
Cancelling selections 169
Cartesian calculation method

setting as default 98
Cartesian coordinates

defined 715
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artographic legends
adding frames 338–341
alignment of frames 345–347
choosing layers 332
creating 67, 326–331
defined 715
deleting frames 344
displaying thematic legend in 255–256
frame borders 334
frame defaults 333
frame titles 334
legend styles 336
metadata 335–338
modifying 338–347
modifying frames 342–344
preferences 334
refreshing 345–347
saving attributes to metadata 337
selecting attributes 335–338
symbols in 334
window properties 333, 342

artography
defined 715

D Browser
installation 17

entroids
defined 715
displaying 122

entroidX function
in expressions 618

entroidY function
in expressions 618–619

hange Zoom command (Layout menu) 448
hanging symbol styles 145
heck Regions command 421–422
hoosing a projection 96–97, 551–552, 555–556
hr$ function

in expressions 619
IB format files

raster format 385
ircle objects. See Ellipse objects
ircles

creating around points via MapBasic 540
leaning objects 423–424
lear Cosmetic Layer command 125
lipping a map

clip methods 97, 116–117
displaying a portion of a map 115
grid surface maps 231–232

Clone maps
creating duplicate map windows 114
with layouts 439–440

Closing
tables 74–75
windows 74–75

Collection objects
combining 417
creating 413–414
Erase and Erase Outside commands 33, 407
legend styles 336

Colors
grid surface maps 229
in custom symbols 358
in street maps 369
MIF files 705
raster image options 385, 393–396

Column graphs
templates 263

Column name aliases
HTML landing pages 307

Columns (fields)
aliases 189
database structure 464–465
derived 189
expressions 178
labeling with 311
temporary 483–484

See also Update Column command
Combining objects

Collection 417
Combine Objects Using Column command 

380, 410–412
creating territories 409–412
data aggregation 402
heterogeneous types 416–417
multipoint 416
set target editing model 403–404

Combining windows for output
layout windows 49, 438

Comparison operators 605–611
Concentric ring buffers 433–434
Conflict resolution

defined 716
linked tables 532–535
live access tables 532–535

Conformal projections 551
Conic projections 666
Consulting 59
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Contacting MapInfo
via the World Wide Web 575

Control points
defined 716
digitizing 564–567, 571
registering a raster image 388–391

Converting
a map back to its native projection 552–554
to regions and polylines 365

Convex hull objects
creating 434–435

Coordinate Extractor tool 160
Coordinate systems

creating 668–670
defined 653, 716
origin point 665–666
projections 653–656
with projections 549

Coordinates
assigning to records 50
defined 716
digitizing 564, 571
displaying 99
extracting from geocoded tables 156–160
manually converting to decimal degrees 651
manually converting to degrees, minutes, 

seconds 651
registering raster images 388–391

Copying
objects to clipboard 94
tables 480

Cos function
in expressions 619

Cosmetic layer
defined 716
Layer Control options 124

Cosmetic objects
saving 125

Creating a graph 265–266
Creating a layout 442–447, 458
Creating a map 113–117
Creating a table

choosing a projection 555
Microsoft Access 471–474
procedure 466–468
using a subset of a file 181–187
working with spreadsheets 468

Creating expressions
clauses 611–613
columns (fields) 178
constructing 601–602
entering values 603
functions 179, 616–634
keywords 613–614
operator precedence 614–615
operators 178, 604–611
Select command 177–181

Creating points
Degree Converter tool 151–153
Excel or Lotus tables 148–149
for intersections 155–156
MapInfo for DOS tables 147–148
using a projection 150–151
using longitude/latitude coordinates 149–150

Creating search polygons 174
See also Polygon objects

Creating territories
combining objects 409–412
reshape mode 361–363
See also Redistricting

Crystal Reports
creating reports 69, 481
default open and save directories 104
installing User’s Guide 24
updated version 37

CurDate function
in expressions 619

Cursor location
StatusBar 8

Custom
ranged map type 220

Custom datums 675–682
Custom installation 19
Custom symbols 357–358
Customizing

layouts 452–457
map objects 120
theme legends 255–258
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D
D
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 key

digitizer mode 571
/m/s coordinates

converting to decimal degrees 392
at files

table structure 42–43
ata

installing 23
locating records on a map 145–146
supported file formats 45–46

ata aggregation
combining objects 402
defined 717
with SQL Select command 193–195

ata bounds
updating in MapInfo_MapCatalog 507

ata disaggregation
defined 717
splitting objects 402

ata limitations in raster tables 396
ata products 23
ata subsets

selecting by querying 166–167
atabases

defined 717
structure 464–465

atasources
defined 717
MS Access 644
ODBC Administrator 643
Oracle 644–645

ate clauses
expressions 613

ate comparison operators 606
atums

conversion methods 682
defining custom 675–681
MAPINFOW.PRJ ID numbers 657–665

ay function
in expressions 620

BASE DBF files
opening in MapInfo 45–46
working with spreadsheets 468

BMS Catalog tool 505
BMS Count Rows in Table tool 526–527
BMS databases

specifying default connection 102

DBMS SQL Builder tool
building queries on remote tables 529–531
primary indices in remote tables 524

DBMS SQL queries
default open and save directories 104
default search paths 65

DBMS support
installation 497–498
installing 20–21

DBMS tables
accessing 496
configuring data sources 499–501
conflict resolution 532–535
downloading 522
geocoding 512–513
live access 522–524, 526–527
making mappable 507–511
opening 515–522
per row styles 513
primary indices 524–525
read only 522
refreshing 535
saving 532–535
SQL queries 528–529
storing/retrieving spatial data 501–511
symbols 514
unlinking 536
with linked tables 514

DBMS toolbar 57
Decimal degrees

converting to d/m/s 392
defined 717
displaying coordinates in 99

Default
defined 717

Default projection
specifying 96–97

Default search paths
specifying 65

Default zoom level
setting on a map via MapBasic 545

Degree Converter tool 392
converting coordinates 151–153

Degrees latitude
defined 718

Degrees longitude
defined 718

Degrees, minutes, seconds
displaying coordinates in 99
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Deleting
labels 319
nodes 353, 361–363
tables 482

Delimited ASCII files
opening in MapInfo 45–46

Derived columns (fields)
creating 189
defined 184, 718

Device drivers
digitizing 562–563

Digitizer
defined 718

Digitizer mode
D key 571
digitizer cursor 569, 572
opening a workspace 566
using the mouse 568
using tools 568

Digitizer setup
configuring digitizer buttons 567
control points 564–567, 571
Digitizer Setup command unavailable 572–

573
map units 564
projections 555, 564

Digitizing
displaying a map 571
distances incorrect 572
drivers 562–563
polygon closure 573
procedure 569
puck 562
setting up equipment 563
snap to nodes 573
source map 563
tablet 562, 572–573
tracing existing objects 570
with two maps 573
zoom levels 573

Digitizing process
heads-up digitizing 384
raster images 393

Digitizing tablet
defined 718

Directory preferences
default display directories 104
graph support files 280

query templates 188
specifying search paths 130
table paths 64–65
workspaces 84

Disaggregating data 402, 717
Disaggregating objects 428–429
Dispersing points 153–155
Displaying a map

digitizing 571
projections 548–549
with a different projection 552–554

Displaying data on a map
geocoded records 50, 145

Displaying thematic layers 215
Distance calculations

setting default 98
Distance function

in expressions 620–621
Distance units of measure

Map window preferences 98
Districts browser

changing and saving district styles 379–380
creating and changing districts 373
defined 718
displaying a district in tabular form 372
ordering districts 379–380
target districts 374

Districts. See Redistricting
Document panning

with Microsoft Intellimouse 8
Document scrolling

with Microsoft Intellimouse 8
Dot density maps

defined 242–244, 719
Drag Map Window tool button

creating duplicate map windows 114
Drawing objects on a map

commands 351–352
symbols 356–358
text objects 358–359
tool buttons 54–56, 350–351
types of shapes 353–356
using Ruler window 353

Drawing toolbar 54–56, 350–352, 719
Drop shadows

creating in a layout 455
Duplicate nodes 97
DXF files

importing 555
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E
E

E

E

E

E

E

E

E

E

E
arth maps 550–551
asyLoader

supported DBMS connections 502
uploading to spatial databases 502–505

CW Compressor
installing 24

CW Raster Handler
raster format 384

CW raster handler
direct installation of 34

dit handles
defined 719

ditable layers
Cosmetic layer 124
editing objects 122–123
making a layer editable 352–353
StatusBar 7–8
with drawing tool buttons 352–353

diting
MAPINFOW.PRJ file 668–670

diting a map
raster images 384
street maps 366–369

diting objects
aggregating/disaggregating data 402
attributes 360–361
buffers 429–434
Combine command 409–410
Combine Objects Using Column command 

410–412
combining 403–404
commands 351–352
converting to regions and polylines 365
creating territories 409–412
erasing 407–408
moving arc endpoints 362
overlaying nodes 408
positioning and sizing 359
reshaping 361–363
selecting multiple nodes 362–363
set target 400–401
smoothing/unsmoothing lines 365
snap to nodes 363–365
splitting 405–406
splitting with polylines 406
tracing existing objects 364–365

Editing tables
DBMS linked tables 649
SpatialWare tables 650

Ellipse objects
drawing tool button 350

Embedding maps
into applications 289–291
MapInfo Map Object 285–295
Microsoft Data Map 297–298
OLE terms 284
printing 296
resizing and repositioning 295
saving 296
sharing documents 297
using containers 288–289

Encapsulated Postcript files
with layouts 461

Enclose command 418–420
Enhanced Metafile Format files

file export format 81
Equal area projections 551
Equal Count

ranged map type 219
Equal dispersion

dispersing points 154
Equal Ranges

ranged map type 219–220
Erasing objects 400–401, 407–408
ESRI shapefiles

opening 469
Exact geocoding matches 578–579
Excel files. See Microsoft Excel files
Exiting MapInfo

MAPINFOW.WOR 86
Export

defined 719
Exporting files

advanced options 81
file formats 81
layouts 460–461
Save Window As command 79–81
setting resolution 79
setting window defaults 107
to raster file formats 382–383
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Expressions
buffer radii 430–431
clauses 611–613
creating 177–181, 601–602
defined 719
displaying coordinates in a table 489–490
entering values 603
functions 616–634
keywords 613–614
labeling with 311–312
operator precedence 614–615
operators 604–611

Extracting coordinates 156–160

F
False Eastings

defined 667
False Northings

defined 667
Features and enhancements 32–39
Fields

defined 719
File formats

file export 81
grid image files 222–224
raster 384
supported in MapInfo 45–46

Files
defined 719
importing 555
opening 43–44
table structure 42–43

Fill patterns
defined 720
printing 355

Find command
locating data on a map 145–146

Floating windows
finding via MapBasic 545

Floor plans. See Non-earth maps
Font styles

MIF file syntax 704
Fonts

defined 720
symbols 357

Format$ function
in expressions 621–623

Frames
displaying windows in 452
drawing 444
layout templates 458
legend 333, 338–341
positioning with rules 448

Front-to-back ordering
in Layer Control 119
in layouts 449

Functions
creating expressions 616–634
in expressions 179
See also Creating expressions

G
GEN files

raster format 385
Generalization

defined 720
Geocoded points

locating 161–162
Geocoded tables

extracting coordinates 156–160
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M

G

G

G
G

G
G
G

G

eocoding
abbreviations 141, 583–587
address range incorrect 592
advanced geocoding 577–596
assigning X and Y coordinates to records 134–

135
automatic 137
by address 135
by boundary 135
by ZipInfo 135
data errors 140
database information 136
DBMS tables 512–513
defined 720
displaying data on a map 50, 145
exact matches 578–579
geographic accuracy 136
indicating spaces 589–590
interactive 140–143
manual 144
map details 136
matching address numbers 580–581
matching regions 581–583
matching street names 579–580
point position 138–139
post office boxes 592
refining boundaries 141–143
result codes 143
simple substitution 588
special characters 590
spelling errors 590–591
street names 591
substitutions 583–587
town name incorrect 593
truncation 587–588
using 58–59

eographic Information System (GIS)
defined 720

eographic operators 607–609
eoreferenced raster images

opening 386–387
eospot Images 637–638
et Info command 360
IF files

raster format 384
lobal Positioning Software (GPS)

installing 25

Graduated symbols maps
defined 241–242, 720

Graph objects
formatting 267
selecting 267

Graph Select tool 278–279
Graph series

editing 271–273
Graph support files

default open and save directories 104
Graph templates

changing search location 279–280
list of 262–264
saving 280–281

Graph windows
defined 720
displaying a table as a graph 48, 69–70
table selections 278

Graphic Interchange Format files
raster format 384

Graphic objects
associated files 42–43
removing from a table 162–163

Graphs
axis attributes 269–270
creating 265–266
editing 266–271
examples 273–277
general options 268
saving 279
specifying titles 270–271
support files 279–280
types 262–264
using pre-5.5 graphs 281

Graticule
defined 558, 720

Grid handlers
specifying default 100

Grid image files
converting to .mig format 230
default open and save directories 104
display settings 105

Grid images
overriding style 396

Grid layers
zoom layering 99
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Grid surface maps
3D view 232–237
color adjustments 229
defined 721
file formats 222–224
inflection methods 227–228
interpolators 224–226
read-only handlers 223
relief shading 228
translucency 229
using grid layers 229
Vertical Mapper handler 223–224
with Info tool 229
zoom layering 229

Grid tables
using with projections 558

Grid Tools 230–231
Group by clause 195
Grouping data (selecting by querying) 166–167
Grouping map objects (redistricting) 372

H
Handlers

grid 223
Hardware requirements 16
Heads-up digitizing

defined 721
with raster images 384

Help button bar
defined 721

Heterogeneous objects
combining 416–417

Highlighting objects 109
Histograms

templates 263
Hot views

defined 721
displaying views of data in different 

windows 49
Hotine Oblique Mercator projection

oblique azimuth 666
HotLink tool button

in Browser windows 305
setting options 302–303
using 300

HotLinks
creating active objects 301–304
saving options to metadata 304

HTML image maps
adding HTML Image Map tool 305–306
creating 305–306
landing pages 307–308

I
id files

table structure 42–43
Images. See Raster images, Vector images
Imported files

default open and save directories 104
default search paths 65

Importing
choosing a projection 555
defined 721
OSGB format GML file support 34

Indexed fields
with Find command 145–146

Indices
creating a primary index on a remote table 

524–525
database structure 464–465
ind files 43
searching for map objects 43

Individual values maps
bivariate thematic maps 250–252
defined 216–217, 721
redistricting 372, 377–378
saving categories in templates 259

Inflection point
grid surface maps 227–228
in thematic maps 253–254
ranged maps 220

Info tool
selectable layers 123
using 58
viewing data 73–74
with grid surface maps 229

Informix Universal Server Driver (IUS)
installing 22

InfoTips 98, 123, 229
in Prism maps 240

Insetting points
street level geocoding 139
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In

In

In

In

In
In

In
In

In
stallation
adding ODBC drivers 22
application data (appdata) files 16, 597–600
Blue Marble Graphics GPS 25
CD browser 17
custom 19
DBMS support 20–21, 497–498
ECW Compressor 24
free data 23
Informix Universal Server Driver (IUS) 22
MapInfo Professional 7.0 17–24
MetaData Browser 24
network 25–26
ODBC drivers 498–499
online reference guides 24
per-user 17
program maintenance 20
running from drive letter 26
setting the temp variable 26
system requirements 16
Windows registry 27–28

Str function
in expressions 624
locating a substring 201–202

t function
in expressions 625

teractive clause
renamed tables in workspaces 85

teractive geocoding 140–143, 577–578
teractive labeling

editing 318
Label tool 319

terleaved line styles 354
terpolators

grid surface maps 224–226
tersections. See Street intersections

Inverse distance weighting (IDW) interpolator
grid surface maps 224–225

Invert Selection tool button 72
using 174

IUS (Informix Universal Server Driver)
installing 22

J
Joining tables

in cartographic legends 337
join definition 721
outer joins 200–201
through thematic mapping 213
using SQL Select dialog 196
where condition 198–199

Joint Photographic Experts Group files
raster format 384

JP2 files
raster format 384

JPEG 2000 files
file export format 81
raster format 384

JPEG File Interchange Format files
file export format 81
raster format 384

JPG files
file export format 81
raster format 384

Jumps
defined 721

K
Keywords

in expressions 613–614
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L
Labeler tool

labelling with text objects 321–323
using text objects 441

Labels
automatic 125, 313–318
content 311–312
controlling display 313–314
creating callouts 316–317
current selection 322
design 310
editing 318
in layouts 441
interactive 318
Label tool button 125, 319
legend styles 336
packing a table 320, 482
partial regions and polylines 37
position 315–316
removing 319
saving 320
size 315
styles 317
using expressions 311–312
zoom layering 314

Lambert conformal conic projection 551
Latitude

defined 722
Layer Control command

Cosmetic layer 124
display options 119–122
editable and selectable layers 122–124
Label Lines option 316–317
Label Options dialog 311–312
zoom layering 121–122

Layers
adding and removing 119
defined 722
display options 119–122
displaying lines, nodes, and centroids 122
map 112–113
reordering 118
seamless 126–131
thematic 131, 214–215
visibility 118

Layout windows
aligning objects 445–447
combining for output 438
combining windows for output 49
customizing 452–457
defined 722
Frame tool button 444
frames 442
ordering overlapping objects 449
zoom levels 448

Layouts, creating
adding a logo 457
adding a north arrow 455–457
adding windows 442
combining windows for output 49, 438
customizing text 454
drop shadows 455
multiple views of a map 439–440
scale 449–451
setting up Map windows 439–442
templates 458
using labels 441
using legends 442

Layouts, managing
exporting to files 460–461
moving frames 444
print options 459–460
printing 458–460

LCase$ function
in expressions 625

Left$ function
in expressions 626

Legend frames
adding 338–341
alignment 345–347
borders 334
default settings 333
deleting 344
modifying 342–344
selecting attributes 335–338
symbols in 334
titles 334

Legend Manager utility 258
Legend styles

labels 336
symbols 336
744 MapInfo Professional User�s Guide

Apple Inc. 
Exhibit 1021 

Page 737



Index

M

L

L

L

L

L

L

L

L

L

L
L

L

L
L
L

L

egend windows
cartographic 255–256
changing properties 342
defined 722
specifying properties 333
theme 257–258

egends
creating cartographic 67, 326–331
in layouts 442
preferences 100–101, 334
theme 67

en function
in expressions 626

ike operator
wildcards 179, 521

ine graphs
templates 264

ine objects
defined 722
displaying direction of 122
drawing tool button 350
map object type 50

ine styles
interleaved 354

inked tables
accessing 496
conflict resolution 532–535
defined 722
editing 649
refreshing 535
unlinking 536
with DBMS tables 514

ive access tables
conflict resolution 532–535
DBMS Count Rows in Table tool 526–527
limitations 523

oad balancing. See Redistricting
oading

MAPINFOW.WOR 101–102
Tool Manager tools 90

ocating
geocoded points 161–162
map data with the Find command 145–146

ogical comparison operators 607
ogical operators 178, 609–611
ogos

adding to a layout 384, 457
See also Raster images

ongitude
defined 723

Longitude/latitude
defined 723

Longitude/latitude coordinates
extracing from geocoded tables 156–159

Longitude/Latitude projection 549
Lotus 1-2-3 files

opening in MapInfo 45–46
working with spreadsheets 468

LTrim$ function
in expressions 626

M
Main toolbar

defined 723
description of buttons 52–54

Manual geocoding 144
Map coordinates

registering raster images 388–391
Map distortion

projections 548–549
Map files

table structure 42–43
Map layers

adding 113–114
adding and removing 119
clipping a map 115
cosmetic 124–125
display options 119–122
displaying lines, nodes, and centroids 122
editable 122–124
grid theme layers 229
labeling objects 125
Layer Control command 117–124
map structure 46–47, 112–113
projections 552–554
raster images 131
reordering 118
seamless 126–131
selectable 122–124
thematic 131, 214–215
visibility 118
zoom layering 121–122

Map menu 66
Map object types 50
Map scale

calculating 449–451
creating a scale bar 450–451
defined 723
StatusBar 8
apInfo Professional User�s Guide 745
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Map segment
defined 723

Map windows
creating duplicates 114
defined 724
displaying a table as a map 47
embedding 284, 288–291
MapInfo Map Object 285
preferences 96–100
printing 76
setting up in a layout 439–442
specifying resize behavior 97

Map Wizard
launching 56

MapBasic language
defined 723

MapBasic programs
default open and save directories 104
default search paths 65, 104

MapBasic tools
Autolabeler 311, 441
Concentric Ring Buffer 433–434
Coordinate Extractor 160
DBMS Catalog 505
DBMS Count Rows in Table 526–527
DBMS SQL Builder 524, 529–531
Degree Converter 151–153, 392
Disperse Points 153–154
EasyLoader 502–505
Grid Tools 230–231
HTML Image Map 305–306
Labeler 321–323, 441
Legend manager 258
RotateLabel 442
Scalebar 450–451
Set Minimum Bounding Rectangle 507
Tool Manager 87–90

MapBasic window
accessing 538–539
default MapBasic projection 96–97

MapInfo 3.0 symbols
MIF file syntax 702

MapInfo Data Interchange format 683–705

MapInfo for DOS tables
creating points 147–148

MapInfo GIS Extension cartridge 497
MapInfo Map Object

embedding into applications 289–291
features 285–287
menu commands

 291–295
OLE embedding capability 284–285
printing 296
saving 296
sharing documents 297
system requirements 287
using containers 288–289
vs. Microsoft Data Map object 297–298

MapInfo MapX Mobile
displaying maps in handheld devices 37–38

MapInfo ODBC connectivity
installing drivers 498–499
ODBC Administrator 643
redistributed drivers 642
supported data types 641

MapInfo Professional
customer service 6
documentation set 5–7
improving performance 28
new features 32–39
program maintenance 20
removing from your system 20, 26
starting 26

MapInfo Professional Reference
installing 24

MapInfo tables
saving as Microsoft Access tables 475–477

MapInfo Test Drive Center 13
MAPINFO_MAPCATALOG

Oracle datasources 645
MapInfo_MapCatalog

creating automatically 505
creating manually 506
miodbcat.mbx 505
spatial index types 507
updating data bounds 507

MapInfo-L
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M
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M

M
M

M

M

M

M

M
M

M
M

M

APINFOW.PRJ file
custom datums 680
datum ID numbers 657–665
editing 668–670
extracting coordinates from a table 88, 160
projection ID numbers 655–656
projections 558–559
specifying bounds 559
unit ID numbers 665

APINFOW.WOR
saving and loading 101–102
workspaces 86

apping a table
New Map Window command 66

apping wizard tool 89
aps

creating 113–117
See alsoThematic maps

argins in a layout 453–454
arquee Select tool button

using 172
athematical operators 178, 604
aximum function

in expressions 627
ercator projection 551
erging

See Combining objects
eridian

defined 724
etadata

legend attributes 335–338
linked tables 514
saving HotLink options 304

etaData Browser 56
installing 24

icrosoft Access tables
creating 471–474
limitations with MapInfo 478
opening in MapInfo 470–471
requirements for opening in MapInfo 469–470
saving 475
saving as another Access table 478
saving as MapInfo tables 478

icrosoft Data Map 297–298
icrosoft Excel files

opening in MapInfo 45–46
icrosoft Intellimouse 8–9
icrosoft Windows

MapInfo compatibility 3
ID file 705

Mid$ function
in expressions 627

MIF files
brush styles 701
data section 693–696
file header 684–693
font styles 704
importing 555
MID file 705
pen styles 699–700
symbols styles 702–704

Military Grid Reference System format
display coordinates in 99

Minimum bounding rectangle (MBR)
defined 724

Minimum function
in expressions 627

Miodbcat.mbx
creating a MapInfo_MapCatalog 505

MODE.INI file
specifying application data file location 29–30

Modifying table structure 479
Month function

in expressions 628
Moving selected objects

Selections
moving selected objects 171

MrSID files
raster format 384

MrSID raster handler
direct installation of 34

MS Access datasources
setting up 644

Multipoint objects
combining 416
creating 413–414
Erase and Erase Outside commands 33, 407
legend styles 336

N
NAD 83 datum 682
Native projections

defined 552–554, 724
Natural break

ranged map type 220
Network installation 25–26
New features 32–39
New Map Window command 66
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New Row command
adding rows to a browser window 68–69

NITF format files
raster format 385

Nodes
defined 724
deleting 353, 361–363
displaying 122
maximum number of 361
moving duplicates 364
overlaying 400–401
Reshape mode 361–363
selecting multiple 362–363

Non-earth maps
defined 550–551, 724

North Arrow tool
creating a North arrow 56, 89

North arrow tool
adding a North arrow to layouts 455–457

NTF files
raster format 385

Numeric clauses
expressions 611

Numerical comparison operators 605

O
Object Attributes dialog 360–361
ObjectLen function

in expressions 628–629
Objects, drawing 353–356
Objects, editing

aligning in a layout window 445–447
attributes 360–361
changing styles 354
checking region data 421–422
cleaning 423–424
converting to regions and polylines 365
default styles 109
Enclose command 418–420
erasing 400–401
moving arc endpoints 362
positioning and sizing 359
reshaping 361–363
smoothing/unsmoothing lines 365
snap to nodes 363–365
snap tolerances 425–428
thinning 425–428
tracing existing objects 364–365

Objects, querying
type of object via MapBasic 541

Oblique azimuth 666
Ocean table

using with projections 558
ODBC Administrator

datasources 643
ODBC connectivity

data types supported 641
redistributed drivers 642
supported data types 641

ODBC drivers
adding 22
installing 498–499

ODBC tables
defined 724
ODBC drivers 724

Offsetting points
street level geocoding 138

OLE embedding
MapInfo Map Object 285–295
maps into applications 289–291
Microsoft Data Map 297–298
OLE terms 284
printing 296
resizing and repositioning a map window 295
saving 296
sharing documents 297
using containers 288–289

Online Help 6
Online reference guides

Adobe Acrobat Reader 24
Crystal Reports 24
installing 24

Online tutorial 7
Opening

DBMS tables 515–522
georeferenced raster images 386–387
MapInfo tables 64–65
Microsoft Access tables 470–471
raster images 45–46, 385–388
workspaces 84
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O

O

O

P
P

P

P
P

P

P

perators
comparison 605–607
creating expressions 604–615
expressions 178
geographic 607–609
logical 609–611
mathematical 604
precedence 614–615
string 604

racle datasources
setting up 644–645

racle Spatial
support 496–497
uploading tables 502–505

racle8i
converting objects 645–646
supported data types 647–648
using tables 648

rder by clause 195
rdering overlapping objects

in a layout 449
using layers 119

rdering thematic layers 214
rganizing data. See Selections
uter joins

defined 725
in SQL Select 200–201

utput settings
preferences 105–107

verlay nodes
set target editing model 400–401, 408

verriding styles
raster images 396

P
acking a table 320, 482, 725
age layout

creating 442–447
page numbers 453–454

age setup
layouts 453–454, 458
preparing to print 76

aper units 95
arameters

projections 654–667
CX files

raster format 384
en styles

MIF file syntax 699–700

Per row styles 513
Perimeter function

in expressions 629–630
Per-user installs 17

application data (appdata) files 597–600
Photoshop 3.0 files

raster format 384
Pie chart maps

defined 246–247, 725
Pie graphs

exploded pie slices 273–274
templates 264

Pin maps
defined 725

Pixels
defined 725

Places Bar
accessing folders 65

Placing graphics information in visible columns 
489–490

PNG files
file export format 81
raster format 384

Point objects
defined 725
Erase and Erase Outside commands 33, 407
map object type 50

Point size
defined 725

Pointer
defined 725

Points
dispersing 153–155
position on street 138–139

Points, creating
Degree Converter tool 151–153
Excel or Lotus tables 148–149
for intersections 155–156
MapInfo for DOS tables 147–148
specifying a coordinate system 555
using a projection 150–151
using longitude/latitude coordinates 149–150

Polyconic projection 667
Polygon objects

Convex Hull command 434–435
creating search polygons 174
creating Voronoi polygons 412–413
defined 726
drawing 355
drawing tool button 350
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Polygon overlay
defined 726

Polygon Select tool button
using 173

Polygons
closure when digitizing 573

Polyline objects
converting to 365
defined 726
drawing 355
drawing tool button 351
Enclose command 418–420
node limits 361
smoothing/unsmoothing 365
splitting objects with 406

Portable Network Graphics Format files
file export format 81
raster format 384

Positioning objects 359
Preferences

address matching 103
directory 64–65, 84, 103–104, 188
graph support files location 280
legend window 100–101, 334
Map window 96–100
output settings 105–107
overview 91–93
printer 108–109
startup 64, 101–103, 188
styles 109
system settings 94–95

Previous View command (Layout menu) 448
Printer information

preferences 108–109
storing in workspaces 87, 102

Printing
advanced options 77
display and color options 78
documents with embedded objects 296
layouts 458–460
Map windows 76
output methods 77
overriding default printer 78–79
page setup 76
setting defaults 106

Prism maps 237–240

Projections
choosing 551–552, 555–556
choosing default 96–97
conformal 551
converting back to native 552–554
coordinate systems 549
creating points in 150–151
datums 657–665
defined 548–549, 653, 726
digitizing 564
displaying a map 548–549
displaying a map with a different projection 

552–554
earth maps 550–551
extracting coordinates from geocoded tables 

159
frequently asked questions 672–673
grid tables 558
Lambert 551
map distortion 548–549
map layers 552–554
MAPINFOW.PRJ file 558–559
MAPINFOW.PRJ ID numbers 655–656
native 552–554
ocean table 558
origin point 665–666
raster images 388, 396, 554
resources 673–674
saving a map with a different projection 552–

554, 557
setting MapBasic default 96–97
units 665

Proper$ function
in expressions 630

Proportion average function
using Update Column 491–492

Proportion sum function
using Update Column 491–492

Proportion weighted average function
using Update Column 492

PSD files
file export format 81
raster format 384

Puck
digitizing 562

Pushpin maps
defined 725
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Q

Q

Q

Q

R

R

R
R

R

R
R

Q
uantile

ranged map type 220
ueries

DBMS tables 528–529
saving in workspaces 102
using DBMS SQL Builder on remote tables 

529–531
See also Selecting by querying

uery tables
closing 74–75
creating templates 188
default open and save directories 104
defined 182, 726
saving 167, 187

uick Start dialog
disabling 64
display preference 102

R
adius (buffer)

calculating 430–431
adius Select tool button

using 171–172
andom point dispersion 153–154
ange

projections 667
anged maps

bivariate thematic maps 250–252
defined 218–221, 726
styles 220
types 219–220
using 58

aster handlers 34
aster images

adding a logo to a layout 384, 457
as base map layers 383
as stand-alone images 383
bringing images into MapInfo 383
color options 385, 393–396
converting coordinates manually 651
creating with a scanner 382–383
defined 382, 727
digitizing considerations 393
display settings 105

displaying 556
exporting into raster file formats 382–383
file search when opening 388
georegistration 386–387
layers 131
obtaining 382–383
opening 45–46, 385–388
overriding style 396
projections 393, 396, 554
registering 388–391
registration error values 392
ROP display method 78, 106
storage 397
supported file formats 384
translucent images 395, 397
World files  387
zoom layering 396

Raster layers
zoom layering 99

Raster tables
data limitations 396

Read-only tables
making editable 352–353

Reassigning existing districts 377–378
Records

defined 727
Rectangle objects

drawing tool button 351
Redistricting

aggregating data 375–377
Assign Selected Object button 376
closing a redistricting session 380
creating new districts 375–377
defined 727
districts browser 372, 379–380
grouping map objects 372
individual values maps 372, 377–378
procedure 375
reassigning existing districts 377–378
records with no graphic objects 380
saving new districts 380
target districts 374
thematic layers 380

Refining boundaries 141–143
Region objects

converting to 365
defined 727
Enclose command 418–420
map object type 50
node limits 361
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Registering a raster image
control points 388–391
converting d/m/s coordinates to decimal 

degrees 392
Geospot images 635–639
map coordinates 388–391
projections 388, 554
registration definition 727
registration error values 392
SPOT images 635–639

Registry keys
ODBC connectivity 643

Registry settings
specifying for MI Pro 27–28

Relief shading
grid surface maps 228

Remote databases
configuring data sources 499–501
conflict resolution 532–535
creating live access 522–524
disconnecting from 536
linked tables 514
per row styles 513
prerequisites for access 496
refreshing linked tables 535
storing and retrieving spatial data 501–511
unlinking a table 536

Remote tables
creating a primary index 524–525
default open and save directories 104
making mappable 507–511
using DBMS SQL Builder 529–531

Removing
cosmetic objects 125
graphic objects from tables 162–163
labels 319
MapInfo Professional from your system 20, 26

Renaming
streets 368
tables 480
tables in workspaces 85
using a column alias 189

Reordering layers 118
Reports

creating with Crystal Reports 69, 481

Reshape mode
Add Node button 351
creating territories 361–363
moving arc endpoints 362
moving duplicate nodes 97
Reshape button 351
selecting multiple nodes 362–363

Resolution
specifying in exported files 79

Result codes 143, 583, 593–596
Right$( ) function

in expressions 630
ROP display method

displaying transparent images 106
raster images 78
transparent images 397

RotateLabel tool 442
Rotating objects 360
Rotating selected objects 171
Round function

in expressions 631
Rounded Rectangle objects

drawing tool button 351
Row ID

record number 203–204
Rows in a table

adding to a browser window 68–69
appending to a table 481
database structure 464–465

RTrim$ function
in expressions 632

Ruler window
using with drawing tools 353

S
S key

snap mode 363
Save Copy As command 479–480

converting a map back to its native projection 
552–554

saving a copy of a table 479–480
saving a map with a different projection 557
saving selections 167

Save Cosmetic Objects command
saving Cosmetic layer contents 125
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S

S

ave Window As command
advanced options 81
exporting files 79–81
exporting layouts to image files 460–461
file formats 81

aving
cosmetic objects 125
DBMS tables 532–535
graph templates 280–281
graphs 279
labels 320
labels as text objects 321
MapInfo Map Object 296
MAPINFOW.WOR 101–102
Microsoft Access tables 475
new districts 380
queries 102, 187
query templates 188
selections 167
thematic maps 258
thematic templates 258–259
to a file 79–81
workspaces 83

cale bar
defined 727

cale factor
Transverse Mercator projection 666

cale of a map
calculating 449–451
creating a scale bar 450–451

calebar tool 450–451
canned images

compared to digitized maps 562
raster 382–383

canning
defined 728

catter graphs
template 264

croll bars
defined 728
displaying 98

eamless map layers
available features 127
creating 130
opening 126–127
specifying search paths 130
turning on and off 130
using 128–129

eamless tables
TOC utility 38, 90

Search paths
changing in Directories preferences 83

Searching for map objects
with indices 43

Segments per circle in a buffer 431
Select tool button

using 170
Selectable layers

Cosmetic layer 124
Info tool 123
Select tool button 123
selecting objects 122–124, 168–169
statusbar 8

Selecting by querying
aggregating data 193–195
calculating distance to a fixed point 207–208
column aliases 189
computing population density 183–186, 190–

193
computing total population and area 196–198
creating expressions 177–181
defined 166–167
derived columns 189
group by clause 195
highways from a StreetInfo table 205
joining tables 196
objects of specific type 541
order by clause 195
outer joins 200–201
query templates 188
query types 176
records with duplicate values in a column 

205–207
saving queries 187
Select command 71, 168, 176, 179–180
Select command example 180–181
selecting by Row ID 203–204
streets by color via MapBasic 541–542
ungeocoded records 161
using common fields 203
using the InStr function 201–202

Selecting from the screen
browser windows 68–69
creating search polygons 174
inverting selections 72, 174
saving temporary tables 167
Select All command 168
selectable layers 168–169
tool buttons 71, 168, 170–174
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Selections
cancelling 169
creating a new table from 181–182
creating subsets with SQL Select 182–187
defined 182, 728
graphed tables 278
inverting 72, 174
rotating selected objects 171
specifying map highlighting 109
symbol hot spot 170
temporary tables 167
using expressions 177–181
using tool buttons 170–174

Send to Back command 449
Session projection

default MapBasic 96–97
Set Clip Region command 115
Set target, apply action editing model

aggregating/disaggregating data 402
combining objects 403–404
erasing objects 407–408
overlaying nodes 408
procedure 400–401
splitting objects 405–406

Setting styles of objects 354
Shapefiles

default open and save directories 104
opening 469
opening directly 34

Shapes
drawing 353–356

SID files
raster format 384

Sin function
in expressions 632

Sizing objects 359
Smoothing/unsmoothing polylines 365
Snap to nodes

aligning objects 363–365
defined 728
digitizing 573
StatusBar 7–8
tracing existing objects 364–365

Snap tolerance
Map window preferences 99
setting for objects 425–428

Software requirements 16
Space problems

solving with Pack Table 482
Spatial analysis

defined 728
Spatial index columns 505
Spatial index types 507
Spatial objects

read only 522
Spatial queries

bound objects in SpatialWare 524
Spatial Query Server (SQS) databases

controlling object size 650
SpatialWare 4.6

live access limitations 523
SpatialWare databases

controlling object size 650
SpatialWare tables

editing 650
uploading 502–505

Specifying a target district 374
Specifying search paths

seamless layers 130
workspaces 84

Spherical calculation method
setting as default 98

Spherical coordinates
defined 728

Splitting objects
data disaggregation 402
polyline as cutter 406
set target editing model 400–401, 405–406

SPOT satellite image files
raster format 384

SPOT satellite images
registering 635–639

Spreadsheets in MapInfo tables 468
SQL database tables. See DBMS tables
SQL queries

DBMS tables 528–529
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S

S
S

S

S

QL Select command
aggregating data 193–195
calculating distance to a fixed point 207–208
column aliases 189
computing population density 183–186, 190–

193
computing total population and area 196–198
derived columns 189
finding records with duplicate values in a 

column 205–207
group by clause 195
joining tables 196
order by clause 195
outer joins 200–201
overview 176, 182–183
query templates 188
saving queries 187
selecting by Row ID 203–204
selecting highways from a StreetInfo table 205
SQL Query defined 728
using common fields 203
using the InStr function 201–202

tandard deviation
defined 729
ranged maps 220

tandard parallels
conic projections 666

tandard toolbar
description of buttons 51

tarting MapInfo
Quick Start dialog 64
STARTUP.WOR 86

tarting MapInfo Professional
procedure 26

tartup preferences 101–103
Quick Start dialog 64
saving queries in workspaces 188

tatistics window
defined 729

tatusBar
defined 729
displayed information 7–8
help 7–8

torage limitations with raster tables 397
tr$ function

in expressions 632
treet addresses

geocoding by 135
treet inset

position of geocoded points 139

Street intersections
creating points 155–156

Street maps, editing 366–369
String clauses

expressions 612
String comparison operators 606
String operator 604
Structured Query Language (SQL)

defined 729
Style Override option

raster and grid images 396
Styles

collection objects 417
custom symbols 358
labels 317
legend 336
multipoint objects 416
of objects 354
per row styles 513
preferences 109
raster images 393–396
symbol 145

Subselect
defined 729

Subtitles
legend frames 334

Surface graphs
templates 264

Symbol objects
custom 357–358
defined 729
drawing 356–358
drawing tool button 351
graduated symbol maps 241
points 50
pre-version 4.0 95
selection hot spot 170
supported fonts 357

Symbol styles
changing in DBMS tables 514
changing in geocoded points 145
MIF file syntax 702–704

System requirements
for Oracle Spatial 496
installation 16
MapInfo Map Object 287

System settings
preferences 94–95
Windows registry 27–28

Systematic point dispersion 153–154
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T
TAB files

registering a raster image 387
table structure 42–43

Table rows
defined 730

Tables
defined 730

Tables, closing 74–75
Tables, creating

choosing a projection 555
procedure 466–468
using a subset of a file 181–187
working with spreadsheets 468

Tables, displaying
browser windows 48, 68–69
graph windows 48
hot views 49
map layers 46–47
New Graph Window command 69–70
New Map Window command 66, 145
viewing data 47–49
viewing table structure 479

Tables, managing
copying 480
deleting 482
exporting 719
file structure 42–43
importing 555, 721
indices 43, 464–465
packing 320, 482
renaming 85, 480
updating 485

Tables, modifying
adding data to a table 483–490
aggregating data 490–493
appending rows 481
converting coordinates to lines in MapBasic 

539–540
displaying coordinates in a table 489–490
joining 58, 196, 200–201, 213
parsing data from one column to another 486–

488
structure 479

Tables, opening
georeferenced raster 386–387
in workspaces 104
Microsoft Access tables 470–471
procedure 43–44, 64–65
raster images 385–388
specifying default directories 104
specifying search paths 64–65

Tables, saving
Microsoft Access tables 475
options with Save Copy As command 479–

480
saving changes 74–75

Tablet
digitizing 562, 572–573

Tagged Image File Format files
file export format 81
raster format 384

Targa files
raster format 384

Target districts
defined 730
specifying 374

Target objects
specifying highlighting 109

Technical Support
automated fax support 14
MapInfo Test Drive Center 13
services 10–13
Tech Tip Archive 9

Temp variable
installation 26

Templates
creating for layouts 458
merging thematic 255
query 188
saving thematic 258–259

Temporary columns
adding to a table 483–484
saving 483–484
See also Update Column command

Temporary tables
selections 71–72
See also Query tables

Territories
creating 409–412
See also Redistricting
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T

T

T

T

T

T

T
T

ext objects
drawing 358–359
drawing tool button 351
map object type 50
text cursor 730
with labels 311, 321–323, 441

GA files
raster format 384

hematic maps
3DMaps 232–237
bar chart maps 244–245
bivariate thematic maps 250–252
cartographic legends 255–256
choosing projections 551–552
defined 209, 730
dot density maps 242–244
expressions with 212
graduated symbol maps 241–242
grid surface maps 221–237
individual values maps 216–217, 372, 377–378
inflection point 253–254
joining tables 247–249
joining tables in 213
layers 131, 214–215, 730
obtaining data 212
pie chart maps 246–247
planning 212–213
Prism maps 237–240
ranged maps 218–221
saving 258
shading 731
theme legends 257–258
Update Column with 213, 247–249
variables 212, 731

hematic templates
default open and save directories 104

heme legends
controlling display 257–258
defined 731
modifying 338–341, 344
selecting attributes 337

heme templates
individual values categories 259
merging templates 255
saving 258–259

hinning objects 425–428
IF files

file export format 81
raster format 384

TIFF CMYK files
file export format 81

Titles
graph 270–271
legend frames 334

TOC utility 90
seamless tables 38

Tool Manager 87–90
Toolbars

defined 731
description of buttons 51–57
displaying or hiding 51
docking 51
reshaping 51

Tools toolbar 56
Tracing existing objects

digitizing 570
snap mode 364–365

Transformation
defined 731

Translucent colors
printing/exporting images 397
raster images 395

Translucent images
grid surface maps 229

Transparent colors
raster images 395

Transparent images
ROP display method 106, 397

Transverse Mercator projection
scale factor 666

Triangulated Irregular Network (TIN) 
interpolator

grid surface maps 225–226
TrueType font symbols

MIF file syntax 703
Tutorial, accessing 7

U
UCase$ function

in expressions 632
Undo command 95
Ungeocode

defined 731
removing graphic objects from a table 162–

163
Ungeocoded points

selecting 161
Uninstalling MapInfo Professional 20, 26
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Units
MAPINFOW.PRJ ID numbers 665

Universal Translator 38
Unregistered raster images

opening 386
Unselecting objects and records 169
Unsmooth command 365
Update Column command

adding temporary columns 483–484
aggregating data 490–493
displaying coordinates in a table 489–490
parsing data from one column to another 486–

488
placing graphics information in visible 

columns 489–490
updating a table 485
with thematic mapping 213, 247–249

Uploading
MapInfo tables to Oracle Spatial 502–505
MapInfo tables to SpatialWare 502–505

V
Val function

in expressions 633
Vector images

defined 382, 732
digitizing 561

Vertical Mapper grid handler 223–224
View Actual Size command (Layout menu) 448
View Entire Layout command (Layout menu) 448
Viewing data 47–49, 73–74
Virtual Tablet Interface

digitizing 562–563
Voronoi polygons 412–413

W
Warning messages

controlling display 97
Weekday function

in expressions 633

Weighted averages
defined 732

Where condition 198–199
Wildcard characters

like operator 179
Wildcards

like operator 521
Windows

closing 74–75
combining for output 49, 75, 438
defined 732
opening 66
types 47–49

Windows 2000
accessing MI Pro-specific folders 65
EasyLoader 502
system requirements 16

Windows 95/98
system requirements 16

Windows 98
EasyLoader 502

Windows bitmaps
file export format 81
raster format 384

Windows Enhanced Metafiles
file export format 81

Windows metafiles
file export format 81
raster format 384

Windows NT
EasyLoader 502

Windows NT 4.0
system requirements 16

Windows registry
modifying 27–28

Windows XP
EasyLoader 502
system requirements 16

WMF files
file export format 81
raster format 384
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W

W

X

orkspaces
cosmetic objects 125
default open and save directories 104
default search paths 65
defined 732
digitizer mode 566
items saved 83
labels 320
MAPINFOW.WOR 86
opening 84
packing a table 320, 482
preserving your setup 82–83
renaming tables 85
saving 83
saving graphs 279
saving queries 102
saving queries in 188
saving style changes in a redistricting session 

379–380
specifying search paths 84
storing printer information 87, 102
table search paths 104
thematic maps 258

orld files
raster images  387

X
 and Y coordinates

assigning to records 134–135
extracting from geocoded tables 156–160

Y
Y2K support

handling 2-digit years 95
Year function

in expressions 634

Z
ZipInfo

geocoding by 135
Zoom layering

defined 732
grid layers 229
labeling 314
map layers 121–122
raster and grid layers 99
raster layers 396

Zoom levels
cosmetic objects 124
digitizing 573
displaying layout windows 448
setting map default via MapBasic 545
StatusBar 7–8
with Microsoft Intellimouse 9

ZSoft Paintbrush files
raster format 384
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