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(hapter One

terms used in this book.) Notice that | just used the word Net and not Internet. For the
most part, the words are synonymous, although some people will use the word Net
to refer to just about any aspect of the global inter-networking of computers.

What Is the Internet?

In this chapter, there are no dumb questions. Everybody talks about the Internet
these days but most people don't really know what it is. One reason for this is that the
Internet looks different depending on how you come across it and what you do with
it. Another reason is that everyone talks about it as if it's actually a network, like a local
network in someone’s office or even a large global network like CompuServe. Fact is,
it's something different. A beast unto itself. The Internet is really a way for computers
to communicate.

As long as a computer or smaller network can “speak” the Internet lingo (or proto-
cols, to be extra formal about it) to other machines, then it's “on the Internet” If the
Internet were a language, it wouldn't be French or Farsi or Tagalog or even English. It
would be Esperanto.

Having said that, | might backtrack and allow that there's nothing wrong with think-
ing of the Internet as if it is a single network unto itself. It certainly behaves like one in
a lot of important ways. But this can be misleading. No one “owns” the Internet. No
one even really runs it. And no one can turn it off.

£-mail and a Whole Lot More

The Internet is also a collection of different ways to communicate or store informa-
tion in a retrievable form. Take e-mail, for example. If you work in an office with a local-
area network, then chances are you have an e-mail account and can communicate
with people in your office by sending them messages. (See Chapters 2 and 3 for an in-
depth discussion of all the ins and outs of e-mail.) This is not the Internet. Likewise, if
you have an account at America Online and you send a message to someone else at
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Just Enough to Get Started

AOL, you're still not using the Internet But, if your office network has a gateway 10 the
Internet, and you send e-mail to someone who does not work at your office, then
you're sending mail over the Internet.

Likewise, if you send a message from your AOL account to someone at
CompuServe, or elsewhere, then, again, you are sending messages over the Intermnet
(see Figure 1.1).

V«‘eﬂca Onli[;e

Internal
AOL
E-mail

FIGURE LI1:

The Internet carries
e-mail from one
network to another.

Internal
Office
»  E-mail

But, from your point of view, the Intermnet is not just a collection of networks all talk-
ing to each other. A single computer can also participate in the Internet by connecting
to a network or service provider that's connected to the Internet. And while the local
office network | described and the big commercial online services are not themselves
the Internet, they can and often do provide access through their gateways to the
Internet. (I cover online services later in this chapter, in the section called Accessing
the Net at Home.)

This can be confusing to first-time Internet users (universally referred to as

newbies). Say you have an AOL agﬁgﬁ@%ﬁ%%]ﬂg NS rf ;h_e éj)/.(scz_isgi‘,og, rc;tép: 5




(hapter One

(bulletin boards) there. It may not be obvious to you right away whether you're talk-
ing in an internal venue, one only accessible to AOL members, or in a public Internet
newsgroup. One of the benefits of an online service is the seamlessness that makes
everything within your grasp appear to be part of the same little program running on
your computer.

The Web Is Not the Net, or Is It?

Nowadays, most of the hype about the Internet is focused on the World Wide Web.
It's existed for under ten years now but it's been the fastest growing and most popu-
lar part of the Net for many of those years (except, perhaps, for the voluminous flow
of e-mail around the globe). But what is the Web (also called WWW or w3) and is it
the same thing as the Internet? Well, to answer the second question first: yes and no.
Technically, the Web is just part of the Internet—or, more properly, a way of getting
around part of the Internet. But it's a big part, because a lot of the Internet that's not
strictly speaking part of the Web can still be reached through it.

So the Web, on one level, is an interface. A window onto the Net. A way of getting
to where you're going. lts appeal derives from three different benefits:

1. It disguises the gobbledygook that passes for Intemnet addresses and
commands. (See A Few Words about Internet Addresses at the end of
this chapter.)

2. Itwraps up most of the different features of the Internet into a single

interface.

3. ltallows you to see pictures, and even hear sounds or watch movies (if

your computer can hack it), along with your helpings of text.
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Just Enough to Get Startem

It helps to know a little bit about the history of the Net to understand why these
three features of the Web have spurred on the Internet boom. First of all, before the
Web, to do anything beyond simple e-mail (and even that could be difficult, depend-
ing on your type of access) used to require knowing weird Unix commands and
understanding the Internet's system for numbering and naming all the computers
connected to it. If you've ever wrestled with DOS and lost, then you can appreciate
the effort required to surmount this type of barrier.

Imagine it's 1991 and you've gotten yourself an Internet account, solved the prob-
lems of logging in with a communications program to a Unix computer somewhere
out there, and mastered the Unix programs needed to send and receive mail, read
newsgroups, download files, and so on. You'd still be looking at lots of screenfuls of
plain text, reams and reams of words. No pictures. Well, if you were dying for pictures
you could download enormous text files that had begun their lives as pictures and
then were encoded as plain text so they could be squeezed through the text-only
pipelines that constituted the Net. Next you'd have to decode the files, download
them onto your PC or Mac, and then run some special program 1o look at them. Not
quite as easy as flipping through a magazine.

The Web uses a method called hypertext to disguise the actual commands and
addresses you use to navigate the Net. Instead of these commands and addresses,
what you see in your Web browser (the program you use 1o travel the Web) is plain
English key words highlighted in some way. Simply select or click on the key words,
and your browser program talks the Internet talk, negotiates the transaction with the
computer at the other end, and brings the picture, text, program, or activity you desire
onto your computer screen. This is how all computer functions should work (and
probably how they will work one day).
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Early, Unix-based Web browsers such as Www (developed at CERN, the European
particle physics laboratory where the Web was invented) and Lynx (developed at the
University of Kansas) were not especially attractive to look at, but they did offer the
“one-step” technique for jumping to a specific location on the Net or downloading a
file or piece of software. Figure 1.2 shows Lynx, running on a Unix machine in a termi-
nal window and connected to a PC by a modem.

Metcom - HyperTerminal

Enterzone {pl of 2}

ENTERZONE EPISODE S

hyper weh text zine media art
cken’ Wire Mother

INSIDE THIS MMHMIVER ¢ EPISODE
¥ 0000, Roadkill .o00o. T bw s © isey (o000, The Wro

Jobn (correction) .o00s. Coping with Not Being Bast of the Hat
-o00c. Enterzone's new thems sound {in . wavr and ¥ formats)

TABELES OF CONTENTS

next page --
Arrow keys: Up and Dowm to move. Right te follow a link; Left to ¥o back.
Hielp O)ptions Plrint Glo Miain scresn Quit /=search [delste]l=history list

FIGURE 1.2: In Lynx, you can press Tab to get to and highlight a link, and then press Enter to execute
the link and follow it to a file or another part of the Internet.
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Just Enough to Get Started

The next advance on the Web was the development of graphical Web browsers that
could run on a desktop PC or Macintosh, permitting the user to employ the familiar
point-and-click techniques available for other programs on the computer and incorpo-
rating text formatting and graphics into the browser screen. The first program of this
type was NCSA Mosaic, which was developed at the National Center for Supercomputer
Applications and distributed for free (see Figure 1.3).

Born ; June 3, 1926

Place of Birth : Newarly, New Jersey

{Now that you've entered the Allen Ginskerg zone af influence, I suggest you leave by

linking to the recitation of Blake at the end of this page. I dor't know why. But this poem is

oflen sung during Ginsberg’s postry readings.)

Louis Cinsberg was a published post, a high school teacher and a moderate Jewish Socialist. His

wife, Maomi, was a radical Communist and irrepressible madist who went tragically insane in early

adulthond. Somewhere between the two in temperarent was the Cinsherg's second son, Irwm

Adler.

A shy and complicated child growing up in F

by his raother's bizarre and frightening episade

when she was convinced the rest of the family and the world was
- : e o

nn, Wew Jersey, sllen's home fife was dominated
&.‘scvere parancid, she often trusted young Allen
plotting against her. As the

FIGURE 1.3: Mosaic made it possible to point to a link and click on it, making the Internet
much more accessible to non-technical users. It also pioneered the use of
in-line graphics (meaning illustrations mixed in with text).

Furthermore, the various Web browsers can more or less substitute for a plethora of
little specialty programs (such as Gopher clients, newsreaders, FTP programs, and so
on) that you had to assemble and set up yourself “in the old days” The browsers all
have their own little idiosyncrasies, but they're still remarkably uniform and consistent
compared to the zoo of different programs and rules you had to follow just a few years
ago. These days, the most popular browser is Netscape Navigator (see Figure 1.4).

Bright House Networks - Ex. 1028, Page 9



Netscape - [Welcome to Netscape]

LATEST NEWS: GOLD RELEASED

NAVIGATOR GOLD SHIPS
Windows 95 and NT users can now download the shupping version of
Netscape Mawmgator Gold. Lear how to upgrade f vou own Navigator.
Once you've downloaded i, enter our expanded Gold Rush contest to win cash and prizes
e listed in a special contest directory provided by Yahoo,

and get your home

FIGURE 1.4: Netscape Navigator is hands-down the most popular World Wide Web browser program.
It works very much the way Mosaic does but with a number of additional features and

improvements.

The Web has made it possible for browsers to display pictures right there in the
midst of text, without you having to know how to decode files. A picture's worth a°
thousand watchamacallits, and pictures look better in newspaper articles and on TV
than scads of typewritten text. So this ability was the final ingredient that made the
Web seem so accessible and interesting to people who'd never in a million years care
to learn what a Unix “regular expression” is.

So, | haven't really answered the question that heads up this section: Is the Web
the Internet? Technically it's not exactly the same thing, but for all intents and pur-
poses, it is. And Web browsers are the must-have programs that have made the
Internet what it is today.
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BROWSING THE W

o Understanding the World Wide Web

« Understanding (and then forgetting) Web
addresses

« Understanding the different types of Web
browsers

o Using Web browsers

« Browsing the Web with America Online,
CompuServe, Lynx, MS Internet Explorer,
Mosaic, NetCruiser, and Netscape
Navigator

One of the newest media available over the Intemet is the World Wide Web. The
Web (or sometimes WWW, w3, or W3) is a huge collection of interconnected
hypertext documents. (See What Is Hypertext? to learn more about hypertext.)
Hypertext documents can contain links to other documents, to other kinds of
files entirely, and to other sites on the Internet. With a Web browser, you can
jump from one link to the next, following the trail of links in any direction that
interests you. Not everything on the Internet is available via the Web, but more

and more of it is linked together.
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Chapter Four

What Is Hypertext7 ‘

ple have created so the medlum is not yet quy rnte‘ra‘ i
always make your own \Neb page—see Chapter 127

always turn around

The beauty of the Web is that the browser programs with whrch you read” the
Web are incredibly easy to use. This gives you access to all kinds of data, programs,
news, pictures, and so on, without having to master the syntax of difficult protocols
and arcane Unix commands.

Throughout the rest of this book, there will be references to the Web. It has
become such a ubiquitous front end (a way to connect to the Net), that much of your
use of the Net will take place through a Web browser.
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Browsing the Webn

Web Addresses (URLs)

If you've ever noticed an advertisement that says "check out our web site," you've
seen the arcane way they describe how to find i, giving you the address, or URL, which
almost always begins with the letters http: - (URL stands for Uniform Resource
Locator.) A Web address starts with the name of a protocol (a method for connecting to
information); most of the time it is HTTP. HTTP stands for Hypertext Transfer Protocol
and means that the resource in question will be found on a Web server. This protocol is
followed by /7 (the oft-heard “colon-slash-slash,” or even more cumbersome,
1colon—forward-slash—forward-slash”), and then an Internet address of the form
site.subdomain.domain, as explained in A Few Words about Internet
Addresses in Chapter 1. After that, you might find a colon and a port number (this is
fairly rare), a path which is a list of folders or directory names leading to the resource in
question, separated by more forward slashes. After the path, you might find a file name,
which often ends with the extension -htm1. An HTML file (which means Hypertext
Markup Language file) is the primary type of document on the Web.

Fortunately, most of the time, you won't have to type in Web addresses yourself,
since you'll be following links that have the URL encoded into them.

Different Types of Web Browsers

Most online services are now offering access to the World Wide Web. Some do it by
launching an external browser program (usually some variety of Mosaic) alongside the
main access program. Others have their browser built-in, as with any other module
available within the access program. Netcom's NetCruiser has a built-in Web
module, but it also enables external Web browsers to run alongside NetCruiser, piggy-
backing on the Internet connection provided by the Netcom software. (Similarly, some
online services, such as CompuServe and Microsoft Network enable you to do the
same with external Web browsers).

Direct-access 1SPs usually enable you to run whichever Web browser you like over
the dial-up connection (and most people opt for Netscape Navigator), but Unix shell-
only accounts require that you run a character-based Unix browser, such as Lynx or
the original browser, Www. They won't be able to show you pictures and won't allow
you to click your mouse to select links, but they can take you anywhere you want to
go, and you can always download binary files that the character-based browsers aren't
able to display.
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Browsing the Web I:l

Using Web Browsers

Generally, when you start a browser, you begin at a home page, a starting place you
designate (or your browser designates) for your Web-crawling sessions. (Hypertext
documents on the Web are commonly referred to as pages.) This will either be the
default home page for your browser or a custom home page that you have created.
You can also start some browsers by pointing them directly at a Web address. Some
e-mail programs, such as Eudora, now allow you to double-click a URL in an e-mail
message to automatically start up your most recently installed browser and bring up

the selected Web page.

Figure 4.1 shows the Netscape home page that comes up automatically when you
start Netscape Navigator (until or unless you change it to start at a different page).
Now that you're connected, you can

« Follow the links that interest you. At any point you can retrace your steps so
far or bring up a complete history of where you've been this session and
then jump immediately back to one of those pages.

e Go 1o a specific Web address (URL) when you start your browser. Generally,
to stop it from loading the default home page, you press the Stop button and
enter an address directly.

e Insert bookmarks that enable you to jurnp back to an interest
having to retrace your steps or bring up a history of where you've been.

e Save (download) or mail interesting documents and files.

e View the hidden URL (Web address) that a given link points to.

e Customize your program's home page so that you always start at a page with
links that interest you, rather than having to start at a generic home page.

e Access Help through a command or menu to get tips about using the
program and information about the Web itself.
e Find out what's new on the Net.

Read on to discover howéo_d?‘?ll these things ... and more.
right House Networks - Ex. 1028, Page 15
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http: /¢home. netscape. com/nds himi

LATEST NEWS: GOLD RELEASED

NAVIGATOR GOLD SHIPS
Windows 85 and IVT users can now download the shipping version of
Netscape Wavigator Gold, Learn how to upgrade f you own Nawigator.
Once you've downloaded i, enter our expanded Gold Rush contest to win cash and prizes
and get vour home page listed in a special contest directory provided by

FIGURE 4.1: Unless customized, Netscape Navigator starts you off at the Netscape home page.

Reading a Page in a Web Browser

Web pages can consist of formatted text and headings, illustrations, background art
and color effects, and hyperlinks, which can be highlighted text or art. In most graphi-
cal browsers, links are shown in blue (unless the creator of the page has decided
otherwise) and are underlined (unless the creator has decided otherwise and
has customized the program).

Often a page won't fit on the screen all at once. Graphical browsers use scroll bars,
just as other programs do, to enable you to see material that doesn't fit on the screen.
If you're hunting for a specific piece of information on a long document page, try
searching for key words, usually with a menu command.
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Browsing the Webm

Following a Link

A OUNGING THE RELEASE OF In graphical browsers, following a link entails positioning
The latust elease contains|  the mouse pointer over the link (the pointer will change to
versionspheck outsuppd ooy o that you're over an active link—in Netscape it

nd) and then clicking once (get out of the habit of double-clicking).

b All browsers have a Back command, often a

shortcut button, for retracing your steps back to

the previous page. Once you've gone back, you
can also go forward, using the Forward com-
mand, to return along your original path to the
furthest point you had gotten to. Also, you can

usually bring up a history list (on a menu, in a

graphical browser; on a separate page, in a text-

| onlybrowser) of all the pages you've been to

since you started the program that session.
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Knowing Where to Go

It's hard to get oriented in the Web, since there’s no real starting point. Your default
home page should provide some pretty useful places to start though. | recommend
surfing around for a while to see where these points lead.

In most browsers, if you have a specific Web address in mind (say one you saw in
an advertisemnent or one that was e-mailed to you), you can type in a URL directly to
visit a Web page without having to follow a trail of links that leads to it

Also at any time, you can retumn to the default home page. Graphical browsers have
a Home button, often decorated with an icon representing a house, for this purpose.

Making a Bookmark

As you travel around the Web, you can save interesting destinations by making
bookmarks (also called Favorites or Favorite Places in some browsers, and ltems on a
Hotlist in others). Once you've made a bookmark, you've created your own personal
shortcut to a favorite destination. You won't have to find your way back to the page in
question next time you want to go there.

Saving or Mailing a Document

If a Web page contains information you want to send to someone or have stored
on your own computer, you can either use your browser's mail command to send the
document to yourself or to someone else, or you can use the save command (File >
Save As in graphical browsers) to save a copy of the document on your hard disk,
much the same way you'd save a file in a word processor.
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Peeking behind the Scenes

If you need to see the URL associated with a specific link, you can do so. For
instance, in most browsers, when you place the pointer over a link, the associated link
appears in the status bar at the bottom of the program. Some browsers enable you to
copy a URL by right-clicking or clicking-and-holding the link to it. You can then paste it
into another document for future reference or paste it into an e-mail message to tell
someone else how to get to the page in question.

If you want to see how a Web page was constructed, you can generally view the
source file underlying a page. In graphical browsers, you do this by selecting View >
Source (or something similar). Figure 4.2 shows the source underlying the Netscape
home page.

FIGURE 4.2: The HTML document that makes the Netscape home page look the way it does. (Don't
letitspookyou)  Bright House Networks - Ex. 1028, Page 19
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(hanging Your Home Page

The commands differ from browser to browser, but most Web browsers allow you
to change your default home page to a different page (or evento a list of your book-
marks) so you can start exploring the Web from any vantage point.

Generally, the way you change you home page is to go into the Options or
Preferences area of your browser and either specify an exact URL or tell the browser
to use the current page as the new home page. Why would you change your page?
Well, you might find a useful page out there on the Net that connects to most of your
favorite sites. Or you might want to make one of the directory or search pages (as dis-
cussed in Chapter 5) into your new starting page.

Web Help and Info

There are a number of helpful resources for the Web, both hypertext and plain text
documents. Try the WWW FAQ, an excellent document. Its URLis http: //www -
boutell.-com/fag/. The W3 Consortium is the official source of information
about the Web, and you can connect to their home page at http://wuw -
w3 - org/. (But be forewarned, much of their information is highly technical!) Many
individual browsers also offer dedicated help files, accessible through a menu com-
mand. I'll cover some specific browsers and their help functions at the end of
this chapter.

org/papé
for the Guide

1 L] '
Keeping Up with What's New
If you want to keep up-to-date on the latest interesting home pages, visit the NCSA
What's New Page (the unofficial newspaper of the Web) at http://www.ncsa-

uiuc.edu/3D (gl’lggcilft oJ‘see/NetSwoﬁ(/ D Oé /1w0 %t %aggw preml. Most



Browsing the Wem

Web browsers have a What's New command or button (and some also have a What's
Cool option as well), leading to some similar compendium of the latest interesting sites.

Surfing the Web with Your
Web Browser

The program you choose to wander around the Web with is largely a matter of
taste, need, and budget. In fact, you may eventually end up with more than one
browser on your hard drive. Il discuss a few of the more common browsers Now.

Browsing the Web with AOL

You can start the AOL browser by going to the Internet Connection area and choos-
ing World Wide Web, by double-clicking on any AOL content that includes the word
Web at the end of its title, or by going to the keyword Web.

Figure 4.3 shows the AOL home page that comes up automatically when you con-
nect to the Web without specifying a particular site.

AOL's browser has no search command for the contents of a Web page. It has Back
and Forward buttons, and you can see a list of sites you've visited in the drop-down
list box directly below the buttons (that's also where you type an address if you want
to go there directly).

Click on the Home button to return to the AOL home page.

You can save interesting Web destinations by adding them to your Favorite Places list,
just as you do with any other AOL resource. Simply dlick on the Heart icon in the upper-
right comer of the window. AOL will ask you to confirm that you want to add the current
page to your favorites. Click on Yes. To go to a favorite place, click on the Favorite Places
button, choose an item in the window that pops up, and click on Connect.

Save a document with File > Save (or Save As); however, there's no way to mail a
document directly from the AOL browser. Also, the AOL browser doesn't allow you to
see the underlying HTML source file for a Web page.

Bright House Networks - Ex. 1028, Page 21
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Fxttp:ilwww bhue aol.com!

YWelcome to America Online's gateway to the World Wide Web! [%

If you've never been here before or need assistance with the Web, take a look at our help area for

anewers to frequently asked questions. Vou might also want to visit the Chat About the Wel chat
room in People Connection.

If you're just passing through and would like to find specific resources on the Web, visit our Explore
area or click the "Search Places” button at the hottom of any page. A text-only overview of our site i3

1 LTI U W =2 | 1

FIGURE 4.3: AOLs browser starts you off at the AOL home page.

To change your home page with AOL's browser, click on the Prefs button. In the dia-

log box that appears, type a new URL in the box at the bottom and then click on OK
(see Figure 4.4).

To get help with AOUs browser, click on the Help button, and to keep up with
what's new, visit the Internet Connection every now and then to see which new Net
resources have been listed there.

Browsing the Web with CompuServe Mosaic

CompuServe offers a licensed version of the original graphical Web browser,
Mosaic. You can start it by selecting Services > CompuServe Mosaic.

Bright House Networks - Ex. 1028, Page 22
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Figure 4.5 shows the CompuServe home page that comes up automatically when
you connect to the Web without specifying a particular site.

In CompuServe, you can search a long Web page, select Edit > Find, type the text
you're looking for, and press Enter. The Search command and its shortcut button on
the toolbar lead to a Web page for searching the Internet. It has Backward and
Forward buttons, and you can bring up a list of the sites you've visited by selecting
Navigate > History. To go somewhere directly, type the URL into the Web Page box at
the top of the window.
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wefcomes you to the

WORLD WIDE WEB

of Services

the bnternet

Home Pag;:
To return to the WinCIM desktop, click on the

in the toel bar above.

To explore the web, click on one of the 1cons above,
or enter a URL in the "Web Page" box above

FIGURE 4.5: CompuServe Mosaic starts you off at the CompuServe home page.

Click on the Home button to return to the CompuServe welcome page.

You can save interesting Web destinations by clicking on the Add button. The page
you add will instantly become a menu item on the Personal Favorites menu. To go to
a Favorite, just select it from that menu.

To save a Web document with CompuServe Mosaic, select View > Load to Disk
Mode to place a checkmark next to this command. Then all of the pages you visit will
be saved on your hard disk (you'll be prompted to confirm each file name). If you just
want to save a single page this way, be sure to uncheck the Load to Disk Mode com-
mand on the View menu when you're done. Unfortunately, you can't mail a docu-
ment directly from CompuServe Mosaic.
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In order to view the HTML source of a Web document, select File > Web
Page Source.

If you want to change your home page with CompuServe Mosaic, select View >
Options and click on the Pages tab in the dialog box that appears. Type a new URL in
the Home Page box and then click on OK. (As you sometimes have to do with AOL,
you may have to go to the page and copy its address from the box at the top of the
window before typing in the address.)

To get help with CompuServe Mosaic, select Help > Help Topics. To keep up with
what's new, go to the Internet topic (GO INTERNET) and then click on the What's
Cool button.

Browsing the Web with Lynx

If your connection to the Internet is through a character-based Unix account, then
the best Web browser for you is Lynx. Lynx is a full-screen program that is very easy to
use. You might also have the Www browser available, which only allows you to type
on the bottom line of the screen—you follow links by typing their number and press-
ing Enter—but you're better off using Lynx if possible.

There are some graphical Web browsers that can run over a Unix shell account con-
nection, most notably SlipKnot, from MicroMind. You can download SlipKnot from
http://plaza-interport.net/slipknot/slipknot-html.See
Chapter 10 for more on downloading. See also Appendix A for other strategies for
coping with a Unix shell account.

You start Lynx by typing fynx at the Unix prompt and pressing Enter. This will start
you off at Lynx's default home page, for your system. On my system, Lynx starts off at
the University of Kansas home page. Figure 4.6 shows the About Lynx page
(http://www.cc-ukans-.edu/about-Lynx/about-Lynx-html).
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If you don't have Lynx installed on your system, Unix will tell you “lynx: Command
not found” You can still run Lynx by "telnetting” to a public-access browser. Type
telnet ukanaix.cc-ukans.edu and press Enter; log inas www (no
password required). See Chapter 10 for more on Telnet.

If you have a specific Web address (URL) in mind, you can also start Lynx by point-
ing it at that URL. Type lynx ur/ and press Enter, substituting the actual URL for url,

of course.

Lynhx is a fully featured WVorld-Wide Web browser for users on both UHNIX
and VNS platcforuns who are cormected to thoss zystems via
cursor-addressable, charactar-cell verminals or emulators. That
includes VTL0D terminals snd desktop-based software packages enulating
VT1l00 terminals (e.g., Kermitc, Procomm, ato. ).

Lynx is used in universities, libraries, freensts, amd many othey
= where thers iz a desire to bring the information of the
World-Wide Web to as wide an audience as possible.

situation

The most recent rslease of Lynx is , which is maintained by
Foteoz Hacrides at the Worcester Foundation for Eiological Research.
The most recent, and probably final, release of Lynx produced by the
Thiversity of Kansas iz 2. . KU has no plans at this time to
continue development of maintenance of Lynx. New or upgrading users
are advised to uss ths Z.4-FN release of Lymx.

space- for next: pagd
aryow keys: Up and Dowmn to move. Pight to follow a link; Left to go back.
H)elp Ojptions Plrint Glo Miain screen Qluic S=search [delete}=history list

About Lymx 10/25/%5 {pl of 4}

ABQUT LYHNX

FIGURE 4.6: The About Lynx page at the University of Kansas Web site.

Most of a Web page will be regular text and headings. In Lynx, hypertext links are
shown in boldface, and the current link is shown in reverse video (white-on-black text,
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instead of vice versa). The first link on the page is the current link when you first arrive

at a page.

Often a page won't fit on the screen alf at once. The commands necessary to move
around a Web page in Lynx are detailed in the table below.

To see the next screenful of a page
To go back up a page

To move down to the next link

To move up to the previous link

To fix a messed up screen, say,
if reverse video is left all over
the screen

To search for specific text

To repeat a search

To select the current link (and jump
to the address it refers to)

To return to the previous link

Press the spacebar or type + (or PageDown or 3 on your numeric
keypad if NumLock is on)

Type b or - or PageUp (or 9 on the numeric keypad with
NumLock on)

Press Tab + 4 (or 2 on the numeric keypad with NumLock on)

Press T(or 8 on the numeric keypad with NumLock on)

Press Ctrl+W to redraw it

Type s or /. Then type the text you want to search for and
press Enter
Typen
Press Enter (or — or 6 on the numeric keypad with NumLock on)

Press «— (or 4 on the numeric keypad with NumLock on)

A

Though you can always retrace your steps in Lynx, by pressing 4 (NumLock)
repeatedly, you can also jump back to any previous point in just two steps: First press
Delete to see your history page, a list of all the links you've followed in this session,
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(try Backspace if Delete doesn't work) and then select the page you want to return to

and press Enter.
At any point you can type i to go to the Internet Resources Meta-Index, which

includes many more starting points for you to try. Figure 4.7 shows the first screen of
the Meta-Index page.

At any point, you can type g to enter a URL directly. Lynx will prompt you with “URL
to open:”. Type (or paste in) the URL and press Enter.

Internat Resources Heta-Indsx (pl of 7}
INTERNET RESOURCES META~INDEX

Thiz document iz intended to be a loosgely catsgorized meta-index of
the warious resource directories and indices available on the
Internet. Please send suggestions for new entries on this list (any
index eor directery of resources) to mosaicingsa. uiug. edn.

World Wide Web

* Zearchable indices:

+ , a zearchable catalog of WUW resources at LU,
Geneva, Switzerland; updated automatically every day from a
variety of sources.

WWW - the World Wids Web Worm
Heta-bhibyary
act indices:
Whols Iy <t

Arrow kKeys:
Hjelp O)ptions Pirint G)o Miain screan Qjuit f=search [deletel=history list

FIGURE 4.7: Not sure how to get started? Check out the Meta-Index.

Also at any time, you can return to the default home page by typing m.

You can save interesting Web destinations by adding bookmarks to your bookmark
page. (Lynx will create one for you if you don't have one.) To add a bookmark link to
the current page, type a.
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You can then view your bookmark page at any time by typing v.

If you want to save a copy of a document you're reading on the Web, type p. This
will bring up the Printing Options page. Press Enter to save the document t0 a file.
Lynx will prompt you 1o "Please enter a file name:’ and suggest one. Press Enter or
type in a different name and press Enter.

At some point you may want to mail the docurment to yourself (sometimes that's the
easiest way to store a copy of a document); press Tab to go to the next link (Mail the File
to Yourself) and then press Enter. Lynx will prompt you with "Please enter a valid internet
mail address:". If you've told Lynx your address, it will appear there. If not, type your
address. Then press Enter.

To see the URL associated with the current link, type =. Type = again to go back to
the normal view. To see the actual HTML text of the current page, type \. Type \ again
to go back to the normal view.

Follow these steps to change some of the Lynx settings:

1. Type O. This brings up the Options Menu.
o Type e to change the Jefault editor for sending e-mail to mail to URLs.
o Type b to change your bookmark file.
¢ Type p to enter or change your e-mail address.

2. When you are done, type >. This saves your changes.

3. To return to where you left off without saving the changes, type F-

To make a different document your default home page, enter the line setenv
WWW _HOME url (using the correct URL for the page you want) in your startup file
(usually called login, profile, or .cshrc).

You can get help at any time in Lynx by typing 2. Quit Lynx at any time by typing 4
Then press Enter. To quit without being prompted, type Q-

Browsing the Web with Microsoft Internet Explorer

Internet Explorer works seamlessly with the Microsoft Network, but it
| also stands alone as a Web browser that can work with any Internet
W onnection. On the Windows 95 desktop, it's represented by the pre-
sumptuous “The Internet” icon.
Bri
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A trial version of Internet Explorer for the Macintosh has just been announced and
should be available by the time this book reaches your hands.

Figure 4.8 shows the Microsoft Network home page that comes up automatically
when you connect to the Web without specifying a particular site. Internet Explorer, by
the way, calls the page you start on your start page, not your home page, as most
other browsers refer to it.

To search a long Web page, select Edit > Find, type the text you're looking for, and
press Enter. Internet Explorer has Back and Forward buttons, and you can return to
any of the recent sites you've visited by pulling down the File menu and selecting the
page from the list just near the bottorn of the menu (just above the Exit command).
To go somewhere directly, type the URL into the Address box (it will change to an

Open box when you click in it).

Click on the button at the right end of the Address box to drop down a list of all the
addresses you've ever entered.

Click on the Home button to return to the Microsoft Network home page.

Vou can save interesting Web destinations by selecting Favorites > Add to Favorites.
The page you add will instantly become a menu item on the Favorites menu. To go to
a Favorite, just select it from that menu.

To save a Web document with Internet Explorer, select File > Save As. You can also
save a shortcut to a file—to a tiny file containing the Web address—by selecting File >
Create Shortcut. To mail a shortcut to someone, select File > Send Shortcut. Internet
Explorer will open a Microsoft Exchange New Message window with the shortcut

already attached.
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s You To The Internet! -

http: 2 dwaps msn.com/

Customize This Page
See the latest sports scores, stock prices, comics, and more.

FIGURE 4.8: Internet Explorer starts you off at the Microsoft Network start page.

To view the HTML source of a Web document, select View > Source.
Changing your start page is simple:
1. First go to the page you want to Use.
2. Then select View > Options and click on the Start and Search Pages tab in
the dialog box that appears.
3. Click on the Use Current button.

4. When you're done, click on OK.
To get help with Internet Explorer, select Help > Help Topics. To keep up with
what's new, click on the Links button on the Microsoft Network start page. It features a

pick of the day and other useful links.
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Browsing the Web with Mosaic

Mosaic is the original graphical Web browser, and versions of it now exist for just
about every graphical user interface. The original version is NCSA Mosaic (NCSA, the
National Center for Supercomputing Applications, is where Mosaic was first created), but
there are other licensed versions out there, including Spyglass Mosaic, AIR Mosaic, and
the version CompuServe uses. All versions of Mosaic work more or less the same way.

Figure 4.9 shows the NCSA Mosaic for Microsoft Windows home page that comes
up automatically when you connect to the Web without specifying a particular site.

To search a long Web page, select Edit > Find, type the text you're looking for, and
press Enter. Mosaic has Back and Forward buttons, and you can return to any of the
recent sites you've visited by selecting Navigate > Session History. This will bring up a
small dialog box listing the recent sites. Choose one and click on the Load button. To
go somewhere directly, type the URL into the box on the Location bar, and click on
the button at the right end of the Address box to drop down a list of all the addresses
you've ever typed in.

Click on the Home button to return to the Mosaic home page for your version.

You can save interesting Web destinations by selecting Navigate > Add Current to
Hotlist. The page you add will instantly become a menu item on the Hotlists >
Starting Points menu. That menu includes many useful hotlist items preloaded. To go
to a hotlist item, select Hotlists > Starting Points > hotlist itern.

To save a Web document with Mosaic, select File > Save As. To mail a Web docu-
ment to someone, select File > Send Email. Mosaic will open a Mail window. To
include the text of the document in the message, click on the Include Text button and
then click on Yes to “quote” the document using the ">" character or No to insert the
text as is.

In order to view the HTML source of a Web document, select File > Document
Source.

If you want to change your home page, first go to the page you want to use or copy
its URL. Then select Options > Preferences and click on the Document tab in the dia-
log box that appears. Either click on the Use Current button in the Home Page area or
type (or paste) the address you want. Then click on OK.
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-

Back Forward

Windows Home Page - NCSA Mosaic

ifferent home page for each version (Windows, Macintosh, X

FIGURE 4.9: NCSA Mosaic has a d
This is the home page for the Windows version.

Window, and so on).

s Contents or Help > Online Resources. To

To get help with Mosaic, select Help
s > Starting Points > NCSA Mosaic's ‘What's

keep up with what's new, select Hotlist

New' Page or any of the other preloaded starting-points links.

AutoSurfWith Mosaic k

own and cache all of the

eisur »«andm alotless ime.

Now when you br
pages at a site, letting
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Browsing the Web with NetCruiser

NetCruiser includes a browser module for the Web (it comes up auto-
matically when you start NetCruiser unless you say otherwise). To run it,
click on the Web icon. This takes you to the Netcom HomePort, a pretty
good jumping-off point (see Figure 4.10).

The Web browser module has a Back and Forward button. To see the list of recent
sites you've visited, select WWW > History. Choose a site in the dialog box that
appears, and then on click the Jump To button. You can go to a specific page by typ-
ing its URL in the Address box at the top of the WWW module window. When you
click on the arrow on the right end of the Address box, a list drops down, showing you
the history list of recent sites you've visited.

To search a page, click on the Search button (or select Edit Find). Type the text
you're looking for and click on OK.

When you want to make a bookmark, click on the Book Mark button (or select
WWW > Book Mark). Click on the Add button in the Book Mark dialog box that pops
up to add the current page to your bookmark list. Select a bookmark and click on
Jump to go directly to that page. Click on Close when you're done in the window.

There are two ways to save a document: click on the Save button or select File >
Save. However, NetCruiser does not provide a way for you to mail documents to
other people.

In order to see the underlying HTML source for a Web document, select View >
Source File.

First select Settings > WWW Options to change your home page. Make sure the
General button appears pushed in. Type or paste the URL you want into the box in
the Home Page File area and then click on OK.

To get help with NetCruiser, select Help > Contents.
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Book

Save Mark Search

Back Forward

FIGURE 4.10: Netcom's HomePort offers a variety of destinations on the Web.
To keep up with Netcom news, click on the New button at the bottom of the

Homeport page. You can also
« Click on the Search Engines & Directory Listings link on the Homeport page.

o Click on the What's New link on the Web Directory Listings page that appears.
e Choose one of the listed What's New pages.
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Browsing the Web with Netscape Navigator

Netscape Navigator (commonly referred to as just Netscape) is by far the world's
most popular Web browser. When you start it (by connecting to your Internet service
provider and then double-clicking on the Navigator icon), it connects to the Netscape
home page and starts you off there (see Figure 4.11).

 [welcome to Netscapel

tp: A home. nhetscape.comdnd

L BUSINESY
HE LY avbuications

LATEST NEWS: GOLD RELEASED

NAVIGATOR (GOLD SHIPS
Windows 95 and NT users can now download the shipping version of
Wetscape Navigator Gold. Learn how to upgrade if you own Navigator.
Onee you've downloaded it, enter our expanded Gold Rush contest to win cash and prizes
isted 1 cial contest directory provided by Yahoo.

_and get v

FIGURE 4.11: The Netscape Home Page has Web-surfing destinations and up-to-date information
about Netscape.

Use the Back and Forward buttons to move between pages, and the Go menu to
see a list of all of the pages you've visited in the current session—your history list. To
go to a specific Web page, type its address in the Location box, which will change into
a Go To box as soon as you start typing. You can pull down a list from that box to see
every page you've ever typed in directly.

To make a bookmark with Netscape, select Bookmarks > Add. To go to a book-
mark, pull down the Bookmarks menu and choose the item.

In order to save a Web document with Netscape, select File > Save As. To mail a
document to someone, select File > Mail Document. Click on the Attachment button
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in the message window to control how the document is sent—as an HTML source file
(the default) or as plain text.

When you want to view the underlying HTML source of a Web page, select View >
Document Source (previously View > Source in earlier versions of Navigator).

To change your home page in Netscape, first copy the URL of the page you want to
use. Then select Options > General Preferences and click on the Appearance tab.
Type or paste the Web address into the Start With box in the Startup area and then
click on OK.

Any time you want to get help with Netscape, choose Help > Handbook (or any of
the other commands on the Help menu). To see what's new on the Net, choose one
of the following options:

e Select Directory > What's New!
e Select Directory > What's Cool!
e Click on the What's New! directory button
e Click on the What's Cool! directory button
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« Finding and saving a home-page template
. Understanding a little HTML

o Editing an HTML document

« Inserting pictures and links into a page

e Previewing a home page

« Finding a home for your page

This is the bonus chapter. You've now learned all you need to know to function
on the Internet and explore the resources that are out there. The next step
for you might be to put your own information up on the Net. You already know
how to contribute to mailing lists and Usenet newsgroups—it's as simple as
sending a message o the right address—but publishing your own home page can
be a little trickier.

Why would you want your own home page? Well, it's a little like putting up 2 flag
in cyberspace. One that says, “Here | am.” A home page can be as simple as a
yearbook entry with a few images, some facts about you and perhaps your
family (and maybe your pets), and a list of your favorite Web sites (most likely
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taken from your bookmark file); or it can be as complicated as a full-service front end
for a company or organization. Telling you all the ins and outs of making an elaborate
Web site would take a whole book, but I can recommend an easy way to put together
a simple home page and point you to a few other alternatives as well.

Creating a Home Page

A number of Web sites offer straightforward procedures that result in a fully assem-
bled home page. Also, quite a few programs are available that do the same thing for
you offline. | recommend the Home Page Construction kit at the GNN (Global
Network Navigator) Web site.

To get there, point your browser at http://gnn.com/netizens/
construction.html (see Figure 12.1).

Netzcape - [Home Page onhuhon Kit}

zens/construction html

FIGURE 12.1: Visit the Home Page Construction Kit to painlessly assemble a simple home page.

The GNN site offers stripped-down step-by-step instructions, as well as a useful
HTML document template you can save to your browser and then edit, replacing the
dummy information with your own personal text.
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a ttght:‘lit‘tle‘pr‘ogram‘ called WEB Wizard
om/artanedia/uebui ard/). A
to be available soon. The WEB Wizard program
Hut your vital info mati‘oht‘:‘y‘our‘h‘am‘e, what you do, and so
; ny art files you rmight want to include onyour
page and the Web addresses of any sites you might want 1o link to. Then it
assembles your page foryou. o .
Also, CompusServe offers a home-page wizard that members can download
ome pages at the Our World. (http: //ourworld:
compuserv m) si Vkisit_thatfsités;to‘ddwnload their stand-alone program..

Visiting the GNN Site

Start by following the Creating a Home Page link (to http://gnn.com /
netizens/create.html)forsome background on how to make a home page
in general. This page <hows some examples of different types of home pages and
demonstrates the HTML codes that make them work the way they do (see Figure 12.2).

Read through the rest of the page for a basic primer on HTML codes, hypertext
links, and embedded images. When you've read this page, scroll back to the top and
select the Back to Home Page Construction Kit link (or just use your browser's Back

command) to return to the main page.
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FIGURE 12.2: GNN's Creating a Home Page page

Going to the Template Page

Skip the next link, which discusses how to “publish” a home page, meaning how to
find a place to store it on the Net and make it available to the public. That's important,
but you have to create your home page first before you need to worry about where to
store it. Instead, follow the link called Home Page Template (http://gnn.com/
netizens/template.html). Read the instructions on that page and then
follow the link that says GO to Home Page Template (http://gnn.
com/netizens/homepage-html). This will take you to a dummy home
page with lots of places to plug in information about yourself (see Figure 12.3).

Saving the Template

Next, save this file to your own computer. With most browsers, this means select-
ing File > Save As; be sure to specify HTML as the type of file. For example, in
Netscape Navigator, the choice is called Source (*.htm, *html). Make a note of where
you're saving it.
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gnin.com/netizens/homef

YourName's Home Page

3

2., picture title

Where I work/go to school

1 work at companyfschool name.

Hobbies

» description
* description
e description

FIGURE 12.3: GNN's dummy home page includes most of the HTML tags you'll need to create a
simple home page. You just have to fill in the actual information to be all set

Looking at the HTML Document

Now you have to edit that HTML document, which you can do in any simple text
editor. In Windows, | recommend using WordPad or Notepad. (WordPad has a few
more features—such as Search and Replace—but you may be more familiar and com-
fortable with Notepad.) For the Macintosh, SimpleText will work just fine and BB
Edit is ideal. In Unix, you're stuck with Vi (pronounced vee-eye and usually spelled all
lowercase: Vi).

The drill at this point is to open the HTML document and replace all the dummy
text with your real information. You may be surprised at how simple and easy 10 read
the HTML source file is (see Figure 12.4).

The document consists of regular text and HTML tags surrounded by <and > (typ-
ically less-than and greater-than signs but | think of them as angle brackets). Some of
the brackets are required, so you shouldn't mess with those (such as <HTML> and
<HEAD> and <BODY>). The following table briefly explains the tags you'll see, but
you don't really need to understand them, sO feel free to skip ahead.
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B homepage. html ~ WordPad

<HTHML>
<HEAD>
<TITLE>YourNswe's Home Page</TITLE>

</HEAD>

<BODY BGCOLOR="#FFFFFF">

<H1>YourName's Home Page</H1>

<ING SRC="YourPicture.gif"”> picture title

<HZ>Where I work/go to school</HZ>

I work st <A HREF="URL here>company/sSchool name</A>.
<HZ>Hobbies</H2>

<UL> I
<LIrdescription

<LI>description

<LIrdescription
</ UL>

FIGURE 12.4: The HTML tags appear surrounded by < and >. The rest is regular text.

H1 through He Headings. The number indicates the level of the heading, meaning its
importance or priority

IMG Image

SRC Source

UL Unordered list. Unordered means “with bullets,” as opposed to ordered,
which means “with numerals”

oL Ordered list

LI List item

A Anchor. Indicates the beginning or end of a link

HREF Hypertext reference

ADDRESS Address

p Paragraph break

Many tags appear in pairs, with an opening tag and a closing tag that starts with a
slash, such as <H2> and </H2>. These particular tags mark the beginning and end,
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respectively, of a second-level heading. Now you know more HTML than 99 percent
of the people on the planet.

Switch over to the browser window again and compare the “raw” HTML file to the
file interpreted and displayed as a Web document. This result is what makes people
say HTML is easy, since the browser does most of the work.

Editing the HTML Document

Okay, enough looking. Time 1o really edit your home page. Just start replacing the
generic text with the real text. This is the easy part.

1. Replace YourName with your real name twice, once on the TITLE line (this
controls what appears in the browser's title bar), and once on the H1 line.

2. Below the IMG tag and above the first H2 tag, type in anything you want to
say about yourself, as much or as little as you want, but start with <P> (a
paragraph break) so the picture title text beforehand doesn't run right into it.

3. Then select the dummy H2 text, Where 1 work/go to school, and replace
it with the name of an employer.

4. Inthe sample text below the H2 heading, replace the text,
company/schoo| name, between the <A HREF=blah, blah> and </A>
tags, with the name of the place where you work or go to school (or plot to
overthrow the government, or whatever).

5. Then change the sentence however you want, but be careful not to mangle
the <A ..> and </A> tags. Add more text as well. This is your chance 10
say a thing or two.

6. Do the equivalent thing with the <H2>Hobbies</H2> tag. This is your
page, you can change the heading to anything you want.

7. Add more items to the list if you want (just start a new line with <LI>10
do so).

8. Add introductory text after the H2 and before the UL starting tag if you feel
like it.

9. Ifyoud like to have other, similar categories, copy the Hobbies section and
paste it in again just below where it is now and just before the Personal Hot
List section, as many times as you like.

10. If you want to break a section into smaller sections, start the first level of
subsections with a <H3>Third-Level Heading </H3> and go from there.

Figure 12.5 shows what the top of my page looks like after Debussy Fields has got-

ten started with it.
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B homepage.html - WordPad

<HTML>
<HEAD>
<TITLE>Debuasy Fields' Howe Page</TITLE>

</HELD>

<BODY BGCOLOR="#FFFFFF'">

<H1>The 'Debussy Fields, This iz My Home Page' FPage</Hi>

<ING SRC="YourPicture.gif"> picture title

<PrDebussy Fields does not really exist. This picture is a fake.

<H2»Watmrmelon Works</HZ>

I work at <l HREF="URL here">the watermelon works</A», in watermelon sugar,
vhere the deeds were done.

<HZ»Favorite Authors</HZ> I
<TL>
<LIxRichard Brautigan

FIGURE 12.5: All about Debussy Fields

Next, scroll down to the bottom of the document. In the ADDRESS area, put your
name and your e-mail address in parentheses, and then save the document.

Putting in an Image and the Links

Now you have to put the file names and locations of any Web pages you want to
link to and any art or illustrations you want embedded in your page. First the image.

Putting in an Image

Go up to the <IMG SRC ... > tag just below the <H 1> tag and replace “YourPicture.
gif” with the actual file name of a picture you want to include on the page.
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The picture will have to be in a GIF or JPEG format, but other formats, such as PICTs,
BMPs, and TIFs can be converted to either of those formats in a variety of image-
manipulation programs (from the expensive, professional tool, PhotoShop, to the
shareware tool, Lview Pro). You might find it easier to ask someone you know to do
this for you.

Type a caption for the picture (replacing picture title). To make it bold, precede it
with <B> and follow it with </B>.

Putting in Links

To insert your first link, go to the first A tag, the one in the first sentence after the
first H2 heading. Replace the words “URL here” (but keep the quotation marks) with
the full address of the home page of your company or school. (Hunt around on the
Net for it if you don't have it handy.) You can erase the <A ..> and </A> tags if your
affiliation does not have a home page.

Then go down to the Personal Hot List area. Change that heading if you want some-
thing different. Then replace the description text. Finally, you have to replace the “URL
here” text with the actual addresses of your favorite links. You can go to those pages
(easy, if you've made bookmarks) with your Web browser and then copy the links with
perfect accuracy from the address box of your browser (Ctrl+C or Command+C will
usually do this if you select the address first) and paste each of the addresses into the
home page document you're working on. Figure 12.6 shows the document with hyper-
text links inserted. Then save the document.

Previewing the Home Page

Now switch back to your Web browser and select File > Open File. Switch to the
directory where you saved the home page originally (if necessary), and open the HTML
document. Your browser will display your finished page (see Figures 12.7 and 12.8).
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B homepage - WordPad

cHZ»Uatermelon Works</Ha>

1 work at <& HREF="http://wwm.syx.com/x/melon/">the watermelon worka</Ax,
in watermelon sugar, where the deeds vere done.

<Hz>»Favorite Authors</H2x
<UL>

<L I>Richard Brautigan
<LI>Thomas Pynchon
<LIxDoris Lessing
<LI»Don DeLillo
<LIrKilgore Trout

</ UL>

<Hz»The Bestest Links on the Net</HZ>
<UL>
<LIx<k HREF="htrp://ezone. org/ez/ "rEnterzone</ >
<LIr<h HREF="http://wwy.charm. net/~brooklyn/">Literary Kicks</ A
<LI><h HREF="http://limestone.kosone. oo/ people/nelsonl/nl. htw'>
The WEB DESIGNER</ &> I
</ ULx>

FIGURE 12.6: Debussy's employer and favorite sites have now been hyperlinked into the
home page.

Learning More about HTML

In the future, you may want 0 expand the page maybe Isnk in some addi
tional pages. In a similar way to how the IMG tag includes a SRC——”f/lename ;
reference to connect a picture to a page, you can make focal //nks to other doc
uments stored in the same place as the home page by usmg 1 he{i .
<A HREF="local file”> and </A> tags. If you want to learn more about HTML::
and Web-page creation, visit the Web. DeSlgner page (h ttp: S/ W
kosone- com/people/nelson/nl htm) a central clearmghous'
for Web-design related information. (That'sa ietter by he . vvay,‘ ‘
numeral “one’ in the fllename of thts page) -
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_ e' —

The 'Debussy Fields, This is My Home
Page' Page

Loa 3 Dehussy Fields forever

Debussy Fields doss not really exist. This picture is a fake.

FIGURE 12.7: The top of Debussy's home page as seen in Netscape Navigator 2.0 for Windows

1 work at the watermelon works, in watermelon sugar, where the deeds were done.

Favorite Authors

® Richard Brautizan
Thomas Pynchon

Don Delillo

-
* Dons Lessing
L]
* Kilgore Trout

The Bestest Links on the Net

® [nterzone
& Literary Kicke
® The WEB DESIGNEE

Debussy Fields (debussy@

FIGURE 12.8: The rest of Debussy's home page
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Finding a Home for Your Page

The final question about your home page is where to put it. Many Internet service
providers (and some of the online services as well) offer free space on their Web
servers, up to some quota of disk space (often five megabytes), to all their customers.
If your e-mail provider does not offer you access to a Web server, you'll have to find
someone else to host your site. Look first at your company or any other affiliations
you may have. There are also some free home-page hosting sites out there (though
they may require that you include an ad for them on your page).

Some providers will ask you to send them your files via e-mail (see Chapter 3 for
how to send files via e-mail). Others will prefer it if you use FTP to upload your files to
them (see Chapter 10 for how to send files via FTP). They will assign you a URL for
your home page, often in the format http //www.their-name-.com/
~your -username, but other variations are possible as well.

Once you get your page (and any associated art files or linked pages) out there on
your provider's Web site, then anyone can drop by. E-mail your friends and ask them
to visit. If you want to truly make your pages public, visit some (or all) of the directory
and search sites mentioned in Chapter 5, and submit the URL for your page to each
of them.

Now you're truly “on the Net”
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